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1 Hardware/Software 
 

Typ/Name Version Software/Firmware  Production date 

CHB-C-N  TN : 3501040  3.6.1.0  

CHB-C-X  TN : 536084    

   

CheckKon  4.3 rel 06  

Checkopti 3.2 rel 06  

Table 1.1: Hardware/Software 

 

1.1 Manuals 

CHB-C-N manual from support portal  www.festo.com/sp. 

DE: 8046181 

EN: 8046182 

 
 

https://www.festo.com/sp


 

 

2 Description of the task 
 

The application note should describe the exchange of a checkbox CHB-C-X (TN 536084) with a checkbox of the 
current CHB-C-N series. Due to technical innovations there is the necessity to adapt parameters and settings to 
the new platform. 

 

Replacement is necessary if the old device can no longer be repaired or a repair is no longer economical. 

Furthermore, there are situations in which an installation is to be duplicated and the previous model can no 
longer be used. The improved hardware and software allows critical inspections to be improved and performed 
more reliably. With 256 test program locations, the new CHB-C-N offers considerably more memory options than 
its previous model. This could also justify an exchange 

 

The exchange described here in the Application Note is based on the data of the existing system. Either they can 
be backed up from the old device, or they come from a data backup that has been saved previously. 

If no more data is available, all basic settings must be carried out again.  

The description of a new basic parameter setting is explained out in another Application Note " Application of a 
checkbox CHB-C-N on a conveyor belt system". Please use them. 

 

The description of the exchange is intended for people with basic knowledge of the Checkbox and the Checkkon 
and Checkopti software package.  

 

 

 

 

      

                                                              
 

 

CHB-C-X               CHB-C-N 



 

 

3 Overview of procedure and sequence 
 

 

The exchange is divided into several sections, which are listed here: 

 

Data backup old device CHB-C-X (or from backup file) 

Disassembly of old unit 

Assembly of replacement unit CHB-C-N 

Electrical connection CHB-C-N 

Configuration CHB-C-N from data backup 

Test run and data backup CHB-C-N 

 

 

When using additional inspection tools from Checkopti: 

 

Adaptation of test program to CHB-C-N from data backup 

Test run and data backup CHB-C-N 

Optimization of the testing process 

Procedure for changed resolution 

 



 

 

4 Data back-up CHB-C-X 
 

This step is about saving the system parameters and the test programs stored on the device. These system pa-
rameters are used for the configuration of the new device. 

Another backup is made when the grey scale line is saved. This documents the "optical/mechanical" mounting 
situation. 

If the checkbox, to be replaced, can no longer be connected, obtain the necessary data from a stored backup. 

The necessary files are: a system parameter file with the file extension xxx.cbs and, if necessary  

a Checkopti project file with the file extension xxx.cbp. 

If you have the files available with the current status, continue with the procedure in Chapter 5. 

  

Establish a connection to the device with Checkkon. When a connection is made, the existing  

system parameters are transferred to the Checkkon. 

 

In the menu View > System Parameters 

Example System Parameters: 

 
These settings are to be taken over in the new device. 

 

To complete the backup, the test programs stored on the device must be copied to Checkkon. 

Open Menu > View > Check program Manager 

  
 

Select all (or those which are used) type memory in the right list and then copy it to the left, using the "Copy"-
button. After copying, the entries are in the left list and in the software Checkkon. 

The Check program Manager can then be closed. 

 

 



 

 

 

Saving the grey scale line: 

 

Menu: View > Grey scale line 

Press the "Record" button. 

Start checkbox, (The display of the checkbox shows "Line") Do not feed any parts! 

Stop checkbox. 

"Press the "Stop" button in the grey scale line window 

Press the red "Save" button 

close window 

 

Abbildung 4.1   example of greycsale line: 

 
 

Then save the data in the menu:  File > Save as...  

 

The backup file has the file extension   .cbs 

 



 

 

5 Disassembly of the CHB-C-X 
 

For safety reason the device must be switched off! 

Before dismounting the device, it is recommended to mark the mounting position exactly.  

In particular the alignment and height to the conveyor belt. 

 

Example: 

 
 

Mark the connectors of the Actuators and Buffer/Feeder cables!  

These 2 connectors could be mixed-up, due to different position on the frontpanel of the new device. 

 

Then remove the front panel connectors in the following order: 

Diag, Actuators, Buffer/Feeder, Encoder , PLC, 24VDC, PE. 

 

Warning! 

Before loosening the hexagon socket head screws of the dovetail guide, make sure that the checkbox does not 
slide down and hit mechanically. 

Avoid touching or soiling the optical prisms. 

 

Mounting the new Checkbox CHB-C-N 

 

Mount the new device according to the markings you made when removing the checkbox. 

Tighten the hexagon socket screws. 

 

Reconnect all connectors in the reverse order of disassembly. 

Pay attention to the label on the front panel when connecting. 



 

 

Figure 5.1 shows the changed positions of the connections on the front panel. 

 
The earth connection point PE is located on the front panel of the new device. Here it has to be checked whether 
the existing length of the PE cable is sufficient. If necessary, the cable must be adapted. 

 

 



 

 

6 Parameter setting CHB-C-N from data backup 
 

Start Checkkon. (Checkbox is in stop mode) 

Establish a connection, now via Ethernet interface, to the device.  

Connect in the user level: “modification (password)”, otherwise no adjustments of the parameters are possible. 
Password is   “mission” 

 

The IP address on delivery is preset to 192.168.2.20 with subnet mask 255.255.0.0. 

 

The current IP address, as well as the firmware version on the device, is also shown in the display. 

 

Figure 6.1  Display after booting.  

 
 

 

Make sure that your PC is also set in the range of the IP address and the corresponding subnet mask.  

 

see Windows > Control Panel > Network and Sharing Center 

 

A connectable checkbox is displayed in the search window with a green dot. At a red dot, check the network set-
tings of PC and checkbox, if necessary boot the checkbox. 

 

Figure 6.2 Display in the checkkon after the device search 

 
 

 

 

 



 

 

 

Open in Menu > View > System Parameters 

In the structure at System, select the function "Set checkbox to default values".

 
 

This ensures that all parameters have a valid range of values. 

 

Adjustment of the parameters to the setting of the previous device 

 

Now the parameter settings of the checkbox to be exchanged must be entered in the CHB-C-N. Automatic upload 
is not possible due to different technologies. 

To set the individual parameters, you should be able to view both parameter structures simultaneously. This 
does not require both devices to be connected. Just the new device. 

 

There are 2 ways to do this set-up: 
 

1. Start the Checkkon software in a second task and display the system parameters of the backup file in a 
split screen. 
 
Select the option: "no connection, open file only". 

 
 
Then open the saved backup file. Customize the view of the windows on your screen so that the 
parameter view of both checkons is displayed. > see figure 6.4 

 

 



 

 

 

 

 

 

 

2. Print out the parameters of the Checkbox to be exchanged. > Open the menu View > Systemparamters 
and unfold the entire parameter structure with the button as shown. 
 
Figure 6.3 

 
 
After that select the printer icon in the menu. 

  
 

 

 

Now set all parameters of the new Checkbox CHB-C-N in the parameter structure, according to the printout of 
the backup file. The value can be changed by double-clicking on the respective parameter. The change is 
transferred immediately and is permanently stored in the device. For new parameters and parameters that do 
not exist in the old backup, leave the default value. 

 

 

 

 

 

 

 

 



 

 

 

 

 

 

 

 

 

Figure 6.4  View of the 2 system paramter windows in a split screen 

 
 

Unfold the parameter structure as shown in figure 6.3. 

Now set all parameters of the new Checkbox CHB-C-N in the parameter structure, according to the printout of 
the backup file. The value can be changed by double-clicking on the respective parameter. The change is 
transferred immediately and is permanently stored in the device. For new parameters and parameters that do 
not exist in the old backup, leave the default value. 

 

Please note: Important change! 

 

One parameter requires special attention. This affects the vertical resolution. In the new device, the CHB-C-N, a 
considerable improvement in image quality has been achieved. This causes, that the default vertical resolution 
raised to 2048 pixels. In many existing applications, however, the CHB-C-X works in the resolution of 512 pixels. 
The difference can be seen in the "size" (height) of the parts in the picture. Small structures in the contour are 
displayed better and more detailed at a higher resolution. 

 

 

If the parameter„Resolution reduction: number of grouped pixel=1“ (see figure 6.5) then you can skip the 
following description and continue with the next passage horizontal resolution.  

 

 

 



 

 

 

 

 

 

 

 

Figure 6.5 Comparison of system parameters vertical resolution:  

CHB-C-X           CHB-C-N 

                
 

If a value other than 1 was set, it must be decided whether the new resolution or the previous (possibly smaller) 
resolution is to be used.  

Generally no clear recommendation for a choice can be given here, however there are following arguments for a 
decision. 

 

Advantage higher resolution: More details for small contour differences, e.g. threads or grooves, thus more 
stable evaluation. 

Previous "critical" inspections may be better and more stable. 

No longer processing times! 

 

Disadvantage: All existing check programs have to be reviewed and adapted with a little more effort, especially 
for inspections with narrow tolerance values. 

 

Advantage of previous resolution: All images and sizes are retained. The user remains with the "familiar" image 
that he already knows. 

Here too, check programs must be adapted, but fixed settings and tolerance limits can be adopted as far as 
possible. 

If many check programs and many types are used, the check programs can be adapted more quickly and with 
slightly less effort. 

 

Disadvantage: You do without a more detailed resolution of the parts. Inspections may not be set to their 
highest accuracy. 

In critical inspections, with small contour differences, stability and liability is not improved. 

 

The following table shows a comparison of the parameter settings: 

 

Device CHB-C-X CHB-C-N 

Resolution vertical 512 Pix Resolution reduction: number of grouped pixel =4 Resolution 512(516) 

Resolution vertical 1024 Pix Resolution reduction: number of grouped pixel =2 Resolution 1024(1032) 



 

 

Resolution vertical 2048 Pix Resolution reduction: number of grouped pixel =1 Resolution 2048(2064) 

 

 

Now adjust the parameter in "Camera and Image" > "Advanced image parameters” > Vertical (Height). 

 

 

 

 

Horizontal resolution 

 

In addition to the vertical resolution, the checkbox also has the horizontal resolution. The horizontal resolution 
determines the number of lines recorded from the part.  

In time-controlled systems, this is determined by the parameter "Exposure time in µsec". (CHB-C-X). With the 
new generation CHB-C-N this is the “Line rate” in Hz.  

The value in µsec must be converted into the line rate. This is simply achieved by the inverse value. e.g. 
1/512µsec = 1953Hz. This value must be entered as the parameter value. The setting is made at certain steps. 
Take the value closest to the calculated value. The image of the parts (length) then corresponds to the old 
system. 

 

Figure 6.6 Horizontal resolution time controlled.  

CHB-C-X      CHB-C-N 

                      
 

In encoder-controlled systems the parameter „Encoder to line-frequency ratio“ stays the same. 

Here you can just take the previous value.  

(see figure 6.5) 

 

It may also make sense to increase the horizontal resolution. This allows smaller details to be displayed and 
evaluated better, e.g. the width of a groove. 

The new checkbox offers significantly more memory for a longer scan length!direction! 

 

The effect on the test program also applies if the horizontal resolution changes. The consideration for or against 
a change is already mentioned at the beginning of this section. Chapter 9 contains notes on adapting the test 
program when the resolution is changed. 

 

Verification of settings 

 

If you change the vertical resolution with respect to the "old system", the field of view limits must be 
readjusted. Even if the resolution remains the same, it is possible that the field of view limits may have to be 
"fine" adjusted due to the tolerance during installation of the new device. 

For more information on changing the resolution, see chapter 9. 

 

The field of view is displayed and set in the gray scale line window. As described in chapter 4, start the recording 
of the gray scale line. The lower area, above the conveyor belt must be observed. The blue line, as the lower 
field of view boundary, should have the same distance as it was previously given with the old device.  

 



 

 

If the old setting is not available, the lower limit is set as close as possible to the dark area (bottom) of the 
conveyor belt. A certain distance is necessary because certain belt movements or dirt particles on the conveyor 
belt should not lead to the image trigger. If necessary, use the example in chapter 4, figure 4.1. 

 

The upper limit of the field of view must be above the maximum part height. Especially if the resolution has been 
changed, the upper limit (green line) must be shifted in the direction of the largest pixel value. However, it must 
remain in the illuminated bright area. Refer to the example in chapter 4, figure 4.1. 

 

The borders of the field of view can be changed by moving the square ends of the corresponding lines with the 
mouse. Or doubleclick on the square and enter the figures. 

 

 
 

The new value is displayed in brackets but has not yet been transferred. 

 

To activate the new value, the checkbox must be in Stop mode and the recording mode must be stopped as well! 

Then the new value can be activated and saved at the same time with the " Accept settings" button. 

 

 
After all parameters have been adjusted, it is recommended to save the status. 

Select in the menu: File "Save as..." and assign a new name for the data of the new device. 

 

Testrun 

 

Start the checkbox and feed parts. All parts should be discharged at the position for bad parts. 

The parts recorded in the "Part contour" window should correspond to the images of the CHB-C-X parts. (At the 
same resolution, the same length and height). Compare this based on your stored data. To do this, you can open 
backup files by double-clicking and viewing them in the Part Contour window. 

 

If you do not use individual check programs, but work with the default check program of the checkbox, you can 
now carry out the "Teach" process. 

This works in the same way as you know it from the "old device".  

Information on teaching in the parts can be found in the user manual for the checkbox CHB-C-N. 

(pn 8046182) 

 

This completes the hardware exchange. After the "Teach process" has been made, the conversion is completed. 
(if no Checkopti tools were used in the check program.) 

 

The following chapters could be ignored! 

 

 

The next chapter describes the adaptation of existing check programs of the CHB-C-X to the new properties of 
the CB-C-N. This affects all settings of the Checkopti software. 



 

 

7 Adaption of the check programs for CHB-C-N 

 
Since the calculation of tools and features in the CHB-C-N has been changed to another technology, automatic 
conversion of the check programs is not possible. 
In the new technology, the flexibility of positioning and the relationship of the tools to each other has been con-
siderably expanded. It is now referenced by coordinates, as it is usual with matrix camera systems. Furthermore, 
the type and number of tools and features have been greatly increased. 
It is possible to "recreate" all previous check programs and it is also possible to install other and previously not 
realizable checks. 
If you have any further questions about the implementation of your Checkopti project, please contact the 
Festo Service. 
 
Use the version: Checkopti V3.2 rel06 for the implementation of the check programs. 
 
The following example shows the implementation of the tools ROI and Ctool. This represents the  
most common applications. Other tools can be used according to this method. The Vstrip tool is no longer avail-
able in the new software. This can be replaced by the ROI tool. 
 
In the following description, a project is converted in which the resolution does not change in any direction. I.e. 
the images of the CHB-C-X correspond to those of the CHB-C-N. Even if the resolution has been changed, follow 
the procedure first. Chapter 9 of this description contains additional information on application with changed 
resolution. 
 
The basic innovation is the referencing, therefore the positioning of a tool, at the part. In the previous software, 
all referencing options were fix and limited implemented in each tool.  
Now it is possible to use all coordinates for referencing also from other tools in the check program.  
In the manual for Checkopti (CheckOpti.pdf) this method is described in chapter 8. 
 
This application note cannot show all the possibilities of Checkopti. Here a frequently used application is de-
scribed. The task is a position orientation which is secured with an additional ROI. And we check the  
quality/presence of a collar with a Ctool. 
 
Example: 
 

  
 
The position orientation is done by 2*ROI. These are placed symmetrically at the front and rear of the part. In 
each position one ROI is “filled” the other ROI is “empty” So the position is clearly defined.  
The presence of the collar in the middle is checked by the Ctool. If the collar is missing, the Ctool creates differ-
ent values. 
 
 
 
 
Procedure 
 
Open the existing Checkopti project with the CHB-C-X check programs. (Project X) Save this file with a new 
name. This file will be the basis of the new settings for the CHB-C-N.(Project N) 
 
Open the original file again in a second task (Project X). This allows you to switch between the 2 projects at any 
time to compare settings. 
 
To simplify the description and to keep the text short, the terms Project X and Project N are used in the follow-
ing explanations. 
Pay attention to the bold printed designations Project X or N. Always work in the indicated project. 
 



 

 

 
Project N: Open the project properties >  menu: View > Project Properties to enter the new target device type. 
Select the appropriate setting in the fields. See figure 7.1 
Alternatively, if you are connected to the device, you can also perform automatic identification by Ethernet inter-
face.(Checkkon must no longer be connected) 
 
Figure 7.1         Figure 7.2 

                                          
  
Confirm with OK > then the modification message appears as shown above.(Figure 7.2) 
The "old" tools are no longer compatible and were deleted. 
 
A default test program with the same features as in Project X is created, but without the additional tools. The 
order of the tools has changed, but this does not matter. 
 

 
 
 
 
 
 
 



 

 

 
 
 
 
 
 
 
Project X: Select in the menu: View the part contour window. Select the first additional tool ROI at pos. 13.  
Double-click on the tool name to open the tool properties. 
 
Figure 7.3 Projekt X 

 
 
 
Note the setting of the size (width/height) and horizontal position settings. (tab: Position) 
This is required in the next step. 
 
Notice! 
The values (reference) in pixels refer to the upper left corner of the ROI. 
When transferring to project N, it must be noted that the reference of the values is now in the center of the tool. 
This means that if the values are copied, the value must be changed by this difference (offset).  
See example in the next step. 
 
Illustration of changed tool reference: 
 

     
 
 



 

 

Project N: Add a new ROI to the check program. This can be done via the icon    or  
in the menu: Action > Add tool > ROI 
The ROI is placed and entered in the tool list. The default position is at the beginning of the part and on the top 
contour. 
 
 
 
 
 
Figure 7.4 part contour window Project N 

 
 
Double-click on the tool name ROI to open the tool properties.  
Skip to the "Position" tab. 
 
a.) Now take the values for width and height from project X. Width = 160 Height=100 
 
b.) The value for the horizontal position (20 pixels from the left / absolute from the left ( part begin x=0) no 
longer exists and must be calculated/adapted to the value "X coordinate center point".  
The "1.ROI X Coord. Left" (Project N) describes that the positioning (reference) of the tool is calculated from the 
left side. 
 
Explanation of the adaption: 
20 pixels from the left are converted to X coordinate center = 100.  
Explanation: the center of the tool is 80 pixels (0.5*Width160 = 80Pix) further to the right as in the old reference. 
In order for the left outer edge of the ROI to begin as before 20 pixels from the beginning, the offset must be 
added to the middle. 20+80=100. 
 
c.) The value of the vertical position "Relative to maximum vert. suspension "Y" is also available in the new  
system with Y coordinate Center. The "2.ROI Y Coord. top" describes that the positioning (reference) of the tool 
is calculated from the top, the highest contour pixel. 
Here too, it requires a conversion from the old reference upper left corner of the ROI to the center point.  
Zero becomes minus 50.  
 
Explanation: the center of the ROI is 50 pixels lower than the upper edge (0.5* height 100 = 50 pixels.).  
To ensure that the upper edge is aligned with the upper contour, the center of the ROI must be reduced by 50 
pixels. Down, means for the Y-coordinate a subtraction. 0 -50 = (-50). 
 
 
 
 
 
 
 
 
 
 



 

 

Positioning the 2nd ROI 
 
Project X: Select the second additional tool ROI2 at position 14.  
Double-click on the tool name to open the tool properties. See figure 7.5 
 
In general, the ROI is placed symmetrically at the part in a position orientation. This means that the values for 
size and position are identical to the first ROI. Only the horizontal reference changes from absolute from left 
(part begin) to absolute from right (part end). Any variations in part length therefore have less influence on the 
positioning of the ROI. 
 
Figure 7.5 part tool properties window Project X 

 
 

Projekt N: Add a new ROI to the check program. This can be done via the icon    or  
in the menu: Action > Add tool > ROI 
The ROI is placed and entered in the tool list. The default position is at the beginning of the part and on the top 
contour. 
 
 
a)Now apply the values for width and height as done in the first ROI. 
 

 
 
b.) Copy also the values "X coordinate center" of the converted reference position from the ROI 1. The only dif-
ference is that the reference "1.ROI:X Coord. left" is changed to the reference "3.ROI:X Coord. right".  This is 
done by selecting from the drop down menu at the input field.  



 

 

Please note! If the reference is changed, Checkopti calculates automatically a new offset value. This value is cal-
culated in a way that the tool remains at the current position. To move the ROI to the right side of the part, the 
original value, in this case 100, must be entered again. Since the offset is added to the coordinate, the value 
must have a negative sign. This ensures that the ROI is symmetrical position compared with the first ROI 1. 
The "Y-coordinate center" is equal to the values for ROI 1. See figure 7.6 
 
Figure 7.6 

 
 
 
 
Alternative method without calculation of reference coordinates: 
 
Project X: Place the mouse pointer on the upper left corner of the ROI. Memorize the coordinates x,y for that 
point. 
 

  
 
Project N: Add an ROI as described above. Set the width and height according to the settings in project X. Now 
move the ROI in the image with the mouse, until the upper left corner of the ROI is at the same position on the 
part. 
Even if the positioning is not "pixel"-exact, this should be sufficiently exact, for the recognition of the position 
orientation! 
The 2nd ROI can be inserted in the same way. Width and height are taken from project X. Then the horizontal 
reference is selected at "X-coordinate center" on “3.ROI:X Coord. Right”.  
Now move the ROI in the image with the mouse until it is in the right place at the part as in project X.  
 
 
Copying tools 
 
If you are familiar with the procedure, you can simplify the process even further.  
When you select a tool, you can use the right mouse button to execute the command "Copy tool". This copies 
the selected tool exactly. Now only the horizontal reference has to be adjusted with offset. 
 
 



 

 

Assigning the Ctool tool 
 
A CTool is used to check the Contour in a specific area. This is often used to check the presence of a collar or 
thread. In this example, this is the collar in the middle of the part. 
 

 
 
In this example, the tool determines the height difference in a defined section of the contour. If the collar is 
missing, then the height difference is different from the sample parts. This could be evaluated. 
 
Project X: Select the CTool1 at pos 15. Double-click on the tool name to open the tool properties. See figure 7.7 
 
Figure 7.7 

  
 
Memorize the settings in the "Function" and "Position" tab. 
 

Projekt N: Add a new CTool to the test program. This can be done via the icon in the tool bar   
or in the menu: Action > Add tool > CTool 
 
Fügen sie dem Prüfprogram ein neues CTool zu. Das geht über das Icon  in der Werkzeugliste oder im Menu: Vor-
gänge > Werkzeug hinzufügen > CTool 
The CTool is inserted and entered in the tool list. The default position is at the beginning of the part on the top 
contour. 
Double-click on the tool name to open the tool properties. Apply the settings from Project X in the "Function" 
tab. 
 
 
 



 

 

Figure 7.8 Project N 

 
 
 
 
 
 
 
 
The settings in the Position tab of the CTool have changed.  
First, the width must be calculated: 
From project X (see figure 7.7) the beginning and the end of the section is given. The width results from the  
difference:  880 pixels - 620 pixels = 260 pixels width.  See figure 7.9 
   
There was no height in the X Project. The tool was calculated over the entire vertical image field. 
It must therefore be ensured in the new project that the upper contour edge is always sensed by the tool. For 
this purpose, the height is set to the entire sensor resolution. (See Chapter 6 upper limit of viewing area) 
 
Since the tool is positioned in the CTool via the X/Y coordinate center (Project N), the coordinates need offset 
values. 
In the example, a resolution of 2048 pixels is used. The height of the CTool is 2048 pixels.  
Since the "Y coordinate center" is in the center of the tool, half of the height is defined as the offset value 
so enter. > 2048 :2 = 1024 as Y-coordinate center. 
There are no "reference" feature for this setting, so the absolute reference is selected from the drop-down list. 
(see figure 7.9  b.) 
 
Enter an offset value for the "X coordinate center" which is exactly in the center of the tool area. So you calcu-
late from left side:  620 pixels +(260/2) = 750 pixels. 
(see figure 7.9 a.) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

Figure 7.9  Project N 

 
 
 
Now 3 tools in total have been implemented. We recommend to name and save the new check program. 
 
 
Name a program: Select the "Check program properties " icon: 

       
 
Then a dialog box opens:  Enter a "appropriate" file name. Ideally with date and creators name. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

7.1  Completion and Finishing 
 
 
Connect Checkopti Project N with the checkbox.  
In the menu Device there is the function "connect or disconnect from device”. 
 

 
 
 
By the menu „View“ you can open the  "Check Program Manager" to transfer the data to device. Or use the Icon 
to open. 
 

 
 
 
In the "Checkopti" and "Device" columns, use the mouse to select the check program and program location. 
If source and destination is selected the “Copy to device” button become active and the checkprogram could be 
transferred.  
 

 



 

 

 
 
After successful transfer, the name of the test program is visible in the “Device” column. 
 

 
 
 
Close window. 
 
Close Checkopti software and disconnect. 
 
This means that all the data on the device and the system has been converted. It is recommended to carry out an 
extensive test run. 
If too many parts are still evaluated as "NOK", then the data basis with the existing images in Checkopti may be 
too small. It is recommended to carry out the next step of the project optimization. 
 



 

 

8 Project optimization 
 
Due to various influences during the implementation of the conversion, it is possible that the images in the data 
storage may differ slightly from the current scanned images. 
These differences cause the inspection result to be negative, especially for the "standard features" in the in-
spection program. This leads to an increasing number of so-called "pseudo rejects". These parts marked as 
"bad", increase the bad-part rate and thus the output of the system. 
It becomes necessary to optimize the project. 
 
he basis for this is the Project N. Connect Checkopti to the device as described above.  
(The connection to the device should be established in the STOP state) 
 
Arrange the "Parts list" and "Part contour" windows on the screen in such a way that you can view them both 
 
 
With the icon "Record test parts" in part list window, the recording of the part images is activated. Then start 
the system and record the parts. 
 

 
 
 
Each part is now displayed in the test part list. In the part contour window, the images appear with the respec-
tive result values of the individual test features. 
 
Record approx. 200 parts. After that you can stop the recording. 
 
The aim of optimizing, is to reduce the "pseudo-reject" rate. Therefore, you can now concentrate on the parts 
marked with the red dot. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

Select a part marked with red dot in the part list. This causes, this part to be displayed in the part contour win-
dow. E.g. part no. 16. 
 

 
 
Now evaluate the possible deviations in the image and for the features. 
 
Then ask yourself the following questions: 
 
Does the image correspond to a good part? 
Is there a relevant change in the contour? e.g. caused by a poor feed.  
Is the feature marked in red relevant for the position orientation or the quality of the part? 
If yes, is the part still permissible or not? 
 
If you come to the result that the displayed part corresponds to the specifications, then the part is copied into 
the sample part list. This is done with the "Copy button" between the columns. (from right to left) 
 

  
 
 
Due to a new additional sample part, the calculation and evaluation is carried out anew automatically. 
 



 

 

The result shows that this part 16 has now been rated "good"(green dot). In addition, other parts are also rated 
as "good" due to new limit values. 
 

 
 
This process is now repeated for the next remaining "red-marked" parts. In the course of these optimizations 
more and more parts are evaluated as "good" and the output of the system is increased.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

Attention: Do not copy any wrong parts into the sample parts! 
 
 
Examples of "Wrong" parts that should not be transferred to the sample parts: Collar too low! 
 

 
 
 
Wrong part type: 

 
 
 
Bad image due to feeding error: 

  
 
 
 
 
Completion of optimization: 
 
Since every change in Checkopti, e.g. moving tools, creates new limit values, the check program must be trans-
ferred to the checkbox again.  
The new test program is transferred to the system as described in chapter 7.1. 
 
Remember to name and save the new check program. 



 

 

9 Procedure for changed resolution  
 
A changed resolution produces "different" images of the part than before. This requires adjusting the position 
and size of the tool. 
This essentially concerns the offset values of the "center coordinates" of the tools. The easiest way to adjust the 
tool is to move it by mouse. The size of the tool can also be easily changed with the mouse. 
 
Example images with different resolutions: 
 
Vertical: 512 Pix,             Vertical: 512 Pix 
Horizontal: Encoder to line-frequency ratio = 10         Horizontal: Encoder to line-frequency ratio = 5 
 
 

                                        
 
The image of the part becomes "wider", the height remains the same. 
The position of ROI is no longer correct. The offset value for "X coordinate center" must be adjusted to the posi-
tion of the notch. Move the mouse to the "correct" position. (Y-coordinates remain unchanged) 
 
 
To make the adaptation of Project X, take the position of the ROI and move it to the point to be checked. 
The size of the tool may also need to be adjusted. That depends on the inspection requirements. 
 
 
Vertical: 2048 Pix,                 Vertical: 2048 Pix 
Horizontal: Encoder to line-frequency ratio = 10             Horizontal: Encoder to line-frequency ratio = 5 
 

                                                                   



 

 

 
The image becomes "higher" and, possibly, "wider". This increases the resolution in both directions. 
The position of ROI is no longer correct. The offset value for "Y-coordinate center" must be adjusted to the posi-
tion of the notch. Move by mouse to the "correct" position. In the left example, the "X coordinate center" re-
mains unchanged. On the right, X and Y coordinates must be adjusted. 
The size of the tool may also need to be adjusted. That depends on the inspection requirements. 
 
The following comparison shows the relations, when using the changed resolution in X and Y direction: 
 

      
 
 
On the left, with low resolution, the presence of an O-ring with approx. 300 pixels is checked. With increased 
resolution in both directions and with adjustment of position and size, the ROI is checked with  
approx. 2200 pixels. 
This makes the evaluation more reliable and stable. 
 
 
Adaptation of the project N with changed resolution 
 
 
The basis remains the Project N. Basically, the aim is to exchange the images with low resolution for new images 
with the increased resolution. 
The procedure corresponds to the procedure described in chapter 8 of the optimization. You exchange the im-
ages with high resolution with the old images in the current file. This is managed in part list window as in figure 
9.1.  
 
Connect Checkopti to the device. Record at least 200 test pieces. Now the parts which correspond to the re-
quired image, position orientation and quality are copied from the test parts list into the sample parts list. 
 
Images with low resolution must be deleted from the sample parts list! Only images of the higher resolution may 
still be in this list (Select the Delete button or part and press "Del" on the keyboard.) 
 
Important!: For a project with position orientation, make sure that the orientation assignment (Ori.1 or Ori.2) is 
matching for the particular part. When copying the "bad parts", a wrong orientation could be assigned. The ori-
entation can be assigned via the numbers 1-8 on the left edge of the sample parts (the respective part must be 
marked). 
 
 
 
 
Figure 9.1  Procedure in the partlist window: 



 

 

 

     
 
 
 
 
Completion: 
 
Every change in Checkopti, e.g. copying parts, creates new limit values, the check program must be transferred 
to the checkbox again.  
The new checkprogram is transferred to the system as described in chapter 8. 
 
Remember to name and save the new check program. 
 

 
 
 

The END 

 


