Open Source Licences

The SBS Software makes use of a couple of third party software packages that come with various licenses. This section is meant to list all these packages and to give credit to those whos code helped in the creation of the SBS Software.

For components that reference the GNU General Public License (GPL) or the GNU Lesser General Public License (LGPL), please find these licenses and the written offer for source code in this software installation in \Festo\SBS Vision-Sensor\Eula\OpenSourceLicenses.

The SBS firmware makes use of Linux Version 2.6.33 (Website: www.kernel.org), which is distributed under the GNU GPL version 2.

The SBS firmware makes use of x-loader, an initial program loader for Embedded boards based on OMAP processors (Website: http://arago-project.org/git/projects/?p=x-load-omap3.git; a=summary) which is distributed under the GNU GPL version 2 or higher.

The SBS firmware makes use of u-boot, an initial program loader for Embedded boards based on OMAP processors (Website: http://arago-project.org/git/projects/?p=x-load-omap3.git; a=summary) which is distributed under the GNU GPL version 2 or higher

The SBS firmware makes use of spike Version 0.2,a SPI-driver (Website: https://github.com/scottellis/spike/blob/master/spike.c ), which is distributed under the GNU GPL version 2 or higher.

The SBS firmware makes use of Busy-Box Version 1.18.1 ( Website: http://www.busybox.net/ ), which is distributed under the GNU GPL version 2 or higher

The SBS firmware makes use of vsftpd Version 2.0.3 ( Website: https://security.appspot.com/vsftpd.html ), which is distributed under the GNU GPL version 2 or higher.

The SBS firmware makes use of mtd-utils Version 1.5.0 ( Website: http://www.linux-mtd.infradead.org/doc/general.html ), which is distributed under the GNU GPL version 2 or higher.

The SBS firmware makes use of Boa Webserver Version 0.94.13 ( Website: http://www.boa.org/ ), which is distributed under the GNU GPL version 2 or higher.

The SBS firmware makes use of Procps Version 3.2.8 ( Website http://procps.sourceforge.net/download.html), which is distributed under the GNU GPL version 2 or higher and GNU LGPL version 2.1 or higher.

The SBS firmware makes use of GnuPG Version 1.4.10 ( Website: https://www.gnupg.org/ ), which is distributed under the GNU GPL version 3 or higher.

The SBS firmware makes use of glibc, which is distributed under GNU LGPL version 2.1 or higher.

The SBS firmware makes use of Dropbear - a SSH2 server Version 2012.55 ( Website: https://matt.ucc.asn.au/ dropbear/dropbear.html ). The Dropbear SSH2 server is distributed under the terms of the Dropbear License which is a MIT/X Consortium style open source license. Please find this license in this software installation in \Festo\SBS Vision-Sensor\Eula\OpenSourceLicenses

Vision Sensor Configuration Studio software is based in part on the work of the Qwt project (http://qwt.sf.net).

Vision Sensor Device Manager, Vision Sensor Configuration Studio, Rescue software is based in part on the work of the Qt-project (https://doc.qt.io/qt-5/licenses-used-in-qt.html).


SBS – Bedien- und Konfigurationssoftware – Übersicht

Aufbau der SBS Software

Die SBS Software besteht aus den folgenden drei Modulen:

  • Vision Sensor Device Manager

    Mit diesem Modul wählen Sie den zu konfigurierenden Sensor oder eine Sensor-Simulation aus und starten wahlweise die Anwendungen Vision Sensor Configuration Studio oder Vision Sensor Visualisation Studio. Systemeinstellungen, wie IP-Adressen oder Firmware-Updates, können hier geändert, sowie Passworte und Benutzerrechte verwaltet werden.

  • Vision Sensor Configuration Studio

    Dieses Modul enthält umfassende Funktionen zur Einrichtung von Sensoren und zur Konfiguration von Prüfaufgaben (Jobs). Falls der Passwortschutz aktiviert ist, benötigen Sie zur Konfiguration die Berechtigung der Benutzergruppe Administrator.

  • Vision Sensor Visualisation Studio

    Diesem Modul zeigt Bilder und Ergebnisse an. Sie können damit Sensoren überwachen / überprüfen und Messergebnisse analysieren. Zusätzlich stehen umfangreiche Archivierungsfunktionen zur Verfügung. Im Vergleich zu Vision Sensor Configuration Studio bietet es nur eingeschränkte Konfigurationsmöglichkeiten. Falls der Passwortschutz aktiviert ist, benötigen Sie zur Bedienung die Berechtigung der Benutzergruppe Administrator oder Werker.

Abbildung: Softwarestruktur

Unter www.festo.com stehen Ihnen kostenfrei aktuelle Versionen der SBS Software zum Download zur Verfügung.

Datum: 03.08.2018


Vision Sensor Device Manager

Abbildung: Vision Sensor Device Manager Übersicht

A) Aktive Sensoren
In dieser Liste werden alle vom PC aus erreichbaren SBS Vision-Sensoren angezeigt.

B) Sensoren für Simulationsbetrieb
Hier werden alle zur Offline- Simulation verfügbaren SBS Vision-Sensoren angezeigt.

C) Sensoren per IP Adresse hinzufügen
Sensoren, die nach Softwarestart bzw. nach „Finden“ (Auslösen weiterer Suchdurchgang) nicht in der Liste „Aktive Sensoren“ erscheinen, aber sicher im Netzwerk vorhanden sind (ggf. z.B. erst hinter einem Gateway), und deren IP-Adresse bekannt ist, können hier mit Ihrer IP- Adresse eingetragen werden. Mit Drücken des Buttons „Hinzufügen“ werden solche Sensoren, wenn gefunden, ebenfalls in die Liste „Aktive Sensoren“ eingetragen und können nun bearbeitet werden.

D) Funktionen

  • Finden
    Auslösen eines weiteren Suchdurchganges
  • Konfigurieren
    Konfigurieren eines angeschlossenen Sensors oder einer Sensorsimulation = Vision Sensor Configuration Studio
  • Anzeigen
    Anzeige von Bild- und Ergebnisdaten eines angeschlossenen Sensors = Vision Sensor Visualisation Studio
  • Einstellungen
    Netzwerkeinstellungen wie IP-Adresse etc. des Sensors bearbeiten

E) Kontext- Hilfe
Kontextsensitive Hilfe zum aktuellen Thema

F) Favoriten
Die SBS Vision-Sensoren können als Favoriten abgespeichert werden. Die Favoriten dienen dem schnellen Zugriff und der Verwaltung der SBS Vision-Sensoren.


Vision Sensor Configuration Studio

Abbildung: Vision Sensor Configuration Studio Übersicht

Die verschiedenen Arbeitsbereiche sind:

A) Menü- und Toolbar

B) Bedienschritte
SBS – Bedien- und Konfigurationssoftware – Vision Sensor Configuration Studio, alle Funktionen

C) Bild
Bildausgabe mit grafisch einstellbaren Arbeits- und Suchbereichen, sowie Zoomfunktion und Filmstreifennavigation

D) Hilfe, Ergebnis, Statistik

  • Hilfe: Kontextsensitive Hilfe zum aktuellen Thema
  • Ergebnis: Detektorergebnisse zu ausgewählten Parametern
  • Statistik: Anzeige einer Statistik zu Auswertung und der Ausführungszeit

E) Einstellungen der Bildaufnahme
Umschaltung zwischen kontinuierlichem Modus und Einzelbildmodus und Software Trigger

F) Verbindungsmodus
Umschaltung zwischen Online- und Offline-Modus (Sensor vorhanden oder Simulation ohne Sensor).

G) Konfigurationsfenster
Variabel, zur entsprechenden Aktion, wechselnder Inhalt zur Einstellung der zugehörigen Parameter.

H) Statusleiste
Verschieden Statusinformationen einschließlich: Modus / Name des SBS / aktiver Job. Im Run Modus: Zykluszeit xy Position des Cursors und Intensität des Pixels / einzelne I/O Ein-/Aus- Status (wie unter "Ausgabe/Ausgangssignale" konfiguriert).


Vision Sensor Visualisation Studio

Abbildung: Vision Sensor Visualisation Studio Übersicht

A) Bildanzeige

B) Kontext- Hilfe
Kontextsensitive Hilfe zum aktuellen Thema

C) Kommandos
Kommandos zur Anzeige, Übertragung und Archivierung von Bildern.

D) Job- und Ergebnisanzeige
Mit diesen Tabs können (statistische) Ergebnisse angezeigt, Jobs umgeschaltet und Jobs / Jobsätze von Vision Sensor Visualisation Studio auf den Sensor geladen werden.


Hilfe im Kontext

Für alle wichtigen Programmfunktionen gibt es kontextsensitive Hilfe-Seiten: Sobald Sie eine bestimmte Funktion auf der Programmoberfläche auswählen, erhalten Sie im Hilfe-Fenster die passenden Informationen.
Alle verfügbaren Hilfeseiten können Sie einsehen, wenn Sie Hilfe (Button mit "?"- Symbol, oder Doppelklick im Online- Hilfe Fenster) im Menü wählen. Dort können Sie auch nach Begriffen oder Stichworten suchen.
Im Unterschied zur kontextsensitiven Hilfe können Sie die Größe dieses Hilfefensters beliebig anpassen, sodass auch längere Hilfetexte übersichtlich dargestellt werden.

Verwendete Open Source Software: Open Source Licences


SBS – Bedien- und Konfigurationssoftware – Kurzanleitung

Diese Kurzanleitung erläutert den exemplarischen Ablauf zur Einstellung einer Prüfaufgabe auf dem SBS Vision-Sensor.
Exemplarischer Ablauf am Beispiel eines Objektsensors.

Starten der SBS Software

Zum Starten der SBS Software auf das Desktop-Icon „SBS Vision-Sensor“ klicken.

Abbildung: Icon SBS

Vision Sensor Device Manager - Sensoren oder Sensorsimulationen öffnen / Passworte

In diesem Programm können Sie einen Sensor oder eine Sensor-Simulation zur Konfiguration oder zur Anzeige (Überwachung) auswählen sowie verschiedene Grundeinstellungen vornehmen.

Sensoren konfigurieren oder anzeigen

Um einen Sensor zur Konfiguration oder zur Anzeige zu öffnen, den gewünschten Sensor in der Liste „Aktive Sensoren“ markieren. Danach startet, mit einem Klick auf den Button „Konfigurieren“, das Modul „Vision Sensor Configuration Studio“. Mit dem Button „Anzeige“ startet das Modul „Vision Sensor Visualisation Studio“.

Sensorsimulation

Um einen Sensor zur Offline- Simulation zu öffnen, den gewünschten Sensor in der Liste „Sensoren für Simulationsbetrieb“ markieren. Danach startet, mit einem Klick auf den Button „Konfigurieren“, das Modul „Vision Sensor Configuration Studio“.

Passworte einrichten

Beim ersten Start nach der Installation ist die Passworteingabe komplett deaktiviert und der Auto-Login als Administrator voreingestellt. Sollen Parametereinstellungen vor unbefugtem Zugriff geschützt werden, sollten Passworte für die Passwortebenen „Admin“ und „User“ vergeben werden. Dies kann über die Menüleiste Datei / Benutzerverwaltung bzw. den Button mit dem Schlüsselsymbol in der Toolbar aufgerufen werden.

Abbildung: Passwort-Button

Passwortebenen

Passwort Ebene Vision Sensor Device Manager Vision Sensor Configuration Studio Vision Sensor Visualisation Studio

Administrator

Passwort

Alle Funktionen

Alle Funktionen

Alle Funktionen

Werker

Passwort

Alle Funktionen außer

  • Konfigurieren
  • Einstellungen
  • Update

Keine

Alle Funktionen,
inklusive Job- Upload und Bildrekorder

Bediener
(ohne Passwort)

Alle Funktionen außer

  • Konfigurieren
  • Einstellungen
  • Update

Keine

Nur Anzeige von Bildern, Prüfergebnissen und Statistik

Um nach Vergabe von Passworten die Funktion „Konfigurieren“ nutzen zu können, ist nun ein Login mit Klick auf den Toolbar- Login- Button, und danach die Eingabe des vorher vergebenen Passworts nötig.

Abbildung: Login-Button

Abbildung: Passworteingabe

Durch Vergabe eines leeren Passworts kann die Abfrage wieder ohne weitere Eingabe quittiert werden. Durch Aktivierung der Checkbox „Passwortabfrage deaktivieren“ wird die Abfrage dauerhaft deaktiviert.

Wurden Passworte vergeben und dann aber vergessen, ist durch Neuinstallation der Software das Rücksetzen auf den Auslieferungszustand möglich.


Vision Sensor Configuration Studio: Sensor einstellen

Mit diesem Programm können Sie Ihren SBS in sechs folgerichtigen Arbeitsschritten für eine oder mehrere Prüfaufgaben (Jobs) konfigurieren.

Job konfigurieren

Um einen Job zu konfigurieren: Unter Bedienschritte/Job den Jobeintrag editieren oder einen neuen Job anlegen.

Abbildung: Vision Sensor Configuration Studio Job

Hier werden neue Jobs angelegt und auch mehrere Jobs verwaltet. Außerdem werden hier alle globalen Einstellungen, die für die gesamte Prüfaufgabe gültig sind, wie z.B. Verschlusszeit, Verstärkung, Beleuchtungseinstellungen etc. vorgenommen.

Ein Job enthält sämtliche Einstellungen und Parameter, die zur Durchführung einer bestimmten Prüfaufgabe erforderlich sind.

  • Zuerst sollten, um ein kontrastreiches und scharfes Bild zu erhalten, folgende grundlegenden Bildeinstellungen gemacht werden:

    • Bildhelligkeit: Verschlusszeit bzw Verstärkung einstellen siehe Job/Bildaufnahme
    • Bildschärfe: Fokus Einstellschraube an der Rückseite des SBS einstellen bis eine scharfe Abbildung sichtbar ist
  • Im Auslieferungszustand ist als Trigger Modus = "Freilauf" (siehe Job/Bildaufnahme) und als „Trigger / Bildaktualisierung“ = "Kontinuierlich" eingestellt. Damit wird zur Fokus- und Helligkeitseinstellung permanent ein neues Bild eingezogen und somit die Anzeige auch permanent aktualisiert.
  • Die danach folgende Einstellung der Lagenachführung und der Detektoren erfolgt vorzugsweise im Einzelbildmodus, da alle Einstellungen dann auf einem Masterbild basieren und der Bildeinzug nicht permanent ausgeführt wird. Dazu unter Bildaufnahme/Triggermodus = Trigger einstellen.
  • Innerhalb eines Jobs kann nachfolgend eine Lagenachführung und (je nach Sensortyp) 32 bzw. 255 verschiedene Detektoren zur Lösung der Prüfaufgabe definiert werden.

Es besteht die Möglichkeit, einen Job als Vorlage zu speichern. Dazu in der Jobliste mit Rechtsklick auf den Job klicken und „Als Vorlage speichern“ auswählen. Für jeden neuen Job werden anschließend die Einstellungen und Detektoren aus der Jobvorlage übernommen. Die Jobvorlage wird mit einem "T" (Template) als Kennzeichen in der Jobliste angezeigt. Die Jobvorlage kann nicht editiert werden. Zum Entfernen der Jobvorlage mit Rechtsklick auf die Vorlage und "Entfernen" wählen.

Nächstes Thema: Lagenachführung einstellen


Lagenachführung einstellen

Bei Objekten bzw. Merkmalen, deren Position im Bild variiert, kann eine Lagenachführung nützlich bzw. erforderlich sein. Hierfür stehen drei verschiedene Detektionsmethoden (Lagedetektoren) zur Verfügung.

Nächstes Thema: Detektoren einstellen

Die Lagenachführung ist optional und steht mit der Methode Mustervergleich, Kantenantastung und Konturvergleich zur Verfügung.
Nach Auswahl der Methode zur Lagenachführung die entsprechenden Arbeitsbereiche im Bild grafisch in Position und Größe auf das Merkmal, welches zur Lagebestimmung dienen soll, einstellen. Die zugehörigen Parameter werden unten rechts dargestellt und können dort auch angepasst werden. Die Lagenachführung wirkt auf alle nachfolgend in diesem Job definierten Detektoren. Im Beispiel hier wird die linke obere Ecke des rechteckigen Bauteils durch die Bestimmung der linken und der oberen Außenkante und deren Schnittpunkt zur Lagebestimmung des nur translatorisch in X- und Y- Richtung in der Position variierenden Bauteiles bestimmt. Sollte auch die Winkellage des Bauteiles variieren können, ist die Methode „Konturvergleich“ zur Lagenachführung zu verwenden.

Abbildung: Vision Sensor Configuration Studio Lagenachführung


Detektoren einstellen

Hier können verschiedene Detektoren zur Lösung einer Prüfaufgabe ausgewählt und eingestellt werden. Zuerst wird im unten dargestellten Dialog ein gewünschter Detektor ausgewählt.

Abbildung: Detektorliste Objektsensor

Danach werden die Arbeits- und Suchbereiche graphisch im Bild eingestellt. Falls Einlernbereiche vorhanden sind, werden diese sofort bei Abschluss der Einstellung eingelernt. Unten links werden alle in diesem Job definierten Detektoren angezeigt. Unten rechts werden die Parameter des aktuell ausgewählten Detektors angezeigt und können dort auch angepasst werden. Falls weitere Merkmale am selben Teil zu prüfen sind, lassen sich mit „Neu" beliebig viele weitere Detektoren, analog wie oben beschrieben, erstellen. Im Beispiel wurden zwei Helligkeits- Detektoren zur Überprüfung der Anwesenheit von Kontakten im Prüfteil definiert.

  • Detektor 1 findet einen Kontakt (Helligkeitswert liegt im geforderten Bereich, da metallisch- glänzender, d.h. hoch reflektierender Kontakt vorhanden), und meldet deshalb ein positives Ergebnis.
  • Detektor 2 findet keinen Kontakt (Helligkeitswert liegt außerhalb des geforderten Bereichs, da kaum Reflexion durch dunkles Kunststoffgehäuse), und meldet deshalb ein negatives Ergebnis.

Abbildung: Detektor erstellen


Ausgabe, I/O und Datenausgabe

Im Bedienschritt Ausgabe können verschiedene Einstellungen bezüglich der digitalen Ein- / Ausgänge und der Datenausgaben gemacht werden.

In den verschiedenen Tabs die Schnittstellen auswählen und aktivieren. Detektorergebnisse logisch verknüpfen, und den vorhandenen I/O's zuordnen.

Zur Ausgabe von Ergebnisdaten ebenfalls gewünschte Schnittstelle wählen und Datenstring zusammenstellen.

Nächstes Thema: Ergebnis

Abbildung: Ausgabe, Digitale Signale und Daten

Einstellmöglichkeiten in den verschiedenen Tabs:

  • Pinbelegung

    Auswahl und Zuordnung der digitalen Schalt- Ein- und Ausgänge.

  • Ausgangssignale

    Zuordnung einer logischen Verknüpfung unter Nutzung der boolschen Ergebnisse aller Detektoren. Definition von komplexen logischen Verknüpfungen via Tabelle oder via Eingabe einer logischen Formel.

    Zu jedem vorhandenen digitalen Ausgang kann eine eigene logische Verknüpfung zugeordnet werden.

  • Schnittstellen

    Auswahl, Einstellung und Aktivierung der einzelnen Schnittstellen.

  • Zeitsteuerung

    Einstellung der Delayzeiten: Trigger-Verzögerung, Ergebnis-Verzögerung und Ergebnis-Dauer

  • Datenausgabe

    Einstellung des Datenausgabestrings via RS422 oder Ethernet.

Auswahl von: Binärem- oder ASCII- Protokoll, Vorspann / Nachspann, Standardinhalten / flexibel zusammenstellbaren, speziellen Einzeldaten der einzelnen Detektoren.
Es können beliebig viele Einzelergebnisse aller definierten Detektoren im Ausgabestring frei angeordnet werden.


Ergebnis

Über diese Funktion wird die Prüfung mit allen gemachten Einstellungen auf dem PC zu Kontrollzwecken ausgeführt. Dabei werden alle Ergebnisse genau wie später auf dem Sensor erzeugt und angezeigt. Jedoch z.B. die Ausführungszeiten nicht aktualisiert, da diese Werte nur aussagefähig sind, wenn die Ausführung auf dem Sensor selbst erfolgt. Es werden keine Hardware- Ausgänge gesetzt.

Nächstes Thema: Sensor starten

Abbildung: Ergebnisanzeige


Sensor starten

Mit Aktivierung dieser Funktion werden alle Einstellungen auf den Sensor übertragen, im Flash gespeichert und dort entsprechend der vorgenommenen Einstellungen z.B. im Freilauf oder im getriggerten Modus ausgeführt. Alle Anzeigen in der Detektorliste, im Ergebnisfeld bzw. unter „Statistik“ werden hier aktualisiert. Bei Aktivierung dieser Funktion werden die übertragenen Parameter permanent gespeichert und bei der Ausführung werden auch die entsprechenden Hardware- Ausgänge gesetzt.

Nächstes Thema: Vision Sensor Visualisation Studio, Bilder und Ergebnisse anzeigen

Abbildung: Sensor starten


Vision Sensor Visualisation Studio, Bilder und Ergebnisse anzeigen

Dieses Programm dient zur Überwachung / Überprüfung von angeschlossenen Sensoren und zur Analyse von Prüfergebnissen, sowie zur Archivierung von Prüfergebnissen und Bildern.

Nach Klick auf den Button „Anzeige" in Vision Sensor Device Manager startet das Modul Vision Sensor Visualisation Studio.

Das aktuelle Bild wird mit Einzeichnungen der Lagenachführung und der Detektoren angezeigt (falls „Bildübertragung = Aktiv“ im Konfigurationsmodul unter Job/Allgemein aktiviert ist).
Im Tab „Ergebnis“ werden die einzelnen Detektoren mit Ihren Ergebnissen, und das Gesamtergebnis dargestellt.
Im Tab „Statistik“ werden weitere statistische Ergebnisse angezeigt.
Mit „Bild einfrieren" können ereignisgesteuert (z.B. Schlechtteil) Bilder in der Anzeige festgehalten werden.
Mit „Zoom" können Bilder vergrößert dargestellt werden.
Mit „Bilder archivieren" können Bilder und Ergebnisdaten, wie zuvor unter „Menü Datei/Archivierung konfigurieren", eingestellt, auf der Festplatte des angeschlossenen PC´s, mit oder ohne numerischen Ergebnisdaten, archiviert werden.
Mit „Rek. Bilder" kann der Bildrekorder ausgelesen werden.
Im Tab „Job“ können auf dem Sensor vorhandene Jobs umgeschaltet werden.
Im Tab „Hochladen“ können weitere zuvor definierte Jobs oder ganze Jobsätze vom Viewer aus auf den Sensor geladen werden.


SBS – Bedien- und Konfigurationssoftware – Vision Sensor Device Manager, alle Funktionen

In diesem Programm können Sie einen Sensor oder eine Sensor-Simulation zur Konfiguration, oder zur Anzeige (Überwachung) auswählen, sowie verschiedene Grundeinstellungen vornehmen:

  • Aktive Sensoren
  • Sensoren für Simulationsbetrieb
  • Aktiven Sensor hinzufügen / Finden
  • Konfigurieren eines angeschlossenen Sensors
  • Vision Sensor Visualisation Studio, Bilder und Ergebnisse anzeigen
  • Netzwerk- Einstellungen des Sensors
  • Firmware-Update (Datei)
  • Benutzerverwaltung / Passworte (Datei)
  • Favoriten
  • Autostart-Datei (Datei)

Abbildung: Vision Sensor Device Manager

Ist die Funktion „Konfigurieren" nicht zugänglich (Button inaktiv) so ist ein Login (Button mit Türsymbol und Pfeil) mit Passworteingabe nötig. Falls Sie das Passwort nicht kennen, bitte den Administrator kontaktieren.


Aktive Sensoren

In der Auswahlliste Aktive Sensoren werden die im Netzwerk verfügbaren Sensoren angezeigt.

Konfigurieren eines angeschlossenen Sensors (Aufruf von Vision Sensor Configuration Studio)

Anzeigen von Bild- und Ergebnisdaten (Aufruf von Vision Sensor Visualisation Studio)

Bedeutung der angezeigten Parameter

Parameter | Bedeutung
IP-Adresse | IP- Adresse des Sensors im Netzwerk
Hardware | Hardware Version (R3B, R2B, ...)
Sensortyp | Sensortyp (Object, Color, Code Reader, o.ä.)
Variante | Sensor-Variante (Advanced ...)
Version | Firmware-Version
Mode | Betriebsart (Run, Config oder Offline)
Sensorname | Name des Sensors
Hersteller | Name des Herstellers
Mac-Adresse | Mac-Adresse des Sensors
Subnetz-Maske | Subnetzmaske des Sensors
Gateway | Standard Gateway
DHCP | DHCP aktiv / inaktiv
Betriebssystem | Art des Betriebssystems
Betriebssystem Version | Version des Betriebssystems
Plattform | z.B. SBS
Hardware | Hardware Version
RAM | RAM Größe
Flash | Flash Größe

Hinweis:

  • Werden in der Liste keine Einträge angezeigt, obwohl ein Sensor angeschlossen ist, können Sie diesen mit Button „Finden" oder Button „Hinzufügen" einfügen.
  • Ist kein Sensor angeschlossen, stehen Ihnen in der Liste Sensoren für Simulationsbetrieb, Simulationen verschiedener Sensoranwendungen zur Verfügung.

Über den Button Details (am rechten Ende der Parameter Liste von „Aktive Sensoren“) ist eine noch detailliertere Liste der SBS Parameter abzurufen.

Abbildung: Sensoreigenschaften


Sensoren für Simulationsbetrieb

Um in den Simulationsmodus zu gelangen, wählen Sie mit einem Doppelklick den gewünschten Sensortyp aus und drücken Sie die Button "Config" (Aufruf von Vision Sensor Configuration Studio).

Funktion der angezeigten Parameter

Parameter | Funktion
Sensortyp | Sensortyp (z.B. Object, Color, Code Reader, ...)
Hardware | Hardwaretyp (z.B. Auflösung, Monochrom- oder Farbsensor)
Version | Firmware-Version
Variante | Sensor-Variante (z. B. Advanced …)

Ist die Funktion "Konfigurieren" nicht zugänglich (Button inaktiv), so ist ein Login mit Passworteingabe nötig. Falls Sie das Passwort nicht kennen, bitte den Administrator kontaktieren.


Aktiven Sensor hinzufügen / Finden

Werden in der Auswahlliste „Aktive Sensoren“ keine Einträge angezeigt, obwohl ein Sensor angeschlossen ist, gehen Sie wie folgt vor:

Finden / Sensor suchen:

Um nach am PC angeschlossenen, oder im Netzwerk verfügbaren Sensoren zu suchen, klicken Sie auf Button „Finden".

Aktiven Sensor hinzufügen:

Wenn Sie die IP-Adresse eines Sensors kennen, geben Sie diese bitte in das Feld IP-Adresse ein und klicken Sie auf die Schaltfläche "Hinzufügen".

Jetzt erscheint der Sensor in der Liste und kann z.B. konfiguriert "Konfigurieren" oder angezeigt "Anzeigen" werden.

Ist die Funktion "Konfigurieren" nicht verfügbar (Schaltfläche nicht aktiv / abgeblendet) ist ein Login mit Passworteingabe erforderlich. Wenn Sie das Passwort nicht kennen, wenden Sie sich an Ihren Systemadministrator.


Favoriten

Die Favoriten dienen dem schnellen Zugriff und der Verwaltung der SBS Vision-Sensoren. Folgende Parameter können für die Favoriten ausgewählt werden.

Rechtsklick auf aktive Sensoren in Vision Sensor Device Manager:

Abbildung: Parameter Favoriten bei Rechtsklick auf aktive Sensoren

Parameter | Funktion
Aus Liste entfernen | Entfernt den ausgewählten Sensor aus der Liste „Aktive Sensoren“.
Liste leeren | Leert die komplette Liste „Aktive Sensoren“.
Als Favorit speichern | Speichert den ausgewählten Sensor als Favorit
Alle als Favorit speichern | Speichert alle Sensoren in der Liste „Aktive Sensoren“ als Favoriten.

"Favoriten" in Vision Sensor Device Manager:

Abbildung: Optionen Favoriten

Parameter | Funktion
Als Favorit speichern | Öffnet das Fenster „Als Favorit speichern“, in dem ein gewünschtes Ziel in der Baumstruktur ausgewählt werden kann, an dem der Sensor aus der Liste "aktive Sensoren" als Favorit gespeichert werden soll.
Alle als Favorit speichern | Öffnet das Fenster „Alle als Favorit speichern“, in dem ein gewünschtes Ziel in der Baumstruktur ausgewählt werden kann, an dem alle Sensoren aus der Liste "aktive Sensoren" als Favoriten gespeichert werden sollen.
Zu aktive Sensoren hinzufügen | Öffnet das Fenster „Zu aktive Sensoren hinzufügen“, in dem ausgewählt werden kann, welcher Sensor bzw. welche Sensorgruppe der Liste „Aktive Sensoren“ hinzugefügt werden soll.
Favoriten verwalten | Öffnet das Fenster „Favoriten verwalten“, in dem die Sensorgruppen verwaltet / bearbeitet werden können.

Favoriten verwalten - Gruppen anlegen

Im linken Fensterbereich werden die Sensoren über eine Baumstruktur in Gruppen unterteilt, z.B. nach Produktionsstandorten und Produktionslinien. Im rechten Bereich des Fensters werden die Sensoren unterhalb einer gewählte Gruppe tabellarisch aufgelistet, z.B. Gruppe "Favorit" zeigt alle Sensoren an.

Abbildung: Gruppeneinteilung

Die Favoriten werden im Installationspfad des SBS Vision-Sensors auf dem PC als XML-Datei abgelegt. Die Datei liegt unter dem Verzeichnis "Festo/SBS Vision-Sensor/Vision Sensor Device Manager/Data". Sie kann zwischen verschiedenen PCs ausgetauscht werden.

Beispiele zur Anwendung der Favoriten:

Beispiel 1:

SBS Vision-Sensoren, die in verschiedenen Netzwerken integriert sind, können lokal in Vision Sensor Device Manager eingesehen und verwaltet werden (siehe auch nachfolgende Abbildung). Die Sensoren können über die Eingabe der IP-Adresse im Feld "Aktiven Sensor hinzufügen" der Liste "Aktive Sensoren" hinzugefügt werden. Die Verwaltung der Sensoren findet anschließend über Favoriten statt. Die Sensoren können über "Vision Sensor Device Manager/Favoriten/Als Favorit speichern" zu den Favoriten hinzugefügt werden. Innerhalb der Favoriten können die Sensoren verschiedenen Gruppen zugeordnet werden.

Abbildung: Beispiel 1 - SBS Vision-Sensoren in verschiedenen Netzwerken

Beispiel 2:

Mehrere Stationen sind im gleichen lokalen Netzwerk. Alle Benutzer haben Zugriff auf alle SBS Vision-Sensoren, obwohl für ihre Tätigkeit nur einzelne SBS Vision-Sensoren relevant sind (siehe auch nachfolgende Abbildung). In Verbindung mit der Autostart-Funktion (siehe hierzu auch Autostart-Datei (Datei)) besteht die Möglichkeit, dass nur eine bestimmte Auswahl an SBS Vision-Sensoren (Favoriten) angezeigt werden. Dazu müssen die Sensoren den Favoriten hinzugefügt und in Gruppen unterteilt werden. In der Autostart-Datei kann anschließend eine Gruppe von Favoriten ausgewählt werden. Die Benutzer haben beim Öffnen von Vision Sensor Device Manager über die Autostart-Datei dann nur noch auf die relevanten Sensoren Zugriff.

Abbildung: Beispiel 2 - Favoriten in der Autostart-Datei


Konfigurieren eines angeschlossenen Sensors

Markieren Sie einen Sensor (bzw. eine Simulation) in der Liste und klicken Sie auf den Button „Konfigurieren". Das Konfigurationsprogramm Vision Sensor Configuration Studio wird aufgerufen und die ggf. auf dem Sensor gespeicherten Jobs werden in der Auswahlliste angezeigt. Beim Aufruf von Vision Sensor Configuration Studio erscheint u.U. eine Passwortabfrage. Zur Festlegung von Passwörtern siehe Benutzerverwaltung / Passworte (Datei)

S. Kapitel: SBS – Bedien- und Konfigurationssoftware – Vision Sensor Configuration Studio, alle Funktionen


Anzeigen von Bild- und Ergebnisdaten

Markieren Sie einen Sensor in der Liste und klicken Sie auf den Button „Anzeigen". Das Programm Vision Sensor Visualisation Studio wird aufgerufen und Bilder und Messergebnisse des aktiven Jobs angezeigt.

Hinweis:

Durch Aufruf von Vision Sensor Visualisation Studio wird der Betrieb des ausgewählten Sensors zunächst nicht beeinflusst.

S. Kapitel: SBS – Bedien- und Konfigurationssoftware – Vision Sensor Visualisation Studio, alle Funktionen


Netzwerk- Einstellungen des Sensors

Mit dem Button „Einstellungen" können Sie die Netzwerkeinstellungen des gewählten Sensors ändern. IP-Adresse, Subnetz-Maske, Standard- Gateway, DHCP und ein Sensorname können hier eingestellt werden. Die IP-Adresse und die Subnetz-Maske des PC wird unten in der Statusleiste von Vision Sensor Device Manager angezeigt. Zur Verbindung des Sensors mit dem PC müssen die Adressräume übereinstimmen. Dazu ggf. hier die IP-Adresse etc. des Sensors entsprechend einstellen. Bitte kontaktieren Sie zur Festlegung von Netzwerkparametern Ihren Administrator. Weitere Informationen hierzu finden Sie auch im Kapitel Netzwerkanschluss Kurzanleitung und Netzwerkanschluss . Wenn "DHCP = aktiv" gewählt wird, muss für den Sensor ein Name vergeben werden, da die IP-Adresse dann bei jedem Sensorstart neu vergeben wird und somit wechseln kann, d.h. nicht mehr eindeutig ist. Für diese Funktionen benötigen Sie Administratorrechte (siehe Benutzerverwaltung).

Abbildung: Vision Sensor Device Manager IP Setup

S. Kapitel: Netzwerkanschluss Kurzanleitung und Netzwerkanschluss


Benutzerverwaltung / Passworte (Datei)

SBS-Konfigurationssoftware unterscheidet drei Benutzergruppen, die unterschiedliche Berechtigungen besitzen: (Button oben, links, mit Schlüsselsymbol)

Abbildung: Vision Sensor Device Manager, Passworte

Passwort Ebene Vision Sensor Device Manager Vision Sensor Configuration Studio Vision Sensor Visualisation Studio

Administrator

Passwort

Alle Funktionen

Alle Funktionen

Alle Funktionen

Werker

Passwort

Alle Funktionen außer

  • Konfigurieren
  • Einstellungen
  • Update

Keine

Alle Funktionen,
inklusive Job- Upload und Bildrekorder

Bediener
(ohne Passwort)

Alle Funktionen außer

  • Konfigurieren
  • Einstellungen
  • Update

Keine

Nur Anzeige von Bildern, Prüfergebnissen und Statistik

Nach Installation der Software wird der Login automatisch sofort bei Aufruf der Anwendung ohne Passwortabfrage ausgeführt. Es sind keine Passworte vergeben.

Passwörter festlegen

Wählen Sie Benutzerverwaltung im Datei-Menü oder klicken Sie in der Toolbar auf den Button mit dem Schlüsselsymbol, um Passwörter für die Benutzerkategorien Administrator und Werker zu vergeben bzw. zu ändern. Nach Eingabe eines Passworts wird automatisch ein Logout ausgeführt, d.h. ab dann ist die Eingabe des neu vergebenen Passwortes notwendig. Bei Vergabe eines "leeren" Passworts kann die Eingabe einfach mit OK quittiert werden.

Abbildung: Passwort-Button

Login / Logout

Nach der Festlegung von Passworten ist ein Login notwendig, z.B. zur Konfiguration eines Sensors. Dazu in der Toolbar auf den Login-Button klicken, das festgelegte Passwort eingeben und mit "Ok" bestätigen. Wurde der Haken bei "Passwortabfrage deaktivieren" gesetzt, wird beim nächsten Start der Anwendung nicht mehr nach dem Passwort gefragt. Um die Benutzerguppe abzumelden auf den Logout-Button klicken.

Abbildung: Login-Button

Abbildung: Logout-Button


Firmware-Update (Datei)

Mit dem Menüpunkt "Vision Sensor Device Manager/Datei/Firmware-Update" können Sie die Firmware des gewählten Sensors aktualisieren (siehe nachfolgende Abbildung). Dazu muss vorher via Download von der Festo Homepage bzw. vom Festo Support die entsprechende Firmware-Update Datei beschafft werden. Wählen Sie, im sich öffnenden Dialog, die entsprechende Firmware-Datei und folgen den Anweisungen. Trennen Sie während dieses Vorgangs nicht die Stromversorgung zum Sensor, solange Sie nicht explizit durch eine Bildschirmanweisung dazu aufgefordert werden.

Abbildung: Vision Sensor Device Manager, Firmware Update

Achtung:

Vor der Ausführung des Firmware-Updates bitte ein aktuelles Backup erstellen!

Dazu die Jobsätze über den Menüpunkt "Vision Sensor Configuration Studio/Datei/Jobsatz speichern unter (Backup) ..." speichern (siehe auch nachfolgende Abbildung).

Abbildung: Backup erstellen, Jobsatz speichern unter


Autostart-Datei (Datei)

Autostart ermöglicht das automatische Starten der SBS Software. Dazu wird eine Batch-Datei erzeugt, die im Windows-Systemordner "Autostart" abgelegt werden kann, um so bei jedem Starten des PCs automatisch aufgerufen zu werden. Das Autostart-Fenster ist in die Bereiche Modus, Fenstereinstellungen und Benutzer unterteilt.

Ablauf

  1. Im Modul Vision Sensor Device Manager die Autostart-Datei öffnen mit dem Pfad: Vision Sensor Device Manager/Datei/Autostart-Datei
  2. Im Bereich "Modus" wird festgelegt, welches Modul der SBS Software automatisch gestartet werden soll.
  3. In den Fenstereinstellungen ist die Ansicht des Moduls zu wählen: Normal oder Vollbild ohne Titelleiste im Panel-PC Modus.
  4. Im Bereich "Benutzer" wird der Benutzer für die Autostart-Datei festgelegt. Rechte der Benutzerrollen finden Sie unter Benutzerverwaltung / Passworte (Datei)
  5. Den Button „Speichern“ wählen und die Batch-Datei (.bat) am gewünschten Ziel speichern. Für den automatischen Start beim Hochfahren des PCs muss die Datei im Windows-Systemordner "Startup" abgelegt werden.
  6. Die SBS Software schließen.
  7. Die Batch-Datei ausführen. Die SBS Software wird entsprechend der vorgenommen Einstellungen gestartet.

Abbildung: Autostart-Datei

Folgende Parameter können im Autostart-Fenster eingestellt werden:

Modus
Parameter | Funktion
Vision Sensor Device Manager | Module der SBS Software, die in der Autostart-Datei automatisch geöffnet werden sollen. Für den Start des Simulationsmodus wird die Modellvariante herangezogen, die gerade im Vision Sensor Device Manager ausgewählt, d.h. blau markiert ist.
Vision Sensor Visualisation Studio
Vision Sensor Configuration Studio
Simulation
Favoriten auswählen | Mit diesem Parameter kann der Autostart-Datei eine Favoritengruppe hinzugefügt werden.
Nur Favoriten anzeigen | Ist der Parameter „Favoritenliste auswählen“ gewählt, so wird die Liste "Aktive Sensoren" geleert und anschließend nur mit den ausgewählten Favoriten befüllt.

Fenstereinstellungen
Parameter | Funktion
Normal | Das ausgewählte SBS Software Modul wird in der Autostart-Datei normal geöffnet mit Titelleiste.
Panel-PC Modus (Vollbild ohne Titelleiste) | Das ausgewählte SBS Software Modul wird in der Autostart-Datei im Vollbild ohne Titelleiste geöffnet. Typische Anwendung bei Touchscreen Panel-PCs.

Benutzer
Parameter | Funktion
Administrator | Die Wahl des Benutzers ist abhängig von den Rechten, über die der Benutzer innerhalb der Autostart-Datei verfügen soll. Rechte der Benutzerrollen finden Sie unter Benutzerverwaltung / Passworte (Datei)
Benutzer
Werker


SBS – Bedien- und Konfigurationssoftware – Vision Sensor Configuration Studio, alle Funktionen

SBS – Bedien- und Konfigurationssoftware –
Vision Sensor Configuration Studio, alle Funktionen

Mit diesem Programm können Sie Ihren SBS Vision-Sensor in sechs Bedienschritten für eine oder mehrere Prüfaufgaben (Jobs) konfigurieren:

  • Bedienschritt Job (Prüfaufgaben)
  • Bedienschritt Lagenachführung
  • Bedienschritt Detektoren
  • Bedienschritt Ausgabe
  • Bedienschritt Ergebnis
  • Bedienschritt Sensor starten

Weitere Programmfunktionen:

  • Trigger / Bildaktualisierung
  • Verbindungsmodus
  • Simulationsbetrieb: Simulation von Jobs (Offline-Modus) anhand von Bilderserien (Filmstreifen)
  • Filmstreifen (Datei) zu Analyse- oder Simulationszwecken.
    Die Ausführung von Vision Sensor Configuration Studio erfordert u.U. die Eingabe eines Passworts (Benutzergruppe: Administrator). Siehe hierzu: Benutzerverwaltung / Passworte (Datei)
  • Bildrekorder

Um auch ohne Trigger ein stetig aktualisiertes Livebild zu erhalten folgende Einstellungen vornehmen:

  • Freilauf einstellen unter "Job/Bildaufnahme"
  • Kontinuierlich einstellen unter "Trigger / Bildaktualisierung" Programmoberfläche und Bedienung


Bedienschritt Job (Prüfaufgaben)

Ein Job enthält sämtliche Einstellungen und Parameter, die zur Durchführung einer bestimmten Prüfaufgabe erforderlich sind.

Nächstes Thema: Erstellen, Bearbeiten und Verwalten von Jobs

Abbildung: Vision Sensor Configuration Studio Job


Erstellen, Bearbeiten und Verwalten von Jobs

Nächstes Thema: Öffnen und Speichern von Job oder Jobsatz (Datei)

Einen ausgewählten (in der Liste links unten markierten) Job können Sie durch Eingabe von Parametern in den Reitern des Konfigurationsfensters (rechts, unten) bearbeiten.

Wenn kein Jobeintrag in der Liste vorhanden ist, müssen Sie zuerst einen neuen Job erstellen.

Neuen Job erstellen:

  1. Klicken Sie auf den Button "Neu" unter der Job-Auswahlliste links unten. Ein neuer Jobeintrag erscheint in der Liste.
  2. Editieren Sie den Eintrag durch Doppelklick auf das jeweilige Feld (Name, Beschreibung, Autor)

Weitere Funktionen:

Funktion | Beschreibung
Neu | Neuen Job definieren
Öffnen | Einen Job vom PC laden
Speichern | Den ausgewählten Job auf dem PC speichern
Löschen | Den ausgewählten Job aus der Liste löschen
Alle löschen | Alle Jobs in der Liste löschen
Schützen | Schützt den Job / Jobsatz mit einem Passwort

Alle beschriebenen Funktionen können Sie auch über das Datei-Menü ausführen.

Abbildung: Vision Sensor Configuration Studio Jobliste

Wenn die Kapazität des Sensorspeichers erschöpft ist und keine weiteren Jobs auf den Sensor geladen werden können, wechselt die Farbe der Restspeicheranzeige in der Statuszeile (unten) auf Rot.

Weitere Informationen:

Öffnen und Speichern von Job oder Jobsatz (Datei)

Jobsatz schützen ... (Datei)


Reiter Bildaufnahme

Nächste Themen: Reiter Vorverarbeitung

Im Reiter Bildaufnahme bestimmen Sie die grundlegenden Parameter der Bildaufnahme.

Die Bildschärfe wird mit der Fokus- Einstellschraube an der Geräterückseite des SBS Vision-Sensors eingestellt.

Parameter | Funktion und Einstellmöglichkeiten
Auflösung | Verfügbare Auflösungen: R3B: WVGA (736x480), VGA (640x480), QVGA (320x240), QQVGA (160x120) R3C: WVGA (736x480), VGA (640x480), QVGA (320x240) R2B: SXGA (1280x1024), VGA (640x480), QVGA (320x240) R2C: SXGA (1280x1024), VGA (640x480) Bei zeitkritischen Anwendungen oder aus Kompatibilitätsgründen kann eine geringere Auflösung gewählt werden. Bei Änderung der Auflösung werden alle bereits definierten Detektoren gelöscht!
Zoom (nur R2B) | Über die Auswahl verschiedener Zoom-Stufen können unterschiedliche Bildausschnitte mit unterschiedlichen Abbildungsgrößen erzielt werden.
Dynamik | Optimierung der Charakteristik der Bildaufnahme: "Linear" bedeutet lineare Kennlinie (verhalten wie bei SBS-Produkten, die keine dynamische Bildaufnahme unterstützen), "Hoch" bedeutet bessere Feinabstufung in hellen Bereichen des Bildes (Übersteuerung).
Triggermodus | Auswahlmöglichkeit, ob der SBS im getriggerten Modus oder im Freilauf betrieben werden soll. Im getriggerten Modus kann über den Triggereingang Pin 03 WH oder über eine der Schnittstellen eine Bildaufnahme ausgelöst werden. Im Freilauf macht der SBS kontinuierlich Bilder und Auswertungen.
Verschlusszeit | Parameter zur Steuerung der Bildhelligkeit. Die Bildhelligkeit sollte vorzugsweise mit der Verschlusszeit eingestellt werden. Erst im zweiten Schritt, wenn nötig, die Verstärkung einstellen (Grundeinstellung Verstärkung = 1). Bei bewegten Prüfobjekten kann eine längere Verschlusszeit zu Bewegungsunschärfe im Bild führen. Mit dem Button „Auto“ kann die Belichtung automatisch eingestellt werden. Die maximal am Schieberegler einstellbare Verschlusszeit ist auf 100 ms eingestellt. Jedoch ist zu beachten, dass die Dauer des internen Belichtungspulses auf 8 ms begrenzt ist. Verschlusszeiten länger als 8 ms machen also nur Sinn, wenn externe Beleuchtung oder interne + externe Beleuchtung verwendet werden.
Verstärkung | Parameter zur Steuerung der Bildhelligkeit. Die Bildhelligkeit sollte vorzugsweise mit der Verschlusszeit eingestellt werden, erst im zweiten Schritt wenn nötig die Verstärkung einstellen (Grundeinstellung Verstärkung = 1)
Quadranten Beleuchtung | Durch Klicken auf die Darstellung der LED können einzelne Quadranten der Beleuchtung abgeschaltet werden. Diese Funktion kann bei geringen Arbeitsabständen Reflexionen unterdrücken.
Interne Beleuchtung | Auswahl für interne Beleuchtung (Ein / Aus)
Externe Beleuchtung | Auswahl für externe Beleuchtung (Ein / Aus / Permanent) Die externe Beleuchtung wird über Pin 09 RD geschaltet.

Um auch ohne Trigger ein stetig aktualisiertes Livebild zu erhalten, folgende Einstellungen (ggf. temporär) vornehmen:

Freilauf einstellen unter "Job/Bildaufnahme"

Kontinuierlich einstellen unter "Trigger/Bildaktualisierung" (links, halbe Höhe)


Reiter Weißabgleich

Der Weißabgleich dient der Kompensation eines eventuellen Farbstiches im Bild durch Lichtverhältnisse oder Kamerachip.

Abbildung: Weißabgleich

Parameter | Funktion
Rot | Mittelwert des Rot-Kanals im Bild
Grün | Mittelwert des Grün-Kanals im Bild
Blau | Mittelwert des Blau-Kanals im Bild
Einlernen | Durchführung des Weißabgleichs, für den Weißabgleich ist eine homogene, weiße oder leicht graue Fläche unter der Kamera zu positionieren
Rücksetzen | Werte zurücksetzen


Reiter Vorverarbeitung

Im Reiter Filter können Sie die vom Sensor aufgenommenen Bilder vor der Auswertung filtern oder neu anordnen.

  • Es können bis zu 5 Filter aktiviert werden, die in der angegebenen Reihenfolge ausgeführt werden.
  • Alle Detektoren (Lagenachführung und Standard-Detektoren) werden auf dem vorverarbeiteten Bild arbeiten, nicht auf dem Originalbild.
  • Insbesondere mit den morphologischen Operatoren (Dilatation und Erosion) können auch in Kombination Verbesserungen des Bildes erreicht werden, z.B. durch Nacheinanderausführung von Erosion und Dilatation oder umgekehrt.

Nächstes Thema: Reiter Kalibrierung

Beispiel: Schwarze, punktförmige Störungen vor hellem Hintergrund lassen sich eliminieren, wenn Dilatation und Erosion aufeinander folgen.

Folgende Anordnungsfilter stehen zur Verfügung:

Anordnung Typ | Effekt
Rotation 180° | Rotation des Bildes um 180°
Spiegelung horizontal | Horizontale Spiegelung des Bildes
Spiegelung vertikal | Vertikale Spiegelung des Bildes

Folgende Filter für die Bildverbesserung stehen zur Verfügung:

Filtertyp | Effekt

Gauss

Das Bild wird mit einem Gauss-Filter geglättet. Dies kann zur Reduktion von Rauschen, Unterdrückung störender Details und Artefakte und Glättung von Kanten angewendet werden..

Erosion

Ausweitung dunkler Bereiche, Eliminierung heller Pixel in dunklen Bereichen, Elimination von Artekfakten, Trennung von hellen Objekten. Wirkung: Jeder Grauwert wird durch den minimalen Grauwert innerhalb der Filtermaske (z.B. 3x3 Filtermaske) ersetzt.

Dilation

Ausweitung heller Bereiche, Eliminierung dunkler Pixel in hellen Bereichen, Elimination von Artekfakten, Trennung von dunklen Objekten. Wirkung: Jeder Grauwert wird durch den maximalen Grauwert innerhalb der Filtermaske (z.B. 3x3 Filtermaske) ersetzt.

Median

Jeder Grauwert wird ersetzt durch den Median- Wert der Pixel, die in der Filtermaske gefunden werden (z.B. 3x3). Typische Anwendung: Glättung des Bildes, Unterdrückung von Bildrauschen, speziell von lokalen hellen oder dunklen Bereichen/Pixeln (Salz- und Pfeffer- Rauschen)

Mittelwert

Jeder Grauwert wird ersetzt durch den Mittelwert der Pixel, die in der Filtermaske gefunden werden (z.B. 3x3). Typische Anwendung: Glättung des Bildes, Unterdrückung von Störungen und Bildrauschen.

Amplitude

Jeder Grauwert wird ersetzt durch den Bereichs- Wert (Maximaler Grauwert - Minimaler Grauwert) der Pixel, die in der Filtermaske gefunden werden (z.B. 3x3).
Typische Anwendungen: Detektion und Verbesserung von Kanten und Verbesserung von lokalem Bildkontrast.
Standardabweichung

Jeder Grauwert wird ersetzt durch die Standardabweichung der Pixel, die in der Filtermaske gefunden werden (z.B. 3x3).
Typische Anwendungen: Hervorheben von Oberflächendefekten oder Kanten.

Kantenfilter (Sobel)

Das gefilterte Bild enthält Kanten, die durch die Anwendung des Sobel- Algorithmus gefunden wurden (vergleiche auch Literatur zur Bildverarbeitung).

Typische Anwendungen: Detektion und Verbesserung von Kanten, Verbesserung von lokalem Kontrast und Erkennung von Oberflächendefekten.

Multiplikation | Der Grauwert jedes Bildpixels wird multipliziert mit dem ausgewählten Multiplikator (2x, 4x, 8x, ...). Der Wertebereich ist begrenzt auf 255.
Invertierung | Invertierung der Bildpixel / Grauwerte

Die Wirkung eines aktivierten Filters ist unmittelbar im Bild erkennbar. Je größer der Filterkern gewählt wird, umso stärker ist die Filterwirkung. Die Reihenfolge der Anwendung der Filter ist mit der Reihenfolge von oben nach unten identisch.

Filter konfigurieren:

  1. Wählen Sie die Filter in der gewünschten Reihenfolge über die Ausklappmenüs in der Spalte Filter.
  2. Geben Sie die Größe des Filterkerns in den Ausklappmenüs in der Spalte Wert ein. Bei Einstellung „Aus“ wird der betreffende Filter deaktiviert.

Abbildung: Reiter Vorverarbeitung


Reiter Kalibrierung

Die Kalibrierung dient zur Umrechnung von Bild-Koordinaten (Pixel) in Welt-Koordinaten (z.B. Millimeter). Bei Nutzung dieser Funktion, werden alle Koordinatenausgaben (Positionen und Messergebnisse) in der gewählten Einheit berechnet und ausgegeben.

Kalibriermethode auswählen

Die Kalibriermethoden werden nach zwei Anwendungsgebieten unterschieden: "Messen" und "Roboter".

Abbildung: Kalibriermethode auswählen

Parameter Funktion
Kalibriermethode

Auswahl einer Kalibriermethode:

  • Keine: Kalibrierung nicht aktiv, Koordinatenermittlung, -anzeige und -ausgabe in Pixel (px)
  • Messen: Kalibriermethoden für Applikationen im Bereich Messen und Prüfen
  • Roboter: Kalibriermethoden für Applikationen im Bereich Robotik
Einheit

Gewünschte Einheit für Weltkoordinaten. Zur Auswahl stehen die Einheiten:

  • mm (Millimeter)
  • cm (Zentimeter)
  • m (Meter)
  • in (Inch / Zoll)
"˃" / "˂" Zum nächsten, letzten Eingabeschritt wechseln

Kalibriermethoden Messen

Kalibriermethode Funktion

Skalierung (Messen)

  • Relative Vermessung von z.B. Abständen in Weltkoordinaten
  • Limitierte Genauigkeit

Die Kalibriermethode "Skalierung" dient zur relativen Bestimmung von z.B. Abständen in Weltkoordinaten (z.B. mm). Dies geschieht hier über einen einfachem Verhältnisfaktor. Es wird ein Faktor für beide Koordinatenachsen X und Y bestimmt. Das hat den Vorteil der sehr einfachen Anwendung, die Genauigkeit ist dabei limitiert.

Verzerrungen durch schrägen Blickwinkel und durch Linsenverzeichnung werden bei dieser Methode nicht korrigiert.

Weltkoordinaten sind nicht absolut, Koordinatenwerte beziehen sich auf Nullpunkt in der linken, oberen Ecke des Sichtfeldes.

Beispiel: Ermittlung des Abstands zwischen zwei Objekten in Millimeter (limitierte Genauigkeit).

Weitere Informationen: Kalibriermethode Skalierung (Messen)

Kalibrierplatte (Messen)

  • Relative Vermessung von z.B. Abständen in Weltkoordinaten
  • Hohe Genauigkeit

Die Kalibriermethode "Kalibrierplatte (Messen)" dient zur relativen Bestimmung von z.B. Abständen in Weltkoordinaten (z.B. mm). Dies geschieht über die Bildaufnahme einer Kalibrierplatte. Durch die hohe Punktanzahl und die bekannte genaue, relative Lage der Punkte auf der Platte zueinander, liefert diese Methode eine hohe Genauigkeit.

Dabei werden die Skalierung in x und y getrennt, die Verkippung des Sensors gegenüber der Sichtfeldebene, und die Linsenverzeichnung korrigiert.

Die Weltkoordinaten sind nicht absolut. Die Koordinatenwerte beziehen sich auf den Nullpunkt in der linken, oberen Ecke des Sichtfeldes.

Neben Koordinaten werden auch Distanzen umgerechnet.

Beispiel: Ermittlung des Abstands zwischen zwei Objekten in mm. (hohe Genauigkeit)

Weitere Informationen: Kalibriermethode Kalibrierplatte (Messen)

Kalibriermethoden Roboter

Kalibriermethode Funktion

Punktpaarliste (Roboter)

Absolute Vermessung in Weltkoordinaten, in beliebigem Bezugssystem z.B. Roboterkoordinatensystem

Die Kalibriermethode "Punktpaarliste" dient zur Bestimmung absoluter Positionen in Weltkoordinaten (z.B. mm). Dabei werden die Skalierung in x und y getrennt, die Verkippung des Sensors gegenüber der Sichtfeldebene, und die Linsenverzeichnung korrigiert.

Beispiel: Absolute Position von Objekten in Weltkoordinaten (z.B. Roboterkoordinatensystem), in Millimeter ermitteln.

Dies geschieht hier über die Bildaufnahme eines zuvor, z.B. von einem Roboter, im Sichtfeld platzierten Kalibrierteiles.

Dabei wird je Punktepaar die

- Bildkoordinate durch grafische Eingabe im Bild oder numerische Eingabe ermittelt, und die

- Weltkoordinate von z.B. der Robotersteuerung übertragen und numerisch eingegeben.

Dieser Ablauf wird so oft durchgeführt bis die gewünschte Anzahl an Punktepaaren in der Liste eingetragen ist.

Weitere Informationen: Kalibriermethode Punktpaarliste (Roboter)

Hinweis:

Es werden alle Ergebniswerte für Positionen und Messergebnisse korrigiert. Um die Zykluszeit nicht zu belasten, d.h. zu verlängern, werden die Bilddaten jedoch nicht umgerechnet bzw. entzerrt dargestellt! So ist, auch mit aktiver Kalibrierung, eine hohe Ausführungsgeschwindigkeit gewährleistet.

Die Aktivierung der Kalibrierung erfolgt in zwei Schritten:

  1. Auswahl der Kalibriermethode
    Wechsel mit den Tasten [˂], [˃] zum nächsten / letzten Schritt
  2. Durchführung der gewählten Kalibriermethode
    Sobald eine Kalibriermethode ausgewählt ist wird links neben dem Reitertitel "Kalibrierung" die Status-LED angezeigt. Ist die Kalibrierung aktiv, so werden alle Funktionen, z.B. Detektoren, nur dann korrekt ausgeführt wenn die Kalibrierung gültig ist, d.h erfolgreich ausgeführt werden konnte.

Bedeutung der Status LED Farben:

Farbe | Status LED: | Punkten in Bild und in Punktpaarliste:
Grün | Kalibrierung gültig | Punkte exakt positioniert
Gelb | Kalibrierung gültig | Punkte nicht exakt positioniert
Rot | Keine gültige Kalibrierung | /

Hinweis:

  • Bei der Skalierung ist nur Grün möglich: Default- oder Eingabewerte ergeben den Skalierfaktor. Es ist keine Fehlerberechnung möglich.
  • Punktpaarliste (Roboter): Bei einem neuen Job erscheint grün. Defaultwerte (9 Punkte) ergeben eine korrekte Defaultkalibrierung.
  • Kalibrierplatte (Messen): Bei einem neuen Job erscheint rot, da noch keine Kalibrierung mit Kalibrierplatte erfolgt.

Die Kalibrierung wirkt auf folgende Detektoren und Lagenachführungen

Detektor | Ergebniswert
Kontur | Zentrumskoordinaten x, y, Winkel
Mustervergleich | Zentrumskoordinaten x, y, Winkel
Messschieber | Zentrumskoordinaten x, y, Abstand
BLOB | Schwerpunkt-/ Zentrumskoordinaten x, y; Breite, Höhe, Winkel

Lagenachführung | Ergebniswert
Kontur | Zentrumskoordinaten x, y, Winkel
Mustervergleich | Zentrumskoordinaten x, y, Winkel
Kantenantastung | Zentrumskoordinaten x, y

Nächste Themen:

Kalibrierung Messen

Kalibrierung Roboter


Kalibrierung Messen

Kalibriermethode Skalierung (Messen)

Kalibriermethode Kalibrierplatte (Messen)


Kalibriermethode Skalierung (Messen)

Die Kalibriermethode "Skalierung (Messen)" dient zur relativen Bestimmung, von z.B. Abständen in Weltkoordinaten (z.B. mm). Dies geschieht hier über einen einfachen Verhältnisfaktor für beide Koordinatenachsen X und Y. Die Methode ist sehr einfach anwendbar, die Genauigkeit ist jedoch limitiert, da keine Korrektur von Verzerrungen und Verzeichnung vorgenommen wird.

Abbildung: Kalibriermethode Skalierung (Messen)

Beispiel: Ermittlung des Abstandes zwischen zwei Objekten in Millimeter.

Parameter Skalierung

Parameter | Funktion
Distanz Bild | Distanz im Bild in Pixel (px), durch grafische Eingabe bzw Werteeingabe.
Distanz Welt | Entsprechende Distanz in Welt, durch Werteeingabe (in zuvor festgelegter Einheit z.B. mm)
Skalierfaktor | Aus oben genannten Einstellungen "Distanz Bild" und "Distanz Welt" resultierende Skalierfaktoren z.B. [x] px/mm bzw. [y] mm/px
Punkt testen | Es kann ein Testpunkt (grafisch oder Werteeingabe) im Bild gesetzt werden, dessen Koordinaten in Weltkoordinaten zur Kontrolle der Skalierung im Testpunktfenster angezeigt werden, Koordinatenursprung: linke, obere Ecke des Sichtfeldes.
"˃" / "˂" | Zum nächsten / vorherigen Eingabeschritt wechseln

Hinweis:

  • Es ist darauf zu achten, dass der Sensor möglichst senkrecht auf die Sichtfeldebene ausgerichtet ist. Dies vermeidet zu stark unterschiedliche Verzerrungen in den beiden Achsen X und Y. Verzerrung durch schrägen Blickwinkel und durch Linsenverzeichnung werden bei dieser Methode nicht korrigiert.
  • Zur Parametrierung ein Objekt mit bekannter Ausdehnung (z.B. Endmaß) im Bild platzieren.
    Die beiden grafischen (grünen) Fadenkreuze im Bild auf die Punkte mit der genau bekannten Distanz positionieren. Der Abstand in Bildpixel zwischen den beiden Mittelpunkten wird im Feld "Distanz Bild" angezeigt.
    Nun den bekannten Welt-Abstand im Feld "Distanz Welt" eintragen (z.B. in mm).
    Der Skalierfaktor wird nun berechnet und angezeigt. Ab sofort werden nun Positionen und Abstände in Weltkoordinaten angezeigt und ausgegeben.
  • Die Größe eines Fadenkreuzes im Sichtfeld kann beliebig angepasst werden. Hierzu muss die gewünschte Referenzmarke per Mausklick ausgewählt und anschließend die Größe mit dem Scrollrad der Maus vergrößert oder verkleinert werden.
  • Weltkoordinaten sind nicht absolut. Die Koordinatenwerte beziehen sich auf den Nullpunkt in der linken, oberen Ecke des Sichtfeldes. Neben Koordinaten werden auch Distanzen umgerechnet.
  • Diese Art der Kalibrierung ist für Standardobjektive, integriert oder C-Mount, geeignet. D.h. nicht für telezentrische Objektive!

Nächstes Thema:

Kalibriermethode Kalibrierplatte (Messen)


Kalibriermethode Kalibrierplatte (Messen)

Die Kalibriermethode "Kalibrierplatte" dient zur relativen Bestimmung von z.B. Abständen in Weltkoordinaten (z.B. mm). Dies geschieht über die Bildaufnahme einer Kalibrierplatte mit einem einzigen Klick.

Abbildung: Kalibriermethode Kalibrierplatte (Messen)

Beispiel: Ermittlung des Abstands zwischen zwei Objekten in mm (hohe Genauigkeit).

Ablauf Kalibrierung mittels Kalibrierplatte

Vorab müssen Bildschärfe und Helligkeit eingestellt sein, und die gewünschte Einheit muss ausgewählt worden sein.

  1. Über den Button "Kalibrierparameter" den Z-Versatz einstellen.
  2. Kalibrierplatte möglichst formatfüllend im Sichtfeld platzieren (siehe dazu auch "Hinweise zur optimierten Nutzung der Kalibrierplatte / Randbedingungen" Kalibriermethode Kalibrierplatte (Messen) und "Typen / Größen von Kalibrierplatten" Kalibriermethode Kalibrierplatte (Messen)).
  3. In der Auswahlbox "Kalibrierplatte" die o.g., entsprechende Kalibrierplatte (Größe und Typ) auswählen.
  4. Mit Klick auf den Button "Starte Kalibrierung" werden alle sichtbaren Punkte der Kalibrierplatte bestimmt, alle erkannten markiert, und die Kalibrierung berechnet.

Parameter Kalibrierplatte (Messen)

Parameter | Funktion
Kalibrierplatte | Hier wird die verwendete Kalibrierplatte (Größe/ Typ) ausgewählt (siehe dazu auch "Hinweise zur optimierten Nutzung der Kalibrierplatte / Randbedingungen" und "Kalibriermethode Kalibrierplatte (Messen)".)
Kalibrierparameter | Hier wird der z- Offset zwischen Kalibrier- und Messebene eingegeben. Und verschiedene Ausgabeparameter sowie Fehler- / Optimierungskenngrößen angezeigt (siehe auch: Kalibrierung, Kalibrierparameter)
Starte Kalibrierung | Kalibriervorgang wird ausgelöst. Alle sichtbaren Punkte der Kalibrierplatte werden bestimmt, alle erkannten markiert und die Kalibrierung berechnet.
Punkt testen | Es kann ein Testpunkt im Bild gesetzt werden dessen Koordinaten in Weltkoordinaten zur Kontrolle / Plausibilitätstest der Kalibrierung der Skalierung im Testpunkt- Fenster angezeigt werden.
> / < | Zum nächsten / vorherigen Eingabeschritt wechseln

Hinweis:

  • Der Sensor kann in beliebiger Ausrichtung (Pose) in Bezug auf die Messebene montiert werden (wobei eine möglichst senkrechte Ausrichtung zur Messebene weniger Korrektur erfordert und damit vorteilhaft ist). Es werden die Skalierung, in X und Y, die Verkippung des Sensors gegenüber der Sichtfeldebene, und die Linsenverzeichnung (je nach gewähltem Kalibriermethode) korrigiert.
  • Die Weltkoordinaten sind nicht absolut. Die Koordinatenwerte beziehen sich auf den Nullpunkt, in linker oberer Ecke des Sichtfeldes. Neben Koordinaten werden auch Distanzen umgerechnet.
  • Diese Art der Kalibrierung ist für Standardobjektive, integriert oder C-Mount, geeignet. D.h. nicht für telezentrische Objektive!
  • Normierung: Unabhängig von Position und Ausrichtung, in der die Kalibrierplatte erfasst wird, liegt bei dieser Kalibriermethode der Koordinatenursprung immer in der linken oberen Ecke des Sichtfeldes (Bild und Welt). Die Null-Grad-Richtung und die positive X- Achse zeigen nach Ost.

Hinweise zur optimierten Nutzung der Kalibrierplatte / Randbedingungen finden Sie unter: Hinweise zur optimierten Nutzung der Kalibrierplatte / Randbedingungen

Weitere Informationen:

Closed Typen / Größen von Kalibrierplatten

Kalibrierplattenmuster | Punkteanzahl
50 mm x 37,9 mm | 15 x 13
100 mm x 75,8 mm | 15 x 13
200 mm x 151,7 mm | 15 x 13

Im Installationsverzeichnis: Festo/SBS Vision-Sensor/Dokumentation/... sind die verfügbaren Kalibrierplatten als .pdf-Datei zu finden. Diese können auf Papier oder auf ein anderes Medium gedruckt / flach aufgebracht werden. Beim Ausdruck die Einstellung "Tatsächliche Größe" verwenden, und darauf achten, dass der Druck nicht skaliert wird. Die Kantenlänge / Beschriftung der Platte muss dem Namen der Platte bei der Auswahl in der Software entsprechen.

Nächste Themen:

Kalibrierung, Kalibrierparameter

Hinweise zur optimierten Nutzung der Kalibrierplatte / Randbedingungen

Kalibrierung Roboter


Kalibrierung Roboter

Kalibriermethode Kalibrierplatte (Roboter)

Kalibriermethode Punktpaarliste (Roboter)

Kalibrierung mit Telegrammen


Kalibriermethode Punktpaarliste (Roboter)

Die Kalibriermethode "Punktpaarliste (Roboter)" dient zur Bestimmung absoluter Positionen in Weltkoordinaten (z.B. mm).

Abbildung: Kalibriermethode Punktpaarliste (Roboter)

Beispiel: Absolute Position (und Orientierung) von Objekten in Weltkoordinaten (z.B. Roboterkoordinatensystem) ermitteln.

Motivation / Nutzen

Nach der Kalibrierung des Sensors via Punktpaarliste liegt die Position des vom Roboter zu greifenden Teiles direkt im absoluten Koordinatensystem des Roboters vor!
Dabei wurden sämtliche Fehler wie Verzerrung und Verzeichnung korrigiert. In Pick and Place Anwendungen kann der Roboter nun mit den vom Sensor gelieferten Positionsdaten direkt in seinem Koordinatensystem verfahren und das Teil greifen!

Abbildung: Position des zu greifenden Teiles direkt im Roboterkoordinatensystem!

Ablauf zur Kalibrierung mit der Punktpaarliste

Vorab müssen Bildschärfe und Helligkeit eingestellt, und die gewünschte Einheit muss ausgewählt worden sein.

  1. Kalibriermodell (-mit/ohne Korrektur der Linsenverzeichnung) auswählen, und ggf. Z-Versatz einstellen.
  2. Zeile 1 in Listbox "Punktpaarliste" auswählen.
  3. Kalibrierteil (vorzugsweise flach, symmetrisch, z.B. ähnlich Unterlegscheibe) an genau bekannter Weltkoordinate im Sichtfeld platzieren (z.B. mit Roboter).
  4. Fadenkreuz (Nr. "n" zu entsprechender Zeile "n" in Punktpaarliste) exakt im Zentrum des Kalibrierobjektes grafisch positionieren. Dazu das Bild ggf. zoomen.
    Alternativ: Per "Snap- Funktion", d.h. Rechtsklick irgendwo innerhalb des Kalibrierobjektes. Dabei wird der Schwerpunkt des Kalibrierobjekts automatisch bestimmt.
    Die Größe des Fadenkreuzes kann über das Scrollrad der Maus bestimmt werden.
    Vorzugsweise punktsymmetrische Kalibrierobjekte verwenden, da dann der Schwerpunkt unabhängig ist von der Orientierung. Bzw. bei nicht punktsymmetrischen Kalibrierobjekten auf immer gleiche Orientierung bei der Positionierung achten (nicht verfügbar bei Farbsensoren).
    Ergebnis: Pixelwerte für Bildkoordinaten "Bild X" und "Bild Y" sind automatisch in Zeile "n" eingetragen.
  5. Nun im Feld "Welt X" und "Welt Y" die entsprechenden, bekannten Weltkoordinatenwerte (bei z.B. Roboter: die Werte von der Robotersteuerung) eintragen.
  6. Schritte 2-5 so lange wiederholen, bis die gewünschte Anzahl an Punktepaaren eingegeben wurde. Ggf. mit "+" weitere Zeilen anlegen bzw. mit "-" löschen. (mind, 6 Punkte, empfohlen >10 Punkte)

Automatisierter Ablauf via Schnittstellen Kommandos: Automatisierte Kalibrierung: Punktpaarliste (Roboter)

Parameter Punktpaarliste

Parameter | Funktion

- Bild X

- Bild Y

Werte in Punktliste

Koordinatenwerte in Pixel (px) im Bild, über die exakte grafische Positionierung des Fadenkreuzes auf den Mittelpunkt des in Weltkoordinaten genau platzierten Kalibrierteils.

Oder, per "Snap- Funktion": rechter Mausklick irgendwo innerhalb des symmetrischen Kalibrierobjekts. Sokann die genaue Position der Mitte automatisch bestimmt werden (empfohlen).

Hinweis:

Die Snap- Funktion ist nicht verfügbar bei Farbsensoren R3C und R2C.

- Welt X

- Welt Y

Werte in Punktliste

Koordinatenwerte in Welt in gewählter Einheit (z.B. mm), durch direkte Wert- Eingabe in Punkteliste.

Diese Werte sind im Falle von z.B. Pick & Place / Roboter die X- / Y- Koordinatenwerte, die von der Robotersteuerung bei Ablage des Kalibrierteiles /Anfahren des entsprechenden Punktes, abgelesen und in die Punkteliste übertragen werden können.

Kalibrierparameter

Kalibriermodell:
Mit oder ohne Korrektur der Linsenverzeichnung.

Z- Offset: (falls Offset gegeben)

Offset zwischen Kalibrier- und Messebene eingeben

Verschiedene Ausgabeparameter

der Ausgleichsrechnung sowie Fehlerkenngrößen. S. Kapitel: Kalibrierung, Kalibrierparameter
"+" / "-" Eine Zeile / Listenpunkt hinzufügen oder löschen. Das Löschen wirkt sich auf die jeweils markierte Zeile aus.
Punkt testen | Es kann ein Testpunkt im Bild gesetzt werden, dessen Koordinaten in Weltkoordinaten zur Kontrolle / Plausibilitätstest der Kalibrierung im Testpunkt- Fenster angezeigt werden.
"˃" / "˂" Zum nächsten / vorherigen Eingabeschritt wechseln

Hinweis:

  • Der Sensor kann in beliebiger Ausrichtung (Pose) in Bezug auf die Messebene montiert werden. Eine möglichst senkrechte Ausrichtung zur Messebene erfordert allerdings weniger Korrektur und ist damit grundsätzlich vorteilhafter ist.
  • Die Genauigkeit hängt vor allem von der hohen Güte und zweitens von der ausreichenden Anzahl der Kalibrierpunkte ab. Die Genauigkeit kann durch eine hohe Güte (hohe Präzision bei der Positionseingabe) der einzelnen Punkte optimiert werden, wenn z.B. einige Punkte in gelber Farbe dargestellt werden.
  • Diese Art der Kalibrierung ist für Standardobjektive, integriert oder C-Mount, geeignet. D.h. nicht für telezentrische Objektive!
  • Die Größe eines Fadenkreuzes im Sichtfeld kann beliebig angepasst werden. Hierzu muss die gewünschte Referenzmarke per Mausklick ausgewählt und anschließend die Größe mit dem Scrollrad der Maus vergrößert oder verkleinert werden.

Minimalanforderung an die Anzahl der Punktpaare ist "6" Punkte.

Die minimal benötigte Punkteanzahl bei der Kalibrierung via Punktpaarliste ist 6 Punkte! Ab dieser Punkteanzahl können Fehleingaben (etwa x und y vertauscht etc.) durch hohe Fehlerwerte im Dialog "Kalibrierparameter" Kalibrierung, Kalibrierparameter aufgedeckt werden (ab <= 5 Punkte sind die Fehlerwerte immer = 0, da keine Fehlerrechnung möglich).

Die eingegebenen Punkte werden zur Anzeige der Positions-Güte d.h. wie gut diese mit der per Ausgleichsrechnung ermittelten Position übereinstimmen, in folgenden Farben dargestellt (erst ab Mindestanzahl "6" Punkten sinnvoll nutzbar).

Bedeutung der Farben der Punkten in Bild und in der Punktpaarliste:

Farbe | Bedeutung
Grün | Kalibrierung gültig, Punkte exakt positioniert
Gelb | Kalibrierung gültig, Punkte nicht exakt positioniert
Rot | Keine gültige Kalibrierung

Im Falle von gelben Punkten ist eine Linie aus dem Punktzentrum heraus sichtbar. Sie ist ein Maß für Richtung und Betrag des Fehlers in Bezug auf die erzielte Positionsgenauigkeit der Punkteingabe in realer Welt.

Sind die Fehler hier groß, sind ggf. bei ein oder mehreren Punkten die x- und y- Werte, oder ganze Punktepaare in Bild und Welt vertauscht.

Im Dialog "Kalibrierparameter" Kalibrierung, Kalibrierparameter werden die Abweichungswerte / Fehler: "Mittelwert", "Min"imaler Fehler und "Max"imaler Fehler angezeigt. Ggf. mit diesen Werten die exakte Positionseingabe der bestehenden Punkte optimieren.

Diese Methode liefert neben den reinen absoluten Koordinatenwerten auch die Orientierung des zu greifenden Teiles, (sofern ein entsprechender Detektor, z.B. Kontur oder Mustervergleich, verwendet wird).

Die Ergebniskoordinaten z.B. des zu greifenden Teiles liegen direkt im Bezugssystem, z.B. des Roboters vor!

Nächste Themen:

Kalibrierung mit Telegrammen

Kalibrierung, Kalibrierparameter


Hinweise zur optimierten Nutzung der Kalibrierplatte / Randbedingungen

  • Die Kalibrierplatte muss sauber und eben sein.
  • Die Ausleuchtung der Platte sollte im gesamten Sichtfeld homogen und nicht überbelichtet sein. Die hellen Bereiche sollten einen Grauwert von mindestens 100 aufweisen und alle unter dem Wert 255 liegen. Der Kontrast zwischen hellen und dunklen Bereichen sollte mindestens 100 Grauwerte betragen. D.h. das Bild darf weder unter - noch überbelichtet sein.
  • Das Kalibriermuster sollte möglichst das gesamte Sichtfeld des SBS Vision-Sensors abdecken. Dabei muss für eine erfolgreiche, präzise Kalibrierung nicht die gesamte Kalibrierplatte sichtbar sein. Um eine Kalibrierung durchzuführen muss mindestens ein Suchmuster gefunden werden können.
  • Bei kleinen Kalibriermustern kann es erforderlich sein zwei Suchmuster zu verwenden.
  • Nach erfolgter Kalibrierung darf der Fokus und die Position des Sensors zur Messebene nicht mehr verändert werden.

Abbildung: Kalibrierplatte, Blau = Suchmuster

Abbildung: Beispiel Suchmuster, Ausschnitt mit schwarzen Punkten im Zentrum (blaue Bereiche s.o.)

Nächste Themen:

Kalibriermethode Kalibrierplatte (Messen)

Kalibriermethode Kalibrierplatte (Roboter)

Kalibrierung, Kalibrierparameter


Kalibrierung, Kalibrierparameter

Hier werden die Kalibrier-, sowie Abweichungsparameter zur eventuell gewünschten Optimierung angezeigt. Außerdem kann hier ggf. der Z-Versatz der Kalibrier- gegenüber der Messebene eingegeben und somit kompensiert werden.

Beim hier verwendeten Kalibriermodell werden Standardobjektive, integriert oder C-Mount beachtet. Für z.B. telezentrische Objektive ist diese Art der Kalibrierung nicht geeignet!

Abbildung: Kalibrierung, Kalibrierparameter

Parameter | Funktion

Kalibriermodell

Kalibriermodell:

Standardobjektiv, mit Linsenverzeichnung

Korrektur von:

  • Skalierung, X und Y getrennt
  • Verzerrung durch Verkippung des Sensors gegenüber der Sichtfeldebene
  • Korrektur der Linsenverzeichnung
Versatz Kalibrierebene gegenüber Messebene in Z- Richtung *1)

(Z-Versatz)

Für Z=0 sind Kalibrier- und Messebene identisch. Für Z!=0 verschiebt sich die Kalibrier- gegenüber der Messebene. Die Ebenen sind dabei stets parallel. Das Vorzeichen der Verschiebung ergibt sich aus der Z-Richtung des rechtshändigen Kalibrier-Koordinatensystems (Daumen = x, Zeigefinger = y, Mittelfinger = z).

Hinweis:

Der Schärfentiefebereich des Sensor muss dabei die Mess- und die Kalibrierebene abdecken! Versatz der Kalibrierebene zur Messebene in Z-Richtung

Interne Sensor Parameter
Brennweite

Brennweite des Objektivs

  • Bei integriertem Objektiv: Wert wird entsprechend dem intern verbauten Objektiv automatisch eingetragen *2)
  • Bei C-Mount Objektiv: Wert von verwendetem Objektiv ablesen und eintragen. Optional: Zur Plausibilitätskontrolle etwa des Z-Wertes bei "Externe Sensor Parameter", keine Fehlfunktion falls nicht genutzt! *1)
Kappa (x10E-6) *2) | Berechneter Kappawert des Objektives, Anzeige in "Mikro-Kappa"
Pixelabstand *2) | Berechnetes Raster / Achsabstand von Pixel zu Pixel auf dem Sensor. Verringerung der Auflösung im Tab „Bildaufnahme“ wirkt sich auf diesen Parameter aus.
Koordinatenursprung / Pixel *2) | Durchstichpunkt der optischen Achse die durch Messebene im Zentrum des Sensorchips, ggü. idealem Zentrum, in Bezug auf linke, obere Ecke in Pixel.
Bildgröße *2 | Bildgröße in Pixel

Externe Sensor Parameter *2)

X

Y

Z

Alle drei berechneten Werte für die Translation des Mess-Koordinatensystems im Bezug auf das Geräte-Koordinatensystem.

Weitere Informationen: Externe Sensor Parameter

Rot. X

Rot. Y

Rot. Z

Alle drei berechneten Werte für die Rotation des Mess-Koordinatensystems im Bezug auf das Geräte-Koordinatensystems.

Weitere Informationen: Externe Sensor Parameter

Abweichung Kalibrierung *2
Mittelwert | Mittlerer Fehler der berechneten Positionen gegenüber der Eingabe
Min. | Minimaler Fehler der berechneten Positionen gegenüber der Eingabe
Max. | Maximaler Fehler der berechneten Positionen gegenüber der Eingabe

*1) Eingabeparameter *2) Anzeigeparameter (Read-only)

Hinweis:

Bei großen Arbeitsabständen müssen die geschätzten Kalibrierparameter geprüft werden. Dies ist nur relevant bei der Verwendung der Funktion Z-Versatz.

Weitere Informationen:

Koordinatensysteme und Transformationen

Koordinatensysteme | Transformationen
 | Externe Sensor Parameter
 | Die "Externen Sensor Parameter" geben die Lage und Orientierung des Mess-Koordinatensystems im Geräte-Koordinatensystem an.

Versatz der Kalibrierebene zur Messebene in Z-Richtung

Negativer Z-Versatz | Positiver Z-Versatz
Liegt die Messebene (Objekt) über der Kalibrierebene entsteht ein negativer Z-Versatz "-ΔZ". | Liegt die Messebene (Objekt) unter der Kalibrierebene entsteht ein positiver Z-Versatz "+ΔZ".
Abbildung: Negativer Z-Versatz | Abbildung: Positiver Z-Versatz

Nächstes Thema:

Kalibrierung mit Telegrammen


Kalibrierung mit Telegrammen

Für die Kalibrierung stehen verschiedene Schnittstellen-Telegramme zur Verfügung: Übersicht Telegramme:

Die Telegramme dienen z.B. der Re-Kalibrierung bei Prozessdrift oder bei geänderter Montagesituation. Sie können z.B. direkt von der Robotersteuerung aus, automatisiert ausgeführt werden.

Nächstes Thema:

Automatisierte Kalibrierung: Punktpaarliste (Roboter)


Automatisierte Kalibrierung: Punktpaarliste (Roboter)

Abbildung: Automatisierter Ablauf zur Kalibrierung via Punktpaarliste

Nächstes Thema:

Kalibrierung mit Telegrammen

Automatisierte Kalibrierung: Kalibrierplatte (Roboter) Ablauf 1


Reiter Zykluszeit

Im Reiter Zykluszeit wird das Zeitverhalten des SBS Vision-Sensors bestimmt.

Nächstes Thema: Bedienschritt Lagenachführung

Abbildung: Bedienschritt Job, Reiter Zykluszeit

(A) Zykluszeit
Parameter | Funktion
Max Zykluszeit | Parameter zur Steuerung der Ausführungszeit eines Zyklus. Innerhalb eines Zyklus können mehrere Bilder ausgewertet werden (im Falle "Anzahl Bilder" > 1). Die maximale Ausführungszeit dient zum Abbruch eines Zyklus nach einer definierten Zeit. Das Ergebnis des Zyklus ist nach Abbruch immer "nicht o.k.". Die maximale Zykluszeit sollte immer größer gewählt werden als der Zeitbedarf für eine komplette Auswertung. Die Zykluszeit misst die Zeit vom Trigger bis zum Setzen der digitalen Schaltausgänge. Soll die Zykluszeit begrenzt werden, z.B. weil der Maschinentakt nicht überschritten werden darf, muss der Wert für die maximale Zykluszeit entsprechend begrenzt werden. Das Ergebnis aller bis zu diesem Zeitpunkt nicht fertig ausgeführten Detektoren wird auf fehlerhaft gesetzt. Bei der Wahl der maximalen Zykluszeit ist zu berücksichtigen, dass diese nicht hart eingehalten wird, sondern in Abhängigkeit des gerade ausgeführten Detektors etliche weitere Millisekunden bis zum Abbruch verstreichen können. Es wird empfohlen, diese Überschreitung der maximalen Zykluszeit anhand der tatsächlichen Ausführungszeit zu überprüfen und den eingestellten Wert für die maximale Zykluszeit entsprechend zu verkleinern.
Max Bearbeitungszeit pro Bild | Maximale Dauer einer Auswertung innerhalb des Zyklus inkl. Bildaufnahme
Min Bearbeitungszeit pro Bild | Minimale Dauer einer Auswertung innerhalb des Zyklus inkl. Bildaufnahme. Die minimale Bearbeitungszeit kann zum Unterdrücken von Mehrfachtriggern verwendet werden. Im Fall von "Anzahl Bilder" = 1 (default) entspricht die Min Bearbeitungszeit pro Bild der minimalen Zykluszeit.
LED-Stärke | Dieser Wert wird automatisch berechnet und nur angezeigt. Standard-Wert ist 100 %. Die LED-Leistung wird automatisch reduziert, wenn bei relativ langen Belichtungszeiten und relativ kurzer minimaler Job-Zeit (kurze min Zykluszeit und / oder sehr schnelle Bearbeitung der Detektoren) die Pause zum Abkühlen der LEDs zu klein wird. Die minimale Zykluszeit muss Faktor 10 größer sein als die Verschlusszeit, damit die LEDs mit 100 % Leistung betrieben werden können.
Auto | Der Schalter "Auto" stellt die "Min. Bearbeitungszeit pro Bild" so ein, dass die LED-Stärke immer 100 % ist.

(B) Mehrfachbildaufnahme
Parameter | Funktion
Anzahl Bilder (max)

Maximale Anzahl von Bildaufnahmen, die nach einem Trigger ausgeführt werden, sofern keines der folgenden Abbruchkriterien erfüllt ist:

  • "Gesamt Jobergebnis" = positiv (einstellbar unter Ausgabe/ Ausgangssignale)
  • "Max Zykluszeit" nicht erfüllt ist (falls aktiviert).

Optional:

  • Detektor einem Bild zuordnen, siehe auch Mehrfachbildaufnahme: Mehrfachbildaufnahme: Detektor einem Bild zuordnen
Verschlusszeitvariation | Ist die Verschlusszeitvariation "Aktiv" kann über eine Tabelle eine Variation aus mehreren unterschiedlichen Verschlusszeiten erstellt werden. Pro eingestellte Verschlusszeit wird dann ein Bild aufgenommen, d.h. das erste Bild mit Verschlusszeit 1, das zweite Bild mit Verschlusszeit 2, das dritte mit Verschlusszeit 3 usw. Default der "Verschlusszeitvariation" ist "Aus". In diesem Fall, wird die Listbox nicht angezeigt.
Faktor und Verschlusszeit

Voreingestellt für den Faktor ist: Erster Wert = 1.00 (der erste Wert ist immer identisch zu 1.00 und ist schreibgeschützt). Nachfolgende Defaultwerte erhöhen sich je um 0.1, z.B. 1.10, 1.20, ... Der Nutzer kann den Faktor in der Tabelle verändern, dabei wird die Verschlusszeit (Zweite Spalte, schreibgeschützt) automatisch angepasst und ein Bild aufgenommen. Bei einem Mausklick in eine Zeile der Tabelle wird ein Bild mit den Einstellungen der angeklickten Tabellenzeile aufgenommen.

Hinweis:

Bei einer Änderung des Parameters "Verschlusszeit" im Reiter "Bildaufnahme" wird die Verschlusszeit in der Listbox "Verschlusszeitvariation" neu berechnet.

Mehrfachbildaufnahme: Detektor einem Bild zuordnen

Im Bedienschritt "Detektor" werden alle eingestellten Detektoren aufgelistet. Wenn der Parameter "Anzahl Bilder (max)" der Mehrfachbildaufnahme größer 1 ist, erhält man die Option einen Detektor einer Bildaufnahme zuzuordnen. In der Spalte "Mehrfachbildaufnahme" kann diese Einstellung für jeden Detektor vorgenommen werden.

  • Immer: In allen Bildaufnahme ausgeführt
  • Aufnahme n: In der entsprechenden Bildaufnahme ausgeführt

Auswahltabelle durch Doppelklick öffnen.

Abbildung: Detektorliste, Mehrfachbildaufnahme


Bedienschritt Lagenachführung

Bei Objekten bzw. Merkmalen, deren Position im Bild variiert, kann eine Lagenachführung erforderlich sein. Die Lagenachführung ermittelt die Objekt-/ Merkmalposition im Bild. Hierfür stehen drei verschiedene Detektionsmethoden (Lagedetektoren) zur Verfügung.

Funktionsweise einer Lagenachführung:

Bei einer Lagenachführung handelt es sich um ein nachgeführtes Koordinatensystem, das an einem ausgewählten Merkmal verankert wird. Definierte Detektoren werden relativ zu diesem Koordinatensystem ausgerichtet. Das nachgeführte Koordinatensystem wird in dunkelblau eingezeichnet (zur Bedeutung und Einstellung der verschiedenen Rahmen im Bild. S. Kapitel: . Such- und Merkmalsbereiche ).

Hinweis:

  • Für jeden Job kann maximal ein Lagedetektor definiert werden.
  • Für jeden Detektor im Job kann ausgewählt werden, ob der Detektor mit der Lagenachführung nachgeführt werden soll oder nicht.
  • Da die Lagenachführung einen zusätzlichen Rechenschritt darstellt und somit Zykluszeit in Anspruch nimmt, sollte sie nur dann eingesetzt werden, wenn es die Anwendung erfordert.

Nächstes Thema: Auswahl und Konfiguration einer Lagenachführung


Auswahl und Konfiguration einer Lagenachführung

Lagenachführung auswählen

  1. Klicken Sie auf den Bedienschritt-Button "Lagenachführung".
  2. Wählen Sie eine Detektionsmethode im Konfigurationsfenster "Methode".
Methode | Auswahlkriterien
Keine | Lagenachführung nicht aktiv
Mustervergleich

Erkennung beliebiger Muster

Der Mustervergleich kann vorzugsweise eingesetzt werden wenn:

  • eher keine / weniger kontrastreiche bzw. achsparallele Kanten, sondern Bereiche mit Grauwertmustern im Bild vorhanden sind

Der Mustervergleich kann nicht bei Winkelversatz / Rotation eingesetzt werden. Drehlagentoleranz ca. +/- 5 % je nach Muster.
Kantenantastung

Die Antastung an Kanten sollte immer dann ausgewählt werden:

  • wenn ein Bildversatz in X- und / oder Y- Richtung auftreten kann.
  • bei einem maximalen Winkelversatz (rotatorischer Versatz gegenüber der Einlernlage) von ca. +/- 20° (je nach Objekt und Applikation).
  • wenn kontrastreiche, achsparallele Kanten vorhanden sind

Die Kantenantastung ist, wenn die oben genannte Kriterien erfüllt sind, eine sehr schnelle Methode der Lagenachführung.

Konturvergleich

Erkennung von Konturen und Kanten in beliebiger Winkellage

Die Konturerkennung ist immer dann zwingend einzusetzen wenn:

  • ein Winkelversatz (rotatorischer Versatz gegenüber der Einlernlage) bis 360° auftreten kann

Sie kann vorzugsweise eingesetzt werden, wenn kontrastreiche Kanten im Bild vorhanden sind. Die relativ aufwändige Funktion Konturerkennung resultiert in der Regel auch in einer vergleichsweise längeren Zykluszeit.

Lagedetektor konfigurieren:

  1. Passen Sie die im Bild dargestellten Such- und Merkmalsbereiche ggf. in Position und Größe an.
  2. Konfigurieren Sie den ausgewählten Lagedetektor im Reiter Parameter.

Lagenachführung für Detektoren aktiv setzen:

Im Bedienschritt "Detektor" werden alle eingestellten Detektoren aufgelistet. In der Spalte "Lagenachführung" kann für jeden Detektor ausgewählt werden, ob er von der eingestellten Lagenachführung nachgeführt werden soll oder nicht. Defaultwert ist "Aktiv".

Abbildung: Detektorliste, Lagenachführung aktiv/ inaktiv

Rücksetzen:

Mit dem Button "Rücksetzen" können die Werkseinstellungen für den ausgewählten Lagedetektoren wiederhergestellt werden.

Nächstes Thema: Lagenachführung Mustervergleich


Lagenachführung Mustervergleich

Dieser Detektor eignet sich zur Erkennung von Mustern beliebiger Form, auch ohne deutliche Kanten oder Konturen. Das Muster wird eingelernt und bei der anschließenden Prüfung über das Bild gelegt. Eine Übereinstimmung erfolgt bei dem größten Ähnlichkeitswert.

Nächste Themen:

Reiter Farbkanal

Reiter Parameter

Reiter Ergebnisoffset


Reiter Farbkanal

Im Reiter Farbkanal wird die Umwandlung eines Farbbildes (3 Kanal) in ein Grauwertbild (1 Kanal) ermöglicht. Im Gegensatz zum Grauwertbild eines monochromen SBS Vision-Sensors können Kontraste deutlich erhöht werden. Die Hervorhebung einer Farbe kann für jeden Detektor einzeln eingestellt werden. Damit ist die Flexibilität im Vergleich zum Einsatz von optischen Farbfiltern wesentlich höher.

Das Bild wird abhängig vom gewählten Detektor angezeigt.

  • Farbdetektoren: Anzeige immer farbig
  • Objekterkennungsdetektoren: Monochrombild, Anzeige abhängig vom gewählten Farbraum und den Farbkanälen

Folgende übergeordnete Parameter können im Reiter Farbkanal eingestellt werden:

Parameter | Funktion
Farbraum | Farbräume: RGB, Farbmodell RGB HSV, Farbmodell HSV LAB, Farbmodell LAB
Auswahl Farbfilter | Je nach Farbraum stehen alle oder ein Teil der folgenden Farbfilter zur Verfügung: Farbkanal (voreingestellt) Farbabstand Binarisierung
 | Umschaltung der Bildanzeige zwischen farbig und monochrom.

Auswahl Farbfilter

Die folgenden Farbfilter stehen zur Verfügung:

Farbkanal (voreingestellt)

Es wird der angegebene Farbkanal als Grauwertbild verwendet.

Abbildung: Farbfilter, Farbkanal (voreingestellt)

Farbabstand

Es wird eine Farbe als Referenzfarbe ausgewählt, indem die Farbraum-Werte angegeben oder per Pipette ausgewählt werden. Das Grauwertbild gibt den Abstand eines jeden Pixels zu dieser Referenzfarbe an. Typische Anwendung: Segmentierung von Buchstaben für OCR.

Abbildung: Farbfilter, Farbabstand

Parameter |  | Funktion
Rot Grün Blau | Luminanz A B | Farbkanäle: Die Farbkanäle sind benutzerdefiniert über den Regler oder mit der Eingabe eines Wertes einstellbar (Default 0).
Pipette-Symbol |  | Mit der Auswahl des Pipette-Buttons und einem anschließenden Klick ins Bild wird der ausgewählte Farbkanal automatisch bestimmt.
Maximaler Farbabstand |  | Abstand der aktuellen Farbe gegenüber der eingelernten Farbe. Farben, die den maximalen Farbabstand überschreiten, werden je nach Einstellung von "Invertiert" schwarz oder weiß.
Invertiert |  | Invertierung des Farbabstandbildes.

Binarisierung

Ein Farbbereich wird ausgewählt. Alle Pixel innerhalb dieses Farbbereiches werden weiß. Pixel mit einem abweichenden Farbwert werden schwarz.

Abbildung: Farbfilter, Binarisierung

Parameter |  |  | Funktion
Rot Grün Blau | Farbton (Hue) Sättigung (Saturation) Helligkeit (Value) | Luminanz A B | Bestimmung des Farbbereiches. Die Farbbereiche sind benutzerdefiniert über den Regler oder mit der Eingabe eines Wertes einstellbar.
Invertierungsbutton |  |  | Die aktuelle Einstellung wird mit Auswahl des Buttons invertiert.
Pipette-Symbol |  |  | Mit der Auswahl des Pipette-Buttons und einem anschließenden Klick ins Bild wird der ausgewählte Farbkanal automatisch bestimmt.


Reiter Parameter

Folgende Parameter können im Reiter "Parameter" eingestellt werden:

Parameter | Funktion
Schaltschwelle | Bereich für die geforderte Übereinstimmung des gefundenen Musters mit dem eingelernten Muster
Genau - Schnell | Anzahl der Suchstufen Großer Wert: Schnelle Suche = riskanter (Kandidaten übersehen) Kleiner Wert: Langsame Suche = risikoärmer (alle Kandidaten)
Muster | Zeigt das eingelernte Muster (roter Rahmen im Sichtfeld)
Muster bearbeiten | Maskierung des Musters, Bereiche des eingelernten Musters können deaktiviert werden. S. Kapitel: : Funktion: Muster/Kontur bearbeiten
Sperren | Sperren / Entsperren der Muster: Im gesperrten Status ist das Muster gegen Veränderung geschützt, z.B. bei der Modifizierung der einzulernenden Region. Entsperren um Muster zu ändern.

Abbildung: Lagenachführung Mustervergleich, Reiter Parameter

Nächstes Thema: Lagenachführung Kantenantastung


Reiter Ergebnisoffset

Mit Ergebnisoffset kann die Position eines gefundenen Objekts verändert werden. Das kann hilfreich sein z.B. zur Definition eines geeigneten Greifpunktes am gefundenen Teil in Pick and Place Anwendungen.

Einstellungen im Reiter Ergebnisoffset

Parameter Funktion

Kein

Kein Offset, d.h. automatisch bestimmtes Zentrum des gefundenen Objekts / der Finderegion.

Offset

Frei wählbare Position (grafisch oder durch Werteeingabe). Etwa zur Anpassung an optimalen Greifpunkt bei Roboteranwendungen.

  • Offset X: Offset in X- Richtung
  • Offset Y: Offset in Y- Richtung
  • Offset Winkel: Winkel- Offset

Abbildung: Ergebnisoffset


Lagenachführung Kantenantastung

Diese Lagenachführung ermittelt die Objektposition und damit das nachgeführte Koordinatensystem anhand des Kreuzungspunktes von Kanten im Bild. Es können Winkellagen bis zu ca. ±20% Abweichung (je nach Objekt) kompensiert werden.

Nächste Themen:

Aufbau der Kantenantastung

Reiter Farbkanal

Reiter Parameter


Aufbau der Kantenantastung

Die "Kantenantastung" wird über sogenannte "Antaster" ausgeführt. Je nach Antastmodus kann es zwischen ein bis drei Antaster geben. Der Suchbereich eines Antasters ist durch den gelben Rahmen (ROI) gekennzeichnet. Innerhalb dieses Rahmens wird das Objekt gesucht und die Kante des Objekts angetastet. Die Antastung erfolgt in Richtung des gelben Pfeils, in die "Antastrichtung". Über diesen gelben Pfeil kann zusätzlich der Suchbereich des Antasters gedreht werden. Vom Startpunkt des Suchbereichs werden Suchstreifen (Anzahl beliebig einstellbar) in die Antastrichtung ausgesendet. Trifft der Suchstreifen auf die Kante des Objekts, so wird an dieser Stelle mit einem Kreuz der "Antastpunkt" des Suchstreifens gekennzeichnet. Je nach Anzahl und Einstellung kann es einen "Gewinnersuchstreifen" geben, dessen Antastpunkt fett eingezeichnet wird. Welche Kante eines Objekts angetastet wird ist an der "Antastlinie" in Suchrichtung zu sehen. Wird ein Objekt nicht aus X- und Y-Richtung angetastet, sondern nur aus einer Richtung, so liegt die zweite Antastlinie im Zentrum des Suchbereichs. Die Pfeile mit dem Ursprung auf dem Schnittpunkt der Antastlinien bilden das nachgeführte Koordinatensystem. In der nachfolgenden Abbildung ist der Aufbau der Lagenachführung "Kantenantastung" visualisiert.

Abbildung: Aufbau Kantenantastung

Nächste Themen:

Reiter Farbkanal

Reiter Parameter


Reiter Farbkanal

S. Kapitel: Reiter Farbkanal


Reiter Parameter

Zur Ausführung der Kantenantastung muss der Antastmodus gewählt werden. Über den Antastmodus wird bestimmt, welche Art von Positionsänderung des Prüfobjekts nachgeführt werden kann: Verschiebung in eine oder zwei Richtungen, Verdrehung. Folgende Antastmodi stehen zur Verfügung:

Antastmodus | Funktion | Empfohlene Verwendung bei variierender Objektposition ...
... in eine Richtung | ... in zwei Richtungen | ... mit Verdrehung
1

Ein Antaster: Lagenachführung bei Verschiebung in eine Richtung

Objektposition wird nachgeführt bei einer Verschiebung in eine Richtung.

Die Position der Antastlinie wird über die Antastrichtung des Antasters bestimmt. Die andere Antastlinie liegt in der Mitte des Suchbereichs.

Hinweis:

Eine Verdrehung der Objektposition wird nicht nachgeführt.

ü

2

Ein Antaster: Lagenachführung bei Verschiebung in eine Richtung und Rotation

Objektposition wird nachgeführt bei einer Verschiebung in eine Richtung und Rotation.

Die Position der Antastlinie wird über die Antastrichtung des Antasters bestimmt. Die andere Antastlinie liegt in der Mitte des Suchbereichs.

ü

ü
3

Zwei Antaster: Lagenachführung bei Verschiebung in zwei Richtungen

Objektposition wird nachgeführt bei Verschiebung in zwei Richtungen.

Die Position der Antastlinie in X-Richtung des Koordinatensystems wird mit dem Antaster 1 bestimmt.

Die Position der Antastlinie in Y-Richtung des Koordinatensystems wird mit dem Antaster 2 bestimmt.

Der Ursprung des Koordinatensystems liegt auf dem Schnittpunkt der beiden Antastlinien.

Hinweis:

Eine Verdrehung der Objektposition wird nicht nachgeführt.

ü
4

Zwei Antaster: Lagenachführung bei Verschiebung in zwei Richtungen und Rotation

Objektposition wird nachgeführt bei Verschiebung in zwei Richtungen und Rotation.

Die Position der Antastlinie in X-Richtung des Koordinatensystems wird mit dem Antaster 1 bestimmt.

Die Position der Antastlinie in Y-Richtung des Koordinatensystems wird mit dem Antaster 2 bestimmt.

Der Ursprung des Koordinatensystems liegt auf dem Schnittpunkt der beiden Antastlinien.

Zusätzlich wird die Orientierung des Objekts bestimmt. Antaster 2 wird entsprechend der Objektbewegung verdreht und verschoben.

Die Position des Antasters 2 wird relativ zur Lage und Orientierung der Antastlinie des Antasters 1 nachgeführt.

ü ü
5

Drei Antaster: Lagenachführung bei Verschiebung in zwei Richtungen und Rotation

Objektposition wird nachgeführt bei Verschiebung in zwei Richtungen und Rotation.

Es wird eine Gerade durch die Antastpunkte der Gewinnersuchstreifen von Antaster 1 und 2 gezogen. Diese Antastlinie (12) bestimmt die Position und Orientierung des Koordinatensystems. Der Ursprung des Koordinatensystems liegt auf dem Schnittpunkt der Antastlinie 12 und Antastlinie 3. Antaster 3 wird entsprechend der Objektbewegung verdreht und verschoben.

Die Position des Antasters 3 wird relativ zur Lage und Orientierung der Antastlinie 12 nachgeführt.

 ü ü

Nach der Auswahl des Antastmodus sind die entsprechenden Parameter zu bestimmen.
Folgende Parameter können im Reiter Parameter eingestellt werden:

Parameter | Funktion

Kantenstärke

 Kantenstärke / Kontrast ab welchem eine Kante als Kante detektiert werden soll.
Glättung | Der Kantenverlauf in Suchrichtung wird geglättet. Mit größeren Werten werden verrauschte Kanten, unscharfe Kanten oder Kanten, die nicht senkrecht zur Suchrichtung stehen, sicherer erkannt. Außerdem können mit größeren Werten eng beieinander liegende Hell-Dunkel-Hell- oder Dunkel-Hell-Dunkel-Übergänge ignoriert werden. Damit lassen sich störende Kanten, z.B. Kratzer, ausblenden. Die Wirkung der Glättung kann über die Schaltfläche "Ergebnisse" grafisch dargestellt werden.
Übergang | Mit dem Parameter "Übergang" kann der Kantenübergang bestimmt werden.
  • Beide Richtungen
 Kantenübergang von hell nach dunkel und umgekehrt.
  • Hell → dunkel
 Kantenübergang von hell nach dunkel.
  • Dunkel → hell
 Kantenübergang von dunkel nach hell.
Suchstreifen | Anzahl der parallelen Suchstreifen in die die Breite des Suchbereichs aufgeteilt wird. Die Kantenantastung wird in jedem Suchstreifen durchgeführt, und die erste Kante ist entscheidend.
Kantenposition | Mit dem Parameter "Kantenposition" wird bestimmt, welche Kante aus der Antastrichtung detektiert werden soll. Es wird bestimmt, wie der Gewinnersuchstreifen und damit die Kantenposition ermittelt wird.
  • Erste

Die erste Kante in Suchrichtung wird detektiert.

Es werden die Abstände vom Beginn des Suchbereichs zu den Antastpunkten der Suchstreifen in Suchrichtung bestimmt. Der Gewinnersuchstreifen ist der mit dem kürzesten Abstand zum Beginn des Suchbereichs.
  • Letzte

Die letzte Kante in Suchrichtung wird detektiert.

Es werden die Abstände vom Beginn des Suchbereichs zu den Antastpunkten der Suchstreifen in Suchrichtung bestimmt. Der Gewinnersuchstreifen ist der mit dem weitesten Abstand zum Beginn des Suchbereichs.
  • Median
 Es werden die Abstände vom Beginn des Suchbereichs zu den Antastpunkten der Suchstreifen in Suchrichtung bestimmt. Dann wird der Median-Wert dieser Abstände gebildet.
  • Mittelwert
 Es werden die Abstände vom Beginn des Suchbereichs zu den Antastpunkten der Suchstreifen in Suchrichtung bestimmt. Dann wird der Mittelwert dieser Abstände gebildet.
Orientierung | Mit dem Parameter "Orientierung" wird die Art der Antastlinien-Bestimmung festgelegt.
  • Ausgleichsgerade
 Bei dieser Einstellung wird die Antastlinie dadurch bestimmt, dass eine Ausgleichsgerade durch alle Suchstreifen gelegt wird.
  • Kantenanschlag
 Bei dieser Einstellung wird eine Antastlinie bestimmt, die wie ein mechanischer Kantenanschlag wirkt. So lassen sich für konkav geformte Kantenverläufe robustere Ergebnisse erzielen als mit einer einfachen Ausgleichsgerade.
Antastrichtung | Dieser Parameter bestimmt die Suchrichtung der Antaster. Aus dieser Richtung wird die Objektkante angetastet. Alle Antaster können über den kleinen schwarzen Pfeil gedreht werden
Die Antastrichtung erfolgt in nur eine Richtung und zwar in Richtung des gelben Pfeils (ROI). Die Antastpunkte und damit der Koordinatenursprung liegen an einer Kante des Objekts.
Für jeden Suchstreifen wird von beiden Richtungen des Antasters ein Antastpunkt bestimmt. Danach wird die Mitte zwischen diesen Antastpunkten ermittelt. Der Ursprung des Koordinatensystems liegt auf dem Mittelpunkt des Gewinnersuchstreifens, d.h. im Objekt.
Ergebnisse

Öffnet das Ergebnis- und Histogramm- Fenster.

Weitere Informationen hierzu finden Sie unter: Ergebnisse / Histogramm Fenster

Abbildung: Lagenachführung Kantenantastung, Reiter Parameter

Weitere Informationen:

Closed Ausführungsgeschwindigkeit erhöhen:
  • Suchbereich für Position (gelber Rahmen) nur so groß wie nötig
  • Suchstreifen verringern
  • Wert für Glättung verkleinern
  • Auflösung von WVGA auf QQVGA, QVGA oder VGA verringern

    Achtung:

    Der globale Parameter, wirkt auf alle Detektoren!

Closed Robustheit optimieren:
  • Falls unscharfe Kante: Wert für Glättung erhöhen
  • Störkanten wie Kratzer werden erkannt: Schaltschwelle oder / und Wert für Glättung erhöhen
  • Kante nicht senkrecht zur Suchrichtung: Suchstreifen erhöhen
Closed Wirkung von Anzahl Suchstreifen

„Suchstreifen“ gibt an, in wie viele parallele Suchstreifen der Suchbereich aufgeteilt wird. Die Kantenantastung wird innerhalb jedes Suchstreifens über die gesamte Breite durchgeführt. Die erste Kante in Suchrichtung aller Suchstreifen wird als Gesamtergebnis betrachtet. Mit Erhöhung von „Anzahl Suchstreifen“ wird sichergestellt, dass die erste Kante im Suchbereich gefunden wird. Durch die Erhöhung der Suchstreifen kann es passieren, dass die gefundene Kantenstärke schwankt, z.B. Wenn nur die halbe Breite des Suchbereichs mit einer Kante bedeckt ist. Die Ursache ist, dass die erste - nicht die stärkste - Kante erkannt wird, die über der Schwelle liegt.

Weitere Hinweise zur Kantenantastung s. Weitere Erläuterungen zur Kantenantastung (Lagenachführung)


Weitere Erläuterungen zur Kantenantastung (Lagenachführung)

Wirkung von Anzahl Suchstreifen

„Suchstreifen“ gibt an, in wie viele parallele Suchstreifen der Suchbereich aufgeteilt wird. Die Kantenantastung wird in jedem Suchstreifen separat durchgeführt. Die erste Kante in Suchrichtung aller Suchstreifen wird als Gesamtergebnis betrachtet. Mit Erhöhung von „Suchstreifen“ wird sichergestellt, dass die erste Kante im Suchbereich gefunden wird.

Beim Erhöhen von „Suchstreifen“ kann es vorkommen, dass die gefundene Kantenstärke stark schwankt, z.B. wenn nur der halbe Suchbereich von der Kante belegt ist. Ursache hierfür ist, dass die Kantenstärke für die erste (nicht die stärkste) Kante angezeigt wird, die in Suchrichtung über der Schaltschwelle liegt.

Kantenantastung mit Suchstreifen = 1. Es wird die dominierende Kante senkrecht zur Suchrichtung gefunden.
Einstellungen im Reiter Parameter: Suchstreifen = 1 | Abbildung: Parameter "Suchstreifen" = 1
Bildanzeige: Es wird die dominierende Kante senkrecht zur Suchrichtung gefunden. | Abbildung: Dominierende Kante senkrecht zur Suchrichtung

Kantenantastung mit Suchstreifen > 1. Es wird die erste Kante senkrecht zur Suchrichtung gefunden
Einstellungen im Reiter Parameter: Suchstreifen = 3 | Abbildung: Parameter Suchstreifen = 3
Bildanzeige: Es wird die erste Kante senkrecht zur Suchrichtung gefunden | Abbildung: Erste Kante senkrecht zur Suchrichtung gefunden

Wirkung von Glättung auf scharfe bzw. unscharfe Kanten

Die Kantenstärke ergibt sich durch Addition von Kantenstufen über einen Bereich in Suchrichtung, dessen Größe durch den Parameter „Glättung“ gegeben ist.
Bei scharfen Kanten wird die Kantenstärke durch wachsende Glättung nicht erhöht.
Bei unscharfen Kanten dagegen wird die Kantenstärke durch wachsende Glättung erhöht.

Antastung von scharfen und unscharfen Kanten bei kleiner Glättung
Einstellungen im Reiter Parameter: Glättung = 1 | Abbildung: Parameter Glättung = 1
Bildanzeige: Antastung von scharfer Kante. Hohe Kantenstärke bei kleiner Glättung. | Abbildung: Hohe Kantenstärke bei kleiner Glättung
Bildanzeige: Antastung von unscharfer Kante. Niedrige Kantenstärke bei kleiner Glättung. | Abbildung: Niedrige Kantenstärke bei kleiner Glättung

Antastung von unscharfen Kanten bei großer Glättung
Einstellungen im Reiter Parameter: Glättung = 6 | Abbildung: Parameter Glättung > 1
Bildanzeige: Antastung von unscharfen Kanten. Hohe Kantenstärke bei großer Glättung. | Abbildung: Hohe Kantenstärke bei großer Glättung

Wirkung von Glättung auf Störkanten

Wie oben erwähnt, ergibt sich die Kantenstärke durch Addition von Kantenstufen über einen Bereich in Suchrichtung, dessen Größe durch den Parameter „Glättung“ gegeben ist. Liegen in diesem Bereich Kanten unterschiedlicher Polarität (dunkel-hell: positive Polarität, hell-dunkel: Negative Polarität) so können sich deren Kantenstufen aufheben. Dies kann ausgenutzt werden, um Störkanten zu unterdrücken, indem „Glättung“ hinreichend groß gewählt wird.

Antastung mit Glättung = 1. Störkante wird nicht übersprungen.
Einstellungen im Reiter Parameter: Glättung = 1 | Abbildung: Parameter Glättung = 1
Bildanzeige: Störkante wird nicht übersprungen. | Abbildung: Störkante wird nicht übersprungen

Antastung mit Glättung > 1. Störkante wird übersprungen.
Einstellungen im Reiter Parameter: Glättung > 1 | Abbildung: Parameter Glättung > 1.
Bildanzeige: Störkante wird übersprungen. | Abbildung: Störkante wird übersprungen


Lagenachführung Konturvergleich

Dieser Detektor eignet sich zur Erkennung von Konturen anhand von Kanten. Die Konturen des Objekts im Suchfeld werden beim Einlernen auf dem Sensor gespeichert. Im Run-Modus sucht der Sensor die Position der größten Übereinstimmung mit der eingelernten Kontur im aktuellen Bild. Ist die Übereinstimmung größer als der eingestellte Schwellwert, wird das Objekt als gut erkannt. Die Konturerkennung ist komplett drehlagentolerant, d.h. das gesuchte Objekt darf in beliebiger Lage im Bild erscheinen (Winkeleinstellung entsprechend wählen).

Nächste Themen:

Reiter Farbkanal

Reiter Parameter

Reiter Konturoptimierung

Reiter Geschwindigkeit

Reiter Ergebnisoffset

Reiter Greiferfreiraum


Reiter Parameter

Im Reiter Parameter können die wichtigsten Parameter zur Konturerkennung eingestellt werden.

Abbildung: Lagenachführung Konturvergleich, Reiter Parameter

Die rechts unten hellblau eingezeichneten Kanten (kontrastreiche Übergänge im Bild) wurden auf Grund der getätigten Parametereinstellungen identifiziert und eingezeichnet. Diese können durch Veränderung der Parameter bzw. durch die Funktion „Kontur bearbeiten“ weiter verändert werden. Der SBS Vision-Sensor sucht diese Kontur nun im Bild innerhalb des Suchbereiches (gelber Rahmen).

Folgende Parameter können im Reiter Parameter eingestellt werden:

Parameter | Funktion
Schaltschwelle | Bereich für die geforderte Übereinstimmung der gefundenen Kontur mit der eingelernten Kontur
Winkelbereich | Winkelbereich, in dem gesucht wird (großer Bereich bedeutet längere Bearbeitungszeit)
Skalierung | Erkennung auch von vergrößerten oder verkleinerten Objekten im angegebenen Skalierungsbereich
Kontur | Zeigt die eingelernte Kontur (roter Rahmen im Sichtfeld)
Kontur bearbeiten | Über den Parameter „Kontur bearbeiten“ können Bereiche der eingelernten Kontur ausgeblendet werden. Wie mit einem Radierer können im Suchbereich die Bereiche entfernt werden, die für die Auswertung nicht benötigt werden. Über die Auswahl "Alles Invertieren" kann die Einstellung auch invertiert werden. Nächstes Thema: Funktion: Muster/Kontur bearbeiten
Sperren | Sperren / Entsperren der Kontur: Im gesperrten Zustand ist die eingelernte Kontur gegen (unbeabsichtigte) Änderung, z.B. durch versehentliche Anpassung der Einlernbereichs, geschützt. Entsperren, um Kontur zu ändern.

Weitere Informationen:

Optimierung der Ausführungsgeschwindigkeit

  • Suchbereich für Position (gelber Rahmen) nur so groß wie nötig.
    Beachte: Suchbereich gibt den Bereich an, in dem der Schwerpunkt der Kontur gesucht wird.
  • Suchbereich für Winkel nur so groß wie nötig
  • Suchbereich für Skalierung nur so groß wie nötig

  • Auflösung von VGA auf QVGA verringern

    Achtung:

    Der globale Parameter, wirkt auf alle Detektoren
  • Setze "genau - schnell" auf schnell
  • Wert für „Min Kontrast Modell“ erhöhen. In der Anzeige des Musters überprüfen, ob die relevanten Konturen noch vorhanden sind.
  • Wert für „Min Kontrast Bild“ erhöhen.
  • Insbesondere im Fall von Lagenachführung: Alternatives Suchmuster verwenden. Beispielsweise mit höherem Kontrast, so dass „Min Kontrast Modell“ und „Min Kontrast Bild“ erhöht werden können.

Robuste Erkennung:

  • Suchbereich für Position (gelber Rahmen) ausreichend groß?
  • Suchbereich für Winkel ausreichend groß?
  • Suchbereich für Skalierung ausreichend groß?
  • Kontrast für das Model und Bild ausreichend (Für das Model ersichtlich in der Probe)?
  • Setze "genau - schnell" auf schnell
  • Sind im Bild mehrere, sich überlappende Instanzen des Musters vorhanden
  • Markante Kanten in Muster vorhanden? Gegebenenfalls Muster neu einlernen, so dass markante Kanten im eingelernten Muster liegen.
  • „Min Kontrast Muster“ geeignet gewählt? Werden im eingelernten Muster die relevanten Konturen nicht angezeigt, so ist „Min Kontrast Muster“ zu verkleinern. Werden zu viele Konturen angezeigt, so ist „Min Kontrast Muster“ zu erhöhen.
  • „Min Kontrast Bild“ für aktuelles Bild geeignet gewählt? Hat das aktuelle Bild einen kleineren / größeren Kontrast als das eingelernte Muster, so ist „Min Kontrast Bild“ kleiner / größer als „Min Kontrast Muster“ zu wählen.
  • Wenn im eingelernten Muster die Konturlinien nicht komplett sichtbar sind: Verminderung "Min Kontrast Muster". Wenn zu viele Konturlinien sichtbar sind: Erhöhung "Min Kontrast Muster".
  • Muster an falscher Position gefunden? Falls eingelerntes Muster nicht eindeutig ist, neues Muster einlernen.
  • Ergebniswert schwankt von Bild zu Bild? Gegebenenfalls dafür sorgen, dass keine „falschen“ Konturen im Bild eingelernt werden (Kanten aufgrund von Schatten oder Konturenfragmente, die im Konturmodell nicht erwünscht sind). Dies kann durch Erhöhung „Min Kontrast Modell“ erreicht werden. Mit Hilfe von „Kontur bearbeiten“ können Suchbereiche ausgeblendet werden

Parameter Winkelbereich: Drehsinn Winkel

Abbildung: Drehsinn "Winkel"

Nächstes Thema:

Reiter Konturoptimierung


Reiter Konturoptimierung

Im Reiter "Konturoptimierung" können weitere Einstellungen zum Kantenübergang und dem Kontrast vorgenommen werden.

Abbildung: Lagenachführung Konturvergleich, Reiter Konturoptimierung

Folgende Parameter können im Reiter Konturoptimierung eingestellt werden:

Parameter | Funktion
Min. Kontrast Modell | Minimal geforderter Kontrast beim eingelernten Modell, bei dem eine Kante als solche akzeptiert wird.
Min. Kontrast Bild | Minimal geforderter Kontrast im aktuellen Bild, bei dem eine Kante als solche akzeptiert wird.

Kantenübergang

  • wie eingelernt
  • wie eingelernt und invertiert
  • flexibel

Mit dem Parameter "Kantenübergang" kann der Übergang zwischen Objekt bzw. Kontur und Hintergrund bestimmt werden. Dabei wird ausgewählt, ob die Kontur nur auf dem eingelernten Hintergrund ("wie eingelernt"), auf dem eingelernten und invertierten Hintergrund ("wie eingelernt und invertiert") oder bei beliebigem Hintergrund ("flexibel") erkannt werden soll.

Mehr dazu finden Sie unter "Weitere Informationen:".
Auto | Automatische Einstellung

Weitere Informationen:

Closed Kantenübergang

Beispiel:

Ein graues Objekt wird, wie in der nachfolgenden Abbildung gezeigt, vor einem hellerem Hintergrund eingelernt.

Abbildung: Eingelernte Kontur vor einem hellen Hintergrund

Die nachfolgende Tabelle zeigt, wie sich der Konturdetektor bei der jeweiligen Einstellung für den Kantenübergang verhält.

Einstellung für den Parameter "Kantenübergang" | Heller Hintergrund | Dunkler Hintergrund | Uneinheitlicher Hintergrund
wie eingelernt |  |  |
 | Konturdetektor: I.O. | Konturdetektor: N.i.O. | Konturdetektor: N.i.O.
wie eingelernt und invertiert |  |  |
 | Konturdetektor: I.O. | Konturdetektor: I.O. | Konturdetektor: N.i.O.
flexibel |  |  |
 | Konturdetektor: I.O. | Konturdetektor: I.O. | Konturdetektor: I.O.

Nächste Themen:

Reiter Ergebnisoffset

Reiter Geschwindigkeit


Reiter Geschwindigkeit

Die Ausführungsgeschwindigkeit wird über die einstellbaren Parameter im Reiter Geschwindigkeit beeinflusst. Durch Anpassen der Suchstufen wird der Detaillierungsgrad der Suche und damit die Zeit für eine bestimmte Suche festgelegt. Die Suche wird entweder weniger fein durchgeführt, d.h.die Suche wird früher abgebrochen und ist damit schneller, oder es werden auch feinere Details bei der Suche berücksichtigt, d.h.es wird länger gesucht und die Suche ist damit langsamer.

Abbildung: Lagenachführung Konturvergleich, Reiter Geschwindigkeit

Folgende Parameter können im Reiter Geschwindigkeit eingestellt werden:

Parameter | Funktion
Schrittweite Winkel | Empfindlichkeit der Suche über den gewählten Winkelbereich in Grad [°]
Schrittweite Skalierung | Empfindlichkeit der Suche über den gewählten Skalierungsbereich

Suchstufen

(genau - schnell)

Anzahl der Suchstufen

  • Großer Wert: Schnelle Suche = riskanter (Kandidaten übersehen)
  • Kleiner Wert: Langsame Suche = risikoärmer (alle Kandidaten)

Übereinstimmungsgrad

(genau - schnell)

Kandidaten mit Übereinstimmungsgrad unterhalb des angegebenen Werts werden bereits bei der Suche verworfen.

  • Großer Wert: Frühes Verwerfen = schneller = riskanter
  • Kleiner Wert: Spätes Verwerfen = langsamer = risikoärmer

Falls die Suche fehlschlägt, kann der Wert verkleinert werden (genauer).

Auto | Automatische Einstellung

Nächste Themen:

Reiter Ergebnisoffset

Reiter Greiferfreiraum


Reiter Ergebnisoffset

S. Kapitel: Reiter Ergebnisoffset


Bedienschritt Detektoren

Nächstes Thema: Erstellen und Bearbeiten von Detektoren

Jeder Job beinhaltet einen oder mehrere Prüfschritte (Detektoren), die Sie hier definieren können. Durch Anklicken der Schaltfläche "Detektor" oder der Schaltfläche "Neu" unter der Detektorliste öffnet sich ein Fenster mit einer Liste aller verfügbaren Detektoren. Die entsprechenden Einstellbereiche werden grafisch im Bild als Rahmen in voreingestellter Lage und Größe dargestellt. Nun die Rahmen und die Parameter entsprechend der Prüfaufgabe einstellen.

Für Hinweise zur Bedeutung und Einstellung der verschiedenen Rahmen im Bild siehe Kapitel: Such- und Merkmalsbereiche .

Abbildung: Detektor Auswahlliste Objektsensor


Erstellen und Bearbeiten von Detektoren

Detektortypen:

  • Detektor Mustervergleich
  • Detektor Kontur
  • Detektor Kontrast
  • Detektor Helligkeit
  • Detektor Graustufe
  • Detektor BLOB
  • Detektor Messschieber
  • Detektor Barcode
  • Detektor Datacode
  • Detektor OCR
  • Detektor Farbfläche
  • Detektor Farbliste
  • Detektor Farbwert

Neuen Detektor erstellen:

  1. Klicken Sie auf Button „Neu" unter der Auswahlliste im Konfigurationsfenster und wählen Sie den gewünschten Detektortyp. Ein neuer Detektoreintrag erscheint in der Auswahlliste.
  2. Editieren Sie den Detektornamen durch Doppelklick auf das Feld „Name".

Detektor konfigurieren:

  1. Markieren Sie einen Detektor in der Auswahlliste und vergeben Sie einen Namen für jeden Detektor.
  2. Legen Sie die zugehörigen Such- und Merkmalsbereiche grafisch im Bild fest.
  3. Konfigurieren Sie den Detektor, indem Sie Parameter in den Reitern Parameter / Allgemein und ggf. erweitert des Konfigurationsfensters eingeben / einstellen. Welche Reiter angezeigt werden, hängt vom gewählten Detektortyp ab.

Einzeichnung konfigurieren:

Im Menü „Ansicht/Einzeichnungen konfigurieren ..." können die Einzeichnungen im Bild (Rahmen in gelb, rot, etc.) beliebig je Detektor oder Kategorie an- oder abgeschaltet werden. Unter "Ansicht/Einzeichnungen nur aktueller Detektor" bzw. mit dem Rahmensymbol-Button, können alle Einzeichnungen im Bild bis auf die des aktuell bearbeiteten Detektors abgeschaltet werden.

Funktionen zum Verwalten der Detektoren:

Schaltfeld Funktion

Neu

Neuen Detektor einfügen ˃ Dialog mit Detektorauswahlliste erscheint

Kopieren

Kopieren sämtlicher Parameter von einem Detektor zu einem oder mehren anderen. Die Merkmalsbereiche (verschiedenfarbige Rahmen wie: Einlernbereich, Suchbereich etc.) werden dabei nicht mitkopiert. Die Detektortypen müssen dazu identisch sein.

Kopiervorgang:

Alle gewünschten Zieldetektoren vom gleichen Typ wie Quelldetektor anlegen. Quelldetektor in der Detektorliste auswählen.

Button „Kopieren“ drücken.

In der nun erscheinenden Liste alle gewünschten Zieldetektoren markieren (Mehrfachmarkierung mit gedrückter „Strg“- Taste). Mit „Kopieren“ bestätigen.

Rücksetzen

Zurücksetzen der Parameter und des Such- und Merkmalsbereichs des ausgewählten Detektors auf die Standardwerte

Löschen

Löschen des ausgewählten Detektors

Alle Löschen

Löschen aller Detektoren in der Liste

Hinweis:

In der Statuszeile am unteren Bildschirmrand wird mit „Flash: x.x/yyyy.y kB", zuerst der durch die momentane Konfiguration benutzte Speicher (x.x), bzw. der auf dem Sensor verfügbare Speicher (yyyy.y) in kB angezeigt. Übersteigt der genutzte Speicher den verfügbaren Speicher wechselt diese Anzeige in eine rote Darstellung, da dann die momentanen Einstellungen nicht mehr auf dem Sensor Platz finden würden. In diesem Fall können Sie vor der Übertragung andere Jobs vom Sensor löschen.


Auswahl eines geeigneten Detektors

Nächstes Thema: Detektor Mustervergleich

Folgende Detektoren stehen zur Verfügung:

Detektortyp | Beschreibung
Mustervergleich | Teileerkennung mittels Mustervergleich, X - und Y-translatorisch
Kontur | Teileerkennung mittels Objektkontur, Rotation bis 360°
Kontrast | Bestimmung des Kontrastes im ausgewählten Suchfeld
Helligkeit | Prüfen der Helligkeit im gewählten Suchbereich
Graustufe | Bestimmung der Grauwerte im ausgewählten Suchfeld
BLOB | Zählen und Bewerten von Objekten
Messschieber | Abstand zwischen Kanten
Farbfläche | Farbauswertung über Fläche
Farbliste | Farbauswertung über Liste
Farbwert | Ausgabe von Farbwerten
Barcode | Barcodelesung 1D Codes
Datacode | Datacodelesung Datacodes
Optical Character Recognition OCR | Klarschriftlesung


Detektor Mustervergleich

Dieser Detektor eignet sich zur Erkennung von Mustern beliebiger Form, auch ohne deutliche Kanten oder Konturen.

Abbildung: Detektor Mustervergleich

Nächste Themen:

Detektor Kontur

Reiter Ergebnisoffset

Funktion: Muster/Kontur bearbeiten

Mustervergleich Applikation

Reiter Muster

Parameter | Funktion
Schaltschwelle | Bereich für die geforderte Übereinstimmung des gefundenen Musters mit dem gelernten Muster in %.
Genau - Schnell | Anzahl der Suchstufen / Vergröberungsstufen (Mögliche Einstellungen 2-10). Großer Wert: schneller = riskanter (Kandidaten übersehen) Kleiner Wert: langsamer = risikoärmer (alle Kandidaten)
Positions-kontrolle | Prüfung, ob sich das gefundene Muster an der richtigen Position befindet. Bei Aktivierung der Positionskontrolle wird der Positionsrahmen in blau (wahlweise rechteckig oder elliptisch) angezeigt. Der Mittelpunkt des Musters muss innerhalb des blauen Rahmens liegen.
Muster | Zeigt das eingelernte Muster = Inhalt des roten Rahmens
Muster bearbeiten | Über den Parameter „Muster bearbeiten“ können Bereiche des eingelernten Muster ausgeblendet werden. Wie mit einem Radierer können im Suchbereich die Bereiche entfernt werden, die für die Auswertung nicht benötigt werden. Diese markierten Bereiche können auch invertiert werden.
Sperren | Muster sperren / entsperren. Im gesperrten Zustand ist das eingelernte Muster gegen (unbeabsichtigte / versehentliche) Änderungen, durch z.B. versehentliche Anpassung des Einlernbereichs geschützt. Zum neuen Einlernen entsperren.

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.

Optimierung Mustervergleich:

Ausführungsgeschwindigkeit:

  • Suchbereich für Position (gelber Rahmen) nur so groß wie nötig.

    Beachten Sie: Suchbereich gibt den Bereich an, in dem der Schwerpunkt des Musters gesucht wird.
  • Auflösung von VGA auf QVGA verringern

    Achtung:

    Der globale Parameter, wirkt auf alle Detektoren!

  • Regler: Genau - Schnell auf: Schnell

Robuste Mustererkennung

  • Suchbereich für Position (gelber Rahmen) ausreichend groß wählen.
  • Regler: Genau - Schnell auf: Genau
  • Markantes Grauwertmuster wählen, ggf. neu einlernen
  • Wenn an falscher Position gefunden: Eindeutiges Muster verwenden, ggf. neu einlernen, evtl. Schwellwert anpassen.

Wird unmittelbar nach Einlernen festgestellt, dass gefundene Position (grüne ROI) nicht mit Einlernbereich (rote ROI) übereinstimmt, sollte Regler: Genau - Schnell auf: Genau eingestellt werden.


Mustervergleich Applikation

Im Beispiel wurde ein Kontakt (ganz links) des Prüfteiles als Muster eingelernt und wird an dieser Stelle auch mit hohem Übereinstimmungsgrad (Schaltschwelle nahe 100 %) erkannt.

Abbildung: Mustervergleich, Applikationsbeispiel, positives Ergebnis

Abbildung: Mustervergleich, Applikationsbeispiel, negatives Ergebnis

Wird nun der gleiche Mustervergleich an einer Stelle des Prüfteiles durchgeführt, an dem der gesuchte Kontakt fehlt, erreicht der Übereinstimmungsgrad nicht den geforderten Schwellwert und das Ergebnis wird negativ. Der Kontakt wird hier aufgrund der Grauwerte an den jeweiligen Orten im Bild gesucht. Da der innenliegende, sehr hoch reflektierende und damit helle Bereich nicht existiert, und stattdessen die Bildpixel entsprechend dunklere Werte aufweisen, ist hier der Übereinstimmungsgrad nicht so hoch wie bei einem vorhandenen Kontakt. Weil aber auch große Teile des Musters identisch mit dem eingelernten sind (der gesamte äußere, schwarze Bereich) ist der Übereinstimmungsgrad immer noch recht hoch bei ca. 70% !

Die hier gemachten Einstellungen sind nur zur Verdeutlichung der Wirkungsweise des Mustervergleichs-Detektors so gewählt. Sie sollten im realen Betrieb weiter optimiert werden, (Etwa durch Verkleinerung des Such- und Merkmalsbereichs >> relevantes Muster wird signifikanter, etc.).

Beim Einlernen wird das im roten Rahmen befindliche Bild als Referenz im Sensor gespeichert. Die Größe und Lage der Referenz wird durch den roten Rahmen definiert. Im Run-Modus sucht der SBS dann im aktuellen Bild nach der größten Übereinstimmung mit dem Referenzbild / Muster innerhalb des Suchbereichs. Je nach Einstellung des Schwellwerts (= Grad der Übereinstimmung) wird das Objekt als gut erkannt oder nicht.

Die Mustererkennung ist nur bis zu ca. ± 5 Winkel-Grad drehlagentolerant. Muster mit größeren Verdrehungen werden nicht erkannt. Nutzbar z.B. zur Prüfung der Lagerichtigkeit von Teilen in Zuführanlagen.

Beispiel:

Folgendes Muster wurde im Sensor eingelernt:

Abbildung: Muster, Referenz

Bei den folgenden drei Beispielbildern wird das Objekt mit 100 % Übereinstimmung erkannt, da das eingelernte Muster exakt gleich ist, obwohl es sich an einem anderen Ort im Bild befindet. Es wird jedoch nur in X- bzw. Y- Richtung verschoben, und nicht verdreht.

Abbildung: Muster, positives Ergebnis

Bei den drei nun folgenden Beispielbildern wird das Objekt ebenfalls erkannt, jedoch mit weniger als 100 % Übereinstimmung (ca. 70 - 80 %), da es in einigen Pixeln vom eingelernten Muster abweicht. Je nach Einstellung des Schwellwerts (Grad der Übereinstimmung) werden Gut- oder Schlecht- Ergebnisse geliefert.

Abbildung: Muster, Grenzfälle

Die Mustererkennung ist nur bis zu ± 5 Winkel- Grad drehlagentolerant. Das bedeutet, die Bilder in unterster Reihe würden auch erkannt, allerdings wäre hier, trotz 100 % Pixelübereinstimmung, der tatsächliche Grad der Übereinstimmung zum Musterbild kleiner 100 %. Muster mit größerer Verdrehung werden nicht erkannt. Dies kann z.B. zur Erkennung der Lagerichtigkeit von Teilen in Zuführanlagen als Funktion genutzt werden.

Abbildung: Muster, Rotation


Funktion: Muster/Kontur bearbeiten

Mit der Funktion "Suchbereich bearbeiten" bzw. "Muster/Kontur bearbeiten", können innerhalb der Suchfelder / Merkmalsfelder der verschiedenen Detektoren Bereiche für die Bewertung zugelassen oder ausgeschlossen werden.

Anwendungsbeispiel:

Äußere und innere Konturlinien, sowie Löcher sollen für die Auswertung irrelevant sein, aber alle Oberflächendefekte sollen detektiert werden.

Nach Maskierung werden nur die nicht markierten Bereiche innerhalb der ROI des Detektors für die Auswertung herangezogen. Die gelb markierten Bereiche sind maskiert und damit nicht mehr relevant für die Auswertung.

Abbildung: Muster / Suchbereich bearbeiten

Bedienung:

Parameter | Funktion
Cursor (Form) | Ändern der Form des Cursors (Quadrat, Kreis oder Linie). Mit der Einstellung: "Cursor = Linie", springt die Winkellage der Linie, bei gleichzeitig gedrückter Shift- Taste, in 15° Schritten.
Cursorgröße | Ändern der Größe des Cursors (Mögliche Einstellung 1-500, auch durch z.B. Mausrad)
Pixel hinzufügen / Pixel entfernen | Auswahl, ob der Cursor Pixel zur Bildverarbeitung hinzufügt oder ausschließt
Alles hinzufügen | Fügt alle Pixel der Bildverarbeitung hinzu
Alles entfernen | Schließt alle Pixel von der Bildverarbeitung aus
Alles invertieren | Invertiert alle Pixel
Rückgängig | Macht die letzte Aktion rückgängig
Wiederherstellen | Stellt die zuletzt rückgängig gemachte Aktion wieder her
Anzeige | Wählt den Anzeigemodus (Vergrößern / Verkleinern)

Durch die flexible Auswahl der Cursorform- und -Größe, sowie, ob eine Aktion Pixel hinzufügt oder entfernt, können sehr einfach und schnell komplexe geometrische oder frei geformte Bereiche definiert werden, die für die Prüfung relevant sind oder nicht berücksichtigt werden (gelb).

Bei den verschiedenen Detektortypen sind folgende Einstellungen für die Nutzung der Funktion „Muster bearbeiten“ nötig.

Detektortyp | Nötige Einstellung zur Bearbeitung des Musters
Mustervergleich, Kontur | Generell möglich mit „Muster bearbeiten“
Kontrast, Helligkeit, Graustufe, BLOB, Farbwert, Farbfläche, Farbliste | Suchbereich „Freiform“ auswählen

Maskierung von Such- und Einlernbereichen, Beispiele

Anpassung des Suchbereichs an das Objekt für Detektoren Kontrast, Helligkeit und Grauschwelle

Für die oben genannten Detektoren gibt es drei Formen für den Suchbereich: Kreis, Rechteck und Freiform. Sollte mit Kreis bzw. Rechteck, das über den Kontrollpunkt an dem Pfeil auch gedreht werden kann, der Arbeitsbereich nicht gut genug an das Objekt angepasst werden können, dann den Freiform-Suchbereich verwenden. Damit lassen sich beliebige Suchbereichsgeometrien erstellen. Der Cursor zur Bearbeitung des Suchbereichs kann als Quadrat oder als Kreis in beliebig einstellbarer Größe gewählt werden. Es folgen einige Beispiele für Freiform -Suchbereiche mit kurzer Beschreibung, wie diese im Freiform-Editor erzeugt wurden.

Beispiel 1

Kreise mit relevanten Bereichen.

Abbildung: Muster bearbeiten 2

Erzeugt durch einen hinzufügenden und einen wegnehmenden Kreis.

Abbildung: Muster bearbeiten 3

Erzeugt durch einen hinzufügenden und einen wegnehmenden Kreis.

Beispiel 2

Nur Oberflächendefekte sind relevant, Konturlinien des Objekts werden dazu maskiert.

Abbildung: BLOB Detektor ohne Nutztung der Maskierung. Mit dem genutzten BLOB Detektor werden alle Oberflächendefekte, aber auch die äußeren und inneren Konturlinien erkannt.

Abbildung: Maskierung der Konturlinien, die nicht erkannt werden sollen = gelbe Bereiche.

Abbildung: BLOB Detektor mit Nutzung der Maskierung. Nur Oberflächendefekte werden erkannt, alle im Maskierungsbereich liegenden Konturlinien / Objekte werden nun nicht mehr erkannt.


Detektor Kontur

Dieser Detektor eignet sich zur Erkennung von Konturen anhand von Kanten. Die Konturen des Objekts im Suchfeld werden beim Einlernen auf dem Sensor gespeichert. Im Run-Modus sucht der Sensor die Position der größten Übereinstimmung mit der eingelernten Kontur im aktuellen Bild. Ist die Übereinstimmung größer als der eingestellte Schwellwert, wird das Objekt als gut erkannt. Die Konturerkennung ist komplett drehlagentolerant, d.h. das gesuchte Objekt darf in beliebiger Lage im Bild erscheinen (Winkeleinstellung entsprechend wählen!).

Nächste Themen:

Reiter Farbkanal

Reiter Kontur

Reiter Konturoptimierung

Reiter Ergebnisoffset

Reiter Mehrfacherkennung

Funktion: Muster/Kontur bearbeiten (Kontur)


Reiter Kontur

Im Reiter Kontur können die wichtigsten Parameter zur Konturerkennung eingestellt werden.

Abbildung: Detektor Kontur, Reiter Kontur

Die rechts unten hellblau eingezeichneten Kanten (kontrastreiche Übergänge im Bild) wurden auf Grund der getätigten Parametereinstellungen identifiziert und eingezeichnet. Diese können durch Veränderung der Parameter bzw. durch die Funktion „Kontur bearbeiten“ weiter verändert werden. Der SBS Vision-Sensor sucht diese Kontur nun im Bild innerhalb des Suchbereiches (gelber Rahmen).

Folgende Parameter können im Reiter Kontur eingestellt werden:

Parameter | Funktion
Schaltschwelle | Bereich für die geforderte Übereinstimmung der gefundenen Kontur mit der eingelernten Kontur
Winkelbereich | Winkelbereich, in dem gesucht wird (großer Bereich bedeutet längere Bearbeitungszeit)
Skalierung | Erkennung auch von vergrößerten oder verkleinerten Objekten im angegebenen Skalierungsbereich
Kontur | Zeigt die eingelernte Kontur (roter Rahmen im Sichtfeld)
Kontur bearbeiten | Über den Parameter „Kontur bearbeiten“ können Bereiche der eingelernten Kontur ausgeblendet werden. Wie mit einem Radierer können im Suchbereich die Bereiche entfernt werden, die für die Auswertung nicht benötigt werden. Über die Auswahl "Alles Invertieren" kann die Einstellung auch invertiert werden. Nächstes Thema:Funktion: Muster/Kontur bearbeiten
Sperren | Sperren / Entsperren der Kontur: Im gesperrten Zustand ist die eingelernte Kontur gegen (unbeabsichtigte) Änderung, z.B. durch versehentliche Anpassung der Einlernbereichs, geschützt. Entsperren, um Kontur zu ändern.

Weitere Informationen:

Optimierung der Ausführungsgeschwindigkeit

  • Suchbereich für Position (gelber Rahmen) nur so groß wie nötig.
    Beachte: Suchbereich gibt den Bereich an, in dem der Schwerpunkt der Kontur gesucht wird.
  • Suchbereich für Winkel nur so groß wie nötig
  • Suchbereich für Skalierung nur so groß wie nötig

  • Auflösung von VGA auf QVGA verringern

    Achtung:

    Der globale Parameter, wirkt auf alle Detektoren
  • Setze "genau - schnell" auf schnell
  • Wert für „Min Kontrast Modell“ erhöhen. In der Anzeige des Musters überprüfen, ob die relevanten Konturen noch vorhanden sind.
  • Wert für „Min Kontrast Bild“ erhöhen.
  • Insbesondere im Fall von Lagenachführung: Alternatives Suchmuster verwenden. Beispielsweise mit höherem Kontrast, so dass „Min Kontrast Modell“ und „Min Kontrast Bild“ erhöht werden können.

Robuste Erkennung:

  • Suchbereich für Position (gelber Rahmen) ausreichend groß?
  • Suchbereich für Winkel ausreichend groß?
  • Suchbereich für Skalierung ausreichend groß?
  • Kontrast für das Model und Bild ausreichend (Für das Model ersichtlich in der Probe)?
  • Setze "genau - schnell" auf schnell
  • Sind im Bild mehrere, sich überlappende Instanzen des Musters vorhanden
  • Markante Kanten in Muster vorhanden? Gegebenenfalls Muster neu einlernen, so dass markante Kanten im eingelernten Muster liegen.
  • „Min Kontrast Muster“ geeignet gewählt? Werden im eingelernten Muster die relevanten Konturen nicht angezeigt, so ist „Min Kontrast Muster“ zu verkleinern. Werden zu viele Konturen angezeigt, so ist „Min Kontrast Muster“ zu erhöhen.
  • „Min Kontrast Bild“ für aktuelles Bild geeignet gewählt? Hat das aktuelle Bild einen kleineren / größeren Kontrast als das eingelernte Muster, so ist „Min Kontrast Bild“ kleiner / größer als „Min Kontrast Muster“ zu wählen.
  • Wenn im eingelernten Muster die Konturlinien nicht komplett sichtbar sind: Verminderung "Min Kontrast Muster". Wenn zu viele Konturlinien sichtbar sind: Erhöhung "Min Kontrast Muster".
  • Muster an falscher Position gefunden? Falls eingelerntes Muster nicht eindeutig ist, neues Muster einlernen.
  • Ergebniswert schwankt von Bild zu Bild? Gegebenenfalls dafür sorgen, dass keine „falschen“ Konturen im Bild eingelernt werden (Kanten aufgrund von Schatten oder Konturenfragmente, die im Konturmodell nicht erwünscht sind). Dies kann durch Erhöhung „Min Kontrast Modell“ erreicht werden. Mit Hilfe von „Kontur bearbeiten“ können Suchbereiche ausgeblendet werden

Parameter Winkelbereich: Drehsinn Winkel

Abbildung: Drehsinn "Winkel"

Nächstes Thema:

Reiter Konturoptimierung


Reiter Konturoptimierung

Im Reiter "Konturoptimierung" können weitere Einstellungen zum Kantenübergang und dem Kontrast vorgenommen werden.

Abbildung: Detektor Kontur, Reiter Konturoptimierung

Folgende Parameter können im Reiter "Konturoptimierung" eingestellt werden:

Parameter | Funktion
Min. Kontrast Modell | Minimal geforderter Kontrast beim eingelernten Modell, bei dem eine Kante als solche akzeptiert wird.
Min. Kontrast Bild | Minimal geforderter Kontrast im aktuellen Bild, bei dem eine Kante als solche akzeptiert wird.

Kantenübergang

  • wie eingelernt
  • wie eingelernt und invertiert
  • flexibel

Mit dem Parameter "Kantenübergang" kann der Übergang zwischen Objekt bzw. Kontur und Hintergrund bestimmt werden. Dabei wird ausgewählt, ob die Kontur nur auf dem eingelernten Hintergrund ("wie eingelernt"), auf dem eingelernten und invertierten Hintergrund ("wie eingelernt und invertiert") oder bei beliebigem Hintergrund ("flexibel") erkannt werden soll.

Mehr dazu finden Sie unter "Weitere Informationen:".
Auto | Automatische Einstellung

Weitere Informationen:

Closed Kantenübergang

Beispiel:

Ein graues Objekt wird, wie in der nachfolgenden Abbildung gezeigt, vor einem hellerem Hintergrund eingelernt.

Abbildung: Eingelernte Kontur vor einem hellen Hintergrund

Die nachfolgende Tabelle zeigt, wie sich der Konturdetektor bei der jeweiligen Einstellung für den Kantenübergang verhält.

Einstellung für den Parameter "Kantenübergang" | Heller Hintergrund | Dunkler Hintergrund | Uneinheitlicher Hintergrund
wie eingelernt |  |  |
 | Konturdetektor: I.O. | Konturdetektor: N.i.O. | Konturdetektor: N.i.O.
wie eingelernt und invertiert |  |  |
 | Konturdetektor: I.O. | Konturdetektor: I.O. | Konturdetektor: N.i.O.
flexibel |  |  |
 | Konturdetektor: I.O. | Konturdetektor: I.O. | Konturdetektor: I.O.

Nächste Themen:

Reiter Ergebnisoffset

Reiter Geschwindigkeit


Reiter Geschwindigkeit

Die Ausführungsgeschwindigkeit wird über die einstellbaren Parameter der Geschwindigkeit beeinflusst. Die Suche wird entweder weniger fein durchgeführt, d.h. früher abgebrochen und ist damit schneller, oder es werden auch feinere Details bei der Suche berücksichtigt, d.h. länger gesucht und die Suche ist damit langsamer.

Abbildung: Detektor Kontur, Reiter Geschwindigkeit

Folgende Parameter können im Reiter "Geschwindigkeit" eingestellt werden:

Parameter | Funktion
Schrittweite Winkel | Empfindlichkeit der Suche über den gewählten Winkelbereich in Grad [°]
Schrittweite Skalierung | Empfindlichkeit der Suche über den gewählten Skalierungsbereich

Suchstufen

(genau - schnell)

Anzahl der Suchstufen

  • Großer Wert: Schnelle Suche = riskanter (Kandidaten übersehen)
  • Kleiner Wert: Langsame Suche = risikoärmer (alle Kandidaten)

Übereinstimmungsgrad

(genau - schnell)

Kandidaten mit Übereinstimmungsgrad unterhalb des angegebenen Werts werden bereits bei der Suche verworfen.

  • Großer Wert: Frühes Verwerfen = schneller = riskanter
  • Kleiner Wert: Spätes Verwerfen = langsamer = risikoärmer

Falls die Suche fehlschlägt, kann der Wert verkleinert werden (genauer).

Auto | Automatische Einstellung

Nächstes Thema:

Reiter Mehrfacherkennung


Reiter Mehrfacherkennung

Die Mehrfacherkennung identifiziert Objekte, deren Kontur mit der eingelernten Kontur übereinstimmt. Dabei werden maximal so viele Objekte identifiziert und ausgegeben, wie im Parameter „Max. Anzahl Objekte“ angegeben werden. Die Ausgabe der Objektergebnisse wird nach eingestelltem Kriterium in absteigender oder aufsteigender Reihenfolge sortiert.

Abbildung: Detektor Kontur, Reiter Mehrfacherkennung

Des Weiteren ist es möglich, mit dieser Funktion Objekte im Bild zu zählen. Die Anzahl der gefundenen Objekte kann als Telegramm ausgegeben werden. Die Mindest- und Höchstanzahl an tolerierten Objekten kann mit dem Parameter "Anzahl Objekte" angegeben werden. Liegt die Anzahl der gefundenen Objekte außerhalb dieses Bereichs wird das Detektorergebnis n.i.O.

Folgende Parameter können im Reiter "Mehrfacherkennung" eingestellt werden:

Parameter | Funktion
Max. Anzahl Objekte | Mit dem Parameter "Max. Anzahl Objekte" kann die maximale Anzahl der zu erkennenden Objekte eingestellt werden.
Anzahl gültiger Objekte | Dieser Parameter ermöglicht es, zu überprüfen ob die Anzahl der gefundenen Objekte innerhalb eines vorgegebenen Bereichs liegt. Liegt sie innerhalb des Bereichs ist das Detektorergebnis i.O., andernfalls n.i.O.
Sortierkriterium | Sortierkriterium, nach dem Objekte "vorsortiert" werden sollen.
  • Score
 Gesamtergebnis
  • Pos. X
 X-Position
  • Pos. Y
 Y-Position
  • Winkel
 Winkel
  • Skalierung
 Skalierung
Sortierreihenfolge | Sortierreihenfolge für das ausgewählte Sortierkriterium.
  • Aufsteigend
 Die Werte des Sortierkriteriums werden in aufsteigender Reihenfolge sortiert.
  • Absteigend
 Die Werte des Sortierkriteriums werden in absteigender Reihenfolge sortiert.
Nur gültige Kandidaten ausgeben | Ist diese Checkbox aktiviert, werden nur Objekte angezeigt und ausgegeben, deren Score-Wert über der eingestellten Schaltschwelle (Reiter "Kontur") liegt. Er kann z.B. zur Parameteroptimierung genutzt werden.


Detektor Kontrast

Nächste Themen:

Detektor Graustufe

Kontrast Applikation

Dieser Detektor bestimmt den Kontrast im ausgewählten Suchfeld. Hierzu werden alle Bildpunkte innerhalb des Suchbereichs mit ihren Grauwerten bewertet und der Kontrast berechnet. Liegt der Kontrastwert innerhalb der unter „Schaltschwelle“ eingestellten Grenzwerte wird das Ergebnis positiv. Die Lage der hellen bzw. dunklen Pixel ist hier irrelevant. Es kommt einzig auf die Spreizung von hellen und dunklen Pixeln und deren Mengenverhältnis an. Höchster Kontrast bei 50% Grauwert 0 (= schwarz) und 50% Grauwert 255 (= weiß).

Abbildung: Detektor Kontrast

Reiter Kontrast

Parameter | Funktion
Schaltschwelle | Vorgabe des Kontrastbereichs, der akzeptiert wird.
Suchbereich (Form ) | Die Form des Suchbereiches kann als Rechteck, Kreis oder als Freiform gewählt werden. Wenn Freiform gewählt wird ist „Suchbereich bearbeiten“ aktiv.
Suchbereich anpassen | Über den Parameter Suchbereich bearbeiten können Bereiche des Suchbereichs ausgeblendet werden. Wie mit einem Radierer können im Suchbereich die Bereiche entfernt werden, die für die Auswertung nicht benötigt werden. Diese markierten Bereiche können auch invertiert werden, also die Bereiche markiert werden, die für die Ausführung wichtig sind etc. S. Kapitel: Funktion: Muster/Kontur bearbeiten
Anzeige Suchbereich | Ein- / Ausschalten der Anzeige der Suchbereich- Bearbeitungen

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


Kontrast Applikation

Detektor Kontrast

Im Beispiel wird anhand eines Kontrastdetektors die Anwesenheit eines Kontaktes geprüft.

Abbildung: Kontrast, Applikationsbeispiel, positives Ergebnis

Der hoch reflektierende, d.h. helle metallische Kontakt, inmitten des ihn umgebenden schwarzen Kunststoffgehäuses, wird mit einem Kontrastdetektor auf Anwesenheit geprüft. Da in diesem Bereich der Kontrast sehr hoch ist, liefert der Detektor einen hohen Wert und somit im Zusammenspiel mit einer Lagenachführung ein zuverlässiges Ergebnis.

Abbildung: Kontrast, Applikationsbeispiel, negatives Ergebnis

Wird derselbe Detektor an einer Stelle eingesetzt, an der der Kontakt fehlt, liefert der Detektor ein negatives Ergebnis. Da zwischen der schwarzen Umgebung und dem nun sichtbaren schwarzen Hintergrund des Kontakts der Kontrast zu gering ist.

Funktion Detektor Kontrast

Die dunklen und hellen Pixel werden nach Anzahl und Hell- bzw. Dunkelintensität bewertet.

Die Lage der hellen bzw. dunklen Pixel im Suchbereich ist irrelevant.

Abbildung: Kontrast Beispiele

Abbildung: Kontrast Erläuterung


Detektor Graustufe

Nächste Themen:

Detektor Helligkeit

Graustufe Applikation

Bei diesem Detektor wird im ersten Schritt mit den beiden Limitschiebern des Parameters „Grauschwelle“ der Wertebereich der Grauwerte festgelegt, die im Suchbereich auftreten dürfen.

Im zweiten Schritt wird unter „Schaltschwelle“ der Flächenanteil (in %) des Suchbereiches definiert, der die in Schritt 1 definierten Grauwerten aufweisen muss, um ein positives Ergebnis zu liefern.

Durch die jeweilige Invertierung können alle denkbaren Kombinationen eingestellt werden, auch solche bei denen z.B. nur Grauwerte am oberen und unteren Rand des Wertebereichs zulässig sind. Die Lage der hellen bzw. dunklen Pixel ist hier irrelevant.

Unter „Einzeichnungen“ können als Auswahlhilfe die Pixel, die einen Grauwert innerhalb (Gültige Pixel) oder außerhalb (Ungültige Pixel) der Grauwertbereichsfestlegung unter „Grauschwelle“ aufweisen, farbig markiert werden. So können sehr leicht z.B. Störpixel / Bereiche, die nicht vom Grauwertbereich abgedeckt sind erfasst werden.

Reiter Grauschwelle

Parameter | Funktion
Grauschwelle | Wertebereich in dem die Grauwerte akzeptiert werden
Schaltschwelle | Prozentualer Anteil der Fläche, die die unter „Grauschwelle“ definierten Grauwerte aufweisen muss
Suchbereich (Form) | Die Form des Suchbereiches kann als Rechteck, Kreis oder als Freiform gewählt werden. Wenn Freiform gewählt wird, ist „Suchbereich bearbeiten“ aktiv.
Einzeichnung | Auswahl der Pixel, die einen Grauwert innerhalb (Gültige Pixel) oder außerhalb (Ungültige Pixel) der Grauwertbereichsfestlegung unter „Grauschwelle“ aufweisen. Diese werden dann aus Auswahlhilfe farbig markiert. So können sehr leicht z.B. Störpixel / Bereiche, die nicht vom Grauwertbereich abgedeckt sind erfasst werden.
Suchbereich bearbeiten | Über den Parameter Suchbereich bearbeiten können Bereiche des Suchbereichs ausgeblendet werden. Wie mit einem Radierer können im Suchbereich die Bereiche entfernt werden, die für die Auswertung nicht benötigt werden. Diese markierten Bereiche können auch invertiert werden, also die Bereiche markiert werden, die für die Ausführung wichtig sind etc. S. Kapitel: Funktion: Muster/Kontur bearbeiten
Anzeige Suchbereich | Ein- / Ausschalten der Anzeige der Suchbereich- Bearbeitungen

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


Graustufe Applikation

Detektor Graustufe

Abbildung: Graustufe, Applikationsbeispiel, positives Ergebnis

Kontakt im Suchbereich vorhanden. Hohe Reflexion des Metallteiles bringt Grauwerte im Bereich > 192, d.h. innerhalb der geforderten Schwellwerte = positives Ergebnis

Abbildung: Grauschwelle, Applikationsbeispiel, negatives Ergebnis

Kontakt (hohe Reflexion des Metallteiles) im Suchfeld nicht vorhanden. D.h. Mittelwert der Grauwerte im Suchbereich nicht innerhalb der Schwellwerte (nicht innerhalb Grauwert 192-255, eher im Bereich < 50). Ergebnis: Negativ = Kontakt nicht gefunden.

Hinweis zur Bestimmung der Grauwerte:

In der Statuszeile am unteren Bildrand wird im zweitletzten Feld rechts beim Platzieren des Cursors irgendwo im Bildbereich die entsprechende X- und Y- Koordinate und der Grauwert („I“ = Intensity) angezeigt.

Funktion Detektor Grauschwelle

Mit den beiden Limits des Schiebereglers Grauschwelle wird der zulässige Grauwertbereich definiert.

Alle Pixel, die innerhalb dieses Grauwertbereichs und innerhalb des definierten Arbeitsbereiches (gelber Rahmen) liegen werden aufsummiert. Das Verhältnis der Anzahl aller Pixel im Arbeitsbereich (gelber Rahmen) und der Anzahl der Pixel im akzeptierten Grauwertbereich repräsentiert das Ergebnis dieses Detektors.

Liegt dieses Ergebnis innerhalb der Limits, die am Schieberegler Schaltschwelle eingestellt sind, ist das Ergebnis positiv.

Die Position der Grauwertpixel im Bild spielt dabei keine Rolle.

Beispiel: (bei Einstellung des Schiebereglers Grauschwelle auf sehr dunkle Werte):

Die beiden Bilder liefern beim Detektor Grauschwelle genau das gleiche Ergebnis, da jeweils 9 von 25 Pixeln als dunkel erkannt werden.

Abbildung: Grauschwelle, Beispiel 1

Angenommen der Schwellwert in diesem Beispiel wäre auf 10 eingestellt, würden folgende Bilder zu einem positiven Ergebnis führen.

Abbildung: Grauschwelle Beispiel 2


Detektor Helligkeit

Nächste Themen:

Detektor Barcode

Helligkeit Applikation

Dieser Detektor bestimmt den Mittelwert der Grauwerte im Suchbereich. Mit den beiden Schwellwert-Schiebern des Parameters „Schaltschwelle“ wird der zulässige Bereich für diesen Helligkeits- Mittelwert eingestellt. Sobald sich der berechnete Mittelwert innerhalb dieser beiden Schwellwerte bewegt ist das Ergebnis positiv. Das Ergebnis wird auf % normiert. Die Lage der hellen bzw. dunklen Pixel im Suchbereich ist irrelevant. Detektor kann dann wirkungsvoll eingesetzt werden, wenn die Position des gesuchten Objektes im Bild von Prüfung zu Prüfung absolut unverändert ist, oder, falls Abweichungen in der Position auftreten können, muss die Lagenachführung verwendet werden.

Reiter Helligkeit

Parameter | Funktion
Schaltschwelle | Vorgabe des Helligkeitsbereichs, der akzeptiert wird
Suchbereich (Form) | Die Form des Suchbereiches kann als Rechteck, Kreis oder als Freiform gewählt werden. Wenn Freiform gewählt wird, ist Suchbereich bearbeiten aktiv.
Suchbereich bearbeiten | Über den Parameter „Suchbereich bearbeiten“ können Bereiche des Suchbereichs ausgeblendet werden. Wie mit einem Radierer können im Suchbereich die Bereiche entfernt werden, die für die Auswertung nicht benötigt werden. Diese markierten Bereiche können auch invertiert werden. Es werden somit die Bereiche markiert, die für die Ausführung wichtig sind. S. Kapitel: Funktion: Muster/Kontur bearbeiten
Anzeige Suchbereich | Ein- / Ausschalten der Anzeige der Suchbereich- Bearbeitungen

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


Helligkeit Applikation

Detektor Helligkeit

Der Detektor Helligkeit berechnet den Mittelwert der Grauwerte aller Pixel im Suchbereich.

Abbildung: Helligkeit, Applikationsbeispiel, positives Ergebnis

Kontakt ist an gesuchter Stelle vorhanden und der Mittelwert der Grauwerte im Suchbereich liefert deshalb einen sehr hohen Wert (nahe 100%). Damit ist der aktuelle Wert innerhalb der geforderten Schaltschwellen und das Ergebnis ist positiv = Kontakt vorhanden.

Abbildung: Helligkeit, Applikationsbeispiel, negatives Ergebnis

Kontakt ist an gesuchter Stelle nicht vorhanden und der Mittelwert der Grauwerte im Suchbereich liefert deshalb einen sehr niedrigen Wert (nahe 0%). Damit ist der aktuelle Wert nicht innerhalb der geforderten Schaltschwellen und das Ergebnis ist negativ = Kontakt nicht vorhanden.

Beispiele: Helligkeitswert als Mittelwerte der Grauwerte

Abbildung: Helligkeit, Beispiele


Detektor BLOB

Mit dem BLOB Detektor können ein oder mehrere Objekte, die gemeinsame Merkmale wie gleiche Grauwertbereiche, gleiche Fläche, gleichen Umfang, etc. aufweisen, identifiziert und gezählt werden.

Reiter Farbkanal

Reiter Binarisierung, Absolute Schaltschwelle

Reiter Binarisierung, Dynamische Schaltschwelle

Reiter Merkmale

Reiter Sortierung

BLOB Einleitung

"BLOB" Abkürzung (engl.) für "Binary Large OBject" oder "Binary Labeled OBject".

Grundfunktion der Bildverarbeitung zur Bewertung von zusammenhängenden Flächen und Objekten in einem Bild.

Unterscheidung der einzelnen Objekte anhand von einfachen Merkmalen, wie z.B. Fläche, Breite, Höhe, etc.

Abbildung: Schrauben 1. Binarisiert, 2. als BLOB / Objekt erkannt

Typische Anwendungen

  • Zählen von Objekten
  • Unterscheidung / Klassifikation von Objekten im Bild anhand von:
  • Größe, Fläche, Kontur
  • Form, Geometrie
  • Position, Orientierung
  • Lage, Seite
  • Oberflächenprüfung

Abbildung: Typische Anwendungen: Zählen, Klassifizieren / Sortieren, Lage / Seite

BLOB, einfache Konfiguration in 3 Schritten

1. Binarisierung

Trennung zwischen Hintergrund und relevanten Objekten

Reiter Binarisierung, Absolute Schaltschwelle

Reiter Binarisierung, Dynamische Schaltschwelle

2. Filterung der erkannten BLOBs

Anhand verschiedener Merkmale wie: Fläche, Umfang, Orientierung, Lage, etc.

Reiter Merkmale

3. Datenausgabe

Definition des Telegramms und Sortierung der Ergebnisse

Reiter Sortierung

Reiter Datenausgabe


Reiter Binarisierung, Absolute Schaltschwelle

Detektor BLOB

In diesem Reiter können alle Parameter für die Binarisierung eines BLOBs gesetzt werden.

Die Binarisierung ist der erste Schritt bei der BLOB Auswertung und wird eingesetzt, um relevante Objekte vom Hintergrund des Bildes zu trennen. Dies geschieht durch Umwandlung des Grauwertbildes in ein reines Schwarz-/Weiß- Bild, d.h. binäres Bild.

Es stehen zwei Binarisierungs- Methoden zur Verfügung.

Abbildung: Detektor BLOB, Reiter Binarisierung

In der ersten Auswahlbox wird die Binarisierungsmethode ausgewählt.

Parameter | Funktion
Absolute Schaltschwelle | Die Binarisierungs- Schaltschwelle wird auf einen absoluten Grauwert im Wertebereich von 0 ... 255 eingestellt.
Dynamische Schaltschwelle | Die Dynamische Schaltschwelle wird automatisch bei jedem Bild auf eine nach statistischen Methoden optimierte Position eingestellt, um möglichst gut zwischen Vorder- und Hintergrund unterscheiden zu können. Reiter Binarisierung, Dynamische Schaltschwelle

Parameter bei Auswahl "Absolute Schaltschwelle"

Parameter | Funktion
Absolute Schaltschwelle | Die obere und untere Schwelle definiert den Bereich gültiger Grauwerte, der Pixel, die zum jeweiligen BLOB zugeordnet werden.
Grauwertbereich | Einstellung der oberen und unteren Schwelle der Grauwerte für die Binarisierung.
Invertierungsbutton | Mit dem Invertierungsbutton (Default: rot/grün/rot) kann die Logik für die Auswertung invertiert werden. Damit kann der relevante Bereich eingeschlossen oder ausgeschlossen werden.
Pipette Button | Durch Klick auf den "Pipette Button" wechselt der Cursor in ein Pipette- Symbol. Wird nun der Cursor bewegt und auf einen Pixel innerhalb des Bildes geklickt, werden die Schwellen der "Absoluten Schaltschwelle" auf +/- 10 Grauwerte über bzw. unter dem Grauwert des ausgewählten Pixels eingestellt (Wertebereich maximal 0 ... 255).

Randobjekte, Einzeichnungen und Histogramm

Parameter

Funktion
Randobjekte

Wenn die Checkbox "Randobjekte" aktiviert ist werden die ausgewählten BLOBs / Objekte berücksichtigt, auch wenn sie nicht komplett innerhalb des gelben Suchbereichs liegen.

Bitte beachten: BLOBs werden auch als Randobjekte betrachtet wenn sie einen Bereich, der mit "Muster/Suchbereich bearbeiten" maskiert wurde, berühren, oder teilweise davon überdeckt werden (auch wenn der maskierte / ausgeblendete Bereich im Innern des Suchbereichs liegt).

Detektor BLOB, Randobjekte

Suchbereich

Die Form des Suchbereichs kann auf "Rechteck", "Kreis" oder "Freiform" eingestellt werden. Im Modus "Freiform" kann die Maskierfunktion "Suchbereich bearbeiten" genutzt, und damit nicht relevante Bereiche ausgeblendet werden.
Suchbereich bearbeiten

Mit Klick auf "Suchbereich bearbeiten" öffnet sich das Fenster zur Bearbeitung des Suchbereichs. Funktion: Muster/Kontur bearbeiten
Einzeichnungen

"Gültige BLOBs": Alle gültigen BLOBs, die die Merkmalkriterien innerhalb der eingestellten Merkmalschwellen erfüllen werden grün markiert. Ungültige BLOBs werden rot markiert.

"BLOB Kontur": Alle gültigen BLOBs, die die Merkmalkriterien innerhalb der eingestellten Merkmalschwellen erfüllen werden mit einer grünen Konturlinie markiert. Ungültige BLOBs werden nicht markiert.
Histogramm

Mit Klick auf "Histogramm" öffnet sich das Histogramm- Fenster.

Detektor BLOB, Reiter Binarisierung, Histogramm


Reiter Binarisierung, Dynamische Schaltschwelle

In diesem Reiter können alle Parameter für die Binarisierung via Dynamischer Schaltschwelle eingestellt werden. Die Dynamische Schaltschwelle kann genutzt werden wenn die gesuchten BLOBs / Objekte signifikant andere Grauwerte aufweisen als der Hintergrund, und dabei die Helligkeit / Beleuchtung über das gesamte Bild gleichmäßig fluktuiert.

Wenn sich die Bildhelligkeit gleichmäßig über das ganze Bild ändert werden die beiden Schaltschwellen automatisch bei jedem Bild nachjustiert. (Bei Nutzung von "Absolute Schaltschwelle" müssten die Schaltschwellen manuell nachjustiert werden!)

Bitte beachten:

  • Bei Nutzung der Dynamischen Schaltschwelle werden die Schwellen bei jedem neuen Bild / Auswertung neu berechnet und nachjustiert.
  • Wechselnde Beleuchtungsbedingungen oder Oberflächen- Beschaffenheit / -Reflektivität können das Ergebnis beeinflussen.

Abbildung: Detektor BLOB, Reiter Binarisierung, Dynamische Schaltschwelle

Parameter bei Auswahl "Dynamische Schaltschwelle"

Parameter | Funktion
Dynamische Schaltschwelle | Die Schaltschwelle wird automatisch bei jedem Bild auf eine nach statistischen Methoden optimierten Position eingestellt um möglichst gut zwischen Vorder- und Hintergrund unterscheiden zu können.
Polarität | Definiert ob BLOB / Objekt heller oder dunkler ist als der Hintergrund.
Grauwertbereich | Grauwertschwellen für die Binarisierung.
Korrekturfaktor für Schwellwert | Der Binarisierungsschwellwert kann über diesen Korrekturfaktor in Richtung der Vordergrund- bzw. der Hintergrund-Helligkeit verschoben werden.

Zur weiteren Veranschaulichung der dynamischen Schaltschwelle siehe Kapitel: Detektor BLOB, Reiter Binarisierung, Histogramm


Detektor BLOB, Randobjekte

Wenn die Checkbox "Randobjekte" aktiviert ist werden die ausgewählten BLOBs / Objekte berücksichtigt, auch wenn sie nicht komplett innerhalb des gelben Suchbereichs liegen. (Natürlich müssen die Objekte auch in jedem Fall die BLOB- Merkmale innerhalb der gewählten Schaltschwellen erfüllen.)

Hinweis:

BLOBs werden auch als Randobjekte betrachtet wenn sie einen Bereich, der mit "Muster/Suchbereich bearbeiten" maskiert wurde, berühren, oder teilweise davon überdeckt werden (auch wenn der maskierte / ausgeblendete Bereich im Innern des Suchbereichs liegt).

Beispiel 1: Randobjekte, berührt äußeren, gelben Suchbereich

Abbildung: Randobjekte, Beispiel 1/1: Der BLOB berührt den äußeren, gelben Suchbereich. Er wird nicht als gültiger BLOB detektiert / markiert, da "Randobjekte" NICHT aktiviert ist.

Abbildung: Randobjekte, Beispiel 1/2: Der BLOB berührt den äußeren, gelben Suchbereich. Er wird nun als gültiger BLOB detektiert / markiert, da "Randobjekte" AKTIV ist.

Beispiel 2, Randobjekte, berühren inneren, maskierten Bereich.

Abbildung: Randobjekte, Beispiel 2/1: Die BLOBs berühren die inneren, gelben, maskierten Bereiche. Sie werden nicht als gültige BLOBs detektiert / markiert, da "Randobjekte" NICHT aktiviert ist.

Abbildung: Randobjekte, Beispiel 2/2: Die BLOBs berühren zwar die inneren, gelben, maskierten Bereiche, sie werden nun aber als gültige BLOBs detektiert / markiert, da "Randobjekte" AKTIV ist.


Detektor BLOB, Reiter Binarisierung, Histogramm

In diesem Fenster wird das Histogramm der Grauwerte im gelben Suchbereich, und die gewählten Schaltschwellen angezeigt.

Im hier gezeigten Beispiel sind klare Maximas für Vorder- und Hintergrund zu erkennen. Die Schaltschwelle zu Binarisierung ist ca. in der Mitte dazwischen positioniert.

Abbildung: Detektor BLOB, Reiter Binarisierung, Histogramm


Reiter Merkmale

Im Reiter Merkmale werden die Merkmale / Filterkriterien zur Unterscheidung zwischen gültigen und ungültigen BLOBs / Objekten definiert. Nur mit gültigen BLOBs können weitere Verarbeitungsschritte erfolgen, z.B. die Datenausgabe.

Beispiel: Falls die Schwellen für das Merkmal "Fläche" auf den Bereich 100 ... 150 (Pixel) eingestellt wurden, werden nur BLOBs mit einer Fläche innerhalb dieses Bereichs als gültig erkannt (grün).

Abbildung: Detektor BLOB, Reiter Merkmale

Folgende Parameter können im Reiter "Merkmale" eingestellt werden:

Parameter

Funktion
Anzahl

Mit dem Parameter "Anzahl" kann zusätzlich zu den Merkmalen die Anzahl der gefundenen und gültigen BLOBs geprüft werden. Dazu wird eine obere und untere Schwelle für die akzeptierte Anzahl von BLOBs (max. 10.000) festgelegt.

  • Detektorergebnis positiv: Die Anzahl der gültigen (gefilterten) BLOBs liegt innerhalb des Bereichs von "Anzahl".
  • Detektorergebnis negativ: Die Anzahl der gültigen (gefilterten) BLOBs liegt außerhalb des Bereichs von "Anzahl".

Falls die Anzahl der BLOBs außerhalb der eingestellten Schwellen liegt, ist das Detektorergebnis negativ, trotzdem werden gültige BLOBs im Bild grün markiert.

Wenn der Detektor mehr als 10.000 BLOBs (Maximum) findet, wird das Detektorergebnis negativ und die Verarbeitung wird abgebrochen.

Hinweis:

Defekterkennung über Anzahl = 0

Invertierungs-Button Mit dem Invertierungs-Button (Default: rot/grün/rot) kann die Logik für die Auswertung invertiert werden. Damit kann der relevante Bereich eingeschlossen oder ausgeschlossen werden.
Pipette-Button (Anzahl)

Durch Klick auf dieses Symbol werden die beiden Schwellen von "Anzahl" auf genau die Anzahl der im Bild gefundenen BLOBs eingestellt.

Pipette-Button (Merkmal)

Durch Klick auf den "Pipette-Button" wechselt der Cursor in ein Pipette-Symbol. Wird nun der Cursor bewegt und auf ein Pixel innerhalb eines gültigen (grünen) BLOBs geklickt, werden die Schwellen des gewählten Merkmals auf +/-10% des Wertes des BLOBs, auf den geklickt wurde, eingestellt.

Beispiel: Wurde das Merkmal "Fläche" gewählt und mit Pipette aktiv auf einen Pixel innerhalb eines gültigen BLOBs geklickt, werden die beiden Schwellen für Fläche auf +/-10% der berechneten Pixelanzahl (= Fläche) des gewählten BLOBs eingestellt.

Checkbox

(Default: Aktiv)
  • Aktiv: Das Merkmal wird berechnet, gefiltert (einstellbare Schwellen) und steht zur Datenausgabe zur Verfügung.
  • Inaktiv: Merkmal wird berechnet, aber NICHT gefiltert und steht aber zur Datenausgabe zur Verfügung.

Merkmale der ersten Ebene: BLOB Typ / Geometrisches Modell

Die Merkmale der ersten Ebene (Fläche, Fläche inkl. Löcher, Konturlänge, ...) werden direkt aus den Daten des BLOBs berechnet, d.h. den zum BLOB zugehörigen Pixeln. Für weitere Merkmale wird zunächst über eine Ausgleichsgerade ein geometrisches Modell an die Daten gefittet. Die Merkmale beruhen dann auf diesem Modell und nicht direkt auf den zum BLOB gehörenden Pixeln.

Merkmal | Funktion
Fläche | Fläche des BLOBs, ohne Löcher, in Pixel. Entspricht der Anzahl der zum BLOB gehörenden Pixel.
Fläche (mit Löchern) | Fläche des BLOBs, mit Löchern, in Pixel. Entspricht der Anzahl der innerhalb der äußeren Kontur befindlichen Pixel.
Konturlänge | Anzahl der Pixel der äußeren Kontur des BLOBs.
Kompaktheit | Kompaktheit des BLOBs (idealer Kreis = 1, alle anderen > 1) Je stärker die Form des BLOBs vom idealen Kreis abweicht, desto größer wird der Wert für die Kompaktheit. Wertebereich 1 ... 100 (limitiert auf 100, BLOBs mit größeren Werten werden als ungültig markiert)
Schwerpunkt X | X- Koordinate des BLOB Schwerpunktes in Pixel. Bei Aktivierung der Kalibrierung im Bedienschritt "Job" kann die Wertausgabe auch in Weltkoordinaten, z.B. in Millimetern erfolgen.
Schwerpunkt Y | Y- Koordinate des BLOB Schwerpunktes in Pixel. Bei Aktivierung der Kalibrierung im Bedienschritt "Job" kann die Wertausgabe auch in Weltkoordinaten, z.B. in Millimetern erfolgen.

BLOB Typ / Geometrisches Modell | Funktion
Einige Merkmale werden berechnet auf der Basis eines gegebenen geometrischen Modells. Zum Beispiel basiert die Exzentrizität auf dem Ellipsen-Fit des Objekts.
Rechteck, achsparallel (R1) | Umschließendes Rechteck parallel zur Y- und X- Achse. Ausreißer werden nicht eliminiert.
Rechteck, minimale Fläche (R2) | Umschließendes Rechteck mit kleinster Fläche. Ausreißer werden nicht eliminiert.
Kreis, fit (C1) | Kreis, fit, nicht umschließend, Ausreißerkorrektur (robust gegenüber Ausreißern)
Ellipse, äquivalent (E1) | Äquivalente Ellipse, basierend auf den Momenten der Fläche.

Merkmale / Zweite Ebene: BLOB Typ Parameter

Merkmal | Relevant für | Funktion | Möglichkeit der Werteausgabe in Weltkoordinaten [mm] bei Aktivierung der Kalibrierung
Zentrum X | R1, R2, C1, E1 | X- Koordinate des Zentrums des gefitteten, geometrischen Elements (Rechteck, Kreis, Ellipse) | ü
Zentrum Y | R1, R2, C1, E1 | Y- Koordinate des Zentrums des gefitteten, geometrischen Elements (Rechteck, Kreis, Ellipse) | ü
Breite | R1, R2, E1 | Breite des geometrischen Elements. Breite ≥ 0, Breite ≥ Höhe. Die Orientierung wird so bestimmt, dass die Breite immer größer als die Höhe ist. (Ausnahme: R1, Rechteck, achsenparallel: Breite immer in horizontaler Richtung = parallel zur X- Achse) | ü
Höhe | R1, R2, E1 | Höhe des geometrischen Elements. Höhe ≥ 0, Höhe ≤ Breite. Die Orientierung wird so bestimmt, dass die Breite immer größer als die Höhe ist. (Ausnahme: R1, Rechteck, achsenparallel: Höhe immer in vertikaler Richtung = parallel zur Y- Achse) | ü
Winkel (180) | R2, E1 | Orientierung der Breite (lange Achse) des Objekts in Grad (°), (Bereich -90... +90°, 0° = Ost, Gegenuhrzeigersinn). Siehe auch: Merkmal Winkel |
Winkel (360) | R2, E1 | Orientierung der Breite (lange Achse) des Objekts in Grad (°), (Bereich -180 ... +180°, 0° = Ost, Gegenuhrzeigersinn). Siehe auch: Merkmal Winkel |
Achsenverhältnis | E1 | Verhältnis der langen zur kurzen Achse (a/b) |
Bauch / Rücken, Fläche | E1 | Bauch / Rücken-Unterscheidung, basierend auf Fläche, durch Vorzeichen angezeigt. Siehe auch: Merkmal "Bauch / Rücken" |
Radius | C1 | Gibt den Radius des gefitteten Kreises an. | ü
Abweichung, innen | C1 | Liefert die größte Abweichung zwischen der BLOB-Kontur und der Kontur des geometrischen Elements (Abweichung in den gefitteten Kreis hinein). Siehe auch: Merkmal Abweichung | ü
Abweichung, außen | C1 | Liefert den größten Abstand zwischen der BLOB-Kontur und der Kontur der geometrischen Form (Abweichung aus dem gefitteten Kreis heraus). Siehe auch: Merkmal Abweichung | ü
Abweichung, mittlere | C1 | Liefert den Mittelwert des Betrags aller Innen- und Außenabweichungen zwischen der BLOB-Kontur und der Kontur der geometrischen Form. Siehe auch: Merkmal Abweichung | ü

Weitere Informationen:

Closed Merkmal Winkel

Mit dem Merkmal "Winkel (180)" und "Winkel (360)" kann die Orientierung des Objekts bestimmt werden. Der Winkel gibt immer die Orientierung der Breitenachse an (Breite ist die längste Seite eines Objekts). Die Winkel werden in [Grad °] angegeben.

Das Merkmal "Winkel (180)" hat eine Orientierungsreichweite von -90° bis +90°, wie die folgende Abbildung zeigt.

Abbildung: Drehsinn "Winkel (180)"

Das Merkmal "Winkel (360)" ist abhängig von der ausgewählten geometrischen Form (z. B. E1 Ellipse, R2 Rechteck minimale Fläche, etc.). Es hat eine Orientierungsreichweite von -180° bis +180°, wie die folgende Abbildung zeigt.

Abbildung: Drehsinn "Winkel (360)"

Im Unterschied zum Merkmal "Winkel (180)" wird beim Merkmal "Winkel (360)"die Orientierung der Breitenachse in Abhängigkeit eines Vektors festgelegt. Dieser Vektor gibt die Richtung zum Konturpunkt mit der längsten Distanz zum Zentrum und der Orientierung (180°) des Vektorpunkts zur gleichen Seite an. Ob ein Objekt in der Halbebene (-90° ... +90°) oder in (-180° ...-90°; 90°...180°) liegt wird dadurch bestimmt, in welcher Halbebene dieser Vektor liegt. Die nachfolgenden Abbildungen zeigen zwei Beispiele zur Winkelbestimmung des Merkmals "Winkel (360)".

Abbildung: Beispiel 1 Winkel (360) mit +45°

Abbildung: Beispiel 2 Winkel (360) mit -135°

Closed Merkmal Abweichung

Das Merkmal Abweichung berechnet Maße, die die Abweichung des tatsächlichen Objekts vom gefitteten Modell quantitativ beschreiben. Die Merkmale "Abweichung, innen", "Abweichung, außen" und "Abweichung, mittlere" beurteilen Einkerbungen und herausragende Elemente der BLOB-/Objektkontur. Die Abweichungen beziehen sich immer auf den gefitteten Kreis. Alle Einkerbungen in den gefitteten Kreis hinein sind "Abweichungen, innen". Alle Elemente, die aus dem gefitteten Kreis herausragen, werden von dem Merkmal "Abweichung, außen" beurteilt. Die Orientierungsrichtungen der Merkmale sind in der folgenden Abbildung grafisch dargestellt.

Abbildung: Orientierungsrichtung "Abweichung, innen" und "Abweichung, außen"

Im Reiter "Ergebnis" der SBS Software wird pro gefittetem Kreis immer der Wert der größten Abweichung nach innen und der Wert der größten Abweichung nach außen angezeigt (sofern sie "Aktiv" gesetzt sind).

Das Merkmal "Abweichung, mittlere" gibt den Mittelwert der Beträge der Abweichungen zu allen Positionen, d.h. zu allen Pixeln des gefitteten Kreises an.

Beispiel zur Beurteilung der mittleren Abweichung

Gezackte Elemente werden auf das Merkmal "Abweichung, mittlere" untersucht, siehe Abbildung "Abweichung, mittlere".

Abbildung: Abweichung, mittlere

Das Merkmal "Abweichung, mittlere" berechnet alle Abweichungen vom gefitteten Kreis (Grün) zur Kontur des Objekts/BLOBs (Cyan) pro Pixel des gefitteten Kreises nach innen und außen. In folgender Abbildung ist ein gezoomter Ausschnitt des Kreises mit der Nummer "2" aus der vorhergehenden Abbildung zu sehen. Die roten Pfeile zeigen die Abweichungen pro Pixel des gefitteten Kreises zur BLOBkontur. Die Beträge aller ermittelten Werte werden gemittelt und bilden das Ergebnis für das Merkmal "Abweichung, mittlere".

Abbildung: Abweichung, mittlere: Kreis 2 gezoomt

Beispiel zur Beurteilung der Abweichungen von Kreisen nach innen und außen

Sechs Kreise mit unterschiedlichen Einkerbungen und herausstehenden Elementen sind auf die Merkmale "Abweichung, innen" und "Abweichung, außen" zu untersuchen.

Zur besseren Darstellung wird im Reiter "Binarisierung" des Detektors "BLOB" die Einzeichnung "BLOB Kontur" gewählt. Der Detektor zeichnet nun die Konturen aller im Suchfeld liegenden Kreise türkis ein.

Im Reiter "Merkmal" werden die Merkmale:

  • "C1 Kreis, fit" (Merkmal erste Ebene), "Abweichung, innen" (Merkmal zweite Ebene)
  • "C1 Kreis, fit" (Merkmal erste Ebene), "Abweichung, außen" (Merkmal zweite Ebene)
  • "C1 Kreis, fit" (Merkmal erste Ebene), "Abweichung, mittlere" (Merkmal zweite Ebene)

ausgewählt.

Im Reiter "Ergebnis" können nun die Ergebnisse der Merkmale pro Kreis ausgelesen werden, siehe auch folgende Abbildung. (Hinweis: Die Ergebnisse können zugeordnet werden, indem die Kreise im Bildfeld mit der Maus abgefahren werden.)

Abbildung: Ergebnisse "Abweichung, innen", "Abweichung, außen" und "Abweichung, mittlere"

Die untenstehende Abbildung dient der Zuordnung und Interpretation der Ergebnisse aus dem obenstehenden Screenshot.

Abbildung: Ergebnisinterpretation von "Abweichung, innen", "Abweichung, außen" und "Abweichung, mittlere"

Closed Merkmal "Bauch / Rücken"

"Bauch/ Rücken, Fläche" und "Bauch/ Rücken, Kontur" beurteilen die Symmetrie eines BLOBs in Bezug auf eine durch die Mitte und der Ausrichtung des BLOBs bestimmte Achse. Wenn ein BLOB vollständig symmetrisch in Bezug auf diese Linie ist, wird das Ergebnis 0, sonst wird es von 0 abweichen. Das Vorzeichen des Wertes zeigt an, ob die Seite links oder rechts dieser Achse "stärker" ausgeprägt ist.

"Bauch/ Rücken, Fläche" und "Bauch/ Rücken, Kontur" können zur Unterscheidung der Bauch-/ Rücken-Lage eines Objekts verwendet werden, wie sie in vielen Bereichen der Zuführtechnik nötig ist. Anwendungen finden sich zum Beispiel an Vibrationsförderern oder in der Robotik.

Abbildung: Bauch / Rücken, Fläche oder Kontur

Das linke Bild zeigt das gesuchte Objekt auf z.B. der Bauchseite liegend. Die Schaltschwellen werden so gewählt, dass diese Bauchseitenlage zu einem positiven Ergebnis führt.

Das mittlere Bild zeigt dasselbe Objekt in Rückenlage, in der es als "nicht ok" erkannt wird.

Das rechte Bild zeigt beide Objekte in einem Bild, wobei nur das Objekt in Bauchlage als "ok" erkannt wird.

  • "Bauch/ Rücken, Fläche" zieht jeden Pixel, der zu dem BLOB gehört, für die Berechnung heran.
  • "Bauch/ Rücken, Kontur" nutzt nur die Konturpixel des BLOBs für die Berechnung. Dieses Verfahren kann verwendet werden, wenn beispielsweise das Objekt innerhalb der Kontur variiert oder Änderungen aufgrund von Reflexionen oder anderen Umwelteinflüssen unterliegt.

Die für die Berechnung verwendete Achse wird durch die Mitte und den Winkel (360°) des geometrischen Modells, das gewählt wurde, z.B. kleinstes umschließendes Rechteck (R2) oder Ellipse (E1), bestimmt.

Das geometrische Modell für die Berechnung sollte so gewählt werden, dass die Orientierung einen stabilen und eindeutigen Wert zurückliefert. So können hoch symmetrische Objekte (z.B. Rechtecke, Kreise, Quadrate oder punktsymmetrische Objekte) nicht zuverlässig mit dieser Methode bewertet werden. Für Objekte, bei denen das kleinste umschließende Rechteck keine eindeutige Orientierungsangabe liefert (z.B. „L“-förmige Geometrien), kann die Ellipse die bessere Wahl als geometrisches Modell sein.

Nächstes Thema:

Reiter Sortierung


Reiter Sortierung

Die im Reiter “Merkmale” festgelegten Merkmale Reiter Merkmalewerden für jeden BLOB berechnet. Die Ergebnisse dieser Berechnungen können über eine Schnittstelle in einem Datentelegramm an einen PC oder eine SPS versendet werden, wenn das Merkmal in der entsprechenden Reiter Datenausgabe ausgewählt wurde. Die Reihenfolge in der die Ergebnisse der einzelnen BLOBs versandt werden wird im Reiter „Sortierung“ festgelegt.

Falls z.B. das Merkmal "Schwerpunkt Y" gewählt wurde und es wurden 5 BLOBs gefunden, umfasst das ausgegebene Datentelegramm die Ergebnisse aller 5 BLOBs.

Falls als Sortierkriterium "Fläche" und als Sortierreihenfolge "absteigend" gewählt wurde, wird das Ergebnis (hier: Schwerpunkt Y) des BLOBs mit der größten Fläche zuerst ausgegeben.

Abbildung: Detektor BLOB, Reiter Sortierung

Einstellungen im Reiter Sortierung

Parameter | Funktion
Sortierkriterium | Als Sortierkriterium kann jedes unter "Detektor BLOB/Reiter Merkmale" genannte Merkmal genutzt werden.
Sortierreihenfolge | Sortierreihenfolge für das ausgewählte Sortierkriterium. Es kann "aufsteigend" oder "absteigend" sortiert werden.


Detektor Messschieber

Mit diesem Detektor können Objekte auf Maßhaltigkeit geprüft werden.

Reiter Farbkanal

Reiter Antastung

Reiter Abstand

Reiter Optimierung

Ergebnisse / Histogramm Fenster


Reiter Antastung

Hier können alle Messschieber- Parameter eingestellt, und das Ergebnis Histogramm aufgerufen werden.

Abbildung: Detektor Messschieber, Reiter Antastung

Parameter

Funktion
Antaster Typ

Auswahl des Antaster Typs:

  • Ein Antaster, beidseitig
  • Ein Antaster, einseitig
  • Zwei Antaster, antiparallel, (entgegengesetzt)
  • Zwei Antaster, gleichgerichtet
Kantenstärke

Kantenstärke / Kontrast ab welchem (0…100) eine Kante als Kante detektiert werden soll.
Glättung

Der Kantenverlauf in Suchrichtung wird geglättet. Mit größeren Werten werden verrauschte Kanten, unscharfe Kanten oder Kanten, die nicht senkrecht zur Suchrichtung stehen, sicherer erkannt. Außerdem können mit größeren Werten eng beieinander liegende Hell-Dunkel-Hell- oder Dunkel-Hell-Dunkel-Übergänge ignoriert werden. Damit lassen sich störende Kanten, z.B. Kratzer, ausblenden. Die Wirkung der Glättung kann über die Schaltfläche "Ergebnisse" grafisch dargestellt werden.
Übergang

Wahl zwischen:

  • Hell → Dunkel

  • Dunkel →Hell

  • Beide Richtungen (Hell-Dunkel und Dunkel-Hell-Übergang)
Anz. Suchstreifen | Anzahl der parallelen Suchstreifen in die, die Breite des Suchbereichs aufgeteilt wird. Die Kantenantastung wird innerhalb jedes Suchstreifens über die gesamte Breite durchgeführt. Je mehr Suchstreifen, desto eher wird die erste Kante gefunden. (Feinere Abtastung hat eine längere Ausführungszeit zur Folge)
Ergebnisse | Öffnet Ergebnis- und Histogramm- Fenster

Nächstes Thema: Reiter Abstand


Reiter Abstand

Hier können alle Parameter für den gesuchten Abstand eingestellt werden.

Abbildung: Detektor Messschieber, Reiter Abstand

Parameter

Funktion
Abstand

Abstandsbereich in Pixel. Blauer Balken: aktueller Abstandswert.
Abstandsart

Für jeden Suchstreifen wird ein Antastpunkt ermittelt. Ist die Zahl der Suchstreifen größer als 1, gibt es mehrere Möglichkeiten, aus diesen Antastpunkten ein Ergebnis zu ermitteln:

  • Maximum: Es wird der Antastpunkt ausgewählt, der den maximalen Abstand ergibt.
  • Minimum: Es wird der Antastpunkt ausgewählt, der den minimalen Abstand ergibt.
  • Mittelwert: Alle Antastpunkte werden arithmetisch gemittelt. Sollten Ausreißer vorliegen, gehen diese in das Ergebnis ein und verfälschen es.
  • Median: Die Antastpunkte werden aufsteigend sortiert und der mittlere Abstand wird verwendet. Ausreißer verfälschen das Ergebnis nicht.

Nur verfügbar für den beidseitigen Antaster " [image] "

  • Größter gegenüberliegender Abstand (eines Suchstreifens): Es werden die Antastpunkte des Suchstreifens mit dem größten Abstand ausgewählt.
  • Kleinster gegenüberliegender Abstand (eines Suchstreifens): Es werden die Antastpunkte des Suchstreifens mit dem kleinsten Abstand ausgewählt.

Weitere Informationen:

Closed Abstandsart

Informationen zum Aufbau der Kantenantastung finden Sie unter: Aufbau der Kantenantastung

Zur Ermittlung eines Abstands können im Reiter "Abstand" verschiedene Abstandsarten hinterlegt werden. In den nachfolgenden Beispielen wird der Unterschied zwischen "Minimum" und "Kleinster gegenüberliegender Abstand" sowie der Unterschied zwischen "Maximum" und "Größter gegenüberliegender Abstand" erläutert.

Folgendes Objekt wird untersucht:

Abbildung: Beispielobjekt

Für die Untersuchung wird im Reiter "Antastung" der beidseitige Antaster Typ " [image] " gewählt und die Anzahl der Suchstreifen auf 20 erhöht.

Unterschied zwischen Minimum und kleinster gegenüberliegender Abstand

Bei der Abstandsart "Kleinster gegenüberliegender Abstand" werden, im Gegensatz zu der Abstandsart "Minimum", die Antastpunkte von nur einem Suchstreifen ausgewertet. Dabei wird der Suchstreifen mit dem kleinsten Abstand zwischen den Antastpunkten ausgewählt (siehe Abbildung: Ergebnisse-Histogramm, Abstandsart "Kleinster gegenüberliegender Abstand").

Bei der Abstandsart "Minimum" wird der kleinste Abstand ermittelt, in dem die Antastlinien mit dem geringsten Abstand zueinander ausgewählt werden. Die Antastpunkte der Antastlinien können aber, im Gegensatz zur Abstandsart "Kleinster gegenüberliegender Abstand", von zwei unterschiedlichen Suchstreifen stammen (siehe Abbildung: Ergebnisse-Histogramm, Abstandsart "Minimum").

Abstandsart "Kleinster gegenüberliegender Abstand"
Kleinster gegenüberliegender Abstand ermittelt an den Antastpunkten eines Suchstreifens.

Abbildung: Ergebnisse-Histogramm, Abstandsart "Kleinster gegenüberliegender Abstand"

Abbildung: Bildausgabe mit Einzeichnung, Abstandsart "Kleinster gegenüberliegender Abstand"

Abstandsart "Minimum"
Minimaler Abstand ermittelt an den Antastlinien mit dem kleinsten Abstand zueinander. Die Antastpunkte der Antastlinien können, müssen aber nicht von nur einem Suchstreifen stammen.

Abbildung: Ergebnisse-Histogramm, Abstandsart "Minimum"

Abbildung: Bildausgabe mit Einzeichnung, Abstandsart "Minimum"

Unterschied zwischen Maximum und größter gegenüberliegender Abstand.

Das ausgewählte Beispielobjekt zeigt bei der Ermittlung des Abstandes mit der Abstandsart "Maximum" und der Abstandsart "Größter gegenüberliegender Abstand" identische Bildausgaben (siehe Abbildungen rechte Spalten in den untenstehenden Tabellen). Die Abstände werden aber nicht identisch ermittelt.

Bei der Abstandsart "Größter gegenüberliegender Abstand" werden die Antastpunkte von nur einem Suchstreifen ausgewertet. Dabei wird der Suchstreifen mit dem größten Abstand zwischen den Antastpunkten ausgewählt (siehe Abbildung: Ergebnisse-Histogramm, Abstandsart "Größter gegenüberliegender Abstand")

Bei der Abstandsart "Maximum" wird der maximale Abstand ermittelt, indem die Antastlinien mit dem größten Abstand zueinander ausgewählt werden. Die Antastpunkte der Antastlinien können aber von zwei unterschiedlichen Suchstreifen stammen (siehe Abbildung: Ergebnisse-Histogramm, Abstandsart "Maximum".

Abstandsart "Größter gegenüberliegender Abstand"
Größter gegenüberliegender Abstand ermittelt an den Antastpunkten eines Suchstreifens.

Abbildung: Ergebnisse-Histogramm, Abstandsart "Größter gegenüberliegender Abstand"

Abbildung: Bildausgabe mit Einzeichnung, Abstandsart "Größter gegenüberliegender Abstand"

Abstandsart "Maximum"
Maximaler Abstand ermittelt an den Antastlinien mit dem größten Abstand zueinander. Die Antastpunkte der Antastlinien können, müssen aber nicht von nur einem Suchstreifen stammen.

Abbildung: Ergebnisse-Histogramm, Abstandsart "Maximum"

Abbildung: Bildausgabe mit Einzeichnung, Abstandsart "Maximum"

Nächste Themen:

Reiter Optimierung


Reiter Optimierung

Im Reiter "Optimierung" können weitere Einstellungen zur Optimierung der Kantenantastung vorgenommen werden. Folgende Abbildung zeigt den Reiter Optimierung.

Abbildung: Detektor Messschieber, Reiter Optimierung

Folgende Parameter können im Reiter "Optimierung" eingestellt werden:

Parameter Funktion

Interpolation

Die Berechnung der Kantenposition kann entweder mit Subpixel-Genauigkeit (bis zu 1/10 Pixel) oder mit einfacher Genauigkeit erfolgen.

  • Genau
 Subpixel-Genauigkeit
  • Schnell
 Einfache Genauigkeit: Diese Einstellung liefert z.T. über 50% schnellere Berechnung

Nächstes Thema: Ergebnisse / Histogramm Fenster


Ergebnisse / Histogramm Fenster

Abbildung: Ergebnisse / Histogramm Fenster

Parameter

Funktion
Antaster (x)

Bild des Antasters (x) mit:

  • Grüne Linie: Ermittelte Ergebniskante
  • Grüne Kreuze: Ermittelter Kantenübergang (Antastpunkt) je Suchstreifen
  • Hellblaue bzw. hellgrüne Region: Darstellung “Ausgewählter Suchstreifen”
Kantenstärke

Histogramm mit:

  • Blaue Linie: Kontrastverlauf im Bild, abhängig von ausgewähltem Suchstreifen
  • Rote Linie: Geforderter Kontrast für Kante („Schaltschwelle“)
  • Hellblaue bzw. hellgrüne Linie: Ermittelter Kantenübergang abhängig von ausgewähltem Suchstreifen

Fit, “+”, “-“

Fit oder Zoom für „Kantenstärke-“ Histogramm
Ausgewählter Antaster Anzeige des ausgewählten Antasters
Ausgewählter Suchstreifen

Auswahl des im Antaster- Bild anzuzeigenden Suchstreifens

  • Gewinner: Gewinnersuchstreifen (abhängig von Einstellungen in Reiter „Abstand”)
  • “1, 2, ..” Nummer des darzustellenden Suchstreifens


Detektor Barcode

Nächste Themen:

Detektor Datacode

Reiter Referenzstring

Reiter Code

Abbildung: Detektor Barcode, Reiter Code

Einstellungen im Reiter Code

Parameter

Funktion

Barcode Typ

Wählen Sie hier den Typ des Barcodes aus, den Sie mit dem Code Leser lesen wollen.

Max. Stringlänge

Max. Länge eines Barcodes. Wenn der Inhalt des Codes die maximale Länge überschreitet, wird der Überhang abgeschnitten.

Beim Lesen von mehreren Codes gleichzeitig, muss dieser Wert auf die maximale Länge des längsten Codes eingestellt werden.

Prüfziffer

Dieser Parameter aktiviert die Erkennung eines Prüfzeichens falls dies im Code vorhanden. Barcodes mit Prüfzeichen sind z.B. Code 39, Codabar, 25 Industrial oder 25 Interleaved. Wird dieser Parameter nicht ausgewählt, dann wird das Prüfzeichen als normales Datenzeichen interpretiert und in der Zeichenfolge mit ausgegeben.

Min. Anzahl Codes

Minimale Anzahl der Codes, die innerhalb des Suchbereichs gelesen werden sollen.

Max. Anzahl Codes

Maximale Anzahl der Codes, die innerhalb des Suchbereichs gelesen werden sollen. Wird dieser Wert höher gewählt, als tatsächlich notwendig, so kann sich die Ausführungszeit des Detektors geringfügig erhöhen.
Anzahl Zeichen

Spezifiziert die zu erwartende Anzahl von Zeichen im Barcode. Codes mit einer abweichenden Anzahl von Zeichen werden ignoriert. Dies dient zur Erhöhung der Erkennungssicherheit wenn die Anzahl der Zeichen des Codes vorher bekannt ist.

Wenn Codes mit einer bestimmten Anzahl an Zeichen unter mehreren Codes gefunden werden sollen, dann ist der Parameter "Max. Anzahl Codes" höher zu wählen als die Anzahl der gesuchten Codes.

Textausgabe bei Fehllesung

Spezifiziert den Text, der im Falle einer Fehllesung über die Schnittstellen ausgegeben wird. Der Text erscheint nicht in der Ergebnisanzeige.

Polarität

Auswahlmöglichkeit für Druckfarbe des Codes „dunkel auf hell" oder „hell auf dunkel".

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.

Optimierung:

Ausführungsgeschwindigkeit:

  • Suchbereich für Position (gelber Rahmen) nur so groß wie nötig.

Robuste Erkennung:

  • Suchbereich (gelber Rahmen) ausreichend groß?
  • Markanter Kontrast vorhanden?
  • Wurde die Auswahl "Prüfzeichen" aktiviert, obwohl kein Prüfzeichen im Code ist?


Reiter Referenzstring

Detektor Barcode

Reiter Qualität

Abbildung: Detektor Barcode, Reiter Referenzstring

Einstellungen im Reiter Referenzstring

Parameter | Funktion
Stringvergleich | Aktiviert die Überprüfung des Inhaltes der gelesenen Informationen. Die Überprüfung des Inhaltes der gelesenen Informationen erfolgt auf Basis von regulären Ausdrücken.
Referenzstring | Dieser Text bzw. reguläre Ausdrücke wird zur Verifikation herangezogen. Hier können konkrete Zeichen stehen, die direkt verglichen werden, oder reguläre Ausdrücke, um den Aufbau des gelesenen Ergebnisses zu überprüfen. Wenn Codes mit einem bestimmten Referenzstring unter mehreren Codes gefunden werden sollen, dann ist der Parameter "Max. Anzahl Codes" im Reiter "Code" höher zu wählen als die Anzahl der gesuchten Codes.
Ausdruck hinzufügen | Öffnet eine Liste mit Vorgaben für reguläre Ausdrücke.
Referenzstring einlernen | Liest den Code, der sich gerade unter dem Code Leser befindet und übernimmt den gelesenen Inhalt als Vergleichstext. Der Text kann nachträglich noch editiert werden.

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.

Beispiele für Referenzzeichenketten definiert durch reguläre Ausdrücke:

Referenzzeichenkette | Treffer | Beispiel für Treffer
123 | Zeichenkette, die 123 enthält | 01234
\A123 | Zeichenkette, die mit 123 beginnt | 1234
123\Z | Zeichenkette, die mit 123 endet | 0123
\A123\Z | Zeichenkette, die genau 123 entspricht | 123
[123] | Zeichenkette, die eines der Zeichen enthält | 33
[123]{2} | Zeichenkette, die eine Kette von 2 der Zeichen enthält | 23
[12]|[34] | Zeichenkette, die ein Zeichen aus einer der beiden Gruppen enthält | 4

Die wichtigsten Elemente regulärer Ausdrücke:

^ Steht für den Anfang der Zeichenkette

$ Steht für das Ende der Zeichenkette, ggf. inklusive einem Newline als letztes Zeichen

. Steht für jedes Zeichen außer Newline

[...] Steht für jedes in den eckigen Klammern aufgeführte Literal. Ist das erste Zeichen ein '^', so ist der Ausdruck negiert. Mit dem Zeichen '-' kann man Wertebereiche angeben wie in '[A-Z0-9]'. Andere Zeichen verlieren ihre spezielle Bedeutung innerhalb eckiger Klammern, außer '\'.

* Erlaubt 0 oder mehr Wiederholungen des vorhergehenden Literals / Gruppe

+ Erlaubt 1 oder mehr Wiederholungen

? Erlaubt 0 oder 1 Wiederholung

{n,m} Erlaubt n bis m Wiederholungen

{n} Erlaubt genau n Wiederholungen

| Trennt alternative Suchausdrücke


Reiter Qualität

Reiter Referenzstring

Reiter Linien

Abbildung: Detektor Barcode, Reiter Qualität

Einstellungen im Reiter Qualität

Parameter Funktion

Qualitätsparameter

Bewertung der Druckqualität gemäß dem internationalen Standard ISO/IEC 15416.

Für eine normgerechte Qualitätsbewertung sind bestimmte Mindestanforderungen an die Abbildung des Codes in der Kamera (Auflösung), die Anordnung der Kamera und die Art und Anordnung der Beleuchtung vorgeschrieben. Diese sind in den jeweiligen Normen abgedruckt.

Für die einfachen 1D Barcodes wird die Bewertung der Druckqualität in einem Tupel mit acht Elementen zusammengefasst:

Q1 Overall

Q2 Nicht genutzt

Q3 Nicht genutzt

Q4 Decode

Q5 Symbol Contrast

Q6 Minimal Reflectance

Q7 Minimal Edge contrast

Q8 Modulation

Q9 Defects

Q10 Decodability

Q11 Additional Requirements

Während die Gesamtqualität der endgültige Symbolgrad ist, weisen die restlichen Grade auf mögliche qualitätsverringernde Ursachen hin. Eine Liste mit häufig vorkommenden Defekten und deren Effekt auf die einzelnen Qualitätsgrade kann man im Standard ISO/IEC 15416 finden.

Die einzelnen Qualitätsgrade sind wie folgt definiert: „overall" ist der Minimalwert aller restlichen Gradwerte. „decode" ist auf 4 gesetzt, wenn das untersuchte Barcodesymbol gelesen werden konnte, und auf 0 anderenfalls. Der „symbol contrast" ist die Differenz zwischen maximalem und minimalem Reflexionswert des Grauwertprofils; stärkerer Kontrast ergibt einen besseren Grad. Der „minimal reflectance" ist auf 4 gesetzt, wenn der minimale Reflexionswert des Grauwertprofils kleiner oder gleich 0.5 der maximale Reflexionswert ist. Andernfalls wird ein Wert von 0 zugewiesen. Der Kantenkontrast ist der Kontrast zwischen zwei benachbarten Symbolelementen (beide Strich-zu-Loch oder Loch-zu-Strich). Der „minimal edge contrast" bewertet den minimalen Kantenkontrast im Grauwertprofil. Die „modulation" bewertet die Amplitude zwischen den Symbolelementen. Höhere Amplituden bedingen, dass Striche und Löcher zuverlässiger voneinander unterschieden werden können und dieser Grad höher bewertet wird. Die „defects" sind Unregelmäßigkeiten im Grauwertprofil innerhalb einzelner Symbolelemente oder der Quietzonen, deren Vorhandensein mit niedrigerem Grad gekennzeichnet wird. Die „decodability" bezeichnet Abweichungen der Symbolelementbreiten von ihrem Nominalwert, der im entsprechenden Symbologiestandard festgelegt ist. Die „additional requirements" sind weitere symbologie-spezifische Anforderungen wie z.B.: die quiet zone Breiten, das wide/narrow Verhältnis, inter character gaps, guarding patterns oder andere.

Die Druckqualitätsbewertung eines „Composit" Barcodes umfasst die folgenden 24 Grade:

OVERALL:

Q1 Overall

Q2 Overall Linear

Q3 Overall Composite

LINEAR:

Q4 Decode

Q5 Symbol Contrast

Q6 Minimal Reflectance

Q7 Minimal Edge contrast

Q8 Modulation

Q9 Defects

Q10 Decodability

Q11 Additional Requirements

COMPOSITE:

Q12 Decode

Q13 Rap Overall

COMPOSITE RAP:

Q14 Contrast

Q15 Minimal Reflectance

Q16 Minimal Edge Contrast

Q17 Modulation

Q18 Defects

Q19 Decodability

Q20 Codeword Yield

Q21 Unused Error Correction

Q22 Modulation

Q23 Decodability

Q24 Defects

Der Gesamtgrad „overall" von der OVERALL Gruppe ist der endgültige Symbolgrad. Er ist der kleinere der anderen zwei Grade in der Gruppe: „overall linear" und „overall composite", welche der Gesamtgrade des linearen (1D) bzw. compositen (2D) Anteils des compositen Symbols darstellen. Die anderen zwei Gruppen, LINEAR und COMPOSITE, bestehen aus einzelnen Qualitätsgraden beider Symbolanteile und weisen auf mögliche qualitätsverringernde Ursachen hin. Die Grade aus der Gruppe LINEAR entsprechen denjenigen aus dem oben beschriebenen einfachen 1D Barcode Fall. Die Grade aus der Gruppe COMPOSITE entsprechen den PDF 417 Qualitätsgraden, wobei rap overall nach dem so genannten RAP Start-Stop Muster benannt ist, das für composite Symbole spezifisch ist. Zusätzlich stellt die Untergruppe COMPOSITE RAP die einzelnen Grauwertprofilgrade des RAP Musters dar. Diese Grade stimmen mit den einfachen 1D Barcode Qualitätsgraden überein.

Qualitätsparameter Ausgabe

Es gibt zwei Darstellungsformate für Qualitätsparameter. Beide Formate entsprechen den Normen. Die Parameter können mit Werten von A-F oder von 0-4 angegeben werden. A und 4 sind die besten Bewertungen. Die hier gemachte Einstellung wirkt sowohl auf die Anzeige der Qualitätsparameter am Bildschirm, als auch auf die Ausgabe der Qualitätsparameter über die Schnittstellen.

Die Zuordnung ergibt sich wie folgt:

A B C D F

4 3 2 1 0

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


Reiter Linien

Reiter Qualität

Reiter Struktur

Abbildung: Detektor Barcode, Reiter Linien

Einstellungen im Reiter Linien

Parameter | Funktion

Minimale

Strichbreite

Die minimale Größe eines Elements, d.h. die minimale Dicke aller Striche und Zwischenräume. Für sehr schmale Barcodes sollte der Wert auf 1.5 reduziert werden. Für sehr große Barcodes kann der Wert entsprechend vergrößert werden, was kürzere Laufzeiten mit sich bringt.

Maximale

Strichbreite

Die maximale Größe eines Elements, d.h. die maximale Dicke aller Striche und Zwischenräume. Dieser Wert sollte groß genug sein, damit für das komplette Symbol die Kandidatenregion gefunden wird. Andererseits darf er nicht zu groß gewählt werden, dass zwei benachbarte Barcodes zu einem einzelnen Kandidaten verschmelzen.

Minimale

Strichhöhe

Die minimale Höhe des Barcodes. Bei sehr flachen Barcodes mit einer Höhe von weniger als 16 Pixeln ist es sinnvoll die Höhe manuell einzustellen, damit der Barcode gefunden und gelesen werden kann. Die minimale Höhe beträgt 8 Pixel. Bei sehr hohen Barcodes, z.B. mit 70 Pixeln und mehr, kann das manuelle Setzen auf die entsprechende Höhe zu einer Beschleunigung beim Lesen führen.
Orientierung

Mit dem Parameter Orientierung kann der Winkelbereich für die Code Lesung eingeschränkt werden. Barcodes mit Drehlagen außerhalb der spezifizierten Orientierung werden nicht gelesen. Der Parameter wird z.B verwendet, falls ein Barcode in verschiedenen Drehlagen vor dem Code Leser liegen kann und nicht alle Drehlagen gelesen werden sollen. Wenn Codes mit einer bestimmten Drehlage unter mehreren Codes gefunden werden sollen, dann ist der Parameter Max. Anzahl Codes im Reiter Code höher zu wählen als die Anzahl der gesuchten Codes.

Falls die Barcodes nur mit einer bestimmten Orientierung in den bearbeiteten Bildern erscheinen, so kann man den Wertebereich entsprechend reduzieren. Dadurch werden falsche Kandidaten früher erkannt. Die Ausführungszeit des Operators wird bei Einschränkung des Orientierungswinkels verkürzt. Diese Strategie gilt vor allem dann, wenn die bearbeiteten Bilder viel Hintergrundtextur mit falsch orientierten, barcodeähnlichen Strukturen enthält.
Orientierungstoleranz | Toleranz der Orientierung. Siehe 'Orientierung' für weitere Erklärungen.

Max. Abweichung (Orientierung)

Ein potentieller Barcode besteht aus Strichen und damit auch aus Kanten mit einer einheitlichen Orientierung. Die Größe „Maximale Orientierungsabweichung“ gibt an, wie stark der Unterschied in der Orientierung benachbarter Kanten sein darf. Die Maximale Orientierungsabweichung ist ein Differenzwinkel in Gradmaß. Ist ein Barcode ausgefranst, d.h. die Strichkanten sind gestört, so ist die Maximale Orientierungsabweichung groß zu wählen. Mit kleinen Werten dagegen kann die Anzahl falscher Barcode Kandidaten reduziert werden.

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.

Weitere Informationen:

Closed Parameter Orientierung

In der nachfolgenden Abbildung ist die Orientierung erläutert.

Hinweis:

Die Angabe der Orientierung bezieht sich auf das Bild und nicht auf die Drehlage des Suchbereichs.

Abbildung: Parameter Orientierung


Optimierung2

Optimierung:

Ausführungsgeschwindigkeit:

  • Suchbereich für Position (gelber Rahmen) nur so groß wie nötig

Robustheit:

  • Suchbereich (gelber Rahmen) ausreichend groß?
  • Markanter Kontrast vorhanden?
  • Sind die Schaltschwelle richtig eingestellt?
  • Code ausreichend groß im Sichtbereich ?
  • Ist die Strichbreite ausreichend groß ?


Reiter Struktur

Reiter Linien

Abbildung: Detektor Barcode, Reiter Struktur

Einstellungen im Reiter Struktur

Parameter | Funktion
Kantenkontrast relativ | Kanten werden innerhalb einer Scanlinie mit Hilfe eines Schwellwerts gefunden. Der Parameter „Kantenkontrast relativ“ bestimmt, wie dieser Schwellwert relativ zum Dynamikbereich der Grauwerte entlang der Scanlinie berechnet wird. Bei großem Hintergrundrauschen oder Störungen sollte Kantenkontrast relativ auf größere Werte gesetzt werden. Typischer Wertebereich: [0.05 .. 0.2]; Standardwert: 0.05
Kantenkontrast absolut | Mit „Kantenkontrast absolut“ wird die Erkennung falscher Kanten verhindert. Bei Bildern mit hohem Rauschpegel sollte dieser Parameter höher gewählt werden. Bei rauschfreien Bildern mit niedrigem Kontrast kann ein zu hoher Wert die Erkennung richtiger Kanten stören. In solchen Fällen ist es empfehlenswert, den Wert zu reduzieren oder auf 0.0 zu setzen. Typischer Wertebereich: [0.0 ... 10.0]; Standardwert: 5.0
Anz. Scanlinien | Anzahl der Scanlinien, die während des Scannens eines Codes benutzt werden. Reduzierte Anzahl der Scanlinien erhöht die Geschwindigkeit. Bilder besserer Qualität benötigen weniger Scanlinien als Bilder von schlechterer Qualität. Bei durchschnittlicher Bildqualität sind Werte zwischen 2 und 5 ausreichend. Sollte ein Barcode nach Verringerung der Scanlinien nicht mehr gefunden werden, so muss die Anzahl der Scanlinien wieder erhöht werden. Typische Werte: [0, 5, 10, 20 ...]; Standardwert: 0
Min. ident. Scanlinien | Die minimale Anzahl von identischen Scanlinien, um eine Code als gelesen zu akzeptieren. Wenn dieser Parameter nicht gesetzt ist (Wert 0) wird der Barcode gelesen, sobald eine Scanlinie erfolgreich dekodiert wurde. Fehllesungen können reduziert werden wenn dieser Parameter auf 2 oder höher gesetzt wird. Typische Werte: [0, 2, 3, ...]; Standardwert: 0
Start- / Stop- Muster | Setzt die Suche nach Start-, bzw. Stopmuster innerhalb einer Scanlinie auf „Tolerant“ oder „Genau“. Tolerant erhöht die allgemeine Leserate, insbesondere in Bildern mit schlechtem Kontrast. „Genau“ erhöht die Robustheit gegenüber falscher Dekodierung, kann aber auch die allgemeine Leseratte mindern. Standardwert: “Tolerant”
Neigung

Wenn „Neigung“ = „An“, Verbesserung der Lesbarkeit wenn einzelne Linien des Barcodes schräg zur Hauptrichtung des Codes ausgerichtet sind, z.B. wenn der Code durch unebene Oberfläche verzerrt erscheint.

Wenn „Neigung“ = „Aus“, Standardeinstellung wenn alle Linien des Barcodes parallel im Bild erscheinen.

Wenn „Neigung“ = "Auto" wird zunächst Stellung „Aus“ und dann Stellung „Ein“ getestet, kann Lesezeit erhöhen.

Werte: „Aus", „Auto“, „An“; Standardwert: „Aus"

Ruhezone | Steuert die Erkennung der Ruhezonen eines Barcodes. Wenn „Ruhezone“ = „An“, muss die Ruhezone mindestens so breit sein, wie in der entsprechenden Barcode-Norm festgesetzt ist. Wenn „Ruhezone“ auf eine Ganzzahl (>= 1) gesetzt ist, dann muss eine Ruhezone von mindestens „Ruhezone“ x X Pixeln eingehalten werden. Wenn „Ruhezone“ = „tolerant“ ist eine beschränkte Anzahl an Kanten in der Ruhezone erlaubt, aber höchstens eine pro vier Modulbreiten. Das Ziel ist zu verhindern, nur einen Teil des Barcodes zu erkennen, aber dennoch Codes mit einer einfachen Verletzung der Ruhezone noch lesen zu können. Wenn „Ruhezone“ = „Aus“, ist die Erkennung der Ruhezonen ausgeschaltet. Die Erkennung der Ruhezone verhindert, dass einfache Barcodes innerhalb einer Strichsequenz eines längeren und/ oder komplexeren Barcodes gefunden werden. Normalerweise liefern Werte zwischen 2 und 4 optimale Ergebnisse, weil dadurch falsche Barcodes unterdrückt werden, während kleine Störungen wie Text, Etikettenkanten, etc. immer noch toleriert werden. Wertevorschläge: „Aus“, „An“, 1, 2, 3, 4, 5; Standardwert: „Aus“

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


Detektor Datacode

Reiter Code

Nächste Themen:

Detektor OCR

Reiter Referenzstring

Abbildung: Detektor Datacode, Reiter Code

Parameter | Funktion

Codetyp

Wählen Sie hier den Typ des Datacodes aus, der gelesen werden soll.

Max Stringlänge

Max. Länge eines Codes. Wenn der Inhalt des Codes die maximale Länge überschreitet, wird der Überhang abgeschnitten.

Beim Lesen von mehreren Codes gleichzeitig, muss dieser Wert auf die maximale Länge des längsten Codes eingestellt werden.

Min. Anzahl Codes

Minimale Anzahl der Codes, die innerhalb des Suchbereichs gelesen werden sollen.

Max. Anzahl Codes

Maximale Anzahl der Codes, die innerhalb des Suchbereichs gelesen werden sollen. Wird dieser Wert höher gewählt, als tatsächlich notwendig, so kann sich die Ausführungszeit des Detektors geringfügig erhöhen.

Rücksetzen

Parameter rücksetzen dient zum Zurücksetzen der eingelernten Parameter auf den Anfangszustand vor dem Einlernen. Es gibt die Auswahlmöglichkeiten „Standard“, „Erweitert“ und „Maximum". „Standard“ setzt die Grenzen des Suchbereiches so, dass beim Einlernen die Mehrzahl der möglichen Codes erkannt wird. Sollte Ihr Code dennoch nicht erkannt werden, dann wählen Sie die Einstellung „Erweitert“. Kann der Code immer noch nicht gelesen werden, so setzten Sie die Einstellung auf „Maximum". Die Einstellungen „Erweitert" und „Maximum" können die Ausführungszeit verlangsamen. Der Unterschied zu einem kompletten Zurücksetzten des Sensors ist, dass nur die Parameter für den Datamatrix Code zurückgesetzt werden. Die grundsätzlichen Parameter des Sensors wie z.B. für Beleuchtung, Ein- Ausgänge, serielle Schnittstelle usw. bleiben erhalten. Nach dem Zurücksetzen der Parameter kann wieder mit „Einlernen“ ein neuer Einlernvorgang gestartet werden.

Erstes Einlernen /

Zusätzliches Einlernen

Einlernen: der Suchbereich des Sensors wird nach einem Datamatrix Code durchsucht. Wurde ein gültiger Code gefunden, dann werden die Parameter für diesen Code gespeichert. Ist der Einlernvorgang erfolgreich, wird der gefundene Code mit einem grünen Rahmen markiert. Im „Run“ - Modus wird dann nur genau nach diesem eingelernten Code gesucht.

Nach erfolgtem Einlernen erscheint an gleicher Stelle der Button „Zusätzliches Einlernen“. Dieser ermöglicht die Erweiterung der eingelernten Parameter um entweder mehrere verschiedene Codes in einer Konfiguration lesen zu können oder eventuell vorhandene Streubereiche in der Druckqualität eines einzigen Codes zu erfassen. Mit "Zusätzliches Einlernen" wird der bereits eingelernte Parametersatz erweitert.
Autotune | Automatische Einstellung (Vorverarbeitungsfilter und Bildeinstellungen) zur Optimierung der Code Lesung.

Textausgabe bei Fehllesung

Spezifiziert den Text, der im Falle einer Fehllesung über die Schnittstellen ausgegeben wird.

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.

Optimierung:

Ausführungsgeschwindigkeit:

  • Suchbereich für Position (gelber Rahmen) nur so groß wie nötig

Robuste Erkennung:

  • Suchbereich (gelber Rahmen) ausreichend groß?
  • Markanter Kontrast vorhanden?
  • Sind die Schaltschwellen richtig gesetzt?

Autotune

Bei der Auswahl der "Autotune"-Funktion nimmt der SBS Vision-Sensor automatische Einstellungen zur Optimierung der Code Lesung vor.

Die Funktion startet dabei immer mit den vom Benutzer bereits eingestellten Parametern. Wenn also vor dem Start der "Autotune"-Funktion Parameter grob eingestellt werden, dann macht Autotune die Feineinstellung zur Optimierung des Ergebnisses.

Nach dem Optimierungsdurchlauf von "Autotune" kann „OK“ oder „Abbrechen“ gedrückt werden. Im Falle von „OK“ werden die neu gefundenen Parameter übernommen. Bei der Auswahl „Abbrechen“ werden die alten Parameter von vor der "Autotune"-Ausführung wieder hergestellt.

Abbildung: "Autotune" Fenster

Die "Autotune" Funktion besteht aus folgenden Elementen:

(A) Fortschritt
Start | Start der "Autotune" Funktion. Nach dem drücken von Start wird der Verlauf des Fortschritts angezeigt.
Stop bei Erreichen der geforderten Qualität | Die "Autotune" Funktion stoppt die automatischen Einstellungen, wenn die mindest- geforderte Qualität erreicht ist.

(B) Bildaufnahme
Verschlusszeit

Aktiv: Mit einem Häkchen im Feld "Aktiv" werden die Parameter bestimmt, die der SBS Vision-Sensor automatisch ermitteln soll. Nicht aktivierte Parameter bleiben unverändert.

Bester Wert: Das Feld "Bester Wert"zeigt die letzte Einstellung, die durch die Autotune Funktion ermittelt wurde.
Verstärkung
Interne Beleuchtung
Polarisationsfilter
Externe Beleuchtung

(C) Vorverarbeitung
Mittelwert

Aktiv: Mit einem Häkchen im Feld "Aktiv" werden die Parameter bestimmt, die der SBS Vision-Sensor automatisch ermitteln soll. Nicht aktivierte Parameter bleiben unverändert.

Bester Wert: Das Feld "Bester Wert" zeigt die letzte Einstellung, die durch die Autotune Funktion ermittelt wurde.
Erosion
Dilatation
Umkehrung Reihenfolge: Erosion/ Dilatation

(D) Codeparameter
Modul Robustheit Es werden jeweils die besten Einstellungen, die durch die Autotune Funktion gefunden wurde, angezeigt.
Suchmuster Toleranz
Kontrast Toleranz

(E) Qualität des besten Parametersatzes
Anzahl Codes | Anzahl der Codes im Sichtfeld, die durch die Autotune Funktion getestet wurden.
Korrektur | Dekodierungsfehler, welcher mit aktivierten Parametern erreicht wird.


Reiter Referenzstring

Detektor Datacode

Reiter Qualitätsparameter

Abbildung: Detektor Datacode, Reiter Referenzstring

Einstellungen im Reiter Referenzstring

Parameter Funktion

Stringvergleich

Aktiviert die Überprüfung des Inhaltes der gelesenen Informationen. Die Überprüfung des Inhaltes der gelesenen Informationen erfolgt auf Basis von regulären Ausdrücken.

Referenzstring

Dieser Text bzw. reguläre Ausdrücke wird zur Verifikation herangezogen. Hier können konkrete Zeichen stehen, die direkt verglichen werden, oder reguläre Ausdrücke, um den Aufbau des gelesenen Ergebnisses zu überprüfen.

Wenn Codes mit einem bestimmten Referenzstring unter mehreren Codes gefunden werden sollen, dann ist der Parameter "Max. Anzahl Codes" im Reiter "Code" höher zu wählen als die Anzahl der gesuchten Codes.

Ausdruck hinzufügen

Öffnet eine Liste mit Vorgaben für reguläre Ausdrücke.

Referenzstring einlernen

Liest den Code, der sich gerade unter dem Code Leser befindet und übernimmt den gelesenen Inhalt als Vergleichstext, der Text kann nachträglich noch editiert werden.

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.

Beispiele für Referenzzeichenketten definiert durch reguläre Ausdrücke:

Referenzzeichenkette | Treffer | Beispiel für Treffer
123 | Zeichenkette, die 123 enthält | 01234
\A123 | Zeichenkette, die mit 123 beginnt | 1234
123\Z | Zeichenkette, die mit 123 endet | 0123
\A123\Z | Zeichenkette, die genau 123 entspricht | 123
[123] | Zeichenkette, die eines der Zeichen enthält | 33
[123]{2} | Zeichenkette, die eine Kette von 2 der Zeichen enthält | 23
[12]|[34] | Zeichenkette, die ein Zeichen aus einer der beiden Gruppen enthält | 4

Die wichtigsten Elemente regulärer Ausdrücke:

^ oder \A | Steht für den Anfang der Zeichenkette
$ oder \Z | Steht für das Ende der Zeichenkette, ggf. inklusive einem Newline als letztes Zeichen
. | Steht für jedes Zeichen außer Newline
[...] | Steht für jedes in den eckigen Klammern aufgeführte Literal. Ist das erste Zeichen ein '^', so ist der Ausdruck negiert. Mit dem Zeichen '-' kann man Wertebereiche angeben wie in '[A-Z0-9]'. Andere Zeichen verlieren ihre spezielle Bedeutung innerhalb eckiger Klammern, außer '\'.
* | Erlaubt 0 oder mehr Wiederholungen des vorhergehenden Literals / Gruppe
+ | Erlaubt 1 oder mehr Wiederholungen
? | Erlaubt 0 oder 1 Wiederholung
{n,m} | Erlaubt n bis m Wiederholungen
{n} | Erlaubt genau n Wiederholungen
| | Trennt alternative Suchausdrücke


Reiter Qualitätsparameter

Reiter Referenzstring

Reiter Abbildung

Abbildung: Detektor Datacode, Reiter Qualität

Einstellungen im Reiter Qualität

Parameter

Funktion

Qualitätsparameter

Qualitätsparameter werden als zusätzliche Informationen zur Bewertung der Qualität der Codes zur Verfügung gestellt. Es gibt Qualitätsparameter nach AIM DPM-1-2006 und ISO/IEC 15415 Standard. Die Qualitätsparameter setzen sich aus folgenden Einzelbewertungen zusammen:

Q1 Overall quality

Q2 Contrast

Q3 Modulation

Q4 Fixed pattern damage

Q5 Decode

Q6 Axial nonuniformity

Q7 Grid nonuniformity

Q8 Unused error correction

Q9 Mean light

Overall quality: Das Minimum aller folgenden Einzelbewertungen.

Der Kontrast ist der Bereich zwischen minimaler und maximaler Pixelintensität. Ein starker Kontrast führt zu einer guten Bewertung.

Modulation: Gibt einen Wert für das Verhältnis von Schwarzanteil zu Weißanteil im Code wieder. Sowohl zu viel, als auch zu wenig Schwarzanteil führen zu einer Reduzierung des Wertes. Ein ausgewogenes Verhältnis von Schwarz- und Weißanteil vereinfacht die Zuordnung der einzelnen Module.

Das feste Muster sowohl des ECC200 als auch des QR-Codes ist für die Erkennung und Dekodierung der Codes von großer Bedeutung. Fixed pattern damage gibt Auskunft über den Zustand des „Finder Patterns” und der Ruhezonen des Codes.

Decode quality: Hat immer den Wert 4, wenn der Code erfolgreich gelesen wurde. Codes, die nicht gelesen werden können, können auch keiner Qualitätsbewertung unterzogen werden. Weil Datamatrix Codes eine Fehlerkorrektur beinhalten, können Fehler in einzelnen Modulen korrigiert werden. Die Summe der korrigierten Fehler wird im Wert „unused error correction” abgebildet. Es ist durchaus möglich, dass Codes mit einer Unused Error Bewertung von 0 trotzdem gelesen werden können.

Axial nonuniformity: Gibt Auskunft über eine eventuelle horizontale oder vertikale Verzerrung des Codes.

Grid nonuniformity: Gibt Auskunft über generelle Verzerrungen des Codes.

Qualitätsparameter nach AIM DPM-1-2006 sind eine Erweiterung zum ISO/IEC 15415 Standard, welche bestimmte Anforderungen an die Grauwert-Eigenschaften des Bildes des Datamatrix Codes definiert und somit die Reproduzierbarkeit der Qualitätsbewertung zwischen verschiedenen Herstellern verbessert.

Die ungenutzte Fehlerkorrekturkapazität des behandelten Symbols wird im Grad unused error correction berechnet.

Qualitätsparameter nach AIM haben einen Wert mehr, als Qualitätsparameter nach ISO/IEC 15415.

Dieser Wert wird mit „Mean Light“ bezeichnet.

„Mean light“ ist kein Qualitätswert für den Code, er gibt Aussage über die Qualität des Bildes, indem der durchschnittliche Grauwert der hellen Datacode Module berechnet wird.

„Mean light“ kann Werte von 0.0 bis 1.0 haben was 0% bis 100% des maximalen Grauwertes entspricht.

Ein Bild hat dann die geforderten Grauwerteigenschaften, wenn der Wert „mean light“ zwischen 70 % und 86 % liegt (also 0.70 bis 0.86).

Für eine normgerechte Qualitätsbewertung sind bestimmte Mindestanforderungen an die Abbildung des Codes in der Kamera (Auflösung), die Anordnung der Kamera und die Art und Anordnung der Beleuchtung vorgeschrieben. Diese sind in den jeweiligen Normen abgedruckt.

Qualitätsparameter Ausgabe

Es gibt zwei Darstellungsformate für Qualitätsparameter. Beide Formate entsprechen den Normen. Die Parameter können mit Werten von A-F oder von 0-4 angegeben werden. A bzw. 4 ist die jeweils beste Bewertung. Die hier gemachte Einstellung wirkt sowohl auf die Anzeige der Qualitätsparameter am Bildschirm, als auch auf die Ausgabe der Qualitätsparameter über die Schnittstellen.

Die Zuordnung ergibt sich wie folgt:

A B C D F

4 3 2 1 0

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


Reiter Abbildung

Reiter Qualitätsparameter

Reiter Symbole

Abbildung: Detektor Datacode, Reiter Abbildung

Einstellungen im Reiter Abbildung

Parameter | Funktion
Min. Kontrast | Minimaler Kontrast in Graustufen zwischen hellen und dunklen Elementen des Codes, Wertebereich (1...100).
Polarität | Einstellmöglichkeit: Soll heller Code auf dunklem Untergrund oder dunkler Code auf hellem Untergrund gelesen werden.
Neigung | Maximale Abweichung des Winkels im L- förmigen Finderpattern vom (idealerweise) rechten Winkel. Die Angabe erfolgt im Bogenmaß und korrespondiert mit perspektivischen Verzerrungen, die beim Druck des Symbols oder bei der Bildaufnahme auftreten können.
Gespiegelt | Einstellmöglichkeit, ob der Code gespiegelt aufgebracht wurde, oder nicht. Aufgrund der Symmetrie des Codes ist dies mit bloßem Auge nicht erkennbar. Die Funktion ist hilfreich, wenn z.B. Codes auf transparentem Untergrund von hinten gelesen werden sollen.

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


Reiter Symbole

Reiter Abbildung

Reiter Module

Abbildung: Detektor Datacode, Reiter Symbole

Einstellungen im Reiter Symbole

Parameter | Funktion
Symbolgröße min. / max. | Nur QR-Code: Größe der Symbole im Bild in Pixel.
Spalten min. / max. | Nur ECC200 und PDF 417: Anzahl der Spalten inklusive Finder Pattern.
Zeilen min. / max. | Nur ECC200 und PDF 417: Anzahl der Zeilen inklusive Finder Pattern.


Reiter Module

Reiter Symbole

Reiter Codedetails

Abbildung: Detektor Datacode, Reiter Module

Einstellungen im Reiter Module

Parameter | Funktion
Modulgröße min. / max. | Größe der Module in Pixeln.
Modulbreite min. / max. | Nur PDF 417: Breite der Module im Bild in Pixel.
Modulverhältnis min. / max. | Nur PDF 417: Seitenverhältnis der Module im Bild (Höhe zu Breite).
Spaltenabstand | Nur ECC200 und QR-Code: Zulässiger Leerraum zwischen zwei Spalten, z.B. bei genagelten Codes, die keine flächendeckenden Module haben.
Zeilenabstand | Nur ECC200 und QR-Code: Zulässiger Leerraum zwischen zwei Zeilen.


Reiter Codedetails

Reiter Module

Detektor OCR

Abbildung: Detektor Datacode, Reiter Codedetails

Einstellungen im Reiter Codedetails

Parameter | Funktion
Version | Nur bei QR-Code: Version des Codes, bei Modell 1 Wertebereich 1 ... 14, bei Modell 2 Wertebereich 1 ...40. Version gibt die Größe des Codes an. Version 1 bedeutet 21 x 21 Module, Version 2 bedeutet 25 x 25 Module . . .(Pro Version je 4 Module mehr)
Modell Typ | Nur bei QR-Code: Modell 1 oder Modell 2. Modell 2 ist die neuere Variante, unterstützt größere Codes.
Form | Nur bei ECC200 und QR-Code: Dient zur Spezifikation, ob rechteckige oder quadratische Codes gelesen werden sollen.
Modul Robustheit | Robustheit der Dekodierung gegenüber Datacodes mit sehr kleiner Modulgröße. Wird der Parameter auf 'hoch' gesetzt, so erhöht sich die Wahrscheinlichkeit, dass Datacodes mit sehr kleinen Modulen dekodiert werden können. Zusätzlich sollte in diesem Fall auch die minimale Modulgröße entsprechend angepasst werden, d.h. auf die angenommene minimale Modulgröße bzw. Modulbreite gesetzt werden.
Modul Raster | Nur ECC200: Angabe darüber, ob die Größe der Module in einem gewissen Rahmen variieren darf oder nicht. In Abhängigkeit von diesem Parameter werden verschiedene Algorithmen für die Berechnung der Modulpositionen verwendet. In einem Fall ('fixed') wird ein festes Gitter, bei dem die Abstände zwischen den Modulmittelpunkten alle gleich sind, verwendet. Im anderen Fall ('variable') wird das Gitter an der alternierenden Seite des Finderpatterns ausgerichtet. Bei 'any' werden beide Varianten für das Gitter nacheinander ausprobiert. Zu beachten ist, dass der Wert von 'module_grid' ignoriert wird, wenn 'finder_pattern_tolerance' auf 'high' gesetzt ist. In diesem Fall wird immer von einem festen Gitter ausgegangen. Werteliste: 'fixed', 'variable', 'any' Default: 'fixed' (enhanced: 'any').
Genaues Modell | Spezifiziert, ob die eingegebenen Parameter genau eingehalten werden müssen. Bei Auswahl von „Ja “ werden Codes außerhalb der Parametergrenzen ignoriert.
Position Muster | Nur QR-Code: Anzahl von Position-Detection-Patterns, die im Bild gut sichtbar sein müssen, damit ein Code gesucht wird.
Suchmuster Toleranz | Nur bei ECC200: Toleranz der Suche gegenüber einem gestörten oder fehlenden Finderpattern. Das Finderpattern umschließt sowohl die L-förmige als auch die gegenüberliegende alternierende Seite. In einem Fall ('low') wird davon ausgegangen, dass das Finderpattern zum großen Teil vorhanden ist und kaum Störungen aufweist. Im anderen Fall ('high') kann das Finderpattern stark gestört sein oder komplett fehlen, ohne dass die Erkennung beeinträchtigt wird. Zu beachten ist allerdings, dass bei dieser Variante eine erhöhte Rechenzeit zu erwarten ist.
Kontrast Toleranz | Toleranz bei der Code Suche bezüglich starker lokaler Kontrastschwankungen.


Detektor OCR

Detektor OCR, Vorgehensweise

Im folgenden wird die Vorgehensweise zur Einrichtung eines OCR- Detektors zur Klarschriftlesung Schritt für Schritt beschrieben. Da die Einrichtungsschritte auf den Ergebnissen der zuvor durchgeführten Schritten aufbauen, muss diese Abfolge für eine korrekte, prozesssichere Funktion eingehalten werden.

Nächste Themen:

Detektor Wafer

Reiter Zeichen (Flexibel)

Abbildung: Detektor OCR

Generelle Abfolge der Parametrierung

  • Segmentierung mit Hilfe der Reiter „Zeichen“ und „Segmente“ sowie des Reiters „Filter“ unter „Job“.
  • Klassifikation mit Reiter „Klassifizierung“ durch Auswahl eines Zeichensatzes sowie durch Vorgabe eines Referenzstrings.
  • Verwerfen von Zeichen, die nicht mit hinreichender Qualität klassifiziert werden konnten mit Reiter „Qualität“.
  • Beim OCR-Detektor ist es nicht ausreichend, die Parameter an einem Bild einzustellen. Prozesssicherheit lässt sich nur an möglichst großen Bildserien beurteilen. Es wird empfohlen, typische Bildsequenzen abzuspeichern und für die Parameteroptimierung in den Simulationsmodus zu laden. Es sollten wenigstens einige Dutzend Bilder verwendet werden, die die Schwankungsbreite des Prozesses abbilden.

Segmentierung

  • Optimierung der Segmentierung mit den beiden Reitern „Zeichen“ und „Segmente“. Ergebnis muss sein, dass alle gewünschten Zeichen sauber segmentiert sind. Das Ergebnis der Klassifikation, d.h. welches Symbol jedem segmentierten Zeichen zugeordnet wurde, spielt hier noch keine Rolle.
  • Die Segmentierung kann durch Vorverarbeitung unter „Job“ – „Filter“ verbessert werden, z.B. durch „Gauss“, „Mean“ oder „Dilatation“/“Erosion“ oder eine Kombination davon. Für eine stabile Segmentierung wird empfohlen, die glättenden Filter wie "Gauss" oder "Mean" einzusetzen.
  • Parameter „Gruppierung der Zeichen“ kann die Segmentierung unterstützen, indem die Zahl der Zeichen (pro Zeichengruppe) vorgegeben wird.
  • Parameter „Max. Abweichung Grundlinie“ gibt an, wie sehr Zeichen vertikal gegenüber der Zeile verschoben sein dürfen. Dies wird in Prozent der Zeichenhöhe angegeben.
  • Überprüfen Sie die korrekte Segmentierung aller Zeichen, bevor Sie zu "Klassifizierung" weitergehen. Die Klassifizierung hat keinen Einfluss auf die Segmentierung. Fehlerhaft segmentierte Zeichen werden fehlerhaft klassifiziert.

Segmentierung Beispiele:

Abbildung: Segmentierung ohne Vorgabe für Parameter „Gruppierung der Zeichen“: Es werden alle Zeichen gefunden.

Abbildung: Segmentierung mit Vorgabe für Parameter „Gruppierung der Zeichen“ „3 3“: Es werden nur die beiden Dreiergruppen segmentiert.

Abbildung: Segmentierung ohne Vorgabe für Parameter „Gruppierung der Zeichen“: Das erste Zeichen „1“ wird nicht segmentiert, da es in der Helligkeit zu stark von den anderen Zeichen abweicht.

Abbildung: Segmentierung mit Vorgabe für Parameter „Gruppierung der Zeichen“ „3 3 2 1“: Auch das in der Helligkeit abweichende Zeichen wird segmentiert.

Abbildung: Segmentierung mit Parameter „Ausrichtung Text“ = „Schrift horizontal im Bild“: Keine Segmentierung da Zeichen nicht horizontal im Bild liegen.

Abbildung: Segmentierung mit Parameter „Ausrichtung Text“ = „Schrift horizontal im Suchbereich“: Segmentierung funktioniert, da Zeichen horizontal im Suchbereich liegen.

Abbildung: Segmentierung mit Wert 15% für Parameter „Max. Abweichung Grundline“: Nur die inneren Zeichen werden segmentiert.

Abbildung: Segmentierung mit Wert 25% für Parameter „Max. Abweichung Grundline“: Alle Zeichen werden segmentiert.

Klassifikation

  • Hier wird die geeignete Schrift („Zeichensatz“) ausgewählt. Jeder Zeichensatz wird mit unterschiedlich vielen Zeichen angeboten. Es sollte der Zeichensatz gewählt werden, der am besten auf die Anwendung zugeschnitten ist.

  • Nomenklatur der Zeichensätze am Beispiel der Gruppe „Industrial“:

    • Industrial_0-9“: Alle Ziffern
    • Industrial_0-9+“: Alle Ziffern und Sonderzeichen
    • Industrial_A-Z+“: Alle Großbuchstaben und Sonderzeichen
    • Industrial_0-9A-Z“: Alle Ziffern und alle Großbuchstaben
    • “Industrial“: Alle Zeichen

  • Der Referenzstring hat zweierlei Funktionen:

  1. Beeinflussung der Klassifikation, d.h. der erkannten Zeichen. Für jedes segmentierte Zeichen wird in Relation zu jedem im Zeichensatz enthaltenen Zeichen ein Gütewert (Zuverlässigkeit) bestimmt.
    Ohne Vorgabe des Referenzstrings wird das Zeichen mit dem höchsten Gütewert (Zuverlässigkeit) ausgegeben.
    Bei Vorgabe des Referenzstrings werden dagegen die N besten Alternativen berücksichtigt (Anzahl der Alternativen). Insgesamt darf für den Referenzstring maximal M Mal ein Zeichen gewählt werden (Anzahl der Korrekturen), das nicht die maximale Zuverlässigkeit hatte.
  2. Beeinflussung des Detektorergebnisses:
    Es wird eine Mindestgüte für die gesamte Zeichenkette (Schwelle) vorgegeben. Wird diese unterschritten, ist das Detektorergebnis negativ.

Qualität

  • Ist die Zuverlässigkeit eines der klassifizierten Zeichen unterhalb dem Schwellwert (Minimale Zuverlässigkeit), wird das Detektorergebnis negativ.
  • Eine niedrige Zuverlässigkeit zeigt an, dass das Zeichen nicht sicher klassifiziert wurde. Eine hohe Zuverlässigkeit ist dagegen keine Garantie für eine sichere Klassifizierung!


Reiter Zeichen (Flexibel)

Detektor OCR

Reiter Segmente

Festlegung der grundlegenden Einstellungen der zu lesenden Zeichen.

Abbildung: Detektor OCR, Reiter Zeichen

Parameter Funktion

Zeichen Höhe

Max. Höhe eines Schriftzeichens in Pixeln.

Zeichen Breite

Max. Breite eines Schriftzeichens in Pixeln.

Strichstärke

Durchschnittliche Breite der Linien der Schrift in Pixeln.

Polarität

Auswahlmöglichkeit, ob dunkle Schrift auf hellem Grund oder umgekehrt.

Ausrichtung Text

„Horizontal im Bild“: die Schrift muss immer horizontal im Bild liegen. Gedrehte Schriften werden nicht oder falsch gelesen.

„Horizontal im Suchbereich“: Über den Drehwinkel des Suchbereichs kann die Verdrehung der Schrift gegenüber der Horizontalen spezifiziert werden.

Max. Anzahl Linien

Max. Anzahl der zu lesenden Zeilen

Nur Großbuchstaben

Einschränkung auf Großbuchstaben

Punkte zu Zeichen verbinden

Verbindet einzelne Punkte, z.B. einer Punktschrift oder einer unsauber gedruckten Schrift zu kompletten Zeichen

Einzeichnung Buchstabengröße

Schaltet das Rechteck zur Markierung der Buchstabengröße ein und aus

Einzeichnung Segmentierung

Schaltet die farbliche Markierung der segmentierten Buchstaben ein und aus

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.

Optimierung:

Ausführungsgeschwindigkeit:

  • Suchbereich für Zeichen (gelber Rahmen) nur so groß wie nötig


Reiter Segmente

Festlegung der grundlegenden Einstellungen der zu lesenden Zeichen.

Reiter Zeichen (Flexibel)

Reiter Klassifizierung

Abbildung: Detektor OCR, Reiter Segmente

Parameter Funktion

Unterdrücke Hintergrundlinien

Kann benutzt werden, um störende Linien im Hintergrund auszublenden.

Bruchstücke verbinden

Verbindet Zeichen, die z.B. durch unsauberen Druck oder Beschädigung in zwei Teile zerfallen sind zu einem Zeichen.

Erhabene / eingeprägte Schrift

Ermöglicht das Lesen von erhabener oder eingeprägter Schrift, z.B. wenn beleuchtungsbedingt die Zeichen z.B. in weißer Schrift mit schwarzem Rand (Schatten) oder umgekehrt erscheinen.

Punkte ausgeben

Aktiviert Ausgabe gelesener Sonderzeichen wie z.B. Punkte und Kommas.

Trennzeichen ausgeben

Aktiviert Ausgabe gelesener Sonderzeichen wie z.B. Bindestrichen.

Gruppierung der Zeichen

Ermöglicht die Vorgabe, wie die Zeichen in der zu lesenden Zeichenkette gruppiert sind. Werden die Zeichen z.B. immer in zwei Vierergruppen gedruckt, so kann dies über die Eingabe “ 4 4 “ vorgegeben werden.

Diese Funktion sollte verwendet werden, wenn bei mehreren Auswertungen im gleichen Bild unterschiedlich lange Zeichenketten gelesen werden.

Max. Abweichung Grundlinie

Maximal zulässige horizontale Abweichung eines Zeichens von einer geraden zwischen dem ersten und dem letzten Zeichen. Diese Funktion kann verwendet werden, wenn die Zeichen nicht auf einer horizontalen Linie gedruckt sind.


Reiter Klassifizierung

Festlegung der grundlegenden Einstellungen der zu lesenden Zeichen.

Reiter Segmente

Detektor OCR, verfügbare Schriften

Reiter Qualität

Abbildung: Detektor OCR, Reiter Klassifizierung

Parameter | Funktion
Zeichensatz | Verfügbare Schriften siehe Kap. Detektor OCR, verfügbare Schriften 0-9 =˃ nur Ziffern 0-9+ =˃ Ziffern und Sonderzeichen A-Z =˃ nur Großbuchstaben A-Z+ =˃ Großbuchstaben und Sonderzeichen Keine Erweiterung =˃ alle Zeichen
Referenzstring (Checkbox) | Aktiviert die Überprüfung des Inhaltes der gelesenen Informationen. Die Überprüfung des Inhaltes der gelesenen Zeichen erfolgt auf Basis von regulären Ausdrücken.
Referenzstring | Dieser Text bzw. reguläre Ausdrücke wird zur Verifikation herangezogen. Hier können konkrete Zeichen stehen, die direkt verglichen werden, oder reguläre Ausdrücke, um den Aufbau des gelesenen Ergebnisses zu überprüfen. Zeichen, die als Buchstabe oder als Zahl sehr ähnlich sind wie z.B. „B“ oder „8“ können bei Verwendung von regulären Ausdrücken im Referenzstring automatisch korrigiert werden.
Ausdruck hinzufügen | Öffnet eine Liste mit Vorgaben für reguläre Ausdrücke.
Referenzstring einlernen | Liest den Code, der sich gerade unter dem Codeleser befindet und übernimmt den gelesenen Inhalt als Vergleichstext. Der Text kann nachträglich noch editiert werden.
Anzahl der Alternativen | Gibt an, wie viele mögliche Alternativen durchsucht werden dürfen, um ein Zeichen entsprechend dem regulären Ausdruck im Referenzstring zu finden und automatisch zu ersetzen.
Anzahl der Korrekturen | Max. Anzahl der Zeichen, die nach Überprüfung durch den regulären Ausdruck geändert werden dürfen. Beispiel: Tag 3 Buchstaben (MON / TUE / WED / etc) ist die Segmentierung.Die Decodierung gibt die Buchstaben W6O statt WED aus. Mit einer Einstellung von '2' in diesem Feld wird die Kamera-Software automatisch die (Nummer) 6 und (Buchstabe) O "korrigieren" und wird zu (Buchstabe) E und D - Wenn die Einstellung im Feld 1 war, würde der Detektor ausfallen.
Schwelle | Schwelle für Gut-Schlecht Entscheidung: Wenn anhand der eingestellten Schwelle die Anzahl der Korrekturen zu hoch ist, wird der gesamte Text als „nicht gelesen“ bewertet.

Beispiele für Referenzzeichenketten definiert durch reguläre Ausdrücke:

Referenzzeichenkette | Treffer | Beispiel für Treffer
123 | Zeichenkette, die 123 enthält | 01234
\A123 | Zeichenkette, die mit 123 beginnt | 1234
123\Z | Zeichenkette, die mit 123 endet | 0123
\A123\Z | Zeichenkette, die genau 123 entspricht | 123
[123] | Zeichenkette, die eines der Zeichen enthält | 33
[123]{2} | Zeichenkette, die eine Kette von 2 der Zeichen enthält | 23
[12]|[34] | Zeichenkette, die ein Zeichen aus einer der beiden Gruppen enthält | 4

Die wichtigsten Elemente regulärer Ausdrücke:

^ oder \A | Steht für den Anfang der Zeichenkette
$ oder \Z | Steht für das Ende der Zeichenkette, ggf. inklusive eines Zeilenwechsels als letztes Zeichen
. | Steht für jedes Zeichen außer Zeilenwechsel
[...] | Steht für jedes in den eckigen Klammern aufgeführte Zeichen. Ist das erste Zeichen ein '^', so ist der Ausdruck negiert. Mit dem Zeichen '-' kann man Wertebereiche angeben wie in '[A-Z0-9]'. Andere Zeichen verlieren ihre spezielle Bedeutung innerhalb eckiger Klammern, außer '\'.
* | Erlaubt 0 oder mehr Wiederholungen des vorhergehenden Zeichens / Gruppe
+ | Erlaubt 1 oder mehr Wiederholungen
? | Erlaubt 0 oder 1 Wiederholung
{n,m} | Erlaubt n bis m Wiederholungen
{n} | Erlaubt genau n Wiederholungen
| | Trennt alternative Suchausdrücke


Detektor OCR, verfügbare Schriften

Reiter Klassifizierung

Reiter Qualität

Übersicht der verschiedenen Schriften:

Semi

Dotprint

Handwritten

Industrial

MICR

OCRA

OCRB

Pharma


Reiter Qualität

Festlegung der grundlegenden Einstellungen der zu lesenden Zeichen.

Reiter Klassifizierung

Detektor OCR

Abbildung: Detektor OCR, Reiter Qualität

Parameter | Funktion
Qualität | Die Qualität jedes einzelnen Zeichens wird mit einem Wert von 0 – 100 % bewertet. Je höher der Wert, umso sicherer ist wurde das gelesene Zeichen bestimmt. Kleine Werte sprechen für eine eher unsichere Zuordnung.
Minimale Zuverlässigkeit | Wenn die Zuverlässigkeit unterhalb der eingestellten Schwelle liegt, wird das Zeichen als nicht gelesen bewertet und durch einen Platzhalter ersetzt.
Ersatzzeichen | Platzhalter für den Fall, dass die minimale Zuverlässigkeit nicht erreicht wurde.


Ergebnis OCR

Mit dieser Funktion wird der definierte Job auf dem PC ausgeführt, und das "Ergebnis Statistik" Fenster mit Detektorliste und Auswerteergebnissen angezeigt. Die Ausführungszeiten werden in diesem Modus nicht aktualisiert, da sie vom Sensor nicht vorliegen.

Nächste Themen:

Reiter Qualität

Detektor Wafer

Im Run-Modus werden die detaillierten Prüfergebnisse des in der Auswahlliste markierten Detektors angezeigt.

Im Bildfenster werden – sofern eingestellt – das Bild, die Such- und Merkmalsbereiche und Ergebnisgraphen angezeigt.

Abbildung: Detektor OCR, Ergebnisausgabe

Die angezeigten Parameter variieren in Abhängigkeit vom ausgewählten Detektortyp:

Parameter | Funktion
String | Gelesene Zeichen
Sicherheit | Wert von 0-100%, gibt an, wie zuverlässig der Leser ein Zeichen bewerten konnte.
Stringlänge | Länge des gelesenen Strings
Pos X | Position X in Pixeln
Pos Y | Position Y in Pixeln
Winkel | Winkel zur Horizontalen
Ergebnis Vergleich | Ist ein Maß für die Qualität des Ergebnisses. Wenn anhand des Referenzstrings keine Korrekturen erforderlich waren, ist dieser Wert bei 100%. Mit steigender Anzahl von Korrekturen sinkt der Wert ab.
Referenzstring getroffen | Anzeige, ob der ausgegebene String mit dem Referenzstring übereinstimmt.
Ergebnis Vergleich | Anzeige, ob die minimale Zuverlässigkeit erreicht wurde.
Abgeschnitten | Anzeige, ob ein Teil des Strings abgeschnitten wurde.


Detektor Farbwert

Ermittelt mittlere Farbwerte RGB / HSV / LAB zur Ausgabe über die Schnittstellen.

Reiter Farbkanal

Reiter Farbwert


Reiter Farbkanal

Auswahl des Farbmodelle und des, oder der Farbkanäle, auf denen der Detektor arbeiten soll.

Ein Bild, das mit einem Farbchip aufgenommen wurde enthält durch die Farbkomponente mehr Information als ein monochromes Bild. Diese Eigenschaft kann bei der Farbkanalauswahl genutzt werden. Durch Auswahl der Farbkanäle können einzelne Bereiche gezielt verstärkt oder abgeschwächt werden. Das angezeigte Bild wird abhängig vom Bildchip und vom gewählten Detektor angezeigt.

  • Monochrom Chip: Anzeige immer schwarz / weiß
  • Farbchip + Farbdetektor: Anzeige immer farbig
  • Farbchip + Objekterkennungsdetektoren: Monochrombild, Anzeige abhängig vom gewählten Farbraum und den Farbkanälen

Abbildung: Farbkanal

Parameter | Funktion
Farbraum | Farbräume: RGB, Farbmodell RGB, HSV, Farbmodell HSV, LAB, Farbmodell LAB
Farbkanal | Ein oder mehrere Kanäle können gewählt werden.


Reiter Farbwert

Ermittelt mittlere Farbwerte RGB / HSV / LAB zur Ausgabe über die Schnittstellen.

Nächste Themen:

Detektor Farbfläche

Funktion: Muster/Kontur bearbeiten

Abbildung: Farbwert

Parameter (alternativ je Einstellung in Farbkanal) | Funktion
Rot (Farbton / Luminaz) | Schwellen für gewählten Kanal min. / max.
Grün (Sättigung / A) | Schwellen für gewählten Kanal min. / max.
Blau (Intensität / B) | Schwellen für gewählten Kanal min. / max.
Suchbereich (Form) | Die Form des Suchbereiches kann als Rechteck, Kreis oder als Freiform gewählt werden. Wenn Freiform gewählt wird, ist „Suchbereich bearbeiten“ aktiv.
Suchbereich bearbeiten | Über den Parameter Suchbereich bearbeiten können Bereiche des Suchbereichs ausgeblendet werden. Wie mit einem Radierer können im Suchbereich die Bereiche entfernt werden, die für die Auswertung nicht benötigt werden. Diese markierten Bereiche können auch invertiert werden, also die Bereiche markiert werden, die für die Ausführung wichtig sind etc.
Anzeige Suchbereich | Ein- / Ausschalten der Anzeige der Suchbereich- Bearbeitungen

Prädestinierte Anwendungen:

  • Ausgabe der ermittelten Farbparameter über eine der Schnittstellen zur Weiterverarbeitung.

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


Detektor Farbfläche

Ermittelt den Flächenanteil einer Farbe oder eines Farbbereichs. Abhängig vom Anteil der Fläche kann ein gut-schlecht Ergebnis erzeugt werden.

Reiter Farbkanal

Reiter Farbfläche

Reiter Schwellen


Farbkanal auswählen

Reiter Farbkanal

S. Kapitel: Reiter Farbkanal


Reiter Farbfläche

Nächste Themen:

Reiter Schwellen

Funktion: Muster/Kontur bearbeiten

Ermittelt den Flächenanteil einer Farbe oder eines Farbbereichs. Abhängig vom Anteil der Fläche kann ein gut-schlecht Ergebnis erzeugt werden.

Abbildung: Farbfläche

Parameter (alternativ je Einstellung im Farbkanal) Detektor | Funktion
Rot (Farbton / Luminaz) | Schwellen für gewählten Kanal min. / max.
Grün (Sättigung / A) | Schwellen für gewählten Kanal min. / max.
Blau (Intensität / B) | Schwellen für gewählten Kanal min. / max.
Suchbereich (Form) | Die Form des Suchbereiches kann als Rechteck, Kreis oder als Freiform gewählt werden. Wenn Freiform gewählt wird, ist „Suchbereich bearbeiten“ aktiv.
Suchbereich bearbeiten | Über den Parameter Suchbereich bearbeiten können Bereiche des Suchbereichs ausgeblendet werden. Wie mit einem Radierer können im Suchbereich die Bereiche entfernt werden, die für die Auswertung nicht benötigt werden. Diese markierten Bereiche können auch invertiert werden, also die Bereiche markiert werden, die für die Ausführung wichtig sind etc.
Anzeige Suchbereich | Ein- / Ausschalten der Anzeige der Suchbereich- Bearbeitungen
Einzeichnung | Farbmarkierung von Pixeln innerhalb oder außerhalb des angegebenen Farbbereichs. Dies ist eine Hilfe während des Setups, um Detektorergebnisse zu visualisieren und Schwellenwerte genauer zu setzen.
Farb Histogramm | Ermöglicht die grafische Einstellung der Schwellen durch ein Histogramm

Prädestinierte Anwendungen:

  • Farbiges Objekt mit bestimmter Größe mit variierender Position in der ROI

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


Farbhistogramm

Es werden je nach gewähltem Farbmodell die Histogramme für RGB, HSV oder LAB angezeigt.
Das Histogramm zeigt die Verteilung der Farben im Suchbereich. Über die Buttons können einzelne Kanäle aus- oder eingeschaltet werden. Über kleine Markierungen unterhalb des Histogramms können die Grenzwerte für die Farberkennung verschoben werden. Der markierte Bereich wird in der entsprechenden Farbe unterlegt. Überkreuzen der Grenzwerte führt zur Invertierung der Auswahl. Kann eine Farbe mit nur einem Kanal sicher erkannt werden, sind die Grenzwerte der anderen Kanäle auf den unteren oder oberen Endwert einzustellen, damit diese keinen störenden Einfluss bei der Erkennung haben.

Abbildung: Farbhistogramm


Reiter Schwellen

Ermittelt den Flächenanteil einer Farbe oder eines Farbbereichs. Einstellung der Schwellen.

Nächstes Thema: Detektor Farbliste

Abbildung: Farbfläche, Schwellen

Parameter | Funktion
Schaltschwelle | Schwellen für Flächenanteil min. / max.
Objektgröße | Min. / Max. Objektgröße (zusammenhängender Farbbereich)

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


Detektor Farbliste

Vergleicht eine Farbe mit einer Liste bekannter Farben. Ergebnis: Nummer oder Name der Farbe, die am nächsten liegt. Somit könnten Teile anhand der Farbe sortiert werden.

Reiter Farbkanal

Reiter Farbliste


Reiter Farbliste

Nächste Themen:

Bedienschritt Ausgabe

Funktion: Muster/Kontur bearbeiten

Vergleicht eine Farbe mit einer Liste bekannter Farben. Ergebnis: Nummer oder Name der Farbe, die am nächsten liegt. Somit könnten Teile anhand der Farbe sortiert werden.

Abbildung: Farbliste

Parameter | Funktion
Farbabstand | Abstand der aktuellen Farbe gegenüber der eingelernten Farbe. Die Metrik des Farbabstandes ist abhängig vom Farbmodelle, dabei gehen nur die jeweils gewählten Farbkanäle ein. *1)
Name | Name der Farbe, kann per Doppelklick auf den Namen geändert werden, z.B. Rot, Gelb, Blau
Musterfarbe | Darstellung der eingelernten Farbe als Muster und in Zahlenwerten (RGB / HSV / LAB)
Einlernen | Lernt die Farbe oder den Farbbereich im Suchbereich ein, sollen mehrere verschiedene Farben eingelernt werden, so muss ein kleiner Suchbereich jeweils auf die einzulernende Farbe geschoben werden.
+ | Neue Zeile am Ende der Tabelle dazu
- | Markierte Zeile löschen
Alle löschen | Alle Einträge der Liste löschen
Auf | Markierte Zeile um eine Zeile nach oben schieben
Ab | Markierte Zeile um eine Zeile nach unten schieben
Suchbereich (Form) | Die Form des Suchbereiches kann als Rechteck, Kreis oder als Freiform gewählt werden. Wenn Freiform gewählt wird, ist „Suchbereich bearbeiten“ aktiv.
Suchbereich bearbeiten | Über den Parameter Suchbereich bearbeiten können Bereiche des Suchbereichs ausgeblendet werden. Wie mit einem Radierer können im Suchbereich die Bereiche entfernt werden, die für die Auswertung nicht benötigt werden. Diese markierten Bereiche können auch invertiert werden, also die Bereiche markiert werden, die für die Ausführung wichtig sind etc.
Anzeige Suchbereich | Ein- / Ausschalten der Anzeige der Suchbereich- Bearbeitungen
Farb Histogramm | Ermöglicht die grafische Einstellung der Schwellen durch ein Histogramm

*1) Im RGB- und im LAB- Farbmodell ist der Farbabstand der euklidische Abstand.
Im Farbmodell LAB ist die Farbverteilung über den gesamten Raum nahezu homogen, d.h. Farbabstände des selben Betrages führen zur sehr ähnlichen Wahrnehmung der Farbdifferenz über das gesamte Modell. Deshalb kann in diesem Modell davon gesprochen werden, dass ein Abstand von >= 5 zur Wahrnehmung einer anderen Farbe führt.

Prädestinierte Anwendungen:

  • Sortierung von Farbobjekten über Index in der Liste
  • Einfaches Prüfen homogener Farbflächen (Farbe wird über Suchbereich gemittelt, Farbe einlernen, kleinen Farbabstand einstellen (Toleranzband) ... fertig)

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


Bedienschritt Ausgabe

Hier definieren Sie die Belegung und logische Verknüpfung der digitalen Signalausgänge, sowie die Schnittstellen und Ausgabedaten des SBS.

Reiter Pinbelegung

Reiter Ausgangssignale (Digitalausgänge / Logik)

Reiter Schnittstellen

Reiter Zeitsteuerung

Reiter Datenausgabe

Reiter Bildübertragung

Reiter Archivierung


Reiter Pinbelegung

Hier werden folgende Einstellungen vorgenommen:

  1. Festlegung welche der variabel nutzbaren I/O als Ein- oder Ausgang genutzt werden sollen.
    Pin 05 rosa, Pin 06 gelb, Pin 07 schwarz (LED B) und Pin 08 grau (LED C), können sowohl als Eingang oder als Ausgang genutzt werden.
  2. Zuordnung der Funktionen zu den Ein- / Ausgängen.
    In den jeweiligen Listboxen sind die für diesen Ein- oder Ausgang verfügbaren Funktionen aufgeführt und können hier auch definiert werden. Die Funktionen die unter "Alleinige Funktionen" aufgeführt sind, sind nur über diesen Pin / Leitung verfügbar.

Abbildung: Ausgabe, Pinbelegung

Funktionen der Eingänge

Funktion | Beschreibung
H/W Trigger | Hardware Trigger (nur über Pin 03 weiß verfügbar)
Encoder A+ | Eingang für Encoder, Spur A+(nur über Pin 10 violett verfügbar)
Encoder B+ | Eingang für Encoder, Spur B+(nur über Pin 05 rosa verfügbar)
Trigger freischalten | Funktion zum Freischalten oder Unterdrücken von Triggersignalen. Das Einlesen dieser Funktion benötigt ca. 1 ms. Es entsteht dadurch also eine Pause in der ein Triggersignal ignoriert wird, obwohl das Enable Trigger Signal anliegt.
Job 1 oder 2 | Jobumschaltung zwischen Job 1 und Job 2 abhängig von Pegel an diesem Eingang. Low = Job 1, High = Job 2.
Job 1...n | Jobumschaltung über Impulsfolge an einem Eingang, Wenn möglich sollte der Jobwechsel über die Binärsignale (binär codiert) stattfinden.
Einlernen temporär / Einlernen permanent | Einlernen aller Detektoren. Sobalf ein High Signal anliegt und ein Trigger erfolgt startet das Einlernen. Temporär = Speicherung im RAM, d.h. flüchtig nach Reset, Permanent = Speicherung im Flash, d.h. dauerhaft, auch nach Reset
Jobwechsel (BitX), binär codiert | Jobumschaltung via binärem Bitmuster an bis zu 5 hierfür definierbaren Eingängen, d.h. Umschaltung zwischen 1 bis zu 32 Jobs. Rangfolge der Bits laut zugewiesener, aufsteigender Eingangsbezeichnung 1 - 5. Bit 1= LSB. S. Kapitel: Job 1… 31 via binärem Eingangs-Bitmuster
Repeat Mode Enable | Es werden Bilder aufgenommen und ausgewertet solange: An diesem Eingang ein High Pegel anliegt und keines der folgenden Abbruchkriterien erfüllt ist: - "Gesamt Jobergebnis" = positiv (einstellbar unter Ausgabe/ Ausgangssignale) - "Max. Zykluszeit" nicht erfüllt ist (falls aktiviert). Wenn der Eingang Repeat Mode Enable genutzt wird wirkt dieser gleichzeitig als Trigger Enable. D.h. nur wenn an diesem Eingang ein High Pegel anliegt werden Trigger angenommen und verarbeitet, siehe unten:Eingang: Repeat Mode Enable, mit Trigger
Keine Funktion, undefiniert | Keine Funktion, nicht genutzt

Funktionen, die schon vollkommen ausgenutzt sind, erscheinen in der Listbox blass grau, da sie nicht mehr verfügbar sind. Alle Eingangssignale müssen eine minimale Signallänge von 2 ms aufweisen.

Abbildung: Ausgabe, Eingänge

Anschluss Encoder

Werden beide Spuren A+ und B+ verwendet ist die Vorwärts- / Rückwärts- Unterscheidung / Zählung möglich. Die Encodereingänge können eine maximale Frequenz von 18 kHz verarbeiten.

Abbildung: Encoder Spuren A+/ B+

Funktionen der Ausgänge

Funktion Beschreibung

Auswerfer

Spezieller Auswerferausgang kann mit bis zu 100 mA belastet werden (alle anderen Ausgänge = 50 mA), nur über Pin 12 RDBU verfügbar (entspricht der Anzeige- LED „A").

Ergebnis

Ergebnisausgang, jedem der hier definierten Ergebnisausgänge kann im Reiter „I/O- Logik" ein Detektorergebnis oder eine Verknüpfung von Detektorergebnissen zugewiesen werden.

Bestätigung Jobwechsel

Bei Jobwechsel via Digital I/O („Job 1..N" oder „Job PinX, binär codiert") kann hier zur Bestätigung des Erfolgsfalles eine Low / High Flanke eingestellt werden. Die High Flanke wird gesetzt, nachdem der neue Job- Inhalt geladen und aktiv ist, d. h. gleichzeitig mit der High Flanke beim Ready- Signal nach Umschaltung (siehe Timing ...). Der High Pegel bleibt für 20 ms stehen und wird dann wieder gelöscht.

Falls die Umschaltung nicht erfolgreich war, wird kein High Pegel ausgegeben und das Signal ist permanent Low.

Externe Beleuchtung

Wird diese Einstellung gewählt (nur über Pin 09 RD verfügbar), kann hier eine externe Beleuchtung angeschlossen / getriggert werden.

Keine Funktion,

undefiniert

Keine Funktion, nicht genutzt

Abbildung: Ausgabe, Ausgänge

Es gibt zwei fest definierte Ausgänge:

  • Ready: Zeigt an, ob der Sensor zum Empfang eines Triggers / nächsten Auswertung bereit ist.
  • Valid: Zeigt an, ob die Daten an den Ausgängen gültig sind.

Programmierbare Funktionen der digitalen Eingänge:

Im Betrieb mit einer Prozesssteuerung können folgende Funkionen über die Eingänge ausgeführt werden:

  • Inaktiv
  • Enable / Disable
  • Lade Job (binär codiert)
  • Lade Job 1 ... n
  • Einlernen temporär
  • Einlernen permanent

Beschreibung der unterschiedlichen Fälle mit Signaldiagramm.

Allen hier dargestellten Signalen liegt die Einstellung "PNP zugrunde"

Eingang: "Trigger freischalten"

Schaltet den Triggereingang des Sensors frei (High Signal), oder blockiert den Hardware-Trigger (Low-Signal).

Abbildung: Eingang Timing, Trigger freischalten

Eingang: Job Wechsel über Binärsignale, oder über Funktion Job 1 oder 2

Jobwechsel Binär, über bis zu 5 Eingänge (Job 1- max. 31):

Beim Wechsel der binären Eingangssignale wird Ready auf Low gesetzt. Ready bleibt Low bis die Umschaltung auf den neuen Job erfolgt ist. Falls das optionale Job- Wechsel Bestätigungs- Signal genutzt wird, erfolgt dieses nach dem Job-Wechsel, und Ready wird erst danach wieder High. Während der Jobumschaltung dürfen keine Triggersignale gesendet werden. Der Pegelwechsel der zugehörigen Eingänge muss gleichzeitig erfolgen (innerhalb von längstens 10ms müssen alle Pegel stabil anliegen, liegen die Pegelwechsel einzelner Eingänge weiter auseinander werden gegebenenfalls mehrere Jobumschaltungen nacheinander ausgeführt).

Jobwechsel durch Funktion Job 1 oder 2:

Beim Wechsel des Pegels des entsprechend definierten Eingangs wird Ready auf Low gesetzt. Ready bleibt Low bis die Umschaltung auf den neuen Job erfolgt ist. Falls das optionale Job- Wechsel Bestätigungs- Signal genutzt wird, erfolgt dieses nach dem Job-Wechsel, und Ready wird erst danach wieder High. Während der Jobumschaltung dürfen keine Triggersignale gesendet werden. Bei Job 1 oder 2 schaltet Low-Pegel auf Job 1 und High-Pegel auf Job 2

Unterschied Binärsignale gegenüber Job 1 oder 2:

Bei Nutzung der Umschaltung via Binärsignalen muss in jedem Fall die gewünschte Job Nr binär kodiert angelegt werden. Dafür müssen bei 2 Jobs mindestens 2 Eingänge genutzt werden.

Bei Job 1 oder 2 schaltet Low-Pegel auf Job 1 und High-Pegel auf Job 2. Es können also über einen Eingang zwei Jobs gewählt werden.

Abbildung: Eingang Timing, Jobwechsel via Binär / Job 1 oder 2

Eingang: Job 1 ... n

Zur Umschaltung von Jobs mittels digitalen Impulsen.

Impulse werden bis zur ersten Pause von >= 50 ms gezählt und danach wird auf den entsprechenden Job umgeschaltet. Ready wird nach erkannter Endebedingung (Pause >= 50 ms) auf Low gesetzt und bleibt Low, bis die Umschaltung auf den neuen Job erfolgt ist. Falls das optionale Job- Wechsel Bestätigungs- Signal genutzt wird, erfolgt dieses nach dem Job-Wechsel, und Ready wird erst danach wieder High. Die Impulslänge zur Jobumschaltung sollte 5 ms Puls und 5 ms Pause betragen (Die Puls/Pausen- Zeiten sollten nicht kürzer als 10ms/10ms, und nicht länger als 25ms/25ms sein). Während der Jobumschaltung dürfen keine Triggersignale gesendet werden. Wenn möglich sollte der Jobwechsel über die oben beschriebene Umschaltung via Binärsignalen erfolgen, diese ist gegebenenfalls die schnellere Variante.

Abbildung: Eingang Timing, Job 1...n

Achtung:

Bei der Jobumschaltung ist folgendes zu beachten:

  • Alle Jobs müssen die gleiche Einstellung zur Jobumschaltung haben.
  • Alle Jobs in Trigger- Modus.
  • Ready muss High sein wenn die Triggersequenz startet.

Eingang: Teach temp. / perm.

Zum neuen Teachen der Muster aller Detektoren des aktuellen Jobs. Eine steigende Flanke initiiert den Teach, dabei muss der High Pegel mindestens bis zum nächsten Trigger anliegen, damit ein Bild eines Prüfteiles in korrekter Lage aufgenommen werden kann. Ready wird auf Low gesetzt und bleibt Low bis der Teach erfolgt ist. Die Speicherung erfolgt je nach Einstellung temporär (nur im RAM), oder permanent (im Flash).

Abbildung: Eingang Timing, Teach

Hinweis:

Die Funktionen Job 1 oder 2, Job 1 ... n oder Einlernen temp./ perm. sind nur im Trigger- Modus nutzbar.

Eingang: Repeat Mode Enable, mit Trigger

Es werden Bilder aufgenommen und ausgewertet solange an diesem Eingang ein High Pegel anliegt und keines der folgenden Abbruchkriterien erfüllt ist:

  • "Gesamt Jobergebnis" = positiv (einstellbar unter Ausgabe / Ausgangssignale)
  • "Max. Zykluszeit" nicht erfüllt ist (falls aktiviert).

Wenn der Eingang Repeat Mode Enable genutzt wird wirkt dieser gleichzeitig als Trigger Enable. D.h. nur wenn an diesem Eingang ein High Pegel anliegt werden Trigger angenommen und verarbeitet

Abbildung: Eingang: Repeat Mode Enable, mit Trigger

Eingang: Repeat Mode Enable, im Freilauf

Abbildung: Eingang, Repeat Mode Enable, im Freilauf


Reiter Ausgangssignale (Digitalausgänge / Logik)

In diesem Reiter definieren Sie das Schaltverhalten und die logische Verknüpfung der einzelnen Detektoren mit den digitalen Ausgängen. Die Anzahl der Ausgänge richtet sich nach den Einstellungen unter dem Reiter Pinbelegung. Zusätzlich kann eine I/O Erweiterung über die serielle Schnittstelle angesteuert werden.

Abbildung: Ausgabe, Reiter Ausgangssignale / Logik

Logische Kombination der Detektoren für den jeweiligen Ausgang auswählen:

Je Pin (Ausgang) gibt es folgende Möglichkeiten:

Parameter | Funktion
Gesamt-Jobergebnis | Kein physikalischer Ausgang. Hat Auswirkung auf Logik für Rekorder, Statistik und Archivierungsfunktionen
Invertieren | Gesamtergebnis aus den folgenden Einstellungen für diesen Pin (Ausgang) invertieren
Modus | Standard: Mehrere Detektoren können über die logischen Operatoren UND (&) / ODER (|) / NOT (!) zu einem logischen Ausdruck kombiniert werden. Erweitert: Die logische Formel zum Kombinieren der Detektoren kann frei erstellt werden.
NOT | Auswahl: Operator NOT (!)
Logik | Auswahl: Operator UND (&) / ODER (|)
D1 - D... | Je nach Anzahl aktivierter Detektoren werden in dieser Liste alle Detektoren eingefügt. Diese können jedem aufgelisteten Ausgang logisch zugeordnet werden. Jeder Detektor kann für den jeweiligen Pin (Ausgang) ein-, invertiert- oder ausgeschaltet werden.
Logischer Ausdruck | Es wird entweder der im Standard Modus zusammengestellte logische Ausdruck angezeigt, oder der logische Ausdruck kann hier im Erweiterten Modus selbst zusammengestellt werden.

Logische Verknüpfung definieren:

Legen Sie die logische Verknüpfung zwischen den Prüfergebnissen der einzelnen Detektoren und den Status des gewählten Ausgangs fest. Sie haben zwei Möglichkeiten der Eingabe:

  • Standard Modus (Checkboxen und Operatoren)
  • Erweiterter Modus (Formeln)


Logische Verknüpfung – Standard-Modus

Im Standard-Modus wird die Verknüpfung der Detektor-Prüfergebnisse für den gewählten Ausgang über die Radiobuttons Operator und die Checkboxen in der Detektorauswahlliste vorgenommen. Das Ergebnis wird im Feld "Logische Formel" angezeigt (nicht editierbar).

Ergebnisse verknüpfen:

1. Wählen Sie im Feld Operator den logischen Operator für die Verknüpfung der Detektoren in der Auswahlliste.

2. Aktivieren Sie in der Auswahlliste diejenigen Detektoren, die zum Ergebnis beitragen sollen (Häkchen in der Spalte Aktiv).

Durch Aktivierung der Spalte „Invertiert“ können Sie das jeweilige Detektorergebnis invertieren.

Entsprechend ändert sich der Eintrag in der Spalte Ergebnis.

Beispiele:

Hier können die Detektorergebnisse nur durch eine logische Operation verknüpft werden wie z.B.:

  • (D1&D2&D3) oder
  • !((!D1)|D2|D3) etc.

Hinweis:

Wird ein Detektor einer Bildaufnahme (siehe "Mehrfachbildaufnahme" Kap. Reiter Zykluszeit) zugewiesen, wirkt sich dessen Ergebnis in den übrigen Bildaufnahmen nicht auf das Verknüpfungsergebnis aus.


Logische Verknüpfung – Formel Modus

Im Formel Modus wird die Verknüpfung der Detektor-Prüfergebnisse für den gewählten Ausgang durch Direkteingabe einer logischen Formel definiert. Hierfür stehen Ihnen die Operatoren AND, OR und NOT sowie runde Klammern zur Verfügung.

Zur Editierung der Formel bitte folgende Zeichen für die logischen Operatoren verwenden:

  • "&" für AND
  • "|" für OR (Taste "AltGr" und Taste "<>")
  • "!" für NOT

Beispiele:

Hier können beliebig komplexe logische Ausdrücke erstellt werden wie z.B:

  • (D1&D2)|(D3&D4)
  • !((D1|D2)&(D3|D4))
  • (D1|D2)&(D3|D4)&(D5|D6)

etc.

Hinweis:

Wird ein Detektor einer Bildaufnahme (siehe "Mehrfachbildaufnahme" Kap. Reiter Zykluszeit) zugewiesen, wird dessen Ergebnis in den übrigen Bildaufnahmen auf logisch "0" gesetzt. Das Verknüpfungsergebnis muss entsprechend angepasst werden.


Reiter Schnittstellen

In diesem Reiter selektieren und aktivieren Sie die genutzten digitalen Ein- / Ausgänge und die Schnittstellen zur Datenausgabe. In der Spalte „Aktiv“ können die Ausgänge und Schnittstellen separat aktiviert oder deaktiviert werden.

Abbildung: Ausgabe, Reiter Schnittstellen

Parameter Funktion

Interne I/O

Auswahl der Funktion der internen I/O: PNP oder NPN

RS422 (Baudrate)

RS422 zur Datenausgabe mit Auswahl der Datenübertragungsrate.

Grundeinstellungen: 8 Datenbits, 1 Stopbit, keine Parität.

Externe I/O Erweiterung

Zusätzliche externe Aus- und Eingänge (mit I/O- und Encoder- Erweiterungsmodul)

Ethernet

Ethernet TCP/IP zur Datenausgabe. Der Sensor ist immer ein Socket Server. Es werden zwei verschiedene Ports verwendet, die vom Anwender definiert werden können. Grundeinstellung: Port 2006 (IN) für Kommandos an den Sensor (Steuerbefehle und Antwortprotokoll) und Port 2005 (OUT) für die eigentliche Datenausgabe. Festo stellt eine Reihe von Utilities zur Erläuterung der Ethernet-Kommunikation zur Verfügung. Diese werden mit dieser Software im Verzeichnis Tools installiert.

EtherNet/IP

Feldbus EtherNet/IP zur Datenausgabe. SBS Vision-Sensor EtherNet/IP, Einleitung

PROFINET

Feldbus PROFINET zur Datenausgabe und SPS Kommunikation.

Hinweis:

Der Sensor startet den PROFINET-Stack, sobald ein Job mit PROFINET ausgewählt wird.

Dadurch verringert sich die Auswertegeschwindigkeit geringfügig. Ein Wechsel in einen Job ohne PROFINET stoppt den PROFINET-Stack nicht. Zum Stoppen des Stacks muss das Gerät ausgeschaltet werden.. SBS Vision-Sensor PROFINET, Einleitung

Vision Sensor Visualisation Studio

Aktivierung oder Deaktivierung des Moduls "Vision Sensor Visualisation Studio".

Bei einer Deaktivierung der Checkbox kann nicht mehr über den Button "Anzeigen" in Vision Sensor Device Manager auf Vision Sensor Visualisation Studio zugegriffen werden.

Ist die Checkbox "Vision Sensor Visualisation Studio" aktiviert (Default), können folgende Einstellungen für die Bildübertragung gewählt werden:

  • Einzeichnung
    Bei der Auswahl von "Einzeichnung" wird nur die Einzeichnung in Vision Sensor Visualisation Studio übertragen. Bild und Vorverarbeitungs-Einstellungen werden nicht übertragen.
  • Bild und Einzeichnung
    Bei der Einstellung "Bild und Einzeichnung" werden das Bild und die Einzeichnungen in Vision Sensor Visualisation Studio übertragen. Vorverarbeitungs-Einstellungen werden nicht übertragen.
  • Bild mit Vorverarbeitung und Einzeichnung
    Bei dieser Einstellung werden sowohl das Bild mit den Vorverarbeitungs-Einstellungen als auch die Einzeichnungen in Vision Sensor Visualisation Studio übertragen.

Weitere Informationen: Einzeichnung konfigurieren: und Reiter Vorverarbeitung

SBSxWebViewer

Schaltet den Webserver auf dem SBS Vision-Sensor ein. Ähnlich wie im lokal installierten Modul "Vision Sensor Visualisation Studio" können so über "SBSxWebViewer" Bilder und Ergebnisse über einen Webbrowser visualisiert werden.

Folgende Browser werden unterstützt: Microsoft Internet Explorer®ab IE10, Google Chrome® und Mozilla Firefox®.

Zum Starten von SBSxWebViewer wie folgt vorgehen:

  • SBSxWebViewer aktivieren, unter Ausgabe/Schnittstellen/SBSxWebViewer
  • "Sensor starten" (Button in Vision Sensor Configuration Studio)
  • Browser öffnen
  • in Adresszeile des Browsers die IP- Adresse des Sensors (sichtbar in Vision Sensor Device Manager) eingeben, im Format: "http://Ihre Sensor IP" z.B. "http://192.168.100.100" (Default).

Mit http://192.168.100.100/zoom.html (bzw. Alternativ der IP Adresse des Sensors) kann die vergrößerte Ansicht direkt aufgerufen werden.

Siehe auch: SBS – SBSxWebViewer

Für weitere Informationen siehe Benutzerhandbuch, Kapitel "Kommunikation"

Logische Ausgänge:

Bei Nutzung von RS422, Ethernet und EtherNet/IP Schnittstelle können zusätzliche logische Ausgänge definiert werden, die nur logisch existieren und nur per Datenausgabeschnittstelle kommuniziert werden können.

Logische Ausgänge können z.B. einem Detektorergebnis oder einem logischen Ausdruck (Formel) zugeordnet werden.


SBS – SBSxWebViewer

Dieses Programm dient zur Überwachung / Überprüfung von angeschlossenen Sensoren und zur Analyse von Prüfergebnissen. Es können keine neuen Einstellungen auf dem Sensor vorgenommen werden.

Abbildung: Ansicht SBSxWebViewer im Browser / Ergebnisse

Funktion

Ausschalten des Hilfefensters.

Zoom der Bildanzeige zum Vollbild. Klick auf das Vollbild verkleinert die Anzeige wieder.

Aus / Einschalten der Ergebnisbalken.

Aus / Einschalten der Einzeichnungen.

Speichern des aktuellen Bildes in eine Datei.

Umschaltung der Anzeigesprache.

Umschaltung zwischen Ergebnis, Statistik und Anzeige der auf dem Sensor vorhandenen Jobs.

Bildsteuerung: Möglichkeit zum „Einfrieren“ der Bildanzeige. Es wird nur die Bildanzeige gestoppt. Die Ausführung des Sensors im Hintergrund läuft weiter.

Anzeige des Status der Ausgänge des Sensors.

Abbildung: SBSxWebViewer / Statistik

Abbildung: SBSxWebViewer / Job

Zum Starten von SBSxWebViewer wie folgt vorgehen:

  1. SBSxWebViewer aktivieren, unter Ausgabe/Schnittstellen/SBSxWebViewer
  2. "Sensor starten" (Button in Vision Sensor Configuration Studio)
  3. Browser öffnen
  4. In Adresszeile des Browsers die IP- Adresse des Sensors (sichtbar in Vision Sensor Device Manager) eingeben, im Format: "http://Ihre Sensor IP", z.B. "http://192.168.100.100" (Default).

Hinweis:

  • Folgende Browser werden unterstützt: Microsoft Internet Explorer® ab IE10, Google Chrome® und Mozilla Firefox®.
  • Mit http://192.168.100.100/zoom.html (bzw. Alternativ der IP Adresse des Sensors) kann die vergrößerte Ansicht direkt aufgerufen werden.
  • Pro SBS Vision-Sensor ist nur eine Browser-Verbindung zulässig.


Reiter Zeitsteuerung

In diesem Reiter bestimmen Sie das Zeitverhalten des gewählten Signalausgangs. Wenn in der IO-Konfiguration ein Encoder aktiviert wurde, werden die Verzögerungen in Encoderschritten angegeben. Abhängig von der Einstellung in der I/O-Konfiguration werden alle folgenden Verzögerungen entweder in ms oder in Encoderschritten angegeben.

Abbildung: Ausgabe, Reiter Zeitsteuerung

Parameter

Funktion

Trigger Verzögerung

Zeit zwischen Trigger und Start der Bildaufnahme (in ms oder Encoderpulsen).

Maximaler Einstellwert ist 3000ms / Encoder Impulse.

Bei Nutzung von:

  • H/W Trigger (Digitaleingang): Diese Verzögerung ist wirksam.
  • Trigger (via Ethernet, PROFINET): Diese Verzögerung ist nicht wirksam (Die Bildaufnahme erfolgt direkt nach dem Trigger).

Digitale Ausgänge

Es können entweder alle Ausgänge verzögert werden, oder nur der Auswerferausgang.

Auswerfer / Ergebnissverzögerung

Zeit zwischen Trigger und Anliegen des Ergebnispegels (in ms oder Encoderpulsen). Es dürfen maximal 20 Bauteile zwischen den Trigger und den Auswerfer sein (Puffergröße).

Maximaler Einstellwert ist 3000 ms / Encoder Impulse.

Bei Nutzung von:

  • H/W Trigger (Digitaleingang): Diese Verzögerung ist wirksam und startet mit dem H/W Trigger.
  • Trigger (via Ethernet, PROFINET): Diese Verzögerung ist wirksam, startet aber erst nach der Bildauswertung (nicht mit dem Trigger!).

Signalisierung

Auswahl des Ereignisses, das die Ausgänge zurücksetzt.

Wechsel bei nächstem Ergebnis (Grundeinstellung)

Wechsel bei Trigger

Ergebnisdauer (feste Dauer in ms, danach Rücksetzen auf Inaktiv)

Ergebnisdauer

Dauer des Ergebnissignals in ms oder Encoder Impulsen.

Maximaler Einstellwert 3000 ms / Encoder Impulse

Achtung:

Bei Jobwechsel und Wechsel Run- zu Config Mode entstehen folgende Sonderzustände: Der Puffer der verzögerten Ausgänge wird gelöscht.

Digitalausgänge:

Diese werden bei Jobwechsel und Wechsel des Betriebsmodus von „Run" nach „Config" auf die Grundeinstellungen (Defaults) zurückgesetzt. Die Grundeinstellungen werden durch „Invert" im Tab Vision Sensor Configuration Studio/Ausgabe/Ausgangssignale festgelegt. “Invertiert = Aktiv" invertiert die Grundeinstellung des Digitalausgangs und gleichzeitig das Ergebnis.

Rücksetzen der Digitalausgänge:

Das Rücksetzen der Ergebnisausgänge kann in Abhängigkeit von verschiedenen Einstellungen / Ereignissen geschehen. Diese sind:

  • „Wechsel bei nächstem Ergebnis“ (Default):
    Der Ausgang wechselt seinen Pegel entsprechend dem logischen Ergebnis nur, wenn das nächste Ergebnis vorliegt. Typisch verwendet bei Weichensteuerung bei z.B. Sortierung etc.
  • „Wechsel bei Trigger“:
    Der Ausgang wird auf Inaktiv gesetzt (im Betriebsmodus PNP = Low) beim nächsten Trigger. Typisch verwendet bei Betrieb an einer SPS.
  • „Ergebnisdauer“:
    Der Ausgang wechselt zurück auf Inaktiv nach der hier eingestellten Ergebnisdauer in ms. Typisch verwendet bei z.B. pneumatischen Auswerfern (Ausblaser)

S. Vision Sensor Configuration Studio/Ausgabe/Zeitsteuerung/Signalisierung

Ready und Valid

  • Ready signalisiert wenn high, Bereitschaft für neue Bildaufnahme.
  • Valid signalisiert wenn high, dass Ergebnisse an den Ausgängen gültig sind.

PNP oder NPN Betriebsmodus

Alle hier beschriebenen Beispiele sind im Betriebsmodus „PNP“ ausgeführt. Ist die Einstellung „NPN“ gesetzt, gelten die Beispiele in analoger Weise mit umgekehrten Pegeln.

S.Vision Sensor Configuration Studio/Ausgabe/Schnittstellen/Interne I/O

Folgende Fälle im Zeitverhalten können unterschieden werden:

Normaler Trigger ohne Nutzung von Verzögerungszeiten:

Ablauf: (hier Signalisierung: Wechsel beim nächsten Ereignis)

  • steigende Flanke am Trigger-Eingang (Pin03 WH)
  • als Folge von Trigger = High: Ready = Low, und Valid = Low
  • Nachdem der SBS das Bild ausgewertet hat, und die entsprechenden Ergebnisse vorliegen, wechseln alle definierten Ausgänge in die entsprechenden logische Zustände und Ready und Valid gehen wieder auf High- Pegel. (Ausgänge gültig, SBS bereit zur nächsten Auswertung)

Abbildung: Digitale Ausgänge Timing, Standardablauf bei normalem Trigger

Trigger-Verzögerung aktiv

(Trigger- Verzögerung wirkt nur auf Hardware- Trigger)

Diese Einstellung dient zur gezielten Verzögerung der Bildaufnahme / Beginn der Auswertung gegenüber dem tatsächlich physikalischen Trigger, der z.B. durch eine Trigger-Lichtschranke oder die Maschinensteuerung ausgelöst wurde. Hiermit ist die Feineinstellung des Triggerzeitpunkts ohne Änderungen an Mechanik oder Steuerungsprogramm möglich.

Ablauf:

Bild wird nach Trigger erst nach verstrichener Trigger- Verzögerungs- Zeit aufgenommen. Die Zykluszeit ist: Trigger-Verzögerung + Auswertezeit.

Siehe Vision Sensor Configuration Studio/Ausgabe/Zeitsteuerung/Trigger/ Verzögerung

  • Steigende Flanke am Trigger- Eingang (Pin03 WH)
  • Als Folge von Trigger = High: Ready = Low, Valid = Low, alle definierten Ergebnisausgänge = Low (Signalisierung = Wechsel bei Trigger)
  • Bevor das Bild für die Auswertung aufgenommen wird, verstreicht die eingestellte Trigger- Verzögerungszeit (Trigger delay)
  • Nun erfolgt die Auswertung. Sobald die entsprechenden Ergebnisse vorliegen, wechseln alle definierten Ausgänge in die entsprechenden logischen Zustände. Ready und Valid gehen wieder auf High-Pegel (Ausgänge gültig, SBS bereit zur nächsten Auswertung).

Abbildung: Digitale Ausgänge Timing, Trigger Verzögerung

Trigger Verzögerung + Ergebnisverzögerung (hier nur Auswerfer):

(Trigger- Verzögerung wirkt nur auf Hardware- Trigger)

Die Ergebnisverzögerung (ob für alle Ausgänge oder nur Auswerfer) dient zur Feineinstellung des z.B. Auswerferzeitpunktes unabhängig von der Auswertezeit, da insbesondere diese auch leichte Schwankungen aufweisen kann.

Ablauf:

Bild wird nach Trigger erst nach verstrichener Trigger- Verzögerungs-Zeit aufgenommen. Außerdem wirkt die Ergebnisverzögerung. In diesem Beispiel jedoch nur auf den Auswerfer-Ausgang (Pin 12 RDBU).

Die Zykluszeit ist für die definierten Ergebnisausgänge, außer dem Auswerfer-Ausgang: Die Trigger- Verzögerung- + Auswertezeit

Die Zykluszeit für den Auswerfer-Ausgang ist: Alleine die Ergebnisverzögerung (gezählt ab Triggerzeitpunkt, nur sinnvoll wenn länger als Summe Zeiten !). Siehe Vision Sensor Configuration Studio/Ausgabe/Zeitsteuerung/Digitale Ausgänge/Verzögerung.

  • Steigende Flanke am Trigger- Eingang (Pin03 WH)
  • Als Folge von Trigger = High: Ready = Low, Valid = Low, alle definierten Ergebnisausgänge = Low. Außer Auswerfer, für diesen ist hier eine feste Ergebnisdauer definiert,
  • Bevor das Bild für die Auswertung aufgenommen wird, verstreicht die eingestellte Trigger- Verzögerungszeit (Trigger delay)
  • Nun erfolgt die Auswertung. Sobald die entsprechenden Ergebnisse vorliegen, wechseln alle definierten Ausgänge (hier außer Auswerfer) in die entsprechenden logischen Zustände. Ready und Valid gehen wieder auf High- Pegel.
  • In diesem Betriebsmodus wird einzig der Auswerferausgang erst nach dem Verstreichen der Ergebnisverzögerung gesetzt. Der Auswerferausgang ist in diesem Beispiel auch mit einer Ergebnisdauer versehen und wird deshalb definiert nach dieser Ergebnisdauer auf Inaktiv gesetzt.

Abbildung: Digitale Ausgänge Timing, Ergebnis Verzögerung Auswerfer

Trigger Verzögerung + Ergebnisverzögerung (hier alle Ausgänge):

(Trigger- Verzögerung wirkt nur auf Hardware- Trigger)

Die Ergebnisverzögerung (ob für alle Ausgänge oder nur Auswerfer) dient zur Feineinstellung des z.B. Auswerferzeitpunktes unabhängig von der Auswertezeit, da insbesondere diese auch leichte Schwankungen aufweisen kann.

Ablauf:

Bild wird nach Trigger erst nach verstrichener Trigger- Verzögerungs- Zeit aufgenommen. Außerdem wirkt die Ergebnisverzögerung, in diesem Beispiel auf ALLE definierten Ergebnisausgänge.

Die Zykluszeit ist für alle Ergebnisausgänge: Alleine die Ergebnisverzögerung (gezählt ab Triggerzeitpunkt, nur sinnvoll wenn länger als Summe von Trigger-Verzögerung + Auswertezeit!). Siehe Vision Sensor Configuration Studio/Ausgabe/Zeitsteuerung/Digitale Ausgänge/Verzögerung

  • Steigende Flanke am Trigger- Eingang (Pin03 WH)
  • Als Folge von Trigger = High: Ready = Low und Valid = Low.
  • Bevor das Bild für die Auswertung aufgenommen wird, verstreicht die eingestellte Trigger- Verzögerungszeit (Trigger delay)
  • Nun erfolgt die Auswertung. Nach Vorliegen der entsprechenden Ergebnisse, wird einzig das Signal Ready nun gleich wieder auf High gesetzt (bereit zur nächsten Auswertung). Ansonsten wird noch auf das Verstreichen der Ergebnisverzögerung gewartet. Erst dann wechseln alle definierten Ausgänge in die entsprechenden logischen Zustände. Auch Valid geht wieder auf High- Pegel (Valid = High: Ergebnisausgänge gültig, Signalisierung = Wechsel bei nächstem Ergebnis).

In diesem Betriebsmodus wechselt einzig das Signal „Ready“ schon nach Verstreichen von Trigger- Verzögerung + Bildaufnahme + Auswertezeit. Ready = High: Bereit zur nächsten Auswertung. Dies ist sinnvoll, da der SBS unabhängig vom späteren Setzen der Ausgänge, schon wieder bereit ist für die nächste Auswertung.

Abbildung: Digitale Ausgänge Timing, Ergebnis Verzögerung alle Ausgänge

Ergebnis-Dauer aktiv (hier z.B. alle Ausgänge):

Diese Zeiteinstellung dient zur Erzielung eines Ausgangspulses mit definierter Länge, etwa zur Ansteuerung eines pneumatischen Auswerfers (Ausblaser) im Falle eines Schlechtteiles, o.ä.

Alle definierten Ergebnisausgänge werden nach dem Aktivieren, exakt nach der eingestellten Ergebnis-Dauer in ms wieder auf Low-Pegel (Inaktiv im PNP-Betrieb) zurück gesetzt.

Abbildung: Digitale Ausgänge Timing, Ergebnis Dauer

Zykluszeit (Min, Max) aktiv:

(hier: Signalisierung: Wechsel bei Trigger)

Parameter zur Steuerung der Ausführungszeit eines Jobs.

Die minimale Ausführungszeit kann zum Unterdrücken von Mehrfachtriggern verwendet werden und kann Auswirkung auf die LED Leistung haben. (D. h. falls noch innerhalb der minimalen Job- Zeit ein weiterer Trigger eingeht wird dieser ignoriert)

Die maximale Ausführungszeit dient zum Abbruch eines Jobs nach einer definierten Zeit. Das Ergebnis des Jobs ist nach Abbruch immer "nicht o.k.". Die maximale Ausführungszeit sollte immer größer gewählt werden als der Zeitbedarf für eine Auswertung.

Die Zykluszeit misst die Zeit vom Trigger bis zum Setzen der digitalen Schaltausgänge. Soll die Zykluszeit begrenzt werden, z.B. weil der Maschinentakt nicht überschritten werden darf, muss der Wert für die maximale Zykluszeit entsprechend begrenzt werden. Das Ergebnis aller bis zu diesem Zeitpunkt nicht fertig ausgeführten Detektoren wird auf fehlerhaft gesetzt. Bei der Wahl der maximalen Zykluszeit ist zu berücksichtigen, dass diese nicht hart eingehalten wird, sondern in Abhängigkeit des gerade ausgeführten Detektors etliche weitere Millisekunden bis zum Abbruch verstreichen können. Es wird empfohlen, diese Überschreitung der maximalen Zykluszeit anhand der tatsächlichen Ausführungszeit zu überprüfen und den eingestellten Wert für die maximale Zykluszeit entsprechend zu verkleinern.

Ablauf:

Alle Ausgänge und das Signal „Valid“ (Ausgänge gültig) werden direkt nach der Auswertung gesetzt.

Das Signal „Ready“ (Bereit zur nächsten Auswertung) wird jedoch erst nach Verstreichen der Min. Job Zeit gesetzt, und damit werden erst ab diesem Zeitpunkt wieder Trigger für die nächste Auswertung akzeptiert.

Abbildung: Digitale Ausgänge Timing, Min Job Zeit

Multiple Ergebnisverzögerung für Auswerfer

Dieser Betriebsmodus wird verwendet, wenn zwischen Trigger/Auswertung für Prüfteil A und dessen Ausschleusung so viel Zeit / Förderstrecke liegt, dass der SBS bereits n (bis max. 20 möglich) weitere Prüfteile prüfen und deren jeweils ebenfalls späteren Ausschleusungszeitpunkt verwalten muss.

(nur verfügbar im Modus: Vision Sensor Configuration Studio/Ausgabe/Zeitsteuerung/Verzögerung: „Nur Auswerfer / Auswerfer- / Ergebnisverzögerung“ (ejector / result delay))

Hier: Signalisierung = Ergebnis-Dauer (alternativ auch „Wechsel bei nächstem Ergebnis“ verwendbar)

Es dürfen maximal 20 Bauteile zwischen den Trigger und den Auswerfer passen.

Abbildung: Digitale Ausgänge Timing, Multiple Ergebnisverzögerung Auswerfer


Reiter Datenausgabe

Nächste Themen:

Reiter Bildübertragung

Übersicht Telegramme:

EtherNet/IP, Anhang

Konfiguration der Datenausgabe für die seriellen Schnittstellen RS422 und Ethernet sowie für die Archivierung in .csv-Dateien. Hier können sämtliche Einstellungen, welche Ergebnisdaten vom SBS über die zuvor ausgewählte und aktivierte Schnittstelle ausgegeben werden sollen, getroffen werden.

Abbildung: Ausgabe, Reiter Datenausgabe

Parameter | Funktion
Binär / ASCII | Auswahl, ob Ausgabedaten in Binär- (Hex) oder in ASCII- Format ausgegeben werden.
Export | Export des Dateiformats mit aktuellen Ergebnissen als .csv. Detail- Ausgabe des Datenformats des frei definierten Ausgabestrings als .csv- Datei mit: Byte- Position (Startposition im String), Datentyp, Feldname, Detektorname, Wert, Länge (in Byte), Detektornummer und Detektortyp.
Rücksetzen | Rücksetzen aller Eintragungen in diesem Reiter

Protokoll-Standardinhalte (Vorspann .... bis .... Prüfsumme)

Oft benötigte Standardinhalte können durch einfaches Ausfüllen bzw. Aktivieren via Checkbox zum Ausgabestring hinzugefügt werden.

Parameter | Funktion
Vorspann | Zeichen, die am Anfang der Zeichenfolge eingefügt werden (Binär oder ASCII).
Nachspann | Zeichen, die am Ende der Zeichenfolge eingefügt werden (Binär oder ASCII).
Trennzeichen | Zeichen, die hinter jedem Nutzdatenwert eingefügt werden (nur ASCII).
Telegrammende | Zeichen, die am Ende einer Antwort an einen PC oder eine SPS gesendet werden (Reaktion auf einen Befehl, nicht mit Nutzdaten, nur im ASCII-Modus, Ausgabe wählbar in ANSI oder Hexa Decimal).
Gewählte Felder | Zeigt an, welche der folgenden Kontrollkästchen aktiviert sind.
.... weitere Standardinhalte, wie z.B.Gewählte Felder, Telegrammlänge | Zum Datenstring: "Payload" Sequenz: Gewählte Felder, Telegrammlänge, Statusbyte, Detektorergebnisse, Digitalausgänge, Logische Ausgänge, Ausführungszeit, Aktiver Job, Prüfsumme

Detektorspezifische Einzelergebnisse zum Ausgabestring hinzufügen

Verfügbare Nutzdaten finden Sie unter: Detektorspezifische Nutzdaten

Zuerst mit der Schaltfläche "+" einen neuen Eintrag erzeugen.

Funktion der Schaltfelder

  • "+": Neuen Eintrag einfügen
  • "-": Markierten Eintrag löschen
  • "Auf", "Ab": Markierten Eintrag verschieben

Über die Auswahlliste „Detektorspezifische Nutzdaten“ können Sie detektorspezifische Einzelergebnisse in der gewünschten Reihenfolge flexibel zum Datentelegramm hinzufügen. Hinzufügen von Werten mit Button „+“

Abbildung: Ausgabe, Detektorspezifische Nutzdaten

Spalte Funktion

Aktiv

Aktivieren/Deaktivieren des markierten Ausgabewerts

Detektor

Detektorname (Wahl über Ausklappliste)

Wert

Verfügbare Detektorergebnisse (Wahl über Ausklappliste): Detektorspezifische Nutzdaten

Min. Länge

Festlegung der Mindestlänge des Felds Wert; ist die tatsächliche Länge geringer als die Vorgabe, wird das Feld mit Leerzeichen (ASCII) bzw. Nullen (binär) aufgefüllt
Anz. Ergebnisse

Nur BLOB!

Anzahl der Ergebnisse eines BLOB Detektors, der mehrere Objekte fand.

Beispiel: Es wurde nach dem Merkmal "Fläche" gefiltert und 10 BLOBs / Objekte wurden gefunden. Nun können hier bis zu 10 dieser Flächenwerte als Ausgabedaten in einer Sequenz übertragen werden.

Alle verfügbaren Ausgabedaten siehe Serielle Kommunikation ASCII , Serielle Kommunikation BINÄR, Kapitel: Datenausgabe in ASCII / Binär

Datenausgabemöglichkeiten (siehe auch Kapitel Kommunikation)

(Ethernet-)port 2005 / RS422

Numerische Daten, die unter Ausgabe/Datenausgabe konfiguriert wurden, können in einem eigenen ASCII/BINAER Format ausgegeben werden.

Ethernet: Der Sensor ist hierbei der (Socket-)“Server" und stellt die Daten über eine „Server-Socket" Schnittstelle zur Verfügung. Hauptsächlich ist dies eine „Programmier-Schnittstelle". Um die Daten lesen/verarbeiten zu können muss ein „Socket-Client" (PC, SPS, etc.) eine (Socket-)Verbindung (aktiv) zum Sensor aufbauen, und kann dann die Daten verarbeiten.

PC-Archivierung (Vision Sensor Visualisation Studio)

Hiermit können Bilder und numerische Daten (im csv Format) durch den „Viewer" (Vision Sensor Visualisation Studio) selbst permanent (in ein Verzeichnis auf dem PC) mitprotokolliert werden. Die Konfiguration (Verzeichnis, etc.) dieser Archivierung erfolgt über den „Viewer" (-> über Menü „Datei/Archivierung konfigurieren"). Dies ist eine reine PC-Funktionalität.

Sensor-Archivierung (ftp, smb)

Hiermit können Bilder und numerische Daten (im csv Format) aktiv durch den Sensor per ftp/smb archiviert werden. Diese Archivierung kann/muss unter „Job/Archivierung" konfiguriert werden. Bei dieser Art der Archivierung ist:

  1. bei ftp der Sensor ein „ftp Client" und „schreibt" die Daten auf ein im Netzwerk verfügbares „ftp-Server" Verzeichnis. Der Sensor verbindet sich bei Job-Start mit dem ftp-Server.
  2. bei smb schreibt der Sensor seine Daten direkt in ein im Netzwerk freigegebenes Verzeichnis. Der Sensor verbindet/mounted sich bei Job-Start mit diesen Verzeichnis.

Ramdisk (auf dem Sensor)

Auf dem Sensor wird das letzte Bild, sowie numerische Daten, welche unter „Ausgabe/Datenausgabe" konfiguriert wurden, permanent (in einer .csv Datei) auf dem Sensor in ein Ramdisk-Verzeichnis unter „/tmp/results/" gespeichert. Diese Funktionalität muss unter „Job/Bildübertragung" aktiviert werden. Um diese Daten „lesen" zu können, muss aktiv eine ftp-Verbindung zum Sensor aufgebaut werden. Hierzu wird ein ftp-Client benötigt.

Hinweis:

  • Das Format der csv Dateien (ftp, smb, ram-disk, Vision Sensor Visualisation Studio) ist einheitlich „gleich".
  • Die Daten werden lesbar (per default mit Semikolon getrennt) in die csv Datei ausgegeben.
  • Es werden nur (Nutz-)Daten, welche unter (Ausgabe/Datenausgabe) konfiguriert wurden ausgegeben.

Kommunikationseinstellungen

Kommunikation | TCP / IP | RS422 / RS232 | EtherNet/IP | PROFINET
Telegramm Format | ASCII / Binär | ASCII / Binär | Binär | Binär

S. auch Kap.: Übersicht Telegramme:

S. auch Kap.: Übersicht Telegramme

Protokoll-Einstellungen

Parameter | Funktion
Protokoll | Kommunikation Binär oder ASCII
Export | Speichern der Vorschau auf dem PC, z.B. als Vorlage für SPS-Programmierung

Grundlagen zum Aufbau der Verbindung:

Der SBS wird immer als tcp/ip (socket-) server verwendet.

Der SBS Vision-Sensor öffnet immer zwei (socket-) Kommunikationsports (default: 2005 + 2006).

  • 2005 = Daten Port zum Senden numerischer Ergebnisse an den Kunden.
  • 2006 = Befehlsport um Befehle am Sensor zu empfangen.

Es kann gleichzeitig nur ein (socket-) client (PC or PLC) an jeden Port verbunden werden.

Empfehlungen:

Bestehende Socket Verbindungen müssen nur wieder verbunden werden, wenn ein Fehler aufgetreten ist (z.B.: SPS oder Client in Stop mode oder Fehler mode, etc.). Während des fehlerfreien Betriebes brauchen keine bestehenden Verbindungen erneut aufgebaut werden.

Ethernet Daten Handling: Besonders bei Nutzung mehrerer SBS, sollte bevorzugt über die Ethernet Kommunikation erfolgen.

Bitte beachten Sie folgende automatisch mit installierte Hilfe:

....:\Programme\Festo\SBS Vision-Sensor\Tools\Ethernet


Reiter Bildübertragung

Nächstes Thema: Reiter Archivierung

Im Reiter Bildübertragung kann die Bildübertragung und / oder der Bildrekorder und die Ram Disk aktiviert werden. Stellen Sie die Bildschärfe mit der Fokus-Einstellschraube auf der Rückseite des SBS Vision-Sensors ein.

Achtung:

Dieses Icon im Livebild sagt aus, dass die Bilddarstellung / Bildspeicherung im PC langsamer läuft als die Bildauswertung auf dem SBS. Es werden nicht mehr alle Bilder, die vom SBS aufgenommen werden, angezeigt. Dies kann bei Verwendung der Schlechtbild-Archivierung evtl. zu Bildverlusten führen.

Bei häufigem Auftreten des Icons, sollten auf dem PC geöffnete Programme im Hintergrund geschlossen werden, um mehr PC-Leistung zur Verfügung zu stellen.

Parameter Funktion

Bildrekorder

Speicherung von max. 10 Bildern im internen Ringspeicher des Sensors. Einstellmöglichkeiten: Aus, Alle, Gutteile, Schlechtteile

Ram Disk

Speicherung des letzten Bildes im internen RAM-Speicher, dieses Bild kann von einem FTP- Client abgeholt werden.

Einstellmöglichkeiten: Aus, Alle, Gutteile, Schlechtteile.

Das Bild wird im RAM des SBS unter dem Namen "image.bmp" im Verzeichnis /tmp/results/ abgelegt.

Parameter für FTP- Client: Benutzer: "user", Passwort: "user"

Beispiel Windows Konsole: Start > Ausführen > cmd

Microsoft Windows XP [Version 5.1.2600]

(C) Copyright 1985-2001 Microsoft Corp.

C:\>ftp 192.168.100.100

Verbindung mit 192.168.100.100 wurde hergestellt.

220 Welcome to SBS ftp-server!

Benutzer (192.168.100.100:(none)): user

331 Please specify the password.

Kennwort: user

230 Login successful.

ftp> cd /tmp/results

250 Directory successfully changed.

ftp> get image.bmp

200 PORT command successful. Consider using PASV.

150 Opening BINARY mode data connection for image.bmp (354358 bytes).

226 File send OK.

FTP: 64d Bytes empfangen in 0,23Sekunden 1514,35KB/s

ftp>

Das Bild befindet sich nun im Laufwerk C des ausführenden PC.

Wenn eingeschaltet, können auf gleichem Wege die Ergebnisdaten (alle in "Ausgabe/ Datenausgabe" definierten, mit Trennzeichen ";") über die Datei "result.csv" bezogen werden.

Verschiedene Möglichkeiten der Bildarchivierung

Zugang | Beschreibung | Max. Anzahl an Bildern | Bildfilter | Grafiken
Bildrekorder in SBS (Ram) | Bilder werden im Run-Modus auf dem SBS abgespeichert. Sie können von Vision Sensor Configuration Studio oder Vision Sensor Visualisation Studio an einen PC gesendet werden. | 10 | wie festgelegt in den Einstellungen "Filter". | Nein
Vision Sensor Visualisation Studio Archivierung/ Vision Sensor Configuration Studio speichert Bild | Gesendete Bilder an Vision Sensor Visualisation Studio können auf der Hard disc des PCs abgespeichert werden. | unbegrenzt (Limit ist die Größe der Hard disc im PC) | wie festgelegt in den Einstellungen "Filter". | auswählbar Ja / Nein
Speichern von Filmstreifen in Vision Sensor Configuration Studio | Aktuelle Bilder des Filmstreifen können als Filmstreifen (*.flm) oder als bitmap (*.bmp) auf der hard disc des PCs gespeichert werden.. | 50 | ohne Filterung | Nein
Letztes Bild in SBS (Ram Disk) | Letztes Bild ist gespeichert auf der ram disc des SBS und kann über FTP von "directory /tamp/results" genommen werden. | 1 | ohne Filterung | Nein
Archivierung der Bilder via FTP oder SMB | Archivierung der Bilder via FTP oder SMB | unbegrenzt (Limit ist die Größe der Hard disc im PC) | Auswählbar mit oder ohne Filterung | Nein
Get Image Request | Das letzte Bild des SBS wird mit dem Kommando "GetImage"in ein Programm der PLC oder des PCs übertragen | unbegrenzt (Limit ist die Größe der Hard disc im PC) | wie festgelegt in den Einstellungen "Filter". | Nein

Abbildung: Reiter Ausgabe / Bildübertragung


Reiter Archivierung

Im Reiter Archivierung können Sie die Archivierung der Daten konfigurieren.

Nächstes Thema: Reiter Vorverarbeitung

Parameter Funktion und Einstellmöglichkeiten

Archivtyp

Aus: Keine Archivierung

FTP: Archivierung zum FTP Server

SMB: Archivierung auf ein Laufwerk über SMB Dienst (Server Message Block)

Hinweis:

Bei Nutzung von Archivservern in anderen Subnetzen zunächst in Vision Sensor Device Manager das Gateway einstellen.

IP-Adresse

IP-Adresse des Zielservers / clients

Freigabename

Freigabename der bei der Ordnerfreigabe im PC im Dialog: "Erweiterte Freigabe" definiert wurde.

Arbeitsgruppe (Domainname)

Optional !, Arbeitsgruppe / Domainname des Zielservers / clients.

Benutzername

Benutzer Name für FTP / SMB Verbindung.

Passwort

Passwort für FTP / SMB Verbindung.

Ergebnisdateien

Wird die Protokolldatei aktiviert, werden alle Daten, die unter "Ausgabe / Datenausgabe" spezifiziert wurden, zusätzlich in eine .csv-Datei protokolliert. Es wird pro Auswertung (Trigger) eine Datei angelegt. Die Dateien werden fortlaufend nummeriert.

Bilddateien

Archivierung der Bilder aktivieren.

Hinweis:

  • Bilder werden ohne Vorverarbeitungseinstellungen, aber mit den Einstellungen zur Anordnung (also evtl. gedreht oder gespiegelt) gespeichert
  • FTP und SMB speichern Bilder immer nur ohne Einzeichnung. Um Bilder mit Einzeichnungen abzuspeichern, bitte Vision Sensor Visualisation Studio verwenden.

Speichermodus

Begrenzt: Wenn die maximale Anzahl der Dateien erreicht ist, wird die Übertragung beendet.

Unbegrenzt: Dateien werden geschrieben, bis das Ziellaufwerk voll ist.

Zyklisch: Nach Erreichen der maximalen Anzahl von Dateien wird jeweils die älteste von der neusten überschrieben.

Max. Anzahl Dateien

Maximale Anzahl von Datensätzen, die im Zielverzeichnis abgelegt werden dürfen.

Verzeichnis (Gutteile)

Verzeichnis für Archivierung der Datensätze der Gutteile (Für C:/TESTGUT nur TESTGUT eingeben).

Verzeichnis (Schlechtteile)

Verzeichnis für Archivierung der Datensätze der Schlechtteile (Für C:/TESTSCHLECHT nur TESTSCHLECHT eingeben) .

Dateiname

Dateiname für Bilder und Protokolldatei, dieser Name wird noch automatisch durch die Bildnummer ergänzt (Z.B. TESTDATEI).

Ausdruck hinzufügen

Dem Dateinamen wird ein dynamischer Anteil (Informationen, wie z.B. Datum und Uhrzeit) hinzugefügt.

S. auch untenstehende Tabelle

Die nachfolgenden Tabelle zeigt die Ausdrücke, die dem Dateinamen hinzugefügt werden können.

Ausdruck | Beschreibung | Beispiel
TIME | HHhMMmSSsSSSms | 09h05m11s034ms
HOUR | hh | 09
MIN | mm | 05
SEC | ss | 11
MSEC | sss | 034
DATE | YYYY-MM-DD | 2011-09-21
YEAR | YYYY | 2011
2YEAR | YY | 11 (für 2011)
MONTH | MM | 09
DAY | DD | 21
STRINGID | Eintrag "Daten" aus dem erweiterten Trigger-Request "TRX" | Part 34
COUNTER | Counter aus der Statistik | 3824
XXCOUNTER

Counter aus der Statistik mit definierter Zifferanzahl.

XX gibt die Anzahl der anzuzeigenden Ziffern an und kann Werte von 01 bis 09 annehmen

Hinweis:

Wenn die Anzahl der Ziffern des Counters zu klein ist, wird vorangehend mit "0" aufgefüllt.

Wenn die Anzahl der Ziffern des Counters zu groß ist, werden Ziffern verworfen.

06COUNTER → 003824
RESULT

Gesamtergebnis des Jobs

Pass or Fail
SENSORNAME | Wie in Vision Sensor Device Manager spezifiziert
JOBNAME | Wie in Vision Sensor Configuration Studio spezifiziert

Abbildung: Reiter Ausgabe / Archivierung


Bedienschritt Ergebnis

Mit dieser Funktion wird der definierte Job auf dem PC ausgeführt, und das „Ergebnisse/Statistik" Fenster mit Detektorliste und Auswerteergebnissen angezeigt. Die Ausführungszeiten werden in diesem Modus nicht aktualisiert, da sie vom Sensor nicht vorliegen.

Im Run-Modus werden die detaillierten Prüfergebnisse des in der Auswahlliste markierten Detektors angezeigt. Im Bildfenster werden – sofern eingestellt – das Bild, die Such- und Merkmalsbereiche und Ergebnisgrafen angezeigt.

Abbildung: Ergebnis

Angezeigte Ergebnisparameter | Funktion | Für Detektortyp
Detektor Ergebnis | Boolsches Detektorergebnis | Alle Detektoren
Score 1 .. n | Score (0..100%), z.B. Detektor Mustervergleich: Übereinstimmungsgrad des gefunden Musters mit dem eingelernten Muster | Alle Detektoren
Ausführungszeit | Ausführungszeit des einzelnen Detektors in [msec]. | Alle Detektoren
Abstand | Berechneter Abstand, signed integer [1/1000] *1) | Messschieber
Position X 1 .. n | Gefundene Position X (x-coordinate). [1/1000] *1) | Mustervergleich Kontur Kantenantastung Messschieber Datacode Barcode OCR
Position Y 1 .. n | Gefundene Position Y (y-coordinate). [1/1000] *1) | Mustervergleich Kontur Kantenantastung Messschieber Datacode Barcode OCR
Delta Pos X | Delta Position X zwischen eingelerntem und gefundenem Objekt [1/1000] *1) | Mustervergleich Kontur Kantenantastung
Delta Pos Y | Delta Position X zwischen eingelerntem und gefundenem Objekt [1/1000] *1) | Mustervergleich Kontur Kantenantastung
Winkel | Orientierung des gefundenen Objekts (0°..360°) [1/1000]*1) | Mustervergleich Kontur Kantenantastung Datacode Barcode OCR
Delta Winkel | Winkel zwischen eingelerntem und gefundenem Objekt (0°..360°) [1/1000] *1) | Mustervergleich Kontur Kantenantastung
Skalierung | Nur bei Kontur (0,5..2) [1/1000] *1) | Kontur
R(ot) | Mittelwert für Farbparameter, signed integer [1/1000] *1) | Farbwert Farbliste
G(rün) | Mittelwert für Farbparameter, signed integer [1/1000] *1) | Farbwert Farbliste
B(lau) | Mittelwert für Farbparameter, signed integer [1/1000] *1) | Farbwert Farbliste
H(ue) | Helligkeitswert der Farbe, signed integer [1/1000] *1) | Farbwert Farbliste
S(aturation) | Sättigungswert der Farbe, signed integer [1/1000] *1) | Farbwert Farbliste
V(alue) | Wert für Farbton, signed integer [1/1000] *1) | Farbwert Farbliste
L(uminanz) | Luminanzwert für Farbparameter, signed integer [1/1000] *1) | Farbwert Farbliste
A | Wert für Farbparameter, signed integer [1/1000] *1) | Farbwert Farbliste
B | Wert für Farbparameter, signed integer [1/1000] *1) | Farbwert Farbliste
Ergebnis Index | Listenindex, signed integer, [1/1000] *1) | Farbliste
Farbabstand | Abstand der aktuellen Farbe gegenüber der eingelernten Farbe, signed integer [1/1000] *1) | Farbliste
Fläche | Fläche des BLOBs, ohne Löcher, in Pixel, signed integer, [1/1000] *1) | BLOB
Fläche (inkl. Löcher) | Fläche des BLOBs, mit Löchern, in Pixel, signed integer, [1/1000] *1) | BLOB
Konturlänge | Anzahl der Pixel der äußeren Kontur, signed integer, [1/1000] *1) | BLOB
Kompaktheit | Kompaktheit des BLOBs, (Kreis = 1, andere >1), signed integer [1/1000] *1) | BLOB
Schwerpunkt X | X- Koordinate des BLOB- Schwerpunkts, signed integer [1/1000] *1) | BLOB
Schwerpunkt Y | Y- Koordinate des BLOB- Schwerpunkts, signed integer [1/1000] *1) | BLOB
Zentrum X | X- Koordinate des gefitteten Rechtecks / Ellipse, signed integer [1/1000] *1) | BLOB
Zentrum Y | Y- Koordinate des gefitteten Rechtecks / Ellipse, signed integer [1/1000] *1) | BLOB
Breite | Breite des gefitteten, geometrischen Elements (Rechtecks / Ellipse). Breite >= 0, Breite >= Höhe, negative Werte = Fehler), signed integer [1/1000] *1) | BLOB
Höhe | Höhe des gefitteten, geometrischen Elemets (Rechtecks / Ellipse). Höhe >= 0, Höhe <= Breite, negative Werte = Fehler), signed integer [1/1000] *1) | BLOB
Winkel (360) | Winkellage des Objekts in Grad (Wertebereich +180° ... -180, 0° = Ost, Drehrichtung = Gegenuhrzeigersinn), signed integer [1/1000] *1) | BLOB
Exzentrizität | Numerische Exzentrizität (Wertebereich 0,0 ... 1,0), signed integer [1/1000] *1) | BLOB
Bauch/Rücken, Fläche | Bauch- / Rücken- Lage, Basis: Fläche, Unterscheidung der Lage durch Vorzeichen, signed integer [1/1000] *1) | BLOB
String | Inhalt des gelesenen Codes, Abhängig vom Code kann die Stringlänge variieren. Wird eine feste Stringlänge gewünscht, so müssen die minimale Stringlänge (Detektorspezifische Nutzdaten) und die maximale Stringlänge (Detektoreinstellungen) auf den gleichen Wert (z.B. 127) gesetzt werden. | Datacode Barcode OCR
Stringlänge | Länge des gelesenen Codes in Bytes | Datacode Barcode OCR
Truncated | Code abgeschnitten | Datacode Barcode OCR
Ergebnis Vergleich | Ergebnis des Stringvergleichs | Datacode Barcode OCR
Qualitätsparameter | Ausgabe der Qualitätsparameter gemäß Auswahl | Datacode Barcode
Kontrast | Kontrast des Codes (0-100%) | Barcode
Korrektur | Anzahl der durch die Fehlerkorrekturen korrigierte Module | Barcode
Modul Höhe | Höhe der Module in Pixeln | Datacode
Modul Breite | Breite der Module in Pixeln | Datacode
Sicherheit | Ausgabe der Sicherheitswerte der einzelnen Zeichen | OCR
Ergebnis | Grad der Übereinstimmung des gelesenen Strings mit dem Referenzstring von 0 bis 100% | OCR
Min. Qualität | Minimale geforderte Qualität wurde erreicht | OCR

*1) Alle detektorspezifischen Daten mit Nachkommastellen werden als ganze Zahlen (mit 1000 multipliziert) übertragen und müssen nach Datenempfang deshalb durch 1000 geteilt werden. Die Werte werden im Format „Big Endian" übertragen.

Die angezeigten Parameter variieren in Abhängigkeit vom ausgewählten Detektortyp.
Um die Prüfergebnisse für einen anderen Detektor aufzurufen, markieren Sie diesen in der Auswahlliste.
Im Programm Vision Sensor Visualisation Studio können Sie Prüfergebnisse und statistische Auswertungen inklusive der gewählten grafischen Darstellungen archivieren.

1) Score Wert bei Ergebnis von "Messschieber"

Im Fall des Messschieber Detektors ist die Bedeutung der Ergebniswerte "Score", "Score 1" und "Score 2" wie folgt:

Score 1 / Score 2: Wert für Kantenstärke in Grauwerten, normiert auf 100, (Höhe des Maximums im Histogramm).

Score: Der Kleinere der beiden Werte: Score 1 oder Score 2

Abbildung: Score Wert bei Messschieber Detektor


Bedienschritt Sensor starten

Mit dieser Funktion können Sie den Sensor in den Run-Modus versetzen und Ihren Job ausführen.

Bildanzeige

Bedienschritt Ergebnis

Reiter Statistik

Jobausführung starten:

Klicken Sie auf den Button "Sensor starten".

Der aktive (= in der Auswahlliste markierte) Job wird auf den Sensor übertragen, im Sensorspeicher nichtflüchtig abgelegt und gestartet (Run-Modus).

Im Bildfenster werden die gefundenen Merkmale, im Konfigurationsfenster die Prüfergebnisse für den ersten bzw ausgewählten Detektor in der Auswahlliste, sowie statistische Parameter angezeigt.

Detektoranzeige wechseln:

Um die Prüfergebnisse für einen anderen Detektor als den gerade ausgewählten anzuzeigen, markieren Sie diesen in der Detektor-Auswahlliste (links unten) oder klicken auf dessen grafische Darstellung im Bildfenster.

Jobausführung beenden:

Klicken Sie auf den Button „Stop Sensor". Sie befinden sich jetzt wieder im Konfigurationsmodus und können Ihren Job bearbeiten.

Abbildung: Starte Sensor


Trigger / Bildaktualisierung

Wählen Sie in den Job-Einstellungen im Reiter „Bildaufnahme" den gewünschten Trigger-Modus:

Parameter | Funktion
Getriggert | Betrieb mit externem Trigger, oder Button „Trigger" auf der Vision Sensor Configuration Studio-Oberfläche
Freilauf | Betrieb mit automatisch laufendem Selbsttrigger; der Sensor liefert Bilder/ Auswertungen mit der maximal möglichen Frequenz

Wählen Sie mit den Schaltflächen im Bereich Trigger/ Bildaktualisierung in welcher Form Bilder vom Sensor geliefert werden sollen:

Parameter Funktion

Einzelbild

Aufnahme eines Einzelbilds, Bildaufnahme erfolgt einmalig bei:

1. Trigger Modus = Getriggert: Erstem externem Triggersignal oder mit dem Button „Trigger" auf der Vision Sensor Configuration Studio- Oberfläche

2. Trigger Modus = Freilauf: Erstem Klick auf Button „Einzelbild" auf der Vision Sensor Configuration Studio- Oberfläche (Wichtig z.B. im Einricht-Betrieb)

Kontinuierlich

Kontinuierliche Lieferung von Bildern, Bildaufnahme erfolgt fortlaufend bei:

1. Trigger Modus = Getriggert: Jedem externen Trigger oder bei jedem Klick auf den Button „Trigger" auf der Vision Sensor Configuration Studio- Oberfläche

2. Trigger Modus = Freilauf: Kontinuierlich durch interne Selbsttriggerung mit maximaler Frequenz

Bei Änderung der Parameter Belichtungszeit, Verstärkung, Beleuchtung oder Auflösung in den Job-Einstellungen wird automatisch ein neues Bild vom Sensor angefordert.

Um auch ohne Trigger ein stetig aktualisiertes Livebild zu erhalten folgende Einstellungen vornehmen:

  • Freilauf einstellen unter „Job/ Bildaufnahme"
  • Kontinuierlich einstellen unter „Trigger/ Bildaktualisierung"


Verbindungsmodus

Für Konfiguration und Testlauf des Sensors stehen Ihnen zwei Betriebsarten zur Verfügung, die Sie im Feld "Verbindungsmodus" auswählen können.

  • Online-Modus: Konfiguration mit angeschlossenem Sensor.
  • Offline-Modus: Simulation eines Sensors mit Hilfe gespeicherter Bilder im Filmstreifen.

Abbildung: Verbindungsmodus

Bei angeschlossenem Sensor stehen beide Modi zur Verfügung, es kann dazwischen umgeschaltet werden. Ist kein Sensor vorhanden, kann nur im Offline- Modus, d. h. mit einer Sensor- Simulation gearbeitet werden.


Anzeigen im Bildfenster

Bildausschnitt und Zoom

Abbildung: Zoom

Mit den Schaltflächen bzw. über das Ausklappmenü unter dem Bildfenster können Sie den gewünschten Bildausschnitt wählen.

Grafische Ergebnisanzeige

Im Menü Ansicht können Sie folgende grafischen Darstellungen aktivieren bzw. deaktivieren:

  • Ergebnis Bargraph: Anzeige des Prüfergebnisses als Balkendiagramm
  • Einzeichnungen: Anzeige von Such-, Merkmals- und Positionsrahmen von Detektoren und Lagedetektoren
  • Fokussierhilfe: Anzeige der Bildschärfe (siehe auch Job-Einstellungen)
  • Vergrößerte Anzeige: Einblendung eines separaten vergrößerten Bildfensters, das sich über Anfasser an den Rahmenecken beliebig skalieren lässt

Im Programm Vision Sensor Visualisation Studio steht Ihnen eine eingeschränkte Auswahl dieser Funktionen zur Verfügung.


Steuerung der Bildwiedergabe

Abbildung: Bildwiedergabe

Mit den Buttons und der Schiebeleiste unter dem Bildfeld können Sie die Auswahl und Wiedergabe gespeicherter Bilder steuern. Im Bildzähler wird Ihnen die Nummer des aktuellen Bildes sowie die Anzahl der Bilder im aktiven Filmstreifen angezeigt.

Buttons | Funktion
 | Zum vorherigen Bild springen.
 | Startet / Stoppt die Wiedergabe der gespeicherten Bilder.
 | Zum nächsten Bild springen.
 | Zum letzten Bild springen. Dabei wird die Statistik zurückgesetzt und alle Bilder bewertet.


Öffnen und Speichern von Job oder Jobsatz (Datei)

Nächstes Thema: Jobsatz schützen ... (Datei) oder Reiter Bildaufnahme

Jobs können einzeln oder ein ganzer Satz von Jobs als Jobsatz geladen und gespeichert werden. Sind mehrere Jobs auf dem Sensor gespeichert, bilden diese einen Jobsatz, den Sie genau so wie einen einzelnen Job als XML-Datei auf Ihrem PC oder einem externen Speichermedium ablegen können.

Job / Jobsatz speichern:

  1. Wählen Sie „Job speichern unter ...“ aus dem Datei-Menü.
  2. Wählen Sie „Jobsatz speichern unter (Backup) ...“ aus dem Datei-Menü.

Job / Jobsatz öffnen:

  1. Wählen Sie „Job öffnen ...“, oder „Jobsatz öffnen (Backup)“ ... aus dem Datei-Menü.
  2. Mit dem Button "Starte Sensor" werden Jobs auf den Sensor übertragen.

Alle auf dem Sensor gespeicherten Jobs werden beim Laden eines neuen Jobsatzes gelöscht!

Abbildung: Vision Sensor Configuration Studio Jobs laden / speichern


Jobsatz schützen ... (Datei)

Im Datei-Menü von Vision Sensor Configuration Studio besteht die Möglichkeit, mit der Funktion "Jobsatz schützen", den Jobsatz mit einem Passwort zu schützen. Dabei werden sowohl der Jobsatz als auch alle Jobs mit einem Passwort geschützt. Sie können nur mit Vision Sensor Configuration Studio geöffnet werden, wenn das richtige Passwort eingegeben wird. Bei Eingabe eines falschen Passworts,kann der Jobsatz nicht angesehen oder verändert werden. Der SBS Vision-Sensor bzw. der Zugriff zum SBS Vision-Sensor wird nicht gesperrt, d.h. der SBS Vision-Sensor arbeitet normal im Run-Mode.

Abbildung: Datei-Menü Vision Sensor Configuration Studio, Jobsatz schützen ...

Achtung:

Es besteht keine Möglichkeit, vergessene oder verlorene Passwörter wiederherzustellen.

Im Falle von vergessenen oder verlorenen Passwörtern muss der gesamte Jobsatz neu erstellt werden.

Passwort vergeben

  1. Wählen Sie "Jobsatz schützen ... " über: "Vision Sensor Configuration Studio/Datei/Jobsatz schützen ..."

  2. Geben Sie ein Passwort ein und hinterlegen Sie, wenn erwünscht, zusätzliche Informationen.

    Abbildung: Passwort eingeben

    Hinweis:

    Das Passwort muss zwischen 1 und 100 Zeichen lang sein.

  3. Bestätigen Sie die Eingaben mit dem Button "Setzen". Es öffnet sich ein weiteres Fenster um das Passwort zu bestätigen.

  4. Bestätigen Sie das Passwort, indem Sie das Passwort erneut eingeben.

    Abbildung: Passwort bestätigen

  5. Drücken Sie "Setzen".

  6. Speichern Sie den geschützten Jobsatz

    1. ... auf ihrem SBS Vision-Sensor, indem Sie den Bedienschritt "Start Sensor" wählen
    2. ... über Datei/Job / Jobsatz speichern:.

Hinweis:

Beim Speichern des Jobs bzw. des Jobsatzes kann zwischen den Dateitypen "Mit Passwortschutz (*.job)" und "Ohne Passwortschutz (*.job)" ausgewählt werden.

  • "Mit Passwortschutz (*.job)" speichert den Job / Jobsatz mit dem eingegebenen Passwort für den Job / Jobsatz. Der Job / Jobsatz kann anschließend nur mit der Eingabe des Passwortes für den Job / Jobsatz geöffnet werden.
  • "Ohne Passwortschutz (*.job)" speichert den Job / Jobsatz ohne den eingegebenen Passwortschutz. Der Job / Jobsatz kann jederzeit ohne Eingabe des Passwortes geöffnet und bearbeitet werden.

In der nachfolgenden Tabelle wird das Verhalten beim Öffnen eines geschützten / ungeschützten Jobs in einen einem geschützten / ungeschützten Jobsatz erläutert:

 | Geschützter Jobsatz auf dem SBS Vision-Sensor | Ungeschützter Jobsatz auf dem SBS Vision-Sensor
Öffnen eines geschützten Jobs | Jobsatz-Schutz bleibt bestehen. Zum Öffnen muss das Passwort des geschützten Jobs eingegeben werden, anschließend wird das Passwort des aktiven Jobsatzes übernommen. | Nach dem Öffnen des geschützten Jobs und Speichern des Jobsatzes bzw. Starten des Sensors wird der Passwortschutz für den gesamten Jobsatz übernommen.
Öffnen eines ungeschützten Jobs | Jobsatz-Schutz bleibt bestehen und wird beim Speichern für den ungeschützten Job übernommen. | Jobsatz bleibt ungeschützt.

Ein geschützter Jobsatz ist mit einem "Schlüsselsymbol" gekennzeichnet. Sehen Sie hierzu auch die nachfolgende Tabelle:

Vision Sensor Device Manager | Vision Sensor Configuration Studio / Vision Sensor Visualisation Studio | Vision Sensor Visualisation Studio
Abbildung: Geschützter Jobsatz, Anzeige Vision Sensor Device Manager | Abbildung: Geschützter Jobsatz, Anzeige Vision Sensor Configuration Studio / Vision Sensor Visualisation Studio | Abbildung: Geschützter Jobsatz, Anzeige Vision Sensor Visualisation Studio
Ein SBS Vision-Sensor mit einem geschützten Jobsatz wird in der Liste "Aktive Sensoren" mit einem Schlüsselsymbol gekennzeichnet. | Ein geschützter Job / Jobsatz wird in der Statusleiste mit einem Schlüsselsymbol gekennzeichnet. | Ein geschützter Job / Jobsatz wird im Reiter "Hochladen" mit einem Schlüsselsymbol gekennzeichnet.

Passwort ändern

  1. Wählen Sie "Jobsatz schützen ... " über: "Vision Sensor Configuration Studio/Datei/Jobsatz schützen ..." .
  2. Geben Sie das bestehende Passwort ein und drücken Sie den Button "Ändern".
  3. Bestätigen Sie das Passwort, indem Sie das Passwort erneut eingeben und drücken Sie den Button "Setzen".

  4. Speichern Sie das neue Passwort

    1. ... auf ihrem SBS Vision-Sensor, indem Sie den Bedienschritt "Start Sensor" wählen
    2. ... über Datei/Job / Jobsatz speichern:.

Passwort deaktivieren

  1. Wählen Sie "Jobsatz schützen ... " über: "Vision Sensor Configuration Studio/Datei/Jobsatz schützen ..."
  2. Geben Sie das bestehende Passwort ein und drücken Sie den Button "Deaktivieren".

  3. Speichern Sie den Jobsatz

    1. ... auf ihrem SBS Vision-Sensor, indem Sie den Bedienschritt "Start Sensor" wählen
    2. ... über Datei/Job / Jobsatz speichern:.


Filmstreifen (Datei)

Im Konfigurationsmodus Online-Modus werden kontinuierlich Bilder vom Sensor in das RAM des PC geladen. Nach dem Umschalten vom Online- in den Offline- Modus stehen Ihnen hier maximal 30 Bilder zur Verfügung, die Sie als Bilderserie in einer Filmstreifendatei speichern können. Alternativ oder zusätzlich zu den auf dem Sensor gespeicherten Bildern können Sie auf Ihrem PC oder einem externen Speichermedium abgelegte Bilderserien oder Einzelbilder laden und zu neuen Filmen zusammenstellen.

Wenn Sie ein Bild in der Liste markieren, wird es im Kleinformat im Preview- Fenster rechts angezeigt.

Bilder vom Sensor als Filmstreifen speichern:

  1. Zuerst den PC mit dem Sensor verbinden. Im Freilauf Bilder in den Speicher auflaufen lassen (Verbindungsmodus = Online).
  2. Wählen Sie Radiobutton „Offline" im Feld Verbindungsmodus.

  3. Wählen Sie „Filmstreifen konfigurieren“ aus dem Datei-Menü oder klicken Sie auf das Icon Filmstreifen in der Toolbar. In der sich unten öffnenden Auswahlliste erscheinen die vom Sensor geladenen Bilder:

    Abbildung: Filmstreifen

    Nun können die Bilder betrachtet, umsortiert oder einzelne Bilder gelöscht bzw hinzugefügt werden. Die maximale Bildanzahl in einem Filmstreifen ist 30.

  4. Klicken Sie auf Button „Speichern Filmstreifen" unter der Auswahlliste.

Sämtliche Bilder in der Liste werden in der angezeigten Reihenfolge in einer Filmstreifendatei (Erweiterung .flm) gespeichert und stehen Ihnen für künftige Simulationen zur Verfügung.

Filmstreifen und Einzelbilder vom PC laden:

  1. Wählen Sie Radiobutton „Offline" im Feld Verbindungsmodus.
  2. Wählen Sie Filmstreifen konfigurieren aus dem Datei-Menü oder klicken Sie auf das Icon Filmstreifen in der Toolbar.
  3. Wählen Sie eine Filmdatei aus der Auswahlliste und klicken Sie auf Button „Laden Filmstreifen" oder laden Sie mit Button „Bild laden" einzelne Bilder von Ihrem PC oder einem externen Speichermedium.

Die geladenen Bilder werden der Auswahlliste hinzugefügt.

In der Spalte Quelle werden Art und Speicherort der Datei angezeigt: Auf dem PC gespeicherter Filmstreifen (Film), auf dem PC gespeichertes Einzelbild (Datei), Bild im Sensorspeicher (Sensor). Nach der Umschaltung vom Online- in den Offline-Modus sind alle Einträge vom Typ Sensor.

Filmstreifen bearbeiten:

Sie können aus den Einzelbildern in der Auswahlliste unabhängig von ihrer Quelle neue Filme erstellen.

Folgende Funktionen stehen Ihnen hierfür zur Verfügung:

Button | Funktion
"˂", "˂˂", "˃", "˃˃" | Bildreihenfolge ändern: Das markierte Bild wird um einen Platz oder bis ans Ende der Liste nach oben/unten verschoben.
Bild laden | Weiteres Bild laden
Löschen, Alle löschen | Bild aus der Liste löschen/Alle Bilder aus der Liste löschen. (Die Bilder auf dem PC werden dabei nicht gelöscht.)
Abbruch> | Verlassen der Listenansicht ohne Änderung
Übernehmen | Laden sämtlicher Bilder in der angezeigten Reihenfolge in den Filmspeicher auf dem PC. Diese stehen dann für die Anzeige und Auswertung im Offline-Modus zur Verfügung.
Laden / Speichern Filmstreifen | Filmstreifen von PC laden oder dort speichern


Bildrekorder

In den Programmen Vision Sensor Configuration Studio und Vision Sensor Visualisation Studio steht Ihnen ein Bildrekorder zur Verfügung. Wenn der Rekorder aktiviert ist, werden kontinuierlich entweder alle Bilder oder nur Fehlerbilder in den internen Speicher des Sensors geladen. Dieser fasst 10 Bilder, die ältesten Bilder werden jeweils überschrieben (Ringpuffer). Die aufgezeichneten Bilder können anschließend mit einem PC abgerufen und angezeigt, sowie auf dem PC oder einem externen Speichermedium abgelegt werden und stehen dann zu Analyse- oder Simulationszwecken im Offline- Modus zur Verfügung.

Im Programm Vision Sensor Visualisation Studio müssen Sie zum Abrufen der Rekorderbilder u.U. (falls aktiviert) ein Passwort eingeben (Benutzergruppe Werke siehe Benutzerverwaltung).

Rekorder aktivieren:

Aktivieren Sie den Bildrekorder im Bedienschritt „Ausgabe“ unter dem Reiter „Bildübertragung“. In der Ausklappliste des Parameters Rekorder können Sie wählen, ob alle Bilder, nur die Bilder der Gutteile oder nur die Bilder der Schlechtteile aufgezeichnet werden sollen.

Bilder auswählen und aufzeichnen:

Wählen Sie Bildrekorder auslesen aus dem Datei-Menü oder klicken Sie auf Button „Rek.Bilder" (nur in Vision Sensor Visualisation Studio).

Es erscheint ein Bildfenster, in dem Sie die im Sensor gespeicherten Bilder auf den PC laden, betrachten und abspeichern können:

Abbildung: Bildrekorder

Parameter | Funktion
Zurück | Anzeige des vorhergehenden Bildes
Vor | Anzeige des nächsten Bildes
Speichern | Speichern des angezeigten Bildes auf dem PC bzw. einem externen Speichermedium
Alle speichern | Speichern aller Bilder

Hinweis:

  • Die laufende Nummer des ausgewählten Bildes und die Gesamtzahl der Bilder (max. 10) werden im Zähler unter dem Bildfenster angezeigt.
  • Beim Speichern werden die Bilder im Bitmap-Format (Extension .bmp) abgelegt.
  • Das zum jeweiligen Bild gehörige Prüfergebnis (OK bzw. Fehler) und das Datum werden im Dateinamen gespeichert (Format JJMMTT_laufende Nr._Pass/Fail.bmp, z.B. 090225_123456_Pass.bmp).
  • Wenn Sie zusammen mit den Bildern detaillierte Prüfergebnisse aufzeichnen wollen, verwenden Sie die Funktion Archivierung in Vision Sensor Visualisation Studio.
  • Wenn Sie nur ein einzelnes Bild mit oder ohne Overlay aufnehmen wollen, können Sie anstelle des Rekorders die Funktion Speichere aktuelles Bild im Datei-Menü verwenden.
  • Die Bilder werden bei der Übertragung auf den PC mit einem Zeitstempel versehen.
  • Durch das Laden der Bilder vom Sensor auf den PC werden die Daten auf dem Sensor gelöscht. Wenn das Rekorder Fenster geschlossen wird ohne die Bilder vorher zu speichern gehen die Bilder verloren.

  • Im Falle eines Stromausfalls gehen Bilder aus dem Puffer verloren.


Beispiele (Datei)

Im Menü "Datei/Beispiele" können einige vordefinierte Applikationsbeispiele geladen werden. Es wird jeweils ein Filmstreifen zusammen mit einer Job Datei geladen.


Such- und Merkmalsbereiche

In den Konfigurationsschritten Lagenachführung und Detektoren können Sie Such- und Merkmalsbereiche definieren. Diese sind im Bildfenster durch verschiedenfarbige Rahmen gekennzeichnet.

Im Menüpunkt „Ansicht/Einzeichnungen konfigurieren" können die Einzeichnungen im Bild (Rahmen in gelb, rot, etc.) beliebig je Detektor oder Kategorie an- oder abgeschaltet werden. Unter „Ansicht/Einzeichnungen nur aktueller Detektor" können alle Einzeichnungen im Bild bis auf die des aktuell bearbeiteten Detektors abgeschaltet werden.

Definition von Such- und Merkmalsbereichen

Bei der Erstellung eines neuen Detektors wird ein gelber Rahmen angezeigt, der den Suchbereich des Detektors definiert. Standardform des Suchbereichs ist ein Rechteck. Es können auch je nach Detektortyp die Form Kreis oder Freiform ausgewählt werden. Die definierten Merkmale (roter Rahmen) werden gefunden (grüner Rahmen), solange sich dessen Mittelpunkt innerhalb des Suchbereiches (gelber Rahmen) befindet.

Bei den Detektoren Mustervergleich und Konturerkennung gibt es zusätzlich einen Merkmalsbereich innerhalb des Suchbereichs, der durch eine roten bzw. grünen Rahmen dargestellt wird:

  • Roter Rahmen = Merkmal einlernen
  • Grüner Rahmen = Merkmal gefunden.

Ist eine Positionserkennung definiert, erscheint zusätzlich ein blauer Rahmen (wahlweise Rechteck, Kreis oder Ellipse).

Ist ein Lagedetektor definiert, werden dessen Rahmen gelb gestrichelt angezeigt.

An der jeweils linken oberen Ecke der Rahmen wird die entsprechende Detektornummer angezeigt.

Anpassen von Such- und Merkmalsbereichen

Die zuerst in Standardgröße und -position angezeigten Bereiche können Sie im Bild oder in der Detektorliste auswählen / markieren und in der Position und Größe verändern. Über acht Anfasser am Rahmen lassen sich Rahmenformat und -größe anpassen. Mit einem Klick innerhalb des Rahmens kann dessen Position verschoben werden. Am zur Mitte zeigenden Pfeil lässt sich die Drehlage des Rahmens verändern.

Das eingelernte Muster wird in Originalgröße im Reiter Allgemein oder Parameter in der rechten unteren Bildschirmecke dargestellt. Nur die Rahmen des im Bild oder in der Detektorliste gewählten, momentan aktiven Detektors wird in dicker Linienstärke und den Anfasspunkten dargestellt, alle anderen, zu diesem Zeitpunkt nicht selektierten Rahmen, werden mit dünnen bzw gestrichelten Linien (Lagedetektor) dargestellt.

Abbildung: Such- und Merkmalsrahmen

Hinweis:

  • Für eine optimale Erkennung sollten Merkmale eindeutig sein und keine variablen Anteile, z.B. Schatten, enthalten.
  • Signifikante Konturen, Kanten und Kontrastunterschiede sind von Vorteil.
  • Um die Auswertezeit zu minimieren, sollte der Suchbereich nicht unnötig groß gewählt werden.

Ergebnisbalken:

Rechts neben dem Suchbereich wird der Übereinstimmungsgrad des gesuchten mit dem gefundenen Merkmal als stehender Ergebnisbalken mit eingestelltem Schwellwert angezeigt:

  • Grüner Balken = Das gesuchte Merkmal wurde gefunden und der voreingestellte Schwellwert der Mindest- Übereinstimmung erreicht.
  • Roter Balken = Das Objekt konnte nicht mit dem erforderlichen Übereinstimmungsgrad gefunden werden. Welche grafischen Darstellungen angezeigt werden, können Sie im Menü Ansicht wählen.


Farbmodelle

Zur Beschreibung von Farben gibt es sogenannte Farbmodelle. Der SBS Color kann in verschiedenen Farbmodellen arbeiten.

Folgende Farbmodelle können verwendet werden:

Farbmodell RGB

Farbmodell HSV

Farbmodell LAB

Nächstes Thema: SBS – Bedien- und Konfigurationssoftware – Vision Sensor Visualisation Studio, alle Funktionen


Farbmodell RGB

Ein RGB-Farbraum ist ein additiver Farbraum, der Farbwahrnehmungen durch das additive Mischen dreier Grundfarben (Rot, Grün und Blau) nachbildet.

Der RGB- Farbraum wird als linearer Farbraum als Farbwürfel mit den drei Achsen Rot, Grün und Blau beschrieben.

Abbildung: Farbmodell RGB

Rot, Grün, Blau, jeweils 0-255

Der RGB-Farbraum wird sowohl vom Bildchip, als auch vom Bildschirm zur Definition der Farben genutzt. Allerdings haben Bildchip und Bildschirm innerhalb der einzelnen Farbkanäle unterschiedliche Empfindlichkeiten. Es muss also immer eine Kompensation erfolgen, also RGB ist niemals gleich RGB.

Linear RGB

RGB-Werte werden als linear RGB-Werte angegeben, da der Sensorchip lineare RGB-Werte liefert. Vorteil der linearen RGB-Werte ist, dass ein linearer Zusammenhang zwischen physikalischer Einwirkung und RGB-Werten besteht.

Beispiel: Eine Verdoppelung der Belichtungszeit führt bei konstanten Beleuchtungsbedingungen zu einer Verdoppelung des RGB-Wertes.


Farbmodell HSV

In Fragen der Farbnachstellung wird der HSV-Farbraum gegenüber den Alternativen RGB und Lab bevorzugt, weil es der menschlichen Farbwahrnehmung ähnelt.

Abbildung: Farbmodell HSV

  • Farbton als Farbwinkel H (Hue) auf dem Farbkreis (z. B. 0° = Rot, 120° = Grün, 240° = Blau)
  • Sättigung S (Saturation) in Prozent (0 % = Neutralgrau, 50 % = wenig gesättigte Farbe, 100 % = gesättigte, reine Farbe)
  • Intensität V (Value) als Prozentwert (0 % = keine Intensität, 100 % = volle Intensität)


Farbmodell LAB

Der LAB oder L*a*b*-Farbraum wird durch ein dreidimensionales Koordinatensystem beschrieben:

Abbildung: Farbmodell LAB

  • Die a*-Achse beschreibt den Grün- oder Rotanteil einer Farbe, wobei negative Werte für Grün und positive Werte für Rot stehen. Zahlenbereich von -150 bis +100.
  • Die b*-Achse beschreibt den Blau- oder Gelbanteil einer Farbe, wobei negative Werte für Blau und positive Werte für Gelb stehen. Zahlenbereich von -100 bis +150.
  • Die L*-Achse beschreibt die Helligkeit (Luminanz) der Farbe mit Werten von 0 bis 100.

Eine der wichtigsten Eigenschaften des L*a*b*-Farbmodells ist seine Geräteunabhängigkeit, das heißt, die Farben werden unabhängig von der Art ihrer Erzeugung und Wiedergabetechnik definiert. LAB-Werte werden aus den linearen RGB-Werten berechnet. Dies basiert auf der Normlichtart D65 und 2° Beobachter.


Simulationsbetrieb: Simulation von Jobs (Offline-Modus)

Sie können Ihre Konfiguration auch ohne angeschlossenen Sensor anhand gespeicherter Filmstreifen (= Bilderserien) erstellen und testen. Eine Simulation kann z.B. sinnvoll sein, um eine Konfiguration vorzubereiten oder eine online vorgenommene Konfigurationen zu optimieren.

Anzeigen im Bildfenster

Filmstreifen (Datei)

Hinweis:

  • Im Auslieferungszustand von Vision Sensor Configuration Studio stehen Ihnen einige vorbereitete Filme zur Verfügung.
  • Weitere Möglichkeiten zur Bildaufnahme: Bildrekorder


SBS – Bedien- und Konfigurationssoftware – Vision Sensor Visualisation Studio, alle Funktionen

Dieses Programm dient zur Überwachung / Überprüfung von angeschlossenen Sensoren und zur Analyse von Prüfergebnissen. Es können keine neuen Einstellungen auf dem Sensor vorgenommen werden.

Bildanzeige

Reiter Ergebnis

Reiter Statistik

Reiter Job

Reiter Hochladen

Bild einfrieren

Bildrekorder

Archivierung von Prüfergebnissen und Bildern

Es kann über die reine Anzeige hinaus nur zwischen bereits existierende Jobs auf dem Sensor umgeschaltet werden, oder vordefinierte Jobsätze vom autorisierten Werker vom PC / Steuerung auf den Sensor hochgeladen werden. Somit dient dieses Anzeigetool hauptsächlich um Bildern und Ergebnissen zu visualisieren und zum Jobwechsel bei z.B. Teilewechsel auf der Maschine.


Bildanzeige

Die grafische Anzeige des Bildes und der Prüfergebnisse im Bildfenster hängt von den Einstellungen im Reiter "Bildübertragung" in den Jobeinstellungen (Reiter "Bildübertragung", Kap. "Bildübertragung Parameter" im Programm Vision Sensor Configuration Studio) ab:

  • Bildübertragung aktiv: Das aktuelle Bild sowie die Rahmen für die definierten Such-, Merkmals- und Positionsbereiche und die gefundenen Merkmale werden angezeigt.
  • Bildübertragung inaktiv: Es werden nur die Rahmen für die definierten Such-, Merkmals- und Positionsbereiche und die gefundenen Merkmale angezeigt (das aktuelle Bild wird nicht angezeigt).

Rechts neben dem Suchbereich des jeweiligen Detektors wird der Übereinstimmungsgrad des gesuchten mit dem gefundenen Merkmal als stehender Ergebnisbalken mit eingestelltem Schwellwert angezeigt:

  • Grüner Balken: Das gesuchte Merkmal wurde gefunden und der voreingestellte Schwellwert der Übereinstimmung erreicht.
  • Roter Balken: Das Objekt konnte nicht mit dem erforderlichen Übereinstimmungsgrad gefunden werden

Achtung:

Dieses Icon im Livebild sagt aus, dass die Bilddarstellung / Bildspeicherung im PC langsamer läuft als die Bildauswertung auf dem SBS. Es werden nicht mehr alle Bilder, die vom SBS aufgenommen werden, angezeigt. Dies kann bei Verwendung der Schlechtbild-Archivierung evtl. zu Bildverlusten führen.

Bei häufigem Auftreten des Icons, sollten auf dem PC geöffnete Programme im Hintergrund geschlossen werden, um mehr PC-Leistung zur Verfügung zu stellen.

Im Menü Vision Sensor Visualisation Studio / Ansicht können Sie die grafische Darstellung der Prüfergebnisse konfigurieren.

Abbildung: Vision Sensor Visualisation Studio

Mit Ausnahme der Archivierung stehen sämtliche Funktionen von Vision Sensor Visualisation Studio auch im Programm Vision Sensor Configuration Studio zur Verfügung.


Kommandos


Bild einfrieren

Mit dem Button „Bild einfrieren" können Sie Einzelbilder des gewünschten Typs (Aktuelles Bild, Nächstes Bild, Nächstes Fehlerbild) anfordern und im Bildfenster zur Anzeige festhalten.

Das gewünschte Einzelbild wird angezeigt und der Bildzähler bleibt auf der entsprechenden Bildnummer stehen.

Mit „Fortsetzen" beenden Sie die Einzelbildanzeige.


Zoom

Mit dem Button "Zoom" wird das Bild in einem neuen Fenster in vergrößerter Anzeige geöffnet.


Archivierung von Prüfergebnissen und Bildern

Sie können Bilder mit und ohne Einzeichnungen sowie Prüfergebnisse auf Ihrem PC oder einem externen Speichermedium zu Analyse- oder Simulationszwecken archivieren (siehe Offline-Modus).

Die Ausführung dieser Funktionen erfordert u.U. die Eingabe eines Passworts (Benutzergruppe Werker, siehe Benutzerverwaltung).

Archivierung konfigurieren:

  1. Wählen Sie „Archivierung konfigurieren“ aus dem Datei-Menü.

    Es erscheint ein Dialogfenster mit folgender Auswahl:

    Abbildung: Archivierung konfigurieren

    Parameter Funktion

    Pfad für Archivierung

    Verzeichnis, in dem die Archivierungsdatei(en) abgelegt werden.

    Einstellungen, Automatischer Start

    Startet die Archivierung automatisch nach Start von Vision Sensor Visualisation Studio.

    Einstellungen, Zyklisches Überschreiben

    Aktiviert das zyklische Überschreiben der ältesten Bilder bei erreichen des Speicherlimit.

    Einstellungen, Speicherlimit

    Hier kann die Datenmenge begrenzt werden.

    Einstellungen, Bildtyp

    In dieser Ausklappliste kann spezifiziert werden, welche Bilder (alle Bilder bzw. nur Gut- bzw. Schlechtbilder) gespeichert werden sollen.

    Einzeichnungen,

    Ergebnis Bargraph

    Auswahl der zu archivierenden grafischen Darstellungen im Bild.

    Numerische Ergebnisse

    Wenn „Mitprotokollieren" aktiviert ist, werden in einer zusätzlichen .csv-Datei numerische Ergebnisdaten wie Koordinatenwerte etc. archiviert.

    Die Einstellung "Legacy" / "Konfiguriert" legt das Format der .csv Datei fest.

    Bei "Legacy" *1) ist der Inhalt der .csv-Datei vorgegeben, bei "Konfiguriert" ist diese über „Ausgabe / Datenausgabe" frei konfigurierbar.

    *1) Der Speichermodus "Legacy" ist veraltet und wird aktuell nur aus Gründen der Abwärtskompatibilität angeboten. Er wird in einer der nächsten Versionen entfallen.

  2. Wählen Sie die gewünschten Optionen und bestätigen Sie Ihre Wahl mit OK.

Archivierung starten/beenden:

Klicken Sie auf den Button „Bilder archivieren" im Fenster „Kommandos", um die Archivierungsfunktion den oben genannten Einstellungen zu starten bzw. zu beenden. In der Statusleiste wird die gegenwärtig zu speichernde Bilddatei mit Namen angezeigt. Die Archivierung wird ausgeführt, solange der Button „Bilder archivieren" gedrückt ist.


Reiter Ergebnis

Mit dieser Funktion wird der definierte Job auf dem PC ausgeführt, und das „Ergebnis Statistik" Fenster mit Detektorliste und Auswerteergebnissen angezeigt. Die Ausführungszeiten werden in diesem Modus nicht aktualisiert, da sie vom Sensor nicht vorliegen.

Im Run-Modus werden die detaillierten Prüfergebnisse des in der Auswahlliste markierten Detektors angezeigt.

Im Bildfenster werden – sofern eingestellt – das Bild, die Such- und Merkmalsbereiche und Ergebnisgrafen angezeigt.

Die angezeigten Parameter variieren in Abhängigkeit vom ausgewählten Detektortyp:

Abbildung: Vision Sensor Visualisation Studio, Ergebnis

Angezeigte Ergebnisparameter | für Detektortyp | Funktion
Ergebnis | alle | Teil / Merkmal erkannt (Erkannt = grün, Nicht erkannt = rot)
Score 1 .. n | alle | Übereinstimmungsgrad des gefunden Musters mit dem eingelernten Muster
Ausführungszeit | alle | Zykluszeit für eine Auswertung in ms
Abstand | Messschieber | Berechneter Abstand
PositionX 1 ... n, PositionY 1 ... n | Mustervgl., Kontur, Messschieber | Koordinaten des gefundenen Merkmals (Mittelpunkt)
Delta X, Delta Y | Mustervgl., Kontur | Abweichung der Findekoordinaten gegenüber Einlernposition / durch Lagenachführung
Positions- kontrolle | Mustervgl., Kontur | Findeposition innerhalb des definierten Positionsrahmens
Winkel | Mustervgl., Kontur | Orientierung (absoluter Winkel) des gefunden Merkmals
Delta Winkel | Mustervgl., Kontur | Winkelabweichung zwischen eingelerntem und gefundenem Merkmal
Skalierung | Kontur | Skalierung der gefundenen Kontur gegenüber der eingelernten
Ergebnis Index | Farbliste | Nummer des Listeneintrags
Farbabstand | Farbliste | Abstand der gemessenen Farbe zur eingelernten Farbe
Rot (Farbmodell RGB) | Farbliste, Farbwert | Mittelwert Rot
Grün (Farbmodell RGB) | Farbliste, Farbwert | Mittelwert Grün
Blau (Farbmodell RGB) | Farbliste, Farbwert | Mittelwert Blau
Farbton (Farbmodell HSV) | Farbliste, Farbwert | Farbton der Farbe
Sättigung (Farbmodell HSV) | Farbliste, Farbwert | Sättigung der Farbe
Helligkeit (Farbmodell HSV) | Farbliste, Farbwert | Helligkeit der Farbe
Luminanz (Farbmodell LAB) | Farbliste, Farbwert | Luminanzwert der Farbe
A (Farbmodell LAB) | Farbliste, Farbwert | A- Wert der Farbe
B (Farbmodell LAB) | Farbliste, Farbwert | B- Wert der Farbe

Um die Prüfergebnisse für einen anderen Detektor aufzurufen, markieren Sie diesen in der Auswahlliste.

Im Programm Vision Sensor Visualisation Studio können Sie Prüfergebnisse und statistische Auswertungen inklusive der gewählten grafischen Darstellungen archivieren.


Reiter Statistik

Im Run-Modus werden die statistischen Daten des Prüfprozesses im Reiter Statistik angezeigt. Die angezeigten statistischen Daten sind für alle Detektortypen identisch:

Parameter | Funktion
Alle Auswertungen | Gesamtzahl der Prüfungen
Gutteile | Anzahl der Prüfungen mit Resultat „OK"
Schlechtteile | Anzahl der Prüfungen mit Resultat „Fehler"
Min./Max./Mittlere Ausführungszeit | Min./Max./Mittlere Ausführungszeit für eine Auswertung in ms

Mit dem Button „Rücksetzen" können Sie alle Statistikwerte auf Null zurücksetzen.

Im Programm Vision Sensor Visualisation Studio können Sie Prüfergebnisse und statistische Auswertungen inklusive der gewählten grafischen Darstellungen archivieren.


Reiter Job

Im Reiter Job werden in der Auswahlliste die auf dem Sensor verfügbaren Jobs angezeigt. Hier können Sie zwischen verschiedenen im Sensor gespeicherten Jobs umschalten. Der grüne Pfeil ( [image]) markiert den aktiven Job.

Die Ausführung von Funktionen, die ein Anhalten des aktiven Sensors zur Folge haben (Job-Umschaltung, Job-Upload und Recoderbilder holen), erfordert falls aktiviert in Vision Sensor Device Manager die Eingabe eines Passworts (Benutzergruppe Werker, siehe Benutzerverwaltung).

Passwortebenen

Abbildung: Passwortebenen

Abbildung: Vision Sensor Visualisation Studio, Jobumschaltung

Ablauf

Wählen Sie einen Job aus der Liste und aktivieren Sie ihn mit Button „Aktivieren".

Der bisherige Job wird deaktiviert, der gewählte Job ist jetzt aktiv.

Hinweis:

Bei Jobwechsel und Wechsel des Betriebsmodus von Run- nach Config Mode entstehen folgende Sonderzustände der Ausgänge:

  • Der Puffer der verzögerten Ausgänge wird bei Jobwechsel und Wechsel des Betriebsmodus von „Run" nach „Config" gelöscht.
  • Digitalausgänge: Diese werden bei Jobwechsel und Wechsel des Betriebsmodus von „Run" nach „Config" auf die Grundeinstellungen (Defaults) zurückgesetzt. Die Grundeinstellungen werden durch „Invert" im Tab Output-> Ausgangssignale festgelegt. „Invert" invertiert die Grundeinstellung des Digitalausgangs und gleichzeitig das Ergebnis.
  • Ready und Valid: Ready und Valid signalisieren bei Jobwechsel und Wechsel des Betriebsmodus von „Run" nach „Config", dass der Sensor nicht bereit ist und die Ergebnisse nicht gültig sind (Low Pegel).


Reiter Hochladen

Im Reiter Hochladen können Sie neue Jobs oder ganze Jobsätze vom PC in den Sensorspeicher laden. Die verfügbaren Jobs bzw. Jobsätze werden in der Auswahlliste angezeigt.

Jobs und Jobsätze können im Programm Vision Sensor Configuration Studio erstellt und dort unter Menü Datei / Speichere Job / Jobsatz unter ... abgespeichert werden.

Abbildung: Vision Sensor Visualisation Studio, Jobsätze laden

Hinweis:

  • Ein Jobsatz besteht aus einem oder mehreren Jobs, die im Sensor oder auf Festplatte gespeichert sind.
  • Die Ausführung von Funktionen, die ein Anhalten des aktiven Sensors zur Folge haben, erfordert u.U. die Eingabe eines Passworts (Benutzergruppe Werker, siehe Benutzerverwaltung).
  • Wählen Sie einen Job oder Jobsatz aus der Liste und laden Sie ihn mit Button „Hochladen" auf den Sensor.
  • Alle bisher auf dem Sensor gespeicherten Jobs werden bei dieser Aktion gelöscht!


Anhang

Telegramm, Reiter Datenausgabe


Telegramm, Reiter Datenausgabe

In diesem Kapitel werden die Telegramme beschrieben, welche für den SBS Vision-Sensor zur Verfügung stehen. Diese Telegramme können über verschiedene Schnittstellen an den SBS Vision-Sensor gesendet werden.

  • Serielle Schnittstelle RS422 / RS232
  • Ethernet TCP/IP
  • PROFINET (Request / Response Modul)

Die Telegramme stehen in ASCII sowie Binär Format zur Verfügung. Das Format wird im Modul "Vision Sensor Configuration Studio" im Reiter "Datenausgabe" des Bedienschritts "Ausgabe" festgelegt.

Folgende Einstellungen sind möglich:

Kommunikation | TCP / IP | RS422 / RS232 | EtherNet/IP | PROFINET
Telegramm Format | ASCII / Binär | ASCII / Binär | Binär | Binär

Nächste Themen:

Übersicht Telegramme:


Übersicht Telegramme:

Closed SBS Allgemein
  • Statistik zurücksetzen (ASCII / Binär)
    Mit dem Telegramm "Statistik zurücksetzen" kann der interne Statistikzähler des SBS Vision-Sensors zurückgesetzt werden.
Closed SBS Kontrolle
  • Trigger (ASCII / Binär)
    Mit dem Telegramm "Trigger" kann eine Bildaufnahme gestartet werden. Einige Befehle benötigen eine zusätzliche Bildaufnahme. Ergebnisdaten der Auswertung werden über den "Out"-Port ausgegeben.
  • Erweiterter Trigger (ASCII / Binär)
    Das Telegramm "Erweiterter Trigger" ist eine Erweiterung zum "Trigger"-Telegramm. Neben den Ergebnisdaten besteht zusätzlich die Möglichkeit eine ID zu vergeben oder Informationen über den Betriebszustand (Run/Config) zu erhalten. Im Unterschied zum "Trigger"-Telegramm werden beim "Erweiterten Trigger" die Ergebnisdaten auch über den "In"-Port gesendet.
  • Jobwechsel (ASCII / Binär)
    Mit dem Telegramm "Jobwechsel" wird ein Jobwechsel auf dem SBS Vision-Sensor angestoßen.
  • Jobwechsel Permanent (ASCII / Binär)
    Mit dem Telegramm "Jobwechsel Permanent" wird ein permanenter Jobwechsel auf dem SBS Vision-Sensor angestoßen. Der Job wird nach dem Neustart wieder ausgeführt.
Closed SBS Jobeinstellungen
  • Verschlusszeit setzen (ASCII / Binär)
    Mit dem Telegramm "Verschlusszeit setzen" kann die Verschlusszeit des Jobs geändert werden. Dieses Telegramm kann z.B. für einen Helligkeitsausgleich verwendet werden.
  • Verschlusszeitwert lesen (ASCII / Binär)
    Mit dem Telegramm "Verschlusszeit lesen" kann die gesetzte Verschlusszeit des Jobs gelesen werden.
  • Verstärkung setzen (ASCII / Binär)
    Mit dem Telegramm "Verstärkung setzen" kann die Verstärkung des Jobs geändert werden. Dieses Telegramm kann z.B. für einen Helligkeitsausgleich verwendet werden.
  • Verstärkungswert lesen (ASCII / Binär)
    Mit dem Telegramm "Verstärkung lesen" kann die gesetzte Verstärkung des Jobs gelesen werden.
  • Parameter setzen (ASCII / Binär)
    Mit dem Telegramm "Parameter setzen" können Parameter von Detektoren angepasst werden, z.B. Referenz Strings, Schwellwerte für Detektoren.
  • Parameter lesen (ASCII / Binär)
    Mit dem Telegramm "Parameter lesen" können die gesetzten Parameter der Detektoren gelesen werden.
  • ROI setzen (ASCII / Binär)
    Mit dem Telegramm "ROI setzen" kann die Position des angegeben Detektors geändert werden.
  • ROI lesen (ASCII / Binär)
    Mit dem Telegramm "ROI lesen" kann die Position des angegeben Detektors ausgelesen werden.
  • Jobliste lesen (ASCII / Binär)
    Mit dem Telegramm "Jobliste lesen" kann eine Auflistung aller verfügbaren Jobs auf dem SBS Vision-Sensor ausgegeben werden.
  • Detektorliste lesen (ASCII / Binär)
    Mit dem Telegramm "Detektorliste lesen" kann eine Auflistung aller Detektoren im aktuellen Job ausgegeben werden.
  • Detektor einlernen (ASCII / Binär)
    Mit dem Telegramm "Detektor einlernen" wird der angegeben Detektor neu eingelernt (nur für Mustervergleich und Konturvergleich verfügbar).

  • Trigger-Verzögerung setzen (ASCII / Binär)
    Mit dem Telegramm "Trigger-Verzögerung setzen" kann eine Verzögerung für das Auslösen eines Triggers eingestellt werden (in Zeit (ms) oder Encoder-Schritten).

  • Trigger-Verzögerung lesen (ASCII / Binär)
    Mit dem Telegramm "Trigger-Verzögerung lesen" kann die eingestellte Verzögerung für das Auslösen eines Triggers ausgelesen werden.
Closed SBS Kalibrierung
  • Kalibrierung: Punkteliste initialisieren (ASCII / Binär)
    Mit dem Telegramm "Kalibrierung: Punkteliste initialisieren" wird die Punkteliste initialisiert.
  • Kalibrierung: Weltpunkt hinzufügen (ASCII / Binär)
    Mit dem Telegramm "Kalibrierung: Weltpunkt hinzufügen" wird ein Weltpunkt (Referenzmarke oder Punktpaar) der Punkteliste hinzugefügt. Das Telegramm kann für Kalibriermethode Punktpaarliste (Roboter) und Kalibrierplatte (Roboter) verwendet werden.
  • Kalibrierung: Punkt hinzufügen (ASCII / Binär) - Abgekündigt
    Mit dem Telegramm "Kalibrierung: Punkt hinzufügen" wird ein Punkt der Punkteliste hinzugefügt.
  • Kalibrierung: Punkteliste (ASCII / Binär)
    Mit dem Telegramm "Kalibrierung: Punkteliste" wird die Kalibrierung anhand der Punkteliste im aktuellen Job durchgeführt.
  • Kalibrierung: Punkteliste validieren (ASCII / Binär)
    Mit dem Telegramm "Kalibrierung: Punkteliste validieren" wird die Kalibrierung anhand der Punkteliste validiert.
  • Kalibrierung: Kalibrierplatte (ASCII / Binär)
    Mit dem Telegramm "Kalibrierung: Kalibrierplatte" wird die Kalibrierung anhand der Kalibrierplatte durchgeführt.
  • Kalibrierung: Kalibrierung kopieren (ASCII / Binär)
    Mit dem Telegramm "Kalibrierung: Kalibrierung kopieren" wird die Kalibrierung aus dem aktuellen Job auf das angegeben Ziel kopiert.

  • Kalibrierung: Parameter setzen (ASCII / Binär)
    Mit dem Telegramm "Kalibrierung: Parameter setzen" können Parameterwerte für die Kalibrierung gesetzt werden.

  • Kalibrierung: Parameter lesen (ASCII / Binär)
    Mit dem Telegramm "Kalibrierung: Parameter lesen" können eingestellte Parameterwerte der Kalibrierung gelesen werden.
Closed SBS Visualisierung
  • Bild holen (ASCII / Binär)
    Mit dem Telegramm "Bild holen" kann das Bild vom SBS Vision-Sensor erhalten werden.
Closed SBS Service (nur auf Port 1998 und in ASCII Format verfügbar)
  • Update Visualisierungsdaten (ASCII)
    Mit dem Telegramm "Update Visualisierung-Daten" werden Visualisierungsdaten, wie z.B. Bild, Detektor Informationen und Ergebnisse aktualisiert.
  • Sensoridentität lesen (ASCII)
    Mit dem Telegramm "Sensoridentität lesen" kann der aktuelle Firmwarestande sowie der Hardwaretyp abgefragt werden.
  • Firmware aktualisieren (ASCII)
    Mit dem Telegramm "Firmware aktualisieren" wird ein Firmwareupdate gestartet. Die Firmware-Datei muss zuvor auf den SBS Vision-Sensor geladen werden.
  • Jobsatz einlesen (ASCII)
    Mit dem Telegramm "Jobsatz einlesen" kann der Jobsatz des SBS Vision-Sensors getauscht werden. Die Jobsatz-Datei muss zuvor auf den SBS geladen werden.
  • Jobsatz sichern (ASCII)
    Mit dem Telegramm "Jobsatz sichern" kann der Jobsatz des SBS Vision-Sensors gelesen werden.
Closed Datenausgabe

(ASCII / Binär)

In diesem Abschnitt findet man Informationen über die Datenausgabe. Insbesondere, welches Format die einzelnen Ergebnisse erhalten.

Telegramme: Verfügbarkeit und unterstütze Schnittstellen


Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:


Fehlercodes

Fehlercode | Beschreibung
000 | Erfolgreich
001 | Fehler
003 | Ungültige Parameterdaten
005 | Ungültiges Telegramm
006 | Eingabeparameter mit ungültiger Größe oder ungültigem Wert
007 | Die Datei existiert nicht
008 | Rekorder ausgeschaltet
009 | Das passende Bild des angeforderten Typs wurde nicht gefunden
010 | Ungültiger Dateiname oder Länge
011 | Ungültige Datenlänge
012 | Nicht zulässig aufgrund nicht übereinstimmendem Jobsatz
013 | Fehler beim Starten eines neuen Jobs aus dem Jobsatz
016 | Nicht übereinstimmende Firmware-Version.
018 | Kalibrierplattendatei nicht vorhanden
020 | Mehr als eine vis-Datei vorhanden
021 | Sensortyp stimmt nicht für vis-Datei
030 | Kalibrierung nicht aktiviert
031 | Fehler beim kopieren
032 | Nicht übereinstimmende Eingangsbedingung für Ziel-Job
033 | Kalibrierung-/ Validierungsfehler
034 | Ungültige Anzahl an Punkten
035 | Fehler in Kalibrierung: Punkt hinzufügen, z.B. letztes Jobergebnis fehlschlagen
036 | Ungültige Referenzmarke
037 | Fehler Jobsatz-Schutz: Jobwechsel "Permanent" ist nicht erlaubt.
038 | Parameter-Werte sind nicht verfügbar zum Schreiben / Lesen.
039 | Sensor ist im Konfigurations-Modus. Das Telegramm wurde abgelehnt.
040 | Fehler beim Parameter-Wert schreiben / lesen.

Übersicht Telegramme:


Serielle Kommunikation ASCII

Übersicht Telegramme:

Bild holen (ASCII)

Kalibrierung: Punkt hinzufügen (ASCII) - Abgekündigt - Abgekündigt

Kalibrierung: Weltpunkt hinzufügen (ASCII)

Kalibrierung: Punkteliste initialisieren (ASCII)

Kalibrierung: Kalibrierung kopieren (ASCII)

Kalibrierung: Parameter lesen (ASCII)

Kalibrierung: Parameter setzen (ASCII)

Kalibrierung: Kalibrierplatte (ASCII)

Kalibrierung: Punkteliste (ASCII)

Kalibrierung: Referenzmarke setzen (ASCII)

Kalibrierung: Punkteliste validieren (ASCII)

Datenausgabe in ASCII

Detektor einlernen (ASCII)

Detektorliste lesen (ASCII)

Erweiterter Trigger (ASCII)

Verstärkungswert auslesen (ASCII)

Verstärkung setzen (ASCII)

Jobliste lesen (ASCII)

Jobwechsel (ASCII)

Jobwechsel Permanent (ASCII)

Jobsatz sichern (ASCII)

Jobsatz einlesen (ASCII)

Parameterwerte lesen (ASCII)

Parameter setzen (ASCII)

ROI lesen (ASCII)

ROI setzen (ASCII)

Sensoridentität lesen (ASCII)

Verschlusszeitwert auslesen (ASCII)

Verschlusszeit setzen (ASCII)

Statistik zurücksetzen (ASCII)

Trigger-Verzögerung lesen (BINÄR)

Trigger-Verszögerung setzen (BINÄR)

Trigger (ASCII)

Firmware aktualisieren (ASCII)

Visualisierungsdaten aktualisieren (ASCII)


Statistik zurücksetzen (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Statistik zurücksetzen (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | R | Reset Statistics
2 | S
3 | T
Beispiel: | RST
Statistik zurücksetzen (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | R | Reset Statistics
2 | S
3 | T
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
Beispiel: | RSTP
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Keine Veränderung
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)


Trigger (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Trigger (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | T | Trigger (einfacher Trigger, In-Port)
2 | R
3 | G
Beispiel: | TRG
Trigger (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | T | Trigger, (Response auf Kommando Trigger ohne Index, via Port 2006. Falls definiert: Ergebnisdaten ohne Index via Port 2005)
2 | R
3 | G
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
Beispiel: | TRGP
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Ja
Akzeptiert wenn Ready Low: |  | Nein
Status des Signals Ready während Bearbeitung: |  | Low
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)


Erweiterter Trigger (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Erweiterter Trigger (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | T | Erweiterter Trigger, (Trigger mit Index, zur Zuordnung Trigger zu entsprechenden Ergebnisdaten, via Port 2006)
2 | R
3 | X
4 - 5 | X | Länge nachfolgender Daten (n)
6 ... n | X | Daten
Beispiel: | TRX06MyPart
Erweiterter Trigger (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | T | Erweiterter Trigger, (Response auf Trigger mit Index und Ergebnisdaten, via Port 2006, zur Zuordnung von Trigger zum Ergebnis. Ergebnisdaten außerdem ohne Index via Port 2005)
2 | R
3 | X
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
5 - 6 | X | Länge nachfolgender Daten (n)
7 ... n | X | Daten aus dem Sendebefehl
n+1 | C R | C = Config R = Run
n+2 ... n+9 | X | Länge nachfolgender Ergebnis Daten (m)
n+9 ... m | X | Ergebnis Daten
Beispiel: | TRX06MyPartR00000000
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Ja
Akzeptiert wenn Ready Low: |  | Nein
Status des Signals Ready während Bearbeitung: |  | Low
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)


Jobwechsel (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Jobwechsel (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Change Job
2 | J
3 | B
4 - 6 | X | Job Nummer
Beispiel: | CJB005
Jobwechsel (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Change Job
2 | J
3 | B
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
5 | T F | Triggered Freerun
6 - 8 | X | Job Nummer
Beispiel 1: Beispiel 2: | CJBPT005 CJBFF005
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Low
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)

Hinweis:

Tritt ein Fehler beim Jobwechsel auf, besteht die Möglichkeit in Job 1 zu wechseln.


Jobwechsel Permanent (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Jobwechsel Permanent (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Change Job Permanent
2 | J
3 | P
4 - 6 | X | Job Nummer
Beispiel: | CJP005
Jobwechsel Permanent (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Change Job Permanent
2 | J
3 | P
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
5 | T F | Triggered Freerun
6 - 8 | X | Job Nummer
Beispiel 1: Beispiel 2: | CJPPT005 CJPFF005
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Low
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)

Hinweis:

Tritt ein Fehler beim Jobwechsel auf, besteht die Möglichkeit in Job 1 zu wechseln.


Verschlusszeit setzen (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Verschlusszeit setzen (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | S | Set Shutter Speed
2 | S
3 | P T | Permanent Temporär Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
4 - 5 | X | Anzahl der Stellen des Verschlusszeitwerts, z.B. 04
6 - 9 | X | Neuer Verschlusszeitwert in Mikrosekunden, z.B. 8000 = 8 ms
Beispiel: | SSP048000
Verschlusszeit setzen (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | S | Set Shutter Speed
2 | S
3 | P T | Permanent Temporär Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
Beispiel: | SSPP
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Low
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)


Verschlusszeit lesen (ASCII)

Verschlusszeitwert auslesen (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Verschlusszeitwert lesen (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | G | Get Shutter Speed (von aktivem Job)
2 | S
3 | H
Beispiel: | GSH
Verschlusszeitwert lesen (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | G | Get Shutter Speed
2 | S
3 | H
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
5 | X | Verschlusszeitwert, Länge
6 ... n | X | Verschlusszeitwert
Beispiel Run Mode: Beispiel Konfigurations Mode: | GSHP41200 GSHF0
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Keine Veränderung
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)


Verstärkung setzen (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Verstärkung setzen (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | S | Set Gain
2 | G
3 | A
4 | 0 1 | 0: Temporär 1: Permanent Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
5 - 9 | X | Neuer Verstärkungswert (in Wert *1000), z.B. 2,0 = 02000
Beispiel: | SGA102000
Verstärkung setzen (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | S | Set Gain
2 | G
3 | A
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
5 - 9 | X | Aktueller Verstärkungswert
Beispiel: | SGAP02000
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Keine Veränderung
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)


Verstärkungswert lesen (ASCII)

Verstärkungswert auslesen (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Verstärkungswert lesen (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | G | Get Gain
2 | G
3 | A
Beispiel: | GGA
Verstärkungswert lesen (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | G | Get Gain
2 | G
3 | A
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
5 - 9 | X | Aktueller Verstärkungswert (in Wert * 1000), z.B. 1,0 = 01000
Beispiel: | GGAP01000
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Keine Veränderung
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)


Parameter setzen (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Parameter setzen (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | S | Set Parameter
2 | P
3 | P T | P Permanent T Temporär Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
4 - 6 | X | Detektor Nummer
7 - 9 | X | Kommando: Referenzstring / Wert setzen *1) siehe unten
10 - 14 | X | Länge Referenzstring / Wert in Bytes (n)
15 ... n | X | Referenzstring / Wert
Beispiel: | SPP0010010044196
Parameter setzen (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | S | Set Parameter
2 | P
3 | P T | P Permanent T Temporär Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
5 | S | SI08 - Signed Integer 08 UI08 - Unsigned Integer 08 SI16 - Signed Integer 16 UI16 - Unsigned Integer 16 SI32 - Signed Integer 32 UI32 - Unsigned Integer 32 SI40 - Signed Integer 40 UI40 - Unsigned Integer 40 FLOT - Float DOBL - Double STRG - String BOOL - Boolean SP08 - Special Signed 8 UDEF - Undefined IARR - Integer Array ZERO - Default Zero Parameter
6 | T
7 | R
8 | G
Beispiel: | SPPPSTRG
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Low
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)

*1) Byte Nr. 7: Kommando Referenzstring / Wert setzen

Detektor | Funktion | Command
Lagenachführung Mustervergleich | Threshold Min Threshold Max ResultOffsetPos_X ResultOffsetPos_Y ResultOffsetAngle | 001 002 031 032 033
Lagenachführung Konturvergleich | Threshold Min Threshold Max ResultOffsetPos_X ResultOffsetPos_Y ResultOffsetAngle | 001 002 031 032 033
Lagenachführung Kantenantastung | Transition probe 1 Transition probe 2 Transition probe 3 Score min probe 1 Score min probe 2 Score min probe 3 | 101 102 103 104 105 106
Mustervergleich | Threshold Min Threshold Max ResultOffsetPos_X ResultOffsetPos_Y ResultOffsetAngle | 001 002 031 032 033
Kontur | Threshold Min Threshold Max ResultOffsetPos_X ResultOffsetPos_Y ResultOffsetAngle | 001 002 031 032 033
Graustufe | Threshold Min Threshold Max GreyMin GreyMax GreyInvert | 001 002 101 102 103
Kontrast | Threshold Min Threshold Max | 001 002
Helligkeit | Threshold Min Threshold Max | 001 002
Barcode | Reference String | 101
Datacode | Reference String | 101
OCR | Reference String | 101
Farbwert | ColorMinChannel1 ColorMaxChannel1 ColorInvertChannel1 ColorMinChannel2 ColorMaxChannel2 ColorInvertChannel2 ColorMinChannel3 ColorMaxChannel3 ColorInvertChannel3 | 101 102 103 104 105 106 107 108 109
Farbfläche | ColorMinChannel1 ColorMaxChannel1 ColorInvertChannel1 ColorMinChannel2 ColorMaxChannel2 ColorInvertChannel2 ColorMinChannel3 ColorMaxChannel3 ColorInvertChannel3 | 101 102 103 104 105 106 107 108 109
BLOB | GreyAbsoluteMin GreyAbsoluteMax GreyAbsoluteInvert | 101 102 103


Parameterwerte lesen (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Parameter lesen (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | G | Get Parameter Value
2 | P
3 | A
4 - 6 | X | Detektor Nummer z.B. 001
7 - 9 | X | Kommando: Referenzstring / Wert lesen *1) siehe unten
Beispiel: | GPA001001
Parameter lesen (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | G | Get Parameter Value
2 | P
3 | A
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
5 | S | SI08 - Signed Integer 08 UI08 - Unsigned Integer 08 SI16 - Signed Integer 16 UI16 - Unsigned Integer 16 SI32 - Signed Integer 32 UI32 - Unsigned Integer 32 SI40 - Signed Integer 40 UI40 - Unsigned Integer 40 FLOT - Float DOBL - Double STRG - String BOOL - Boolean SP08 - Special Signed 8 UDEF - Undefined IARR - Integer Array ZERO - Default Zero Parameter
6 | T
7 | R
8 | G
9 - 13 | X | Länge des Referenzstrings / Wert (n) z.B. 00005
14 ... n | X | Referenzstring / Wert
Beispiel: | GPAPSTRG00005Test1
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Keine Veränderung
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)

*1) Byte Nr. 7: Kommando: Referenzstring / Wert lesen

Detektor | Funktion | Command
Lagenachführung Mustervergleich | Threshold Min Threshold Max ResultOffsetPos_X ResultOffsetPos_Y ResultOffsetAngle | 001 002 031 032 033
Lagenachführung Konturvergleich | Threshold Min Threshold Max ResultOffsetPos_X ResultOffsetPos_Y ResultOffsetAngle | 001 002 031 032 033
Lagenachführung Konturvergleich | Transition probe 1 Transition probe 2 Transition probe 3 Score min probe 1 Score min probe 2 Score min probe 3 | 101 102 103 104 105 106
Mustervergleich | Threshold Min Threshold Max ResultOffsetPos_X ResultOffsetPos_Y ResultOffsetAngle | 001 002 031 032 033
Kontur | Threshold Min Threshold Max ResultOffsetPos_X ResultOffsetPos_Y ResultOffsetAngle | 001 002 031 032 033
Graustufe | Threshold Min Threshold Max GreyMin GreyMax GreyInvert | 001 002 101 102 103
Kontrast | Threshold Min Threshold Max | 001 002
Helligkeit | Threshold Min Threshold Max | 001 002
Barcode | Reference String | 101
Datacode | Reference String | 101
OCR | Reference String | 101
Farbwert | ColorMinChannel1 ColorMaxChannel1 ColorInvertChannel1 ColorMinChannel2 ColorMaxChannel2 ColorInvertChannel2 ColorMinChannel3 ColorMaxChannel3 ColorInvertChannel3 | 101 102 103 104 105 106 107 108 109
Farbfläche | ColorMinChannel1 ColorMaxChannel1 ColorInvertChannel1 ColorMinChannel2 ColorMaxChannel2 ColorInvertChannel2 ColorMinChannel3 ColorMaxChannel3 ColorInvertChannel3 | 101 102 103 104 105 106 107 108 109
BLOB | GreyAbsoluteMin GreyAbsoluteMax GreyAbsoluteInvert | 101 102 103


ROI setzen (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

ROI setzen (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | S | Set ROI
2 | R
3 | P T | P = Permanent T = Temporär Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
4 - 11 | X | ROI Info Länge in Bytes ab Byte 4 bis Ende z.B. 00000055
12 - 14 | X | Detektor Nr. z.B. 001
15 - 16 | X | ROI Index = 00 für gelben Suchbereich = 01 für roten Teachbereich = 02 Positionskontrolle
17 - 18 | X | ROI Form 01=Kreis 02=Rechteck 03=Ellipse 04=Freiform
19 - 26 | X | Zentrum X (Wert in Pixeln * 1000), z.B. 160 Pixel = 00160000
27 - 34 | X | Zentrum Y (Wert in Pixeln * 1000), z.B. 120 Pixel = 00120000
35 - 42 | X | Halbe Breite / X-Radius (Wert in Pixeln * 1000), z.B. 80 Pixel = 00080000
43 - 50 | X | Halbe Höhe / Y-Radius (Wert in Pixeln * 1000), z.B. 40 Pixel = 00040000
51 - 58 | X | Winkel (nicht bei Kreis / Ellipse) (Wert in ° * 1000), z.B. 180° = 00180000
Beispiel: | SRP0000005500100020016000000120000000800000004000000180000 Länge=55, Detektor=1, gelber Suchbereich, Rechteck, Zentrum X=160, Zentrum Y=120, Halbe Breite= 80, Halbe Höhe=40
ROI setzen (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | S | Set ROI
2 | R
3 | P T | Permanent Temporär Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
Beispiel: | SRPP
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Low
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)
Parameter: |  | Die Parameter werden im Koordinatensystem der Lagenachführung und nicht im Koordinatensystem des Bildes angegeben.


ROI lesen (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

ROI lesen (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | G | Get ROI
2 | R
3 | I
4 - 6 | X | Detektor Nr. z.B. 001
7 - 8 | X | ROI Index = 00 für gelben Suchbereich = 01 für roten Teachbereich = 02 für Positionskontrolle
Beispiel: | GRI00100
ROI lesen (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | G | Get ROI
2 | R
3 | I
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
5 - 12 | X | ROI Info Länge in Bytes, ab Byte 5 bis Ende String
13 - 15 | X | Detektor Nr. z.B. 001
16 - 17 | X | ROI Index = 00 für gelben Suchbereich = 01 für roten Teachbereich = 02 für Positionskontrolle
18 - 19 | X | ROI Form 01= Kreis 02= Rechteck 03= Ellipse 04= Freiform
20 - 27 | X | Zentrum X (Wert in Pixeln * 1000)
28 - 35 | X | Zentrum Y (Wert in Pixeln * 1000)
36 - 43 | X | Halbe Breite / X-Radius (Wert in Pixeln * 1000)
44 - 51 | X | Halbe Höhe / Y-Radius (Wert in Pixeln * 1000)
52 - 59 | X | Winkel (nicht bei Kreis / Ellipse) (Wert in ° * 1000)
Beispiel: | GRIP0000005500100020016000000120000000800000004000000090000 (Länge= 55, Detektor 1, Suchbereich, Rechteck, Zentrum X=160, Zentrum Y=120, Halb Breite=80, Halb Höhe=40, Winkel = 90)
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Low
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)


Jobliste lesen (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Jobliste lesen (ASCII) Request String an Sensor

Byte Nr.

Inhalt

Bedeutung
1 | G | Get Job List
2 | J
3 | L
Beispiel: GJL

Jobliste lesen (ASCII) Response String vom Sensor

Byte Nr.

Inhalt

Bedeutung
1 | G | Get Job List
2 | J
3 | L
4 P
F

P (Pass) Erfolgreich

F (Fail) Fehler

5 - 7 | X | Version des Response
8 - 10 | X | Anzahl der Jobs
11 - 13 | X | Aktive Job Nummer

Hinweis:

Folgende Bytefolge wird für jeden Job von 1 bis "Anzahl der Jobs" wiederholt. Die Byte Nummern verschieben sich entsprechend.
14 - 16 | X | Anzahl der Zeichen für den Jobnamen. Damit kann ein eindeutiger Name für den Job n angegeben werden.
17 ... n | X | Ab dieser Position folgt, in der angegebenen Länge, der Name für Job n.
n+1 ... n + 3 | X | Anzahl der folgenden Bytes. Damit kann eine Beschreibung für den Job n angegeben werden.
n + 4 ... m | X | Ab dieser Position folgt, in der angegebenen Länge, die Beschreibung für Job n.
m + 1 ... m + 3 | X | Anzahl der folgenden Bytes. Damit kann ein eindeutiger Name für den Autor des Job n angegeben werden.
m + 4 ... k | X | Ab dieser Position folgt, in der angegebenen Länge, der Name für den Autor aus Job n.
k + 1 ... k + 8 | X | Datum der Erstellung von Job n
k + 9 ... k + 16 | X | Datum der letzten Änderung von Job n
Beispiel: GJLP001001001007testjob010DefaultJob004Test2014112720141128

Weitere Informationen:

Akzeptiert im Run Mode:

Ja

Akzeptiert im Konfigurations Mode:

Nein

Akzeptiert wenn Ready Low:

Ja

Status des Signals Ready während Bearbeitung:

Keine Veränderung
Unterstützte Schnittstellen: Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: Max. 4 Byte (optional)


Detektorliste lesen (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Detektorliste lesen (ASCII) Request String an Sensor

Byte Nr.

Inhalt

Bedeutung
1 | G | Get Detector List
2 | D
3 | L
Beispiel: GDL

Detektorliste lesen (ASCII) Response String vom Sensor

Byte Nr.

Inhalt

Bedeutung
1 | G | Get Detector List
2 | D
3 | L
4 P
F

P (Pass) Erfolgreich

F (Fail) Fehler

5 - 7 | X | Job Nummer des aktuellen Jobs
8 - 10 | X | Anzahl der Detektoren im aktuellen Job

Hinweis:

Folgende Bytefolge wird für jeden Detektor im Job wiederholt. Die Byte Nummern verschieben sich entsprechend.
11 - 13 | X | Anzahl der folgenden Bytes. Damit kann ein eindeutiger Name für den Detektor n angegeben werden.
14 ... n | X | Ab dieser Position folgt, in der angegebenen Länge, der Name für Detektor n.
n + 1 ... n+ 5 X

001 - Mustervergleich

004 - Kontur

005 - Graustufe

006 - Kontrast

007 - Helligkeit

011 - OCR

013 - Datacode

014 - Barcode

018 - Farbwert

019 - Farbfläche

020 - Farbliste

021 - Messschieber

022 - BLOB
Beispiel: GDLP001001012testdetector00005

Weitere Informationen:

Akzeptiert im Run Mode:

Ja

Akzeptiert im Konfigurations Mode:

Nein

Akzeptiert wenn Ready Low:

Ja

Status des Signals Ready während Bearbeitung:

 Keine Veränderung
Unterstützte Schnittstellen: Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: Max. 4 Byte (optional)


Detektor einlernen (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Detektor einlernen (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | T | Teach Detector
2 | E
3 | D
4 - 6 | X | 0 = Lagenachführung >= 1 Detektoren
7 | X | 0: Temporär 1: Permanent Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
8 | X | 0 = kein Trigger 1 = Trigger
Beispiel: | TED00111
Detektor einlernen (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | T | Teach Detector
2 | E
3 | D
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
Beispiel: | TEDP
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Low
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)


Trigger-Verzögerung setzen (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Trigger-Verzögerung setzen V1 (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | S | Set Trigger Delay
2 | T
3 | D
4 | 1 | Version des Request
5 | X | 0: Temporär 1: Permanent
6 - 13 | X | Trigger Verzögerung in msec (max. 3000 msec) in Encoder-Schritten (max. 65535 Schritte)
Beispiel: | STD1100001000
Trigger-Verzögerung setzen V1 (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | S | Set Trigger Delay
2 | T
3 | D
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
5 - 7 | X | Fehlercodes
Beispiel: | STDP000
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Keine Veränderung
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)


Trigger-Verzögerung lesen (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Trigger-Verzögerung lesen V1 (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | G | Get Trigger Delay
2 | T
3 | D
4 | 1 | Version des Request
Beispiel: | GTD1
Trigger-Verzögerung lesen (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | G | Get Trigger Delay
2 | T
3 | D
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
5 - 7 | X | Fehlercode
8 - 15 | X | Trigger Verzögerung in msec (max. 3000 msec) in Encoder-Schritten (max. 65535 Schritte)
Beispiel: | GTDP00000001000
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Keine Veränderung
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)


Kalibrierung: Punkteliste initialisieren (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Punkteliste initialisieren (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Calibration: Clear Data
2 | C
3 | D
Beispiel: | CCD
Punkteliste initialisieren (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Calibration: Clear Data
2 | C
3 | D
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
Beispiel: | CCDP
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Keine Veränderung
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)


Kalibrierung: Weltpunkt hinzufügen (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Kalibrierung: Weltpunkt hinzufügen V1 (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Calibration: Add World Point
2 | A
3 | W
4 | 1 | Version des Request
5 | X | 1: Nur Referenzmarken Kalibrierplatte (Roboter) 4: Weltpunkt und Bildpunkt Punktpaarliste (Roboter)
6 - 10 | 0 | Konstant (5 Byte)
11 - 18 | X | Welt- X (in mm *1000)
19 - 26 | X | Welt- Y (in mm *1000)
27 - 34 | 0 | Konstant (8 Byte)
Beispiel: | CAW1000010010000000200000000000000 (Welt-X = 100 mm; Welt-Y = 200 mm)
Kalibrierung: Weltpunkt hinzufügen V1 (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Calibration: Add World Point
2 | A
3 | W
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
5 - 7 | X | Fehlercodes
8 - 12 | X | Aktuelle Anzahl Punkte
13 - 20 | X | Bildpunkt X
21 - 28 | X | Bildpunkt Y
Beispiel: | CAWP000000010028800000566000 (Referenzpunkt 1; Bild-X=288; Bild-Y=566)
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Keine Veränderung
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)


Kalibrierung: Punkt hinzufügen (ASCII)

Kalibrierung: Punkt hinzufügen (ASCII) - Abgekündigt

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Kalibrierung: Punkt hinzufügen (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Calibration: Add Point
2 | A
3 | P
4 - 8 | 0 | Konstant
9 - 16 | X | Welt- X (in mm *1000)
17 - 24 | X | Welt- Y (in mm *1000)
Beispiel: | CAP000000010000000200000 (Welt-X=100mm; Welt-Y=200mm)
Kalibrierung: Punkt hinzufügen (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Calibration: Add Point
2 | A
3 | P
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
5 - 9 | X | Aktuelle Anzahl der Punkte in der Liste
10 - 17 | X | Bildpunkt X
18 - 25 | X | Bildpunkt Y
Beispiel: | CAPP000010064000000512000 (Index 1; Bild-X=640; Bild-Y=512)
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Keine Veränderung
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)
Nötige Einstellungen im aufrufenden Job |  | Unter "Ausgabe/Datenausgabe/Detektorspezifische Nutzdaten" müssen als erster und zweiter Ausgabewert der X- und der Y- Wert der Findeposition eingestellt sein.

Hinweis:

Dieses Telegramm "Kalibrierung Punkt hinzufügen" ist abgekündigt.

Alternativ steht das Telegramm: "Kalibrierung: Weltpunkt hinzufügen (ASCII)" zur Verfügung.


Kalibrierung: Punkteliste (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Kalibrierung per Punkteliste (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Calibration: Calibrate by Point List
2 | C
3 | L
4 | X | 0: Temporär 1: Permanent
Beispiel: | CCL1
Kalibrierung Punkteliste (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Calibration: Calibrate by Point List
2 | C
3 | L
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
5 - 9 | X | Aktuell höchster Punktpaarindex
10 - 17 | X | Abweichung Kalibrierung, RMSE (Root Mean Square Error)
18 - 25 | X | Abweichung Kalibrierung, Mittelwert
26 - 33 | X | Abweichung Kalibrierung, Max
34 - 41 | X | Abweichung Kalibrierung, Min
Beispiel: | CCLP0001012345678123456781234567812345678
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Keine Veränderung
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)


Kalibrierung: Punkteliste validieren (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Kalibrierung: Punkteliste validieren (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Calibration: Validate by Point List
2 | V
3 | L
Beispiel: | CVL
Kalibrierung: Punkteliste validieren (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Calibration: Validate by Point List
2 | V
3 | L
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
5 - 9 | X | Aktuell höchster Punktpaarindex
10 - 17 | X | Abweichung Kalibrierung, RMSE (Root Mean Square Error)
18 - 25 | X | Abweichung Kalibrierung, Mittelwert
26 - 33 | X | Abweichung Kalibrierung, Max
34 - 41 | X | Abweichung Kalibrierung, Min
Beispiel: | CVLP0001012345678123456781234567812345678
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Keine Veränderung
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)


Kalibrierung: Kalibrierplatte (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Kalibrierung: Kalibrierplatte (ASCII) Request String an Sensor

Byte Nr.

Inhalt

Bedeutung
1 | C | Calibration: Calibrate by Plate
2 | C
3 | P
4 | 1 | Version des Request
5 X

0: Temporär

1: Permanent

Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
6 X

0: Es werden keine Referenzmarken verwendet. Ursprung des Mess-Koordinatensystems ist identisch mit dem Ursprung des Kalibrier-Koordinatensystems.

1: Es werden keine Referenzmarken verwendet. Mess-Koordinatensystem ist identisch zu Geräte-Koordinatensystem.

2: Verwendet Weltsystem, Referenzmarke Job

3: Verwendet Weltsystem, Referenzmarke Befehl CAW
7 X

0: Kalibrierung interne- und externe Sensor Parameter

1: Validierung der Kalibrierung

2: Kalibrierung interne Sensor Parameter

5: Kalibrierung Transformation Mess-Koordinatensystem
Beispiel: CCP1110

Kalibrierung: Kalibrierplatte (ASCII) Response String vom Sensor

Byte Nr.

Inhalt

Bedeutung
1 | C | Calibration: Calibrate by Plate
2 | C
3 | P
4 P
F

P (Pass) Erfolgreich

F (Fail) Fehler

5 - 7 | X | Fehlercodes
8 - 12 | X | Anzahl der aktuell detektierten Kalibrierpunkte
13 - 20 | X | Abweichung Kalibrierung, RMSE (Root Mean Square Error)
21 - 28 | X | Abweichung Kalibrierung, Mittelwert
29 - 36 | X | Abweichung Kalibrierung, Max
37 - 44 | X | Abweichung Kalibrierung, Min
45 - 52 | X | Delta X (in Kundeneinheit * 1000)
53 - 60 | X | Delta Y (in Kundeneinheit * 1000)
61 - 68 | 0 | Reserviert
69 - 76 | 0 | Reserviert
77 - 84 | 0 | Reserviert
85 - 92 | X | Delta Gamma (In Grad * 1000)
93 - 100 | X | Abweichung Referenzmarken, Mittelwert
101 - 108 | X | Abweichung Referenzmarken, Max
109 - 116 | X | Abweichung Referenzmarken, Min
Beispiel:

CCPP00000012000010010000200200003003000040040

00050050000600600007007000080080000900900001001

Weitere Informationen:

Akzeptiert im Run Mode:

Ja

Akzeptiert im Konfigurations Mode:

Nein

Akzeptiert wenn Ready Low:

Ja

Status des Signals Ready während Bearbeitung:

Keine Veränderung
Unterstützte Schnittstellen: Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: Max. 4 Byte (optional)


Kalibrierung: Referenzmarke setzen (ASCII)

Kalibrierung: Referenzmarke setzen V1 (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Calibration: Set Fiducial
2 | S
3 | F
4 | 1 | Version des Request
5 | X | 0: Temporär 1: Permanent
Beispiel: | CSF11
Kalibrierung: Referenzmarke setzen V1 (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Calibration: Set Fiducial
2 | S
3 | F
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
5 - 7 | X | Fehlercodes
8 - 15 | X | X-Wert
16 - 23 | X | Y-Wert
24 - 31 | X | Z-Wert
32 - 39 | X | Rot X-Wert
40 - 47 | X | Rot Y-Wert
48 - 55 | X | Rot Z-Wert
56 - 63 | X | Abweichung Referenzmarken, Mittelwert
64 - 71 | X | Abweichung Referenzmarken, Max
72 - 79 | X | Abweichung Referenzmarken, Min
Beispiel: | CSFP 000 00001001 00002002 00003003 00004004 00005005 00006006 00001001 0000202 00003003
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Keine Veränderung
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)


Kalibrierung: Kalibrierung kopieren (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Kalibrierung: Kalibrierung kopieren (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Calibration: Copy Calibration
2 | C
3 | C
4 | 1 | Version des Request
5 | 1 | Konstant
6 - 8 | X | Destination 0 : In alle Jobs kopieren >0 : In angegebenen Job kopieren
9 | X | 0: Immer kopieren, wenn die Kalibrierung aktiv ist. 1: Nur kopieren, wenn die Kalibriermethode identisch ist.
Beispiel: | CCC110021
Kalibrierung: Kalibrierung kopieren (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Calibration: Copy Calibration
2 | C
3 | C
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
5 - 7 | X | Fehlercodes
8 - 10 | X | Jobnummer des Jobs, indem der Fehler auftritt 00 - Erfolgreich >0 - Jobnummer des Jobs, indem der Fehler zuerst auftritt
Beispiel: | CCCP000000
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Keine Veränderung
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)


Kalibrierung: Parameter setzen (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Kalibrierung: Parameter setzen V1 (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Calibration: Set Parameter
2 | S
3 | P
4 | 1 | Version des Request
5 | X | 0: Temporär 1: Permanent
6 - 8 | X | Parameter Nummer
9 - 16 | X | Länge der nachfolgenden Daten
17 ... n | X | Parameter Wert
Beispiel: | CSP11002000000019
Kalibrierung: Parameter setzen V1 (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Calibration: Set Parameter
2 | S
3 | P
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
5 - 7 | X | Fehlercodes
Beispiel: | CSPP000
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Keine Veränderung
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)

Parameter Bezeichnung | Parameter Nummer | Parameter Wert | Länge | Format | Status
Einheit (Kundeneinheit) | 004 | 0: mm 1: cm 2: m 3. inch 4: au | 1 Byte | Zeichen | no change
Z-Versatz | 021 | (in Kundeneinheit * 1000) | 8 Byte | Signed Integer | no change
Brennweite | 022 | (in mm *1000) | 8 Byte | Signed Integer | invalid
Referenzmarke 1 | 024 | jeweils: 0: X-Wert (in Kundeneinheit * 1000) 1: Y-Wert (in Kundeneinheit * 1000) 2: Z-Wert (in Kundeneinheit * 1000) | Je Wert 8 Byte | Signed Integer | no change
Referenzmarke 2 | 025
Referenzmarke 3 | 026
Referenzmarke 4 | 027


Kalibrierung: Parameter lesen (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Kalibrierung: Parameter lesen V1 (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Calibration: Get Parameter
2 | G
3 | P
4 | 1 | Version des Request
5 - 7 | X | Parameter Nummer
Beispiel: | CGP1001
Kalibrierung: Parameter lesen V1 (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Calibration: Get Parameter
2 | G
3 | P
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
5 - 7 | X | Fehlercodes
8 - 10 | X | Parameter Nummer
11 - 18 | X | Länge der nachfolgenden Daten
19 ... n | X | Parameter Werte, abhängig von dem gewählten Parameter
Beispiel: | CGPP000001000000011
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Keine Veränderung
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)

Parameter Bezeichnung | Parameter Nummer | Wert | Länge | Format
Status Kalibrierung | 001 | 0: Ungültig 1: Gültig | 1 Byte | Signed Integer
Kalibriermethode | 002 | 0: Keine 1: Skalierung (Messen) 2: Punktpaarliste (Roboter) 3: Kalibrierplatte (Messen) 4: Kalibrierplatte (Roboter) | 1 Byte | Zeichen
Einheit (Kundeneinheit) | 004 | 0: mm 1: cm 2: m 3. inch 4: au | 1 Byte | Zeichen
Interne Sensor Parameter | 010 | 0: Brennweite (in mm *1000) 1: Kappawert (*1000) 2: Pixelabstand X (in µm * 1000) 3: Pixelabstand Y (in µm * 1000) 4: Koordinatenursprung X (in Pixel * 1000) 5: Koordinatenursprung Y (in Pixel * 1000) 6: Bildgröße X (Pixel) 7: Bildgröße Y (Pixel) | Je Wert 8 Byte | Signed Integer
Externe Parameter | 011 | 0: Verschiebung X Achse (in Kundeneinheit * 1000) 1: Verschiebung Y Achse (in Kundeneinheit * 1000) 2: Verschiebung Z Achse (in Kundeneinheit * 1000) 3: Rotation X (in Grad * 1000) 4: Rotation Y (in Grad * 1000) 5: Rotation Z (in Grad * 1000) | Je Wert 8 Byte | Signed Integer
Transformation Kalibrier-Koordinatensystem | 012 | 0: Verschiebung X Achse (in Kundeneinheit * 1000) 1: Verschiebung Y Achse (in Kundeneinheit * 1000) 2: Verschiebung Z Achse (in Kundeneinheit * 1000) 3: Rotation X (in Grad * 1000) 4: Rotation Y (in Grad * 1000) 5: Rotation Z (in Grad * 1000) | Je Wert 8 Byte | Signed Integer
Transformation Mess-Koordinatensystem | 014 | 0: Verschiebung X Achse (in Kundeneinheit * 1000) 1: Verschiebung Y Achse (in Kundeneinheit * 1000) 2: Verschiebung Z Achse (in Kundeneinheit * 1000) 3: Rotation X (in Grad * 1000) 4: Rotation Y (in Grad * 1000) 5: Rotation Z (in Grad * 1000) | Je Wert 8 Byte | Signed Integer
Z-Versatz | 021 | Wert in Kundeneinheit (siehe Einheit * 1000) | 8 Byte | Signed Integer
Brennweite | 022 | (in mm *1000) | 8 Byte | Signed Integer
Referenzmarke 1 | 024 | jeweils: 0: X-Wert (in Kundeneinheit * 1000) 1: Y-Wert (in Kundeneinheit * 1000) 2: Konstant 0 | Je Wert 8 Byte | Signed Integer
Referenzmarke 2 | 025
Referenzmarke 3 | 026
Referenzmarke 4 | 027


Bild holen

Bild holen (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Bild holen (ASCII) Request String an Sensor

Byte Nr.

Inhalt

Bedeutung

1

G

Get Image

2

I

3

M

4

X

0 – Letztes Bild

1 – Letztes Schlecht-Bild

2 – Letztes Gut-Bild
Beispiel: GIM1

Bild holen (ASCII) Response String vom Sensor

Byte Nr.

Inhalt

Bedeutung

1

G

Get Image

2

I

3

M

4

P

F

P (Pass) Erfolgreich

F (Fail) Fehler

5

X

Fehlercodes

6

X

Typ Bild

0 - Graustufen

3 – Bayer Pattern_BG

Bei Konvertierung des Farbbildes von Bayer in RGB, muss der entsprechende Bild Typ berücksichtigt werden.

Vorverarbeitungsfilter der Kategorie "Anordnung" haben Einfluss auf den Bayer- Type. Bayer Pattern fängt mit Blau - Grün an.

7

X

Bildergebnis

1 - Gutbild

0 - Fehlerbild

8 - 11

X

Anzahl der Zeilen

z.B. 0480 / 0200

12 - 15

X

Anzahl der Spalten

z.B. 0640 / 0320

16 - 19 X Ende des Nachrichten-Strings

20 ... n

X

Binäre Bilddaten (Zeilen * Spalten)

Beispiel: GIMP0004800640...

Weitere Informationen:

Akzeptiert im Run Mode:

Ja

Akzeptiert im Konfigurations Mode:

Nein

Akzeptiert wenn Ready Low:

Ja

Status des Signals Ready während Bearbeitung:

Low
Unterstützte Schnittstellen: Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Telegrammende:

 Max. 4 Byte (optional)


Visualisierungsdaten aktualisieren

Visualisierungsdaten aktualisieren (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Visualisierungsdaten aktualisieren V1 (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | U | Update Visualization Results
2 | V
3 | R
4 | 1 | Version des Request
5 | X | Bild: 0 - Kein Bild wird erstellt 1 - Grauwert-Bild / RGB Bild wird erzeugt 2 - Grauwert-Bild / Bayerpattern wird erzeugt
6 | X | Ergebnis XML: 0 - Ergebnisdatei wird nicht erstellt 1 - Ergebnisdatei wird erstellt
7 | X | Statisik XML: 0 - Statistik-Datei wird nicht erstellt 1 - Statistik-Datei wird erstellt
8 | X | Bildtyp: 0 - Letztes beliebiges Bild (Any) 1 - Letztes Fehler-Bild (Fail) 2 - Letztes erfolgreiches Bild (Pass) 3 - Nächstes beliebiges Bild (Any) 4 - Nächstes Fehler-Bild (Fail) 5 - Nächstes erfolgreiches Bild (Pass)
9 - 11 | X | Verzeichnis Nummer 000: visu000
Beispiel: | UVR11110000
Visualisierungsdaten aktualisieren V1 (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | U | Update Visualization Results
2 | V
3 | R
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
5 - 7 | X | Fehlercodes
8 | X | Daten verfügbar: 0: Neue Daten verfügbar, wenn ready.txt geschrieben 1: keine neuen Daten verfügbar.
9 - 11 | X | Verzeichnis-Nummer 000: visu000
Beispiel: | UVRP0000000
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Keine Veränderung
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)

Die erstellten Dateien liegen im Verzeichnis /tmp/[Verzeichnis-Nummer] zum Download bereit:

  • image.bmp
  • overlay.xml

Mit der Datei "overlay.xml" können alle relevanten Informationen zur Erstellung der Einzeichnung bezogen werden. Die Datei ist im XML Format erstellt. Die wichtigsten Elemente werden in der untenstehenden Tabelle beschrieben

Name |  | Wert | Beschreibung
detector | type | pattern_matching contour contrast brightness grey caliper blob ocr datacode barcode | Detektor-Typ
 | number | Integer | Position in Detektor-Liste
 | name | String | Name des in der Konfiguration definierten Detektors
roi | purpose | search teach position_control result | Art des Einzeichnung-Elements. Die verschiedene Arten haben unterschiedliche Farben.
 | shape | rectangle rectangle_mask ellipse | Form des Einzeichnung-Elements
center | x | Float | Position des Zentrums in X (Pixel)
 | y | Float | Position des Zentrums in Y (Pixel)
size | half_width | Float | Halbe Breite des Einzeichnung-Elements
 | half_hight | Float | Halbe Höhe des Einzeichnung-Elements
angle | angle | Float | Winkel des Einzeichnung-Elements (Grad)
number | value | Float | Anzahl der Einzeichnung-Elemente in diesem Detektor
line | x1 | Float | Startpunkt X Linie 1 (Pixel)
 | y1 | Float | Startpunkt Y Linie 1 (Pixel)
 | x2 | Float | Startpunkt X Linie 2 (Pixel)
 | y2 | Float | Startpunkt Y Linie 2 (Pixel)

Abhängig vom Detektortyp (detector → type) gibt es verschiedene Elemente die angezeigt werden können. Folgende Tabelle gibt an, welches Element bei welchem Detektor angezeigt werden kann.

Detektor | search | teach | position_control | result
Mustervergleich | Ja | Ja | Ja | 1
Kontur | Ja | Ja | Ja | 200
Kontrast | Ja | Nein | Nein | 0
Helligkeit | Ja | Nein | Nein | 0
Graustufe | Ja | Nein | Nein | 0
Messschieber | Ja | Nein | Nein | 0
BLOB | Ja | Nein | Nein | 1000
OCR | Ja | Nein | Nein | 1
Datacode | Ja | Nein | Nein | 5
Barcode | Ja | Nein | Nein | 5


Sensoridentität lesen (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Sensoridentität lesen V1 (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | G | Sensoridentität lesen
2 | S
3 | I
4 | 1 | Version des Request
Beispiel: | GSI1
Sensoridentität lesen V1 (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | G | Sensoridentität lesen
2 | S
3 | I
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
5 - 7 | X | Fehlercodes
8 - 10 | X | Länge der folgenden Daten
11 ... n | X | Version der Firmware sowie Informationen über die Hardware. Bereiche sind durch ein Semikolon eindeutig getrennt.
Beispiel: | GSIP0000221.19.3.2; SBSI-Q-AF-R2B-F12-W
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)


Firmware aktualisieren (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Firmware aktualisieren V1 (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | U | Update Firmware
2 | F
3 | W
4 | 1 | Version des Request
Beispiel: | UFW1
Firmware aktualisieren V1 (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | U | Update Firmware
2 | F
3 | W
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
5 - 7 | X | Fehlercodes
Beispiel: | UFWP000
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)

Nach absenden des Befehls wird im Verzeichnis /tmp/ auf dem SBS Vision-Sensor auf eine gültige Firmware Datei geprüft. Der Name muss der typischen Namensvergabe entsprechen (z.B. wie nach dem Download von der Festo Homepage). Das Ende ist erreicht sobald die Kamera wieder Ready (Pin 4 GN) signalisiert. Alternativ kann über das Telegramm "GSI1" geprüft werden, ob eine gültige Antwort gesendet wird.

Hinweis:

Bei der Firmwareaktualisierung ist die Spannungsversorgung sicherzustellen. Ein Update kann bis zu 10 Minuten dauern.


Jobsatz einspielen (ASCII)

Jobsatz einlesen (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Jobsatz einlesen V1 (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | S | Jobsatz einlesen
2 | J
3 | S
4 | 1 | Version des Request
5 - 7 | X | Länge des nachfolgenden Dateinamens. Maximale Länge 250 Zeichen.
8 ... n | X | Optionaler Dateiname. Wird kein Dateiname angegeben wird der Standardname „Jobset.bjs“ verwendet.
Beispiel: | SJS1012myjobset.bjs
Jobsatz einlesen V1 (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | S | Jobsatz einlesen
2 | J
3 | S
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
5 - 7 | X | Fehlercodes
8 - 10 | X | Aktive Jobnummer im geladenen Jobsatz
Beispiel: | SJSP000001
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Nein
Status des Signals Ready während Bearbeitung: |  | Low
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)

Der Jobsatz mit dem angegebenen Namen wird im Verzeichnis /tmp/ auf dem SBS Vision-Sensor gesucht. Ist die Datei vorhanden, wird dieser Jobsatz aktiviert. Die Datei wird anschließend entfernt.


Jobsatz lesen (ASCII)

Jobsatz sichern (ASCII)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Jobsatz sichern V1 (ASCII) Request String an Sensor
Byte Nr. | Inhalt | Bedeutung
1 | G | Jobsatz sichern
2 | J
3 | S
4 | 1 | Version des Request
5 - 7 | X | Länge des nachfolgenden Dateinamens. Maximale Länge 250 Zeichen.
8 ... n | X | Optionaler Dateiname. Wird kein Dateiname angegeben wird der Standardname „Jobset.bjs“ verwendet.
Beispiel: | GJS1012myjobset.bjs
Jobsatz sichern V1 (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | G | Jobsatz sichern
2 | J
3 | S
4 | P F | P (Pass) Erfolgreich F (Fail) Fehler
5 - 7 | X | Fehlercodes
Beispiel: | GJSP000
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Telegrammende: |  | Max. 4 Byte (optional)

Die Jobsatz auslesen Datei liegt nun im Verzeichnis /tmp/ unter dem angegebenen Namen zum Download bereit.


Datenausgabe in ASCII

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Ausgabedaten (ASCII), dynamisch zusammengesetzt nach Benutzereinstellungen in der Software. Für detaillierte Angaben zum Datenformat siehe auch: Reiter Datenausgabe

Prinzipieller Stringaufbau:

<START> (((<OPTIONAL FIELDS> <SEPARATOR> <PAYLOAD>))) <CHKSUM> <TRAILER>

Ausgabedaten (ASCII):

<OPTIONAL FIELDS>
Name | Byte Anzahl | Inhalt Binär / Beispiel | Bedeutung / Kommentare
Vorspann | 1 - max. 8 | User definiert, bis max. 8 Zeichen | Start String (Header)
Gewählte Felder | 16 | 1 Byte pro Feld | über dieses Feld werden alle aktivierten Checkboxen ausgegeben. - Die Reihenfolge der Ausgabe ist von links nach rechts und von oben nach unten - D.h. pro aktiver Checkbox wird ein Byte beginnend beim LSB = Low significant Bit ausgegeben. - Die Checkbox „Gewählte Felder" selbst wird nicht mit ausgegeben! P = logischer Ausgang gesetzt F = logischer Ausgang nicht gesetzt 0 = logischer Ausgang nicht aktiv
Trennzeichen | 1 - 5 | User definiert, bis max 5 Zeichen (pro Separator) | Separator ab: „nach erstem optionalen Feld“, oder „nach erstem detektorspez. Datum“
Telegrammlänge | n | Pro Ziffer der Dezimalzahl ein Byte z.B. 102 „1“; „0“; „2“ | Telegrammlänge in Byte
Statusbyte | 3 | „110” triggered mode oder „101” free-run mode |
Detektorergebnis | n | Byte 1 = UND Verknüpfung aller Detektoren Byte 2 = Boolsches Ergebnis der Lagenachführung Byte 3 = Globales Ergebnis des aktiven Jobs Folgende Bytes: Anzahl der Detektoren Folgende Bytes: Detektor Ergebnisse (P = Erfolgreich (Pass), F = Fehler (Fail)), das letzte Byte steht für den ersten Detektor Länge.: 4 Byte + 1 Byte je genutztem Detektor |
Digitalausgänge | n | Erste Bytes: Anzahl aktiver Ausgänge Folgende Bytes: Digitale Ausgänge, | P = logischer Ausgang gesetzt F = logischer Ausgang nicht gesetzt 0 = logischer Ausgang nicht aktiv
Logische Ausgänge | n | Erste Bytes: Anzahl aktiver logischer Ausgänge Folgende Bytes: Logische Ausgänge, | Beispiel: 18 logische Ausgänge werden konfiguriert, aber nur Ausgang 1, 2 und 9 werden tatsächlich mit Funktionen belegt (sind also aktiv): 3PP000000P 2 Bytes Anzahl aktiver Ausgänge dann alle Ergebnisse bit- codiert... Im Beispiel werden wegen Ausgang 9, zwei Bytes benötigt.... P = logischer Ausgang gesetzt F = logischer Ausgang nicht gesetzt 0 = logischer Ausgang nicht aktiv
Ausführungszeit | n |  | Aktuelle (Job-)Zykluszeit in [ms]
Aktiver Job | 1 - 3 |  | Aktive Job Nr. (1 ... 255)

<PAYLOAD>
Detektorspezifische Nutzdaten |  |  |  | Für Detektortyp
Name | Byte Anzahl | Inhalt ASCII / Beispiel | Bedeutung / Kommentare
Detektor Ergebnis | 1 | P = Pass F = Fail | Boolsches Detektorergebnis | Alle Detektoren
Score 1 ... n | n |  | Score (0 ... 100 %) | Alle Detektoren
Ausführungszeit | n |  | Ausführungszeit des einzelnen Detektors in [msec]. | Alle Detektoren
Abstand | n |  | Berechneter Abstand, signed integer [1/1000] *1) | Messschieber
Position X 1 ... n | n | z.B..: X = 180 (pix) = (in ASCII) “180000” = 6 Byte | Gefundene Position X (X-Koordinate). [1/1000] *1) | Mustervergleich Kontur Kantenantastung Messschieber Datacode Barcode OCR
Position Y 1 ... n | n |  | Gefundene Position Y (Y-Koordinate). [1/1000] *1) | Mustervergleich Kontur Kantenantastung Messschieber Datacode Barcode OCR
Delta Pos X | n |  | Delta Position X zwischen eingelerntem und gefundenem Objekt [1/1000] *1) | Mustervergleich Kontur Kantenantastung
Delta Pos Y | n |  | Delta Position X zwischen eingelerntem und gefundenem Objekt [1/1000] *1) | Mustervergleich Kontur Kantenantastung
Winkel | n |  | Orientierung des gefundenen Objekts (0° ... 360°) [1/1000]*1) | Mustervergleich Kontur Kantenantastung Datacode Barcode OCR
Delta Winkel | n |  | Winkel zwischen eingelerntem und gefundenem Objekt (0° ... 360°) [1/1000] *1) | Mustervergleich Kontur Kantenantastung
Skalierung | n |  | Nur bei Kontur (0,5 ... 2) [1/1000] *1) | Kontur
R(ot) G(rün) B(lau) | n |  | Wert für Farbparameter, signed integer [1/1000] *1) | Farbwert Farbliste
H(ue) S(aturation) V(alue) | n |  | Wert für Farbparameter, signed integer [1/1000] *1) | Farbwert Farbliste
L(uminanz) A B | n |  | Wert für Farbparameter, signed integer [1/1000] *1) | Farbwert Farbliste
Ergebnis Index | n |  | Listenindex, signed integer, [1/1000] *1) | Farbliste
Farbabstand | n |  | Abstand der aktuellen Farbe gegenüber der eingelernten Farbe, signed integer [1/1000] *1) | Farbliste
Fläche | n |  | Fläche des BLOBs, ohne Löcher, in Pixel, signed integer, [1/1000] *1) | BLOB
Fläche (inkl. Löcher) | n |  | Fläche des BLOBs, mit Löchern, in Pixel, signed integer, [1/1000] *1) | BLOB
Konturlänge | n |  | Anzahl der Pixel der äußeren Kontur, signed integer, [1/1000] *1) | BLOB
Kompaktheit | n |  | Kompaktheit des BLOBs, (Kreis = 1, andere >1) Je stärker die Form des BLOB vom Kreis abweicht, desto größer wird der Wert der Kompaktheit. Signed integer [1/1000] *1) | BLOB
Schwerpunkt X | n |  | X- Koordinate des BLOB- Schwerpunkts, signed integer [1/1000] *1) | BLOB
Schwerpunkt Y | n |  | Y- Koordinate des BLOB- Schwerpunkts, signed integer [1/1000] *1) | BLOB
Zentrum X | n |  | X- Koordinate des gefitteten Rechtecks / Ellipse, signed integer [1/1000] *1) | BLOB
Zentrum Y | n |  | Y- Koordinate des gefitteten Rechtecks / Ellipse, signed integer [1/1000] *1) | BLOB
Breite | n |  | Breite des geometrischen Elements (Rechtecks / Ellipse). Breite >= 0, Breite >= Höhe, negative Werte = Fehler, signed integer [1/1000] *1) | BLOB
Höhe | n |  | Höhe des geometrischen Elements (Rechtecks / Ellipse) Höhe >= 0, Höhe <= Breite, negative Werte = Fehler, signed integer [1/1000] *1) | BLOB
Winkel (360) | n |  | Winkellage des Objekts in Grad (Wertebereich +180° ... -180,0° = Ost, Drehrichtung = Gegenuhrzeigersinn), signed integer [1/1000] *1) | BLOB
Exzentrizität | n |  | Numerische Exzentrizität (Wertebereich 0,0 ... 1,0), signed integer [1/1000] *1) | BLOB
Bauch / Rücken, Fläche | n |  | Bauch- / Rücken- Lage, Basis: Fläche, Unterscheidung der Lage durch Vorzeichen, signed integer [1/1000] *1) | BLOB
String | n | Maximale Länge 127 !! | Inhalt des gelesenen Codes. Abhängig vom Code kann die Stringlänge variieren. Wird eine feste Stringlänge gewünscht, so müssen die minimale Stringlänge (Detektorspezifische Nutzdaten) und die maximale Stringlänge (Detektoreinstellungen) auf den gleichen Wert (z.B. 127) gesetzt werden. | Datacode Barcode OCR
Stringlänge | n |  | Länge des gelesenen Codes in Bytes | Datacode Barcode OCR
Truncated | 1 | F = Code komplett, P = Code abgeschnitten | Code abgeschnitten | Datacode Barcode OCR
Ergebnis Vergleich | 1 |  | Ergebnis des Stringvergleichs | Datacode Barcode OCR
Qualitätsparameter | n |  | Ausgabe der Qualitätsparameter gemäß Auswahl | Datacode Barcode
Kontrast | n |  | Kontrast des Codes (0 - 100 %) | Barcode
Korrektur | n |  | Anzahl der durch die Fehlerkorrekturen korrigierte Module | Barcode
Modul Höhe | n |  | Höhe der Module in Pixeln | Datacode
Modul Breite | n |  | Breite der Module in Pixeln | Datacode
Sicherheit | 5 ... n |  | Ausgabe der Sicherheitswerte der einzelnen Zeichen | OCR
Ergebnis | n |  | Grad der Übereinstimmung des gelesenen Strings mit dem Referenzstring von 0 bis 100 % | OCR
Min. Qualität | 1 |  | Minimale geforderte Qualität wurde erreicht | OCR

<CHKSUM>
Name | Byte Anzahl | Inhalt ASCII / Beispiel | Bedeutung / Kommentare
Prüfsumme | 1 |  | XOR-Prüfsumme über alle Bytes im Telegramm

<TRAILER>
Name | Byte Anzahl | Inhalt ASCII / Beispiel | Bedeutung / Kommentare
Nachspann | 1 - max. 8 | User defined, bis max. 8 Charakter | Ende String (Trailer)

*1)Alle detektorspezifischen Daten mit Nachkommastellen werden als ganze Zahlen (mit 1000 multipliziert) übertragen und müssen nach Datenempfang deshalb durch 1000 geteilt werden.


Serielle Kommunikation BINÄR

Übersicht Telegramme:

Bild holen (BINÄR)

Kalibrierung: Punkt hinzufügen (BINÄR) - Abgekündigt

Kalibrierung: Weltpunkt hinzufügen (BINÄR)

Kalibrierung: Punkteliste initialisieren (BINÄR)

Kalibrierung: Kalibrierung kopieren (BINÄR)

Kalibrierung: Parameter lesen (BINÄR)

Kalibrierung: Parameter setzen (BINÄR)

Kalibrierung: Kalibrierplatte (BINÄR)

Kalibrierung: Punkteliste (BINÄR)

Kalibrierung: Referenzmarke setzen (BINÄR)

Kalibrierung: Punkteliste validieren (BINÄR)

Datenausgabe in BINÄR

Detektor einlernen (BINÄR)

Detektorliste lesen (BINÄR)

Erweiterter Trigger (BINÄR)

Verstärkungswert lesen (BINÄR)

Verstärkungswert setzen (BINÄR)

Jobliste lesen (BINÄR)

Jobwechsel (BINÄR)

Jobwechsel Permanent (BINÄR)

Parameter lesen (BINÄR)

Parameter setzen (BINÄR)

ROI lesen (BINÄR)

ROI setzen (BINÄR)

Verschlusszeitwert lesen (BINÄR)

Verschlusszeitwert setzen (BINÄR)

Statistik zurücksetzen (BINÄR)

Trigger (BINÄR)

Trigger-Verzögerung lesen (BINÄR)

Trigger-Verszögerung setzen (BINÄR)


Statistik zurücksetzen (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Statistik zurücksetzen (Binär) Request String an Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x05 | Telegrammlänge
5 | Unsigned Char | 0x04 | Reset Statistics
Statistik zurücksetzen (Binär) Response String vom Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x07 | Telegrammlänge
5 | Unsigned Char | 0x04 | Reset Statistics
6 - 7 | Unsigned Short | 0xXX | Fehlercodes
Weitere Informationen:
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Low
Unterstützte Schnittstellen: |  |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen


Trigger (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Trigger (Binär) Request String an Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x05 | Telegrammlänge
5 | Unsigned Char | 0x01 | Trigger, (einfacher Trigger ohne Index, via Port 2006)
Trigger (Binär) Response String vom Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x07 | Telegrammlänge
5 | Unsigned Char | 0x01 | Trigger, (Response auf Kommnado Trigger ohne Index, via Port 2006. Falls definiert: Ergebnisdaten ohne Index via Port 2005)
6 - 7 | Unsigned Short | 0xXX | Fehlercodes
Weitere Informationen:
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Ja
Akzeptiert wenn Ready Low: |  |  | Nein
Status des Signals Ready während Bearbeitung: |  |  | Low
Unterstützte Schnittstellen: |  |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen


Erweiterter Trigger (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Erweiterter Trigger (Binär) Request String an Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0xXX | Telegrammlänge
5 | Unsigned Char | 0x13 | Extended Trigger, Trigger mit Index, zur ZuordnungTrigger zu entsprechenden Ergebnisdaten, via Port 2006)
6 | Unsigned Char | 0xXX | Länge nachfolgender Daten (n)
7 ... n | Unsigned Char | 0xXX | Daten
Erweiterter Trigger (Binär) Response String vom Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0xXX | Telegrammlänge
5 | Unsigned Char | 0x13 | Extended Trigger, (Response auf Trigger mit Index und Ergebnisdaten, via Port 2006, von Zuordnung von Trigger zum Ergebnis, Ergebnisdaten außerdem ohne Index via Port 2005)
6 - 7 | Unsigned Short | 0xXX | Fehlercodes
8 | Unsigned Char | 0xXX | Länge nachfolgender Daten (n)
9 ... n | Unsigned Char | 0xXX | Daten aus dem Sendebefehl
n+1 | Unsigned Char | 0xXX | Betriebsmodus 0 = Config Mode 1 = Run Mode
n + 2 ... n + 5 | Unsigned Int | 0xXX | Länge der Ergebnisdaten
n + 6 ... m | Unsigned Char | 0xXX | Ergebnis Daten
Weitere Informationen:
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Ja
Akzeptiert wenn Ready Low: |  |  | Nein
Status des Signals Ready während Bearbeitung: |  |  | Low
Unterstützte Schnittstellen: |  |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen


Jobwechsel (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Jobwechsel (Binär) Request String an Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x06 | Telegrammlänge
5 | Unsigned Char | 0x02 | Change Job
6 | Unsigned Char | 0xXX | Job Nr. XX = 1 - n
Jobwechsel (Binär) Response String vom Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x09 | Telegrammlänge
5 | Unsigned Char | 0x02 | Change Job
6 - 7 | Unsigned Short | 0xXX | Fehlercodes
8 | Unsigned Char | 0xXX | Trigger Mode 0 = Getriggert 1 = Freilauf
9 | Unsigned Char | 0xXX | Job Nr. XX = 1 - n
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Low
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Hinweis:

Tritt ein Fehler beim Jobwechsel auf, besteht die Möglichkeit in Job 1 zu wechseln.


Jobwechsel Permanent (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Jobwechsel Permanent (Binär) Request String an Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x06 | Telegrammlänge
5 | Unsigned Char | 0x22 | Change Job Permanent
6 | Unsigned Char | 0xXX | Job Nr. XX = 1-n
Jobwechsel Permanent (Binär) Response String vom Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x09 | Telegrammlänge
5 | Unsigned Char | 0x22 | Change Job Permanent
6 - 7 | Unsigned Short | 0xXX | Fehlercodes
8 | Unsigned Char | 0xXX | Trigger Mode 0 = Getriggert 1 = Freilauf
9 | Unsigned Char | 0xXX | Job Nr. XX = 1 - n
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Low
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Hinweis:

Tritt ein Fehler beim Jobwechsel auf, besteht die Möglichkeit in Job 1 zu wechseln.


Verschlusszeitwert setzen (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Verschlusszeit setzen (Binär) Request String an Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x09 | Telegrammlänge
5 | Unsigned Char | 0x0E 0x0F | Verschlusszeit setzen temporär Verschlusszeit setzen permanent Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
6 - 9 | Unsigned Int | 0xXX | Verschlusszeitwert
Verschlusszeit setzen (Binär) Response String vom Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x07 | Telegrammlänge
5 | Unsigned Char | 0x0E 0x0F | Verschlusszeit setzen temporär Verschlusszeit setzen permanent Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
6 - 7 | Unsigned Short | 0xXX | Fehlercodes
Weitere Informationen:
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Low
Unterstützte Schnittstellen: |  |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen


Verschlusszeitwert lesen (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Verschlusszeitwert lesen (Binär) Request String an Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x05 | Telegrammlänge
5 | Unsigned Char | 0x17 | Get Shutter Speed
Verschlusszeitwert lesen (Binär) Response String vom Sensor
1 - 4 | Unsigned Int | 0x0B | Telegrammlänge
5 | Unsigned Char | 0x17 | Get Shutter Speed
6 - 7 | Unsigned Short | 0xXX | Fehlercodes
8 - 11 | Unsigned Int | 0xXX | Verschlusszeitwert
Weitere Informationen:
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode:: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Keine Veränderung
Unterstützte Schnittstellen: |  |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen


Verstärkungswert setzen (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Verstärkung setzen (Binär) Request String an Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x0A | Telegrammlänge
5 | Unsigned Char | 0x1B | Set Gain
6 | Unsigned Char | 0xXX | 0: Temporär 1: Permanent Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
7 - 10 | Unsigned Int | 0xXX | Verstärkungswert
Verstärkung setzen (Binär) Response String vom Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x0B | Telegrammlänge
5 | Unsigned Char | 0x1B | Set Gain
6 - 7 | Unsigned Short | 0xXX | Fehlercodes
8 - 11 | Unsigned Int | 0xXX | Aktueller Verstärkungswert (Verstärkungswert *1000)
Weitere Informationen:
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Keine Veränderung
Unterstützte Schnittstellen: |  |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen


Verstärkungswert lesen (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Verstärkungswert lesen (Binär) Request String an Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x05 | Telegrammlänge
5 | Unsigned Char | 0x1C | Get Gain
Verstärkungswert lesen (Binär) Response String vom Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x0B | Telegrammlänge
5 | Unsigned Char | 0x1C | Get Gain
6 | Unsigned Short | 0xXX | Fehlercodes
7 |  | 0xXX
8 - 11 | Unsigned Int | 0xXX | Aktueller Verstärukungswert
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Keine Veränderung
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen


Parameter setzen (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Parameter setzen (Binär) Request String an Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0xXX | Telegrammlänge = 9 Bytes + Länge Referenzstring (n)
5 | Unsigned Char | 0x05 0x06 | Parameter permanent setzen Parameter temporär setzen Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
6 | Unsigned Char | 0xXX | Detektor Nr., XX = 1- n
7 | Unsigned Char | 0xXX | Kommando Referenzstring / Wert setzen *1), siehe unten!
8 - 9 | Unsigned Short | 0xXX | Länge neuer Referenzstring / Wert (n)
10 ... n | Unsigned Char | 0xXX | Referenzstring / Wert
Parameter setzen (Binär) Response String vom Sensor (kann bis zu 4-5 Sekunden verzögert ankommen)
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x08 | Telegrammlänge
5 | Unsigned Char | 0x05 0x06 | Parameter permanent gesetzt Parameter temporär gesetzt Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
6 - 7 | Unsigned Short | 0xXX | Fehlercodes
8 | Unsigned Char | 0xXX | Parameter Typ String
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Low
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen

*1) Byte Nr. 7: Kommando Referenzstring / Wert setzen

Detektor | Funktion | Command | Länge der nachfolgenden Daten
Lagenachführung Mustervergleich | Threshold Min Threshold Max ResultOffsetPos_X ResultOffsetPos_Y ResultOffsetAngle | 1 2 31 32 33 | 4 4 5 5 5
Lagenachführung Konturvergleich | Threshold Min Threshold Max ResultOffsetPos_X ResultOffsetPos_Y ResultOffsetAngle | 1 2 31 32 33 | 4 4 5 5 5
Lagenachführung Kantenantastung | Transition probe 1 Transition probe 2 Transition probe 3 Score min probe 1 Score min probe 2 Score min probe 3 | 101 102 103 104 105 106 | 4 4 4 4 4 4
Mustervergleich | Threshold Min Threshold Max ResultOffsetPos_X ResultOffsetPos_Y ResultOffsetAngle | 1 2 31 32 33 | 4 4 5 5 5
Kontur | Threshold Min Threshold Max ResultOffsetPos_X ResultOffsetPos_Y ResultOffsetAngle | 1 2 31 32 33 | 4 4 5 5 5
Graustufe | Threshold Min Threshold Max GreyMin GreyMax GreyInvert | 1 2 101 102 103 | 4 4 4 4 1
Kontrast | Threshold Min Threshold Max | 1 2 | 4 4
Barcode | Reference String | 101 | n
Datacode | Reference String | 101 | n
OCR | Reference String | 101 | n
Farbwert | ColorMinChannel1 ColorMaxChannel1 ColorInvertChannel1 ColorMinChannel2 ColorMaxChannel2 ColorInvertChannel2 ColorMinChannel3 ColorMaxChannel3 ColorInvertChannel3 | 101 102 103 104 105 106 107 108 109 | 4 4 4 4 4 4 4 4 4
Farbfläche | ColorMinChannel1 ColorMaxChannel1 ColorInvertChannel1 ColorMinChannel2 ColorMaxChannel2 ColorInvertChannel2 ColorMinChannel3 ColorMaxChannel3 ColorInvertChannel3 | 101 102 103 104 105 106 107 108 109 | 4 4 4 4 4 4 4 4 4
BLOB | GreyAbsoluteMin GreyAbsoluteMax GreyAbsoluteInvert | 101 102 103 | 4 4 1


Parameter lesen (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Parameter lesen (Binär) Request String an Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x07 | Telegrammlänge
5 | Unsigned Char | 0x0A | Get Parameter
6 | Unsigned Char | 0xXX | Detektor Nr., XX = 1- n
7 | Unsigned Char | 0xXX | Referenzstring / Wert lesen *1), siehe unten!
Parameter lesen (Binär) Response String vom Sensor (kann bis zu 4-5 Sekunden verzögert ankommen)
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0xXX | Telegrammlänge = 10 Bytes + Länge Referenzstring (n)
5 | Unsigned Char | 0x0A | Get Parameter
6 - 7 | Unsigned Short | 0xXX | Fehlercodes
8 | Unsigned Char | 0xXX | Parameter Typ String
9 - 10 | Unsigned Short | 0xXX | Länge gelesener Wert (n)
11 ... n + n | Unsigned Char | 0xXX | Referenzstring / Wert
Weitere Informationen:
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Keine Veränderung
Unterstützte Schnittstellen: |  |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen

*1) Byte Nr. 7: Kommando Referenzstring / Wert lesen

Detektor | Funktion | Command | Länge der nachfolgenden Daten
Lagenachführung Mustervergleich | Threshold Min Threshold Max ResultOffsetPos_X ResultOffsetPos_Y ResultOffsetAngle | 1 2 31 32 33 | 4 4 5 5 5
Lagenachführung Konturvergleich | Threshold Min Threshold Max ResultOffsetPos_X ResultOffsetPos_Y ResultOffsetAngle | 1 2 31 32 33 | 4 4 5 5 5
Lagenachführung Kantenantastung | Transition probe 1 Transition probe 2 Transition probe 3 Score min probe 1 Score min probe 2 Score min probe 3 | 101 102 103 104 105 106 | 4 4 4 4 4 4
Mustervergleich | Threshold Min Threshold Max ResultOffsetPos_X ResultOffsetPos_Y ResultOffsetAngle | 1 2 31 32 33 | 4 4 5 5 5
Kontur | Threshold Min Threshold Max ResultOffsetPos_X ResultOffsetPos_Y ResultOffsetAngle | 1 2 31 32 33 | 4 4 5 5 5
Graustufe | Threshold Min Threshold Max GreyMin GreyMax GreyInvert | 1 2 101 102 103 | 4 4 4 4 1
Kontrast | Threshold Min Threshold Max | 1 2 | 4 4
Barcode | Reference String | 101 | n
Datacode | Reference String | 101 | n
OCR | Reference String | 101 | n
Farbwert | ColorMinChannel1 ColorMaxChannel1 ColorInvertChannel1 ColorMinChannel2 ColorMaxChannel2 ColorInvertChannel2 ColorMinChannel3 ColorMaxChannel3 ColorInvertChannel3 | 101 102 103 104 105 106 107 108 109 | 4 4 4 4 4 4 4 4 4
Farbfläche | ColorMinChannel1 ColorMaxChannel1 ColorInvertChannel1 ColorMinChannel2 ColorMaxChannel2 ColorInvertChannel2 ColorMinChannel3 ColorMaxChannel3 ColorInvertChannel3 | 101 102 103 104 105 106 107 108 109 | 4 4 4 4 4 4 4 4 4
BLOB | GreyAbsoluteMin GreyAbsoluteMax GreyAbsoluteInvert | 101 102 103 | 4 4 1


ROI setzen (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

ROI setzen (Binär) Request String an Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x18 0x20 | Telegrammlänge 0x18 bei Kreis 0x20 bei Rechteck/Freiform/Elipse
5 | Unsigned Char | 0x10 0x11 | ROI setzen temporär ROI setzen permanent Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
6 - 9 | Unsigned Int | 0xXX | ROI Info Länge in Bytes ab Byte 6 bis Ende
10 | Unsigned Char | 0xXX | Detektor Nr.
11 | Unsigned Char | 0x00 | ROI Index 00 = gelber Rahmen 01= Teach 02 = Positionskontrolle
12 | Unsigned Char | 0xXX | ROI Form 01=Kreis 02=Rechteck 03=Ellipse 04=Freiform
13 - 16 | Unsigned Int | 0xXX | ROI Parameter: Mittelpunkt X (Wert in Pixeln * 1000)
17 - 20 | Unsigned Int | 0xXX | ROI Parameter: Mittelpunkt Y (Wert in Pixeln * 1000)
21 - 24 | Unsigned Int | 0xXX | ROI Parameter: halbe Breite bzw. Radius X (Wert in Pixeln * 1000)
 | Nur bei Ellipse/Rechteck:
25 - 28 | Unsigned Int | 0xXX | ROI Parameter: Halbe Breite bzw. Radius Y (Wert in Pixeln * 1000)
29 - 32 | Unsigned Int | 0xXX | ROI Parameter: Winkel in ° (Wert in ° * 1000)
ROI setzen (Binär) Response String vom Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 | Unsigned Int | 0x07 | Telegrammlänge
5 | Unsigned Char | 0x10 0x11 | ROI setzen temporär ROI setzen permanent Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
6 - 7 | Unsigned Short | 0xXX | Fehlercodes
Weitere Informationen:
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Low
Unterstützte Schnittstellen: |  |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Parameter: |  |  | Die Parameter werden im Koordinatensystem der Lagenachführung und nicht im Koordinatensystem des Bildes angegeben.


ROI lesen (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

ROI lesen (Binär) Request String an Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x07 | Telegrammlänge
5 | Unsigned Char | 0x12 | Get ROI
6 | Unsigned Char | 0xXX | Detektor Nr.
7 | Unsigned Char | 0xXX | ROI Index 00 = gelber Rahmen 01= Teach 02= Positionskontrolle
ROI lesen (Binär) Response String vom Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0xXX | Telegrammlänge
5 | Unsigned Char | 0x12 | Get ROI
6 - 7 | Unsigned Short | 0xXX | Fehlercodes
8 - 11 | Unsigned Int | 0xXX | ROI Info Länge in Bytes ab Byte 8
12 | Unsigned Char | 0xXX | Detektor Nr.
13 | Unsigned Char | 0x00 | ROI Index 00 = gelber Rahmen 01= Teach 02= Positionskontrolle
14 | Unsigned Char | 0xXX | ROI Form 01=Kreis 02=Rechteck 03=Ellipse 04=Freiform
15 - 18 | Unsigned Int | 0xXX | ROI Parameter: Mittelpunkt X (Wert in Pixeln * 1000)
19 - 22 | Unsigned Int | 0xXX | ROI Parameter: Mittelpunkt Y (Wert in Pixeln * 1000)
23 - 26 | Unsigned Int | 0xXX | ROI Parameter: halbe Breite bzw. Radius X (Wert in Pixeln * 1000)
 | Nur bei Ellipse/Rechteck:
27 - 30 | Unsigned Int | 0xXX | ROI Parameter: Halbe Breite bzw. Radius Y (Wert in Pixeln * 1000)
31 - 34 | Unsigned Int | 0xXX | ROI Parameter: Winkel in ° (Wert in ° * 1000)
Weitere Informationen:
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Low
Unterstützte Schnittstellen: |  |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen


Jobliste lesen (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Jobliste lesen (Binär) Request String an Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x05 | Telegrammlänge
5 | Unsigned Char | 0x14 | Get Job List

Jobliste lesen (Binär) Response String vom Sensor

Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0xXX | Telegrammlänge
5 | Unsigned Char | 0x14 | Get Job List
6 Unsigned Short 0xXX

Fehlercodes

8 | Unsigned Char | 0x01 | Konstant
9 | Unsigned Char | 0xXX | Anzahl der Jobs
10 | Unsigned Char | 0xXX | Aktive Job Nummer

Hinweis:

Folgende Bytefolge wird für jeden Job von 1 bis "Anzahl der Jobs" wiederholt. Die Byte Nummern verschieben sich entsprechend.
11 | Unsigned Char | 0xXX | Anzahl der folgenden Bytes. Damit kann ein eindeutiger Name für den Job n angegeben werden.
11 ... n | Char | 0xXX | Ab dieser Position folgt, in der angegebenen Länge, der Name für Job n.
n + 1 ... n + 3 Unsigned Char 0xXX

Anzahl der folgenden Bytes. Damit kann eine Beschreibung für den Job n angegeben werden.
n + 4 ... m | Char | 0xXX | Ab dieser Position folgt, in der angegebenen Länge, die Beschreibung für Job 1.
m + 1 ... m+ 3 | Unsigned Char | 0xXX | Anzahl der folgenden Bytes. Damit kann ein eindeutiger Name für den Autor des Job n angegeben werden.
m + 4 ... k | Char | 0xXX | Ab dieser Position folgt, in der angegebenen Länge, der Name für den Autor aus Job n.
k + 1 ... k + 8 | Unsigned Int | 0xXX | Datum der Erstellung von Job n
k + 9 ... k + 16 | Unsigned Int | 0xXX | Datum der letzten Änderung von Job n
Weitere Informationen:
Akzeptiert im Run Mode: Ja
Akzeptiert im Konfigurations Mode: Nein
Akzeptiert wenn Ready Low: Ja
Status des Signals Ready während Bearbeitung: Keine Veränderung
Unterstützte Schnittstellen: Telegramme: Verfügbarkeit und unterstütze Schnittstellen


Detektorliste lesen (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Detektorliste lesen (Binär) Request String an Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x05 | Telegrammlänge
5 | Unsigned Char | 0x15 | Get Detector List

Detektorliste lesen (Binär) Response String vom Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0xXX | Telegrammlänge
5 | Unsigned Char | 0x18 | Get Detector List
6 Unsigned Short 0xXX

Fehlercodes

8 | Unsigned Char | 0xXX | Jobnummer des aktuellen Jobs
9 | Unsigned Char | 0xXX | Anzahl der Detektoren im aktuellen Job

Hinweis:

Folgende Bytefolge wird für jeden Detektor im Job wiederholt. Die Byte Nummern verschieben sich entsprechend.
10 | Unsigned Char | 0xXX | Anzahl der folgenden Bytes. Damit kann ein eindeutiger Name für den Detektor n angegeben werden.
11 ... n | Unsigned Char | 0xXX | Ab dieser Position folgt, in der angegebenen Länge, der Name für Detektor n.
n + 1 ... n + 3 Unsigned Char 0xXX

001 - Mustervergleich

004 - Kontur

005 - Graustufe

006 - Kontrast

007 - Helligkeit

011 - OCR

013 - Datacode

014 - Barcode

018 - Farbwert

019 - Farbfläche

020 - Farbliste

021 - Messschieber

022 - BLOB
Weitere Informationen:
Akzeptiert im Run Mode: Ja
Akzeptiert im Konfigurations Mode: Nein
Akzeptiert wenn Ready Low: Ja
Status des Signals Ready während Bearbeitung: Keine Veränderung
Unterstützte Schnittstellen: Telegramme: Verfügbarkeit und unterstütze Schnittstellen


Detektor einlernen (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Detektor einlernen (Binär) Request String an Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x08 | Telegrammlänge
5 | Unsigned Char | 0x18 | Teach Detector
6 | Unsigned Char | 0xXX | 0 = Lagenachführung >= 1 Detektoren
7 | Unsigned Char | 0xXX | 0: Temporär 1: Permanent
8 | Unsigned Char | 0xXX | 0 = Kein Trigger 1 = Trigger
Detektor einlernen (Binär) Response String vom Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x00 | Telegrammlänge
5 | Unsigned Char | 0x18 | Teach Detector
6 - 7 | Unsigned Short | 0xXX | Fehlercodes
Weitere Informationen:
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Keine Veränderung
Unterstützte Schnittstellen: |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen


Trigger Verzögerung setzen (BINÄR)

Trigger-Verszögerung setzen (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Trigger-Verszögerung setzen V1 (Binär) Request String an Sensor
Byte Nr.. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0xB | Telegrammlänge
5 | Unsigned Char | 0x27 | Trigger-Verszögerung setzen
6 | Unsigned Char | 0xXX | Version des Request
7 | Unsigned Char | 0xXX | 0: Temporär 1: Permanent
8 - 11 | Unsigned Int | 0xXX | Trigger Verzögerung in msec (max. 3000 msec) in Encoder-Schritten (max. 65535 Schritte)
Trigger-Verszögerung setzen V1 (Binär) Response String vom Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x07 | Telegrammlänge
5 | Unsigned Char | 0x1A | Trigger-Verszögerung setzen
6 - 7 | Unsigned Short | 0xXX | Fehlercodes
Weitere Informationen:
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Low
Unterstützte Schnittstellen: |  |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen


Trigger-Verzögerung lesen (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Trigger-Verszögerung lesen V1 (Binär) Request String an Sensor
Byte Nr.. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x6 | Telegrammlänge
5 | Unsigned Char | 0x28 | Trigger-Verszögerung lesen
6 | Unsigned Char | 0xXX | Version des Request
Trigger-Verszögerung lesen V1 (Binär) Response String vom Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0xB | Telegrammlänge
5 | Unsigned Char | 0x28 | Trigger-Verszögerung lesen
6 - 7 | Unsigned Short | 0xXX | Fehlercodes
8 - 11 | Unsigned Int | 0xXX | Trigger Verzögerung in msec (max. 3000 msec) in Encoder-Schritten (max. 65535 Schritte)
Weitere Informationen:
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Keine Veränderung
Unterstützte Schnittstellen: |  |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen


Kalibrierung: Punkteliste initialisieren (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Punkteliste initialisieren (Binär) Request String an Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x05 | Telegrammlänge
5 | Unsigned Char | 0x1F | Calibration: Clear Data
Punkteliste initialisieren (Binär) Response String vom Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x07 | Telegrammlänge
5 | Unsigned Char | 0x1F | Calibration: Clear Data
6 - 7 | Unsigned Short | 0xXX | Fehlercodes
Weitere Informationen:
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Keine Veränderung
Unterstützte Schnittstellen: |  |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen


Kalibrierung: Weltpunkt hinzufügen (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Kalibrierung: Weltpunkt hinzufügen V1 (Binär) Request String an Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x0F | Telegrammlänge
5 | Unsigned Char | 0x26 | Calibration: Add World Point (CAW)
6 | Unsigned Char | 0xXX | Version des Request
7 | Unsigned Char | 0xXX | 1: Nur Referenzmarken Kalibrierplatte (Roboter) 4: Weltpunkt und Bildpunkt Punktpaarliste (Roboter)
9 - 10 | Unsigned Short | 0xXX | Konstant (5 Byte)
11 - 14 | Unsigned Int | 0xXX | Welt- X (in mm *1000)
15 - 18 | Unsigned Int | 0xXX | Welt- Y (in mm *1000)
19 - 22 | Unsigned Char | 0xXX | Konstant (8 Byte)
Kalibrierung: Weltpunkt hinzufügen V1 (Binär) Response String vom Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x11 | Telegrammlänge
5 | Unsigned Char | 0x26 | Calibration: Add World Point (CAW)
6 - 7 | Unsigned Short | 0xXX | Fehlercodes
8 - 9 | Unsigned Short | 0xXX | Aktuelle Anzahl Punkte
10 -13 | Unsigned Int | 0xXX | Bildpunkt X
14 - 17 | Unsigned Int | 0xXX | Bildpunkt Y
Weitere Informationen:
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Keine Veränderung
Unterstützte Schnittstellen: |  |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen


Kalibrierung: Punkt hinzufügen (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Kalibrierung: Punkt hinzufügen (Binär) Request String an Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x0F | Telegrammlänge
5 | Unsigned Char | 0x1D | Calibration: Add Point
6 - 7 | Unsigned Short | 0x00 | Konstant
8 - 11 | Unsigned Int | 0xXX | Welt- X (in mm *1000)
12 - 15 | Unsigned Int | 0xXX | Welt- Y (in mm *1000)
Kalibrierung: Punkt hinzufügen (Binär) Response String vom Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 | Unsigned Int | 0x11 | Telegrammlänge
5 | Unsigned Char | 0x1D | Calibration: Add Point
6 - 7 | Unsigned Short | 0x00 | Fehlercodes
8 - 9 | Unsigned Short | 0x00 | Aktuelle Anzahl der Punkte in der Liste
10 - 13 | Unsigned Int | 0xXX | Bild- X (in px * 1000)
14 - 17 | Unsigned Int | 0xXX | Bild- Y (in px * 1000)
Weitere Informationen:
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Keine Veränderung
Unterstützte Schnittstellen: |  |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen
Nötige Einstellungen im aufrufenden Job |  |  | Unter "Ausgabe/Datenausgabe/Detektorspezifische Nutzdaten" müssen als erster und zweiter Ausgabewert der X- und der Y- Wert der Findeposition eingestellt sein.


Kalibrierung: Punkteliste (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Kalibrierung Punkteliste (Binär) Request String an Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x06 | Telegrammlänge
5 | Unsigned Char | 0x1E | Calibration: Calibrate by Point List
6 | Unsigned Char | 0xXX | 0: Temporär 1: Permanent
Kalibrierung Punkteliste (Binär) Response String vom Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x19 | Telegrammlänge
5 | Unsigned Char | 0x1E | Calibration: Calibrate by Point List
6 - 7 | Unsigned Short | 0xXX | Fehlercodes
8 - 9 | Unsigned Short | 0xXX | Aktuell höchster Punktpaarindex
10 - 13 | Unsigned Int | 0xXX | Abweichung Kalibrierung, RMSE (Root Mean Square Error)
14 - 17 | Unsigned Int | 0xXX | Abweichung Kalibrierung, Mittelwert
18 - 21 | Unsigned Int | 0xXX | Abweichung Kalibrierung, Max
22 - 25 | Unsigned Int | 0xXX | Abweichung Kalibrierung, Min
Weitere Informationen:
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Keine Veränderung
Unterstützte Schnittstellen: |  |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen


Kalibrierung: Punkteliste validieren (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Kalibrierung: Punkteliste validieren (Binär) Request String an Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x05 | Telegrammlänge
5 | Unsigned Char | 0x20 | Calibration: Validate by Point List
Kalibrierung: Punkteliste validieren (Binär) Response String vom Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x19 | Telegrammlänge
5 | Unsigned Char | 0x20 | Calibration: Validate by Point List
6 | Unsigned Short | 0xXX | Fehlercodes
8 - 9 | Unsigned Short | 0xXX | Aktuell höchster Punktpaarindex
10 - 13 | Unsigned Int | 0xXX | Abweichung Kalibrierung, RMSE (Root Mean Square Error)
14 - 17 | Unsigned Int | 0xXX | Abweichung Kalibrierung, Mittelwert
18 - 21 | Unsigned Int | 0xXX | Abweichung Kalibrierung, Max
22 - 25 | Unsigned Int | 0xXX | Abweichung Kalibrierung, Min
Weitere Informationen:
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Keine Veränderung
Unterstützte Schnittstellen: |  |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen


Kalibrierung: Kalibrierplatte (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Kalibrierung: Kalibrierplatte (Binär) Request String an Sensor

Byte Nr.

Daten Typ

Inhalt

Bedeutung

1 - 4

Unsigned Int

0x09

Telegrammlänge

5

Unsigned Char

0x24

Calibration: Calibrate by Plate
6 | Unsigned Char | 0x01 | Version des Request
7 Unsigned Char 0xXX

0: Temporär

1: Permanent
8 Unsigned Char 0xXX

0 - Es werden keine Referenzmarken verwendet. Ursprung des Mess-Koordinatensystems ist identisch mit dem Ursprung des Kalibrier-Koordinatensystems.

1 - Es werden keine Referenzmarken verwendet. Mess-Koordinatensystem ist identisch mit Geräte-Koordinatensystem.

2 - Verwendet Weltsystem, Referenzmarke Job

3 - Verwendet Weltsystem, Referenzmarke Befehl CAW
9 Unsigned Char 0xXX

0: Kalibrierung interne und externe Sensor Parameter

1: Validierung der Kalibrierung

2: Kalibrierung interne Sensor Parameter

5: Kalibrierung Transformation Mess-Koordinatensystem

Kalibrierung: Kalibrierplatte (Binär) Response String vom Sensor

Byte Nr.

Daten Typ

Inhalt

Bedeutung

1 - 4

Unsigned Int

0x3D

Telegrammlänge

5

Unsigned Char

0x24

Calibration: Calibrate by Plate
6 - 7 | Unsigned Short | 0xXX | Fehlercodes
8 - 9 | Unsigned Short | 0xXX | Anzahl der aktuell detektierten Kalibrierpunkte
10 - 13 | Unsigned Int | 0xXX | Abweichung Kalibrierung, RMSE (Root Mean Square Error)
14 - 17 | Unsigned Int | 0xXX | Abweichung Kalibrierung, Mittelwert
18 - 21 | Unsigned Int | 0xXX | Abweichung Kalibrierung, Max
22 - 25 | Unsigned Int | 0xXX | Abweichung Kalibrierung, Min
26 - 29 | Unsigned Int | 0xXX | Delta X (in Kundeneinheit * 1000)
30 - 33 | Unsigned Int | 0xXX | Delta Y (in Kundeneinheit * 1000)
34 - 37 | Unsigned Int | 0 | Reserviert
38 - 41 | Unsigned Int | 0 | Reserviert
42 - 45 | Unsigned Int | 0 | Reserviert
46 - 49 | Unsigned Int | 0xXX | Delta Gamma (In Grad * 1000)
50 - 53 | Unsigned Int | 0xXX | Abweichung Referenzmarken, Mittelwert
54 - 57 | Unsigned Int | 0xXX | Abweichung Referenzmarken, Max
58 - 61 | Unsigned Int | 0xXX | Abweichung Referenzmarken, Min
Weitere Informationen:
Akzeptiert im Run Mode: Ja
Akzeptiert im Konfigurations Mode: Nein
Akzeptiert wenn Ready Low: Ja
Status des Signals Ready während Bearbeitung: Keine Veränderung
Unterstützte Schnittstellen: Telegramme: Verfügbarkeit und unterstütze Schnittstellen


Kalibrierung: Referenzmarke setzen (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Kalibrierung Referenzmarke setzen V1 (Binär) Request String an Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x08 | Telegrammlänge
5 | Unsigned Char | 0x1E | Calibration: Set Fiducial
6 | Unsigned Char | 0xXX | Version des Request
7 | Unsigned Char | 0xXX | 0: Temporär 1: Permanent
Kalibrierung Referenzmarke setzen V1 (Binär) Response String vom Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x37 | Telegrammlänge
5 | Unsigned Char | 0x2B | Calibration: Set Fiducial
6 - 7 | Unsigned Short | 0xXX | Fehlercodes
8 - 11 | Unsigned Int | 0xXX | X-Wert
12- 15 | Unsigned Int | 0xXX | Y-Wert
16 - 19 | Unsigned Int | 0xXX | Z-Wert
18 - 21 | Unsigned Int | 0xXX | Rot X-Wert
22 - 25 | Unsigned Int | 0xXX | Rot Y-Wert
26 - 29 | Unsigned Int | 0xXX | Rot Z-Wert
30 - 33 | Unsigned Int | 0xXX | Abweichung Referenzmarken, Mittelwert
34 - 37 | Unsigned Int | 0xXX | Abweichung Referenzmarken, Max
38 - 41 | Unsigned Int | 0xXX | Abweichung Referenzmarken, Min
Weitere Informationen:
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Keine Veränderung
Unterstützte Schnittstellen: |  |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen


Kalibrierung: Kalibrierung kopieren (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Kalibrierung: Kalibrierung kopieren (Binär) Request String an Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x09 | Telegrammlänge
5 | Unsigned Char | 0x25 | Calibration: Copy Calibration
6 | Unsigned Char | 0x01 | Version des Request
7 | Unsigned Char | 0x01 | Konstant
8 | Unsigned Char | 0xXX | Destination 0 : In alle Jobs kopieren >0 : In angegebenen Job kopieren
9 | Unsigned Char | 0xXX | 0: Immer kopieren, wenn die Kalibrierung aktiv ist. 1: Nur kopieren, wenn die Kalibriermethode identisch ist.
Kalibrierung: Kalibrierung kopieren (Binär) Response String vom Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x08 | Telegrammlänge
5 | Unsigned Char | 0x25 | Calibration: Copy Calibration
6 - 7 | Unsigned Short | 0xXX | Fehlercodes
8 | Unsigned Char | 0xXX | 00: Erfolgreich > 0: Jobnummer bei dem der Fehler auftritt.
Weitere Informationen:
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Keine Veränderung
Unterstützte Schnittstellen: |  |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen


Kalibrierung: Parameter setzen (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Kalibrierung Parameter setzen V1 (Binär) Request String an Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x07 | Telegrammlänge
5 | Unsigned Char | 0x29 | Calibration: Set Parameter
6 | Unsigned Char | 0x01 | Version des Request
7 | Unsigned Char | 0xXX | 0: Temporär 1: Permanent
8 | Unsigned Char | 0xXX | Parameter Nummer
9 - 12 | Unsigned Int | 0xXX | Länge der nachfolgenden Daten
13 ... n | Unsigned Char | 0xXX | Parameter Wert
Kalibrierung Parameter setzen V1 (Binär) Response String vom Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0xXX | Telegrammlänge
5 | Unsigned Char | 0x29 | Calibration: Set Parameter
6 - 7 | Unsigned Short | 0xXX | Fehlercodes
Weitere Informationen:
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Keine Veränderung
Unterstützte Schnittstellen: |  |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Parameter Bezeichnung | Parameter Nummer | Parameter Wert | Länge | Format | Status
Einheit (Kundeneinheit) | 004 | 0: mm 1: cm 2: m 3. inch 4: au | 1 Byte | Zeichen | no change
Z-Versatz | 021 | (in Kundeneinheit * 1000) | 8 Byte | Signed Integer | no change
Brennweite | 022 | (in mm *1000) | 8 Byte | Signed Integer | invalid
Referenzmarke 1 | 024 | jeweils: 0: X-Wert (in Kundeneinheit * 1000) 1: Y-Wert (in Kundeneinheit * 1000) 2: Z-Wert (in Kundeneinheit * 1000) | Je Wert 8 Byte | Signed Integer | no change
Referenzmarke 2 | 025
Referenzmarke 3 | 026
Referenzmarke 4 | 027


Kalibrierung: Parameter lesen (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Kalibrierung Parameter lesen V1 (Binär) Request String an Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x07 | Telegrammlänge
5 | Unsigned Char | 0x2A | Calibration: Get Parameter
6 | Unsigned Char | 0x01 | Version des Request
7 | Unsigned Char | 0xXX | Parameter Nummer
Kalibrierung Parameter lesen V1 (Binär) Response String vom Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0xXX | Telegrammlänge
5 | Unsigned Char | 0x2A | Calibration: Get Parameter
6 - 7 | Unsigned Short | 0xXX | Fehlercodes
8 | Unsigned Char | 0xXX | Parameter Nummer
9 - 12 | Unsigned Int | 0xXX | Länge der nachfolgenden Daten
13 ... n | Unsigned Char | 0xXX | Parameter Wert
Weitere Informationen:
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Keine Veränderung
Unterstützte Schnittstellen: |  |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Parameter Bezeichnung | Parameter Nummer | Parameter Wert | Länge | Format
Status Kalibrierung | 001 | 0: Ungültig 1: Gültig | 1 Byte | Signed Integer
Kalibriermethode | 002 | 0: Keine 1: Skalierung (Messen) 2: Punktpaarliste (Roboter) 3: Kalibrierplatte (Messen) 4: Kalibrierplatte (Roboter) | 1 Byte | Zeichen
Einheit (Kundeneinheit) | 004 | 0: mm 1: cm 2: m 3. inch 4: au | 1 Byte | Zeichen
Interne Sensor Parameter | 005 | 0: Brennweite (in mm *1000) 1: Kappawert (*1000) 2: Pixelabstand X (in µm * 1000) 3: Pixelabstand Y (in µm * 1000) 4: Koordinatenursprung X (in Pixel * 1000) 5: Koordinatenursprung Y (in Pixel * 1000) 6: Bildgröße X (Pixel) 7: Bildgröße Y (Pixel) | Je Wert 8 Byte | Signed Integer
Externe Parameter | 011 | 0: Verschiebung X Achse (in Kundeneinheit * 1000) 1: Verschiebung Y Achse (in Kundeneinheit * 1000) 2: Verschiebung Z Achse (in Kundeneinheit * 1000) 3: Rotation X (in Grad * 1000) 4: Rotation Y (in Grad * 1000) 5: Rotation Z (in Grad * 1000) | Je Wert 8 Byte | Signed Integer
Transformation Kalibrier-Koordinatensystem | 012 | 0: Verschiebung X Achse (in Kundeneinheit * 1000) 1: Verschiebung Y Achse (in Kundeneinheit * 1000) 2: Verschiebung Z Achse (in Kundeneinheit * 1000) 3: Rotation X (in Grad * 1000) 4: Rotation Y (in Grad * 1000) 5: Rotation Z (in Grad * 1000) | Je Wert 8 Byte | Signed Integer
Transformation Mess-Koordinatensystem | 014 | 0: Verschiebung X Achse (in Kundeneinheit * 1000) 1: Verschiebung Y Achse (in Kundeneinheit * 1000) 2: Verschiebung Z Achse (in Kundeneinheit * 1000) 3: Rotation X (in Grad * 1000) 4: Rotation Y (in Grad * 1000) 5: Rotation Z (in Grad * 1000) | Je Wert 8 Byte | Signed Integer
Z-Versatz | 021 | (in Kundeneinheit * 1000) | 8 Byte | Signed Integer
Brennweite | 022 | (in mm *1000) | 8 Byte | Signed Integer
Referenzmarke 1 | 024 | jeweils: 0: X-Wert (Kundeneinheit * 1000) 1: Y-Wert (Kundeneinheit * 1000) 2: Konstant 0 | Je Wert 8 Byte | Signed Integer
Referenzmarke 2 | 025
Referenzmarke 3 | 026
Referenzmarke 4 | 027


Bild holen (BINÄR)

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Bild holen (Binär) Request String an Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0x06 | Telegrammlänge
5 | Unsigned Char | 0x03 | Bild holen
6 | Unsigned Char | 0xXX | 0 – Letztes Bild 1 – Letztes Fehlerbild 2 – Letztes Gutbild
Bild holen (Binär) Response String vom Sensor
Byte Nr. | Daten Typ | Inhalt | Bedeutung
1 - 4 | Unsigned Int | 0xXX | Telegrammlänge z.B. 00 04 B0 0D (Dez. 307213)
5 | Unsigned Char | 0x03 | Antwort ID Bild holen
6 - 7 | Unsigned Short | 0xXX | Fehlercodes
8 | Unsigned Char | 0xXX | Typ Bild 0 - Graustufen 3 – Bayer Pattern_BG Bei Konvertierung des Farbbildes von Bayer in RGB, muss der entsprechende Bildtyp berücksichtigt werden.
9 | Unsigned Char | 0xXX | Ergebnis Bild 00 - Schlecht-Bild 01 - Gut-Bild
10 - 11 | Unsigned Short | 0xXX | Anzahl der Zeilen z.B. 01 E0 = 480
12 - 13 | Unsigned Short | 0xXX | Anzahl der Spalten z.B. 02 80 = 640
14 ... n | Unsigned Char | 0xXX | Binäre Bilddaten (Zeilen * Spalten)
Weitere Informationen:
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Low
Unterstützte Schnittstellen: |  |  | Telegramme: Verfügbarkeit und unterstütze Schnittstellen


Datenausgabe BINÄR

Datenausgabe in BINÄR

Telegramme: Verfügbarkeit und unterstütze Schnittstellen

Übersicht Telegramme:

Reiter Datenausgabe

Ausgabedaten (BINÄR), dynamisch zusammengesetzt nach Benutzereinstellungen in der Software. Für detaillierte Angaben zum Datenformat siehe auch: Reiter Datenausgabe

Prinzipieller Stringaufbau:

<START> (((<OPTIONAL FIELDS> <PAYLOAD>))) <CHKSUM> <TRAILER>

Ausgabedaten (BINÄR):

<OPTIONAL FIELDS>

Name

Byte Anzahl

Inhalt Binär / Beispiel

Bedeutung / Kommentare

Vorspann

1 - max. 8

User definiert, bis max. 8 Byte

Start String (Header)

Gewählte Felder

2 (Word)

1 Bit pro Feld

Über dieses Feld werden „bit-codiert" (in 2Bytes!) alle aktivierten Checkboxen ausgegeben.

  • Die Reihenfolge der Ausgabe ist von links nach rechts und von oben nach unten.
  • D.h. pro aktiver Checkbox wird ein Bit (gesetzt/nicht gesetzt) beginnend beim LSB = Low significant Bit ausgegeben.
  • Die Checkbox „Gewählte Felder" selbst wird nicht mit ausgegeben!

Telegrammlänge

2 (Word)

z.B. 0x00, 0x02 = Länge = 2 Byte

Telegrammlänge in Byte

Statusbyte

2 (Word)

z.B. 0x00, 0x06 (triggered)

z.B. 0x00, 0x05 (free-run)

Byte1: 00000xxx

Bit0 = <Free-run>

Bit1 = <triggered>

Bit2 = <Op.mode> (1=run / 0=config)

Byte2 (reserved), always 0x00

Detektorergebnis

4 .. .n

z.B.

0x05 (Bit1+3=5)

0x00 (zwei Bytes Anz. Detektoren)

0x01

0x01 (Detektor-Ergebnis D1)

Byte 1

Bit1 (LSB) = Globales Jobergebnis (1 = Pass, 0 = Fail)

Bit2 = Boolsches Ergebnis nur Lagenachführung, Lagenachführung inaktiv =True

Bit3 = UND Verknüpfung aller Detektoren des aktiven Jobs

Byte 2 und 3 zwei Bytes für die Anzahl der Detektoren im Job (ohne Alignment-Detektor).

Byte 4 - n

1 Byte je Block von 8 genutzten Detektoren

z.B: Bit1(LSB) = Detektor 1, Bit2 = Det. 2, ....

Digitalausgänge

n

Byte 1 und 2: die Anzahl aktiver Ausgänge

Byte 3 ... n: Ausgänge, bit-codiert

Ergebnisse aller digitalen Ausgänge (bit-codiert)

Logische Ausgänge

n

Byte 1 und Byte 2: die Anzahl aktiver logischer Ausgänge

Byte 3 ... n alle aktiven logischen Ausgänge, bit-codiert

Beispiel: 18 logische Ausgänge werden konfiguriert, aber nur Ausgang 1,2 und 9 werden tatsächlich mit Funktionen belegt (sind also aktiv):

000,003, 003, 001

2 Bytes Anzahl aktiver Ausgänge dann alle Ergebnisse bit-codiert...

Im Beispiel werden wegen Ausgang 9, zwei Bytes benötigt....

1.ErgebnisByte = 00000011 (log. Ausgang 1 + 2)

2.ErgebnisByte = 00000001 (log. Ausgang 9)

Ausführungszeit

4 (Integer)

Aktuelle (Job-) Zykluszeit in [ms]

Aktiver Job

1

Aktive Job Nr. (1 ... 255)

<PAYLOAD>
Detektorspezifisch |  |  |  | Für Detektortyp
Name | Byte Anzahl | Inhalt Binär / Beispiel | Bedeutung / Kommentare
Detektor Ergebnis | 1 | 1 = Pass 0 = Fail | Boolsches Detektorergebnis | Alle Detektoren
Score 1 .. n | 4 |  | Score (0 ... 100 %) | Alle Detektoren
Ausführungszeit | 4 |  | Ausführungszeit des einzelnen Detektors in [msec]. | Alle Detektoren
Abstand | 4 |  | Berechneter Abstand, signed integer [1/1000] *1) | Messschieber
Position X 1 ... n | 4 |  | Gefundene Position X (x-coordinate). [1/1000] *1) | Mustervergleich Kontur Kantenantastung Messschieber Datacode Barcode OCR
Position Y 1 ... n | 4 |  | Gefundene Position Y (y-coordinate). [1/1000] *1) | Mustervergleich Kontur Kantenantastung Messschieber Datacode Barcode OCR
Delta Pos X | 4 |  | Delta Position X zwischen eingelerntem und gefundenem Objekt [1/1000] *1) | Mustervergleich Kontur Kantenantastung
Delta Pos Y | 4 |  | Delta Position X zwischen eingelerntem und gefundenem Objekt [1/1000] *1) | Mustervergleich Kontur Kantenantastung
Winkel | 4 |  | Orientierung des gefundenen Objekts (0° ... 360°) [1/1000]*1) | Mustervergleich Kontur Kantenantastung Datacode Barcode OCR
Delta Winkel | 4 |  | Winkel zwischen eingelerntem und gefundenem Objekt (0°..360°) [1/1000] *1) | Mustervergleich Kontrast Kantenantastung
Skalierung | 4 |  | Nur bei Kontur (0,5 ... 2) [1/1000] *1) | Kontur
R(ot) G(rün) B(lau) | 4 |  | Wert für Farbparameter, signed integer [1/1000] *1) | Farbwert Farbliste
H(ue) S(aturation) V(alue) | 4 |  | Wert für Farbparameter, signed integer [1/1000] *1) | Farbwert Farbliste
L(uminanz) A B | 4 |  | Wert für Farbparameter, signed integer [1/1000] *1) | Farbwert Farbliste
Ergebnis Index | 4 |  | Listenindex, signed integer, [1/1000] *1) | Farbliste
Farbabstand | 4 |  | Abstand der aktuellen Farbe gegenüber der eingelernten Farbe, signed integer [1/1000] *1) | Farbliste
Fläche | 4 |  | BLOB | BLOB
Fläche (inkl. Löcher) | 4 |  | Fläche des BLOBs, mit Löchern, in Pixel, signed integer, [1/1000] *1) | BLOB
Konturlänge | 4 |  | Anzahl der Pixel der äußeren Kontur, signed integer, [1/1000] *1) | BLOB
Kompaktheit | 4 |  | Kompaktheit des BLOBs, (Kreis = 1, andere >1). Je stärker die Form des BLOB vom Kreis abweicht, desto größer wird der Wert der Kompaktheit., Signed integer [1/1000] *1) | BLOB
Schwerpunkt X | 4 |  | X- Koordinate des BLOB- Schwerpunkts, signed integer [1/1000] *1) | BLOB
Schwerpunkt Y | 4 |  | Y- Koordinate des BLOB- Schwerpunkts, signed integer [1/1000] *1) | BLOB
Zentrum X | 4 |  | X- Koordinate des gefitteten Rechtecks / Ellipse, signed integer [1/1000] *1) | BLOB
Zentrum Y | 4 |  | Y- Koordinate des gefitteten Rechtecks / Ellipse, signed integer [1/1000] *1) | BLOB
Breite | 4 |  | Breite des geometrischen Elements (Rechtecks / Ellipse). Breite >= 0, Breite >= Höhe, negative Werte = Fehler), signed integer [1/1000] *1) | BLOB
Höhe | 4 |  | Höhe des geometrischen Elemets (Rechtecks / Ellipse). Höhe >= 0, Höhe <= Breite, negative Werte = Fehler), signed integer [1/1000] *1) | BLOB
Winkel (360) | 4 |  | Winkellage des Objekts in Grad (Wertebereich +180° ... -180°, 0° = Ost, Drehrichtung = Gegenuhrzeigersinn), signed integer [1/1000] *1) | BLOB
Exzentrizität | 4 |  | Numerische Exzentrizität (Wertebereich 0,0 ... 1,0), signed integer [1/1000] *1) | BLOB
Bauch / Rücken, Fläche | 4 |  | Bauch- / Rücken-Lage, Basis: Fläche, Unterscheidung der Lage durch Vorzeichen, signed integer [1/1000] *1) | BLOB
String | 1...n | Maximale Länge 127 !! | Inhalt des gelesenen Codes. Abhängig vom Code kann die Stringlänge variieren. Wird eine feste Stringlänge gewünscht, so müssen die minimale Stringlänge (Detektorspezifische Nutzdaten) und die maximale Stringlänge (Detektoreinstellungen) auf den gleichen Wert (z.B. 127) gesetzt werden. | Datacode Barcode OCR
Stringlänge | 4 |  | Länge des gelesenen Codes in Bytes | Datacode Barcode OCR
Truncated | 1 | 0x00 = Code komplett, 0x01 = Code abgeschnitten | Code abgeschnitten | Datacode Barcode OCR
Ergebnis Vergleich | 1 |  | Ergebnis des Stringvergleichs | Datacode Barcode OCR
Qualitätsparameter | 1 ... n |  | Ausgabe der Qualitätsparameter gemäß Auswahl | Datacode Barcode
Kontrast | 4 |  | Kontrast des Codes (0-100%) | Barcode
Korrektur | 4 |  | Anzahl der durch die Fehlerkorrekturen korrigierte Module | Barcode
Modul Höhe | 4 |  | Höhe der Module in Pixeln | Datacode
Modul Breite | 4 |  | Breite der Module in Pixeln | Datacode
Sicherheit | 5 ... n |  | Ausgabe der Sicherheitswerte der einzelnen Zeichen | OCR
Ergebnis | 4 |  | Grad der Übereinstimmung des gelesenen Strings mit dem Referenzstring von 0 bis 100 % | OCR
Min. Qualität | 1 |  | Minimale geforderte Qualität wurde erreicht | OCR

<CHKSUM>
Name | Byte Anzahl | Bedeutung / Kommentare
Prüfsumme | 1 | XOR-Prüfsumme über alle Bytes im Telegramm

<TRAILER>
Name | Byte Anzahl | Inhalt Binär / Beispiel | Bedeutung / Kommentare
Nachspann | 1 - max. 8 | Benutzerdefiniert, max. 8 Zeichen | Ende String (Trailer)

*1) Alle detektorspezifischen Daten mit Nachkommastellen werden als ganze Zahlen (mit 1000 multipliziert) übertragen und müssen nach Datenempfang deshalb durch 1000 geteilt werden. Die Werte werden im Format „Big Endian" übertragen.

Beispiel: „Score" Werte (Binär Protokoll)

In Vision Sensor Configuration Studio/Vision Sensor Visualisation Studio wird „Score" = 35 angezeigt.
Via Ethernet werden dann z.B. folgende vier Bytes empfangen: 000,000,139,115
Formel zu Umrechnung: (HiWordByte*256 + HiLowByte) *65536 + HiByte*256 + LoByte = Value

Da Big Endian (vom Sensor) geschickt wird, gilt:
000 = HiWordByte, 000 = HiLowByte, 139 = HiByte, 115 = LoByte
(0*256 + 0) * 65536 + (139 * 256) + 115 = 35699 / 1000 = 35,699 (= echter Score Wert).
Winkelangaben bzw. andere negative Zahlen werden im Zweierkomplement dargestellt.


Übersicht Telegramme

SBS Allgemein

  • Statistik zurücksetzen (Statistik zurücksetzen (ASCII) / Statistik zurücksetzen (BINÄR))
    Mit dem Telegramm "Statistik zurücksetzen" kann der interne Statistikzähler des SBS Vision-Sensors zurückgesetzt werden.

SBS Kontrolle

  • Trigger (Trigger (ASCII) / Trigger (BINÄR))
    Mit dem Telegramm "Trigger" kann eine Bildaufnahme gestartet werden. Einige Befehle benötigen eine zusätzliche Bildaufnahme. Ergebnisdaten der Auswertung werden über den "Out"-Port ausgegeben.
  • Erweiterter Trigger (Erweiterter Trigger (ASCII)/ Erweiterter Trigger (BINÄR))
    Das Telegramm "Erweiterter Trigger" ist eine Erweiterung zum "Trigger"-Telegramm. Neben den Ergebnisdaten besteht zusätzlich die Möglichkeit eine ID zu vergeben oder Informationen über den Betriebszustand (Run / Config) zu erhalten. Im Unterschied zum "Trigger"-Telegramm werden beim "Erweiterten Trigger" die Ergebnisdaten auch über den "In"-Port gesendet.
  • Jobwechsel (Jobwechsel (ASCII) / Jobwechsel (BINÄR))
    Mit dem Telegramm "Jobwechsel" wird ein Jobwechsel auf dem SBS Vision-Sensor angestoßen.
  • Jobwechsel Permanent (Jobwechsel Permanent (ASCII)/ Jobwechsel Permanent (BINÄR))
    Mit dem Telegramm "Jobwechsel Permanent" wird ein permanenter Jobwechsel auf dem SBS Vision-Sensor angestoßen. Der Job wird nach dem Neustart wieder ausgeführt.

SBS Jobeinstellungen

  • Verschlusszeit setzen (Verschlusszeit setzen (ASCII) / Verschlusszeitwert setzen (BINÄR))
    Mit dem Telegramm "Verschlusszeit setzen" kann die Verschlusszeit des Jobs geändert werden. Dieses Telegramm kann z.B. für einen Helligkeitsausgleich verwendet werden.
  • Verschlusszeitwert lesen (Verschlusszeitwert auslesen (ASCII) / Verschlusszeitwert lesen (BINÄR))
    Mit dem Telegramm "Verschlusszeit lesen" kann die gesetzte Verschlusszeit des Jobs gelesen werden.
  • Verstärkung setzen (Verstärkung setzen (ASCII) / Verstärkungswert setzen (BINÄR))
    Mit dem Telegramm "Verstärkung setzen" kann die Verstärkung des Jobs geändert werden. Dieses Telegramm kann z.B. für einen Helligkeitsausgleich verwendet werden.
  • Verstärkungswert lesen (Verstärkungswert auslesen (ASCII)/ Verstärkungswert lesen (BINÄR))
    Mit dem Telegramm "Verstärkung lesen" kann die gesetzte Verstärkung des Jobs gelesen werden.
  • Parameter setzen (Parameter setzen (ASCII) / Parameter setzen (BINÄR))
    Mit dem Telegramm "Parameter setzen" können Parameter von Detektoren angepasst werden, z.B. Referenz Strings, Schwellwerte für Detektoren.
  • Parameter lesen (Parameterwerte lesen (ASCII) / Parameter lesen (BINÄR))
    Mit dem Telegramm "Parameter lesen" können die gesetzten Parameter der Detektoren gelesen werden.
  • ROI setzen (ROI setzen (ASCII) / ROI setzen (BINÄR))
    Mit dem Telegramm "ROI setzen" kann die Position des angegeben Detektors geändert werden.
  • ROI lesen (ROI lesen (ASCII)/ ROI lesen (BINÄR))
    Mit dem Telegramm "ROI lesen" kann die Position des angegeben Detektors ausgelesen werden.
  • Jobliste lesen (Jobliste lesen (ASCII)/ Jobliste lesen (BINÄR))
    Mit dem Telegramm "Jobliste lesen" kann eine Auflistung aller verfügbaren Jobs auf dem SBS Vision-Sensor ausgegeben werden.
  • Detektorliste lesen (Detektorliste lesen (ASCII) / Detektorliste lesen (BINÄR))
    Mit dem Telegramm "Detektorliste lesen" kann eine Auflistung aller Detektoren im aktuellen Job ausgegeben werden.
  • Detektor einlernen (Detektor einlernen (ASCII) / Detektor einlernen (BINÄR))
    Mit dem Telegramm "Detektor einlernen" wird der angegeben Detektor neu eingelernt (nur für Mustervergleich und Konturvergleich verfügbar).
  • Trigger-Verzögerung setzen (Trigger-Verzögerung setzen (ASCII) / Trigger-Verszögerung setzen (BINÄR))
    Mit dem Telegramm "Trigger-Verzögerung setzen" kann eine Verzögerung für das Auslösen eines Triggers eingestellt werden (in Zeit (ms) oder Encoder-Schritten).
  • Trigger-Verzögerung lesen (Trigger-Verzögerung lesen (ASCII) / Trigger-Verzögerung lesen (BINÄR))
    Mit dem Telegramm "Trigger-Verzögerung lesen" kann die eingestellte Verzögerung für das Auslösen eines Triggers ausgelesen werden.

SBS Kalibrierung

  • Kalibrierung: Punkteliste initialisieren (Kalibrierung: Punkteliste initialisieren (ASCII) / Kalibrierung: Punkteliste initialisieren (BINÄR))
    Mit dem Telegramm "Kalibrierung Punkteliste initialisieren" wird die Punkteliste initialisiert.
  • Kalibrierung: Weltpunkt hinzufügen (Kalibrierung: Weltpunkt hinzufügen (ASCII)/ Kalibrierung: Weltpunkt hinzufügen (BINÄR))
    Mit dem Telegramm "Kalibrierung Weltpunkt hinzufügen" wird ein Weltpunkt (Referenzmarke oder Punktpaar) der Punkteliste hinzugefügt. Das Telegramm kann für Kalibriermethode Punktpaarliste (Roboter) und Kalibrierplatte (Roboter) verwendet werden.
  • Kalibrierung: Punkt hinzufügen (Kalibrierung: Punkt hinzufügen (ASCII) - Abgekündigt/ Kalibrierung: Punkt hinzufügen (BINÄR)) - Abgekündigt
    Mit dem Telegramm "Kalibrierung: Punkt hinzufügen" wird ein Punkt der Punkteliste hinzugefügt.
  • Kalibrierung: Punkteliste (Kalibrierung: Punkteliste (ASCII)/ Kalibrierung: Punkteliste (BINÄR))
    Mit dem Telegramm "Kalibrierung: Punkteliste" wird die Kalibrierung anhand der Punkteliste im aktuellen Job durchgeführt.
  • Kalibrierung: Punkteliste validieren (Kalibrierung: Punkteliste validieren (ASCII) / Kalibrierung: Punkteliste validieren (BINÄR))
    Mit dem Telegramm "Kalibrierung: Punkteliste validieren" wird die Kalibrierung anhand der Punkteliste validiert.
  • Kalibrierung: Kalibrierplatte (Kalibrierung: Kalibrierplatte (ASCII)/ Kalibrierung: Kalibrierplatte (BINÄR))
    Mit dem Telegramm "Kalibrierung: Kalibrierplatte" wird die Kalibrierung anhand der Kalibrierplatte durchgeführt.
  • Kalibrierung: Kalibrierung kopieren (Kalibrierung: Kalibrierung kopieren (ASCII) / Kalibrierung: Kalibrierung kopieren (BINÄR))
    Mit dem Telegramm "Kalibrierung: Kalibrierung kopieren" wird die Kalibrierung aus dem aktuellen Job auf das angegeben Ziel kopiert.
  • Kalibrierung: Parameter setzen (Kalibrierung: Parameter setzen (ASCII) / Kalibrierung: Parameter setzen (BINÄR))
    Mit dem Telegramm "Kalibrierung: Parameter setzen" können Parameterwerte für die Kalibrierung gesetzt werden.
  • Kalibrierung: Parameter lesen (Kalibrierung: Parameter lesen (ASCII) / Kalibrierung: Parameter lesen (BINÄR))
    Mit dem Telegramm "Kalibrierung: Parameter lesen" können eingestellte Parameterwerte der Kalibrierung gelesen werden.

SBS Visualisierung

  • Bild holen (Bild holen (ASCII)/ Bild holen (BINÄR))
    Mit dem Telegramm "Bild holen" kann das Bild vom SBS Vision-Sensor erhalten werden.

SBS Service

  • Update Visualisierungsdaten (Visualisierungsdaten aktualisieren (ASCII))
    Mit dem Telegramm "Update Visualisierung-Daten" werden Visualisierungsdaten, wie z.B. Bild, Detektor Informationen und Ergebnisse aktualisiert.
  • Sensoridentität lesen (Sensoridentität lesen (ASCII))
    Mit dem Telegramm "Sensoridentität lesen" kann der aktuelle Firmwarestande sowie der Hardwaretyp abgefragt werden.
  • Firmware aktualisieren (Firmware aktualisieren (ASCII))
    Mit dem Telegramm "Firmware aktualisieren" wird ein Firmwareupdate gestartet. Die Firmware-Datei muss zuvor auf den SBS Vision-Sensor geladen werden.
  • Jobsatz einspielen (Jobsatz einlesen (ASCII))
    Mit dem Telegramm "Jobsatz einspielen" kann der Jobsatz des SBS Vision-Sensors getauscht werden. Die Jobsatz-Datei muss zuvor auf den SBS geladen werden.
  • Jobsatz sichern (Jobsatz sichern (ASCII))
    Mit dem Telegramm "Jobsatz sichern" kann der Jobsatz des SBS Vision-Sensors gelesen werden.

Datenausgabe

(Datenausgabe in ASCII / Datenausgabe in BINÄR )

In diesem Abschnitt findet man Informationen über die Datenausgabe. Insbesondere, welches Format die einzelnen Ergebnisse erhalten.


Netzwerkanschluss Kurzanleitung

Durch die nachfolgenden Anweisungen wird die Netzwerkkonfiguration des PC und des SBS Vision-Sensors geändert. Werden dabei falsche Einstellungen verwendet, können unter Umständen die Netzwerkverbindungen auf dem PC verloren gehen. Zur Sicherheit sind die alten Einstellungen zu notieren und bei Bedarf wieder zu verwenden. Ein Neustart des Systems wird nach der Durchführung dieser Anweisungen möglicherweise notwendig. Um herauszufinden welche IP-Adresse in Ihrem Netzwerk oder lokal auf Ihrem PC zulässig ist, und um Ihre Einstellungen an Ihrem PC durchzuführen, bitte zuvor den zuständigen Systembetreuer oder Administrator kontaktieren. Die verwendeten Abbildungen, Dialoge und Menüs stammen aus dem Betriebssystem Microsoft Windows XP™. In anderen Betriebssystemen sind die Abbildungen ähnlich.

S. Kapitel: .Grundeinstellungen des PC und des SBS Vision-Sensors


Direkter Anschluss - Einstellen der IP-Adresse des PC

Für die Verbindung des SBS Vision-Sensors mit einem Computer via Ethernet müssen die IP-Adress-Einstellungen der beiden Geräte korrespondieren. Die Werkseinstellung der IP-Adresse des SBS Vision-Sensors ist 192.168.100.100 mit der Subnetzmaske 24 / 255.255.255.0. Beim direkten Anschluss muss der PC auf eine, zum Sensor passende, fixe IP-Adresse eingestellt werden, wie folgt:

  1. Mit Klick auf Start / Systemsteuerung / Netzwerkverbindung / LAN-Verbindung / Eigenschaften, öffnet sich das Dialogfenster "Eigenschaften von LAN-Verbindung".
  2. In der Liste „Diese Verbindung verwendet folgende Elemente“ den Eintrag „Internetprotokoll (TCP / IP)“ auswählen und auf „Eigenschaften“ klicken.
  3. Im folgenden Fenster sind die gewünschte IP-Adresse und die Sub-Netzmaske des PC einzustellen.
  4. Mit OK die Eingaben bestätigen.

Beispiel:

Der SBS Vision-Sensor wird mit der IP-Adresse 192.168.100.100 und der Subnetzmaske 255.255.255.0 ausgeliefert. Die IP-Adresse kann im Beispielfall von 192.168.100.1 bis 192.168.100.254 bei eingestellter Subnetzmaske 255.255.255.0 gewählt werden - mit Ausnahme der IP-Adresse des Sensors (192.168.100.100).
Zur Änderung der Sensor IP-Adresse siehe Netzwerk- Einstellungen des Sensors. Netzwerkadressen .0 und .255 nicht als Geräteadressen verwenden, da diese meist für Netzwerkinfrastruktur wie z.B. für Server, Gateways etc. vorbehalten sind.

Abbildung: PC IP Setup


Grundeinstellungen des PC und des SBS Vision-Sensors

Voraussetzung für die Konfiguration des SBS Vision-Sensors mit einem PC: PC mit Netzwerkkarte und eine installierte TCP / IP LAN-Verbindung, auch wenn der PC an keinem Netzwerk angeschlossen ist. Der SBS unterstützt die automatische Erkennung der Ethernetübertragungsrate, jedoch maximal 100 MBit. Das Internetprotokoll IPv4 muss aktiviert sein. Der SBS Vision-Sensor kann grundsätzlich über zwei Möglichkeiten konfiguriert und parametriert werden.

Siehe auch Kap. Netzwerkanschluss

1. Direkter Anschluss - Einstellen der IP-Adresse des PC

2. Netzwerkanschluss - Einstellen der IP-Adresse des SBS Vision-Sensors


Netzwerkanschluss - Einstellen der IP-Adresse des SBS Vision-Sensors

Vor dem Anschluss des Sensors ins Netzwerk mit dem Netzwerkadministrator klären, ob die Adresse des Sensors bereits vergeben ist (default: 192.168.100.100 mit Subnetzmaske 255.255.255.0). Ansonsten kann dies zum Ausfall des Netzwerkes führen. Die eingestellte IP-Adresse ist auf dem beiliegenden Etikett des SBS Vision-Sensors zu notieren. Das Etikett ist nach der Montage auf dem Sensor an gut sichtbarer Stelle aufzukleben.

Netzwerk-Verbindungsgeschwindigkeit:

Insbesondere bei der Nutzung der VGA Auflösung und Vision Sensor Visualisation Studio sollte der Sensor unbedingt und ausschließlich mit 100 Mbit /full-duplex betrieben werden.

Sensor IP noch frei:

Schließen Sie den Sensor an das Netzwerk an und stellen Sie dann die IP-Adresse des Sensors entsprechend den Vorgaben des Administrators wie folgt ein, beginnen Sie mit Punkt 2.

Sensor IP schon vergeben:

  1. Sensor und PC zuerst über den direkten Anschluss verbinden und eine zulässige IP-Adresse im Sensor einstellen.

  2. Danach kann der Anschluss via Netzwerk wie folgt durchgeführt werden. Voraussetzung ist der elektrische Anschluss und die Installation der PC-Software. Für die Einstellung der IP-Adresse am SBS Vision-Sensor sind folgende Schritte in der PC-Software auszuführen:

    1. Vision Sensor Device Manager starten.
    2. Wählen Sie den gewünschten SBS Vision-Sensor aus der Liste der aktiven Sensoren aus.
    3. Mit "Einstellungen" die neue IP-Adresse des Sensors setzen. Diese wurde vom Administrator oder Systembetreuer vergeben. Die IP-Adresse des PC wird in Statuszeile unter den Buttons angezeigt. Hinweis: Einige PC's haben mehr als eine Ethernet-Verbindung, d.h. drahtlose und verdrahtete LAN-Verbindungen.
    4. Sensor markieren und mit Vision Sensor Configuration Studio oder Vision Sensor Visualisation Studio verbinden.

Abbildung: Vision Sensor Device Manager

Die Änderung des Standard Gateway ermöglicht den Betrieb in unterschiedlichen Subnetzwerken. Ändern Sie diese Einstellung nur nach Rücksprache mit dem Administrator. Durch DHCP ist die automatische Einbindung eines neuen Computers oder Sensors in ein bestehendes Netzwerk ohne dessen manuelle Konfiguration möglich. Am Sensor, dem Client, muss im Normalfall lediglich der automatische Bezug der IP-Adresse eingestellt sein. Beim Start des Sensors am Netz kann er die IP-Adresse, die Netzmaske und das Gateway von einem DHCP-Server beziehen. Die Aktivierung des DHCP-Modus erfolgt über den Button „Einstellungen“ durch Betätigung der Checkbox „DHCP“. Da ein und derselbe SBS Vision-Sensor somit zu verschiedenen Zeitpunkten verschiedene IP-Adressen haben kann, muss bei Aktivierung des DHCP ein Sensorname vergeben werden. Sollten mehrere SBS in einem Netzwerk sein, muss jedem ein eindeutiger Name zugewiesen werden.

Abbildung: SBS IP Setup

Wenn ein SBS mit DHCP an einem Netzwerk ohne DHCP-Server eingeschaltet wird, setzt sich der SBS automatisch auf die IP-Adresse 0.0.0.0. Dies kann der Fall sein, z.B. bei Stromausfall / Serverausfall oder Neustart der Anlage nach einem Anlagenstillstand, weil der DHCP Server evtl. langsamer bootet als der SBS. Stellen Sie sicher, dass der SBS erst dann eingeschaltet wird, wenn der DHCP-Server zur Verfügung steht.


SBS Vision-Sensor EtherNet/IP, Einleitung

Dieses Kapitel beschreibt den Betrieb des Vision Sensors mit EtherNet/IP

Zum Datenaustausch zwischen SBS Vision-Sensor und SPS via EtherNet/IP werden dazu im Folgenden neben dem elektrischen Anschluss die erforderlichen Einstellungen im SBS Vision-Sensor und in der SPS (beispielhaft für Rockwell RSLogix) beschrieben.


EtherNet/IP, Anhang

Assembly Request

Kommunikationseinstellungen

Description: | Request posted from PLC to SBS Vision-Sensor
Class: | Class 1
nAssemblyInstance: | 100
nType: | AssemblyConsuming
nLength (bytes): | 344
szAssemblyName: | AssemblyRequest

Assembly Request

Der SBS Vision-Sensor empfängt einen Daten Frame mit 344 bytes.

Um Kommandos abzusetzen den Anweisungen folgen.

Jedes Byte entspricht den Werten, die von der SPS zum Sensor geschickt werden. Die Position definiert das genutzte Byte und die Größe definiert die Länge des Kommandos.

Position | Größe (Bytes) | Member | Daten Typ | Beschreibung
0 | 2 | unKey | U16 | Request Key, z.B. ein Request-Zähler
2 | 2 | unId | U16 | Request ID, z.B. für Requests "Trigger", "Change job"
4 | 2 | unNumChar | U16 | Anzahl gültiger char-Parameter
6 | 2 | unNumInt | U16 | Anzahl gültiger int-Parameter
8 | 256 | pcValueChar[RQST_NUM_CHAR] | I8 | Char-Parameter für Request, Member darf nur einen String halten
264 | 80 | 16 int parameters for request | I16 | Int-Parameter für Rrequest

Request Key:

Der Request Key steht an Position 0 (Byte 0) und ist 2 Bytes lang. Um die Änderung eines Parameters der gesendet wurde zu bestätigen muss dieser um einen beliebigen Wert inkrementiert werden. Dies ist erforderlich, um das Kommando abzusetzen / zu validieren.

Beispiel:

Im SBS Vision-Sensor einen Trigger auslösen. Der Default Code des Request Key ist 0x0 0x0. Nach der Trigger Konfiguration (nachfolgende Beschreibung), Request Key inkrementieren um den Trigger auszulösen. Der Request Key Code ist nun: 0x0 0x2.

Position 0:

Byte 1 | Byte 0
Always 0 | 0000 0010

Kommando Konfiguration:

Der Request Key hat eine Größe von 2 Bytes (Position 0 und 1). Das Kommando beginnt an Position 2 und ist 2 Bytes lang. Über die Request ID sind die Kommandos: Trigger, Change job, Statistics reset, Auto shutter, Teach permanent oder temporary, wählbar.

Position 2:

Byte 3 | Byte 2
Always 0 | 0000 0001

Change job: Zum Senden des Change job Kommandos den Code 0x0 0x2 an Position 2 schreiben. LSB an Position 6 auf "1" setzen (Standard Version: Job 1 oder Job 2, Advanced Version: 255 Jobs). Job Nummer (4 Bytes) an Position / Byte 264 schreiben. Um den Request zu validieren, den Request key inkrementieren. Um danach den Job zu wechseln muss ein Trigger abgesetzt werden (Wichtig: LSB an Positon 6 auf "0" setzen).

Position 2:

Byte 3 | Byte 2
Always 0 | 0000 0010

Position 6:

Byte 7 | Byte 6
Always 0 | 0000 0001

Position 264:

Byte 265 | Byte 264
Always 0 | 0000 0010

Byte 3 | Byte 2
Always 0 | 0000 0100

Auto Shutter: Code: 0x0 0x7 an Position 2 schreiben.

Position 2:

Byte 3 | Byte 2
Always 0 | 0000 0111

Permanenter Teach: Der permanente Teach erlaubt das Einlernen eines neuen Musters / Kontur etc. mit denselben Werkzeugen und denselben Einstellungen. Dieses Einlernen wird permanent gespeichert, d.h. das neue Referenzmuster / Kontur etc. bleibt auch nach einem Reset im Sensor gespeichert. Code: 0x0 0x8 an Position 2 schreiben. Trigger setzen um Kommando auszuführen und Request Key inkrementieren.

Position 2:

Byte 3 | Byte 2
Always 0 | 0000 1000

Temporärer Teach: Der temporäre Teach ermöglicht ein neues Muster / Kontur etc. mit denselben Werkzeugen und derselben Einstellung. Dieses Einlernen erfolgt temporär, d.h das Referenzmuster / die Kontur etc. ist nach einem Reset des Sensors nicht mehr verfügbar. Der Code lautet: 0x0 0x9 an Position 2. Trigger setzen um Kommando auszuführen und Request Key inkrementieren.

Position 2:

Byte 3 | Byte 2
Always on 0 | 0000 1001

Summary of available commands:

Commands | Position | Size | Code
Trigger | 2 | 2 | 0x0 0x1
Change job | 2 | 2 | 0x0 0x2
Job number | 264 | 4 | Job number
Statistics reset | 2 | 2 | 0x0 0x4
Auto shutter | 2 | 2 | 0x0 0x7
Permanent teach | 2 | 2 | 0x0 0x8
Temporary teach | 2 | 2 | 0x0 0x9

Beispiel: Um einen Trigger zu setzen Code 0x0 0x1 an Position 2 schreiben. Request Key an Positon 0 verändern: 0x0 0x2 => 0x0 0x4. Der SBS Vision-Sensor startet eine neue Bildaufnahme.

Wichtig: Vergessen Sie nicht den Request Key zu inkrementieren um das Kommando zu validieren.

Assembly Response

Communication settings

Description: | Response returned from SBS Vision-Sensor to PLC
Class: | Class 1
nAssemblyInstance: | 101
nType: | AssemblyProducing
nLength (bytes): | 444
szAssemblyName: | AssemblyResponse

Assembly Response

Assembly Responses sind Daten, die vom Sensor gesendet werden, nachdem einige Kommandos, die er von der SPS oder einem Programm erhalten hatte, ausgeführt wurden.

SPS- Kommandos siehe EtherNet/IP Request File.

Nach der SPS und Vision Sensor Configuration Studio Konfiguration ist die Größe des Frames des Assembly response 444 Bytes. Jedes Byte entspricht den Werten, die im folgenden beschrieben sind.

Position | Größe (Bytes) | Member | Daten Typ | Beschreibung
0 | 4 | unFault | U32 | member is standard in Rockwell RSLogix
4 | 2 | unKey | U16 | Request key is returned in response
6 | 2 | unId | U16 | Request ID is returned in response. (Trigger, Change job, Statistics reset…)
8 | 2 | unError | U16 | Error code of response
10 4 unNumChar U32

Responses values for requests like job change, teach …

 | Byte 13 | Byte 12 | Byte 11 | Byte 10
Trigger | Always 0 | Always 0 | Always 0 | 0000 0001
Change job | Always 0 | Always 0 | Always 0 | 0000 0010
Permanent teach | Always 0 | Always 0 | Always 0 | 0000 1000
14 | 2 | RESERVED
16 | 16 | pcValueChar[RPNS_NUM_CHAR] | 18 | char parameters for response, member may only hold one string
32 | 16 | pnValueInt[RPNS_NUM_INT] | U32 | int parameters for response
48 | 4 | unImageCount | U32 | Number of images taken by the SBS Vision-Sensor.
52 | 4 | unExecutionTime | U32 | Average execution time of last processed image. (To active this data, select in Vision Sensor Configuration Studio: Execution time)
56 4 pucStatus[RPNS_IMPL_NUM_BYTE_STATUS] U32

Status : SBS Vision-Sensor mode (To active this data, select in Vision Sensor Configuration Studio : Status)

Free run: The sensor takes a new picture when the processing is finished.

Trigger: The sensor wait an external signal to take a new picture.

Example Byte 56, bit "0" and "1":

 | Byte 59 | Byte 58 | Byte 57 | Byte 56
Freerun | Always 0 | Always 0 | 0000 000X | 0000 0X01
Trigger mode | Always 0 | Always 0 | 0000 000X | 0000 0X10

Additional data for 1.7.10.1 version or more

Configuration : The sensor is connected to a PC for configuration

Example Byte 56, bit "2":

 | Byte 59 | Byte 58 | Byte 57 | Byte 56
Configuration | Always 0 | Always 0 | 0000 000X | 0000 00XX
Run | Always 0 | Always 0 | 0000 000X | 0000 01XX

Run : The job is downloaded in the SBS Vision-Sensor memory. The sensor works stand alone.

Byte "57", bit "0" shows the sensor ready status

 | Byte 59 | Byte 58 | Byte 57 | Byte 56
Sensor ready | Always 0 | Always 0 | 0000 0001 | 0000 0XXX
Sensor not ready | Always 0 | Always 0 | 0000 0000 | 0000 0XXX

60

 2 unActiveJob U16 Active job : Value of job number
62 | 2 | RESERVED
64 2 unNumDigital U16

Number of active digital outputs (assigned to one tool) (To active this data, select in Vision Sensor Configuration Studio: Digital outputs)

According to: Byte 1 and 2, of "Digitalausgänge", in "Serielle Kommunikation /Datenausgabe Binär"
66 2 unNumLogic U16

Number of active logical outputs (assigned to one tool) (To active this data, select inVision Sensor Configuration Studio: Logical outputs)

According to: Byte 1 and 2, of "Logische Ausgänge", in "Serielle Kommunikation /Datenausgabe Binär"
68 2 unNumDetector U16

Number of selected tools (It is a default value)

According to: Byte 2 and 3, of "Detektorergebnis", in "Serielle Kommunikation /Datenausgabe Binär"
70 | 2 | unNumBool | U16 | no. of valid boolean parameters
72 | 2 | unNumString | U16 | no. of strings included in pcValueChar
74 | 2 | unNumInt | U16 | Number of received payload (To active this data, select a data in Vision Sensor Configuration Studio: Payload)
76 2 pucDigital[RPNS_IMPL_NUM_BYTE_DIGITAL] U8

Digital outputs results: result according to the order of the outputs. LSB => first output. MSB => Last output.

Example: 4 active outputs (12, 09, 05, 06). Status of outputs :

12 = OK; 09 = NOK; 05 = OK; 06 = OK. The code will be:

 | Byte 79 | Byte 78 | Byte 77 | Byte 76
Result | 0000 0000 | 0000 0000 | 0000 0000 | 0000 1101

(To active this data, select in Vision Sensor Configuration Studio: Digital outputs)

According to: Byte 3 ... n, of "Digitalausgänge", in "Serielle Kommunikation /Datenausgabe Binär"
80 8 pucLogic[RPNS_IMPL_NUM_BYTE_LOGIC] U8

Logical outputs results: result according to the order of the outputs. LSB => first output. MSB => Last output.

Example: 4 active outputs (12, 09, 05, 06). Status of outputs:

12 = OK; 09 = NOK; 05 = OK; 06 = OK. The code will be: 1011

 | Byte 83..87 | Byte 82 | Byte 81 | Byte 80
Result | 0000 0000 | 0000 0000 | 0000 0000 | 0000 1011

(To active this data, select in Vision Sensor Configuration Studio: Logical outputs)

According to: Byte 3 ... n, of "Logische Ausgänge", in "Serielle Kommunikation / Datenausgabe Binär"
88 1 pucDetector[RPNS_IMPL_NUM_BYTE_DETECTOR] U8

Global result (Only available on Vision Sensor Configuration Studio and Vision Sensor Visualisation Studio):

Only coded on the third LSB bits.

Bit0 = Global result status (0 : OK ; 1 : NOK)

Bit1 = Status of the case « Detector result » in Optional field during the data configuration.

Bit2 = Indicate if one of tools is NOK even if result global is OK => 0

Example 1: We select Detector result case; Tool1 OK; Tool2 OK; Global result on tool1 and on tool2 => OK, the bit2 will be on 1.

 | Byte 88
Result | 0000 0111

Example 2: We select Detector result case; Tool1 OK; Tool 2 NOK; Global result on Tool1 => OK, the bit2 will be on 0.

 | Byte 88
Result | 0000 0011

Other bits always on 0.

(To active this data, select in Vision Sensor Configuration Studio: Detector results)

According to: Byte 1, of "Detektorergebnis", in "Serielle Kommunikation / Datenausgabe Binär"
89 3 pucDetector[RPNS_IMPL_NUM_BYTE_DETECTOR] U8

Detector result: Each bit corresponds to a tool.

Only on 1Byte: Bit1 = tool1; bit2 = tool2; bit3 = tool3... until 8 bits.

Other bytes, always on 0.

Future Applications, coded on 3 bytes.

(To active this data, select in Vision Sensor Configuration Studio: Detector results)

According to: Byte 4 ... n, of "Detektorergebnis", in "Serielle Kommunikation / Datenausgabe Binär"
92 | 4 | pucBool[RPNS_IMPL_NUM_BYTE_BOOL] | U8 | boolean results (bitwise) as configured in HMI (listbox)
96 | 16 | punStringLength[RPNS_IMPL_NUM_STRING] | U16 | lengths of strings included in pcValueChar
112 | 2 | pucStringTruncated[RPNS_IMPL_NUM_BYTE_STRING_TRUNCATED] | U8 | indicates for each string whether it has been truncated (bitwise)
114 | 2 | RESERVED
116 | 128 | pcString[RPNS_IMPL_NUM_BYTE_STRING] | I8 | char result as configured in HMI (listbox), member may hold multiple strings
244 | 200 | pnInt[RPNS_IMPL_NUM_INT] | U32 | Results of payload configured on Vision Sensor Configuration Studio in tab « frame ». All data on payload are describe as follow:


Job 1… 31 via binärem Eingangs-Bitmuster

Für die Umschaltung von bis zu 31 Jobs via binärer Eingangskombination an den bis zu 5 Eingängen werden alle benötigten Eingänge unter Vision Sensor Configuration Studio/Ausgabe/Pinbelegung mit der entsprechenden Funktion „Jobwechsel Bit x“ belegt. Die entsprechenden, wie im unterem Bild gezeigten binären Eingangsmuster, schalten dann direkt beim Anlegen auf den entsprechenden Job um. S. auch Kap: Reiter Pinbelegung / Funktionen der Eingänge.

Hinweis:

  • Jobumschaltung startet sofort nachdem die Eingangskombination gewechselt hat.
  • Die Anzeige des aktiven Jobs in der Statuszeile wechselt mit dem ersten folgenden Trigger.
  • Die Zuordnung der I/O´s ist nicht fix. Sie hängt von den Einstellungen unter Vision Sensor Configuration Studio/Ausgabe/Pinbelegung ab.
  • Der Pegelwechsel der zugehörigen Eingänge muss gleichzeitig erfolgen (innerhalb von max. 10 ms müssen alle Pegel stabil anliegen).

Abbildung: Job- Umschaltung binär


Netzwerkanschluss

  • Einbindung des SBS ins Netzwerk / Gateway
  • Netzwerkanschluss, Ablauf / Problembehebung - Direkter Anschluss
  • Netzwerkanschluss, Ablauf / Problembehebung – Anschluss über Netzwerk
  • Verwendete Ethernet - Ports
  • Zugriff auf SBS über Netzwerk
  • Zugriff auf SBS über das Internet / World Wide Web


Einbindung des SBS ins Netzwerk / Gateway

In Vision Sensor Device Manager/Aktive Sensoren werden alle SBS Vision-Sensoren, die sich im gleichen Netzwerksegment wie der PC, auf dem Vision Sensor Device Manager läuft, befinden, als Liste angezeigt. Zur Aktualisierung der Liste den Button „Finden“ drücken, für z.B. Sensoren, die erst nach Aufruf von Vision Sensor Device Manager eingeschaltet wurden.

Für Sensoren die zwar im Netzwerk angeschlossen sind, sich jedoch über ein Gateway in einem anderen Netzwerksegment befinden, bitte unter „Aktiven Sensor hinzufügen“ die entsprechende IP-Adresse des Sensors eingeben und den Button „Hinzufügen“ drücken.

Der entsprechende Sensor erscheint nun ebenfalls in der Liste „Aktive Sensoren“ und kann nun angesprochen und bearbeitet werden.


Netzwerkanschluss, Ablauf / Problembehebung - Direkter Anschluss

Herstellen einer direkten Ethernetverbindung zwischen SBS Vision-Sensor und PC

Abbildung: Direkter Anschluss Sensor / PC, Ablauf und Problembehebung


Netzwerkanschluss, Ablauf / Problembehebung – Anschluss über Netzwerk

Herstellen einer Ethernetverbindung zwischen SBS Vision-Sensor und PC über ein Netzwerk.

Abbildung: Anschluss über ein Netzwerk Sensor / PC, Ablauf und Problembehebung


Verwendete Ethernet - Ports

Wenn der SBS in einem Netzwerk eingebunden werden soll, müssen die folgenden Ports ggf. durch einen Administrator entsprechend freigegeben werden. Dies ist nur dann der Fall, wenn diese Ports im Firmennetzwerk bzw. durch eine auf dem PC installierte Firewall zuvor explizit gesperrt wurden.

Für die Kommunikation zwischen Konfigurations-PC und SBS werden folgende Ports verwendet:

  • Port 80, TCP (SBSxWebViewer)
  • Port 2000, TCP
  • Port 2001, UDP Broadcast (Zum Finden der Sensoren durch Vision Sensor Device Manager)
  • Port 2002, TCP
  • Port 2003, TCP
  • Port 2004, TCP

Für die Kommunikation zwischen Steuerung (SPS oder Steuerungs-PC) und SBS werden folgende Ports verwendet:

  • Port 2005, TCP (Implizite Ergebnisse, d.h. vom Anwender konfigurierte Ergebnisdaten)
  • Port 2006, TCP (Explizite Anfragen, z.B. Trigger oder Jobwechsel)

Wenn die Ports 2005 bzw. 2006 in der Konfigurationssoftware geändert werden, müssen diese auch bei der Firewall durch einen Administrator entsprechend geändert werden.

Wenn die Schnittstelle EtherNet/IP verwendet wird, so müssen auch die folgenden beiden Ports im Netzwerk freigegeben sein.

  • Port 2222, UDP (EtherNet/IP)
  • Port 44818, TCP (EtherNet/IP)


Zugriff auf SBS über Netzwerk

Beispielhafte Werte für IP etc.

Zugriff auf SBS 1 von PC 1 aus, wenn in gleichem Subnetz

  • Über Vision Sensor Device Manager (/Finden)

Zugriff auf SBS 2 von PC1 aus, wenn in anderem Subnetz

nur wenn:

  • Gateway in Sensor 2 korrekt gesetzt (hier auf 192.168.30.1) - und

  • in Vision Sensor Device Manager über IP- hinzufügen die IP des Sensor 2 richtig eingegeben wurde

    ˃ danach erscheint auch SBS 2 in Liste „Aktive Sensoren“ in Vision Sensor Device Manager!

Abbildung: Zugriff auf SBS über Netzwerk, gleiches oder anderes Subnetz


Zugriff auf SBS über das Internet / World Wide Web

Beispielhafte Werte für IP etc.

Zugang von PC 1 (Firmennetz 1), über das Word Wide Web, in Firmennetz 2 zu SBS 1.

  1. Auf PC1 (Firmennetz 1) in Vision Sensor Device Manager die IP- WAN des Router 2 (Firmennetz 2) unter „Aktiven Sensor hinzufügen“ eintragen und hinzufügen (hier im Beispiel: 62.75.148.101)
  2. In Router 2 die Ports die vom Sensor genutzt werden sollen im Router freigeben (S. Kapitel: Verwendete Ethernet - Ports).

Abbildung: Zugriff auf SBS über das Internet / World Wide Web


SBS Vision-Sensor PROFINET, Einleitung

Dieses Kapitel beschreibt den Betrieb des SBS Vision-Sensor mit PROFINET. Dies steht zur Verfügung ab Version 1.12.x.x.


Reiter Greiferfreiraum

Roboter greifen Objekte, z.B. mit einem Backengreifer, an der Außenkontur der Objekte. Berühren oder überlappen sich die Objekte, so ist ein Greifen mit dem Roboter unter Umständen nicht möglich. Mit der SBS Greiferfreiraumprüfung kann geprüft werden, ob die Greifpositionen am Objekt in der erforderlichen Größe auch frei sind. Dabei wird die Position des ersten gefundenen Objekts ausgegeben, bei der auch dessen nachgeführte Detektoren (Greifbereiche) i.O. sind (gemäß den logischen Verknüpfungen im Gesamtergebnis).

Die Greiferfreiraumprüfung ist für die Konturlagenachführung verfügbar.

Ablauf:

  1. Die Konturlagenachführung identifiziert Objekte als Kandidaten, deren Kontur mit der eingelernten Kontur übereinstimmt.
  2. Diese Kandidaten werden sortiert. Die Sortierung erfolgt nach den im Reiter „Greiferfreiraum“ eingestellten Werten für „Sortierkriterium“ und „Reihenfolge“.

  3. In dieser Reihenfolge werden die Kandidaten daraufhin geprüft, ob die von der Lagenachführung nachgeführten Detektoren (z.B. Prüfung auf Freiraum) alle erfüllt sind. Dies geschieht unter Berücksichtigung der logischen Verknüpfungen im Gesamtergebnis. Im Reiter "Ausgangssignale" des Bedienschritts "Ausgabe" können logische Verknüpfungen zur Auswertung der Objekte vorgenommen werden. Hier können z.B. Freiräume für verschiedene Greifpositionen definiert werden. Für das in der nachfolgenden Abbildung dargestellte Objekt wären die Greifpositionen X-X und Y-Y möglich. Von diesen Greifmöglichkeiten können dann nur die tatsächlich für einen Griff notwendigen auf „frei“ geprüft werden.

    Abbildung: Mögliche Greifposition X-X (links) und mögliche Greifposition Y-Y (rechts)

    Hinweis:

    In der Detektorliste kann die Lagenachführung je Detektor aktiviert oder deaktiviert werden (Default: aktiv). Nur hier aktivierte Detektoren sind für die Greiferfreiraumprüfung wirksam.
  4. Die Positionsdaten des ersten Objekts, das all diese Kriterien erfüllt, werden ausgegeben und die Suche an dieser Stelle abgebrochen.

Voraussetzung für das erfolgreiche Finden eines Objekts ist mindestens ein Objekt je Bild/Auswertung, bei dem auch das Gesamtergebnis, d.h. auch nachgeführte Detektoren "i.O." sind!

Abbildung: Lagenachführung Konturvergleich, Reiter Greiferfreiraum

Folgende Parameter können im Reiter "Greiferfreiraum" eingestellt werden:

Parameter

Funktion
Anzahl Kandidaten

Mit dem Parameter "Anzahl Kandidaten" kann die maximale Anzahl der zu erkennenden Objekte bestimmt werden. Liegen mehr Objekte im Bildfeld als im Parameter angegeben, so werden nur so viele Objekte ausgewertet, wie im Parameter angegeben wurden.

Achtung:

Es wird immer nur ein Objekt ausgegeben und zwar das Erste, das entsprechend der folgenden Einstellungen gefunden wird!
Sortierkriterium | Sortierkriterium nach dem Objekte "vorsortiert" werden sollen.
  • Score
 Gesamtergebnis
  • Pos. X
 X-Position
  • Pos. Y
 Y-Position
  • Winkel
 Winkel
  • Skalierung
 Skalierung
Sortierreihenfolge | Sortierreihenfolge für das ausgewählte Sortierkriterium.
  • Aufsteigend
 Die Werte des Sortierkriteriums werden in aufsteigender Reihenfolge sortiert.
  • Absteigend
 Die Werte des Sortierkriteriums werden in absteigender Reihenfolge sortiert.
Nur gültige Kandidaten ausgeben | Ist diese Checkbox aktiviert, werden nur Objekte angezeigt und ausgegeben, deren Score-Wert über der eingestellten Schaltschwelle (Reiter "Parameter") liegt. Er kann z.B. zur Optimierung genutzt werden.


Reiter Kalibrierung

Reiter Loch

Reiter Binarisierung

Abbildung: Detektor Wafer, Reiter Kalibrierung

Einstellungen im Reiter Kalibrierung

Parameter Funktion

Verzeichnungskorrektur

Verzeichnungskorrektur aktivieren.
  • Kappa (x10E-6)

Verzeichnungskoeffizient zur Modellierung der radialen Verzeichnung.
  • Skalierung

Multiplikative Korrektur.

mm Einheiten

mm Einheiten aktivieren.
  • Kalibrierfaktor

Pixel pro mm; Kalibrierungsfaktor zur Umrechnung von Bilddaten in Weltdaten.

  • Übernehmen

Durch Drücken von „Übernehmen" werden die Dimensionen in den anderen Reitern automatisch an den neuen Kalibrierfaktor angepasst.
  • Waferhöhe

Programm passt automatisch den Kalibrierfaktor an Hand der gemessenen Waferhöhe in Pixel an.
  • Kalibriere auf Waferhöhe

Kalibrierfaktor wird aus dem Wert „Waferhöhe" berechnet.
  • Versatz Ausbruchstiefe
 Korrekturfaktor für den Messwert der Ausbruchstiefe. Der Faktor wird zum tatsächlich ermittelten Messwert addiert.


Reiter Ausbruch Form

Reiter Ausbruch Maße

Reiter Loch

Abbildung: Detektor Wafer, Reiter Ausbruch Form

Einstellungen im Ausbruch Form

Parameter | Funktion
Ausbruch Form | Ausbruch Form aktivieren.
Schwelle Ausbruchstiefe | Wurde ein Überstand erkannt und befindet sich in der Fehlerregion auch ein Ausbruch, so werden die Innenfehler unterhalb der eingestellten Abweichung (in Pixel, bezogen auf die umschließende Box) als Fehler klassifiziert.
Winkeländerung | Ein Konturpunkt wird als Fehler detektiert, wenn die berechnete Winkeländerung oberhalb des Schwellwertes liegt.
Kantensegment (Expertenmodus) | Zu jedem einzelnen Konturpunkt wird ein Kantensegment (Länge, Drehlage im Bild) auf Basis zweier, benachbarter Konturpunkte bestimmt. Eingabe: Distanz zu den Nachbarpunkten.
Winkeländerung über n Pixel (Expertenmodus) | Zu jedem einzelnen Konturpunkt wird aus n benachbarten Konturpunkten die maximale Differenz der Drehlagen der zugehörigen n Kantensegmente bestimmt.


Reiter Ausbruch Maße

Detektor Wafer

Reiter Ausbruch Form

Abbildung: Detektor Wafer, Reiter Ausbruch Maße

Einstellungen im Reiter Ausbruch Maße

Parameter | Funktion
Ausbruch Maße | Ausbruch Maße aktivieren.
Schwelle Ausbruchstiefe | Aus den detektierten Konturpunkten wird eine ideal approximierte, symmetrische Rechtecht-Kontur berechnet. Hierauf bezogen werden zu allen Konturpunkten die Distanzen berechnet. Der Schwellwert "max. Abweichung" definiert den Wert für eine fehlerhafte Distanz.
Abweichungen je Ausbruch | Definiert die max. Anzahl fehlerhafter Distanzen für eine GUT/SCHLECHT-Erkennung.
Fläche je Ausbruch | Definiert den Schwellwert einer fehlerhaften Fläche für eine GUT/SCHLECHT-Erkennung.
Außenfehler ignorieren (Expertenmodus) | Alle detektierten Fehlerkonturpunkte, die außerhalb der den Wafer umschließenden Box liegen (Farbe: türkis), werden bei der Kontur-Prüfung nicht berücksichtigt.


Reiter Rechteckanpassung

Hinweis:

Die Reiter "Binarisierung, Rechteckanpassung und Verschiedenes" sind nur im Expertenmodus zugänglich. Die Aktivierung erfolgt über Menüleiste "Optionen/Expertenmodus"

Reiter Binarisierung

Abbildung: Detektor Wafer, Reiter Rechteckanpassung

Einstellungen im Reiter Rechteckanpassung (Expertenmodus)

Parameter | Funktion
Kantensegment | Schrittweite oder Anzahl Konturelemente zur Berechnung lokaler Konturgeraden.
Berechnung Kantensegment | Zur Rechteckberechnung stehen zwei Modi zur Auswahl: Sekanten- oder Geradenanpassung.
Glättung Waferwinkel | +/- Bereich, bezogen auf das Maximum der Gaußverteilung der Einzel-Winkel, das zur Winkelberechnung herangezogen wird.
Glättung Wafergröße | +/- Bereich, bezogen auf das Maximum der Gaußverteilung der Einzel-Größen, das zur Größenberechnung herangezogen wird.
Toleranz Kantensegment | +/- Winkelbereich, bezogen auf den Ist-Winkel des Wafers der lokalen Konturgeraden, die zur Berechnung der Wafergröße berücksichtigt werden.


Detektor Wafer

Der Wafer-Detektor ist ein sehr leistungsfähiges, einfach zu bedienendes Bildverarbeitungswerkzeug, um die Position und mögliche Ausbrüche an Wafern oder Zellen während der Produktion zu erkennen. Er kann extrem genau die Größe und Position des Wafers messen und kann so auch als Hilfsmittel zum Aufnehmen und Platzieren von Robotersystemen verwendet werden.

Hinweis:

Die Reiter "Binarisierung, Rechteckanpassung und Verschiedenes" sind nur im Expertenmodus zugänglich. Die Aktivierung erfolgt über Menüleiste "Optionen/Expertenmodus"

Nächste Themen:

Bedienschritt Ausgabe

Reiter Ausbruch Maße

Der SBS Solar zeichnet sich aus durch:

  • Automatische Erkennung der Wafer- und Zellgeometrie
  • Zuverlässige Erkennung von Fehlstellen an geraden und geschwungenen Konturen
  • Flexible Einstellung der Prüfkriterien: z. B. Toleranzen für Wafergröße und Drehlage, Größe und Anzahl der erlaubten Konturdefekte
  • Einfache Optimierung des Sensors hinsichtlich Auswertegeschwindigkeit und Prüfgenauigkeit (Subpixelverfahren)
  • Freie Zuschnittfunktion bei größeren Defekten
  • Verzeichnungskorrektur

Reiter Wafer

Dieser Detektor eignet sich, um Ausbrüche an den Kanten der Waferkontur zu prüfen und geometrische Parameter wie Breite, Höhe, Position, Drehwinkel usw, zu messen.

Abbildung: Detektor Wafer, Reiter Wafer

Einstellungen im Reiter Wafer

Parameter | Funktion
Höhe | Bereich für die zu akzeptierende Waferhöhe
Breite | Bereich für die zu akzeptierende Waferbreite
Fläche | Bereich für die zu akzeptierende Waferfläche
Winkelbereich | Bereich für die zu akzeptierende Waferdrehlage
Helligkeit | Definition der Wafer-Helligkeit bezogen auf die Intensität des Objekthintergrundes
Form | Auswahl zwischen rechteckiger oder quadratischer Waferform
Ausblendbereiche | Über diese Auswahlbox können bis zu 12 Rechteckbereiche frei im Bild positioniert werden. Die Bereiche innerhalb dieser Zonen werden zur Waferkontrolle nicht herangezogen.
Lagekontrolle | Zur Kontrolle der Lage des Waferschwerpunktes kann als Sollbereich ein Rechteck bzw. eine Ellipse frei im Bildbereich positioniert werden.

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


Reiter Loch

Reiter Ausbruch Form

Reiter Kalibrierung

Abbildung: Detektor Wafer, Reiter Loch

Einstellungen im Reiter Loch

Parameter | Funktion
Loch | Locherkennung aktivieren.
Helligkeit | Auswahl der Helligkeit des Objekts bezogen auf die Helligkeit des Wafers.
Helligkeitsschwelle / Absolut | Festlegen der Helligkeitsschwelle zur Objekterkennung als absoluten Grauwert.
Helligkeitsschwelle / Relativ | Festlegen der Helligkeitsschwelle zur Objekterkennung als Offsetwert in Addition zum dynamisch bestimmten, mittleren Grauwert des Wafer.
Fläche | Definition der minimalen zu detektierenden Loch-/Objektfläche. Wert in Pixel*Pixel bzw. kalibriert im mm*mm.
Einzeichnung | (De)-Aktivierung der graphischen Einzeichnung detektierter Objekte.
Kantenfilter (Expertenmodus) | Ausweitung dunkler Bereiche, Eliminierung heller Pixel in dunklen Bereichen, Elimination von Artefakten, Trennung von hellen Objekten.
Gauss (Expertenmodus) | Reduktion von Rauschen, Unterdrückung störender Details und Artefakte, Glättung von Kanten.


Reiter Binarisierung

Hinweis:

Die Reiter "Binarisierung, Rechteckanpassung und Verschiedenes" sind nur im Expertenmodus zugänglich. Die Aktivierung erfolgt über Menüleiste "Optionen/Expertenmodus"

Reiter Kalibrierung

Reiter Rechteckanpassung

Abbildung: Detektor Wafer, Reiter Binarisierung

Einstellungen im Reiter Binarisierung (Expertenmodus)

Parameter | Funktion
Automatisch | Automatische Binarisierung aktivieren.
Korrekturfaktor für Schwellwert | Der Schwellwert zur Konturerkennung wird automatisch aus der Helligkeitsverteilung von Vorder- und Hintergrund berechnet. Die Lage der Kontrastschwelle im Histogramm kann in Richtung der Vordergrund- bzw. der Hintergrund-Farbe verschoben werden.
Histogrammschrittweite | Grauwert-Auflösung des Histogrammverlaufs.
Manuell | Manuelle Binarisierung aktivieren.
Wafer Helligkeitsschwelle | Feste Eingabe der Helligkeitsschwelle.


Kalibriermethode Kalibrierplatte (Roboter)

Die Kalibriermethode "Kalibrierplatte (Roboter)" dient der Bestimmung absoluter Positionen in Weltkoordinaten (z.B. mm). Dies geschieht über die Bildaufnahme der Kalibrierplatte und dem Einlernen der vier Referenzmarken. Mit dem Einlernen der Referenzmarken wird die Transformation ins absolute Koordinatensystem des Roboters ermöglicht.

Abbildung: Kalibriermethode Kalibrierplatte (Roboter)

Ablauf der Kalibrierung mit der "Kalibrierplatte (Roboter)"

Vorab sind Bildschärfe und Helligkeit zu bestimmen, sowie die gewünschte Einheit auszuwählen.

  1. Über den Button "Kalibrierparameter" den Z-Versatz einstellen.
  2. Kalibrierplatte möglichst formatfüllend im Sichtfeld platzieren (siehe dazu auch "Hinweise zur optimierten Nutzung der Kalibrierplatte / Randbedingungen" Kalibriermethode Kalibrierplatte (Roboter)und "Kalibriermethode Kalibrierplatte (Roboter)").
  3. In der Auswahlbox "Kalibrierplatte" die o.g., entsprechende Kalibrierplatte (Größe und Typ) auswählen.
  4. Kalibrierung starten.
  5. Wenn der Arbeitsbereich des Roboters vom Sichtfeld abweicht, die Kalibrierplatte in den Arbeitsbereich des Roboters überführen, z.B. über ein Förderband.
  6. Listbox "Referenzmarken" aktivieren.
  7. Zeile 1 in Listbox "Referenzmarken" auswählen.
  8. Erste Referenzmarke mit dem Roboter anfahren.
  9. Nun im Feld "Welt X" und "Welt Y" die entsprechenden, bekannten Weltkoordinatenwerte (bei Roboter: die Werte von der Robotersteuerung) eintragen.
  10. Schritte 7-10 so lange wiederholen, bis alle Referenzmarken eingegeben wurden.

Parameter Kalibrierplatte (Roboter)

Parameter | Funktion

Kalibrierplatte

Hier wird die verwendete Kalibrierplatte (Größe/ Typ) ausgewählt (siehe dazu auch "Kalibriermethode Kalibrierplatte (Roboter)" und "Kalibriermethode Kalibrierplatte (Roboter)".)

Kalibrierparameter

Hier wird außerdem ggf. der z- Offset zwischen Kalibrier- und Messebene eingegeben. Und verschiedene Ausgabeparameter sowie Fehler- / Optimierungskenngrößen angezeigt. Siehe: Kalibrierung, Kalibrierparameter
Starte Kalibrierung

Kalibriervorgang wird ausgelöst. Alle sichtbaren Punkte der Kalibrierplatte werden bestimmt, alle erkannten markiert und die Kalibrierung berechnet.
Punkt testen | Es kann ein Testpunkt im Bild gesetzt werden dessen Koordinaten in Weltkoordinaten zur Kontrolle / Plausibilitätstest der Kalibrierung der Skalierung im Testpunkt- Fenster angezeigt werden.

Referenzmarken

- Welt X

- Welt Y

Koordinatenwerte in Welt in gewählter Einheit (z.B. mm), durch direkte Wert- Eingabe in die Referenzmarkenliste.

Diese Werte sind im Falle von z.B. Pick&Place / Roboter die X- / Y- Koordinatenwerte, die von der Robotersteuerung bei Ablage des Kalibrierteiles /Anfahren des entsprechenden Punktes, abgelesen und in die Referenzmarkenliste übertragen werden können.

"˃" / "˂" Zum nächsten / vorherigen Eingabeschritt wechseln

Hinweise zur optimierten Nutzung der Kalibrierplatte / Randbedingungen finden Sie unter: Hinweise zur optimierten Nutzung der Kalibrierplatte / Randbedingungen

Weitere Informationen

Closed Typen / Größen von Kalibrierplatten

Kalibrierplattengrößen | Kalibrierplattenmuster | Punkteanzahl
98 mm x 54 mm | 50 mm x 37,9 mm | 15 x 13
180 mm x 100 mm | 100 mm x 75,8 mm | 15 x 13
340 mm x 176 mm | 200 mm x 151,7 mm | 15 x 13
820 mm x 403 mm | 500 mm x 379,2 mm | 15 x 13

Im Installationsverzeichnis: Festo/SBS Vision-Sensor/Dokumentation/... sind die verfügbaren Kalibrierplatten als .pdf-Datei zu finden. Diese können auf Papier oder auf ein anderes Medium gedruckt / flach aufgebracht werden. Beim Ausdruck die Einstellung "Tatsächliche Größe" verwenden, und darauf achten, dass der Druck nicht skaliert wird. Die Kantenlänge / Beschriftung der Platte muss dem Namen der Platte bei der Auswahl in der Software entsprechen.

Nächste Themen:

Kalibriermethode Punktpaarliste (Roboter)

Kalibrierung mit Telegrammen

Kalibrierung, Kalibrierparameter


Automatisierte Kalibrierung: Kalibrierplatte (Roboter) Ablauf 1

Abbildung: Automatisierte Kalibrierung Ablauf 1

Nächstes Thema:

Kalibrierung mit Telegrammen

Automatisierte Kalibrierung: Kalibrierplatte (Roboter) Ablauf 2


Automatisierte Kalibrierung: Kalibrierplatte (Roboter) Ablauf 2

Abbildung: Automatisierte Kalibrierung Ablauf 2

Nächstes Thema:

Kalibrierung mit Telegrammen

Reiter Kalibrierung