SBS – Bedien- und Konfigurationssoftware

SBS – Bedien- und Konfigurationssoftware – Übersicht

Aufbau der PC- Software

Die SBS Vision Sensor Konfigurationssoftware besteht aus den folgenden drei Anwendungen:

  • Vision Sensor Device Manager

    Mit diesem Programm wählen Sie den zu konfigurierenden Sensor oder einen Sensor-Simulator aus und starten wahlweise die Anwendungen Vision Sensor Configuration Studio oder Vision Sensor Visualisation Studio. Hier werden auch wenn gewünscht / erforderlich Passworte und Benutzerrechte verwaltet.

  • Vision Sensor Configuration Studio

    Dieses Programm stellt Ihnen umfassende Funktionen für Einrichtung und Test von Sensoren sowie die Definition von Prüfaufgaben (Jobs) zur Verfügung. Zur Bedienung benötigen Sie, falls Passwortschutz aktiviert, die Berechtigung der Benutzergruppe Administrator.

  • Vision Sensor Visualisation Studio

    Dieses Programm dient zur Anzeige von Bildern und Ergebnissen und damit zur Überwachung/Überprüfung von Sensoren und zur Analyse von Messergebnissen. Im Vergleich zu Vision Sensor Configuration Studio bietet es nur eingeschränkte Konfigurationsmöglichkeiten. Zur Bedienung benötigen Sie, falls Passwortschutz aktiviert, die Berechtigung der Benutzergruppe Administrator oder Werker. Von hier aus stehen auch umfangreiche Archivierungsfunktionen zur Verfügung.

Abbildung: Softwarestruktur

Hilfe im Kontext

Für alle wichtigen Programmfunktionen gibt es kontextsensitive Hilfe-Seiten: Sobald Sie eine bestimmte Funktion auf der Programmoberfläche auswählen, erhalten Sie im Hilfe-Fenster die passenden Informationen.

Alle verfügbaren Hilfeseiten im Zusammenhang können Sie einsehen, wenn Sie Hilfe (Button mit "?"- Symbol, oder Doppelklick im Online- Hilfe Fenster) im Menü wählen. Dort können Sie auch nach Begriffen oder Stichworten suchen.

Im Unterschied zur kontextsensitiven Hilfe können Sie die Größe dieses Hilfefensters beliebig anpassen, sodass auch längere Hilfetexte übersichtlich dargestellt werden.

Verwendete Open Source Software: Open Source Licences

05.08.2016


GPL_Lizenz

Open Source Licences

The SBS Vision Sensor software makes use of a couple of third party software packages that come with various licenses. This section is meant to list all these packages and to give credit to those whos code helped in the creation of the SBS Vision Sensor software.

For components that reference the GNU General Public License (GPL) or the GNU Lesser General Public License (LGPL), please find these licenses and the written offer for source code in this software installation in \FESTO\SBS Vision Sensor\Eula\OpenSourceLicenses.

The SBS Vision Sensor firmware makes use of Linux Version 2.6.33 (Website: www.kernel.org), which is distributed under the GNU GPL version 2.

The SBS Vision Sensor firmware makes use of x-loader, an initial program loader for Embedded boards based on OMAP processors (Website: http://arago-project.org/git/projects/?p=x-load-omap3.git; a=summary) which is distributed under the GNU GPL version 2 or higher.

The SBS Vision Sensor firmware makes use of u-boot, an initial program loader for Embedded boards based on OMAP processors (Website: http://arago-project.org/git/projects/?p=x-load-omap3.git; a=summary) which is distributed under the GNU GPL version 2 or higher

The SBS Vision Sensor firmware makes use of spike Version 0.2,a SPI-driver (Website: https://github.com/scottellis/spike/blob/master/spike.c ), which is distributed under the GNU GPL version 2 or higher.

The SBS Vision Sensor firmware makes use of Busy-Box Version 1.18.1 ( Website: http://www.busybox.net/ ), which is distributed under the GNU GPL version 2 or higher

The SBS Vision Sensor firmware makes use of vsftpd Version 2.0.3 ( Website: https://security.appspot.com/vsftpd.html ), which is distributed under the GNU GPL version 2 or higher.

The SBS Vision Sensor firmware makes use of mtd-utils Version 1.5.0 ( Website: http://www.linux-mtd.infradead.org/doc/general.html ), which is distributed under the GNU GPL version 2 or higher.

The SBS Vision Sensor firmware makes use of Boa Webserver Version 0.94.13 ( Website: http://www.boa.org/ ), which is distributed under the GNU GPL version 2 or higher.

The SBS Vision Sensor firmware makes use of Procps Version 3.2.8 ( Website http://procps.sourceforge.net/download.html), which is distributed under the GNU GPL version 2 or higher and GNU LGPL version 2.1 or higher.

The SBS Vision Sensor firmware makes use of GnuPG Version 1.4.10 ( Website: https://www.gnupg.org/ ), which is distributed under the GNU GPL version 3 or higher.

The SBS Vision Sensor firmware makes use of glibc, which is distributed under GNU LGPL version 2.1 or higher.

The SBS Vision Sensor firmware makes use of Dropbear - a SSH2 server Version 2012.55 ( Website: https://matt.ucc.asn.au/ dropbear/dropbear.html ). The Dropbear SSH2 server is distributed under the terms of the Dropbear License which is a MIT/X Consortium style open source license. Please find this license in this software installation in \FESTO\SBS \Eula\OpenSourceLicenses

Vision Sensor Configuration Studio software is based in part on the work of the Qwt project (http://qwt.sf.net).


SBS , Tutorial, Starten der Software

Dieses Tutorial erläutert Schritt für Schritt einen exemplarischen Ablauf zur Einstellung des Vision Sensors SBS Vision Sensor auf eine Prüfaufgabe.

Nächstes Thema: SBS Vision Sensor – Bedien- und Konfigurationssoftware –Kurzanleitung

Starten der Software

Zum Starten der SBS Vision Sensor Anwendungssoftware auf das Desktop- Icon klicken.

Aufbau der PC Software

Die PC- Software ist in folgende drei Module gegliedert:

  • Vision Sensor Device Manager

Auswahl eines Sensors oder einer Sensor- Simulation zur Konfiguration oder zur Anzeige (Überwachung), bzw. verschiedene Grundeinstellungen festlegen

  • Vision Sensor Configuration Studio

Konfiguration des SBS Vision Sensors für eine oder mehrere Prüfaufgaben (Jobs) in sechs Arbeitsschritten.

  • Vision Sensor Visualisation Studio

Anzeige und Überwachung von Bildern und Ergebnissen angeschlossener Sensoren, sowie Jobupload.

Nächster Schritt: SBS Vision Sensor – Bedien- und Konfigurationssoftware –Kurzanleitung


SBS Vision Sensor – Bedien- und Konfigurationssoftware –Kurzanleitung

Exemplarischer Ablauf, (Beispiel: Objektsensor)

SBS Vision Sensor , Kurzanleitung, Starten der Software

Diese Kurzanleitung erläutert Schritt für Schritt den exemplarischen Ablauf zur Einstellung einer Prüfaufgabe auf dem Vision Sensor.

Zum Starten der SBS Vision Sensor Anwendungssoftware auf das Desktop- Icon „SBS Vision Sensor“ klicken.

Abbildung: Icon SBS Vision Sensor

Vision Sensor Device Manager: Sensoren oder Sensorsimulationen öffnen / Passworte

In diesem Programm können Sie einen Sensor oder eine Sensor-Simulation zur Konfiguration oder zur Anzeige (Überwachung) auswählen sowie verschiedene Grundeinstellungen vornehmen.

Nächstes Thema: Vision Sensor Configuration Studio: Sensor einstellen

Sensoren konfigurieren oder anzeigen

Um einen Sensor zur Konfiguration oder zur Anzeige zu öffnen, den gewünschten Sensor in der Liste „Aktive Sensoren“ markieren. Danach startet ein Klick auf den Button „Konfigurieren“ das Modul „Vision Sensor Configuration Studio“. Mit dem Button „Anzeige“ startet das Modul „Vision Sensor Visualisation Studio“.

Sensorsimulation

Um einen Sensor zur Offline- Simulation zu öffnen, den gewünschten Sensor in der Liste „Sensoren für Simulationsbetrieb“ markieren. Danach startet ein Klick auf den Button „Konfigurieren“ das Modul „Vision Sensor Configuration Studio“.

Abbildung: Vision Sensor Device Manager Übersicht

A) Aktive Sensoren

In dieser Liste werden alle vom PC aus erreichbaren SBS Vision Sensoren angezeigt.

B) Sensoren für Simulationsbetrieb

Hier werden alle zur Offline- Simulation verfügbaren SBS Vision Sensoren angezeigt.

C) Sensoren per IP Adresse hinzufügen

Sensoren, die nach Softwarestart bzw. nach „Finden“ (Auslösen weiterer Suchdurchgang) nicht in der Liste „Aktive Sensoren“ erscheinen, aber sicher im Netzwerk vorhanden sind (ggf. z.B. erst hinter einem Gateway), und deren IP-Adresse bekannt ist, können hier mit Ihrer IP- Adresse eingetragen werden. Mit Drücken des Buttons „Hinzufügen“ werden solche Sensoren, wenn gefunden, ebenfalls in die Liste „Aktive Sensoren“ eingetragen und können nun bearbeitet werden.

D) Funktionen

  • Finden

Auslösen eines weiteren Suchdurchganges

  • Konfigurieren

Konfigurieren eines angeschlossenen Sensors oder einer Sensorsimulation = Vision Sensor Configuration Studio

  • Anzeigen

Anzeige von Bild- und Ergebnisdaten eines angeschlossenen Sensors = Vision Sensor Visualisation Studio

  • Einstellungen

Netzwerkeinstellungen wie IP-Adresse etc. des Sensors bearbeiten

E) Kontext- Hilfe

Kontextsensitive Hilfe zum aktuellen Thema

Passworte

Beim ersten Start nach der Installation ist die Passworteingabe komplett deaktiviert und der Auto-Login als Administrator voreingestellt. Sollen Parametereinstellungen vor unbefugtem Zugriff geschützt werden, sollten Passworte für die Passwortebenen „Admin“ und „User“ s.u. vergeben werden. Dies kann über die Menüleiste Datei / Benutzerverwaltung bzw. den Button mit dem Schlüsselsymbol in der Toolbar aufgerufen werden.

Abbildung: Passwort Button

Passwortebenen:

Abbildung: Passwortebenen

Passwort Ebene | Vision Sensor Device Manager | Vision Sensor Configuration Studio | Vision Sensor Visualisation Studio
Administrator Passwort | alle Funktionen | alle Funktionen | alle Funktionen
Werker Passwort | alle Fkt. außer - Konfigurieren - Einstellungen - Update | keine | alle Funktionen, inklusive Job- Upload und Bildrekorder
Bediener (ohne Passwort) | alle Fkt. außer - Konfigurieren - Einstellungen - Update | keine | nur Anzeige von Bildern, Prüfergebnissen und Statistik

Um nach Vergabe von Passworten die Funktion „Konfigurieren“ nutzen zu können, ist nun ein Login mit Klick auf den Toolbar- Login- Button, und danach die Eingabe des vorher vergebenen Passworts nötig.

Abbildung: Login Button

Abbildung: Passworteingabe

Durch Vergabe eines leeren Passworts kann die Abfrage wieder ohne weitere Eingabe quittiert werden. Durch Aktivierung der Checkbox „Passwortabfrage deaktivieren“ wird die Abfrage dauerhaft deaktiviert.

Wurden Passworte vergeben und dann aber vergessen, ist durch Neuinstallation der Software das Rücksetzen auf den Auslieferungszustand möglich.


Vision Sensor Configuration Studio: Sensor einstellen

Mit diesem Programm können Sie Ihren SBS Vision Sensor in sechs folgerichtigen Arbeitsschritten für eine oder mehrere Prüfaufgaben (Jobs) konfigurieren.

Nächstes Thema:Lagenachführung einstellen

Abbildung: Vision Sensor Configuration Studio

Die verschiedenen Arbeitsbereiche sind:

A) Menü- und Toolbar

B) Bedienschritte
Erklärung s. nächstes Kapitel

C) Bild
Bildausgabe mit grafisch einstellbaren Arbeits- und Suchbereichen, sowie Zoomfunktion und Filmstreifennavigation

D) Kontext- Hilfe
Kontextsensitive Online Hilfe, automatisch zu jeder Aktion aktualisiert.

E) Einstellungen der Bildaufnahme
Umschaltung zwischen kontinuierlichem Modus und Einzelbildmodus und Software Trigger

F) Verbindungsmodus
Umschaltung zwischen Online- und Offline- Modus. (Sensor vorhanden oder Simulation ohne Sensor)

G) Konfigurationsfenster
Variabel, zur entsprechenden Aktion, wechselnder Inhalt zur Einstellung der zugehörigen Parameter.

H) Statusleiste

Verschieden Statusinformationen einschließlich: Modus / Name des SBS / aktiver Job. Im Run Modus: Zykluszeit xy Position des Cursors und Identsität des Pixels / einzelene I/O Ein-/Aus- Status (wie unter "Ausgabe/Ausgangssignale" konfiguriert).

Job konfigurieren

Um einen Job zu konfigurieren: unter Bedienschritte/Job im Feld "Jobs" (G), den Jobeintrag editieren oder ggf. einen neuen Job anlegen.

Abbildung: Vision Sensor Configuration Studio Job

Hier werden im Feld „Jobs“ neue Jobs angelegt und auch mehrere Jobs verwaltet. Außerdem werden hier alle globalen Einstellungen, die für die gesamte Prüfaufgabe gültig sind, wie z.B. Verschlusszeit, Verstärkung, Beleuchtungseinstellungen etc. vorgenommen.

Ein Job enthält sämtliche Einstellungen und Parameter, die zur Durchführung einer bestimmten Prüfaufgabe erforderlich sind.

  • Zuerst sollten, um ein kontrastreiches und scharfes Bild zu erhalten, folgende grundlegenden Bildeinstellungen gemacht werden:
    * Bildhelligkeit: Verschlusszeit bzw Verstärkung einstellen s. Job/Bildaufnahme
    * Bildschärfe: Focus Einstellschraube an der Rückseite des SBS Vision Sensors einstellen bis eine scharfe Abbildung sichtbar ist
  • Im Auslieferungszustand ist als Trigger Modus = "Freilauf" (s. Job/Bildaufnahme) und als „Trigger / Bildaktualisierung“ = "Kontinuierlich" eingestellt. Damit wird zur Focus- und Helligkeitseinstellung permanent ein neues Bild eingezogen und somit die Anzeige auch permanent aktualisiert.
  • Die danach folgende Einstellung der Lagenachführung und der Detektoren erfolgt vorzugsweise im Einzelbildmodus, da alle Einstellungen dann auf einem Masterbild basieren und der Bildeinzug nicht permanent ausgeführt wird. Dazu unter Bildaufnahme/Triggermodus = Trigger einstellen.
  • Innerhalb eines Jobs kann nachfolgend eine Lagenachführung und (je nach Sensortyp) 32 bzw beliebig viele verschiedene Detektoren zur Lösung der Prüfaufgabe definiert werden.


Lagenachführung einstellen

Bei Objekten bzw. Merkmalen, deren Position im Bild variiert, kann eine Lagenachführung nützlich bzw. erforderlich sein. Hierfür stehen drei verschiedene Detektionsmethoden (Lagedetektoren) zur Verfügung.

Nächstes Thema: Detektoren einstellen

Die Lagenachführung ist optional und steht mit der Methode Mustervergleich, Kantenantastung und Konturvergleich zur Verfügung.
Nach Auswahl der Methode zur Lagenachführung die entsprechenden Arbeitsbereiche im Bild grafisch in Position und Größe auf das Merkmal, welches zur Lagebestimmung dienen soll, einstellen. Die zugehörigen Parameter werden unten rechts dargestellt und können dort auch angepasst werden. Die Lagenachführung wirkt auf alle nachfolgend in diesem Job definierten Detektoren. Im Beispiel hier wird die linke obere Ecke des rechteckigen Bauteils durch die Bestimmung der linken und der oberen Außenkante und deren Schnittpunkt zur Lagebestimmung des nur translatorisch in X- und Y- Richtung in der Position variierenden Bauteiles bestimmt. Sollte auch die Winkellage des Bauteiles variieren können, ist die Methode „Konturvergleich“ zur Lagenachführung zu verwenden.

Abbildung: Configuration Studio Lagenachführung


Detektoren einstellen

Hier können verschiedene Detektoren zur Lösung einer Prüfaufgabe ausgewählt und eingestellt werden. Zuerst wird im unten dargestellten Dialog ein gewünschter Detektor ausgewählt.

Abbildung: Detektorliste Objektsensor

Danach werden die Arbeits- und Suchbereiche graphisch im Bild eingestellt. Falls Einlernbereiche vorhanden sind, werden diese sofort bei Abschluss der Einstellung eingelernt. Unten links werden alle in diesem Job definierten Detektoren angezeigt. Unten rechts werden die Parameter des aktuell ausgewählten Detektors angezeigt und können dort auch angepasst werden. Falls weitere Merkmale am selben Teil zu prüfen sind, lassen sich mit „Neu" beliebig viele weitere Detektoren, analog wie oben beschrieben, erstellen. Im Beispiel wurden zwei Helligkeits- Detektoren zur Überprüfung der Anwesenheit von Kontakten im Prüfteil definiert. Detektor 1 findet einen Kontakt (Helligkeitswert liegt im geforderten Bereich, da metallisch- glänzender, d.h. hoch reflektierender Kontakt vorhanden), und meldet deshalb ein positives Ergebnis. Detektor 2 findet keinen Kontakt (Helligkeitswert liegt außerhalb des geforderten Bereichs, da kaum Reflektion durch dunkles Kunststoffgehäuse), und meldet deshalb ein negatives Ergebnis.

Abbildung: Detektor erstellen


Ausgabe, I/O und Datenausgabe

Im Bedienschritt Ausgabe können verschiedene Einstellungen bezüglich der digitalen Ein- / Ausgänge und der Datenausgaben gemacht werden.

Nächstes Thema: Ergebnis

In den verschiedenen Tabs die Schnittstellen auswählen und aktivieren. Detektorergebnisse logisch verknüpfen, und den vorhandenen I/O´s zuordnen.

Zur Ausgabe von Ergebnisdaten ebenfalls gewünschte Schnittstelle wählen und Datenstring zusammenstellen.

Abbildung: Ausgabe, Digitale Signale und Daten

Einstellmöglichkeiten in den verschiedenen Tabs:

  • Pinbelegung

    Auswahl und Zuordnung der digitalen Schalt- Ein- und Ausgänge.

  • Ausgangssignale

    Zuordnung einer logischen Verknüpfung unter Nutzung der boolschen Ergebnisse aller Detektoren. Definition von komplexen logischen Verknüpfungen via Tabelle oder via Eingabe einer logischen Formel.

    Zu jedem vorhandenen digitalen Ausgang kann eine eigene logische Verknüpfung zugeordnet werden.

  • Schnittstellen

    Auswahl, Einstellung und Aktivierung der einzelnen Schnittstellen.

  • Zeitsteuerung

    Einstellung der Delayzeiten: Trigger-Verzögerung, Ergebnis-Verzögerung und Ergebnis-Dauer

  • Datenausgabe

    Einstellung des Datenausgabestrings via RS422 oder Ethernet.

Auswahl von: Binärem- oder ASCII- Protokoll, Vorspann u./o. Nachspann, Standardinhalten u./o. flexibel zusammenstellbaren, speziellen Einzeldaten der einzelnen Detektoren.
Es können beliebig viele Einzelergebnisse aller definierten Detektoren im Ausgabestring frei angeordnet werden.


Ergebnis

Über diese Funktion wird die Prüfung mit allen gemachten Einstellungen auf dem PC zu Kontrollzwecken ausgeführt. Dabei werden alle Ergebnisse genau wie später auf dem Sensor erzeugt und angezeigt. Jedoch z.B. die Ausführungszeiten nicht aktualisiert, da diese Werte nur aussagefähig sind, wenn die Ausführung auf dem Sensor selbst erfolgt. S. nächster Schritt: „Sensor starten“. Es werden keine Hardware- Ausgänge gesetzt.

Nächstes Thema: Sensor starten

Abbildung: Ergebnisanzeige


Sensor starten

Mit Aktivierung dieser Funktion werden alle Einstellungen auf den Sensor übertragen, im Flash gespeichert und dort entsprechend der vorgenommenen Einstellungen z.B. im Freilauf oder im getriggerten Modus ausgeführt. Alle Anzeigen in der Detektorliste, im Ergebnisfeld bzw. unter „Statistik“ werden hier aktualisiert. Bei Aktivierung dieser Funktion werden die übertragenen Parameter permanent gespeichert und bei der Ausführung werden auch die entsprechenden Hardware- Ausgänge gesetzt.

Nächstes Thema: Vision Sensor Visualisation Studio, Bilder und Ergebnisse anzeigen

Abbildung: Sensor starten


Vision Sensor Visualisation Studio, Bilder und Ergebnisse anzeigen

Dieses Programm dient zur Überwachung/Überprüfung von angeschlossenen Sensoren und zur Analyse von Prüfergebnissen, sowie zur Archivierung von Prüfergebnissen und Bildern.

Nach Klick auf den Button „Anzeige" in Vision Sensor Device Manager startet das Modul Vision Sensor Visualisation Studio.
Das aktuelle Bild wird mit Einzeichnungen der Lagenachführung und der Detektoren angezeigt (falls „Bildübertragung = Aktiv“ im Konfigurationsmodul unter Job/Allgemein aktiviert ist).
Im Tab „Ergebnis“ werden die einzelnen Detektoren mit Ihren Ergebnissen, und das Gesamtergebnis dargestellt.
Im Tab „Statistik“ werden weitere statistische Ergebnisse angezeigt.
Mit „Bild einfrieren" können ereignisgesteuert (z.B. Schlechtteil) Bilder in der Anzeige festgehalten werden.
Mit „Zoom" können Bilder vergrößert dargestellt werden.
Mit „Bilder archivieren" können Bilder und Ergebnisdaten, wie zuvor unter „Menü Datei/Archivierung konfigurieren", eingestellt, auf der Festplatte des angeschlossenen PC´s, mit oder ohne numerischen Ergebnisdaten, archiviert werden.
Mit „Rek. Bilder" kann der Bildrekorder ausgelesen werden.
Im Tab „Job“ können auf dem Sensor vorhandene Jobs umgeschaltet werden.
Im Tab „Hochladen“ können weitere zuvor definierte Jobs oder ganze Jobsätze vom Viewer aus auf den Sensor geladen werden.

Abbildung: Vision Sensor Visualisation Studio


Login, als Administrator oder Werker anmelden

Nach der Vergabe von Passworten und darauf folgendem automatischem LogOut ist z. B. zur Konfiguration eines Sensors ein Login nötig. Dazu in der Toolbar auf Icon Login klicken, um sich einzuloggen oder / und, nach erfolgter Passworteingabe, die Passworteingabe für die nächsten Sitzungen für die gewählte Benutzergruppe zu deaktivieren.

Abbildung: Button Login

Wurde der Haken bei "Passwortabfrage deaktivieren" gesetzt, wird beim nächsten Start der Anwendung nicht mehr nach dem Passwort gefragt.

Abbildung: Vision Sensor Device Manager, Passwort

Benutzerverwaltung / Passworte


SBS – Bedien- und Konfigurationssoftware – Vision Sensor Device Manager, alle Funktionen

In diesem Programm können Sie einen Sensor oder eine Sensor-Simulation zur Konfiguration, oder zur Anzeige (Überwachung) auswählen, sowie verschiedene Grundeinstellungen vornehmen:

  • Aktive Sensoren
  • Sensoren für Simulationsbetrieb
  • Finden / Aktiven Sensor hinzufügen
  • Konfigurieren eines angeschlossenen Sensors
  • Anzeigen von Bild- und Ergebnisdaten
  • Netzwerk- Einstellungen des Sensors
  • Update / Firmware-Aktualisierung
  • Benutzerverwaltung / Passworte

Abbildung: Vision Sensor Device Manager

Ist die Funktion „Konfigurieren"" nicht zugänglich (Button inaktiv) so ist ein Login (Button mit Türsymbol und Pfeil) mit Passworteingabe nötig. Falls Sie das Passwort nicht kennen, bitte den Administrator kontaktieren.


Aktive Sensoren

In der Auswahlliste Aktive Sensoren werden die im Netzwerk verfügbaren Sensoren angezeigt.

Konfigurieren eines angeschlossenen Sensors (Aufruf von Vision Sensor Configuration Studio)

Anzeigen von Bild- und Ergebnisdaten (Aufruf von Vision Sensor Visualisation Studio)

Bedeutung der angezeigten Parameter
Parameter | Bedeutung
IP-Adresse | IP- Adresse des Sensors im Netzwerk
Hardware | Hardware Version (R3B, R2B o.ä.)
Sensortyp | Sensortyp (Objekt-, Farbsensor, Code reader, o.ä.)
Variante | Sensor-Variante (Advanced o.ä.)
Version | Firmware-Version
Mode | Betriebsart (Run, Config oder Offline)
Funktionseinschränkungen | Neue Funktionen die noch nicht unterstützt werden ???
Sensorname | Name des Sensors
Hersteller | Name des Herstellers
Mac-Adresse | Mac-Adresse des Sensors
Subnetz-Maske | Subnetzmaske des Sensors
Gateway | Standard Gateway
DHCP | DHCP aktiv / inaktiv
Betriebssystem | Art des Betriebssystems
Betriebssystem Version | Version des Betriebssystems
Plattform | z.B. SBS Vision Sensor H
ardware | Hardware Version
RAM | RAM Größe
Flash | Flash Größe
Hinweise:
  • Werden in der Liste keine Einträge angezeigt, obwohl ein Sensor angeschlossen ist, können Sie diesen mit Button „Finden" oder Button „Hinzufügen" einfügen.
  • Ist kein Sensor angeschlossen, stehen Ihnen in der Liste Sensoren für Simulationsbetrieb, Simulationen verschiedener Sensoranwendungen zur Verfügung.

Über den Button Details (am rechten Ende der Parameter Liste von „Aktive Sensoren“) ist eine noch detailiertere Liste der SBS Vision Sensor Parameter abzurufen.

Abbildung: Sensoreigenschaften


Sensoren für Simulationsbetrieb

In der Auswahlliste Simulation werden Ihnen verfügbare Sensor-Simulationen angezeigt. Zur Bearbeitung einen Listeneintrag doppelklicken bzw. auswählen und Button: Konfigurieren (Aufruf von Vision Sensor Configuration Studio) drücken.

Bedeutung der angezeigten Parameter

Parameter | Bedeutung
Sensortyp | Sensortyp (z.B. Objekt-, Farbsensor, Code reader, ...)
Hardware | Hardwaretyp (z.B. Auflösung, Monochrom- oder Farbsensor)
Version | Firmware-Version
Variante | Sensor-Variante (z. B. Advanced …)

Ist die Funktionen "Konfigurieren" nicht zugänglich (Button inaktiv), so ist ein Login mit Passworteingabe nötig. Falls Sie das Passwort nicht kennen, bitte den Administrator kontaktieren.


Finden / Aktiven Sensor hinzufügen

Werden in der Auswahlliste „Aktive Sensoren“ keine Einträge angezeigt, obwohl ein Sensor angeschlossen ist, gehen Sie wie folgt vor:

Finden / Sensor suchen:

Um nach am PC angeschlossenen, oder im Netzwerk verfügbaren Sensoren zu suchen, klicken Sie auf Button „Finden".

Aktiven Sensor hinzufügen:

Wenn ein Sensor, obwohl er im Netzwerk, ggf. auch erst hinter einem Gateway, angeschlossen ist, auch nach einem weiteren mit Button „Finden“ durchgeführten Suchlauf nicht in der Liste „Aktive Sensoren“ erscheint. Und aber die IP-Adresse des Sensors bekannt ist, geben Sie diese in das Feld IP-Adresse ein und klicken Sie anschließend auf Button „Hinzufügen".

Der Sensor erscheint nun in der Liste und kann zur Bearbeitung ausgewählt werden.


Konfigurieren eines angeschlossenen Sensors

Markieren Sie einen Sensor (bzw. eine Simulation) in der Liste und klicken Sie auf den Button „Konfigurieren". Das Konfigurationsprogramm Vision Sensor Configuration Studio wird aufgerufen und die ggf. auf dem Sensor gespeicherten Jobs werden in der Auswahlliste angezeigt. Beim Aufruf von Vision Sensor Configuration Studio erscheint u.U. eine Passwortabfrage. Zur Festlegung von Passwörtern siehe Benutzerverwaltung. (Button mit Schlüsselsymbol)

s. Kapitel: SBS – Bedien- und Konfigurationssoftware –Vision Sensor Configuration Studio, alle Funktionen


Anzeigen von Bild- und Ergebnisdaten

Markieren Sie einen Sensor in der Liste und klicken Sie auf den Button „Anzeigen". Das Programm Vision Sensor Visualisation Studio wird aufgerufen und Bilder und Messergebnisse des aktiven Jobs angezeigt.

Hinweise:

Durch Aufruf von Vision Sensor Visualisation Studio wird der Betrieb des ausgewählten Sensors zunächst nicht beeinflusst.

s. Kapitel : SBS – Bedien- und Konfigurationssoftware –Vision Sensor Visualisation Studio, alle Funktionen


Netzwerk- Einstellungen des Sensors

Mit dem Button „Einstellungen" können Sie die Netzwerkeinstellungen des gewählten Sensors ändern. IP-Adresse, Subnetz-Maske, Standard- Gateway, DHCP und ein Sensorname können hier eingestellt werden. Die IP-Adresse und die Subnetz-Maske des PC wird unten in der Statusleiste von Vision Sensor Device Manager angezeigt. Zur Verbindung des Sensors mit dem PC müssen die Adressräume übereinstimmen. Dazu ggf. hier die IP-Adresse etc. des Sensors entsprechend einstellen. Bitte kontaktieren Sie zur Festlegung von Netzwerkparametern Ihren Administrator. Weitere Informationen hierzu finden Sie auch im Kapitel Netzwerkanschluss Kurzanleitung und Netzwerkanschluss . Wenn "DHCP = aktiv" gewählt wird, muss für den Sensor ein Name vergeben werden, da die IP-Adresse dann bei jedem Sensorstart neu vergeben wird und somit wechseln kann, d.h. nicht mehr eindeutig ist. Für diese Funktionen benötigen Sie Administratorrechte (siehe Benutzerverwaltung).

Abbildung: Vision Sensor Device Manager IP Setup

s. Kapitel: Netzwerkanschluss Kurzanleitung und Netzwerkanschluss


Update / Firmware-Aktualisierung

Mit dem Menüpunkt Datei/Firmware-Update können Sie die Firmware des gewählten Sensors aktualisieren. Dazu muss vorher via Download von der FESTO Homepage bzw. vom FESTO Support die entsprechende Firmware-Update Datei beschafft werden. Wählen Sie im sich öffnenden Dialog die entsprechende Firmware-Datei und folgen den Anweisungen.

Abbildung: Vision Sensor Device Manager, Firmware Update


Benutzerverwaltung / Passworte

Die SBS -Konfigurationssoftware unterscheidet drei Benutzergruppen, die unterschiedliche Berechtigungen besitzen: (Button oben, links, mit Schlüsselsymbol)

Abbildung: Vision Sensor Device Manager, Passworte

Passwort Ebene | Vision Sensor Device Manager | Vision Sensor Configuration Studio | Vision Sensor Visualisation Studio
Administrator Passwort | alle Funktionen | alle Funktionen | alle Funktionen
Werker Passwort | alle Fkt. außer - Konfigurieren - Einstellungen - Update | keine | alle Funktionen, inklusive Job- Upload und Bildrekorder
Bediener (ohne Passwort) | alle Fkt. außer - Konfigurieren - Einstellungen - Update | keine | nur Anzeige von Bildern, Prüfergebnissen und Statistik

Nach Installation der Software wird der Login automatisch sofort bei Aufruf der Anwendung ohne Passwortabfrage ausgeführt. Es sind keine Passworte vergeben.

Passwörter festlegen:

Wählen Sie Benutzerverwaltung im Datei-Menü oder klicken Sie in der Toolbar auf den Button mit Schlüsselsymbol, um Passwörter für die Benutzerkategorien Administrator und Werker zu vergeben bzw. zu ändern. Nach Eingabe eines Passworts wird automatisch ein LogOut ausgeführt, d.h. ab dann ist die Eingabe des neu vergebenen Passwortes nötig. Bei Vergabe eines "leeren" Passworts kann die Eingabe einfach mit OK quittiert werden.

Abbildung: Vision Sensor Device Manager, Passwort-Button

Login

Nach der Vergabe von Passworten und darauf folgendem automatischem LogOut ist z. B. zur Konfiguration eines Sensors ein Login nötig. Dazu in der Toolbar auf den Button mit Schlüsselsymbol klicken, um sich einzuloggen oder / und, nach erfolgter Passworteingabe, die Passworteingabe für die nächsten Sitzungen für die gewählte Benutzergruppe zu deaktivieren.

Wurde der Haken bei „Passwortabfrage deaktivieren" gesetzt, wird beim nächsten Start der Anwendung nicht mehr nach dem Passwort gefragt.

Abbildung: Vision Sensor Device Manager Login- Button


SBS – Bedien- und Konfigurationssoftware –Vision Sensor Configuration Studio, alle Funktionen

Mit diesem Programm können Sie Ihren SBS Vision Sensor in sechs Arbeitsschritten für eine oder mehrere Prüfaufgaben (Jobs) konfigurieren:

  • Jobs (Prüfaufgaben)
  • Lagenachführung
  • Detektoren
  • Ausgabe von Prüfergebnissen
  • Ergebnis
  • Start des Sensors

Weitere Programmfunktionen:

  • Trigger-Einstellungen
  • Verbindungsmodus- Umschalten zwischen Online- und Offline-Modus
  • Simulation von Jobs (Offline-Modus) von Prüfjobs anhand von Bilderserien (Filmstreifen)
  • Erstellen von Filmstreifen zu Analyse- oder Simulationszwecken.
    Die Ausführung von Vision Sensor Configuration Studio erfordert u.U. die Eingabe eines Passworts (Benutzergruppe: Administrator). Siehe hierzu : Benutzerverwaltung / Passworte
  • Archivierung Bildrekorder (auch via FTP / SMB)

Um auch ohne Trigger ein stetig aktualisiertes Livebild zu erhalten folgende Einstellungen vornehmen:

  • Freilauf einstellen unter "Job/Bildaufnahme"
  • Kontinuierlichh einstellen unter "Trigger / Bild holen" Programmoberfläche und Bedienung


Jobs (Prüfaufgaben)

Ein Job enthält sämtliche Einstellungen und Parameter, die zur Durchführung einer bestimmten Prüfaufgabe erforderlich sind.

Nächstes Thema: Erstellen, Bearbeiten und Verwalten von Jobs

Abbildung: Vision Sensor Configuration Studio Job


Erstellen, Bearbeiten und Verwalten von Jobs

Einen ausgewählten (in der Liste links unten markierten) Job können Sie durch Eingabe von Parametern in den Reitern des Konfigurationsfensters (rechts, unten) bearbeiten.

Nächstes Thema: Laden und Speichern von Job oder Jobsatz

Wenn kein Jobeintrag in der Liste vorhanden ist, müssen Sie zuerst einen neuen Job erstellen.

Neuen Job erstellen:

1. Klicken Sie auf den Button "Neu" unter der Job-Auswahlliste links unten. Ein neuer Jobeintrag erscheint in der Liste.

2. Editieren Sie den Eintrag durch Doppelklick auf das jeweilige Feld (Name, Beschreibung, Autor)

Weitere Funktionen:

Funktion | Beschreibung
Neu | Neuen Job definieren
Laden | Einen Job vom PC laden
Speichern | Den ausgewählten Job auf dem PC speichern
Löschen | Den ausgewählten Job aus der Liste löschen
Alle löschen | Alle Jobs in der Liste löschen

Alle beschriebenen Funktionen können Sie auch über das Datei-Menü ausführen.

Abbildung: Vision Sensor Configuration Studio Jobliste

Wenn die Kapazität des Sensorspeichers erschöpft ist und keine weiteren Jobs auf den Sensor geladen werden können, wechselt die Farbe der Restspeicheranzeige in der Statuszeile (unten) auf Rot.


Laden und Speichern von Job oder Jobsatz

Jobs können einzeln oder ein ganzer Satz von Jobs als Jobsatz geladen und gespeichert werden. Sind mehrere Jobs auf dem Sensor gespeichert, bilden diese einen Jobsatz, den Sie genau so wie einen einzelnen Job als XML-Datei auf Ihrem PC oder einem externen Speichermedium ablegen können.

Nächstes Thema: Bildaufnahme Parameter

Job / JobSet speichern:

Wählen Sie „Job speichern unter ...“, oder „Jobsatz speichern unter ...“ aus dem Datei-Menü.

Job / Jobsatz öffnen:

Wählen Sie „Job öffnen ...“, oder „Jobsatz öffnen“ ... aus dem Datei-Menü.

Mit dem Button "Starte Sensor" werden Jobs auf den Sensor übertagen.

Alle auf dem Sensor gespeicherten Jobs werden beim Laden eines neuen Jobsatzes gelöscht!

Abbildung: Vision Sensor Configuration Studio Jobs laden / speichern


Bildaufnahme Parameter

Im Reiter Bildaufnahme S. Kap. Jobs (Prüfaufgaben) bestimmen Sie die grundlegenden Parameter der Bildaufnahme.

Nächstes Thema: Vorverarbeitung, Filter zur Bildverbesserung

Die Bildschärfe wird mit der Focus- Einstellschraube an der Geräterückseite des SBS Vision Sensors eingestellt.

Parameter | Funktion und Einstellmöglichkeiten

Auflösung

Standardauflösung ist WVGA (736x480), bei zeitkritischen Anwendungen kann eine andere Auflösung gewählt werden.

Verfügbare Auflösungen:

R3B: WVGA (736x480), VGA (640x480), QVGA (320x240), QQVGA (160x120)

R3C: WVGA (736x480), VGA (640x480), QVGA (320x240)

R2B: XGA (1280x1024), VGA (640x480), QVGA (320x240)

R2C: XGA (1280x1024), VGA (640x480)

Bei Änderung der Auflösung werden alle bereits definierten Detektoren gelöscht!

Zoom (nur R2B)

Über die Auswahl verschiedener Zoom-Stufen können unterschiedliche Bildausschnitte mit unterschiedlichen Abbildungsgrößen erzielt werden.
Dynamik | Optimierung der Charakteristik der Bildaufnahme: "Linear" bedeutet lineare Kennlinie (verhalten wie bei SBS -Produkten, die keine dynamische Bildaufnahme unterstützen), "Hoch" bedeutet bessere Feinabstufung in hellen Bereichen des Bildes (Übersteuerung).

Triggermodus

Auswahlmöglichkeit, ob der SBS Vision Sensor im getriggerten Modus oder im Freilauf betrieben werden soll.

Im getriggerten Modus kann über den Triggereingang Pin 03 WH oder über eine der Schnittstellen eine Bildaufnahme ausgelöst werden.

Im Freilauf macht der SBS Vision Sensor kontinuierlich Bilder und Auswertungen.

Verschlusszeit

Parameter zur Steuerung der Bildhelligkeit. Die Bildhelligkeit sollte vorzugsweise mit der Verschlusszeit eingestellt werden. Erst im zweiten Schritt, wenn nötig, die Verstärkung einstellen (Grundeinstellung Verstärkung = 1). Bei bewegten Prüfobjekten kann eine längere Verschlusszeit zu Bewegungsunschärfe im Bild führen. Mit dem Button „Auto“ kann die Belichtung automatisch eingestellt werden. Die maximal am Schieberegler einstellbare Verschlusszeit ist auf 100 ms eingestellt. Jedoch ist zu beachten, dass die Dauer des internen Belichtungspulses auf 8 ms begrenzt ist. Verschlusszeiten länger als 8 ms machen also nur Sinn, wenn externe Beleuchtung oder interne + externe Beleuchtung verwendet werden.

Verstärkung

Parameter zur Steuerung der Bildhelligkeit. Die Bildhelligkeit sollte vorzugsweise mit der Verschlusszeit eingestellt werden, erst im zweiten Schritt wenn nötig die Verstärkung einstellen (Grundeinstellung Verstärkung = 1)

Quadranten Beleuchtung

Durch Klicken auf die Darstellung der LED können einzelne Quadranten der Beleuchtung abgeschaltet werden. Diese Funktion kann bei geringen Arbeitsabständen Reflexionen unterdrücken.

Interne Beleuchtung

Auswahl für interne Beleuchtung (Ein / Aus)

Externe Beleuchtung

Auswahl für externe Beleuchtung (Ein / Aus / Permanent), die externe Beleuchtung wird über Pin 09 RD geschaltet.

Um auch ohne Trigger ein stetig aktualisiertes Livebild zu erhalten, folgende Einstellungen (ggf. temporär) vornehmen:

Freilauf einstellen unter "Job/Bildaufnahme"

Kontinuierlich einstellen unter "Trigger/Bildaktualisierung" (links, halbe Höhe)


Weißabgleich

Der Weißabgleich dient der Kompensation eines eventuellen Farbstiches im Bild durch Lichtverhältnisse oder Kamerachip.

Abbildung: Weißabgleich

Parameter | Funktion
Rot | Prozentuale Gewichtung der Rot-Kanals (0-100)
Grün | Prozentuale Gewichtung der Grün-Kanals (0-100)
Blau | Prozentuale Gewichtung der Blau-Kanals (0-100)
Einlernen | Durchführung des Weißabgleichs, für den Weißabgleich ist eine weiße oder leichtgraue Fläche unter der Kamera zu positionieren
Rücksetzen | Werte zurück setzen


Vorverarbeitung, Filter zur Bildverbesserung

Im Reiter Filter können Sie die vom Sensor aufgenommenen Bilder vor der Auswertung filtern oder neu anordnen.

  • Es können bis zu 5 Filter aktiviert werden, die in der angegebenen Reihenfolge ausgeführt werden.
  • Alle Detektoren (Lagenachführung und Standard-Detektoren) werden auf dem vorverarbeiteten Bild arbeiten, nicht auf dem Originalbild.
  • Insbesondere mit den morphologischen Operatoren (Dilatation und Erosion) können auch in Kombination Verbesserungen des Bildes erreicht werden, z.B. durch Nacheinanderausführung von Erosion und Dilatation oder umgekehrt.

Nächstes Thema: Kalibrierung, Kalibriermethode auswählen

Beispiel: Schwarze, punktförmige Störungen vor hellem Hintergrund lassen sich eliminieren, wenn Dilatation und Erosion aufeinander folgen.

Folgende Anordnungsfilter stehen zur Verfügung:

Anordnung Typ | Effekt
Rotation 180° | Rotation des Bildes um 180°
Spiegelung horizontal | Horizontale Spiegelung des Bildes
Spiegelung vertikal | Vertikale Spiegelung des Bildes

Folgende Filter für die Bildverbesserung stehen zur Verfügung:

Filtertyp | Effekt

Gauss

Das Bild wird mit einem Gauss- Filter geglättet, zur Reduktion von Rauschen, Unterdrückung störender Details und Artefakte und Glättung von Kanten.

Erosion

Ausweitung dunkler Bereiche, Eliminierung heller Pixel in dunklen Bereichen, Elimination von Artekfakten, Trennung von hellen Objekten. Wirkung: Jeder Grauwert wird durch den minimalen Grauwert innerhalb der Filtermaske (z.B. 3x3 Filtermaske) ersetzt.

Dilation

Ausweitung heller Bereiche, Eliminierung dunkler Pixel in hellen Bereichen, Elimination von Artekfakten, Trennung von dunklen Objekten. Wirkung: Jeder Grauwert wird durch den maximalen Grauwert innerhalb der Filtermaske (z.B. 3x3 Filtermaske) ersetzt.

Median

Jeder Grauwert wird ersetzt durch den Median- Wert der Pixel, die in der Filtermaske gefunden werden (z.B. 3x3). Typische Abwendung: Glättung des Bildes, Unterdrückung von Bildrauschen, speziell von lokalen hellen oder dunklen Bereichen/Pixeln (Salz- und Pfeffer- Rauschen)

Mittelwert

Jeder Grauwert wird ersetzt durch den Mittelwert der Pixel, die in der Filtermaske gefunden werden (z.B. 3x3). Typische Anwendung: Glättung des Bildes, Unterdrückung von Störungen und Bildrauschen.

Amplitude

Jeder Grauwert wird ersetzt durch den Bereichs- Wert (Maximaler Grauwert - Minimaler Grauwert) der Pixel, die in der Filtermaske gefunden werden (z.B. 3x3).
Typische Anwendungen: Detektion und Verbesserung von Kanten und Verbesserung von lokalem Bildkontrast. (ab Firmware 1.5.X.X)
Standardabweichung

Jeder Grauwert wird ersetzt durch die Standardabweichung der Pixel, die in der Filtermaske gefunden werden (z.B. 3x3).
Typische Anwendungen: Hervorheben von Oberflächendefekten oder Kanten.

Kantenfilter (Sobel)

Das gefilterte Bild enthält Kanten, die durch die Anwendung des Sobel- Algorithmus gefunden wurden (vergleiche auch Literatur zur Bildverarbeitung).

Typische Anwendungen: Detektion und Verbesserung von Kanten, Verbesserung von lokalem Kontrast und Erkennung von Oberflächendefekten.

Multiplikation | Der Grauwert jedes Bildpixels wird multipliziert mit dem ausgewählten Multiplikator. (2x, 4x, 8x, ...). Der Wertebereich ist begrenzt auf 255.
Invertierung | Invertierung der Bildpixel / Grauwerte

Die Wirkung eines aktivierten Filters ist unmittelbar im Bild erkennbar. Je größer der Filterkern gewählt wird, umso stärker ist die Filterwirkung. Die Reihenfolge der Anwendung der Filter ist mit der Reihenfolge von oben nach unten identisch.

Filter konfigurieren:

1. Wählen Sie die Filter in der gewünschten Reihenfolge über die Ausklappmenüs in der Spalte Filter.

2. Geben Sie die Größe des Filterkerns in den Ausklappmenüs in der Spalte Wert ein. Bei Einstellung „Aus“ wird der betreffende Filter deaktiviert.

Abbildung: Reiter Job / Filter


Kalibrierung, Kalibriermethode auswählen

Die Kalibrierung dient zur Umrechnung von Bild-Koordinaten (Pixel) in Welt-Koordinaten (z.B. Milllimeter). Bei Nutzung dieser Funktion, werden alle Koordinatenausgaben, (Positionen und Messergebnisse) in der gewählten Einheit berechnet und ausgegeben.

Nächstes Thema: Kalibrierung, Skalierung

Kalibriermethoden

Skalierung (Messen) | Relative Vermessung, limitierte Genauigkeit (Messen, Prüfen, Koordinatenursprung = linke, obere Ecke des Sichtfeldes).
Punktpaarliste (Roboter/ Pick and Place) | Absolute Vermessung, beliebiges Bezugssystem (Roboterkalibrierung, Koordinatenursprung des Roboters)
Kalibrierplatte (Messen) | Relative Vermessung, hohe Genauigkeit (Messen, Prüfen, Koordinatenursprung = linke, obere Ecke des Sichtfeldes).
Einheit | Gewünschte Einheit für Weltkoordinaten
">" / "<" | Zum nächsten, letzten Eingabeschritt wechseln

Hinweis: Es werden alle Ergebniswerte für Positionen und Messergebnisse korrigiert. Um die Zykluszeit nicht zu belasten, d.h. zu verlängern, werden die Bilddaten jedoch nicht umgerechnet bzw. entzerrt dargestellt! So ist, auch mit aktiver Kalibrierung, eine hohe Ausführungsgeschwindigkeit gewährleistet.

Die Aktivierung der Kalibrierung erfolgt in zwei Schritten:

1. Auswahl der Kalibriermethode

Wechsel mit den Tasten [<], [>] zum nächsten / letzten Schritt

2. Durchführung der gewählten Kalibriermethode

Sobald eine Kalibriermethode ausgewählt ist wird links neben dem Tab-Titel "Kalibrierung" die Status-LED angezeigt. Ist die Kalibrierung aktiv, so werden alle Funktionen, z.B. Detektoren, nur dann korrekt ausgeführt wenn die Kalibrierung gültig ist, d.h erfolgreich ausgeführt werden konnte.

Bedeutung der Farben: Punkten in Bild, und in Punktpaarliste:

Farbe | Bedeutung
Grün | Kalibrierung gültig, Punkte exakt positioniert
Gelb | Kalibrierung gültig, Punkte nicht exakt positioniert
Rot | keine gültige Kalibrierung

Bedeutung der Farben: Bei den einzelnen Kalibriermethoden

Kalibriermethode | Bedeutung
Skalierung | Status-LED = grün: Default- oder Eingabewerte ergeben den Skalierfaktor, keine Fehlerberechnung möglich.
Punktpaarliste | Status-LED, Punkte im Bild und entsprechende Zeile(n) in Punktpaarliste: - grün: gültige Kalibrierung, Punkte exakt positioniert - gelb: gültige Kalibrierung, Punkte nicht exakt positioniert - rot: keine gültige Kalibrierung Bei neuem Job: - grün: Defaultwerte (6 Punkte) ergeben korrekte Defaultkalibrierung
Kaibrierplatte | Status-LED: - grün: gültige Kalibrierung - rot: keine gültige Kalibrierung Bei neuem Job: - rot: da noch keine Kalibrierung mit Kalibrierplatte erfolgt.

Abbildung: Kalibriermethode auswählen

Detailbeschreibung

Methode Funktion und Einstellmöglichkeiten

Keine

Kalibrierung nicht aktiv, Koordinaten -Ermittlung, .-Anzeige und -Ausgabe in Pixel (px)

Skalierung (Messen)

(Relative Vermessung von z.B. Abständen in Weltkoordinaten)

Die Kalibriermethode "Skalierung" dient zur relativen Bestimmung von z.B. Abständen in Weltkoordinaten (z.B. mm). Dies geschieht hier über einen einfachem Verhältnisfaktor. Es wird ein Faktor für beide Koordinatenachsen X und Y bestimmt.

Das hat den Vorteil der sehr einfachen Anwendung, die Genauigkeit ist dabei limitiert.

Verzerrungen durch schrägen Blickwinkel und durch Linsenverzeichnung werden bei dieser Methode nicht korrigiert.

Weltkoordinaten sind nicht absolut, Koordinatenwerte beziehen sich auf Nullpunkt in der linken, oberen Ecke des Sichtfeldes.

Beispiel: Ermittlung des Abstands zwischen zwei Objekten in mm. (limitierte Genauigkeit)

Punktpaarliste

(Roboter / Pick and Place)
(Absolute Vermessung in Weltkoordinaten, in beliebigem Bezugssystem z.B. Roboterkoordinatensystem)

Die Kalibriermethode "Punktpaarliste" dient zur Bestimmung absoluter Positionen in Weltkoordinaten (z.B. mm).

Dabei werden die Skalierung in x und y getrennt, die Verkippung des Sensors ggü. der Sichtfeldebene, und die Linsenverzeichnung korrigiert.

Beispiel: Absolute Position von Objekten in Weltkoordinaten (z.B. Roboterkoordinatensystem), in Millimeter ermitteln.

Dies geschieht hier über die Bildaufnahme eines zuvor, z.B. von einem Roboter, im Sichtfeld platzierten Kalibrierteiles.

Dabei wird je Punktepaar die

- Bildkoordinate durch grafische Eingabe im Bild oder numerische Eingabe ermittelt, und die

- Weltkoordinate von z.B. der Robotersteuerung übertragen und numerisch eingegeben.

Dieser Ablauf wird so oft durchgeführt bis die gewünschte Anzahl an Punktepaaren in der Liste eingetragen ist.

Kalibrierplatte
(Messen)

(Relative Vermessung von z.B. Abständen in Weltkoordinaten)

Die Kalibriermethode "Kalibrierplatte" dient zur relativen Bestimmung von z.B. Abständen in Weltkoordinaten (z.B. mm). Dies geschieht über die Bildaufnahme einer Kalibrierplatte. Durch die hohe Punktanzahl und die bekannte genaue, relative Lage der Punkte auf der Platte zueinander, liefert diese Methode eine hohe Genauigkeit.

Dabei werden die Skalierung in x und y getrennt, die Verkippung des Sensors ggü. der Sichtfeldebene, und die Linsenverzeichnung korrigiert.

Die Weltkoordinaten sind nicht absolut, die Koordinatenwerte beziehen sich auf den Nullpunkt in der linken, oberen Ecke des Sichtfeldes.
Neben Koordinaten werden auch Distanzen umgerechnet.

Beispiel: Ermittlung des Abstands zwischen zwei Objekten in mm. (hohe Genauigkeit)
Einheit

Einheit der Welt-Koordinaten / Distanzen.

- mm (Millimeter)

- cm (Zentimeter)

- m (Meter)

- in (Inch / Zoll)
">" / "<" Zum nächsten, letzten Eingabeschritt wechseln

Die Kalibrierung wirkt auf folgende Detektoren / Lagenachführungen

Detektor | Ergebniswert
Kontur | Zentrumskoordinaten x, y, Winkel
Mustervergleich | Zentrumskoordinaten x, y, Winkel
Messschieber | Zentrumskoordinaten x, y, Abstand
BLOB | Schwerpunkt-/ Zentrumskoordinaten x, y; Breite, Höhe, Winkel
Lagenachführung | Ergebniswert
Kontur | Zentrumskoordinaten x, y, Winkel
Mustervergleich | Zentrumskoordinaten x, y, Winkel
Kantenantastung | Zentrumskoordinaten x, y

Nächstes Thema: Zeitverhalten Parameter


Kalibrierung, Skalierung

Die Kalibriermethode "Skalierung" dient zur relativen Bestimmung, von z.B. Abständen in Weltkoordinaten (z.B. mm). Dies geschieht hier über einen einfachem Verhältnisfaktor für beide Koordinatenachsen X und Y. Die Methode ist sehr einfach anwenbar, die Genauigkeit ist jedoch limitiert, da keine Korrektur von Verzerrungen und Verzeichnung vorgenommen wird.

Nächstes Thema: Kalibrierung, Punktpaarliste

Abbildung: Kalibriermethode Skalierung

Beispiel: Ermittlung des Abstandes zwischen zwei Objekten in Millimeter.

Parameter Skalierung

Parameter | Funktion
Distanz Bild | Distanz im Bild in Pixel (px), durch grafische Eingabe bzw Werteeingabe.
Distanz Welt | Entsprechende Distanz in Welt, durch Werteeingabe (in zuvor festgelegter Einheit z.B. mm)
Skalierfaktor | Aus o.g. Einstellungen "Distanz Bild" und "Distanz Welt" resultierende Skalierfaktoren z.B. [x] px/mm bzw. [y] mm/px
Punkt testen | Es kann ein Testpunkt (grafisch oder Werteeingabe) im Bild gesetzt werden, dessen Koordinaten in Weltkoordinaten zur Kontrolle der Skalierung im Testpunktfenster angezeigt werden, Koordinatenursprung: linke, obere Ecke des Sichtfeldes.
">" / "<" | Zum nächsten / vorherigen Eingabeschritt wechseln

Hinweise:

Es ist darauf zu achten, dass der Sensor möglichst senkrecht auf die Sichtfeldebene ausgerichtet ist, um zu stark unterschiedliche Verzerrungen in den beiden Achsen X und Y zu vermeiden. Verzerrung durch schrägen Blickwinkel und durch Linsenverzeichnung werden bei dieser Methode nicht korrigiert.

Zur Parametrierung ein Objekt mit bekannter Ausdehnung (z.B. Endmaß) im Bild platzieren.
Die beiden grafischen (grünen) Fadenkreuze im Bild auf die Punkte mit der genau bekannten Distanz positionieren. Der Abstand in Bildpixel zwischen den beiden Mittelpunkten wird im Feld "Distanz Bild" angezeigt.
Nun den bekannten Welt-Abstand im Feld "Distanz Welt" eintragen (z.B. in mm).
Der Skalierfaktor wird nun berechnet und angezeigt. Ab sofort werden nun Positionen und Abstände in Weltkoordinaten / z.B. mm angezeigt und ausgegeben.

Weltkoordinaten sind nicht absolut, Koordinatenwerte beziehen sich auf den Nullpunkt in der linken, oberen Ecke des Sichtfeldes. Neben Koordinaten werden auch Distanzen umgerechnet.

Diese Art der Kalibrierung ist für Standardobjektive, integriert oder C-Mount, geeignet. D.h. nicht für telezentrische Objektive!


Kalibrierung, Punktpaarliste

Die Kalibriermethode "Punktpaarliste" dient zur Bestimmung absoluter Positionen in Weltkoordinaten (z.B. mm).

Nächstes Thema: Kalibrierung, Kalibrierplatte

Abbildung: Kalibriermethode Punktpaarliste

Beispiel: Absolute Position (und Orientierung) von Objekten in Weltkoordinaten (z.B. Roboterkoordinatensystem) ermitteln.

Motivation / Nutzen

Nach der Kalibrierung des Sensors via Punktpaarliste liegt die Position des vom Roboter zu greifenden Teiles direkt im absoluten Koordinatensystem des Roboters vor!
Dabei wurden sämtliche Fehler wie Verzerrung und Verzeichnung korrigiert. In Pick and Place Anwendungen kann der Roboter nun also mit den vom Sensor gelieferten Positionsdaten direkt in seinem Koordinatensystem verfahren und das Teil greifen!

Abbildung: Position des zu greifenden Teiles direkt im Roboterkoordinatensystem!

Ablauf zur Kalibrierung mit der Punktpaarliste

Vorab müssen Bildschärfe und Helligkeit eingestellt, und die gewünschte Einheit muss ausgewählt worden sein.

1. Kalibriermodell (-mit/ohne Korrektur der Linsenverzeichnung) auswählen, und ggf. z-Offset einstellen.

2. Zeile 1 in Listbox "Punktpaarliste" auswählen.

3. Kalibrierteil (vorzugsweise flach, symmetrisch, z.B. ähnlich Beilagscheibe) an genau bekannter Weltkoordinate im Sichtfeld platzieren (z.B. mit Roboter).

4. Fadenkreuz (Nr. "n" zu entsprechender Zeile "n" in Punktpaarliste) exakt im Zentrum des o.g. Kalibrierobjektes grafisch positionieren. Dazu das Bild ggf. zoomen.
Alternativ: per "Snap- Funktion", d.h. Rechtsklick irgendwo innerhalb des Kalibrierobjektes. Dabei wird der Schwerpunkt des Kalibierobjekts automatisch bestimmt.
Vorzugsweise punktsymmetrische Kalibrierobjekte verwenden, da dann der Schwerpunkt unabhängig ist von der Orientierung. Bzw. bei nicht punktsymmetrsichen Kalibrierobjekten auf immer gleiche Orientierung bei der Positionierung achten! (nicht verfügbar bei Farbsensoren)
Ergebnis: Pixelwerte für Bildkoordinaten "Bild X" und "Bild Y" sind automatisch in Zeile "n" eingetragen.

5. Nun im Feld "Welt X" und "Welt Y" die entsprechenden, bekannten Weltkoordinatenwerte (bei z.B. Roboter: die Werte von der Robotersteuerung) eintragen.

6. Schritte 2-5 so lange wiederholen, bis die gewünschte Anzahl an Punktepaaren eingegeben wurde. Ggf. mit "+" weitere Zeilen anlegen bzw. mit "-" löschen. (mind, 6 Punkte, empfohlen >10 Punkte)

Automatisierter Ablauf via Schnittstellen Kommandos: Kalibrierung mit Schnittstellen-Kommandos

Parameter Punktpaarliste

Methode | Funktion und Einstellmöglichkeiten

- Bild X

- Bild Y

Werte in Punktliste

Koordinatenwerte in Pixel (px) im Bild, über die exakte grafische Positonierung des Fadenkreuzes auf den Mittelpunkt des in Weltkoordinaten genau platzierten Kalibrierteils.

Oder, per "Snap- Funktion": rechter Mausklick irgendwo innerhalb des symmetrischen Kalibrierobjekts, kann die genaue Mittenposition auch automatisch bestimmt werden (empfohlen).

Hinweis:
Die Snap- Funktion ist nicht verfürgbar bei Farbsensoren.

- Welt X

- Welt Y

Werte in Punktliste

Koordinatenwerte in Welt in gewählter Einheit (z.B. mm), durch direkte Wert- Eingabe in Punktelliste.

Diese Werte sind im Falle von z.B. Pick&Place / Roboter die X- / Y- Koordinatenwerte, die von der Robotersteuerung bei Ablage des Kalibirerteiles /Anfahren des entsprechenden Punktes, abglesen und in die Punkteliste übertragen werden können.

Kalibrierparameter

Kalibriermodell:
Mit oder ohne Korrektur der Linsenverzeichnung.

Z- Offset: (falls Offset gegeben)

Offset zwischen Kalibrier- und Messebene eingeben

Verschiedene Ausgabeparameter

der Ausgleichsrechnung sowie Fehlerkenngrößen. s. Kalibrierung, Kalibrierparameter
"+" / "-" Eine Zeile / Listenpunkt hinzufügen oder löschen. Löschen wirkt auf die jeweils markierte Zeile
Punkt testen | Es kann ein Testpunkt im Bild gesetzt werden, dessen Koordinaten in Weltkoordinaten zur Kontrolle / Plausibilitätstest der Kalibrierung im Testpunkt- Fenster angezeigt werden.
">" / "<" Zum nächsten / vorherigen Eingabeschritt wechseln

Hinweise:

Der Sensor kann in beliebiger Ausrichtung (Pose) in Bezug auf die Messebene montiert werden (wobei eine möglichst senkrechte Ausrichtung zur Messebene weniger Korrektur erfordert, und damit grundsätzlich vorteilhafter ist).

Die Genauigkeit hängt vor allem von der hohen Güte und zweitens von der ausreichenden Anzahl der Kalibierpunkte ab. Die Genauigkeit kann durch eine hohe Güte (hohe Präzsion bei der Positionseingabe) der einzelnen Punkte optimiert werden, wenn z.B. einige Punkte in gelber Farbe dargestellt werden.

Diese Art der Kalibrierung ist für Standardobjektive, integriert oder C-Mount, geeignet. D.h. nicht für telezentrische Objektive!

Minimalanforderung an die Anzahl der Punktpaare ist "6" Punkte.

Die minimal benötigte Punkteanzahl bei der Kalibrierung via Punktpaarliste ist 6 Punkte! Ab dieser Punkteanzahl können Fehleingabe (etwa x und y vertauscht etc.) durch hohe Fehlerwerte im Dialog "Kalibrierparameter" Kalibrierung, Kalibrierparameter aufgedekt werden. (ab <= 5 Punte sind die Fehlerwerte immer = 0, da keine Fehlerrechnung möglich).

Die eingebenen Punkte werden zur Anzeige der Positions-Güte d.h. wie gut diese mit der per Ausgleichsrechnung ermittelten Position übereinstimmen, in folgenden Farben dargestellt (erst ab Mindestanzahl "6" Punkten sinnvoll nutzbar).

Bedeutung der Farben der Punkten in Bild und in der Punktpaarliste:

Farbe | Bedeutung
Grün | Kalibrierung gültig, Punkte exakt positioniert
Gelb | Kalibrierung gültig, Punkte nicht exakt positioniert
Rot | keine gültige Kalibrierung

Die im Falle von gelber Darstellung sichbare Linie aus dem Punktzentrum heraus, ist ein Maß für Richtung und Betrag des Fehlers in Bezug auf die erziele Positionsgenauigkeit der Punkteingabe in realer Welt.

Sind die Fehler hier groß, sind ggf. bei ein oder mehreren Punkten die x- und y- Werte, oder ganze Punktepaare in Bild und Welt vertauscht. .

Im Dialog "Kalibrierparameter"Kalibrierung, Kalibrierparameter werden die Abweichungswerte / Fehler: "Mittelwert", "Min"imaler Fehler und "Max"imaler Fehler angezeigt. Ggf. mit diesen Werten die exakte Positionseingabe der bestehenden Punkte optimieren.

Diese Methode liefert neben den reinen absoluten Koordinatenwerten auch die Orientierung des zu greifenden Teiles, (sofern ein entsprechender Detektor, z.B. Kontur oder Mustervergleich, verwendet wird).

Die Ergebniskoordinaten z.B. des zu greifenden Teiles liegen direkt im Bezugssystem, z.B. des Roboters vor!


Kalibrierung, Kalibrierparameter

Hier werden die Kalibrier-, sowie Abweichungsparameter zur eventuell gewünschten Optimierung angezeigt. Ausserdem kann hier ggf. der Z-Versatz der Kalibrier- ggü. der Messebene eingegeben und somit kompensiert werden.

Beim hier verwendeten Kalibriermodell werden Standardobjektive, integriert oder C-Mount beachtet. Für z.B. telezentrische Objektive ist diese Art der Kalibrierung nicht geeignet!

Nächstes Thema: Kalibrierung mit Schnittstellen-Kommandos

Abbildung: Kalibrierung, Kalibrierung Parameter

Parameter | Funktion

Kalibriermodell.

Standardobjektiv, mit Linsenverzeichnung

Korrektur von:

- Skalierung, X und Y getrennt

- Verzerrung durch Verkippung des Sensors ggü. der Sichtfeldebene

- Korrektur der Linsenverzeichnung
Eingabeparameter

Versatz Kalibrierebene ggü. Messebene in Z- Richtung

Für Z=0 sind Kalibrier- und Messebene identisch. Für Z!=0 verschiebt sich die Kalibrier- gegenüber der Messebene, wobei die Ebenen stets parallel sind. Das Vorzeichen der Verschiebung ergibt aus der Z-Richtung des rechtshändigen Weltsystems (Daumen = x, Zeigefinger = y, Mittelfinger = z).

Hinweis:

Der Schärfentiefebereich des Sensor muss dabei die Mess- und die Kalibrierebene abdecken! s. Kalibrierung, Kalibrierparameter
Fokus

Fokus / Brennweite des Objektivs

  • Bei intergriertem Objektiv: Wert wird entsprechend dem intern verbauten Objektiv automatisch eingetragen
  • Bei C-Mount Objektiv: Wert von verwendetem Objektiv ablesen und eintragen. Optional: zur Plausibilitätskontrolle etwa des Z- Wertes bei u.g. "Translation des Kalibrierobjekts", kein Fehlfunktion falls nicht genutzt!
Anzeigeparameter (read only)
Kappa (x10E-6) | Berechneter Kappawert des Objektives, Anzeige in "Mikro-Kappa"
Pixelabstand | Berechnetes Raster / Achsabstand von Pixel zu Pixel auf dem Sensor. Verringerung der Auflösung im Tab „Bildaufnahme“ wirkt sich auf diesen Parameter aus.
Koordiantenursprung / Pixel | Durchstichpunkt der optischen Achse die durch Messebene im Zentrum des Sensorchips, ggü. idealem Zentrum, in Bezug auf linke, obere Ecke in Pixel.
Bildgröße | Bildgröße in Pixel
Translation des Kalibrierobjekts | Alle drei berechneten Werte für die Translation des Kalibrierobjekts, d.h. in X-, Y- und Z- Richtung
Rotation des Kalibrierobjekts | Alle drei berechneten Werte für die Rotation des Kalibrierobjekts, d.h. die Winkel Alpha, Beta und Gamma
Abweichungen
Mittelwert | Mittlerer Fehler der berechneten Positionen ggü. der Eingabe
Min. | Maximaler Fehler der berechneten Positionen ggü. der Eingabe
Max. | Minimaler Fehler der berechneten Positionen ggü. der Eingabe

Versatz Kalibrierebene ggü. Messebene in Z- Richtung

Vorzeichen des "Z"-Werts, abhängig von Ausrichtung des Weltkoordinatensystems / rechtshändigen Weltsystems (Daumen = x, Zeigefinger = y, MIttelfinger = z, s.u. ).

Abbildung: Delta "D" / Z-Offset = negativ! Falls Z-Richtung nach oben, und Kalibrierebene tiefer als Messebene!

Abbildung: Delta "D" / Z-Offset = positiv! Falls Z-Richtung nach oben, und Kalibrierebene höher als Messebene!

Abbildung: Delta "D" / Z-Offset = positiv! Falls Z-Richtung nach unten, und Kalibrierebene tiefer als Messebene!

Abbildung: Delta "D" / Z-Offset = negativ! Falls Z-Richtung nach unten, und Kalibrierebene höher als Messebene!


Kalibrierung mit Schnittstellen-Kommandos

Mittels spezieller Schnittstellen-Kommandos zur automatisierten Erzeugung der Punktpaarliste, etwa zur Re- Kalibrierung bei Prozessdrift oder Verstellungen an der Sensor- oder Robotermontage, kann der Kalibrierablauf via Punktpaarliste automatisiert z.B. von der Robotersteuerung aus ausgeführt werden.

Beispiel: Als Kalibrierobjekt dient ein kreisförmiges Blechteil, das mit einem BLOB Detektor erkannt wird, der den Kreismittelpunkt / Schwerpunkt findet. Zur korrekten Ausführung der Schnittstellen-Kommandos auf dem Sensor muss die Schnittstelle zur Steuerung, z.B. Ethernet, aktiviert, und als Ausgabedaten müssen der X- und Y- Wert der Findekoordinate als ersten und zweiten Wert definiert sein.

Ablauf zur automatierten (Re-) Kalibrierung mit Schnittstellen-Kommandos via
Punktpaarliste

Szenario

1. Separater Job zur Detektion des Kalibrierteils (hier "Job 1")

Kontur Detektor, der den Schwerpunkt des kreisförmigen Kalibrierteils findet. Als erster und zweiter Wert in den Ethernet- Datenausgabe sind der X- und der Y-Wert des gefundenen Kreismittelpunktes definiert.

2. Zu kalibrierender Job (hier "Job2")

Der Sensor befindet sich in diesem Job. Es ist Job/Kalibrierung/Punktpaarliste eingestellt, und der Sensor wurde mit diesem Job gestartet

Ablauf / Flussdiagramm

Abbildung: Automatisierter Ablauf zur Kalibrierung via Punktpaarliste

Die Telegrammbeschreibung ist zu finden unter: Serielle Kommunikation ASCII

Über die hier verwendeten Telegramme "Trigger / TRG", "Calibration Add Point / CAP" und "Calibration Calibrate / CCL" hinaus, sind die folgenden Telegramme verfügbar:

- "Calibration Clear Data / CCD": Rücksetzen aller Werte in der Punktpaarliste

- "Calibration Validate / CVL": Validierung der Kalibrierung, ohne die gültige Kalibrierung zu verändern.


Kalibrierung, Kalibrierplatte

Die Kalibriermethode "Kalibrierplatte" dient zur relativen Bestimmung von z.B. Abständen in Weltkoordinaten (z.B. mm). Dies geschieht über die Bildaufnahme einer Kalibrierplatte mit einem einzigen Klick.

Abbildung: Kalibriermethode Kalibrierplatte

Beispiel: Ermittlung des Abstands zwischen zwei Objekten in mm (hohe Genauigkeit).

Ablauf Kalibrierung mittels Kalibrierplatte

Vorab müssen Bildschärfe und Helligkeit eingestellt sein, und die gewünschte Einheit muss ausgewählt worden sein.

1. Kalibriermodell (mit / ohne Korrektur der Linsenverzeichnung) auswählen, und ggf. z-Offset einstellen.

2. Kalibrierplatte möglichst formatfüllend im Sichtfeld platzieren (s. dazu auch "Hinweise zur optimierten Nutzung der Kalibrierplatte / Randbedingungen" und "Typen / Größen von Kalibrierplatten" Kalibrierung, Kalibrierplatte).

3. In der Auswahlbox "Kalibrierplatte" die o.g., entsprechende Kalibrierplatte (Größe und Typ) auswählen.

4. Mit Klick auf den Button "Starte Kalibrierung" werden alle sichtbaren Punkte der Kalibirerplatte bestimmt, alle erkannten markiert, und die Kalibrierung berechnet.

Parameter Kalibrierplatte

Parameter | Funktion
Kalibrierplatte | Hier wird die verwendete Kalibrierplatte (Größe/ Typ) ausgewählt. (s. dazu auch "Hinweise zur optimierten Nutzung der Kalibrierplatte / Randbedingungen" und "Typen / Größen von Kalibrierplatten" Kalibrierung, Kalibrierplatte).
Kalibrierparameter | Kalibriermodell: mit oder ohne Korrektur der Linsenverzeichnung. Hier wird ausserdem ggf. der z- Offset zwischen Kalibrier- und Messebene eingegeben. Und verschiedene Ausgabeparameter sowie Fehler- / Optimierungskenngrößen angezeigt. Siehe: Kalibrierung, Kalibrierparameter
Starte Kalibrierung | Kalibriervorgang wird ausgelöst. Alle sichtbaren Punkte der Kalibirerplatte werden bestimmt, alle erkannten markiert und die Kalibrierung berechnet.
Punkt testen | Es kann ein Testpunkt im Bild gesetzt werden dessen Koordinaten in Weltkoordinaten zur Kontrolle / Plausibilitätstest der Kalibrierungder Skalierung im Testpunkt- Fenster angezeigt werden.
">" / "<" | Zum nächsten / vorherigen Eingabeschritt wechseln

Hinweise:

Der Sensor kann in beliebiger Ausrichtung (Pose) in Bezug auf die Messebene montiert werden (wobei eine möglichst senkrechte Ausrichtung zur Messebene weniger Korrektur erfordert und damit vorteilhaft ist). Es werden die Skalierung, in X und Y, die Verkippung des Sensors ggü. der Sichtfeldebene, und die Linsenverzeichnung (je nach gewähltem Kalibrierkorrigiert.

Die Weltkoordinaten sind nicht absolut, die Koordinatenwerte beziehen sich auf den Nullpunkt, in linker, oberer Ecke des Sichtfeldes. Neben Koordinaten werden auch Distanzen umgerechnet.

Diese Art der Kalibrierung ist für Standardobjektive, integriert oder C-Mount, geeignet. D.h. nicht für telezentrische Objektive!

Normierung: Unabhängig von Position und Ausrichtung in der die Kalibrierplatte erfasst wird, liegt bei dieser Kalibriermethode der Koordinatenursprung immer in der linken oberen Ecke des Sichtfeldes (Bild und Welt). Die Null-Grad-Richtung und die positive X- Achse zeigen nach Ost.

Hinweise zur optimierten Nutzung der Kalibrierplatte / Randbedingungen

  • Die Kalibrierplatte muss sauber und eben sein.
  • Die Ausleuchtung der Platte sollte über im gesamten Sichtfeld homogen und die nicht überbelichtet sein. Die hellen Bereiche sollten einen Grauwert von mindestens 100 aufweisen und alle unter dem Wert 255 liegen. Der Kontrast zwischen hellen und dunklen Bereichen sollte mind. 100 Grauwerte betragen.
    D.h. das Bild darf weder komplett noch bereichsweise, überbelichtet noch unterbelichtet sein.
  • Der gesamte Sichtbereich sollte von der Kalibrierplatte abgedeckt sein. Dabei muss für eine erfolgreiche, präzise Kalibrierung nicht die gesamte Platte sichtbar sein. Es ist ausreichend wenn ca. ein Viertel der Platte, (immer inklusive des Zentrums der Platte, mit den kleinen schwarzen Punkten in der Mitte der weißen Punke) wie unten dargestellt, sichtbar sind.
  • Nach erfolgter Kalibrierung darf die Fokusierung und die Position des Sensors zur Messebene nicht mehr verändert werden.

Abbildung: Kalibrierplatte, Rot = minimales Sichtfeld, d. h. mind. 2x blaue Bereiche im Bild.

Abbildung: Kalibrierplatte, Ausschnitt mit schwarzen Punkten im Zentrum (blaue Bereiche s.o.)

  • Der Durchmesser eines weißen Kreises sollte mindestens 20 Pixel betragen.

Typen / Größen von Kalibrierplatten

Kalibrierplattengrößen | Punkteanzahl
50mm x 50mm | 15 x 13
100mm x 100mm | 15 x 13
200mm x 200mm | 15 x 13

Im Installationsverzeichnis: FESTO/SBS Vision Sensor/Dokumentation/... sind die verfügbaren Kalibrierplatten als .pdf-Datei zu finden. Diese können auf Papier oder auf ein anderes Medium gedruckt / flach aufgebracht werden. Beim Ausdruck die Einstellung "Tatsächliche Größe" verwenden, und darauf achten, dass der Druck nicht skaliert wird. Die Kantenlänge / Beschriftung der Platte muss dem Namen der Platte bei der Auswahl in der Software entsprechen.


Zeitverhalten Parameter

Im Reiter Zeitverhalten bestimmen Sie das Zeitverhalten des SBS .

Nächstes Thema: Lagenachführung

Parameter | Funktion und Einstellmöglichkeiten

Max. Zykluszeit

Parameter zur Steuerung der Ausführungszeit eines Zyklus. Innerhalb eines Zyklus können mehrere Bilder ausgewertet werden (im Falle "Anzahl Bilder" > 1).

Die maximale Ausführungszeit dient zum Abbruch eines Zyklus nach einer definierten Zeit. Das Ergebnis des Zyklus ist nach Abbruch immer "nicht o.k.". Die maximale Zykluszeit sollte immer größer gewählt werden als der Zeitbedarf für eine komplette Auswertung.

Die Zykluszeit misst die Zeit vom Trigger bis zum Setzen der digitalen Schaltausgänge. Soll die Zykluszeit begrenzt werden, z.B. weil der Maschinentakt nicht überschritten werden darf, muss der Wert für die maximale Zykluszeit entsprechend begrenzt werden. Das Ergebnis aller bis zu diesem Zeitpunkt nicht fertig ausgeführten Detektoren wird auf fehlerhaft gesetzt. Bei der Wahl der maximalen Zykluszeit ist zu berücksichtigen, dass diese nicht hart eingehalten wird, sondern in Abhängigkeit des gerade ausgeführten Detektors etliche weitere Millisekunden bis zum Abbruch verstreichen können. Es wird empfohlen, diese Überschreitung der maximalen Zykluszeit anhand der tatsächlichen Ausführungszeit zu überprüfen und den eingestellten Wert für die maximale Zykluszeit entsprechend zu verkleinern.
Max. Bearbeitungszeit pro Bild | Maximale Dauer einer Auswertung innerhalb des Zyklus inkl. Bildaufnahme.
Min. Bearbeitungszeit pro Bild | Minimale Dauer einer Auswertung innerhalb des Zyklus inkl. Bildaufnahme. Die minimale Bearbeitungszeit kann zum Unterdrücken von Mehrfachtriggern verwendet werden. Im Fall von "Anzahl Bilder" = 1 (default) entspricht die Min. Bearbeitungszeit pro Bild der minimalen Zykluszeit.
Anzahl Bilder (max)

Maximale Anzahl von Bildaufnahmen, die nach einem Trigger ausgeführt werden, sofern keines der folgenden Abbruchkriterien erfüllt ist:

- "Gesamt Jobergebnis" = positiv (einstellbar unter Ausgabe/Ausgangssignale)

- "Max. Zykluszeit" nicht erfüllt ist (falls aktiviert).

LED-Stärke

Dieser Wert wird automatisch berechnet und nur angezeigt. Standard-Wert ist 100%. Die LED-Leistung wird automatisch reduziert, wenn bei relativ langen Belichtungszeiten und relativ kurzer minimaler Job-Zeit (kurze min. Zykluszeit und / oder sehr schnelle Bearbeitung der Detektoren) die Pause zum Abkühlen der LEDs zu klein wird. Die minimale Zykluszeit muss Faktor 10 größer sein als die Shutterzeit, damit die LEDs mit 100% Leistung betrieben werden können.

Auto

Der Schalter "Auto" stellt die "Min. Bearbeitungszeit pro Bild" so ein, dass die LED-Stärke immer 100 % ist.

Abbildung: Reiter Job / Zykluszeit


Lagenachführung

Bei Objekten bzw. Merkmalen, deren Position im Bild variiert, kann eine Lagenachführung erforderlich sein. Hierfür stehen Ihnen drei verschiedene Detektionsmethoden (Lagedetektoren) zur Verfügung.

Nächstes Thema: Auswahl und Konfiguration eines Lagedetektors

Für jeden Job kann maximal ein Lagedetektor definiert werden.

Funktionsweise einer Lagenachführung

Bei einer Lagenachführung handelt es sich um ein nachgeführtes Koordinatensystem, das an einem ausgewählten Merkmal verankert wird. Alle in der Folge definierten Detektoren werden relativ zu diesem Koordinatensystem ausgerichtet. Das nachgeführte Koordinatensystem wird in dunkelblau eingezeichnet

Hinweise zur Bedeutung und Einstellung der verschiedenen Rahmen im Bild s. Kap.

Such- und Merkmalsbereiche

Da die Lagenachführung einen zusätzlichen Rechenschritt darstellt und somit Zykluszeit in Anspruch nimmt, sollte sie nur dann eingesetzt werden, wenn es die Anwendung erfordert.

Anwendungsbeispiel:

Lagenachführung des gesamten Teiles anhand von zwei Antastern, d.h. hier wird die linke, obere Teileecke erkannt. Nun können alle Merkmale relativ zu dieser Teileposition gefunden und überprüft werden. Alle nachfolgenden Detektoren werden relativ zu der jeweils aktuell gefundenen Teilelage positioniert.

Abbildung: Lagenachführung


Auswahl und Konfiguration eines Lagedetektors

Lagedetektor auswählen:

1. Klicken Sie auf den Button „Lagenachführung".

2. Wählen Sie eine Detektionsmethode im Konfigurationsfenster:

Nächstes Thema: Lagedetektor Mustervergleich, Parameter

Die verschiedenen Lagedetektoren und Hinweise zu deren Auswahl

Methode Auswahlkriterien

Keine

Lagenachführung nicht aktiv

Kantenantastung

Erkennung horizontal und/oder vertikaler Kanten

Die Antastung an Kanten sollte immer dann ausgewählt werden wenn:

  • ein Bildversatz nur in X- und / oder Y- Richtung auftreten kann
  • kontrastreiche, achsparallele Kanten vorhanden sind

Die Kantenantastung ist, wenn o.g. Kriterien erfüllt sind, eine sehr schnelle Methode der Lagenachführung.

Die Kantenantastung kann nicht bei Winkelversatz / Rotation eingesetzt werden.

Konturerkennung

Erkennung von Konturen und Kanten in beliebiger Winkellage

Die Konturerkennung ist immer dann zwingend einzusetzen wenn:

  • auch ein Winkelversatz (rotatorischer Versatz ggü. der Einlernlage) auftreten kann

Sie kann vorzugsweise eingesetzt werden, wenn kontrastreiche Kanten im Bild vorhanden sind. Die relativ aufwändige Funktion Konturerkennung resultiert in der Regel auch in einer vergleichsweise längeren Zykluszeit.

Mustervergleich

Erkennung beliebiger Muster

Der Mustervergleich kann vorzugsweise eingesetzt werden wenn

  • eher keine / weniger kontrastreiche bzw. achsparallele Kanten, sondern Bereiche mit Grauwertmustern im Bild vorhanden sind

Der Mustervergleich kann nicht bei Winkelversatz / Rotation eingesetzt werden. Drehlagentoleranz ca +/- 5% je nach Muster.

Lagedetektor konfigurieren:

1. Passen Sie die im Bild dargestellten Such- und Merkmalsbereiche ggf. in Position und Größe an.

2. Konfigurieren Sie den ausgewählten Lagedetektor im Reiter Parameter.


Lagenachführung Mustervergleich

Dieser Detektor eignet sich zur Erkennung von Mustern beliebiger Form, auch ohne deutliche Kanten oder Konturen.

Farbkanal auswählen

Lagedetektor Mustervergleich, Parameter


Farbkanal auswählen

Auswahl des Farbraums und der Zusammensetzung der Graubildes (Farbkomponenten), auf dem der Detektor arbeitet.

Ein Bild, das mit einem Farbchip aufgenommen wurden enthält durch die Farbkomponente mehr Information als ein monochromes Bild.

Diese Eigenschaft kann auch bei monochromen Detektoren genutzt werden. Durch Auswahl der Farbkanäle kann die Zusammensetzung des Graubildes verändert werden und damit können einzelne Bereiche gezielt verstärkt oder abgeschwächt werden.

Das angezeigte Bild wird abhängig vom Bildchip und vom gewählten Detektor angezeigt.

- Monochrom Chip: Anzeige immer Grauwerte

- Farbchip + Farbdetektor: Anzeige immer farbig

- Farbchip + Objekterkennungsdetektoren: Monochrombild, Anzeige abhängig vom gewählten Farbraum und den Farbkanälen

Abbildung: Farbkanal

Parameter | Funktion
Farbraum | Farbräume: RGB, Farbmodell RGB, HSV, Farbmodell HSV, LAB, Farbmodell LAB
Farbkanal | Auswahl eines Farbfilters, im resultierenden Graubild, auf dem der Detektor arbeitet. Nicht gewählte Farben werden ausgeblendet..


Ergebnisoffset

Mit Ergebnisoffset kann die Position eines gefundenen Objekts verändert werden. Das kann hilfreiche sein z.B. zur Definition eines geeigneten Greifpunktes am gefundenen Teil in Pick and Place Anwendungen.

Einstellungen im Reiter Ergebnisoffset

Parameter Funktion

Kein

Kein Offset, d.h. automatisch bestimmtes Zentrum des gefundenen Objekts / der Finderegion.

Offset

Frei wählbare Position (grafisch oder durch Werteeingabe). Etwa zur Anpassung an optimalen Greifpunkt bei Roboteranwendungen.

  • Offset X: Offset in X- Richtung
  • Offset Y: Offset in Y- Richtung
  • Offset Winkel: Winkel- Offset

Abbildung: Ergebnisoffset


Lagedetektor Mustervergleich, Parameter

Nächstes Thema: Lagedetektor Kantenantastung, Parameter

Einstellungen im Reiter Parameter:

Parameter | Funktion
Schaltschwelle | Bereich für die geforderte Übereinstimmung des gefundenen Musters mit dem gelernten Muster
Genau - Schnell | Anzahl der Suchstufen / Vergröberungsstufen Großer Wert: schneller = riskanter (Kandidaten übersehen) Kleiner Wert: langsamer = risikoärmer (alle Kandidaten)
Muster | Zeigt das eingelernte Muster = roter Rahmen
Rücksetzen | Für diesen Lagedetektor die Werkseinstellungen wieder herstellen
Suchbereich anpassen | Maskierung des Musters, Bereiche des eingelernten Musters können deaktiviert werden, s. auch Kap. Funktion: Muster bearbeiten

Abbildung: Lagedetektor, Mustervergleich


Lagenachführung Kantenantastung

Diese Lagenachführung ermittelt Merkmale mittels Kantenantastungen (in X- und Y-Richtung).

Sie eignet sich zur Detektion horizontaler und vertikaler Kanten und somit des daraus

resultierenden Kreuzungspunktes.

Zur Erkennung von Kanten in beliebigen Winkellagen empfiehlt sich der Einsatz des Konturvergleichs.

Farbkanal auswählen

Lagedetektor Kantenantastung, Parameter


Lagedetektor Kantenantastung, Parameter

Diese Lagenachführung ermittelt Merkmale mittels Kantenantastungen (in X- und Y-Richtung). Sie eignet sich zur Detektion horizontaler und vertikaler Kanten und somit des daraus resultierenden Kreuzungspunktes.

Zur Erkennung von Kanten in beliebigen Winkellagen empfiehlt sich der Einsatz des Konturvergleichs.

Nächstes Thema: Lagedetektor Konturerkennung, Parameter

Einstellungen im Reiter Parameter:

Parameter | Funktion und Einstellmöglichkeiten
Antastung | Hier wird festgelegt, ob die Antastung in „Horizontal und Vertikal", „Nur Horizontal" oder „Nur Vertikal" erfolgen soll. Bei „Horizontal und Vertikal" wird der Ursprungsort senkrecht und waagrecht verschoben. Bei „Nur horizontal" wird der Ursprungsort nur waagerecht verschoben. Bei „Nur Vertikal" wird der Ursprungsort nur senkrecht verschoben.
Kantenstärke | Kantenstärke / Kontrast ab welchem eine Kante als Kante detektiert werden soll
Übergang | Wahl zwischen Hell-Dunkel- oder Dunkel-Hell-Übergang
Glättung | Der Kantenverlauf in Suchrichtung wird geglättet. Mit größeren Werten werden verrauschte Kanten, unscharfe Kanten oder Kanten, die nicht senkrecht zur Suchrichtung stehen, sicherer erkannt. Außerdem können mit größeren Werten eng beieinander liegende Hell-Dunkel-Hell- oder Dunkel-Hell-Dunkel-Übergänge ignoriert werden. Damit lassen sich störende Kanten, z.B. Kratzer, ausblenden. Die Wirkung der Glättung kann über die Schaltfläche "Ergebnisse" grafisch dargestellt werden.
Suchrichtung | Suchrichtung „Links -> Rechts" / „Rechts -> Links" oder „Unten -> Oben" / „Oben -> Unten" einstellen.
Anzahl Suchstreifen | Anzahl der parallelen Suchstreifen in die die Breite des Suchbereichs aufgeteilt wird. Die Kantenantastung wird in jedem Suchstreifen durchgeführt, und die erste Kante ist entscheidend. Je mehr Suchstreifen, desto eher wird die erste Kante gefunden. (Feinere Abtastung hat eine längere Ausführungszeit zur Folge)
Rücksetzen | Die Werkseinstellungen für diesen Detektor wieder herstellen.

Optimierung:

Ausführungsgeschwindigkeit erhöhen:

  • Suchbereich für Position (gelber Rahmen) nur so groß wie nötig
  • Suchstreifen verringern
  • Wert für Glättung verkleinern
  • Auflösung auf QQVGA, QVGA oder VGA statt WVGA verringern (Achtung: Globaler Parameter, wirkt auf alle Detektoren!)

Robustheit optimieren:

  • Falls unscharfe Kante: Wert für Glättung erhöhen
  • Störkanten wie Kratzer werden erkannt: Schaltschwelle oder / und Wert für Glättung erhöhen
  • Kante nicht senkrecht zur Suchrichtung: Suchstreifen erhöhen

Wirkung von Anzahl Suchstreifen

„Suchstreifen“ gibt an, in wie viele parallele Suchstreifen der Suchbereich aufgeteilt wird. Die Kantenantastung wird innerhalb jedes Suchstreifens über die gesamte Breite durchgeführt. Die erste Kante in Suchrichtung aller Suchstreifen wird als Gesamtergebnis betrachtet. Mit Erhöhung von „Anzahl Suchstreifen“ wird sichergestellt, dass die erste Kante im Suchbereich gefunden wird.

Weitere Hinweise zur Kantenantastung s. Anhang, Kap. Weitere Erläuterungen zur Kantenantastung (Lagenachführung)

Abbildung: Lagenachführung, Kantenantastung


Lagenachführung Kontur

Dieser Lagedetektor eignet sich zur Erkennung von Konturen bestehend aus Kanten in beliebigen Winkellagen.

Farbkanal auswählen

Lagedetektor Konturerkennung, Parameter


Lagedetektor Konturerkennung, Parameter

Dieser Lagedetektor eignet sich zur Erkennung von Konturen bestehend aus Kanten in beliebigen Winkellagen.

Nächstes Thema: Detektoren

Einstellungen im Reiter Parameter:

Parameter Funktion und Einstellmöglichkeiten

Schaltschwelle

Bereich für die geforderte Übereinstimmung der gefundenen Kontur mit der gelernten Kontur

Winkelbereich

Winkelbereich, in dem gesucht wird (großer Bereich bedeutet längere Bearbeitungszeit)

Schrittweite (Winkel)

Schrittweite in ° der Suche über den gewählten Winkelbereich

(Wenn Winkelbereich und Schrittweite auf 0 gesetzt werden, sucht der Detektor nur nach nicht gedrehten Objekten)

Genau - Schnell

Kandidaten mit Übereinstimmungsgrad unterhalb des angegebenen Werts werden bereits bei der Suche verworfen.
Großer Wert: schneller = riskanter (Kandidaten übersehen)

Kleiner Wert: langsamer = risikoärmer (alle Kandidaten)

Min. Kontrast Modell

Minimal geforderter Kontrast beim eingelernten Modell bei dem eine Kante als solche akzeptiert wird.

Min. Kontrast Bild

Minimal geforderter Kontrast im aktuellen Bild bei dem eine Kante als solche akzeptiert wird

Rücksetzen

Für diesen Lagedetektor die Werkseinstellung wieder herstellen

Kontur bearbeiten

Über den Parameter „Kontur anpassen“ können Bereiche der eingelernten Kontur ausgeblendet werden. Wie mit einem Radierer können im Suchbereich die Bereiche

entfernt werden, die für die Auswertung nicht benötigt werden. Diese markierten Bereiche können auch invertiert werden, also die Bereiche markiert werden, die für die Ausführung wichtig sind. S. auch Kap. Funktion: Muster bearbeiten

Abbildung: Lagedetektor Kontur


Geschwindigkeit

Über die hier einstellbaren Parameter wird die Ausführungsgeschwindigkeit beeinflusst. Die Suche wird entweder weniger fein durchgeführt, d.h. früher abgebrochen = schneller, oder es werden auch feinere Details bei der Suche berücksichtigt, d.h. länger gesucht = langsamer.

Einstellungen im Reiter Geschwindigkeit:

Parameter Funktion

Übereinstimmungsgrad

(genau - schnell)

Kandidaten mit Übereinstimmungsgrad unterhalb des angegebenen Werts werden bereits bei der Suche verworfen.

  • Großer Wert: frühes Verwerfen = schneller = riskanter
  • Kleiner Wert: spätes Verwerfen = langsamer = risikoärmer

Falls die Suche fehlschlägt, kann der Wert für "Vollständige Suche" verkleinert werden.

Suchstufen

(genau - schnell)

Anzahl der Suchstufen / Vergröberungsstufen.

  • Großer Wert: schneller = riskanter (Kandidaten übersehen)
  • Kleiner Wert: langsamer = risikoärmer (alle Kandidaten)
  • Auto = Automatische Wahl

Abbildung: Geschwindigkeit


Detektoren

Jeder Job beinhaltet einen oder mehrere Prüfschritte (Detektoren), die Sie hier definieren können.

Nächstes Thema: Erstellen und Bearbeiten von Detektoren

Für Hinweise zur Bedeutung und Einstellung der verschiedenen Rahmen im Bild s. Kap. Such- und Merkmalsbereiche

Bei der ersten Auswahl des Verarbeitungsschrittes „Detektoren“ öffnet sich direkt der Auswahldialog für einen neuen Detektor. Hier einen Detektor auswählen. Die entsprechenden Einstellbereiche werden grafisch im Bild als Rahmen in voreingestellter Lage und Größe dargestellt. Nun die Rahmen und die Parameter entsprechend der Prüfaufgabe einstellen.

Abbildung: Detektor Auswahlliste Objektsensor


Erstellen und Bearbeiten von Detektoren

Detektortypen:
  • Detektor Mustervergleich
  • Detektor Konturerkennung
  • Detektor Kontrast
  • Detektor Helligkeit
  • Detektor Graustufe
  • Detektor BLOB, Einleitung
  • Detektor Messschieber
  • Detektor Barcode
  • Detektor 2D-Code
  • Detektor OCR
  • Detektor Farbfläche
  • Detektor Farbliste
  • Detektor Farbwert

Neuen Detektor erstellen:

1. Klicken Sie auf Button „Neu" unter der Auswahlliste im Konfigurationsfenster und wählen Sie den gewünschten Detektortyp. Ein neuer Detektoreintrag erscheint in der Auswahlliste.

2. Editieren Sie den Detektornamen durch Doppelklick auf das Feld „Name".

Detektor konfigurieren:

1. Markieren Sie einen Detektor in der Auswahlliste. Für jeden Detektor kann hier ein Name vergeben werden.

2. Legen Sie die zugehörigen Such- und Merkmalsbereiche grafisch im Bild fest.

3. Konfigurieren Sie den Detektor, indem Sie Parameter in den Reitern Parameter /Allgemein und ggf. Erweitert des Konfigurationsfensters eingeben / einstellen.

Welche Reiter angezeigt werden, hängt vom gewählten Detektortyp ab.

Im Menüpunkt „Ansicht/Einzeichnungen konfigurieren" können die Einzeichnungen im Bild (Rahmen in gelb, rot, etc.) beliebig je Detektor oder Kategorie an- oder abgeschaltet werden. Unter "Ansicht/Einzeichnungen nur aktueller Detektor" bzw. mit dem Button mit Rahmensymbol, können alle Einzeichnungen im Bild bis auf die des aktuell bearbeiteten Detektors abgeschaltet werden.

Funktionen zum Verwalten der Detektoren:

Schaltfeld Funktion

Neu

Neuen Detektor einfügen > Dialog mit o.g. Detektorauswahlliste erscheint

Kopieren

Kopieren sämtlicher Parameter von einem Detektor zu einem oder mehren anderen. Die Merkmalsbereiche (verschiedenfarbige Rahmen wie: Einlernbereich, Suchbereich etc.) werden dabei nicht mitkopiert. Die Detektortypen müssen dazu identisch sein.

Kopiervorgang:

Alle gewünschten Zieldetektoren vom gleichen Typ wie Quelldetektor anlegen. Quelldetektor in der Detektorliste auswählen.

Button „Kopieren“ drücken.

In der nun erscheinenden Liste alle gewünschten Zieldetektoren markieren (Mehrfachmarkierung mit gedrückter „Strg“- Taste und mit „Kopieren“ bestätigen.

Rücksetzen

Zurücksetzen der Parameter und des Such- und Merkmalsbereichs des ausgewählten Detektors auf die Standardwerte

Löschen

Löschen des ausgewählten Detektors

Alle Löschen

Löschen aller Detektoren in der Liste

Hinweis:

In der Statuszeile am unteren Bildschirmrand wird mit „Flash: x.x/yyyy.y kB", zuerst der durch die momentane Konfiguration benutzte Speicher (x.x), bzw. der auf dem Sensor verfügbare Speicher (yyyy.y) in kB angezeigt. Übersteigt der genutzte Speicher den verfügbaren Speicher wechselt diese Anzeige in rote Darstellung, da dann die momentanen Einstellungen nicht mehr auf dem Sensor Platz finden würden. In diesem Fall können Sie vor der Übertragung andere Jobs vom Sensor löschen.


Auswahl eines geeigneten Detektors

Nächstes Thema: Detektor Mustervergleich

Folgende Detektoren stehen zur Verfügung:

Detektortyp | Beschreibung
Mustervergleich | Teileerkennung mittels Mustervergleich, X - und Y- translatorisch
Konturvergleich | Teileerkennung mittels Objektkontur, Rotation bis 360°
Kontrast | Bestimmung des Kontrastes im ausgewählten Suchfeld
Helligkeit | Prüfen der Helligkeit im gewählten Suchbereich
Graustufe | Bestimmung der Grauwerte im ausgewählten Suchfeld
BLOB | Zählen und Bewerten von Objekten
Messschieber | Abstand zwischen Kanten
Farbfläche | Farbauswertung über Fläche
Farbliste | Farbauswertung über Liste
Farbwert | Ausgabe von Farbwerten
Barcode | Barcodelesung 1D Codes
DataCode | Datacodelesung 2D Codes
Optical Character Reader (OCR) | Klarschriftlesung


Detektor Mustervergleich

Dieser Detektor eignet sich zur Erkennung von Mustern beliebiger Form, auch ohne deutliche Kanten oder Konturen.

Abbildung: Detektor Mustervergleich

Nächstes Thema: Detektor Konturerkennung

Ergebnisoffset

Funktion: Muster bearbeiten

Mustervergleich Applikation

Einstellungen im Reiter Muster:

Parameter | Funktion

Schaltschwelle

Bereich für die geforderte Übereinstimmung des gefundenen Musters mit dem gelernten Muster in %.

Genau - Schnell

Anzahl der Suchstufen / Vergröberungsstufen. ( Mögliche Einstellungen 2-10)

Großer Wert: schneller = riskanter (Kandidaten übersehen)

Kleiner Wert: langsamer = risikoärmer (alle Kandidaten)

Positions-

kontrolle

Prüfung, ob sich das gefundene Muster an der richtigen Position befindet.

Bei Aktivierung der Positionskontrolle wird der Positionsrahmen in blau (wahlweise rechteckig oder elliptisch) angezeigt. Der Mittelpunkt des Musters muss innerhalb des blauen Rahmens liegen.

Muster

Zeigt das eingelernte Muster = Inhalt des roten Rahmens

Muster bearbeiten

Über den Parameter „Muster bearbeiten“ können Bereiche des eingelernten Muster ausgeblendet werden. Wie mit einem Radierer können im Suchbereich die Bereiche

entfernt werden, die für die Auswertung nicht benötigt werden. Diese markierten Bereiche können auch invertiert werden. Es werden somit die Teile markiert , die für die Ausführung wichtig sind.

Sperren | Muster sperren / entsperren. Im gesperrten Zustand ist das eingelernte Muster gegen (unbeacbsichtigte / versehentliche) Änderungen, durch z.B. versehentliche Anpassung des Einlenbereichs geschützt. Zum neuen Einlernen entsperren.

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.

Optimierung Mustervergleich:

Ausführungsgeschwindigkeit:

  • Suchbereich für Position (gelber Rahmen) nur so groß wie nötig.

    Beachte: Suchbereich gibt den Bereich an, in dem der Schwerpunkt des Musters gesucht wird.
  • Auflösung auf QVGA statt VGA verringern (Achtung: Globaler Parameter, wirkt auf alle Detektoren!)
  • Regler: Genau - Schnell auf: Schnell

Robuste Mustererkennung

  • Suchbereich für Position (gelber Rahmen) ausreichend groß?
  • Regler: Genau - Schnell auf: Genau
  • Markantes Grauwertmuster wählen, ggf. neu einlernen
  • Wenn an falscher Position gefunden: Eindeutiges Muster verwenden, ggf. neu einlernen, ectl Schwellwert anpassen.

Wird unmittelbar nach Einlernen festgestellt, dass gefundene Position (grüne ROI) nicht mit Einlernbereich (rote ROI) übereinstimmt, sollte Regler: Genau - Schnell auf: Genau eingestellt werden.


Mustervergleich Applikation

Im Beispiel wurde ein Kontakt (ganz links) des Prüfteiles als Muster eingelernt und wird an dieser Stelle auch mit hohem Übereinstimmungsgrad (Schaltschwelle nahe 100%) erkannt.

Abbildung: Mustervergleich, Applikationsbeispiel, positives Ergebnis

Abbildung: Mustervergleich, Applikationsbeispiel, negatives Ergebnis

Wird nun der gleiche Mustervergleich an einer Stelle des Prüfteiles durchgeführt, an dem der gesuchte Kontakt fehlt, erreicht der Übereinstimmungsgrad nicht den geforderten Schwellwert und das Ergebnis wird negativ. Der Kontakt wird hier aufgrund der Grauwerte an den jeweiligen Orten im Bild gesucht. Da der innenliegende, sehr hoch reflektierende und damit helle Bereich nicht existiert, und stattdessen die Bildpixel entsprechend dunklere Werte aufweisen, ist hier der Übereinstimmungsgrad nicht so hoch wie bei einem vorhandenen Kontakt. Weil aber auch große Teile des Musters identisch mit dem eingelernten sind (der gesamte äußere, schwarze Bereich) ist der Übereinstimmungsgrad immer noch recht hoch bei ca. 70% !

Die hier gemachten Einstellungen sind nur zur Verdeutlichung der Wirkungsweise des Mustervergleichs-Detektors so gewählt, und sollten im realen Betrieb weiter optimiert werden, (Etwa durch Verkleinerung des Such- und Merkmalsbereichs >> relevantes Muster wird signifikanter, etc. )

Beim Einlernen wird das im roten Rahmen befindliche Bild als Referenz im Sensor gespeichert. Die Größe und Lage der Referenz wird durch den roten Rahmen definiert. Im Run-Modus sucht der SBS Vision Sensor dann im aktuellen Bild nach der größten Übereinstimmung mit dem Referenzbild / Muster innerhalb des Suchbereichs. Je nach Einstellung des Schwellwerts (= Grad der Übereinstimmung) wird das Objekt als gut erkannt oder nicht.

Die Mustererkennung ist nur bis zu ca. ± 5 Winkel-Grad drehlagentolerant. Muster mit größeren Verdrehungen werden nicht erkannt. Nutzbar z.B. zur Prüfung der Lagerichtigkeit von Teilen in Zuführanlagen.

Beispiel:

Folgendes Muster wurde im Sensor eingelernt:

Abbildung: Muster, Referenz

Bei den folgenden drei Beispielbildern wird das Objekt mit 100% Übereinstimmung erkannt, da das eingelernte Muster exakt gleich ist, obwohl es sich an einem anderen Ort im Bild befindet, jedoch nur in X- bzw. Y- Richtung verschoben, und nicht verdreht ist.

Abbildung: Muster, positives Ergebnis

Bei den drei nun folgenden Beispielbildern wird das Objekt ebenfalls erkannt, jedoch mit weniger als

100% Übereinstimmung (ca. 70-80%), da es in einigen Pixeln vom eingelernten Muster abweicht. Je nach Einstellung des Schwellwerts (Grad der Übereinstimmung) werden Gut- oder Schlecht- Ergebnisse geliefert.

Abbildung: Muster, Grenzfälle

Die Mustererkennung ist nur bis zu ± 5 Winkel- Grad drehlagentolerant. Das bedeutet, die Bilder in unterster Reihe würden auch erkannt, allerdings wäre hier, trotz 100% Pixelübereinstimmung, der tatsächliche Grad der Übereinstimmung zum Musterbild kleiner 100%. Muster mit größerer Verdrehung werden nicht erkannt. Dies kann z.B. zur Erkennung der Lagerichtigkeit von Teilen in Zuführanlagen als Funktion genutzt werden.

Abbildung: Muster, Rotation


Funktion: Muster bearbeiten

Mit der Funktion "Suchbereich bearbeiten", können innerhalb der Suchfelder / Merkmalsfelder der verschiedenen Detektoren Bereiche für die Bewertung zugelassen oder ausgeschlossen werden.

Anwendungsbeispiel:

Äussere und innere Konturlinien, sowie Löcher sollen für die Auswertung irrelevant sein, aber alle Oberflächendefekte sollen detektiert werden.

Nach Maskierung werden nur die nicht markierten Bereiche innerhalb der ROI des Detektors für die Auswertung herangezogen. Die gelb markierten Bereiche sind maskiert und damit nicht mehr relevant für die Auswertung.

Abbildung: Muster / Suchbereich bearbeiten

Bedienung:

Parameter | Funktion
Cursor (Form) | Ändern der Form des Cursors (Quadrat, Kreis oder Linie). Mit der Einstellung: "Cursor = Linie", springt die Winkellage der Linie, bei gleichzeitig gedrückter Shift- Taste, in 15° Schritten.
Cursorgröße | Ändern der Größe des Cursors (Mögliche Einstellung 1-500, auch durch z.B. Mausrad)
Pixel hinzufügen / Pixel entfernen | Auswahl, ob der Cursor Pixel zur Bildverarbeitung hinzufügt oder ausschließt
Alles hinzufügen | Fügt alle Pixel der Bildverarbeitung hinzu
Alles entfernen | Schließt alle Pixel von der Bildverarbeitung aus
Alles invertieren | Invertiert alle Pixel
Rückgängig | Macht die letzte Aktion rückgängig
Wiederherstellen | Stellt die zuletzt rückgängig gemachte Aktion wieder her
Anzeige | Wählt den Anzeigemodus (Vergrößern / Verkleinern)

Durch die flexible Auswahl der Cursorform- und -Größe, sowie, ob eine Aktion Pixel hinzufügt oder entfernt, können sehr einfach und schnell komplexe geometrische oder frei geformte Bereiche definiert werden, die für die Prüfung relevant sind oder nicht berücksichtigt werden (gelb).

Bei den verschiedenen Detektortypen sind folgende Einstellungen für die Nutzung der Funktion „Muster bearbeiten“ nötig.

Detektortyp | Nötige Einstellung zur Bearbeitung des Musters
Mustervergleich, Kontur | Generell möglich mit „Muster bearbeiten“
Kontrast, Helligkeit, Graustufe, BLOB, Farbwert, Farbfläche, Farbliste | Suchbereich „Freiform“ auswählen

Maskierung von Such- und Einlernbereichen, Beispiele

Anpassung des Suchbereichs an das Objekt für Detektoren Kontrast, Helligkeit und Grauschwelle

Für die oben genannten Detektoren gibt es drei Formen für den Suchbereich: Kreis, Rechteck und Freiform. Sollte mit Kreis bzw. Rechteck, das über den Kontrollpunkt an dem Pfeil auch gedreht werden kann, der Arbeitsbereich nicht gut genug an das Objekt angepasst werden können, dann den Freiform-Suchbereich verwenden. Damit lassen sich beliebige Suchbereichsgeometrien erstellen. Der Cursor zur Bearbeitung der Suchbereichs kann als Quadrat oder als Kreis in beliebig einstellbarer Größe gewählt werden. Es folgen einige Beispiele für Freiform -Suchbereiche mit kurzer Beschreibung, wie diese im Freiform-Editor erzeugt wurden.

Beispiel 1,

Muster mit relevanten Bereichen.

Abbildung: Muster bearbeiten 2

Erzeugt durch einen hinzufügenden und einen wegnehmenden Kreis.

Abbildung: Muster bearbeiten 3

Erzeugt durch einen hinzufügenden und einen wegnehmenden Kreis.

Beispiel 2,

Nur Oberflächendefekte sind relevant, Konturlinien des Objekts werden dazu maskiert.

Abbildung: BLOB Detektor ohne Nutztung der Maskierung. Mit dem genutzten BLOB Detektor werden alle Oberflächendefekte, aber auch die äusseren und inneren Konturlinien erkannt.

Abbildung: Maskierung der Konturlinien, die nicht erkannt werden sollen = gelbe Bereiche.

Abbildung: BLOB Detektor mit Nutzung der Maskierung. Nur Oberflächendefekte werden erkannt, alle im Maskierungsbereich liegenden Konturlinien / Objekte werden nun nicht mehr erkannt.


Detektor Konturerkennung

Dieser Detektor eignet sich zur Erkennung von Mustern anhand von Kanten, auch in beliebigen Winkellagen.

Nächstes Thema: Detektor Kontrast

Einstellungen im Reiter Winkel:

Einstellungen im Reiter Skalierung:

Geschwindigkeit

Ergebnisoffset

Kontur Applikation

Funktion: Muster bearbeiten (Kontur)

Die Konturen des Objekts im Suchfeld werden beim Einlernen im Sensor gespeichert. Im Run-Modus sucht der Sensor die Position der größten Übereinstimmung mit der eingelernten Kontur im aktuellen Bild. Ist die Übereinstimmung zur abgespeicherten Kontur größer als der eingestellte Schwellwert, wird das Objekt als gut erkannt. Die Konturerkennung ist komplett drehlagentolerant, d.h. das gesuchte Objekt darf in beliebiger Lage im Bild erscheinen (Winkeleinstellungen entsprechend wählen!).

Abbildung: Detektor Kontur, Reiter Kontur

Die rechts unten hellblau eingezeichneten Kanten (kontrastreiche Übergänge im Bild) wurden auf Grund der getätigten Parametereinstellungen identifiziert und eingezeichnet. Diese können ggf. durch Veränderung der Parameter bzw. durch die Funktion „Kontur bearbeiten“ weiter verändert werden. Diese Kontur wird nun im Bild innerhalb des Suchbereiches (gelber Rahmen) gesucht.

Einstellungen im Reiter Kontur:

Parameter | Funktion
Schaltschwelle | Bereich für die geforderte Übereinstimmung der gefundenen Kontur mit der gelernten Kontur.
Min. Kontrast Muster | Minimal geforderter Kontrast beim eingelernten Modell bei dem eine Kante als solche akzeptiert wird.
Min. Kontrast Bild | Minimal geforderter Kontrast im aktuellen Bild bei dem eine Kante als solche akzeptiert wird.
Positionskontrolle | Prüfung, ob sich das gefundene Muster an der richtigen Position befindet. Bei Aktivierung der Positionskontrolle wird der zulässige Bereich für die Position des gefundenen Merkmals in einem blauen Rahmen (wahlweise rechteckig oder elliptisch) angezeigt. Das Zentrum (grünes Kreuz) des gefundenen Merkmals muss sich dabei innerhalb des blauen Rahmens befinden.
Kontur | Zeigt die eingelernte Kontur mit Anzeige der gefundenen Kanten (Inhalt des roten Rahmen beim Einlernen)
Kontur bearbeiten | Über Kontur bearbeiten können Teile des Suchbereichs ausgeblendet werden. Wie mit einem Radierer können im Suchbereich die Bereiche entfernt werden, die für die Auswertung nicht gewünscht sind. Die markierten Bereiche können auch invertiert werden. Es werden somit die Teile markiert , die für die Ausführung wichtig sind. S. auch Kap. Funktion: Muster bearbeiten
Sperren | Muster sperren / entsperren. Im gesperrten Zustand ist das eingelernte Muster gegen (unbeacbsichtigte / versehentliche) Änderungen, durch z.B. versehentliche Anpassung des Einlenbereichs geschützt. Zum neuen Einlernen entsperren.

Optimierung:

Ausführungsgeschwindigkeit:

  • Suchbereich für Position (gelber Rahmen) nur so groß wie nötig.

    Beachte: Suchbereich gibt den Bereich an, in dem der Schwerpunkt des Musters gesucht wird.
  • Suchbereich für Winkel nur so groß wie nötig
  • Suchbereich für Skalierung nur so groß wie nötig
  • Auflösung auf QVGA statt VGA verringern (Achtung: Globaler Parameter, wirkt auf alle Detektoren!)
  • Wert für „Min. Kontrast Muster“ erhöhen. In der Anzeige des Musters überprüfen, ob die relevanten Konturen noch vorhanden sind.
  • Wert für „Min. Kontrast Bild“ erhöhen.
  • Insbesondere im Fall von Lagenachführung: Alternatives Suchmuster verwenden. Beispielsweise mit höherem Kontrast, so dass „Min. Kontrast Muster“ und „Min. Kontrast Bild“ erhöht werden können.

Robuste Erkennung:

  • Suchbereich für Position (gelber Rahmen) ausreichend groß?
  • Suchbereich für Winkel ausreichend groß?
  • Suchbereich für Skalierung ausreichend groß?
  • „Min. Kontrast Muster“ geeignet gewählt? Werden im eingelernten Muster die relevanten Konturen nicht angezeigt, so ist „Min. Kontrast Muster“ zu verkleinern. Werden zu viele Konturen angezeigt, so ist „Min. Kontrast Muster“ zu erhöhen.
  • „Min. Kontrast Bild“ für aktuelles Bild geeignet gewählt? Hat das aktuelle Bild einen kleineren/größeren Kontrast als das eingelernte Muster, so ist „Min. Kontrast Bild“ kleiner/größer als „Min. Kontrast Muster“ zu wählen.
  • Sind im Bild mehrere, sich überlappende Instanzen des Musters vorhanden
  • Markante Kanten in Muster vorhanden? Gegebenenfalls Muster neu einlernen, so dass markante Kanten im eingelernten Muster liegen.
  • Ergebniswert schwankt von Bild zu Bild? Gegebenenfalls dafür sorgen, dass keine „falschen“ Konturen im Bild eingelernt werden. Dies kann durch Erhöhnung „Min. Kontrast Muster“ erreicht werden. Mit Hilfe von „Kontur bearbeiten“ können Suchbereiche ausgeblendet werden.
  • Muster an falscher Position gefunden? Falls eingelerntes Muster nicht eindeutig ist, neues Muster einlernen.


Funktion: Kontur bearbeiten

s. Kap: Funktion: Muster bearbeiten


Einstellungen im Reiter Winkel:

Detektor Konturerkennung

Einstellungen im Reiter Skalierung:

Kontur Applikation

Funktion: Muster bearbeiten

Parameter | Funktion
Winkelbereich | Winkelbereich, in dem gesucht wird
Schrittweite (Winkel) | Empfindlichkeit der Suche über den gewählten Winkelbereich in °

Abbildung: Detektor Kontur, Reiter Winkel

Winkel, Drehsinn

Abbildung: Drehsinn "Winkel"


Einstellungen im Reiter Skalierung:

Detektor Konturerkennung

Einstellungen im Reiter Winkel:

Kontur Applikation

Funktion: Muster bearbeiten (Kontur)

Parameter | Funktion
Skalierung Min/Max | Erkennung auch von vergrößerten oder verkleinerten Objekten im angegebenen Skalierungsbereich
Schrittweite Skalierung | Empfindlichkeit der Suche über den gewählten Skalierungsbereich

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.

Abbildung: Detektor Kontur, Reiter Skalierung


Kontur Applikation

Die sichtbaren Kanten eines im Prüfteil eingebauten Kontaktes werden als Kontur eingelernt und so das Vorhandensein des Kontaktes kontrolliert.

Abbildung: Kontur, Applikationsbeispiel, positives Ergebnis

Die gefundenen Konturlinien werden rechts unten in hell blau eingezeichnet. Der Kontakt wird so zuverlässig gefunden

Abbildung: Kontur, Applikationsbeispiel, negatives Ergebnis

Wird nun dieselbe Konturprüfung an einer Stelle gemacht an der das Kontaktteil fehlt, werden dort auch die entsprechenden Kanten nicht gefunden und die Prüfung liefert ein negatives Ergebnis.


Detektor Kontrast

Nächstes Thema: Detektor Graustufe

Kontrast Applikation

Dieser Detektor bestimmt den Kontrast im ausgewählten Suchfeld. Hierzu werden alle Bildpunkte innerhalb des Suchbereichs mit ihren Grauwerten bewertet und der Kontrast berechnet. Liegt der Kontrastwert innerhalb der unter „Schaltschwelle“ eingestellten Grenzwerte wird das Ergebnis positiv. Die Lage der hellen bzw. dunklen Pixel ist hier irrelevant. Es kommt einzig auf die Spreizung von hellen und dunklen Pixeln und deren Mengenverhältnis an (Höchster Kontrast bei 50% Grauwert 0 = schwarz, und 50% Grauwert 255 = weiß).

Abbildung: Detektor Kontrast

Einstellungen im Reiter Kontrast

Parameter | Funktion
Schaltschwelle | Vorgabe des Kontrastbereichs, der akzeptiert wird.
Suchbereich (Form ) | Die Form des Suchbereiches kann als Rechteck, Kreis oder als Freiform gewählt werden. Wenn Freiform gewählt wird ist „Suchbereich bearbeiten“ aktiv.
Suchbereich anpassen | Über den Parameter Suchbereich bearbeiten können Bereiche des Suchbereichs ausgeblendet werden. Wie mit einem Radierer können im Suchbereich die Bereiche entfernt werden, die für die Auswertung nicht benötigt werden. Diese markierten Bereiche können auch invertiert werden, also die Bereiche markiert werden, die für die Ausführung wichtig sind etc. s. Kap Funktion: Muster bearbeiten
Anzeige Suchbereich | Ein- / Ausschalten der Anzeige der Suchbereich- Bearbeitungen

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


Kontrast Applikation

Detektor Kontrast

Im Beispiel wird anhand eines Kontrastdetektors die Anwesenheit eines Kontaktes geprüft.

Abbildung: Kontrast, Applikationsbeispiel, positives Ergebnis

Der hochreflektrierende, d.h. helle metallische Kontakt, inmitten des ihn umgebenden schwarzen Kunststoffgehäuses, wird mit einem Kontrastdetektor auf Anwesenheit geprüft. Da in diesem Bereich der Kontrast sehr hoch ist, liefert der Detektor einen hohen Wert und somit im Zusammenspiel mit einer Lagenachführung ein zuverlässiges Ergebnis.

Abbildung: Kontrast, Applikationsbeispiel, negatives Ergebnis

Wird der selbe Detektor an einer Stelle eingesetzt, an der der Kontakt fehlt, liefert der Detektor ein negatives Ergebnis, da hier der Kontrast sehr niedrig ist zwischen der schwarzen Umgebung und dem nun sichtbaren, ebenfalls schwarzen Hintergrund des Kontaktes.

Funktion Detektor Kontrast

Die dunklen und hellen Pixel werden nach Anzahl und Hell- bzw. Dunkelintensität bewertet.

Die Lage der hellen bzw. dunklen Pixel im Suchbereich ist irrelevant.

Abbildung: Kontrast Beispiele

Abbildung: Kontrast Erläuterung


Detektor Graustufe

Nächstes Thema: Detektor Helligkeit

Graustufe Applikation

Bei diesem Detektor wird im ersten Schritt mit den beiden Limitschiebern des Parameters „Grauschwelle“ der Wertebereich der Grauwerte festgelegt, die im Suchbereich auftreten dürfen.

Im zweiten Schritt wird unter „Schaltschwelle“ der Flächenanteil (in %) des Suchbereiches definiert, der die in Schritt 1 definierten Grauwerten aufweisen sein muss, um ein positives Ergebnis zu liefern.

Durch die jeweilige Invertierung können alle denkbaren Kombinationen eingestellt werden, auch solche bei denen z.B. nur Grauwerte am oberen und unteren Rand des Wertebereichs zulässig sind. Die Lage der hellen bzw. dunklen Pixel ist hier irrelevant.

Unter „Einzeichnungen“ können als Auswahlhilfe die Pixel, die einen Grauwert innerhalb (Gültige Pixel) oder außerhalb (Ungültige Pixel) der Grauwertbereichsfestlegung unter „Grauschwelle“ aufweisen, farbig markiert werden. So können sehr leicht z.B. Störpixel / Bereiche, die nicht vom Grauwertbereich abgedeckt sind erfasst werden.

Einstellungen im Reiter Grauschwelle:

Parameter | Funktion
Grauschwelle | Wertebereich in dem die Grauwerte akzeptiert werden
Schaltschwelle | Prozentualer Anteil der Fläche, die die unter „Grauschwelle“ definierten Grauwerte aufweisen muss
Suchbereich (Form) | Die Form des Suchbereiches kann als Rechteck, Kreis oder als Freiform gewählt werden. Wenn Freiform gewählt wird, ist „Suchbereich bearbeiten“ aktiv.
Einzeichnung | Auswahl der Pixel, die einen Grauwert innerhalb (Gültige Pixel) oder außerhalb (Ungültige Pixel) der Grauwertbereichsfestlegung unter „Grauschwelle“ aufweisen. Diese werden dann aus Auswahlhilfe farbig markiert. So können sehr leicht z.B. Störpixel / Bereiche, die nicht vom Grauwertbereich abgedeckt sind erfasst werden.
Suchbereich bearbeiten | Über den Parameter Suchbereich bearbeiten können Bereiche des Suchbereichs ausgeblendet werden. Wie mit einem Radierer können im Suchbereich die Bereiche entfernt werden, die für die Auswertung nicht benötigt werden. Diese markierten Bereiche können auch invertiert werden, also die Bereiche markiert werden, die für die Ausführung wichtig sind etc. s. Kap Funktion: Muster bearbeiten
Anzeige Suchbereich | Ein- / Ausschalten der Anzeige der Suchbereich- Bearbeitungen

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


Graustufe Applikation

Detektor Graustufe

Abbildung: Graustufe, Applikationsbeispiel, positives Ergebnis

Kontakt im Suchbereich vorhanden. Hohe Reflektion des Metallteiles bringt Grauwerte im Bereich > 192, d.h. innerhalb der geforderten Schwellwerte = positives Ergebnis

Abbildung: Grauschwelle, Applikationsbeispiel, negatives Ergebnis

Kontakt (hohe Reflektion des Metallteiles) im Suchfeld nicht vorhanden. D.h. Mittelwert der Grauwerte im Suchbereich nicht innerhalb der Schwellwerte (nicht innerhalb Grauwert 192-255, eher im Bereich < 50). Ergebnis: negativ = Kontakt nicht gefunden.

Hinweis zur Bestimmung der Grauwerte:

In der Statuszeile am unteren Bildrand wird im zweitletzten Feld rechts beim Platzieren des Cursors irgendwo im Bildbereich die entsprechende X- und Y- Koordinate und der Grauwert („I“ = Intensity) angezeigt.

Funktion Detektor Grauschwelle

Mit den beiden Limits des Schiebereglers Grauschwelle wird der zulässige Grauwertbereich definiert.

Alle Pixel, die innerhalb dieses Grauwertbereichs und innerhalb des definierten Arbeitsbereiches (gelber Rahmen) liegen werden aufsummiert. Das Verhältnis der Anzahl aller Pixel im Arbeitsbereich (gelber Rahmen) und der Anzahl der Pixel im akzeptierten Grauwertbereich repräsentiert das Ergebnis dieses Detektors.

Liegt dieses Ergebnis innerhalb der Limits, die am Schieberegler Schaltschwelle eingestellt sind, ist das Ergebnis positiv.

Die Position der Grauwertpixel im Bild spielt dabei keine Rolle.

Beispiel: (bei Einstellung des Schiebereglers Grauschwelle auf sehr dunkle Werte):

Die beiden Bilder liefern beim Detektor Grauschwelle genau das gleiche

Ergebnis, da jeweils 9 von 25 Pixeln als dunkel erkannt werden.

Abbildung: Grauschwelle, Beispiel 1

Angenommen der Schwellwert in diesem Beispiel wäre auf 10 eingestellt,

würden folgende Bilder zu einem positiven Ergebnis führen.

Abbildung: Grauschwelle Beispiel 2


Detektor Helligkeit

Nächstes Thema: Detektor Barcode

Helligkeit Applikation

Dieser Detektor bestimmt den Mittelwert der Grauwerte im Suchbereich. Mit den beiden Schwellwert-Schiebern des Parameters „Schaltschwelle“ wird der zulässige Bereich für diesen Helligkeits- Mittelwert eingestellt. Sobald sich der berechnete Mittelwert innerhalb dieser beiden Schwellwerte bewegt ist das Ergebnis positiv. Das Ergebnis wird auf % normiert. Die Lage der hellen bzw. dunklen Pixel im Suchbereich ist irrelevant. Detektor kann dann wirkungsvoll eingesetzt werden, wenn die Position des gesuchten Objektes im Bild von Prüfung zu Prüfung absolut unverändert ist, oder, falls Abweichungen in der Position auftreten können, muss die Lagenachführung verwendet werden.

Einstellungen im Reiter Helligkeit

Parameter | Funktion
Schaltschwelle | Vorgabe des Helligkeitsbereichs, der akzeptiert wird
Suchbereich (Form) | Die Form des Suchbereiches kann als Rechteck, Kreis oder als Freiform gewählt werden. Wenn Freiform gewählt wird, ist Suchbereich bearbeiten aktiv.
Suchbereich bearbeiten | Über den Parameter „Suchbereich bearbeiten“ können Bereiche des Suchbereichs ausgeblendet werden. Wie mit einem Radierer können im Suchbereich die Bereiche entfernt werden, die für die Auswertung nicht benötigt werden. Diese markierten Bereiche können auch invertiert werden. Es werden somit die Bereiche markiert, die für die Ausführung wichtig sind, s. Kap Funktion: Muster bearbeiten
Anzeige Suchbereich | Ein- / Ausschalten der Anzeige der Suchbereich- Bearbeitungen

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


Helligkeit Applikation

Detektor Helligkeit

Der Detektor Helligkeit berechnet den Mittelwert der Grauwerte aller Pixel im Suchbereich.

Abbildung: Helligkeit, Applikationsbeispiel, positives Ergebnis

Kontakt ist an gesuchter Stelle vorhanden und der Mittelwert der Grauwerte im Suchbereich liefert deshalb einen sehr hohen Wert (nahe 100%). Damit ist der aktuelle Wert innerhalb der geforderten Schaltschwellen und das Ergebnis ist positiv = Kontakt vorhanden.

Abbildung: Helligkeit, Applikationsbeispiel, negatives Ergebnis

Kontakt ist an gesuchter Stelle nicht vorhanden und der Mittelwert der Grauwerte im Suchbereich liefert deshalb einen sehr niedrigen Wert (nahe 0%). Damit ist der aktuelle Wert nicht innerhalb der geforderten Schaltschwellen und das Ergebnis ist negativ = Kontakt nicht vorhanden.

Beispiele: Helligkeitswert als Mittelwerte der Grauwerte

Abbildung: Helligkeit, Beispiele


Detektor BLOB, Einleitung

Mit dem BLOB Detektor können ein oder mehrere Objekte, die gemeinsame Merkmale wie gleiche Grauwertbereiche, gleiche Fläche, gleichen Umfang, o.ä. aufweisen, identifiziert und gezählt werden.

Farbkanal auswählen

Detektor BLOB, Reiter Binarisierung, Absolute Schaltschwelle

Detektor BLOB, Reiter Binarisierung, Dynamische Schaltschwelle

Detektor BLOB, Reiter Merkmale

Detektor BLOB, Reiter Sortierung

BLOB Einleitung

"BLOB" Abkürzung (engl.) für "Binary Large OBject" oder "Binary Labeled OBject".

Grundfunktion der Bildverarbeitung zur Bewertung von zusammenhängenden Flächen und Objekten in einem Bild.

Unterscheidung der einzelnen Objekte anhand von einfachen Merkmalen, wie z.B. Fläche, Breite, Höhe, etc.

Abbildung: Schrauben 1. Binarisiert, 2. als BLOB / Objekt erkannt

Typische Anwendungen

  • Zählen von Objekten
  • Unterscheidung / Klassifikation von Objekten im Bild anhand von:
  • Größe, Fläche, Kontur
  • Form, Geometrie
  • Position, Orientierung
  • Lage, Seite
  • Oberflächenprüfung

Abbildung: Typische Anwendungen: Zählen, Klassifizieren / Sortieren, Lage / Seite

BLOB, einfache Konfiguration in 3 Schritten

1. Binarisierung

Trennung zwischen Hintergrund und relevanten Objekten

Detektor BLOB, Reiter Binarisierung, Absolute Schaltschwelle

Detektor BLOB, Reiter Binarisierung, Dynamische Schaltschwelle

2. Filterung der erkannten BLOBs

Anhand verschiedener Merkmale wie: Fläche, Umfang, Orientierung, Lage, etc.

Detektor BLOB, Reiter Merkmale

3. Datenausgabe

Definition des Telegramms und Sortierung der Ergebnissse

Detektor BLOB, Reiter Sortierung

Datenausgabe


Detektor BLOB, Reiter Binarisierung, Absolute Schaltschwelle

In diesem Reiter können alle Parameter für die Binarisierung eines BLOBs gesetzt werden.

Detektor BLOB, Einleitung

Die Binarisierung ist der erste Schritt bei der BLOB Auswertung und wird eingesetzt, um relevante Objekte vom Hintergrund des Bildes zu trennen. Dies geschieht durch Umwandlung des Grauwertbildes in ein reines Schwarz-/Weiß- Bild, d.h. binäres Bild.

Es stehen zwei Binarisierungs- Methoden zur Verfügung.

Abbildung: Detektor BLOB, Reiter Binarisierung

In der ersten Auswahlbox wird die Binarisierungsmethode ausgewählt.

Parameter | Funktion
Absolute Schaltschwelle | Die Binarisierungs- Schaltschwelle wird auf einen absoluten Grauwert im Wertebereich von 0 ... 255 eingestellt.
Dynamische Schaltschwelle | Die Dynamische Schaltschwelle wird automatisch bei jedem Bild auf eine nach statistischen Methoden optimierte Position eingestellt, um möglichst gut zwischen Vorder- und Hintergrund unterscheiden zu können. Detektor BLOB, Reiter Binarisierung, Dynamische Schaltschwelle

Parameter bei Auswahl "Absolute Schaltschwelle"

Parameter | Funktion
Absolute Schaltschwelle | Die obere und untere Schwelle definiert den Bereich gültiger Grauwerte, der Pixel, die zum jeweiligen BLOB zugeordnet werden.
Grauwertbereich | Einstellung der oberen und unteren Schwelle der Grauwerte für die Binarisierung.
Invertierung Button | Mit dem "Invertierungs Button" (Default: rot/grün/rot) kann die Logik für die Auswertung invertiert werden. Damit kann der relevante Bereich eingeschlossen oder ausgeschlossen werden.
Pipette Button | Durch Klick auf den "Pipette Button" wechselt der Cursor in ein Pipette- Symbol. Wird nun der Cursor bewegt und auf einen Pixel innerhalb des Bildes geklickt, werden die Schwellen der "Absoluten Schaltschwelle" auf +/- 10 Grauwerte über bzw. unter dem Grauwert des ausgewählten Pixels eingestellt. (Werteberiech maximal 0 ... 255)

Randobjekte, Einzeichnungen und Histogramm

Parameter

Funktion
Randobjekte

Wenn die Checkbox "Randobjekte" aktiviert ist werden die ausgewählten BLOBs / Objekte berücksichtigt, auch wenn sie nicht komplett innerhalb des gelben Suchbereichs liegen. (natürlich müssen die Objekte in jedem Fall auch die BLOB- Merkmale innerhalb der gewählten Schaltschwellen erfüllen.)

Bitte beachten: BLOBs werden auch als Randobjekte betrachtet wenn sie einen Bereich, der mit "Muster/Suchbereich bearbeiten" maskiert wurde, berühren, oder teilweise davon überdeckt werden. (auch wenn der maskierte / ausgeblendete Bereich im Innern des Suchbereichs liegt)

Detektor BLOB, Randobjekte

Suchbereich

Die Form des Suchbereichs kann auf "Rechteck", "Kreis" oder "Freiform" eingestellt werden. Im Modus "Freiform" kann die Maskierfunktion "Suchbereich bearbeiten" genutzt, und damit nicht relevante Bereiche ausgeblendet werden.
Suchbereich bearbeiten

Mit Klick auf "Suchbereich bearbeiten" öffnet sich das Fenster zur Bearbeitung des Suchbereichs. Funktion: Muster bearbeiten
Einzeichnungen

"Gültige BLOBs": alle gültigen BLOBs, die die Merkmalskriterien innerhalb der eingestellten Merkmalsschwellen erfüllen werden grün markiert. Ungültige BLOBs werden rot markiert.

"BLOB Kontur": alle gültigen BLOBs, die die Merkmalskriterien innerhalb der eingestellten Merkmalsschwellen erfüllen werden mit einer grünen Konturlinie markiert. Ungültige BLOBs werden nicht markiert.
Histogramm

Mit Klick auf "Histogramm" öffnet sich das Histogramm- Fenster.

Detektor BLOB, Reiter Binarisierung, Histogramm


Detektor BLOB, Reiter Binarisierung, Dynamische Schaltschwelle

In diesem Reiter können alle Parameter für die Binarisierung via Dynamischer Schaltschwelle eingestellt werden. Die Dynamische Schaltschwelle kann genutzt werden wenn die gesuchten BLOBs / Objekte signifikant andere Grauwerte aufweisen als der Hintergrund, und dabei die Helligkeit / Beleuchtung über das gesamte Bild gleichmäßig fluktuiert.

Wenn sich die Bildhelligkeit gleichmäßig über das ganze Bild ändert werden die beiden Schaltschwellen automatisch bei jedem Bild nachjustiert. (Bei Nutzung von "Absolute Schaltschwelle" müssten die schaltschwellen manuell nachjustiert werden!)

Bitte beachten:

Bei Nutzung der Dynamischen Schaltschwelle werden die Schwellen bei jedem neuen Bild / Auswertung neu berechnet und nachjustiert.

Wechselnde Beleuchtungsbedingungen oder Oberflächen- Beschaffenheit / -Reflektivität können das Ergebnis beeinflussen.

Abbildung: Detektor BLOB, Reiter Binarisierung, Dynamische Schaltschwelle

Parameter bei Auswahl "Dynamische Schaltschwelle"

Parameter | Funktion
Dynamische Schaltschwelle | Die Schaltschwelle wird automatisch bei jedem Bild auf eine nach statistischen Methoden optimierten Position eingestellt um möglichst gut zwischen Vorder- und Hintergrund unterscheiden zu können.
Helligkeit | Definiert ob BLOB / Objekt heller oder dunkler ist als der Hintergrund.
Grauwertbereich | Grauwertschwellen für die Binarisierung.
Korrekturfaktor für Schwellwert | Der Binarisierungsschwellwert kann über diesen Korrekturfaktor in Richtung der Vordergrund- bzw. der Hintergrund-Helligkeit verschoben werden.

Zur weiteren Veranschaulichung der Dynamsichen Schaltschwelle s. auch: Detektor BLOB, Reiter Binarisierung, Histogramm


Detektor BLOB, Randobjekte

Wenn die Checkbox "Randobjekte" aktiviert ist werden die ausgewählten BLOBs / Objekte berücksichtigt, auch wenn sie nicht komplett innerhalb des gelben Suchbereichs liegen. (Natürlich müssen die Objekte auch in jedem Fall die BLOB- Merkmale innerhalb der gewählten Schaltschwellen erfüllen.)

Bitte beachten: BLOBs werden auch als Randobjekte betrachtet wenn sie einen Bereich, der mit "Muster/Suchbereich bearbeiten" maskiert wurde, berühren, oder teilweise davon überdeckt werden. (auch wenn der maskierte / ausgeblendete Bereich im Innern des Suchbereichs liegt)

Beispiel 1: Randobjekte, berührt äußeren, gelben Suchbereich.

Abbildung: Randobjekte, Beispiel 1/1: Der BLOB berührt den äußeren, gelben Suchbereich. Er wird nicht als gültiger BLOB detektiert / markiert, da "Randobjekte" NICHT aktiviert ist.

Abbildung: Randobjekte, Beispiel 1/2: Der BLOB berührt den äußeren, gelben Suchbereich. Er wird nun als gültiger BLOB detektiert / markiert, da "Randobjekte" AKTIV ist.

Beispiel 2, Randobjekte, berühren inneren, maskierten Bereich.

Abbildung: Randobjekte, Beispiel 2/1: Die BLOBs berühren die inneren, gelben, maskierten Bereiche. Sie werden nicht als gültige BLOBs detektiert / markiert, da "Randobjekte" NICHT aktiviert ist.

Abbildung: Randobjekte, Beispiel 2/2: Die BLOBs berühren zwar die inneren, gelben, maskierten Bereiche, sie werden nun aber als gültige BLOBs detektiert / markiert, da "Randobjekte" AKTIV ist.


Detektor BLOB, Reiter Binarisierung, Histogramm

In diesem Fenster wird das Histogramm der Grauwerte im gelben Suchbereich, und die gewählten Schaltschwellen angezeigt.

Im hier gezeigten Beispiel sind klare Maximas für Vorder- und Hintergrund zu erkennen. Die Schaltschwelle zu Binarisierung ist ca. in der Mitte dazwischen positioniert.

Abbildung: Detektor BLOB, Reiter Binarisierung, Histogramm


Detektor BLOB, Reiter Merkmale

Hier werden die Merkmale / Filterkriterien zur Unterscheidung zwischen gültigen und ungültigen BLOBs / Objekten definiert.

Ablauf:
1. Schritt Binarisierung: Liste von BLOBs (alle gültig / grün).
2. Für jeden BLOB werden alle ausgewählten Merkmale bestimmt.
3. Für jedes Merkmal kann der Bereich für einen gültigen BLOB eingestellt werden. Vorzugsweise jeweilige "Pipette" verwenden.
4. Jeder BLOB wird auf die Einhaltung aller o.g. Merkmale mit ihren Schaltschwellen geprüft.
5. Jeder BLOB, der alle geforderten Merkmale erfüllt, ist ein gültiger BLOB (grün), alle anderen sind ungültig (rot).

Nur mit gültigen BLOBs können weitere Verarbeitungsschritte erfolgen, z.B. Datenausgabe.

Beispiel: Falls die Schwellen für das Merkmal "Fläche" auf den Bereich 100 ... 150 (Pixel) eingestellt wurde, werden nur BLOBs mit einer Fläche innerhalb dieses Bereichs als gültig erkannt (grün).

Checkbox (Default: Aktiv)
aktiv: Merkmal wird berechnet, gefiltert (einstellbare Schwellen), und steht zur Datenausgabe zur Verfügung.
inaktiv: Merkmal wird berechnet, aber NICHT gefiltert, steht aber zur Datenausgabe zur Verfügung.

Abbildung: Detektor BLOB, Reiter Merkmale

"Anzahl" im Reiter Merkmale

Zusätzlich zu den Merkmalen, die zur Filterung der BLOBs genutzt werden. kann die Anzahl der gefundenen und gültigen BLOBs geprüft werden.

Ergebnis positiv: wenn Anzahl der gültigen (gefilterten) BLOBs innerhalb des Bereichs von "Anzahl".
Ergebnis negativ: wenn Anzahl der gültigen (gefilterten) BLOBs außerhalb des Bereichs von "Anzahl".

Wenn der Detektor mehr als 10.000 BLOBs (Maximum) findet, wird das Detektorergebnis negativ und die Verarbeitung wird abgebrochen.

Merkmal | Funktion
Anzahl | Obere und untere Schwelle für die akzeptierte Anzahl von BLOBs (max. 10.000). Falls die Anzahl der BLOB´s außerhalb der eingestellten Schwellen liegt ist das Detektorergebnis negativ, trotzdem werden gültige BLOBs im Bild grün markiert. Hinweis: Defekterkennung über Anzahl = 0
Invertierungs Button | Mit dem "Invertierungs Button" (Default: rot/grün/rot) kann die Logik für die Auswertung invertiert werden. Damit kann der relevante Bereich eingeschlossen oder ausgeschlossen werden.
Pipette- Button (Anzahl) | Durch Klick auf dieses Symbol werden die beiden Schwellen von "Anzahl" auf genau die Anzahl der im Bild gefundenen BLOBs eingestellt.
Checkbox (Anzahl, Default: Aktiv) | aktiv: Merkmal wird berechnet, gefiltert (einstellbare Schwellen), und steht zur Datenausgabe zur Verfügung. inaktiv: Merkmal wird berechnet, aber NICHT gefiltert, steht aber zur Datenausgabe zur Verfügung.

Merkmale / Erste Ebene: Basis Parameter, und BLOB Typ / Geometrisches Modell

Merkmal

Funktion

Pipette- Button (Merkmal)

Durch Klick auf den "Pipette Button" wechselt der Cursor in ein Pipette- Symbol. Wird nun der Cursor bewegt und auf einen Pixel innerhalb eines gültigen (grünen) BLOBs geklickt, werden die Schwellen des gewählten Merkmals auf +/- 10 % des Wertes des BLOBs auf den geklickt wurde eingestellt.

Beispiel: Wurde das Merkmal "Fläche" gewählt und mit Pipette aktiv auf einen Pixel innerhalb eines gültigen BLOBs geklickt, werden die beiden Schwellen für Fläche auf +/- 10% der berechneten Pixelanzahl (= Fläche) des gewählten BLOBs eingestellt.

Checkbox (Merkmal, Default: Aktiv) aktiv: Merkmal wird berechnet, gefiltert (einstellbare Schwellen), und steht zur Datenausgabe zur Verfügung.
inaktiv: Merkmal wird berechnet, aber NICHT gefiltert, steht aber zur Datenausgabe zur Verfügung.
- Fläche | Fläche des BLOB, ohne Löcher, in Pixel.
- Fläche (mit Löchern) | Fläche des BLOB, mit Löchern, in Pixel.
- Konturlänge | Anzahl der Pixel der äußeren Kontur des BLOB.
- Kompaktheit

Kompaktheit des BLOB (idealer Kreis = 1, alle anderen > 1)

Je stärker die Form des BLOBs vom idealen Kreis abweicht, desto größer wird der Wert für die Kompaktheit. Wertebereich. 1 ... 100 (limitiert auf 100, BLOBs mit größeren Werten werden als ungültig markiert)
- Schwerpunkt X | X- Koordinate des BLOB Schwerpunktes
- Schwerpunkt Y | Y- Koordinate des BLOB Schwerpunktes
BLOB Typ /
Geometrisches Modell 		Funktion

Einige Mermale werden berechnet auf der Basis eines gegebenen geometrischen Modells. Z.B. basiert die Exzentrizität auf dem Ellipsen- Fit des Objekts.

- Rechteck,
achsenparallel (R1) 		Umschließendes Rechteck parallel zur Y- und X- Achse. Ausreisser werden nicht eliminiert.

- Rechteck,
minimale Fläche (R2)

 Umschließendes Rechteck mit kleinster Fläche. Ausreisser werden nicht eliminiert.

- Ellipse, äquivalent (E1)

 Äquivalente Ellipse, basierend auf den Momenten der Fläche.

Merkmale / Zweite Ebene: BLOB Typ Parameter

Merkmal | Relevant für | Funktion
- Zentrum X | R1, R2, E1 | X- Koordinate des Zentrums des gefitteten, geometrischen Elements (Rechteck, Ellipse)
- Zentrum Y | R1, R2, E1 | Y- Koordinate des Zentrums des gefitteten, geometrischen Elements (Rechteck, Ellipse)
- Breite | R1, R2, E1 | Breite des geometrischen Elements. Breite >= 0, Breite >= Höhe. Die Orientierung wird so bestimmt, daß die Breite immer größer als die Höhe ist. (Ausnahme: R1, Rechteck, achsenparallel: Breite immer in horizontaler Richtung = parallel zur X- Achse)
- Höhe | R1, R2, E1 | Höhe des geometrischen Elements. Höhe >= 0, Höhe <= Breite. Die Orientierung wird so bestimmt, daß die Breite immer größer als die Höhe ist. (Ausnahme: R1, Rechteck, achsenparallel: Höhe immer in vertikaler Richtung = parallel zur Y- Achse)
- Winkel (180) | R2, E1 | Orientierung der Breite (lange Achse) des Objekts in Grad (°), (Bereich -90... +90°, 0° = Ost, Gegenuhrzeigersinn) siehe unten *1)
- Winkel (360) | R2, E1 | Orientierung der Breite (lange Achse) des Objekts in Grad (°), (Bereich -180 ... +180°, 0° = Ost, Gegenuhrzeigersinn) siehe unten *1)
- Achsenverhältnis | E1 | Verhältnis der langen zur kurzen Achse (a/b)
- Bauch / Rücken, Fläche | E1 | Bauch / Rücken Unterscheidung, basierend auf Fläche, durch Vorzeichen angezeigt. Siehe auch:Detektor BLOB, Reiter Merkmale, Bauch / Rücken

*1) Winkel ( 180° / 360° ), Drehsinn

Abbildung: Drehsinn "Winkel (180)"

Abbildung: Drehsinn "Winkel (360)"


Detektor BLOB, Reiter Merkmale, Bauch / Rücken

"Bauch/Rücken, Fläche" und "Bauch/Rücken, Kontur" beurteilen die Symmetrie eines BLOBs in Bezug auf eine durch die Mitte und der Ausrichtung des BLOBs bestimmt Achse. Wenn ein BLOB vollständig symmetrisch in Bezug auf diese Linie ist, wird das Ergebnis 0, sonst wird es von 0 abweichen Das Vorzeichen des Wertes zeigt an, ob die Seite, links oder rechts dieser Achse "stärker" ausgeprägt ist.

"Bauch/Rücken, Fläche" und "Bauch/Rücken, Kontur" können zur Unterscheidung der Bauch-/Rücken-Lage eines Objekts verwendet werden, wie sie in vielen Bereichen der Zuführtechnik nötig ist. Anwendungen finden sich zum Beispiel an Vibrationsförderern oder in der Robotik.

Abbildung: Bauch / Rücken, Fläche oder Kontur

Das linke Bild zeigt das gesuchte Objekt auf z.B. der Bauchseite liegend. Die Schaltschwellen werden so gewählt, dass diese Bauch- Seite / Lage zu einem positiven Ergebnis führt.
Das mittlere Bild zeigt das selbe Objekt in Rückenlage, in der es als "nicht ok" erkannt wird.
Das rechte Bild zeigt beide Objekte in einem Bild, wobei nur das Objekt in Rücklage als "ok" erkannt wird.

  • "Bauch/Rücken, Fläche" zieht jeden Pixel, der zu dem BLOB gehört für die Berechnung heran.
  • "Bauch/Rücken, Kontur" nutzt nur die Konturpixel des BLOBs für die Berechnung. Dieses Verfahren kann verwendet werden, wenn beispielsweise das Objekt innerhalb der Kontur variiert oder Änderungen aufgrund von Reflexionen oder andere Umwelteinflüssen unterliegt.

Die für die Berechnung verwendete Achse wird durch die Mitte und den Winkel (360°) des geometetrischen Modells, das gewählt wurde, z.B. kleinstes umschließendes Rechteck (R2) oder Ellipse (E1), bestimmt.

Das geometrische Modell für die Berechnung sollte so gewählt werden, dass die Orientierung einen stabilen und eindeutigen Wert zurückliefert. So können hoch symmetrische Objekte (z.B. Rechtecke, Kreise, Quadrate oder punktsymmetrische Objekte) nicht zuverlässig mit dieser Methode bewertet werden. Für Objekte, bei denen das kleinste umschließende Rechteck keine eindeutige Orientierungsangabe liefert (z.B. „L“-förmige Geometrien), kann die Ellipse die bessere Wahl als geometrisches Modell sein


Detektor BLOB, Reiter Sortierung

Die im Reiter “Merkmale” festgelegten Merkmale Detektor BLOB, Reiter Merkmalewerden für jeden BLOB berechnet. Die Ergebnisse dieser Berechnungen können über eine Schnittstelle in einem Datentelegramm an einen PC oder eine SPS versendet werden, wenn das Merkmal im entsprechenden Datenausgabe ausgewählt wurde. Die Reihenfolge in der die Ergebnisse der einzelnen BLOBs versandt werden wird im Reiter „Sortierung“ festgelegt.

Falls z.B. das Merkmal "Schwerpunkt Y" gewählt wurde und es wurden 5 BLOBs gefunden, umfasst das ausgegebene Datentelegramm die Ergebnisse aller 5 BLOBs.

Falls als Sortierkriterium "Fläche" und als Sortierreihenfolge "absteigend" gewählt wurde, wird das Ergebniss (hier: Schwerpunkt Y) das BLOBs mit der größten Fläche zuerst ausgegeben.

Abbildung: Detektor BLOB, Reiter Sortierung

Einstellungen im Reiter Sortierung

Parameter | Funktion
Sortierkriterium | Als Sortierkriterium kann jedes unter "Detektor BLOB/Reiter Merkmale" genannte Merkmal genutzt werden.
Sortierreihenfolge | Sortierreihenfolge "aufsteigend" oder "absteigend"


Detektor Messschieber

Mit diesem Detektor können Objekte auf Maßhaltigkeit geprüft werden.

Farbkanal auswählen

Detektor Messschieber, Reiter Antastung

Detektor Messschieber, Reiter Abstand

Messschieber Ergebnisse / Histogramm Fenster


Detektor Messschieber, Reiter Antastung

Hier können alle Messschieber- Parameter eingestellt, und das Ergebnis Histogramm aufgerufen werden.

Abbildung: Detektor Messschieber, Reiter Antastung

Parameter | Funktion
Antaster Typ | Auswahl des Antaster Typs: - Ein Antaster, beidseitig - Ein Antaster, einseitig - Zwei Antaster, antiparallel, (entgegengesetzt) - Zwei Antaster, gleichgerichtet
Kantenstärke | Kantenstärke / Kontrast ab welchem (0…100) eine Kante als Kante detektiert werden soll.
Glättung | Der Kantenverlauf in Suchrichtung wird geglättet. Mit größeren Werten werden verrauschte Kanten, unscharfe Kanten oder Kanten, die nicht senkrecht zur Suchrichtung stehen, sicherer erkannt. Außerdem können mit größeren Werten eng beieinander liegende Hell-Dunkel-Hell- oder Dunkel-Hell-Dunkel-Übergänge ignoriert werden. Damit lassen sich störende Kanten, z.B. Kratzer, ausblenden. Die Wirkung der Glättung kann über die Schaltfläche "Ergebnisse" grafisch dargestellt werden.
Übergang | Wahl zwischen Hell-Dunkel- oder Dunkel-Hell-Übergang
Anz. Suchstreifen | Anzahl der parallelen Suchstreifen in die die Breite des Suchbereichs aufgeteilt wird. Die Kantenantastung wird innerhalb jedes Suchstreifens über die gesamte Breite durchgeführt. Je mehr Suchstreifen, desto eher wird die erste Kante gefunden. (Feinere Abtastung hat eine längere Ausführungszeit zur Folge)
Ergebnisse | Öffnet Ergebnis- und Histogramm- Fenster


Detektor Messschieber, Reiter Abstand

Hier können alle Parameter für den gesuchten Abstand eingestellt werden.

Abbildung: Detektor Messschieber, Reiter Abstand

Parameter | Funktion
Abstand | Abstandsbereich in Pixel. Blauer Balken: aktueller Abstandswert.
Abstandsart | Für jeden Suchstreifen wird ein Antastpunkt ermittelt. Ist die Zahl der Suchstreifen größer 1, gibt es mehrere Möglichkeiten wie aus diesen Antastpunkten ein Ergebnis ermittelt wird: - Maximum: Es wird der Antastpunkt ausgewählt, der den maximalen Abstand ergibt. - Minimum: Es wird der Antastpunkt ausgewählt, der den minimalen Abstand ergibt. - Mittelwert: Alle Antastpunkte werden arithmetisch gemittelt. Sollten Ausreißer vorliegen, gehen diese in das Ergebnis ein und verfälschen es. - Median: Die Antastpunkte werden aufsteigend sortiert und der mittlere Antastpunkt wird verwendet. Ausreißer verfälschen das Ergebnis nicht.


Messschieber Ergebnisse / Histogramm Fenster

Abbildung: Messschieber Ergebnisse / Histogramm Fenster

Parameter | Funktion
Antastung (x) | Bild des Antasters (x) mit: - Grüne Linie: ermittelte Ergebniskante - Grüne Kreuze: ermittelter Kantenübergang je Suchstrahl - Hellblaue Region: Darstellung “Ausgewählter Suchstrahl”
Kantenstärke | Histogramm mit: - Blaue Linie: Kontrastverlauf im Bild, abhängig von ausgewähltem Suchstrahl - Rote Linie: geforderter Kontrast für Kante („Schaltschwelle“) - Hellblaue Linie: ermittelter Kantenübergang abhängig von ausgewähltem Suchstrahl
Fit, “+”, “-“ | Fit oder Zoom für „Kantenstärke-“ Histogramm
Ausgewählter Suchstreifen | Auswahl des im Antaster- Bild anzuzeigenden Suchstreifens (hellblaue Region) - Gewinner: Gewinner Suchstreifen (abhängig von Einstellungen in Reiter „Abstand”) - “1, 2, ..” Nummer des darzustellenden Suchstreifens


Detektor Barcode

Nächstes Thema: Detektor 2D-Code

Barcode-Detektor, Reiter Referenzstring

Abbildung: Detektor Barcode, Reiter Code

Barcode-Detektor, Reiter Code

Parameter

Funktion

Barcode Typ

Wählen Sie hier den Typ des Barcodes aus, den Sie mit dem Code Leser lesen wollen.

Max. Stringlänge

Max. Länge eines Barcodes. Wenn der Inhalt des Codes die maximale Länge überschreitet, wird der Überhang abgeschnitten.

Beim Lesen von mehreren Codes gleichzeitig, muss dieser Wert auf die maximale Länge des längsten Codes eingestellt werden.

Prüfziffer

Dieser Parameter aktiviert die Erkennung eines Prüfzeichens falls dies im Code vorhanden. Barcodes mit Prüfzeichen sind z.B. Code 39, Codabar, 25 Industrial oder 25 Interleaved. Wird dieser Parameter nicht ausgewählt, dann wird das Prüfzeichen als normales Datenzeichen interpretiert und in der Zeichefolge mit ausgegeben.

Min. Anzahl Codes

Minimale Anzahl der Codes, die innerhalb des Suchbereichs gelesen werden sollen.

Max. Anzahl Codes

Maximale Anzahl der Codes, die innerhalb des Suchbereichs gelesen werden sollen. Wird dieser Wert höher gewählt, als tatsächlich notwendig, so kann sich die Ausführungszeit des Detektors geringfügig erhöhen.
Anzahl Zeichen Spezifiziert die zu erwartende Anzahl von Zeichen im Barcode. Codes mit einer abweichenden Anzahl von Zeichen werden ignoriert. Dies dient zur Erhöhung der Erkennungssicherheit wenn die Anzahl der Zeichen des Codes vorher bekannt ist.

Textausgabe bei Fehllesung

Spezifiziert den Text, der im Falle einer Fehllesung über die Schnittstellen ausgegeben wird. Der Text erscheint nicht in der Ergebnisanzeige.

Polarität

Auswahlmöglichkeit für Druckfarbe des Codes „dunkel auf hell" oder „hell auf dunkel".

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.

Optimierung:

Ausführungsgeschwindigkeit:

  • Suchbereich für Position (gelber Rahmen) nur so groß wie nötig.

Robuste Erkennung:

  • Suchbereich (gelber Rahmen) ausreichend groß?
  • Markanter Kontrast vorhanden?
  • Wurde die Auswahl "Prüfzeichen" aktiviert, obwohl kein Prüfzeichen im Code ist?


Barcode-Detektor, Reiter Referenzstring

Detektor Barcode

Barcode-Detektor, Reiter Qualität

Abbildung: Abbildung, Detektor Barcode, Reiter Referenzstring

Einstellungen im Reiter Referenzstring

Parameter | Funktion
Stringvergleich | Aktiviert die Überprüfung des Inhaltes der gelesenen Informationen. Die Überprüfung des Inhaltes der gelesenen Informationen erfolgt auf Basis von regulären Ausdrücken.
Referenzstring | Dieser Text bzw. reguläre Ausdruck wird zur Verifikation herangezogen. Hier können konkrete Zeichen stehen, die direkt verglichen werden, oder reguläre Ausdrücke, um den Aufbau des gelesenen Ergebnisses zu überprüfen.
Ausdruck hinzufügen | Öffnet eine Liste mit Vorgaben für reguläre Ausdrücke.
Referenzstring einlernen | Liest den Code, der sich gerade unter dem Code Leser befindet und übernimmt den gelesenen Inhalt als Vergleichstext, der Text kann nachträglich noch editiert werden.

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.

Beispiele für Referenzzeichenketten definiert durch reguläre Ausdrücke:

Referenzzeichenkette | Treffer | Beispiel für Treffer
123 | Zeichenkette, die 123 enthält | 01234
\A123 | Zeichenkette, die mit 123 beginnt | 1234
123\Z | Zeichenkette, die mit 123 endet | 0123
\A123\Z | Zeichenkette, die genau 123 entspricht | 123
[123] | Zeichenkette, die eines der Zeichen enthält | 33
[123]{2} | Zeichenkette, die eine Kette von 2 der Zeichen enthält | 23
[12]|[34] | Zeichenkette, die ein Zeichen aus einer der beiden Gruppen enthält | 4

Die wichtigsten Elemente regulärer Ausdrücke:

^ Steht für den Anfang der Zeichenkette

$ Steht für das Ende der Zeichenkette, ggf. inklusive einem Newline als letztes Zeichen

. Steht für jedes Zeichen außer Newline

[...] Steht für jedes in den eckigen Klammern aufgeführte Literal. Ist das erste Zeichen ein '^', so ist der Ausdruck negiert. Mit dem Zeichen '-' kann man Wertebereiche angeben wie in '[A-Z0-9]'. Andere Zeichen verlieren ihre spezielle Bedeutung innerhalb eckiger Klammern, außer '\'.

* Erlaubt 0 oder mehr Wiederholungen des vorhergehenden Literals / Gruppe

+ Erlaubt 1 oder mehr Wiederholungen

? Erlaubt 0 oder 1 Wiederholung

{n,m} Erlaubt n bis m Wiederholungen

{n} Erlaubt genau n Wiederholungen

| Trennt alternative Suchausdrücke


Barcode-Detektor, Reiter Qualität

Barcode-Detektor, Reiter Referenzstring

Barcode-Detektor, Reiter Linien

Abbildung: Abbildung, Detektor Barcode, Reiter Qualität

Einstellungen im Reiter Allgemein

Parameter Funktion

Qualitätsparameter

Bewertung der Druckqualität gemäß dem internationalen Standard ISO/IEC 15416.

Für eine normgerechte Qualitätsbewertung sind bestimmte Mindestanforderungen an die Abbildung des Codes in der Kamera (Auflösung), die Anordnung der Kamera und die Art und Anordnung der Beleuchtung vorgeschrieben. Diese sind in den jeweiligen Normen abgedruckt.

Für die einfachen 1D Barcodes wird die Bewertung der Druckqualität in einem Tupel mit acht Elementen zusammengefasst:

Q1 Overall

Q2 nicht genutzt

Q3 nicht genutzt

Q4 Minimal Reflectance

Q5 Minimal Edge contrast

Q6 Modulation

Q7 Defects

Q8 Decodability

Während die Gesamtqualität der endgültige Symbolgrad ist, weisen die restlichen Grade auf mögliche qualitätsverringernde Ursachen hin. Eine Liste mit häufig vorkommenden Defekten und deren Effekt auf die einzelnen Qualitätsgrade kann man im Standard ISO/IEC 15416 finden.

Die einzelnen Qualitätsgrade sind wie folgt definiert: „overall" ist der Minimalwert aller restlichen Gradwerte. „decode" ist auf 4 gesetzt, wenn das untersuchte Barcodesymbol gelesen werden konnte, und auf 0 anderenfalls. Der „symbol contrast" ist die Differenz zwischen maximalem und minimalem Reflexionswert des Grauwertprofils; stärkerer Kontrast ergibt einen besseren Grad. Der „minimal reflectance" ist auf 4 gesetzt, wenn der minimale Reflexionswert des Grauwertprofils kleiner oder gleich 0.5 der maximale Reflexionswert ist, und auf 0 anderenfalls. Der Kantenkontrast ist der Kontrast zwischen zwei benachbarten Symbolelementen (beide Strich-zu-Loch oder Loch-zu-Strich). Der „minimal edge contrast" bewertet den minimalen Kantenkontrast im Grauwertprofil. Die „modulation" bewertet die Amplitude zwischen den Symbolelementen. Höhere Amplituden bedingen, dass Striche und Löcher zuverlässiger voneinander unterschieden werden können und dieser Grad höher bewertet wird. Die „defects" sind Unregelmäßigkeiten im Grauwertprofil innerhalb einzelner Symbolelemente oder der Quietzonen, deren Vorhandensein mit niedrigerem Grad gekennzeichnet wird. Die „decodability" bezeichnet Abweichungen der Symbolelementbreiten von ihrem Nominalwert, der im entsprechenden Symbologiestandard festgelegt ist. Die „additional requirements" sind weitere symbologie-spezifische Anforderungen wie z.B.: die quiet zone Breiten, das wide/narrow Verhältnis, inter character gaps, guarding patterns oder andere.

Die Druckqualitätsbewertung eines „Composit" Barcodes umfasst die folgenden 24 Grade:

OVERALL:

Q1 Overall

Q2 Overall Linear

Q3 Overall Composite

LINEAR:

Q4 Decode

Q5 Symbol Contrast

Q6 Minimal Reflectance

Q7 Minimal Edge contrast

Q8 Modulation

Q9 Defects

Q10 Decodability

Q11 Additional Requirements

COMPOSITE:

Q12 Decode

Q13 Rap Overall

COMPOSITE RAP:

Q14 Contrast

Q15 Minimal Reflectance

Q16 Minimal Edge Contrast

Q17 Modulation

Q18 Defects

Q19 Decodability

Q20 Codeword Yield

Q21 Unused Error Correction

Q22 Modulation

Q23 Decodability

Q24 Defects

Der Gesamtgrad „overall" von der OVERALL Gruppe ist der endgültige Symbolgrad. Er ist der kleinere der anderen zwei Grade in der Gruppe: „overall linear" und „overall composite", welche der Gesamtgrade des linearen (1D) bzw. compositen (2D) Anteils des compositen Symbols darstellen. Die anderen zwei Gruppen, LINEAR und COMPOSITE, bestehen aus einzelnen Qualitätsgraden beider Symbolanteile und weisen auf mögliche qualitätsverringernde Ursachen hin. Die Grade aus der Gruppe LINEAR entsprechen denjenigen aus dem oben beschriebenen einfachen 1D Barcode Fall. Die Grade aus der Gruppe COMPOSITE entsprechen den PDF 417 Qualitätsgraden, wobei rap overall nach dem so genannten RAP Start-Stop Muster benannt ist, das für composite Symbole spezifisch ist. Zusätzlich stellt die Untergruppe COMPOSITE RAP die einzelnen Grauwertprofilgrade des RAP Musters dar. Diese Grade stimmen mit den einfachen 1D Barcode Qualitätsgraden überein.

Typ Qualitätsparam.

Es gibt zwei Darstellungsformate für Qualitätsparameter. Beide Formate entsprechen den Normen. Die Parameter können mit Werten von A-F oder von 0-4 angegeben werden A, bzw. 4 ist die jeweils beste Bewertung. Die hier gemachte Einstellung wirkt sowohl auf die Anzeige der Qualitätsparameter am Bildschirm, als auch auf die Ausgabe der Qualitätsparameter über die Schnittstellen.

Die Zuordnung ergibt sich wie folgt:

A B C D F

4 3 2 1 0

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


Barcode-Detektor, Reiter Linien

Barcode-Detektor, Reiter Qualität

Barcode-Detektor, Reiter Struktur

Abbildung: Abbildung, Detektor Barcode, Reiter Linien

Einstellungen im Reiter Linien

Parameter | Funktion
Minimale Strichbreite | Die minimale Größe eines Elements, d.h. die minimale Dicke aller Striche und Zwischenräume. Für sehr schmale Barcodes sollte der Wert auf 1.5 reduziert werden. Für sehr große Barcodes kann der Wert entsprechend vergrößert werden, was kürzere Laufzeiten mit sich bringt.
Maximale Strichbreite | Die maximale Größe eines Elements, d.h. die maximale Dicke aller Striche und Zwischenräume. Dieser Wert sollte groß genug sein, damit für das komplette Symbol die Kandidatenregion gefunden wird. Anderseits darf er nicht zu groß gewählt werden, dass zwei benachbarte Barcodes zu einem einzelnen Kandidaten verschmelzen.
Minimale Strichhöhe | Die minimale Höhe des Barcodes. Bei sehr flachen Barcodes mit einer Höhe von weniger als 16 Pixeln ist es sinnvoll die Höhe manuell einzustellen, damit der Barcode gefunden und gelesen werden kann. Die minimale Höhe beträgt 8 Pixel. Bei sehr hohen Barcodes, z.B. mit 70 Pixeln und mehr, kann das manuelle Setzen auf die entsprechende Höhe zu einer Beschleunigung beim Lesen führen.
Orientierung | Erwarteter Barcode Orientierungswinkel. Falls die Barcodes nur mit einer bestimmten Orientierung in den bearbeiteten Bildern erscheinen, so kann man den Wertebereich entsprechend reduzieren. Dadurch werden falsche Kandidaten früher erkannt. Die Ausführungszeit des Operators wird bei Einschränkung des Orientierungswinkels verkürzt. Diese Strategie gilt vor allem dann, wenn die bearbeiteten Bilder viel Hintegrundtextur mit falsch orientierten, barcodeähnliche Strukturen.
Orientierungs- toleranz | Toleranz der Orientierung. Siehe 'Orientierung' für weitere Erklärungen.
Kanten- schwellwert | Innerhalb einer Scanlinie werden Kanten mit Hilfe eines relativen Schwellwertes gefunden. Liegen in dem Barcode Störungen vor oder ist das Rauschen groß, so sollte der 'Kantenschwellwert' auf größere Werte gesetzt werden.
Max. Abweichung (Orientierung) | Ein potentieller Barcode besteht aus Strichen und damit auch Kanten mit einer einheitlichen Orientierung. Die Größe „Maximale Orientierungsabweichung“ gibt an, wie stark der Unterschied in der Orientierung benachbarter Kanten sein darf. Die Maximale Orientierungsabweichung ist ein Differenzwinkel in Gradmaß. Ist ein Barcode ausgefranst, d.h. die Strichkanten sind gestört, so ist die Maximale Orientierungsabweichung groß zu wählen. Mit kleinen Werten dagegen kann die Anzahl falscher Barcode Kandidaten reduziert werden.

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


Optimierung:

Ausführungsgeschwindigkeit:
  • Suchbereich für Position (gelber Rahmen) nur so groß wie nötig

Robustheit:

  • Suchbereich (gelber Rahmen) ausreichend groß?
  • Markanter Kontrast vorhanden?
  • Wurde die Auswahl "Prüfzeichen" aktiviert obwohl kein Prüfzeichen im Code ist?
  • Code ausreichend groß im Sichtbereich ?
  • Ist die Strichbreite ausreichend groß ?


Barcode-Detektor, Reiter Struktur

Barcode-Detektor, Reiter Linien

Abbildung: Detektor Barcode, Reiter Struktur

Einstellungen im Reiter Struktur

Parameter | Funktion
Kantenkontrast relativ | Kanten werden innerhalb einer Scanlinie mit Hilfe eines Schwellwerts gefunden. Der Parameter „Kantenkontrast relativ“ bestimmt, wie dieser Schwellwert relativ zum Dynamikbereich der Grauwerte entlang der Scanlinie berechnet wird. Bei großem Hintergrundrauschen oder Störungen sollte Kantenkontrast relativ auf größere Werte gesetzt werden. Typischer Wertebereich: [0.05 .. 0.2]; Standardwert: 0.05
Kantenkontrast absolut | Mit „Kantenkontrast absolut“ wird die Erkennung falscher Kanten verhindert. Bei Bildern mit hohem Rauschpegel sollte dieser Parameter höher gewählt werden. Bei rauschfreien Bildern mit niedrigem Kontrast kann ein zu hoher Wert die Erkennung richtiger Kanten stören. In solchen Fällen ist es empfehlenswert, den Wert zu reduzieren oder auf 0.0 zu setzen. Typischer Wertebereich: [0.0 .. 10.0]; Standardwert: 5.0
Anz. Scanlinien | Anzahl der Scanlinien, die während des Scannens eines Codes benutzt werden. Reduzierte Anzahl der Scanlinien erhöht die Geschwindigkeit. Bilder besserer Qualität benötigen weniger Scanlinien als Bilder von schlechterer Qualität. Bei durchschnittlicher Bildqualität sind Werte zwischen 2 und 5 ausreichend. Sollte ein Barcode nach Verringerung der Scanlinien nicht mehr gefunden werden, so muss die Anzahl der Scanlinien wieder erhöht werden. Typische Werte: [0, 5, 10, 20 ...]; Standardwert: 0
Min. ident. Scanlinien | Die minimale Anzahl von identischen Scanlinien, um eine Code als gelesen zu akzeptieren. Wenn dieser Parameter nicht gesetzt ist (Wert 0) wird der Barcode gelesen, sobald eine Scanlinie erfolgreich dekodiert wurde. Fehllesungen können reduziert werden wenn dieser Parameter auf 2 oder höher gesetzt wird. Typische Werte: [0, 2, 3, ...]; Standardwert: 0
Start- / Stop- Muster | Setzt die Suche nach Start-, bzw. Stopmuster innerhalb einer Scanlinie auf „Tolerant“ oder „Genau“. Tolerant erhöht die allgemeine Leserate, insbesondere in Bildern mit schlechtem Kontrast. „Genau“ erhöht die Robustheit gegenüber falscher Dekodierung, kann aber auch die allgemeine Leseratte mindern. Standardwert: “Tolerant”
Neigung

Wenn „Neigung“ = „An“, Verbesserung der Lesbarkeit wenn einzelne Linien des Barcodes schräg zur Hauptrichtung des Codes ausgerichtet sind, z.B. wenn der Code durch unebene Oberfläche verzerrt erscheint.

Wenn „Neigung“ = „Aus“, Standardeinstellung wenn alle Linien des Barcodes parallel im Bild erscheinen.

Wenn „Neigung“ =“Auto“ wird zunächst Stellung „Aus“ und dann Stellung „Ein“ getestet, kann Lesezeit erhöhen.

Werte: „Aus, „Auto“, „An“; Standardwert: „Aus

Ruhezone | Steuert die Erkennung der Ruhezonen eines Barcodes. Wenn „Ruhezone“ = „An“, muss die Ruhezone mindestens so breit sein, wie in der entsprechenden Barcode-Norm festgesetzt ist. Wenn „Ruhezone“ auf eine Ganzzahl (>= 1) gesetzt ist, dann muss eine Ruhezone von mindestens „Ruhezone“ x X Pixeln eingehalten werden. Wenn „Ruhezone“ = „tolerant“ ist eine beschränkte Anzahl an Kanten in der Ruhezone erlaubt, aber höchstens eine pro vier Modulbreiten. Das Ziel ist zu verhindern, nur einen Teil des Barcodes zu erkennen, aber dennoch Codes mit einer einfachen Verletzung der Ruhezone noch lesen zu können. Wenn „Ruhezone“ = „Aus“, ist die Erkennung der Ruhezonen ausgeschaltet. Die Erkennung der Ruhezone verhindert, dass einfache Barcodes innerhalb einer Strichsequenz eines längeren und/oder komplexeren Barcodes gefunden werden. Normalerweise liefern Werte zwischen 2 und 4 optimale Ergebnisse, weil dadurch falsche Barcodes unterdrückt werden, während kleine Störungen wie Text, Etikettenkanten, etc. immer noch toleriert werden. Wertevorschläge: „Aus“, „An“, 1, 2, 3, 4, 5; Standardwert: „Aus“

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


Detektor 2D-Code

2D-Code-Detektor, Reiter Code

Nächstes Thema: Detektor OCR

2D-Code-Detektor, Reiter Referenzstring

Abbildung: Detektor 2D Code, Reiter Code

Parameter Funktion

Codetyp

Wählen Sie hier den Typ des 2D Codes aus, der gelesen werden soll.

Max Stringlänge

Max. Länge eines Codes. Wenn der Inhalt des Codes die maximale Länge überschreitet, wird der Überhang abgeschnitten.

Beim Lesen von mehreren Codes gleichzeitig, muss dieser Wert auf die maximale Länge des längsten Codes eingestellt werden.

Min. Anzahl Codes

Minimale Anzahl der Codes, die innerhalb des Suchbereichs gelesen werden sollen.

Max. Anzahl Codes

Maximale Anzahl der Codes, die innerhalb des Suchbereichs gelesen werden sollen. Wird dieser Wert höher gewählt, als tatsächlich notwendig, so kann sich die Ausführungszeit des Detektors geringfügig erhöhen.

Rücksetzen

Parameter rücksetzen dient zum Zurücksetzen der eingelernten Parameter auf den Anfangszustand vor dem Einlernen. Es gibt die Auswahlmöglichkeiten „Standard“, „Erweitert“ und „Maximum". „Standard“ setzt die Grenzen des Suchbereiches so, dass beim Einlernen die Mehrzahl der möglichen Codes erkannt wird. Sollte Ihr Code dennoch nicht erkannt werden, dann wählen Sie die Einstellung „Erweitert“. Kann der Code immer noch nicht gelesen werden, so setzten Sie die Einstellung auf „Maximum". Die Einstellungen „Erweitert" und „Maximum" können die Ausführungszeit verlangsamen. Der Unterschied zu einem kompletten Zurücksetzten des Sensors ist, dass nur die Parameter für den Datamatrix Code zurückgesetzt werden. Die grundsätzlichen Parameter des Sensors wie z.B. für Beleuchtung, Ein- Ausgänge, serielle Schnittstelle usw. bleiben erhalten. Nach dem Zurücksetzen der Parameter kann wieder mit „Einlernen“ ein neuer Einlernvorgang gestartet werden.

Erstes Einlernen /

Zusätzliches Einlernen

Einlernen: der Suchbereich des Sensors wird nach einem Datamatrix Code durchsucht. Wurde ein gültiger Code gefunden, dann werden die Parameter für diesen Code gespeichert. Ist der Einlernvorgang erfolgreich, wird der gefundene Code mit einem grünen Rahmen markiert. Im „Run“ - Modus wird dann nur genau nach diesem eingelernten Code gesucht.

Nach erfolgtem Einlernen erscheint an gleicher Stelle der Button „Zusätzliches Einlernen“. Dieser ermöglicht die Erweiterung der eingelernten Parameter um entweder mehrere verschiedene Codes in einer Konfiguration lesen zu können oder eventuell vorhandene Streubereiche in der Druckqualität eines einzigen Codes zu erfassen. Mit "Zusätzliches Einlernen" wird der bereits eingelernte Parametersatz erweitert.

Textausgabe bei Fehllesung

Spezifiziert den Text, der im Falle einer Fehllesung über die Schnittstellen ausgegeben wird.

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.

Optimierung:

Ausführungsgeschwindigkeit:

  • Suchbereich für Position (gelber Rahmen) nur so groß wie nötig

Robuste Erkennung:

  • Suchbereich (gelber Rahmen) ausreichend groß?
  • Markanter Kontrast vorhanden?


2D-Code-Detektor, Reiter Referenzstring

Detektor 2D-Code

2D-Code-Detektor, Reiter Qualitätsparameter

Abbildung: Detektor 2D Code, Reiter Referenzstring

Einstellungen im Reiter Referenzstring

Parameter | Funktion
Stringvergleich | Aktiviert die Überprüfung des Inhaltes der gelesenen Informationen. Die Überprüfung des Inhaltes der gelesenen Informationen erfolgt auf Basis von regulären Ausdrücken.
Referenzstring | Dieser Text bzw. reguläre Ausdruck wird zur Verifikation herangezogen. Hier können konkrete Zeichen stehen, die direkt verglichen werden, oder reguläre Ausdrücke, um den Aufbau des gelesenen Ergebnisses zu überprüfen.
Ausdruck hinzufügen | Öffnet eine Liste mit Vorgaben für reguläre Ausdrücke.
Referenzstring einlernen | Liest den Code, der sich gerade unter dem Code Leser befindet und übernimmt den gelesenen Inhalt als Vergleichstext, der Text kann nachträglich noch editiert werden.

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.

Beispiele für Referenzzeichenketten definiert durch reguläre Ausdrücke:

Referenzzeichenkette | Treffer | Beispiel für Treffer
123 | Zeichenkette, die 123 enthält | 01234
\A123 | Zeichenkette, die mit 123 beginnt | 1234
123\Z | Zeichenkette, die mit 123 endet | 0123
\A123\Z | Zeichenkette, die genau 123 entspricht | 123
[123] | Zeichenkette, die eines der Zeichen enthält | 33
[123]{2} | Zeichenkette, die eine Kette von 2 der Zeichen enthält | 23
[12]|[34] | Zeichenkette, die ein Zeichen aus einer der beiden Gruppen enthält | 4

Die wichtigsten Elemente regulärer Ausdrücke:

^ | Steht für den Anfang der Zeichenkette
$ | Steht für das Ende der Zeichenkette, ggf. inklusive einem Newline als letztes Zeichen
. | Steht für jedes Zeichen außer Newline
[...] | Steht für jedes in den eckigen Klammern aufgeführte Literal. Ist das erste Zeichen ein '^', so ist der Ausdruck negiert. Mit dem Zeichen '-' kann man Wertebereiche angeben wie in '[A-Z0-9]'. Andere Zeichen verlieren ihre spezielle Bedeutung innerhalb eckiger Klammern, außer '\'.
* | Erlaubt 0 oder mehr Wiederholungen des vorhergehenden Literals / Gruppe
+ | Erlaubt 1 oder mehr Wiederholungen
? | Erlaubt 0 oder 1 Wiederholung
{n,m} | Erlaubt n bis m Wiederholungen
{n} | Erlaubt genau n Wiederholungen
| | Trennt alternative Suchausdrücke


2D-Code-Detektor, Reiter Qualitätsparameter

2D-Code-Detektor, Reiter Referenzstring

2D-Code-Detektor, Reiter Abbildung

Abbildung: Abbildung, Detektor 2D Code, Reiter Qualität

Einstellungen im Reiter Qualität

Parameter

Funktion

Qualitätsparameter

Qualitätsparameter werden als zusätzliche Infomationen zur Bewertung der Qualität der Codes zur Verfügung gestellt. Es gibt Qualitätsparameter nach nach AIM DPM-1-2006 und ISO/IEC 15415 Standard. Die Qualitätsparameter setzen sich aus insgesamt 8 Einzelbewertungen zusammen:

Q1 Overall quality

Q2 Contrast

Q3 Modulation

Q4 Fixed pattern damage

Q5 Decode

Q6 Axial nonuniformity

Q7 Grid nonuniformity

Q8 Unused error correction

Q9 Mean light

Overall quality: Das Minimum aller folgenden Einzelbewertungen.

Contrast: Ist der Bereich zwischen minimaler und maximaler Pixelintensität.

Modulation: Gibt einen Wert für das Verhältnis von Schwarzanteil zu Weißanteil im Code wieder. Sowohl zu viel, als auch zu wenig Schwarzanteil führen zu einer Reduzierung des Wertes. Ein ausgewogenes Verhältnis von Schwarz- und Weißanteil vereinfacht die Zuordnung der einzelnen Module.

Fixed pattern damage: Gibt Auskunft über den Zustand des „Finder Patterns” und der Ruhenzonen des Codes.

Decode quality: hat immer den Wert 4, wenn der Code erfolgreich gelesen wurde. Codes, die nicht gelesen werden können, können auch keiner Qualitätsbewertung unterzogen werden. Weil Datamatrix Codes eine Fehlerkorrektur beinhalten, können Fehler in einzelnen Modulen korrigiert werden. Die Summe der korrigierten Fehler wird im Wert „unused error correction” abgebildet. Es ist durchaus möglich, dass Codes mit einer Unused Error Bewertung von 0 trotzdem gelesen werden können.

Axial nonuniformity: Gibt Auskunft über eine eventuelle horizontale oder vertikale Verzerrung des Codes.

Grid nonuniformity: Gibt Auskunft über generelle Verzerrungen des Codes.

Qualitätsparameter nach AIM DPM-1-2006 sind eine Erweiterung zum ISO/IEC 15415 Standard, welche bestimmte Anforderungen an die Grauwert-Eigenschaften des Bildes des Datamatrix Codes definiert und somit die Reproduzierbarkeit der Qualitätsbewertung zwischen verschiedenen Herstellern verbessert.

Die ungenutzte Fehlerkorrekturkapazität des behandelten Symbols wird im Grad unused error correction berechnet.

Qualitätsparameter nach AIM haben einen Wert mehr, als Qualitätsparameter nach ISO/IEC 15415. Dieser Wert wird mit „Mean Light“ bezeichnet. „Mean light“ ist kein Qualitätswert für den Code, er gibt Aussage über die Qualität des Bildes, indem der durchschnittliche Grauwert der hellen Datacode Module berechnet wird. „Mean light“ kann Werte von 0.0 bis 1.0 haben was 0% bis 100% des maximalen Grauwertes entspricht. Ein Bild hat dann die geforderten Grauwerteigenschaften, wenn der Wert „mean light“ zwischen 70% und 86% liegt (also 0.70 bis 0.86).

Für eine normgerechte Qualitätsbewertung sind bestimmte Mindestanforderungen an die Abbildung des Codes in der Kamera (Auflösung), die Anordnung der Kamera und die Art und Anordnung der Beleuchtung vorgeschrieben. Diese sind in den jeweiligen Normen abgedruckt.

Typ Qualitätsparameter

Es gibt zwei Darstellungsformate für Qualitätsparameter. Beide Formate entsprechen den Normen. Die Parameter können mit Werten von A-F oder von 0-4 angegeben werden A, bzw. 4 ist die jeweils beste Bewertung. Die hier gemachte Einstellung wirkt sowohl auf die Anzeige der Qualitätsparameter am Bildschirm, als auch auf die Ausgabe der Qualitätsparameter über die Schnittstellen.

Die Zuordnung ergibt sich wie folgt:

A B C D F

4 3 2 1 0

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


2D-Code-Detektor, Reiter Abbildung

2D-Code-Detektor, Reiter Qualitätsparameter

2D-Code-Detektor, Reiter Symbole

Abbildung: Detektor 2D Code, Reiter Abbildung

Einstellungen im Reiter Abbildung

Parameter | Funktion
Min. Kontrast | Minimaler Kontrast in Graustufen zwischen hellen und dunklen Elementen des Codes, Wertebereich (1...100).
Polarität | Einstellmöglichkeit, ob heller Code auf dunklem Untergrund oder dunkler Code auf hellem Untergrund gelesen werden soll.
Neigung | Maximale Abweichung des Winkels im L- förmigen Finderpattern vom (idealerweise) rechten Winkel; die Angabe erfolgt im Bogenmaß und korrespondiert mit perspektivischen Verzerrungen, die beim Druck des Symbols oder bei der Bildaufnahme auftreten können.
Gespiegelt | Einstellmöglichkeit, ob der Code gespiegelt aufgebracht wurde, oder nicht. Aufgrund der Symmetrie des Codes ist dies mit bloßem Auge nicht erkennbar. Die Funktion ist hilfreich, wenn z.B. Codes auf transparentem Untergrund von hinten gelesen werden sollen.

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


2D-Code-Detektor, Reiter Symbole

2D-Code-Detektor, Reiter Abbildung

2D-Code-Detektor, Reiter Module

Abbildung: Abbildung, Detektor 2D Code, Reiter Symbole

Einstellungen im Reiter Symbole

Parameter | Funktion
Symbolgröße min. / max. | Nur QR-Code: Größe der Symbole im Bild in Pixel.
Spalten min. / max. | Nur ECC200 und PDF 417: Anzahl der Spalten inklusive Finder Pattern.
Zeilen min. / max. | Nur ECC200 und PDF 417: Anzahl der Zeilen inklusive Finder Pattern.


2D-Code-Detektor, Reiter Module

2D-Code-Detektor, Reiter Symbole

2D-Code-Detektor, Reiter Codedetails

Abbildung: Detektor 2D Code, Reiter Module

Einstellungen im Reiter Module

Parameter | Funktion
Modulgröße min. / max. | Größe der Module in Pixeln.
Modulbreite min. / max. | Nur PDF 417: Breite der Module im Bild in Pixel.
Modulverhältnis min. / max. | Nur PDF 417: Seitenverhältnis der Module im Bild (Höhe zu Breite).
Spaltenabstand | Nur ECC200 und QR-Code: Zulässiger Leerraum zwischen zwei Spalten, z.B. bei genagelten Codes, die keine flächendeckenden Module haben.
Zeilenabstand | Nur ECC200 und QR-Code: Zulässiger Leerraum zwischen zwei Zeilen.


2D-Code-Detektor, Reiter Codedetails

2D-Code-Detektor, Reiter Module

Detektor OCR

Abbildung: Detektor 2D Code, Reiter Codedetails

Einstellungen im Reiter Codedetails

Parameter | Funktion
Version | Nur bei QR-Code: Version des Codes, bei Modell 1 Wertebereich 1..14, bei Modell 2 Wertebereich 1..40. Version gibt die Größe des Codes an. Version 1 bedeutet 21x21 Module, Version 2 bedeutet 25x25 Module . . .(Pro Version je 4 Module mehr)
Modell Typ | Nur bei QR-Code: Modell1 oder Modell 2, Modell 2 ist die neuere Variante, unterstützt größere Codes.
Form | Nur bei ECC200 und QR-Code: Dient zur Spezifikation, ob rechteckige oder quadratische Codes gelesen werden sollen.
Modul Robustheit | Robustheit der Dekodierung gegenüber Datacodes mit sehr kleiner Modulgröße. Wird der Parameter auf 'hoch' gesetzt, so erhöht sich die Wahrscheinlichkeit, dass Datacodes mit sehr kleinen Modulen dekodiert werden können. Zusätzlich sollte in diesem Fall auch die minimale Modulgröße entsprechend angepasst werden, d.h. auf die angenommene minimale Modulgröße bzw. Modulbreite gesetzt werden.
Modul Raster | Nur ECC200: Angabe darüber, ob die Größe der Module in einem gewissen Rahmen variieren darf oder nicht. In Abhängigkeit von diesem Parameter werden verschiedene Algorithmen für die Berechnung der Modulpositionen verwendet. In einem Fall ('fixed') wird ein festes Gitter, bei dem die Abstände zwischen den Modulmittelpunkten alle gleich sind, verwendet. Im anderen Fall ('variable') wird das Gitter an der alternierenden Seite des Finderpatterns ausgerichtet. Bei 'any' werden beide Varianten für das Gitter nacheinander ausprobiert. Zu beachten ist, dass der Wert von 'module_grid' ignoriert wird, wenn 'finder_pattern_tolerance' auf 'high' gesetzt ist. In diesem Fall wird immer von einem festen Gitter ausgegangen. Werteliste: 'fixed', 'variable', 'any' Default: 'fixed' (enhanced: 'any')
Genaues Modell | Spezifiziert, ob die eingegebenen Parameter genau eingehalten werden müssen. Bei Auswahl von „Ja“ werden Codes Außerhalb der Parametergrenzen ignoriert.
Position Muster | Nur QR-Code: Anzahl von Position-Detection-Patterns, die im Bild gut sichtbar sein müssen, damit ein Code gesucht wird.
Suchmuster Toleranz | Nur bei ECC200: Toleranz der Suche gegenüber einem gestörten oder fehlenden Finderpattern. Das Finderpattern umschließt sowohl die L-förmige als auch die gegenüberliegende alternierende Seite. In einem Fall ('low') wird davon ausgegangen, dass das Finderpattern zum großen Teil vorhanden ist und kaum Störungen aufweist. Im anderen Fall ('high') kann das Finderpattern stark gestört sein oder komplett fehlen, ohne dass die Erkennung beeinträchtigt wird. Zu beachten ist allerdings, dass bei dieser Variante eine erhöhte Rechenzeit zu erwarten ist.


Detektor OCR

Detektor OCR, Vorgehensweise

Im folgenden wird die Vorgehensweise zur Einrichtung eines OCR- Detektors zur Klarschriftlesung Schritt für Schritt beschrieben. Da die Einrichtungsschritte auf den Ergebnissen der zuvor durchgeführten Schritten aufbauen, muss diese Abfolge für eine korrekte, prozesssichere Funktion eingehalten werden.

Detektor OCR, Reiter Zeichen (Flexibel)

Abbildung: Detektor OCR

Generelle Abfolge der Parametrierung

  • Segmentierung mit Hilfe der Reiter „Zeichen“ und „Segmente“ sowie des Reiters „Filter“ unter „Job“.
  • Klassifikation mit Reiter „Klassifizierung“ durch Auswahl eines Zeichensatzes sowie durch Vorgabe eines Referenzstrings.
  • Verwerfen von Zeichen, die nicht mit hinreichender Qualität klassifiziert werden konnten mit Reiter „Qualität“.
  • Beim OCR-Detektor ist es nicht ausreichend, die Parameter an einem Bild einzustellen. Prozesssicherheit lässt sich nur an möglichst großen Bildserien beurteilen. Es wird empfohlen, typische Bildsequenzen abzuspeichern und für die Parameteroptimierung in den Simulationsmodus zu laden. Es sollten wenigsten einige Dutzend Bilder verwendet werden, die die Schwankungsbreite des Prozesses abbilden.

Segmentierung

  • Optimierung der Segmentierung mit den beiden Reitern „Zeichen“ und „Segmente“. Ergebnis muss sein, dass alle gewünschten Zeichen sauber segmentiert sind. Das Ergebnis der Klassifikation, d.h. welches Symbol jedem segmentierten Zeichen zugeordnet wurde, spielt hier noch keine Rolle.
  • Die Segmentierung kann durch Vorverarbeitung unter „Job“ – „Filter“ verbessert werden, z.B. durch „Gauss“, „Mean“ oder „Dilatation“/“Erosion“ oder eine Kombination davon. Für eine stabile Segmentierung wird empfohlen, die glättenden Filter wie "Gauss" oder "Mean" einzusetzen.
  • Parameter „Gruppierung der Zeichen“ kann die Segmentierung unterstützen, indem die Zahl der Zeichen (pro Zeichengruppe) vorgegeben wird.
  • Parameter „Max. Abweichung Grundlinie“ gibt an, wie sehr Zeichen vertikal gegenüber der Zeile verschoben sein dürfen. Dies wird in Prozent der Zeichenhöhe angegeben.
  • Überprüfen Sie die korrekte Segmentierung aller Zeichen, bevor Sie zu "Klassifizierung" weitergehen. Die Klassifizierung hat keinen Einfluss auf die Segmentierung. Fehlerhaft segmentierte Zeichen werden fehlerhaft klassifiziert.

Segmentierung Beispiele:

Abbildung: Abbildung 110: Segmentierung ohne Vorgabe für Parameter „Gruppierung der Zeichen“: Es werden alle Zeichen gefunden.

Abbildung: Abbildung 111: Segmentierung mit Vorgabe für Parameter „Gruppierung der Zeichen“ „3 3“: Es werden nur die beiden Dreiergruppen segmentiert.

Abbildung: Abbildung 112: Segmentierung ohne Vorgabe für Parameter „Gruppierung der Zeichen“: Das erste Zeichen „1“ wird nicht segmentiert, da es in der Helligkeit zu stark von den anderen Zeichen abweicht.

Abbildung: Abbildung 113: Segmentierung mit Vorgabe für Parameter „Gruppierung der Zeichen“ „3 3 2 1“: Auch das in der Helligkeit abweichende Zeichen wird segmentiert.

Abbildung: Abbildung 114: Segmentierung mit Parameter „Ausrichtung Text“ = „Schrift horizontal im Bild“: Keine Segmentierung da Zeichen nicht horizontal im Bild liegen.

Abbildung: Abbildung 115: Segmentierung mit Parameter „Ausrichtung Text“ = „Schrift horizontal im Suchbereich“: Segmentierung funktioniert, da Zeichen horizontal im Suchbereich liegen.

Abbildung: Abbildung 116: Segmentierung mit Wert 15% für Parameter „Max. Abweichung Grundline“: Nur die inneren Zeichen werden segmentiert.

Abbildung: Abbildung 117: Segmentierung mit Wert 25% für Parameter „Max. Abweichung Grundline“: Alle Zeichen werden segmentiert.

Klassifikation

  • Hier wird die geeignete Schrift („Zeichensatz“) ausgewählt. Jeder Zeichensatz wird mit unterschiedlich vielen Zeichen angeboten. Es sollte der Zeichensatz gewählt werden, der am besten auf die Anwendung zugeschnitten ist.

  • Nomenklatur der Zeichensätze am Beispiel der Gruppe „Industrial“:

    - „Industrial_0-9“: Alle Ziffern

    - „Industrial_0-9+“: Alle Ziffern und Sonderzeichen

    - „Industrial_A-Z+“: Alle Großbuchstaben und Sonderzeichen

    - „Industrial_0-9A-Z“: Alle Ziffern und alle Großbuchstaben

    - “Industrial“: Alle Zeichen

  • Der Referenzstring hat zweierlei Funktionen:

1.) Beeinflussung der Klassifikation, d.h. der erkannten Zeichen. Für jedes segmentierte Zeichen wird in Relation zu jedem im Zeichensatz enthaltenen Zeichen ein Gütewert (Zuverlässigkeit) bestimmt.

Ohne Vorgabe des Referenzstrings wird das Zeichen mit dem höchsten Gütewert (Zuverlässigkeit) ausgegeben.

Bei Vorgabe des Referenzstrings werden dagegen die N besten Alternativen berücksichtigt (Anzahl der Alternativen). Insgesamt darf für den Referenzstring maximal M Mal ein Zeichen gewählt werden (Anzahl der Korrekturen), das nicht die maximale Zuverlässigkeit hatte.

2.) Beeinflussung des Detektorergebnisses:
Es wird eine Mindestgüte für die gesamte Zeichenkette (Schwelle) vorgegeben. Wird diese unterschritten, ist das Detektorergebnis negativ.

Qualität

  • Ist die Zuverlässigkeit eines der klassifizierten Zeichen unterhalb dem Schwellwert (Minimale Zuverlässigkeit), wird das Detektorergebnis negativ.
  • Eine niedrige Zuverlässigkeit zeigt an, dass das Zeichen nicht sicher klassifiziert wurde. Eine hohe Zuverlässigkeit ist dagegen keine Garantie für eine sichere Klassifizierung!


Detektor OCR, Segmentierung Methode

Einstellungen im Reiter Segmentierung Typ

Festlegung der Segmentierungsmethode.

Parameter | Funktion
Segmentierung | Flexibel: Die Segmentierung sucht nach Zeichenketten, diese müssen minimal 3 Zeichen lang sein, diese Methode hat zwar mehr Zeitbedarf als "Schnell", ist dafür aber auch für kontrastschwache Schriften mit wechselnden Belechtungsverhältnissen geeignet oder anspruchsvolle Punktschriften geeignet.
 | Schnell: Die Segmentierung erfolgt über Binarisierungsschwellen zur Trennung der Zeichen vom Hintergrund. Es können auch Texte mit nur einem Zeichen gelesen werden, diese Methode ist sehr schnell, aber nur bedingt geeignet für kontrastschwache Schriften oder bei wechselnden Beleuchtungsverhältnissen.

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.

Weitere Hinweise zur Arbeit mit dem OCR Detektor: Vorgehensweise bei der Einrichtung

Weitere Hinweise zur Arbeit mit Detektoren: Erstellen und Bearbeiten von Detektoren


Detektor OCR, Reiter Zeichen (Flexibel)

Detektor OCR

Detektor OCR, Reiter Segmente

Festlegung der grundlegenden Einstellungen der zu lesenden Zeichen.

Abbildung: Abbildung, Detektor OCR, Reiter Zeichen

Parameter Funktion

Zeichen Höhe

Max. Höhe eines Schriftzeichens in Pixeln.

Zeichen Breite

Max. Breite eines Schriftzeichens in Pixeln.

Strichstärke

Durchschnittliche Breite der Linien der Schrift in Pixeln.

Polarität

Auswahlmöglichkeit, ob dunkle Schrift auf hellem Grund oder umgekehrt.

Ausrichtung Text

„Horizontal im Bild“: die Schrift muss immer horizontal im Bild liegen. Gedrehte Schriften werden nicht oder falsch gelesen.

„Horizontal im Suchbereich“: Über den Drehwinkel des Suchbereichs kann die Verdrehung der Schrift gegenüber der Horizontalen im spezifiziert werden.

Max. Anzahl Linien

Max. Anzahl der zu lesenden Zeilen

Nur Großbuchstaben

Einschränkung auf Großbuchstaben

Punkte zu Zeichen verbinden

Verbindet einzelne Punkte, z.B. einer Punktschrift oder einer unsauber gedruckten Schrift zu kompletten Zeichen

Einzeichnung Buchstabengröße

Schaltet das Rechteck zur Markierung der Buchstabengröße ein und aus

Einzeichnung Segmentierung

Schaltet die farbliche Markierung der segmentierten Buchstaben ein und aus

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.

Optimierung:

Ausführungsgeschwindigkeit:

  • Suchbereich für Zeichen (gelber Rahmen) nur so groß wie nötig


Detektor OCR, Reiter Segmente

Festlegung der grundlegenden Einstellungen der zu lesenden Zeichen.

Detektor OCR, Reiter Zeichen (Flexibel)

Detektor OCR, Reiter Klassifizierung

Abbildung: Abbildung, Detektor OCR, Reiter Segmente

Parameter Funktion

Unterdrücke Hintergrundlinien

Kann benutzt werden, um störende Linien im Hintergrund auszublenden.

Bruchstücke verbinden

Verbindet Zeichen, die z.B. durch unsauberen Druck oder Beschädigung in zwei Teile zerfallen sind zu einem Zeichen.

Erhabene / eingeprägte Schrift

Ermöglicht das Lesen von erhabender oder eingeprägter Schrift, z.B. wenn beleuchtungsbedingt die Zeichen z.B. in weißer Schrift mit schwarzem Rand (Schatten) oder umgekehrt erscheinen.

Punkte ausgeben

Aktiviert Ausgabe gelesener Sonderzeichen wie z.B. Punkte und Kommas.

Trennzeichen ausgeben

Aktiviert Ausgabe gelesener Sonderzeichen wie z.B. Bindestrichen.

Gruppierung der Zeichen

Ermöglicht die Vorgabe, wie die Zeichen in der zu lesenden Zeichenkette gruppiert sind. Werden die Zeichen z.B. immer in zwei Vierergruppen gedruckt, so kann dies über die Eingabe “ 4 4 “ vorgegeben werden.

Diese Funktion sollte verwendet werden, wenn bei mehreren Auswertungen im gleichem Bild unterschiedlich lange Zeichenketten gelesen werden.

Max. Abweichung Grundlinie

Maximal zulässige horizontale Abweichung eines Zeichens von einer geraden zwischen dem ersten und dem letzten Zeichen. Diese Funktion kann verwendet werden, wenn die Zeichen nicht auf einer horizontalen Linie gedruckt sind.


Detektor OCR, Reiter Klassifizierung

Festlegung der grundlegenden Einstellungen der zu lesenden Zeichen.

Detektor OCR, Reiter Segmente

Detektor OCR, verfügbare Schriften

Detektor OCR, Reiter Qualität

Abbildung: Abbildung, Detektor OCR, Reiter Klassifizierung

Parameter | Funktion
Zeichensatz | Verfügbare Schriften s. Kap. Detektor OCR, verfügbare Schriften 0-9 => nur Ziffern 0-9+ => Ziffern und Sonderzeichen A-Z => nur Großbuchstaben A-Z+ => Großbuchstaben und Sonderzeichen Keine Erweiterung => alle Zeichen
Referenzstring (Checkbox) | Aktiviert die Überprüfung des Inhaltes der gelesenen Informationen. Die Überprüfung des Inhaltes der gelesenen Zeichen erfolgt auf Basis von regulären Ausdrücken.
Referenzstring | Dieser Text bzw. reguläre Ausdruck wird zur Verifikation herangezogen. Hier können konkrete Zeichen stehen, die direkt verglichen werden, oder reguläre Ausdrücke, um den Aufbau des gelesenen Ergebnisses zu überprüfen. Zeichen, die als Buchstabe oder als Zahl sehr ähnlich sind wie z.B. „B“ oder „8“ können bei Verwendung von regulären Ausdrücken im Referenzstring automatisch korrigiert werden.
Ausdruck hinzufügen | Öffnet eine Liste mit Vorgaben für reguläre Ausdrücke.
Referenzstring einlernen | Liest den Code, der sich gerade unter dem Codeleser befindet und übernimmt den gelesenen Inhalt als Vergleichstext, der Text kann nachträglich noch editiert werden.
Anzahl der Alternativen | Gibt an, wie viele mögliche Alternativen durchsucht werden dürfen, um ein Zeichen entsprechend dem regulären Ausdruck im Referenzstring zu finden und automatisch zu ersetzen.
Anzahl der Korrekturen | Max. Anzahl der Zeichen, die nach Überprüfung durch den regulären Ausdruck geändert werden dürfen.
Schwelle | Schwelle für Gut-Schlecht Entscheidung: wenn Anhand der eingestellten Schwelle die Anzahl der Korrekturen zu hoch ist, wird der gesamte Text als „nicht gelesen“ bewertet.
Beispiele für Referenzzeichenketten definiert durch reguläre Ausdrücke:
Referenzzeichenkette | Treffer | Beispiel für Treffer
123 | Zeichenkette, die 123 enthält | 01234
\A123 | Zeichenkette, die mit 123 beginnt | 1234
123\Z | Zeichenkette, die mit 123 endet | 0123
\A123\Z | Zeichenkette, die genau 123 entspricht | 123
[123] | Zeichenkette, die eines der Zeichen enthält | 33
[123]{2} | Zeichenkette, die eine Kette von 2 der Zeichen enthält | 23
[12]|[34] | Zeichenkette, die ein Zeichen aus einer der beiden Gruppen enthält | 4
Die wichtigsten Elemente regulärer Ausdrücke:
^ | Steht für den Anfang der Zeichenkette
$ | Steht für das Ende der Zeichenkette, ggf. inklusive eines Zeilenwechsels als letztes Zeichen
. | Steht für jedes Zeichen außer Zeilenwechsel
[...] | Steht für jedes in den eckigen Klammern aufgeführte Zeichen. Ist das erste Zeichen ein '^', so ist der Ausdruck negiert. Mit dem Zeichen '-' kann man Wertebereiche angeben wie in '[A-Z0-9]'. Andere Zeichen verlieren ihre spezielle Bedeutung innerhalb eckiger Klammern, außer '\'.
* | Erlaubt 0 oder mehr Wiederholungen des vorhergehenden Zeichens / Gruppe
+ | Erlaubt 1 oder mehr Wiederholungen
? | Erlaubt 0 oder 1 Wiederholung
{n,m} | Erlaubt n bis m Wiederholungen
{n} | Erlaubt genau n Wiederholungen
| | Trennt alternative Suchausdrücke


Detektor OCR, verfügbare Schriften

Detektor OCR, Reiter Klassifizierung

Detektor OCR, Reiter Qualität

Übersicht der verschiedenen Schriften:

Semi

Dotprint

Handwritten

Industrial

MICR

OCRA

OCRB

Pharma


Detektor OCR, Reiter Qualität

Festlegung der grundlegenden Einstellungen der zu lesenden Zeichen.

Detektor OCR, Reiter Klassifizierung

Detektor OCR

Abbildung: Abbildung, Detektor OCR, Reiter Qualität

Parameter | Funktion
Qualität | Die Qualität jedes einzelnen Zeichens wird mit einem Wert von 0 – 100 % bewertet. Je höher der Wert, umso sicherer ist wurde das gelesene Zeichen bestimmt. Kleine Werte sprechen für eine eher unsichere Zuordnung.
Minimale Zuverlässigkeit | Wenn die Zuverlässigkeit unterhalb der eingestellten Schwelle liegt, wird das Zeichen als nicht gelesen bewertet und durch einen Platzhalter ersetzt.
Ersatzzeichen | Platzhalter für den Fall, dass die minimale Zuverlässigkeit nicht erreicht wurde.


OCR-Detektor, Reiter Schwelle

Festlegung der grundlegenden Einstellungen der zu lesenden Zeichen.

Parameter | Funktion
Automatisch | Automatische Binarisierung aktivieren. Der Binarisierungsschwellwert wird automatisch aus der Helligkeitsverteilung von Vorder- und Hintergrund berechnet.
Korrekturfaktor für Schwellwert | Der Binarisierungsschwellwert kann in Richtung der Vordergrund- bzw. der Hintergrund-Helligkeit verschoben werden.
Manuell | Manuelle Binarisierung aktivieren.
Schwelle Helligkeit | Feste Eingabe des Binarisierungsschwellwerts.
Polarität | Auswahlmöglichkeit, ob dunkle Schrift auf hellem Grund oder umgekehrt.
Max. Stringlänge | Maximal erlaubte Länge der Zeichenkette.
Bruchstücke verbinden | Aus, 1...30, geeignet um fragmentierte Zeichen aus mehreren Bruchstücken zu verbinden.
Einzeichnung Buchstabengröße | Schaltet das Rechteck zur Markierung der Buchstabengröße ein und aus
Einzeichnung Segmentierung | Schaltet die farbliche Markierung der segmentierten Buchstaben ein und aus

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.

Weitere Hinweise zur Arbeit mit dem OCR Detektor:

Vorgehensweise bei der Einrichtung

Weitere Hinweise zur Arbeit mit Detektoren:

Erstellen und Bearbeiten von Detektoren


OCR-Detektor, Reiter Zeichen (Schnell)

Festlegung der grundlegenden Einstellungen der zu lesenden Zeichen.

Parameter | Funktion
Zeichenhöhe | Typ. Höhe eines Schriftzeichens in Pixeln.
Zeichenbreite | Typ. Breite eines Schriftzeichens in Pixeln.
Ausrichtung Text

„Horizontal im Bild“: die Schrift muss immer horizontal im Bild liegen. Gedrehte Schriften werden nicht oder falsch gelesen.

„Horizontal im Suchbereich“: Über den Drehwinkel des Suchbereichs kann die Verdrehung der Schrift gegenüber der Horizontalen spezifiziert werden.
Teilung | Trennt horizontal verbundene Zeichen, die von der eingestellten Zeichenbreite wesentlich abweichen.
Reduktion | Reduziert segmentierte Bereiche, die durch "Bruchstücke Verbinden" vergrößert wurden auf die ursprüngliche Größe.
Auswahl Zeichen | Angabe von Toleranzen zu den eingegebenen Zeichengrößen.
Höhe | Angabe von Toleranzen zur eingegebenen Zeichenhöhe (50% bis 150%). Zunächst mit "Aktiv" zu aktivieren.
Breite | Angabe von Toleranzen zur eingegebenen Zeichenbreite (50% bis 150%). Zunächst mit "Aktiv" zu aktivieren.
Fläche | Angabe von Toleranzen zu der aus den Einstellungen resultierenden Zeichenfläche (10% bis 100%). Zunächst mit "Aktiv" zu aktivieren.
Keine Zeichen auf Grenze Suchbereich | Verwerfen von Zeichen, die auf über die Grenze des Suchbereichs ragen.

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.

Weitere Hinweise zur Arbeit mit dem OCR Detektor:

Vorgehensweise bei der Einrichtung

Weitere Hinweise zur Arbeit mit Detektoren:

Erstellen und Bearbeiten von Detektoren


Ergebnis OCR

Mit dieser Funktion wird der definierte Job auf dem PC ausgeführt, und das "Ergebnis Statistik" Fenster mit Detektorliste und Auswerteergebnissen angezeigt. Die Ausführungszeiten werden in diesem Modus nicht aktualisiert, da sie vom Sensor nicht vorliegen.

Detektor OCR, Reiter Qualität

Im Run-Modus werden die detailierten Prüfergebnisse des in der Auswahlliste markierten Detektors angezeigt.

Im Bildfenster werden – sofern eingestellt – das Bild, die Such- und Merkmalsbereiche und Ergebnisgraphen angezeigt.

Abbildung: Abbildung, Detektor OCR, Ergebnisausgabe

Die angezeigten Parameter variieren in Abhängigkeit vom ausgewählten Detektortyp:

Parameter | Funktion
String | Gelesene Zeichen
Sicherheit | Wert von 0-100%, gibt an, wie zuverlässig der Leser ein Zeichen bewerten konnte.
Stringlänge | Länge des gelesenen Strings
Pos X | Position X in Pixeln
Pos Y | Position Y in Pixeln
Winkel | Winkel zur Horizontalen
Ergebnis Vergleich | Ist ein Maß für die Qualität des Ergebnisses. Wenn anhand des Referenzstrings keine Korrekturen erforderlich waren, ist dieser Wert bei 100%. Mit steigender Anzahl von Korrekturen sinkt der Wert ab.
Referenzstring getroffen | Anzeige, ob der ausgegebene String mit dem Referenzstring übereinstimmt.
Ergebnis Vergleich | Anzeige, ob die minimale Zuverlässigkeit erreicht wurde.
Abgeschnitten | Anzeige, ob ein Teil des Strings abgeschnitten wurde.


Detektor Farbwert

Ermittelt mittlere Farbwerte RGB / HSV / LAB zur Ausgabe über die Schnittstellen.

Farbkanal auswählen

Tab Farbwert


Farbkanal auswählen

Auswahl des Farbmodelle und des, oder der Farbkanäle, auf denen der Detektor arbeiten soll.

Ein Bild, das mit einem Farbchip aufgenommen wurden enthält durch die Farbkomponente mehr Information als ein monochromes Bild.

Diese Eigenschaft kann bei der Farbkanalauswahl genutzt werden. Durch Auswahl der Farbkanäle können einzelne Bereiche gezielt verstärkt oder abgeschwächt werden.

Das angezeigte Bild wird abhängig vom Bildchip und vom gewählten Detektor angezeigt.

- Monochrom Chip: Anzeige immer schwarz / weiß

- Farbchip + Farbdetektor: Anzeige immer farbig

- Farbchip + Objekterkennungsdetektoren: Monochrombild, Anzeige abhängig vom gewählten Farbraum und den Farbkanälen

Abbildung: Farbkanal

Parameter | Funktion
Farbraum | Farbräume: RGB, Farbmodell RGB, HSV, Farbmodell HSV, LAB, Farbmodell LAB
Farbkanal | Ein oder mehrere Kanäle können gewählt werden.


Detektor Farbwert, Parameter

Tab Farbwert

Ermittelt mittlere Farbwerte RGB / HSV / LAB zur Ausgabe über die Schnittstellen.

Nächstes Thema: Detektor Farbfläche

Funktion: Muster bearbeiten

Abbildung: Farbwert

Parameter (alternativ je Einstellung in Farbkanal) | Funktion
Rot (Farbton / Luminaz) | Schwellen für gewählten Kanal min. / max.
Grün (Sättigung / A) | Schwellen für gewählten Kanal min. / max.
Blau (Intensität / B) | Schwellen für gewählten Kanal min. / max.
Suchbereich (Form) | Die Form des Suchbereiches kann als Rechteck, Kreis oder als Freiform gewählt werden. Wenn Freiform gewählt wird, ist „Suchbereich bearbeiten“ aktiv.
Suchbereich bearbeiten | Über den Parameter Suchbereich bearbeiten können Bereiche des Suchbereichs ausgeblendet werden. Wie mit einem Radierer können im Suchbereich die Bereiche entfernt werden, die für die Auswertung nicht benötigt werden. Diese markierten Bereiche können auch invertiert werden, also die Bereiche markiert werden, die für die Ausführung wichtig sind etc. s. Kap Funktion: Muster bearbeiten
Anzeige Suchbereich | Ein- / Ausschalten der Anzeige der Suchbereich- Bearbeitungen

Prädestinierte Anwendungen:

- Ausgabe der ermittelten Farbparameter über eine der Schnittstellen zur Weiterverarbeitung.

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


Detektor Farbfläche

Ermittelt den Flächenanteil einer Farbe oder eines Farbbereichs. Abhängig vom Anteil der Fläche kann ein gut-schlecht Ergebnis erzeugt werden.

Farbkanal auswählen

Detektor Farbfläche, Farbauswahl

Detektor Farbfläche, Schwellen


Detektor Farbfläche, Farbauswahl

Nächstes Thema: Detektor Farbfläche, Schwellen

Funktion: Muster bearbeiten

Ermittelt den Flächenanteil einer Farbe oder eines Farbbereichs. Abhängig vom Anteil der Fläche kann ein gut-schlecht Ergebnis erzeugt werden.

Abbildung: Farbfläche

Parameter (alternativ je Einstellung in Farbkanal)Detektor | Funktion
Rot (Farbton / Luminaz) | Schwellen für gewählten Kanal min. / max.
Grün (Sättigung / A) | Schwellen für gewählten Kanal min. / max.
Blau (Intensität / B) | Schwellen für gewählten Kanal min. / max.
Suchbereich (Form) | Die Form des Suchbereiches kann als Rechteck, Kreis oder als Freiform gewählt werden. Wenn Freiform gewählt wird, ist „Suchbereich bearbeiten“ aktiv.
Suchbereich bearbeiten | Über den Parameter Suchbereich bearbeiten können Bereiche des Suchbereichs ausgeblendet werden. Wie mit einem Radierer können im Suchbereich die Bereiche entfernt werden, die für die Auswertung nicht benötigt werden. Diese markierten Bereiche können auch invertiert werden, also die Bereiche markiert werden, die für die Ausführung wichtig sind etc. s. Kap Funktion: Muster bearbeiten
Einzeichnung | Auswahl der Pixel, die einen Grauwert innerhalb (Gültige Pixel) oder außerhalb (Ungültige Pixel) der Grauwertbereichsfestlegung unter „Grauschwelle“ aufweisen. Diese werden dann aus Auswahlhilfe farbig markiert. So können sehr leicht z.B. Störpixel / Bereiche, die nicht vom Grauwertbereich abgedeckt sind erfasst werden.
Anzeige Suchbereich | Ein- / Ausschalten der Anzeige der Suchbereich- Bearbeitungen
Farb Histogramm | Ermöglicht die grafische Einstellung der Schwellen durch ein Histogramm

Prädestinierte Anwendungen:

- Farbiges Objekt mit bestimmter Größe mit variierender Position in der ROI

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


Farbhistogramm

Es werden je nach gewähltem Farbmodell die Histogramme für RGB, HSV oder LAB angezeigt.
Das Histogramm zeigt die Verteilung der Farben im Suchbereich. Über die Buttons können einzelne Kanäle aus- oder eingeschaltet werden. Über kleine Markierungen unterhalb des Histogramms können die Grenzwerte für die Farberkennung verschoben werden. Der markierte Bereich wird in der entsprechenden Farbe unterlegt. Überkreuzen der Grenzwerte führt zur Invertierung der Auswahl. Kann eine Farbe mit nur einem Kanal sicher erkannt werden, sind die Grenzwerte der anderen Kanäle auf den unteren oder oberen Endwert einzustellen, damit diese keinen störenden Einfluss bei der Erkennung haben.

Abbildung: Farbhistogramm


Detektor Farbfläche, Schwellen

Ermittelt den Flächenanteil einer Farbe oder eines Farbbereichs. Einstellung der Schwellen.

Nächstes Thema: Detektor Farbliste

Abbildung: Farbfläche, Schwellen

Parameter | Funktion
Schaltschwelle | Schwellen für Flächenanteil min. / max.
Objektgröße | Min. / Max. Objektgröße (zusammenhängender Farbbereich)

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


Detektor Farbliste

Vergleicht eine Farbe mit einer Liste bekannter Farben. Ergebnis: Nummer oder Name der Farbe, die am nächsten liegt. Somit könnten Teile anhand der Farbe sortiert werden.

Farbkanal auswählen

Detektor Farbliste, Farbauswahl


Detektor Farbliste, Farbauswahl

Nächstes Thema: Ausgabe von Prüfergebnissen

Funktion: Muster bearbeiten

Vergleicht eine Farbe mit einer Liste bekannter Farben. Ergebnis: Nummer oder Name der Farbe, die am nächsten liegt. Somit könnten Teile anhand der Farbe sortiert werden.

Abbildung: Farbliste

Parameter | Funktion
Farbabstand | Abstand der aktuellen Farbe ggü. der eingelernten Farbe. Die Metrik des Farbabstandes ist abhängig vom Farbmodellel, dabei gehen nur die jeweils gewählten Farbkanäle ein. *1)
Name | Name der Farbe, kann per Doppelklick auf den Namen geändert werden, z.B. Rot, Gelb, Blau
Musterfarbe | Darstellung der eingelernten Farbe als Muster und in Zahlenwerten (RGB / HSV / LAB)
Einlernen | Lernt die Farbe oder den Farbbereich im Suchbereich ein, sollen mehrere verschiedene Farben eingelernt werden, so muss ein kleiner Suchbereich jeweils auf die einzulernende Farbe geschoben werden.
+ | Neue Zeile am Ende der Tabelle dazu
- | Markierte Zeile löschen
Alle löschen | Alle Einträge der Liste löschen
Auf | Markierte Zeile um eine Zeile nach oben schieben
Ab | Markierte Zeile um eine Zeile nach unten schieben
Suchbereich (Form) | Die Form des Suchbereiches kann als Rechteck, Kreis oder als Freiform gewählt werden. Wenn Freiform gewählt wird, ist „Suchbereich bearbeiten“ aktiv.
Suchbereich bearbeiten | Über den Parameter Suchbereich bearbeiten können Bereiche des Suchbereichs ausgeblendet werden. Wie mit einem Radierer können im Suchbereich die Bereiche entfernt werden, die für die Auswertung nicht benötigt werden. Diese markierten Bereiche können auch invertiert werden, also die Bereiche markiert werden, die für die Ausführung wichtig sind etc. s. Kap Funktion: Muster bearbeiten
Einzeichnung Anzeige Suchbereich | Auswahl der Pixel, die einen Grauwert innerhalb (Gültige Pixel) oder außerhalb (Ungültige Pixel) der Grauwertbereichsfestlegung unter „Grauschwelle“ aufweisen. Diese werden dann aus Auswahlhilfe farbig markiert. So können sehr leicht z.B. Störpixel / Bereiche, die nicht vom Grauwertbereich abgedeckt sind erfasst werden. Ein- / Ausschalten der Anzeige der Suchbereich- Bearbeitungen
Anzeige Suchbereich | Ein- / Ausschalten der Anzeige der Suchbereich- Bearbeitungen
Farb Histogramm | Ermöglicht die grafische Einstellung der Schwellen durch ein Histogramm

*1) Im RGB- und im LAB- Farbmodell ist der Farbabstand der euklidische Abstand.
Im Farbmodell LAB ist die Farbverteilung über den gesamten Raum nahezu homogen, d.h. Farbabstände des selben Betrages führen zur sehr ähnlichen Wahrnehmung der Farbdifferenz über das gesamte Modell. Deshalb kann in diesem Modell davon gesprochen werden, dass ein Abstand von >= 5 zur Wahrnehmung einer anderen Farbe führt.

Prädestinierte Anwendungen:

- Sortierung von Farbobjekten über Index in der Liste

- Einfaches Prüfen homogener Farbflächen (Farbe wird über Suchbereich gemittelt, Farbe einlernen, kleinen Farbabstand einstellen (Toleranzband) ... fertig)

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


Ausgabe von Prüfergebnissen

Hier definieren Sie die Belegung und logische Verknüpfung der digitalen Signalausgänge, sowie die Schnittstellen und Ausgabedaten des SBS .

Pinbelegung

Ausgangssignale (Digitalausgänge / Logik)

Schnittstellen

Zeitsteuerung Digitale Ausgänge

Datenausgabe

Bildübertragung Parameter

Archivierung Parameter


Pinbelegung

Hier werden folgende Einstellungen vorgenommen:

1. Festlegung welche der variabel nutzbaren I/O als Ein- oder Ausgang genutzt werden sollen.
Pin 05 rosa, Pin 06 gelb, Pin 07 schwarz (LED B) und Pin 08 grau (LED C), können sowohl als Eingang oder als Ausgang genutzt werden.

2. Zuordnung der Funktionen zu den Ein- / Ausgängen.
In den jeweiligen Listboxen sind die für diesen Ein- oder Ausgang verfügbaren Funktionen aufgeführt und können hier auch definiert werden. Die Funktionen die unter. "Alleinige Funktionen" aufgeführt sind, sind nur über diesen Pin / Leitung verfügbar.

Abbildung: Ausgabe, Pinbelegung

Funktionen der Eingänge

Funktion | Beschreibung
H/W Trigger | Hardware Trigger (nur über Pin 03 weiß verfügbar)
Encoder A+ | Eingang für Encoder, Spur A+(nur über Pin 10 violett verfügbar)
Encoder B+ | Eingang für Encoder, Spur B+(nur über Pin 05 rosa verfügbar)
Trigger freischalten | Funktion zum Freischalten oder Unterdrücken von Triggersignalen. Das Einlesen dieser Funktion benötigt ca. 1 ms. Es entsteht dadurch also eine Pause in der ein Triggersignal ignoriert wird, obwohl das Enable Trigger Signal anliegt.
Job 1 oder 2 | Jobumschaltung zwischen Job 1 und Job 2 abhängig von Pegel an diesem Eingang. Low = Job 1, High = Job 2.
Job 1..N | Jobumschaltung über Impulsfolge an einem Eingang, Wenn möglich sollte der Jobwechsel über die Binärsignale (binär codiert) stattfinden.
Einlernen temporär / Einlernen permanent | Einlernen aller Detektoren, sobald an diesem Eingang ein High Signal anliegt und ein Trigger erfolgt. Temporär = Speicherung im RAM, d.h. flüchtig nach Reset, Permanent = Speicherung im Flash, d.h. dauerhaft, auch nach Reset
Jobwechsel (BitX), binär codiert | Jobumschaltung via binärem Bitmuster an bis zu 5 hierfür definierbaren Eingängen, d.h. Umschaltung zwischen 1 bis zu 32 Jobs. Rangfolge der Bits laut zugewiesener, aufsteigender Eingangsbezeichnung 1-5. Bit 1= LSB. S. auch Kap. Job 1… 31 via binärem Eingangs-Bitmuster
Repeat Mode Enable | Es werden Bilder aufgenommen und ausgewertet solange: An diesem Eingang ein High Pegel anliegt und keines der folgenden Abbruchkriterien erfüllt ist: - "Gesamt Jobergebnis" = positiv (einstellbar unter Ausgabe/Ausgangssignale) - "Max. Zykluszeit" nicht erfüllt ist (falls aktiviert). Wenn der Eingang Repeat Mode Enable genutzt wird wirkt dieser gleichzeitig zu o.g. Funktion als Trigger Enable, d.h. nur wenn an diesem Eingang ein High Pegel anliegt werden Trigger angenommen und verarbeitet. s. u. Eingang: Repeat Mode Enable, mit Trigger
Keine Funktion, undefiniert | Keine Funktion, nicht genutzt

Funktionen, die schon vollkommen ausgenutzt sind, erscheinen in der Listbox blass grau, da nicht mehr verfügbar. Alle Eingangssignale müssen eine minimale Signallänge von 2ms aufweisen.

Abbildung: Ausgabe, Eingänge

Anschluss Encoder

Werden beide Spuren A+ und B+ verwendet ist die Vorwärts- / Rückwärts- Unterscheidung / Zählung möglich.

Abbildung: Encoder Spuren A+/ B+

Funktionen der Ausgänge

Funktion Beschreibung

Auswerfer

Spezieller Auswerferausgang (kann mit bis zu 100mA belastet werden, alle anderen Ausgänge = 50mA) nur über Pin 12 RDBU verfügbar (entspricht der Anzeige- LED „A").

Ergebnis

Ergebnisausgang, jedem der hier definierten Ergebnisausgänge kann im Reiter „I/O- Logik" ein Detektorergebnis oder eine Verknüpfung von Detektorergebnissen zugewiesen werden.

Bestätigung Jobwechsel

Bei Jobwechsel via Digital I/O („Job 1..N" oder „Job PinX, binär codiert") kann hier zur Bestätigung des Erfolgsfalles eine Low/High Flanke eingestellt werden. Die High Flanke wird gesetzt, nachdem der neue Job- Inhalt geladen und aktiv ist , d. h. gleichzeitig mit der High Flanke beim Ready- Signals nach Umschaltung (s. Timing ..). Der High Pegel bleibt für 20ms stehen und wird dann wieder gelöscht.

Falls die Umschaltung nicht erfolgreich war, wird kein High Pegel ausgegeben d. h. das Signal ist permanent Low.

Externe Beleuchtung

Wird diese Einstellung gewählt (nur über Pin 09 RD verfügbar), kann hier eine externe Beleuchtung angeschlossen / getriggert werden.

Keine Funktion,

undefiniert

Keine Funktion, nicht genutzt

Abbildung: Ausgabe, Ausgänge

Es gibt zwei weitere, fest definierte Ausgänge:

  • Ready: zeigt an, ob der Sensor zum Empfang eines Triggers / nächsten Auswertung bereit ist.
  • Valid: zeigt an, ob die Daten an den Ausgängen gültig sind.

Programmierbare Funktionen der digitalen Eingänge:

Im Betrieb mit einer Prozesssteuerung können folgende Funkionen über die Eingänge ausgeführt werden:

  • Inaktiv
  • Enable/Disable
  • Lade Job (binär codiert)
  • Lade Job 1 ... n
  • Einlernen temporär
  • Einlernen permanent

Beschreibung der unterschiedlichen Fälle mit Signaldiagramm.

Allen hier dargestellten Signalen liegt die Einstlellung "PNP zugrunde"

Eingang: "Trigger freischalten"

Schaltet den Triggereingang des Sensors frei (High Signal), oder blockiert den Hardware-Trigger (Low-Signal).

Abbildung: Eingang Timing, Trigger freischalten

Eingang: Job Wechsel über Binärsignale, oder über Funktion Job 1 oder 2

Jobwechsel Binär, über bis zu 5 Eingänge (Job 1- max. 31):

Beim Wechsel der binären Eingangssignale wird Ready auf Low gesetzt. Ready bleibt Low bis die Umschaltung auf den neuen Job erfolgt ist. Falls das optionale Job- Wechel Bestätigungs- Signal genutzt wird, erfolgt dieses nach dem Job-Wechsel, und Ready wird erst danach wieder High. Während der Jobumschaltung dürfen keine Triggersignale gesendet werden. Der Pegelwechsel der zugehörigen Eingänge muss gleichzeitig erfolgen (innerhalb von längstens 10ms müssen alle Pegel stabil anliegen, liegen die Pegelwechsel einzelner Eingänge weiter auseinander werden ggf. mehrere Jobumschaltungen nacheinander ausgeführt)

Jobwechsel durch Funktion Job 1 oder 2:

Beim Wechsel des Pegels des entsprechend definierten Eingangs wird Ready auf Low gesetzt. Ready bleibt Low bis die Umschaltung auf den neuen Job erfolgt ist. Falls das optionale Job- Wechel Bestätigungs- Signal genutzt wird, erfolgt dieses nach dem Job-Wechsel, und Ready wird erst danach wieder High. Während der Jobumschaltung dürfen keine Triggersignale gesendet werden. Bei Job 1 oder 2 schaltet Low-Pegel auf Job 1 und High-Pegel auf Job 2

Unterschied Binärsignale gegenüber Job 1 oder 2:

Bei Nutzung der Umschaltung via Binärsignalen muss in jedem Fall die gewünschte Job Nr binär kodiert angelegt werden, also müssen bei 2 Jobs mindestens 2 Eingänge genutzt werden.

Bei Job 1 oder 2 schaltet Low-Pegel auf Job 1 und High-Pegel auf Job 2. Es können also über einen Eingang zwei Jobs gewählt werden.

Abbildung: Eingang Timing, Jobwechsel via Binär / 1 oder 2

Eingang: Job 1 ... n

Zur Umschaltung von Jobs mittels digitalen Impulsen. Nur möglich wenn Ready = High. Impulse werden bis zur ersten Pause von >= 50ms gezählt und danach wird auf den entsprechenden Job umgeschaltet. Ready wird nach erkannter Endebedingung (Pause >= 50ms) auf Low gesetzt und bleibt Low, bis die Umschaltung auf den neuen Job erfolgt ist. Falls das optionale Job- Wechel Bestätigungs- Signal genutzt wird, erfolgt dieses nach dem Job-Wechsel, und Ready wird erst danach wieder High. Die Impulslänge zur Jobumschaltung sollte 5 ms Puls und 5 ms Pause betragen. (Die Puls/Pausen- Zeiten sollten nicht kürzer als 10ms/10ms, und nicht länger als 25ms/25ms sein) Während der Jobumschaltung dürfen keine Triggersignale gesendet werden. Wenn möglich sollte der Jobwechsel über die oben beschriebene Umschaltung via Binärsignalen erfolgen, diese ist ggf. die schnellere Variante.

Abbildung: Eingang Timing, Job 1...n

Achtung !

Bei der Jobumschaltung ist Folgendes zu beachten:

- alle Jobs müssen die gleiche Einstellung zur Jobumschaltung haben.

- alle Jobs in Trigger- Modus.

- Ready muss High sein wenn die Triggersequenz startet.

Eingang: Teach temp. / perm.

Zum neuen Teachen der Muster aller Detektoren des aktuellen Jobs. Eine steigende Flanke initiiert den Teach, dabei muss der High Pegel mindestens bis zum nächsten Trigger anliegen, damit ein Bild eines Prüfteiles in korrekter Lage aufgenommen werden kann. Ready wird auf Low gesetzt und bleibt Low bis der Teach erfolgt ist. Die Speicherung erfolgt je nach Einstellung temporär (nur im RAM), oder permanent (im Flash).

Abbildung: Eingang Timing, Teach

Achtung!

Die Funktionen Job 1 oder 2, Job 1 ... n oder Einlernen temp./perm. sind nur im Trigger- Modus sinnvoll nutzbar.

Eingang: Repeat Mode Enable, mit Trigger

Es werden Bilder aufgenommen und ausgewertet solange:
An diesem Eingang ein High Pegel anliegt und keines der folgenden Abbruchkriterien erfüllt ist:
- "Gesamt Jobergebnis" = positiv (einstellbar unter Ausgabe/Ausgangssignale)
- "Max. Zykluszeit" nicht erfüllt ist (falls aktiviert).
Wenn der Eingang Repeat Mode Enable genutzt wird wirkt dieser gleichzeitig zu o.g. Funktion als Trigger Enable, d.h. nur wenn an diesem Eingang ein High Pegel anliegt werden Trigger angenommen und verarbeitet

Abbildung: Eingang: Repeat Mode Enable, mit Trigger

Eingang: Repeat Mode Enable, im Freilauf

Abbildung: Eingang: Repeat Mode Enable, im Freilauf


Ausgangssignale (Digitalausgänge / Logik)

In diesem Reiter definieren Sie das Schaltverhalten und die logische Verknüpfung der einzelnen Detektoren mit den digitalen Ausgängen. Die Anzahl der Ausgänge richtet sich nach den Einstellungen unter dem Reiter Pinbelegung. Zusätzlich kann eine I/O Erweiterung über die serielle Schnittstelle angesteuert werden.

Abbildung: Abbildung, Ausgabe, Reiter Ausgangssignale / Logik

Logische Kombination der Detektoren für den jeweiligen Ausgang auswählen:

Je Pin (Ausgang) gibt es folgende Möglichkeiten:

Parameter | Funktion
Gesamt-Jobergebnis | kein physikalischer Ausgang. Hat Auswirkung auf Logik für Rekorder, Statistik und Archivierungsfunktionen
Invertieren | Gesamtergebnis aus den folgenden Einstellungen für diesen Pin (Ausgang) invertieren
Modus | Standard: Mehrere Detektoren können über die logischen Operatoren UND (&) / ODER (|) / NOT (!) zu einem logischen Ausdruck kombiniert werden. Erweitert: Die logische Formel zum Kombinieren der Detektoren kann frei erstellt werden.
NOT | Auswahl: Operator NOT (!)
Logik | Auswahl: Operator UND (&) / ODER (|)
D1 - D... | Je nach Anzahl aktivierter Detektoren werden in dieser Liste alle Detektoren eingefügt, diese können jedem aufgelisteten Ausgang logisch zugeordnet werden. Jeder Detektor kann für den jeweiligen Pin (Ausgang) ein-, invertiert- oder ausgeschaltet werden.
Logischer Ausdruck | Es wird entweder der im Standart Modus zusammengestellte logische Ausdruck angezeigt, oder der logische Ausdruck kann hier im Erweiterten Modus selbst zusammengestellt werden.
Logische Verknüpfung definieren:

Legen Sie die logische Verknüpfung zwischen den Prüfergebnissen der einzelnen Detektoren und den Status des gewählten Ausgangs fest. Sie haben zwei Möglichkeiten der Eingabe:

  • Standard Modus (Checkboxen und Operatoren)
  • Formel Modus


Logische Verknüpfung – Standard-Modus

Im Standard-Modus wird die Verknüpfung der Detektor-Prüfergebnisse für den gewählten Ausgang über die Radiobuttons Operator und die Checkboxen in der Detektorauswahlliste vorgenommen. Das Ergebnis wird im Feld Logische Formel angezeigt (nicht editierbar).

Ergebnisse verknüpfen:

1. Wählen Sie im Feld Operator den logischen Operator für die Verknüpfung der Detektoren in der Auswahlliste.

2. Aktivieren Sie in der Auswahlliste diejenigen Detektoren, die zum Ergebnis beitragen sollen (Häkchen in der Spalte Aktiv).

Durch Aktivierung der Spalte „Invertiert“ können Sie das jeweilige Detektorergebnis invertieren.

Entsprechend ändert sich der Eintrag in der Spalte Ergebnis.

Beispiele:

Hier können die Detektorergebnisse nur durch eine logische Operation verknüpft werden wie z.B.:

  • (D1&D2&D3) oder
  • !((!D1)|D2|D3) etc.

(Für komplexere Verknüpfungen bitte den Formel Modus wählen)


Logische Verknüpfung – Formel Modus

Im Formel Modus wird die Verknüpfung der Detektor-Prüfergebnisse für den gewählten Ausgang durch Direkteingabe einer logischen Formel definiert. Hierfür stehen Ihnen die Operatoren AND, OR und NOT sowie runde Klammern zur Verfügung.

Zur Editierung der Formel bitte folgende Zeichen für die logischen Operatoren verwenden:

  • "&" für AND
  • "|" für OR (Taste "AltGr" und Taste "<>")
  • "!" für NOT

Beispiele:

Hier können beliebig komplexe logische Ausdrücke erstellt werden wie z.B:

  • (D1&D2)|(D3&D4)
  • !((D1|D2)&(D3|D4))
  • (D1|D2)&(D3|D4)&(D5|D6)

etc.


Schnittstellen

In diesem Reiter selektieren und aktivieren Sie die genutzten digitalen Ein-/Ausgänge und die Schnittstellen zur Datenausgabe:

Abbildung: Ausgabe, Reiter Schnittstellen

Parameter Funktion

Interne I/O

Auswahl der Funktion der internen I/O: PNP oder NPN

RS 422 (Baudrate)

RS422 zur Datenausgabe mit Auswahl der Datenübertragungsrate.
Grundeinstellungen: 8 Datenbits, 1 Stopbit, keine Parität.

Externe I/O Erweiterung

Zusätzliche externe Aus- und Eingänge (mit I/O- und Encoder- Erweiterungsmodul)

Ethernet

Ethernet TCP/IP zur Datenausgabe. Der Sensor ist immer ein Socket Server. Es werden zwei verschiedene Ports verwendet, die vom Anwender definiert werden können. Grundeinstellung: Port 2006 (IN) für Kommandos an den Sensor (Steuerbefehle und Antwortprotokoll) und Port 2005 (OUT) für die eigentliche Datenausgabe. FESTO stellt eine Reihe von Utilities zur Erläuterung der Ethernet-Kommunikation zur Verfügung. Diese werden mit dieser Software im Verzeichnis Tools installiert.

EtherNet/IP

Feldbus EtherNet/IP zur Datenausgabe. Vision Sensor EtherNet/IP, Einleitung

Profinet

Feldbus Profinet zur Datenausgabe und SPS Kommunikation.
Der Vision Sensor startet den Profinet-Stack, sobald ein Job mit Profinet ausgewählt wird. Dadurch verringert sich die Auswertegeschwindigkeit geringfügig. Ein Wechsel in einen Job ohne Profinet stoppt den Profinet-Stack nicht, sondern erst das Ausschalten des Geräts.

Hinweis:

Der Sensor startet den Profinet-Stack, sobald ein Job mit Profinet ausgewählt wird.

Dadurch verringert sich die Auswertegeschwindigkeit geringfügig. Ein Wechsel in

einen Job ohne Profinet stoppt den Profinet-Stack nicht, sondern erst das

Ausschalten des Geräts. Vision Sensor Profinet, Einleitung

SBSxWebViewer

Schaltet den Webserver auf dem Vision Sensor ein. Ähnlich wie im lokal installierten Modul "Vision Sensor Visualisation Studio" können so über "SBSxWebViewer" Bilder und Ergebnisse über einen Webbrowser visualisiert werden.

Folgende Browser werden unterstützt: Microsoft Internet Explorer ab IE10, Google Chrome und Mozilla Firefox .

Zum Starten von SBSxWebViewer wie folgt vorgehen:

- SBSxWebViewer aktivieren, unter Ausgabe/Schnittstellen/ SBSxWebViewer

- "Sensor starten" (Button in Vision Sensor Configuration Studio)

- Browser öffnen

- in Adresszeile des Browsers die IP- Adresse des Sensors (sichtbar in Vision Sensor Device Manager) eingeben, im Format: "http://Ihre Sensor IP" z.B. "http://192.168.100.100" (Default).

Mit http://192.168.100.100/zoom.html (bzw. Alternativ der IP Adresse des Sensors) kann die vergrößerte Ansicht direkt aufgerufen werden.

Siehe auch: SBS – SBSxWebViewer

Für weitere Informationen siehe Benutzerhandbuch, Kapitel "Kommunikation"

Logische Ausgänge:

Bei Nutzung von RS422, Ethernet und EtherNet/IP Schnittstelle können zusätzliche logische Ausgänge definiert werden, die nur logisch existieren und nur per Datenausgabeschnittstelle kommuniziert werden können.

Logische Ausgänge können z.B. einem Detektorergebnis oder einem logischen Ausdruck (Formel) zugeordnet werden.

Hinweis:

In der Spalte „Aktiv“ können die Ausgänge und Schnittstellen separat aktiviert oder deaktiviert werden.


SBS – SBSxWebViewer

Dieses Programm dient zur Überwachung/Überprüfung von angeschlossenen Sensoren und zur Analyse von Prüfergebnissen.

Von hier aus können auf dem Sensor keine neuen Einstellungen gemacht werden. Somit dient dieses Anzeigetool hauptsächlich der Visualisierung von Bildern und Ergebnissen über einen Webbrowser.

Abbildung: Ansicht SBSxWebViewer im Browser / Ergebnisse

Ausschalten des Hilfefensters.

Zoom der Bildanzeige zum Vollbild. Klick auf das Vollbild verkleinert die Anzeige wieder.

Aus / Einschalten der Ergebnisbalken.

Aus / Einschalten der Einzeichnungen.

Speichern des aktuellen Bildes in eine Datei.

Umschaltung der Anzeigesprache.

Umschaltung zwischen Ergebnis, Statistik und Anzeige der auf dem Sensor vorhandenen Jobs.

Bildsteuerung: Möglichkeit zum „Einfrieren“ der Bildanzeige. Es wird nur die Bildanzeige gestoppt. Die Ausführung des Sensors im Hintergrund läuft weiter.

Anzeige des Status der Ausgänge des Sensors.

Abbildung: SBSxWebViewer / Statistik

Abbildung: SBSxWebViewer / Job

Zum Starten von SBSxWebViewer wie folgt vorgehen:
- SBSxWebViewer aktivieren, unter Ausgabe/Schnittstellen/SBSxWebViewer
- "Sensor starten" (Button in Vision Sensor Configuration Studio)
- Browser öffnen
- in Adresszeile des Browsers die IP- Adresse des Sensors (sichtbar in Vision Sensor Device Manager) eingeben,
im Format: "http://Ihre Sensor IP", z.B. "http://192.168.100.100". (Default)

Hinweise:

Folgende Browser werden unterstützt: Microsoft Internet Explorer ab IE10, Google Chrome und Morzilla Firefox .

Mit http://192.168.100.100/zoom.html (bzw. Alternativ der IP Adresse des Sensors) kann die vergrößerte Ansicht direkt aufgerufen werden.

Pro Vision Sensor ist nur eine Browser-Verbindung zulässig.


Zeitsteuerung Digitale Ausgänge

In diesem Reiter bestimmen Sie das Zeitverhalten des gewählten Signalausgangs: Wenn in der IO-Konfiguration ein Encoder aktiviert wurde, werden die Verzögerungen in Encoderschritten angegeben. Abhängig von der Einstellung in der IOKonfiguration werden alle folgenden Verzögerungen entweder in ms oder in Encoderschritten angegeben.

Abbildung: Ausgabe, Reiter Zeitsteuerung

Parameter

Funktion

Trigger Verzögerung

Zeit zwischen Trigger und Start der Bildaufnahme (in ms oder Encoderpulsen).
Maximaler Einstellwert ist 3000ms / Encoder Impulse.

Bei Nutzung von:

- H/W Trigger (Digitaleingang): Diese Verzögerung ist wirksam.

- Trigger (via Ethernet, Profinet): Diese Verzögerung ist nicht wirksam. (Die Bildaufnahme erfolgt direkt nach dem Trigger)

Digitale Ausgänge

Es können entweder alle Ausgänge verzögert werden, oder nur der Auswerferausgang.

Auswerfer / Ergebnissverzögerung

Zeit zwischen Trigger und Anliegen des Ergebnispegels (in ms oder Encoderpulsen). Es dürfen maximal 20 Bauteile zwischen den Trigger und den Auswerfer sein (Puffergröße).

Maximaler Einstellwert ist 3000 ms / Encoder Impulse.

Bei Nutzung von:

- H/W Trigger (Digitaleingang): Diese Verzögerung ist wirksam und startet mit dem H/W Trigger.

- Trigger (via Ethernet, Profinet): Diese Verzögerung ist wirksam, startet aber erst nach der Bildauswertung. (nicht mit dem Trigger!)

Signalisierung

Auswahl des Ereignisses, das die Ausgänge zurücksetzt.

Wechsel bei nächstem Ergebnis (Grundeinstellung)

Wechsel bei Trigger

Ergebnisdauer (feste Dauer in ms, danach Rücksetzen auf Inaktiv)

Ergebnisdauer

Dauer des Ergebnissignals (in ms oder Encoder Impulsen).

Maximale Einstellwert 3000 ms / Encoder Impulse

Hinweise:

Bei Jobwechsel und Wechsel Run- zu Config Mode entstehen folgende Sonderzustände:

  • Der Puffer der verzögerten Ausgänge wird bei Jobwechsel und Wechsel des Betriebsmodus von „Run" nach „Config" gelöscht.

Digitalausgänge:

Diese werden bei Jobwechsel und Wechsel des Betriebsmodus von „Run" nach „Config" auf die Grundeinstellungen (Defaults) zurückgesetzt. Die Grundeinstellungen werden durch „Invert" im Tab Vision Sensor Configuration Studio/Ausgabe/Ausgangssignale festgelegt.“Invertiert = Aktiv" invertiert die Grundeinstellung des Digitalausgangs und gleichzeitig das Ergebnis.

Rücksetzen der Digitalausgänge:

Das Rücksetzen der Ergebnisausgänge kann in Abhängigkeit von verschiedenen Einstellungen / Ereignissen geschehen. Diese sind:

  • „Wechsel bei nächstem Ergebnis“ (Default):
    Der Ausgang wechselt seinen Pegel entsprechend dem logischen Ergebnis nur, wenn das nächste Ergebnis vorliegt. Typisch verwendet bei Weichensteuerung bei z.B. Sortierung etc.
  • „Wechsel bei Trigger“:
    Der Ausgang wird auf Inaktiv gesetzt (im Betriebsmodus PNP = Low) beim nächsten Trigger. Typisch verwendet bei Betrieb an einer SPS.
  • „Ergebnisdauer“:
    Der Ausgang wechselt zurück auf Inaktiv nach der hier eingestellten Ergebnisdauer in ms. Typisch verwendet bei z.B. pneumatischen Auswerfern (Ausblaser)

S. Vision Sensor Configuration Studio/Ausgabe/Zeitsteuerung/Signalisierung

Ready und Valid

  • Ready signalisiert wenn high, Bereitschaft für neue Bildaufnahme.
  • Valid signalisiert wenn high, dass Ergebnisse an den Ausgängen gültig sind.

PNP oder NPN Betriebsmodus

Alle hier beschriebenen Beispiele sind im Betriebsmodus „PNP“ ausgeführt. Ist die Einstellung „NPN“ gesetzt, gelten die Beispiele in analoger Weise mit umgekehrten Pegeln.

S. Vision Sensor Configuration Studio/Ausgabe/Schnittstellen/Interne I/O

Folgende Fälle im Zeitverhalten können unterschieden werden:

Normaler Trigger ohne Nutzung von Verzögerungszeiten:

Ablauf: (hier Signalisierung: Wechsel beim nächsten Ereignis)

  • steigende Flanke am Trigger-Eingang (Pin03 WH)
  • als Folge von Trigger = High: Ready = Low, und Valid = Low
  • Nachdem der SBS Vision Sensor das Bild ausgewertet hat, und die entsprechenden Ergebnisse vorliegen, wechseln alle definierten Ausgänge in die entsprechenden logische Zustände und Ready und Valid gehen wieder auf High- Pegel. (Ausgänge gültig, SBS Vision Sensor bereit zur nächsten Auswertung)

Abbildung: Abbildung, Digitale Ausgänge Timing, Standardablauf bei normalem Trigger

Trigger-Verzögerung aktiv

(Trigger- Verzögerung wirkt nur auf Hardware- Trigger)

Diese Einstellung dient zur gezielten Verzögerung der Bildaufnahme / Beginn der Auswertung ggü. dem tatsächlich physikalischen Trigger, der z.B. durch eine Trigger-Lichtschranke oder die Maschinensteuerung ausgelöst wurde. Hiermit ist die Feineinstellung des Triggerzeitpunkts ohne Änderungen an Mechanik oder Steuerungsprogramm möglich.

Ablauf:

Bild wird nach Trigger erst nach verstrichener Trigger- Verzögerungs- Zeit aufgenommen. Die Zykluszeit ist: Trigger-Verzögerung + Auswertezeit) s. Vision Sensor Configuration Studio/Ausgabe/Zeitsteuerung/Trigger/ Verzögerung

  • steigende Flanke am Trigger- Eingang (Pin03 WH)
  • als Folge von Trigger = High: Ready = Low, Valid = Low, alle definierten Ergebnisausgänge = Low (Signalisierung = Wechsel bei Trigger)
  • bevor das Bild für die Auswertung aufgenommen wird, verstreicht die eingestellte Trigger- Verzögerungszeit (Trigger delay)
  • Nun erfolgt die Auswertung. Sobald die entsprechenden Ergebnisse vorliegen, wechseln alle definierten Ausgänge in die entsprechenden logischen Zustände, und Ready und Valid gehen wieder auf High-Pegel. (Ausgänge gültig, SBS Vision Sensor bereit zur nächsten Auswertung)

Abbildung: Abbildung, Digitale Ausgänge Timing, Trigger Verzögerung

Trigger Verzögerung + Ergebnisverzögerung (hier nur Auswerfer):

(Trigger- Verzögerung wirkt nur auf Hardware- Trigger)

Die Ergebnisverzögerung (ob für alle Ausgänge oder nur Auswerfer) dient zur Feineinstellung des z.B. Auswerferzeitpunktes unabhängig von der Auswertezeit, da insbesondere diese auch leichte Schwankungen aufweisen kann.

Ablauf:

Bild wird nach Trigger erst nach verstrichener Trigger- Verzögerungs-Zeit aufgenommen. Außerdem wirkt die Ergebnisverzögerung. In diesem Beispiel jedoch nur auf den Auswerfer-Ausgang (Pin 12 RDBU).

Die Zykluszeit ist für die definierten Ergebnisausgänge, außer dem Auswerfer-Ausgang: Die Trigger- Verzögerung- + Auswertezeit

Die Zykluszeit für den Auswerfer-Ausgang ist: Alleine die Ergebnisverzögerung (gezählt ab Triggerzeitpunkt, nur sinnvoll wenn länger als Summe o.g. Zeiten !) s. Vision Sensor Configuration Studio/Ausgabe/Zeitsteuerung/Digitale Ausgänge/Verzögerung.

  • steigende Flanke am Trigger- Eingang (Pin03 WH)
  • als Folge von Trigger = High: Ready = Low, Valid = Low, alle definierten Ergebnisausgänge = Low. Ausser Auswerfer, für diesen ist hier eine feste Ergebnisdauer definiert,
  • bevor das Bild für die Auswertung aufgenommen wird, verstreicht die eingestellte Trigger- Verzögerungszeit (Trigger delay)
  • Nun erfolgt die Auswertung. Sobald die entsprechenden Ergebnisse vorliegen, wechseln alle definierten Ausgänge (hier außer Auswerfer) in die entsprechenden logischen Zustände und Ready und Valid gehen wieder auf High- Pegel.
  • In diesem Betriebsmodus wird einzig der Auswerferausgang erst nach dem Verstreichen der Ergebnisverzögerung gesetzt. Der Auswerferausgang ist in diesem Beispiel auch mit einer Ergebnisdauer versehen und wird deshalb definiert nach dieser Ergebnisdauer auf Inaktiv gesetzt.

Abbildung: Abbildung, Digitale Ausgänge Timing, Ergebnis Verzögerung Auswerfer

Trigger Verzögerung + Ergebnisverzögerung (hier alle Ausgänge):

(Trigger- Verzögerung wirkt nur auf Hardware- Trigger)

Die Ergebnisverzögerung (ob für alle Ausgänge oder nur Auswerfer) dient zur Feineinstellung des z.B. Auswerferzeitpunktes unabhängig von der Auswertezeit, da insbesondere diese auch leichte Schwankungen aufweisen kann.

Ablauf:

Bild wird nach Trigger erst nach verstrichener Trigger- Verzögerungs- Zeit aufgenommen. Außerdem wirkt die Ergebnisverzögerung, in diesem Beispiel auf ALLE definierten Ergebnisausgänge.

Die Zykluszeit ist für alle Ergebnisausgänge: Alleine die Ergebnisverzögerung (gezählt ab Triggerzeitpunkt, nur sinnvoll wenn länger als Summe von Trigger-Verzögerung + Auswertezeit!)
s. Vision Sensor Configuration Studio/Ausgabe/Zeitsteuerung/Digitale Ausgänge/Verzögerung

  • steigende Flanke am Trigger- Eingang (Pin03 WH)
  • als Folge von Trigger = High: Ready = Low und Valid = Low,
  • bevor das Bild für die Auswertung aufgenommen wird, verstreicht die eingestellte Trigger- Verzögerungszeit (Trigger delay)
  • Nun erfolgt die Auswertung. Nach Vorliegen der entsprechenden Ergebnisse, wird einzig das Signal Ready nun gleich wieder auf High gesetzt (bereit zur nächsten Auswertung). Ansonsten wird noch auf das Verstreichen der Ergebnisverzögerung gewartet. Erst dann wechseln alle definierten Ausgänge in die entsprechenden logischen Zustände. Auch Valid geht wieder auf High- Pegel. (Valid = High: Ergebnissausgänge gültig, Signalisierung = Wechsel bei nächstem Ergebnis)

In diesem Betriebsmodus wechselt einzig das Signal „Ready“ schon nach Verstreichen von Trigger- Verzögerung + Bildaufnahme + Auswertezeit. Ready = High: Bereit zur nächsten Auswertung. Dies ist sinnvoll, da der SBS Vision Sensor unabhängig vom späteren Setzen der Ausgänge, schon wieder bereit ist für die nächste Auswertung.

Abbildung: Abbildung, Digitale Ausgänge Timing, Ergebnis Verzögerung alle Ausgänge

Ergebnis-Dauer aktiv, betrifft hier z.B. alle Ausgänge:

Diese Zeiteinstellung dient zur Erzielung eines Ausgangspulses mit definierter Länge, etwa zur Ansteuerung eines pneumatischen Auswerfers (Ausblaser) im Falle eines Schlechtteiles, o.ä.

Alle definierten Ergebnissausgänge werden nach dem Aktivieren, exakt nach der eingestellten Ergebnis-Dauer in ms wieder auf Low-Pegel (Inaktiv im PNP-Betrieb) zurück gesetzt.

Abbildung: Abbildung, Digitale Ausgänge Timing, Ergebnis Dauer

Zykluszeit (Min, Max) aktiv:

(hier: Signalisierung: Wechsel bei Trigger)

Parameter zur Steuerung der Ausführungszeit eines Jobs. Schieber für Minimal- und Maximal-Wert.

Die minimale Ausführungszeit kann zum Unterdrücken von Mehrfachtriggern verwendet werden und kann Auswirkung auf die LED Leistung haben. (D. h. falls noch innerhalb der minimalen Job- Zeit ein weiterer Trigger eingeht wird dieser ignoriert)

Die maximale Ausführungszeit dient zum Abbruch eines Jobs nach einer definierten Zeit. Das Ergebnis des Jobs ist nach Abbruch immer "nicht o.k.". Die maximale Ausführungszeit sollte immer größer gewählt werden als der Zeitbedarf für eine Auswertung.

Die Zykluszeit misst die Zeit vom Trigger bis zum Setzen der digitalen Schaltausgänge. Soll die Zykluszeit begrenzt werden, z.B. weil der Maschinentakt nicht überschritten werden darf, muss der Wert für die maximale Zykluszeit entsprechend begrenzt werden. Das Ergebnis aller bis zu diesem Zeitpunkt nicht fertig ausgeführten Detektoren wird auf fehlerhaft gesetzt. Bei der Wahl der maximalen Zykluszeit ist zu berücksichtigen, dass diese nicht hart eingehalten wird, sondern in Abhängigkeit des gerade ausgeführten Detektors etliche weitere Millisekunden bis zum Abbruch verstreichen können. Es wird empfohlen, diese Überschreitung der maximalen Zykluszeit anhand der tatsächlichen Ausführungszeit zu überprüfen und den eingestellten Wert für die maximale Zykluszeit entsprechend zu verkleinern.

Ablauf:

Alle Ausgänge und das Signal „Valid“ (Ausgänge gültig) werden direkt nach der Auswertung gesetzt.

Das Signal „Ready“ (Bereit zur nächsten Auswertung) wird jedoch erst nach Verstreichen der Min. Job Zeit gesetzt, und damit werden erst ab diesem Zeitpunkt wieder Trigger für die nächste Auswertung akzeptiert.

Abbildung: Abbildung, Digitale Ausgänge Timing, Min Job Zeit

Multiple Ergebnisverzögerung für Auswerfer

Dieser Betriebsmodus wird verwendet, wenn zwischen Trigger/Auswertung für Prüfteil A und dessen Ausschleusung so viel Zeit / Förderstrecke liegt, dass der SBS Vision Sensor bereits n (bis max. 20 möglich) weitere Prüfteile prüfen und deren jeweils ebenfalls späteren Ausschleusungszeitpunkt verwalten muss.

(nur verfügbar im Modus: Vision Sensor Configuration Studio/Ausgabe/Zeitsteuerung/Verzögerung: „Nur Auswerfer / Auswerfer- / Ergebnisverzögerung“ (ejector / result delay))

Hier: Signalisierung = Ergebnis-Dauer (alternativ auch „Wechsel bei nächstem Ergebnis“ verwendbar)

Es dürfen maximal 20 Bauteile zwischen den Trigger und den Auswerfer passen.

Abbildung: Abbildung, Digitale Ausgänge Timing, Multiple Ergebnisverzögerung Auswerfer

Hinweis

Beim Betrieb mit einer I/O Box vorzugsweise die Zeitfunktionen in der I/O Box realisieren,


Datenausgabe

Konfiguration der Datenausgabe für die seriellen Schnittstellen RS422 und Ethernet sowie für die Archivierung in .csv-Dateien. Hier können sämtliche Einstellungen, welche Ergebnisdaten vom SBS über die zuvor ausgewählte und aktivierte Schnittstelle ausgegeben werden sollen, getroffen werden.

Nächstes Thema: Bildübertragung Parameter

Serielle Kommunikation ASCII

Serielle Kommunikation BINÄR

EtherNet/IP, Anhang

Abbildung: Ausgabe, Reiter Datenausgabe

Parameter | Funktion
Binär / ASCII | Auswahl, ob Ausgabedaten in Binär- (Hex) oder in ASCII- Format ausgegeben werden.
Export | Export des Dateiformats mit aktuellen Ergebnissen als .csv. Detail- Ausgabe des Datenformats des frei definierten Ausgabestrings als .csv- Datei mit: Byte- Position (Startposition im String), Datentyp, Feldname, Detektorname, Wert, Länge (in Byte), Detektornummer und Detektortyp.
Rücksetzen | Rücksetzen aller Eintragungen in diesem Reiter

Protokoll-Standardinhalte (Vorspann .... bis .... Prüfsumme)

Oft benötigte Standardinhalte können durch einfaches Ausfüllen bzw. Aktivieren via Checkbox zum Ausgabestring hinzugefügt werden.

  • Vorspann
  • Nachspann
  • Trennzeichen
  • Telegrammende
  • Gewählte Felder
  • ......

Detektorspezifische Einzelergebnisse zum Ausgabestring hinzufügen

Zuerst mit der Schaltfläche "+" einen neuen Eintrag erzeugen.

Funktion der Schaltfelder

  • "+": Neuen Eintrag einfügen
  • "-": Markierten Eintrag löschen
  • "Up", "Down": Markierten Eintrag verschieben

Über die Auswahlliste „Detektorspezifische Nutzdaten“ können Sie detektorspezifische Einzelergebnisse in der gewünschten Reihenfolge flexibel zum Datentelegramm hinzufügen. Hinzufügen von Werten mit Button „+“

Abbildung: Abbildung, Ausgabe, Detektrospezifische Nutzdaten

Spalte | Funktion
Aktiv | Aktivieren/Deaktivieren des markierten Ausgabewerts
Detektor | Detektorname (Wahl über Ausklappliste)
Wert | Verfügbare Detektorergebnisse (Wahl über Ausklappliste)
Min. Länge | Festlegung der Mindestlänge des Felds Wert; ist die tatsächliche Länge geringer als die Vorgabe, wird das Feld mit Leerzeichen (ASCII) bzw. Nullen (binär) aufgefüllt
Anz. Ergebnisse | Nur BLOB! Anzahl der Ergebnisse eines BLOB Detektors, der mehrere Objekte fand. Beispiel: es wurde nach dem Merkmal "Fläche" gefiltert und 10 BLOBs / Objekte wurden gefunden. Nun können hier bis zu 10 dieser Flächenwerte als Ausgabedaten in einer Sequenz übertragen werden. Alle verfügbaren Ausgabedaten s. Serielle Kommunikation ASCII , Serielle Kommunikation BINÄR, Kapitel: Datenausgabe in ASCII / Binär

Datenausgabemöglichkeiten (s. auch Kap. Kommunikation)

(Ethernet-)port 2005 / RS422

Numerische Daten, die unter Ausgabe/Datenausgabe konfiguriert wurden, können in einem eigenen ASCII/BINAER Format ausgegeben werden.

Ethernet: Der Sensor ist hierbei der (Socket-)“Server" und stellt die Daten über eine „Server-Socket" Schnittstelle zur Verfügung. Hauptsächlich ist dies eine „Programmier-Schnittstelle". Um die Daten lesen/verarbeiten zu können muss ein „Socket-Client" (PC, SPS, etc.) eine (Socket-)Verbindung (aktiv) zum Sensor aufbauen, und kann dann die Daten verarbeiten.

PC-Archivierung (Vision Sensor Visualisation Studio)

Hiermit können Bilder und numerische Daten (im csv Format) durch den „Viewer" (Vision Sensor Visualisation Studio) selbst permanent (in ein Verzeichnis auf dem PC) mitprotokolliert werden. Die Konfiguration (Verzeichnis, etc.) dieser Archivierung erfolgt über den „Viewer" (-> über Menue „Datei/Archivierung konfigurieren"). Dies ist eine reine PC-Funktionalität.

Sensor-Archvierung (ftp, smb)

Hiermit können Bilder und numerische Daten (im csv Format) aktiv durch den Sensor per ftp/smb archiviert werden. Diese Archivierung kann/muss unter „Job/Archivierung" konfiguriert werden. Bei dieser Art der Archivierung ist:

a) bei ftp der Sensor ein „ftp Client" und „schreibt" die Daten auf ein im Netzwerk verfügbares „ftp-Server" Verzeichnis. Der Sensor verbindet sich bei Job-Start mit dem ftp-Server.

b) bei smb schreibt der Sensor seine Daten direkt in ein im Netzwerk freigebenes Verzeichnis. Der Sensor verbindet/mounted sich bei Job-Start mit diesen Verzeichnis.

Ramdisk (auf dem Sensor)

Auf dem Sensor wird das letzte Bild, sowie numerische Daten, welche unter „Ausgabe/Datenausgabe" konfiguriert wurden, permanent (in einer .csv Datei) auf dem Sensor in ein Ramdisk-Verzeichnis unter „/tmp/results/" gespeichert. Diese Funktionalität muss unter „Job/Bildübertragung" aktiviert werden. Um diese Daten „lesen" zu können, muss aktiv eine ftp-Verbindung zum Sensor aufgebaut werden. Hierzu wird ein ftp-Client benötigt.

Hinweise

* Das Format der csv Dateien (ftp, smb, ram-disk, Vision Sensor Visualisation Studio) ist einheitlich „gleich".

* Die Daten werden lesbar (per default mit Semikolon getrennt) in die csv Datei ausgegeben.

* Es werden nur (Nutz-)Daten, welche unter (Ausgabe/Datenausgabe) konfiguriert wurden ausgegeben.

Kommunikations- Einstellungen

Kommunikation | Ethernet | RS422
Zum Sensor, Kommando | Wählbar im Tab: Datenausgabe (Binär oder ASCII)
An Sensor, Datenausgabe | Wählbar im Tab: Datenausgabe (Binär oder ASCII)

Protokoll-Einstellungen

Parameter | Funktion
Protokoll | Kommunikation Binär oder ASCII
Export | Speichern der Vorschau auf dem PC, z.B. als Vorlage für SPS-Programmierung

Grundlagen zum Aufbau der Verbindung:

Der SBS Vision Sensor wird immer als tcp/ip (socket-) server verwendet.

Der SBS Vision Sensor öffnet immer zwei (socket-) Kommunikationsports (default: 2005 + 2006).

  • 2005 = Daten Port zum Senden numerischer Ergebnisse an den Kunden.
  • 2006 = Befehlsport um Befehle am Sensor zu empfangen.

Es kann gleichzeitig nur ein (socket-) client (PC or PLC) an jeden Port verbunden werden.

Empfehlungen:

Bestehende Socket Verbindungen müssen nur wieder verbunden werden, wenn ein Fehler aufgetreten ist (z.B.: SPS oder Client in Stop mode oder Fehler mode, etc.). Während des fehlerfreien Betriebes brauchen keine bestehenden Verbindungen erneut aufgebaut werden.

Ethernet Daten Handling: Besonders bei Nutzung mehrerer SBS , sollte bevorzugt über die Ethernet Kommunikation erfolgen.

Bitte beachten Sie folgende automatisch mit installierte Hilfe:

....:\Programme\FESTO\SBS Vision Sensor \Tools\EthernetSBS_Ethernet_communication.pdf


Bildübertragung Parameter

Im Reiter Bildübertragung kann die Bildübertragung und/oder der Bildrekorder und die Ram Disk aktiviert werden.

Nächstes Thema: Archivierung Parameter

Hinweis

Ein Ausrufezeichen als Einblendung im Livebild sagt aus, dass die Bilddarstellung / Bildspeicherung im PC langsamer läuft als die Bildauswertung auf dem SBS. Es werden nicht mehr alle Bilder, die vom SBS Vision Sensor aufgenommen werden, angezeigt. Dies kann bei Verwendung der Schlechtbildarchivierung evtl. zu Bildverlusten führen. Bei häufigem Auftreten des Ausrufezeichens, sollten auf dem PC Programme im Hintergrund geschlossen werden, um mehr PC-Leistung zur Verfügung zu stellen.

Parameter Funktion und Einstellmöglichkeiten

Vision Sensor Visualisation Studio

Anzeige von Bildern im Anzeigemodul Vision Sensor Visualisation Studio im Run Modus aktivieren/deaktivieren. (Deaktivierung erhöht die Geschwindigkeit der Anwendung)

Einstellmöglichkeiten:

- Aus: Es werden keine Bilder zu Vision Sensor Visualisation Studio übertragen.

- Ein: Bilder werden ohne die Anwendung der Vorverarbeitungsfilter übertragen. (Jedoch, falls aktiviert, wirken die Anordnungsfilter auf die zu übertragenden Bilder!)

- Ein (mit Vorverarbeitung): Bilder werden unter Anwendung aller aktivierten Vorverarbeitungs- und Anordnungs- Filter übertragen

Bildrekorder

Speicherung von max. 10 Bildern im internen Ringspeicher des Sensors. Einstellmöglichkeiten: Aus, Alle, Gutteile, Schlechtteile

Ram Disk

Speicherung des letzten Bildes im internen RAM-Speicher, dieses Bild kann von einem FTP- Client abgeholt werden.

Einstellmöglichkeiten: Aus, Alle, Gutteile, Schlechtteile.

Das Bild wird im RAM des SBS Vision Sensors unter dem Namen "image.bmp" im Verzeichnis /tmp/results/ abgelegt.

Parameter für FTP- Client: Benutzer: "user", Passwort: "user"

Beispiel Windows Konsole: Start > Ausführen > cmd

Microsoft Windows XP [Version 5.1.2600]

(C) Copyright 1985-2001 Microsoft Corp.

C:\>ftp 192.168.100.100

Verbindung mit 192.168.100.100 wurde hergestellt.

220 Welcome to SBS ftp-server!

Benutzer (192.168.100.100:(none)): user

331 Please specify the password.

Kennwort: user

230 Login successful.

ftp> cd /tmp/results

250 Directory successfully changed.

ftp> get image.bmp

200 PORT command successful. Consider using PASV.

150 Opening BINARY mode data connection for image.bmp (354358 bytes).

226 File send OK.

FTP: 64d Bytes empfangen in 0,23Sekunden 1514,35KB/s

ftp>

Das Bild befindet sich nun im Laufwerk C des ausführenden PC.

Wenn eingeschaltet, können auf gleichem Wege die Ergebnisdaten (alle in "Ausgabe/ Datenausgabe" definierten, mit Trennzeichen ";") über die Datei "result.csv" bezogen werden.

Abbildung: Reiter Ausgabe / Bildübertragung


Archivierung Parameter

Im Reiter Archivierung können Sie die Archivierung der Daten konfigurieren.

Parameter | Funktion und Einstellmöglichkeiten
Archivtyp | Aus: keine Archivierung, FTP: Archivierung zum FTP Server, SMB: Archivierung auf ein Laufwerk über SMB Dienst (Server Message Block) Achtung! Bei Nutzung von Archivservern in anderen Subnetzen zunächst in Vision Sensor Device Manager das Gateway einstellen.
IP-Adresse | IP-Adresse des Zielservers / clients
Freigabename | Freigabename der bei der Ordnerfreigabe im PC im Dialog: "Erweiterte Freigabe" definiert wurde.
Arbeitsgruppe (Domainname) | Optional !, Arbeitsgruppe / Domainname des Zielservers / clients.
Benutzername | Benutzer Name für FTP / SMB Verbindung.
Passwort | Passwort für FTP / SMB Verbindung.
Verzeichnis (Gutteile) | Verzeichnis für Archivierung der Datensätze der Gutteile (Für C:/TESTGUT nur TESTGUTeingeben).
Verzeichnis (Schlechtteile) | Verzeichnis für Archivierung der Datensätze der Schlechtteile (Für C:/TESTSCHLECHT nur TESTSCHLECHT eingeben) .
Dateiname | Dateiname für Bilder und Protokolldatei, dieser Name wird noch automatisch durch die Bildnummer ergänzt (Z.B. TESTDATEI).
Bilddateien | Aktivierung der Archivierung der Bilder .
Ergebnisdateien | Wird die Protokolldatei aktiviert, werden alle Daten, die unter "Ausgabe / Datenausgabe" spezifiziert wurden, zusätzlich in eine .csv-Datei protokolliert. Es wird pro Auswertung (Trigger) eine Datei angelegt. Die Dateien werden fortlaufend nummeriert.
Bildinhalt | Möglichkeit zur Auswahl, ob Bilder unter Anwendung des eingestellten Software-Filters gespeichert werden sollen oder als „Roh"-Bilder, wie sie von der Kamera gekommen sind.
Speichermodus | Begrenzt: wenn die maximale Anzahl der Dateien erreicht ist, wird die Übertragung beendet. Unbegrenzt: Dateien werden geschrieben, bis das Ziellaufwerk voll ist. Zyklisch: nach Erreichen der maximalen Anzahl von Dateien wird jeweils die älteste von der neusten überschrieben.
Max. Anzahl Dateien | Maximale Anzahl von Datensätzen, die im Zielverzeichnis abgelegt werden dürfen.

Abbildung: Reiter Ausgabe / Archivierung


Ergebnis

Mit dieser Funktion wird der definierte Job auf dem PC ausgeführt, und das „Ergebnisse/Statistik" Fenster mit Detektorliste und Auswerteergebnissen angezeigt. Die Ausführungszeiten werden in diesem Modus nicht aktualisiert, da sie vom Sensor nicht vorliegen.

Im Run-Modus werden die detaillierten Prüfergebnisse des in der Auswahlliste markierten Detektors angezeigt.

Im Bildfenster werden – sofern eingestellt – das Bild, die Such- und Merkmalsbereiche und Ergebnisgrafen angezeigt.

Abbildung: Ergebnis

Angezeigte Ergebnispar. | für Detektortyp | Bedeutung
Ergebnis | alle | Teil / Merkmal erkannt (Erkannt = grün, Nicht erkannt = rot)
Score 1 ... n | alle, außer Messschieber | Übereinstimmungsgrad des gefunden Musters mit dem eingelernten Muster
Score (1 ... n) | Messschieber *1) | Score 1 / Score 2: Wert für Kantenstärke in Grauwerten, normiert auf 100, (Höhe des Maximums im Histogramm). Score: Der Kleinere der beiden Werte: Score 1 und Score 2
Ausführungszeit | alle | Zykluszeit für eine Auswertung in ms
Abstand | Messschieber | Berechneter Abstand
PositionX 1 .. n, PositionY 1 .. n | Mustervgl., Kontur, Messschieber | Koordinaten des gefundenen Merkmals
Delta X, Delta Y | Mustervgl., Kontur | Abweichung der Findekoordinaten ggü. Einlernposition / durch Lagenachführung
Positionskontrolle | Mustervgl., Kontur | Findeposition innerhalb des definierten Positionsrahmens
Winkel | Mustervgl., Kontur | Orientierung (absoluter Winkel) des gefunden Merkmals
Delta Winkel | Mustervgl., Kontur | Winkelabweichung zwischen eingelerntem und gefundenem Merkmal
Skalierung | Kontur | Skalierung der gefundenen Kontur ggü. der eingelernten
Ergebnis Index | Farbliste | Nummer des Listeneintrags
Farbabstand | Farbliste | Abstand der gemessenen Farbe zur eingelernten Farbe
Rot (Farbmodell RGB) | Farbliste, Farbwert | Mittelwert Rot
Grün (Farbmodell RGB) | Farbliste, Farbwert | Mittelwert Grün
Blau (Farbmodell RGB) | Farbliste, Farbwert | Mittelwert Blau
Farbton (Farbmodell HSV) | Farbliste, Farbwert | Farbton der Farbe
Sättigung (Farbmodell HSV) | Farbliste, Farbwert | Sättigung der Farbe
Helligkeit (Farbmodell HSV) | Farbliste, Farbwert | Helligkeit der Farbe
Luminanz (Farbmodell LAB) | Farbliste, Farbwert | Luminanzwert der Farbe
A (Farbmodell LAB) | Farbliste, Farbwert | A- Wert der Farbe
B (Farbmodell LAB) | Farbliste, Farbwert | B- Wert der Farbe

Die angezeigten Parameter variieren in Abhängigkeit vom ausgewählten Detektortyp.
Um die Prüfergebnisse für einen anderen Detektor aufzurufen, markieren Sie diesen in der Auswahlliste.
Im Programm Vision Sensor Visualisation Studio können Sie Prüfergebnisse und statistische Auswertungen inklusive der gewählten grafischen Darstellungen archivieren.

*1) Score Wert bei Ergeniss von "Messschieber"

im Fall des Messschieber Detektors ist die Bedeutung der Ergebniswerte "Score", "Score 1" und "Score 2" wie folgt:

Score 1 / Score 2: Wert für Kantenstärke in Grauwerten, normiert auf 100, (Höhe des Maximums im Histogramm).

Score: Der Kleinere der beiden Werte: Score 1 oder Score 2

Abbildung: Score Wert bei Messschieber Detektor


Start des Sensors

Mit dieser Funktion können Sie den Sensor in den Run-Modus versetzen und Ihren Job ausführen.

Bildanzeige

Ergebnis

Statistik

Jobausführung starten:

Klicken Sie auf den Button "Starte Sensor".

Der aktive (= in der Auswahlliste markierte) Job wird auf den Sensor übertragen, im Sensorspeicher nichtflüchtig abgelegt und gestartet (Run-Modus).

Im Bildfenster werden die gefundenen Merkmale, im Konfigurationsfenster die Prüfergebnisse für den ersten bzw ausgewählten Detektor in der Auswahlliste, sowie statistische Parameter angezeigt.

Detektoranzeige wechseln:

Um die Prüfergebnisse für einen anderen Detektor als den gerade ausgewählten anzuzeigen, markieren Sie diesen in der Detektor-Auswahlliste (links unten) oder klicken auf dessen grafische Darstellung im Bildfenster.

Jobausführung beenden:

Klicken Sie auf den Button „Stop Sensor". Sie befinden sich jetzt wieder im Konfigurationsmodus und können Ihren Job bearbeiten.

Abbildung: Starte Sensor


Weitere Themen zu Vision Sensor Configuration Studio

Trigger-Einstellungen

Umschalten zwischen Online- und Offline-Modus

Simulation von Jobs (Offline-Modus)

Erstellen von Filmstreifen

Bildrekorder

Anzeigen im Bildfenster

Such- und Merkmalsbereiche

Farbmodelle


Trigger-Einstellungen

Wählen Sie in den Job-Einstellungen im Reiter „Bildaufnahme" den gewünschten Trigger-Modus:

Parameter | Funktion
Getriggert | Betrieb mit externem Trigger, oder Button „Trigger" auf der Vision Sensor Configuration Studio-Oberfläche
Freilauf | Betrieb mit automatisch laufendem Selbsttrigger; der Sensor liefert Bilder/Auswertungen mit der maximal möglichen Frequenz

Wählen Sie mit den Schaltflächen im Bereich Trigger/Bildaktualisierung in welcher Form Bilder vom Sensor geliefert werden sollen:

Parameter Funktion

Einzelbild

Aufnahme eines Einzelbilds, Bildaufnahme erfolgt einmalig bei:

1. Trigger Modus = Getriggert: Erstem externem Triggersignal oder mit dem Button „Trigger" auf der Vision Sensor Configuration Studio- Oberfläche

2. Trigger Modus = Freilauf: Erstem Click auf Button „Einzelbild" auf der Vision Sensor Configuration Studio- Oberfläche (Wichtig z.B. im Einricht- Betrieb)

Kontinuierlich

Kontinuierliche Lieferung von Bildern, Bildaufnahme erfolgt fortlaufend bei:

1. Trigger Modus = Getriggert: Jedem externen Trigger oder bei jedem Click auf den Button „Trigger" auf der Vision Sensor Configuration Studio- Oberfläche

2. Trigger Modus = Freilauf: Kontinuierlich durch interne Selbsttriggerung mit maximaler Frequenz

Bei Änderung der Parameter Belichtungszeit, Verstärkung, Beleuchtung oder Auflösung in den Job-Einstellungen wird automatisch ein neues Bild vom Sensor angefordert.

Um auch ohne Trigger ein stetig aktualisiertes Livebild zu erhalten folgende Einstellungen vornehmen:

  • Freilauf einstellen unter „Job/Bildaufnahme"
  • Kontinuierlich einstellen unter „Trigger / Bildaktualisierung"


Umschalten zwischen Online- und Offline-Modus

Für Konfiguration und Testlauf des Sensors stehen Ihnen zwei Betriebsarten zur Verfügung, die Sie im Feld Verbindung auswählen können.

  • Online-Modus: Konfiguration mit angeschlossenem Sensor.
  • Offline-Modus: Simulation eines Sensors mit Hilfe gespeicherter Bilder im Filmstreifen.

Abbildung: Abbildung, Verbindungsmodus

Bei angeschlossenem Sensor stehen beide Modi zur Verfügung, es kann dazwischen umgeschaltet werden. Ist kein Sensor vorhanden, kann nur im Offline- Modus, d. h. mit einer Sensor- Simulation gearbeitet werden.


Simulation von Jobs (Offline-Modus)

Sie können Ihre Konfiguration auch ohne angeschlossenen Sensor anhand gespeicherter Filmstreifen (= Bilderserien) erstellen und testen. Eine Simulation kann z.B. sinnvoll sein, um eine Konfiguration vorzubereiten oder eine online vorgenommene Konfigurationen zu optimieren.

Anzeigen im Bildfenster

Erstellen von Filmstreifen

Hinweise:

  • Im Auslieferungszustand von Vision Sensor Configuration Studio stehen Ihnen einige vorbereitete Filme zur Verfügung.
  • Weitere Möglichkeiten zur Bildaufnahme: Bildrekorder


Erstellen von Filmstreifen

Im Konfigurationsmodus Online-Modus werden kontinuierlich Bilder vom Sensor in das RAM des PC geladen. Nach dem Umschalten vom Online- in den Offline- Modus stehen Ihnen hier maximal 30 Bilder zur Verfügung, die Sie als Bilderserie in einer Filmstreifendatei speichern können. Alternativ oder zusätzlich zu den auf dem Sensor gespeicherten Bildern können Sie auf Ihrem PC oder einem externen Speichermedium abgelegte Bilderserien oder Einzelbilder laden und zu neuen Filmen zusammenstellen.

Wenn Sie ein Bild in der Liste markieren, wird es im Kleinformat im Preview- Fenster rechts angezeigt.

Bilder vom Sensor als Filmstreifen speichern:

1. Zuerst den PC mit dem Sensor verbinden. Im Freilauf Bilder in den Speicher auflaufen lassen. (Verbindungsmodus = Online)

2. Wählen Sie Radiobutton „Offline" im Feld Verbindungsmodus.

3. Wählen Sie „Filmstreifen konfigurieren“ aus dem Datei-Menü oder klicken Sie auf das Icon Filmstreifen in der Toolbar. In der sich unten öffnenden Auswahlliste erscheinen die vom Sensor geladenen Bilder:

Abbildung: Filmstreifen

Nun können die Bilder betrachtet, umsortiert oder einzelne Bilder gelöscht bzw hinzugefügt werden. Die maximale Bildanzahl in einem Filmstreifen ist 30.

4. Klicken Sie auf Button „Speichern Filmstreifen" unter der Auswahlliste.

Sämtliche Bilder in der Liste werden in der angezeigten Reihenfolge in einer Filmstreifendatei (Erweiterung .flm) gespeichert und stehen Ihnen für künftige Simulationen zur Verfügung.

Filmstreifen und Einzelbilder vom PC laden:

1. Wählen Sie Radiobutton „Offline" im Feld Verbindungsmodus.

2. Wählen Sie Filmstreifen konfigurieren aus dem Datei-Menü oder klicken Sie auf das Icon Filmstreifen in der Toolbar.

3. Wählen Sie eine Filmdatei aus der Auswahlliste und klicken Sie auf Button „Laden Filmstreifen" oder laden Sie mit Button „Bild laden" einzelne Bilder von Ihrem PC oder einem externen Speichermedium.

Die geladenen Bilder werden der Auswahlliste hinzugefügt.

In der Spalte Quelle werden Art und Speicherort der Datei angezeigt: Auf dem PC gespeicherter Filmstreifen (Film), auf dem PC gespeichertes Einzelbild (Datei), Bild im Sensorspeicher (Sensor). Nach der Umschaltung vom Online- in den Offline-Modus sind alle Einträge vom Typ Sensor.

Filmstreifen bearbeiten:

Sie können aus den Einzelbildern in der Auswahlliste unabhängig von ihrer Quelle neue Filme erstellen.

Folgende Funktionen stehen Ihnen hierfür zur Verfügung:

Button | Funktion
"<", "<<", ">", ">>" | Bildreihenfolge ändern: Das markierte Bild wird um einen Platz oder bis ans Ende der Liste nach oben/unten verschoben.
Bild laden | Weiteres Bild laden
Löschen, Alle löschen | Bild aus der Liste löschen/Alle Bilder aus der Liste löschen. (Die Bilder auf dem PC werden dabei nicht gelöscht.)
Abbruch> | Verlassen der Listenansicht ohne Änderung
Übernehmen | Laden sämtlicher Bilder in der angezeigten Reihenfolge in den Filmspeicher auf dem PC. Diese stehen dann für die Anzeige und Auswertung im Offline-Modus zur Verfügung.
Laden / Speichern Filmstreifen | Filmstreifen von PC laden oder dort speichern


Anzeigen im Bildfenster

Steuerung der Bildwiedergabe

Abbildung: Bildwiedergabe

Mit den Buttons „<" (Zurück), Start / Stop und „>" (Vor) sowie der Schiebeleiste unter dem Bildfeld können Sie die Auswahl und Wiedergabe gespeicherter Bilder steuern. Im Bildzähler wird Ihnen die Nummer des aktuellen Bildes sowie die Anzahl der Bilder im aktiven Filmstreifen angezeigt.

Bildausschnitt und -vergrößerung

Abbildung: Zoom

Mit den Schaltflächen bzw. über das Ausklappmenü unter dem Bildfenster können Sie den gewünschten Bildausschnitt wählen.

Grafische Ergebnisanzeige

Im Menü Ansicht können Sie folgende grafischen Darstellungen aktivieren bzw. deaktivieren:

  • Ergebnis Bargraph: Anzeige des Prüfergebnisses als Balkendiagramm
  • Einzeichnungen: Anzeige von Such-, Merkmals- und Positionsrahmen von Detektoren und Lagedetektoren
  • Fokussierhilfe: Anzeige der Bildschärfe (siehe auch Job-Einstellungen)
  • Vergrößerte Anzeige: Einblendung eines separaten vergößerten Bildfensters, das sich über Anfasser an den Rahmenecken beliebig skalieren lässt

Im Programm Vision Sensor Visualisation Studio steht Ihnen eine eingeschränkte Auswahl dieser Funktionen zur Verfügung.


Bildrekorder

In den Programmen Vision Sensor Configuration Studio und Vision Sensor Visualisation Studio steht Ihnen ein Bildrekorder zur Verfügung. Wenn der Rekorder aktiviert ist, werden kontinuierlich entweder alle Bilder oder nur Fehlerbilder in den internen Speicher des Sensors geladen. Dieser fasst 10 Bilder, die ältesten Bilder werden jeweils überschrieben (Ringpuffer). Die aufgezeichneten Bilder können anschließend mit einem PC abgerufen und angezeigt, sowie auf dem PC oder einem externen Speichermedium abgelegt werden und stehen dann zu Analyse- oder Simulationszwecken im Offline- Modus zur Verfügung.

Im Programm Vision Sensor Visualisation Studio müssen Sie zum Abrufen der Rekorderbilder u.U. (falls aktiviert) ein Passwort eingeben (Benutzergruppe Werker, siehe Benutzerverwaltung).

Rekorder aktivieren:

Aktivieren Sie die Aufnahmefunktion in den Jobeinstellungen des Programms Vision Sensor Configuration Studio (Reiter Allgemein). In der Ausklappliste des Parameters Rekorder können Sie wählen, ob alle Bilder oder nur Fehlerbilder aufgezeichnet werden sollen.

Bilder auswählen und aufzeichnen:

Wählen Sie Bildrekorder auslesen aus dem Datei-Menü oder klicken Sie auf Button „Rek.Bilder" (nur in Vision Sensor Visualisation Studio).

Es erscheint ein Bildfenster, in dem Sie die im Sensor gespeicherten Bilder auf den PC laden, betrachten und abspeichern können:

Abbildung: Abbildung, Bildrekorder

Parameter | Bedeutung
Zurück | Anzeige des vorhergehenden Bildes
Vor | Anzeige des nächsten Bildes
Speichern | Speichern des angezeigten Bildes auf dem PC bzw. einem externen Speichermedium
Alle speichern | Speichern aller Bilder

Hinweise:

  • Die laufende Nummer des ausgewählten Bildes und die Gesamtzahl der Bilder (max. 10) werden im Zähler unter dem Bildfenster angezeigt.
  • Beim Speichern werden die Bilder im Bitmap-Format (Extension .bmp) abgelegt.
  • Das zum jeweiligen Bild gehörige Prüfergebnis (OK bzw. Fehler) und das Datum werden im Dateinamen gespeichert (Format JJMMTT_laufende Nr._Pass/Fail.bmp, z.B. 090225_123456_Pass.bmp).
  • Wenn Sie zusammen mit den Bildern detaillierte Prüfergebnisse aufzeichnen wollen, verwenden Sie die Funktion Archivierung in Vision Sensor Visualisation Studio.
  • Wenn Sie nur ein einzelnes Bild mit oder ohne Overlay aufnehmen wollen, können Sie anstelle des Rekorders die Funktion Speichere aktuelles Bild im Datei-Menü verwenden.
  • Die Bilder werden bei der Übertragung auf den PC mit einem Zeitstempel versehen.
  • Durch das Laden der Bilder vom Sensor auf den PC werden die Daten auf dem Sensor gelöscht. Wenn das Rekorder Fenster geschlossen wird ohne die Bilder vorher zu speichern gehen die Bilder verloren.


Such- und Merkmalsbereiche

In den Konfigurationsschritten Lagenachführung und Detektoren können Sie Such- und Merkmalsbereiche definieren. Diese sind im Bildfenster durch verschiedenfarbige Rahmen gekennzeichnet.

Im Menüpunkt „Ansicht/Einzeichnungen konfigurieren" können die Einzeichnungen im Bild (Rahmen in gelb, rot, etc.) beliebig je Detektor oder Kategorie an- oder abgeschaltet werden. Unter „Ansicht/Einzeichnungen nur aktueller Detektor" können alle Einzeichnungen im Bild bis auf die des aktuell bearbeiteten Detektors abgeschaltet werden.

Definition von Such- und Merkmalsbereichen

Bei der Erstellung eines neuen Detektors wird ein gelber Rahmen angezeigt, der den Suchbereich des Detektors definiert. Standardform des Suchbereichs ist ein Rechteck. Es können auch je nach Detektortyp die Form Kreis oder Freiform ausgewählt werden. Die definierten Merkmale (roter Rahmen) werden gefunden (grüner Rahmen), solange sich dessen Mittelpunkt innerhalb des Suchbereiches (gelber Rahmen) befindet.

Bei den Detektoren Mustervergleich und Konturerkennung gibt es zusätzlich einen Merkmalsbereich innerhalb des Suchbereichs, der durch eine roten bzw. grünen Rahmen dargestellt wird:

  • Roter Rahmen = Merkmal einlernen
  • Grüner Rahmen = Merkmal gefunden.

Ist eine Positionserkennung definiert, erscheint zusätzlich ein blauer Rahmen (wahlweise Rechteck, Kreis oder Ellipse).

Ist ein Lagedetektor definiert, werden dessen Rahmen gelb gestrichelt angezeigt.

An der jeweils linken oberen Ecke der Rahmen wird die entsprechende Detektornummer angezeigt.

Anpassen von Such- und Merkmalsbereichen

Die zuerst in Standardgröße und -position angezeigten Bereiche können Sie im Bild oder in der Detektorliste auswählen / markieren und in der Position und Größe verändern. Über acht Anfasser am Rahmen lassen sich Rahmenformat und -größe anpassen, über Klick irgendwo innerhalb des Rahmens dessen Position verschieben. Am zur Mitte zeigenden Pfeil lässt sich die Drehlage des Rahmens verändern.

Das eingelernte Muster wird in Originalgröße im Reiter Allgemein oder Parameter in der rechten unteren Bildschirmecke dargestellt. Nur die Rahmen des im Bild oder in der Detektorliste gewählten, momentan aktiven Detektors wird in dicker Linienstärke und den Anfasspunkten dargestellt, alle anderen, zu diesem Zeitpunkt nicht selektierten Rahmen, werden mit dünnen bzw gestrichelten Linien (Lagedetektor) dargestellt.

Abbildung: Abbildung, Such- und Merkmalsrahmen

Hinweise:

  • Für eine optimale Erkennung sollten Merkmale eindeutig sein und keine variablen Anteile, z.B. Schatten, enthalten.
  • Signifikante Konturen, Kanten und Kontrastunterschiede sind von Vorteil.
  • Um die Auswertezeit zu minimieren, sollte der Suchbereich nicht unnötig groß gewählt werden.

Ergebnisbalken:

Rechts neben dem Suchbereich wird der Übereinstimmungsgrad des gesuchten mit dem gefundenen Merkmal als stehender Ergebnisbalken mit eingestelltem Schwellwert angezeigt:

  • Grüner Balken = Das gesuchte Merkmal wurde gefunden und der voreingestellte Schwellwert der Mindest- Übereinstimmung erreicht.
  • Roter Balken = Das Objekt konnte nicht mit dem erforderlichen Übereinstimmungsgrad gefunden werden. Welche grafischen Darstellungen angezeigt werden, können Sie im Menü Ansicht wählen.


Farbmodelle

Zur Beschreibung von Farben gibt es sogenannte Farbmodelle.

Der SBS Vision Sensor Color kann in verschiedenen Farbmodellen arbeiten.

Folgende Farbmodelle können verwendet werden:

Farbmodell RGB

Farbmodell HSV

Farbmodell LAB

Nächstes Thema: SBS – Bedien- und Konfigurationssoftware –Vision Sensor Visualisation Studio, alle Funktionen


Farbmodell RGB

Ein RGB-Farbraum ist ein additiver Farbraum, der Farbwahrnehmungen durch das additive Mischen dreier Grundfarben (Rot, Grün und Blau) nachbildet.

Der RGB- Farbraum wird als linearer Farbraum als Farbwürfel mit den drei Achsen Rot, Grün und Blau beschrieben.

Abbildung: Farbmodell RGB

Rot, Grün, Blau, jeweils 0-255

Der RGB-Farbraum wird sowohl vom Bildchip, als auch vom Bildschirm zur Definition der Farben genutzt.

Allerdings haben Bildchip und Bildschirm innerhalb der einzelnen Farbkanäle unterschiedliche Empfindlichkeiten.

Es muß also immer eine Kompensation erfolgen, also RGB ist niemals gleich RGB.

Linear RGB

RGB-Werte werden als linear RGB-Werte angegeben. Hintergrund ist, dass der Sensorchip lineare RGB-Werte liefert. Vorteil der linearen RGB-Werte ist, dass ein linearer Zusammenhang zwischen physikalischer Einwirkung und RGB-Werten besteht.

Beispiel: Eine Verdoppelung der Belichtungszeit führt bei konstanten Beleuchtungsbedingungen zu einer Verdoppelung des RGB-Wertes.


Farbmodell HSV

In Fragen der Farbnachstellung wird der HSV-Farbraum gegenüber den Alternativen RGB und Lab bevorzugt, weil es der menschlichen Farbwahrnehmung ähnelt.

Abbildung: Farbmodell HSV

HSV | Hue | Saturation | Value
 | Farbton | Sättigung | Intensität

Farbton als Farbwinkel H auf dem Farbkreis (z. B. 0° = Rot, 120° = Grün, 240° = Blau)

Sättigung S in Prozent (0 % = Neutralgrau, 50 % = wenig gesättigte Farbe, 100 % = gesättigte, reine Farbe)

Intensität V als Prozentwert (0 % = keine Intensität, 100 % = volle Intensität)


Farbmodell LAB

Der LAB oder L*a*b*-Farbraum wird durch ein dreidimensionales Koordinatensystem beschrieben:

Abbildung: Farbmodell LAB

Die a*-Achse beschreibt den Grün- oder Rotanteil einer Farbe, wobei negative Werte für Grün und positive Werte für Rot stehen, Zahlenbereich von -150 bis +100.

Die b*-Achse beschreibt den Blau- oder Gelbanteil einer Farbe, wobei negative Werte für Blau und positive Werte für Gelb stehen, Zahlenbereich von -100 bis +150.

Die L*-Achse beschreibt die Helligkeit (Luminanz) der Farbe mit Werten von 0 bis 100.

Eine der wichtigsten Eigenschaften des L*a*b*-Farbmodells ist seine Geräteunabhängigkeit, das heißt, die Farben werden unabhängig von der Art ihrer Erzeugung und Wiedergabetechnik definiert.

LAB-Werte werden aus den linearen RGB-Werten berechnet, wobei die Normlichtart D65 und 2° Beobachter zugrunde gelegt werden.


Applikationsbeispiele

Im Menü "Datei/Beispiele" können einige vordefinierte Applikationsbeispiele geladen werden. Es wird jeweils ein Filmstreifen zusammen mit einer Job Datei geladen.


SBS – Bedien- und Konfigurationssoftware –Vision Sensor Visualisation Studio, alle Funktionen

Dieses Programm dient zur Überwachung/Überprüfung von angeschlossenen Sensoren und zur Analyse von Prüfergebnissen.

Von hier aus können auf dem Sensor keine neuen Einstellungen gemacht werden.

Bildanzeige

Ergebnis

Statistik

Wechsel des aktiven Jobs

Hochladen

Kommandos / Bild einfrieren

Bildrekorder

Archivierung von Prüfergebnissen und Bildern

Es kann über die reine Anzeige hinaus nur zwischen bereits existierende Jobs auf dem Sensor umgeschaltet werden, oder vordefinierte Jobsätze vom autorisierten Werker vom PC / Steuerung auf den Sensor hochgeladen werden. Somit dient dieses Anzeigetool hauptsächlich zur Visualisierung von Bildern und Ergebnissen, und zum Jobwechsel bei z.B. Teilewechsel auf der Maschine.


Bildanzeige

Die grafische Anzeige des Bildes und der Prüfergebnisse im Bildfenster hängt von den Einstellungen im Reiter "Bildübertragung" in den Jobeinstellungen (Reiter "Bildübertragung", Kap. "Bildübertragung Parameter" im Programm Vision Sensor Configuration Studio) ab:

  • Bildübertragung aktiv: Das aktuelle Bild sowie die Rahmen für die definierten Such-, Merkmals- und Positionsbereiche und die gefundenen Merkmale werden angezeigt.
  • Bildübertragung inaktiv: Es werden nur die Rahmen für die definierten Such-, Merkmals- und Positionsbereiche und die gefundenen Merkmale angezeigt (das aktuelle Bild wird nicht angezeigt).

Rechts neben dem Suchbereich des jeweiligen Detektors wird der Übereinstimmungsgrad des gesuchten mit dem gefundenen Merkmal als stehender Ergebnisbalken mit eingestelltem Schwellwert angezeigt:

  • Grüner Balken: Das gesuchte Merkmal wurde gefunden und der voreingestellte Schwellwert der Übereinstimmung erreicht.
  • Roter Balken: Das Objekt konnte nicht mit dem erforderlichen Übereinstimmungsgrad gefunden werden

Ein „Ausrufezeichen“ als Einblendung im Livebild sagt aus, dass die Bildauswertung im PC langsamer läuft als die Bildauswertung auf dem SBS Vision Sensor. Es werden nicht mehr alle Bilder, die vom SBS Vision Sensor aufgenommen werden angezeigt.

Dies kann bei Verwendung der Schlechtbildarchivierung evtl. zu Bildverlusten führen. Bei häufigem Auftreten des Ausrufezeichens, sollten auf dem PC Programme im Hintergrund geschlossen werden, um mehr PC-Leistung zur Verfügung zu stellen.

Im Menü Vision Sensor Visualisation Studio / Ansicht können Sie die grafische Darstellung der Prüfergebnisse konfigurieren.

Abbildung: Abbildung, Vision Sensor Visualisation Studio

Mit Ausnahme der Archivierung stehen sämtliche Funktionen von Vision Sensor Visualisation Studio auch im Programm Vision Sensor Configuration Studio zur Verfügung.


Kommandos / Bild einfrieren

Mit dem Button „Bild einfrieren" können Sie Einzelbilder des gewünschten Typs (Aktuelles Bild, Nächstes Bild, Nächstes Fehlerbild) anfordern und im Bildfenster zur Anzeige festhalten.

Das gewünschte Einzelbild wird angezeigt und der Bildzähler bleibt auf der entsprechenden Bildnummer stehen.

Mit „Fortsetzen" beenden Sie die Einzelbildanzeige.


Zoom

Mit dem Button "Zoom" wird das Bild in einem neuen Fenster in vergrößerter Anzeige geöffnet.


Archivierung von Prüfergebnissen und Bildern

Sie können Bilder mit und ohne Einzeichnungen sowie Prüfergebnisse auf Ihrem PC oder einem externen Speichermedium zu Analyse- oder Simulationszwecken archivieren (siehe Offline-Modus).

Die Ausführung dieser Funktionen erfordert u.U. die Eingabe eines Passworts (Benutzergruppe Werker, siehe Benutzerverwaltung).

Archivierung konfigurieren:

1. Wählen Sie „Archivierung konfigurieren“ aus dem Datei-Menü.

Es erscheint ein Dialogfenster mit folgender Auswahl:

Abbildung: Archivierung konfigurieren

Parameter Funktion

Pfad für Archivierung

Verzeichnis, in dem die Archivierungsdatei(en) abgelegt werden.

Einstellungen, Automatischer

Start

Startet die Archivierung automatisch nach Start von Vision Sensor Visualisation Studio.

Einstellungen, Zyklisches

Überschreiben

Aktiviert das zyklische Überschreiben der ältesten Bilder bei erreichen des Speicherlimit.

Einstellungen, Speicherlimit

Hier kann die Datenmenge begrenzt werden.

Einstellungen, Bildtyp

In dieser Ausklappliste kann spezifiziert werden, welche Bilder (alle Bilder bzw. nur Gut- bzw. Schlechtbilder) gespeichert werden sollen.

Einzeichnungen,

Ergebnis Bargraph

Auswahl der zu archivierenden grafischen Darstellungen im Bild.

Numerische Ergebnisse

Wenn „Mitprotokollieren" aktiviert ist, werden in einer zusätzlichen .csv-Datei numerische Ergebnisdaten wie Koordinatenwerte o.ä. archiviert.

Die Einstellung "Legacy" / "Konfiguriert" legt das Format der .csv Datei fest.

Bei "Legacy" *1) ist der Inhalt der .csv-Datei vorgegeben,

bei "Konfiguriert" ist diese über „Ausgabe / Datenausgabe" frei konfigurierbar.

*1) Der Speichermodus "Legacy" ist veraltet und wird aktuell nur aus Gründen der Abwärtskompatibilität angeboten. Er wird in einer der nächsten Versionen entfallen.

2. Wählen Sie die gewünschten Optionen und bestätigen Sie Ihre Wahl mit OK.

Archivierung starten/beenden:

Klicken Sie auf den Button „Bilder archivieren" im Fenster „Kommandos", um die Archivierungsfunktion mit o.g. Einstellungen zu starten bzw. zu beenden. In der Statusleiste wird die gegenwärtig zu speichernde Bilddatei mit Namen angezeigt. Die Archivierung wird ausgeführt, solange der Button „Bilder archivieren" gedrückt ist.


Statistik

Im Run-Modus werden die statistischen Daten des Prüfprozesses im Reiter Statistik angezeigt. Die angezeigten statistischen Daten sind für alle Detektortypen identisch:

Parameter | Bedeutung
Alle Auswertungen | Gesamtzahl der Prüfungen
Gutteile | Anzahl der Prüfungen mit Resultat „OK"
Schlechtteile | Anzahl der Prüfungen mit Resultat „Fehler"
Min./Max./Mittlere Ausführungszeit | Min./Max./Mittlere Ausführungszeit für eine Auswertung in ms

Mit dem Button „Rücksetzen" können Sie alle Statistikwerte auf Null zurücksetzen.

Im Programm Vision Sensor Visualisation Studio können Sie Prüfergebnisse und statistische Auswertungen inklusive der gewählten grafischen Darstellungen archivieren.


Ergebnis

Mit dieser Funktion wird der definierte Job auf dem PC ausgeführt, und das „Ergebnis Statistik" Fenster mit Detektorliste und Auswerteergebnissen angezeigt. Die Ausführungszeiten werden in diesem Modus nicht aktualisiert, da sie vom Sensor nicht vorliegen.

Im Run-Modus werden die detaillierten Prüfergebnisse des in der Auswahlliste markierten Detektors angezeigt.

Im Bildfenster werden – sofern eingestellt – das Bild, die Such- und Merkmalsbereiche und Ergebnisgrafen angezeigt.

Die angezeigten Parameter variieren in Abhängigkeit vom ausgewählten Detektortyp:

Abbildung: Abbildung, Vision Sensor Visualisation Studio, Ergebnis

Angezeigte Ergebnispar. | für Detektortyp | Bedeutung
Ergebnis | alle | Teil / Merkmal erkannt (Erkannt = grün, Nicht erkannt = rot)
Score 1 .. n | alle | Übereinstimmungsgrad des gefunden Musters mit dem eingelernten Muster
Ausführungszeit | alle | Zykluszeit für eine Auswertung in ms
Abstand | Messschieber | Berechneter Abstand
PositionX 1 .. n, PositionY 1.. n | Mustervgl., Kontur, Messschieber | Koordinaten des gefundenen Merkmals (Mittelpunkt)
Delta X, Delta Y | Mustervgl., Kontur | Abweichung der Findekoordinaten ggü. Einlernposition / durch Lagenachführung
Positions- kontrolle | Mustervgl., Kontur | Findeposition innerhalb des definierten Positionsrahmens
Winkel | Mustervgl., Kontur | Orientierung (absoluter Winkel) des gefunden Merkmals
Delta Winkel | Mustervgl., Kontur | Winkelabweichung zwischen eingelerntem und gefundenem Merkmal
Skalierung | Kontur | Skalierung der gefundenen Kontur ggü. der eingelernten
Ergebnis Index | Farbliste | Nummer des Listeneintrags
Farbabstand | Farbliste | Abstand der gemessenen Farbe zur eingelernten Farbe
Rot (Farbmodell RGB) | Farbliste, Farbwert | Mittelwert Rot
Grün (Farbmodell RGB) | Farbliste, Farbwert | Mittelwert Grün
Blau (Farbmodell RGB) | Farbliste, Farbwert | Mittelwert Blau
Farbton (Farbmodell HSV) | Farbliste, Farbwert | Farbton der Farbe
Sättigung (Farbmodell HSV) | Farbliste, Farbwert | Sättigung der Farbe
Helligkeit (Farbmodell HSV) | Farbliste, Farbwert | Helligkeit der Farbe
Luminanz (Farbmodell LAB) | Farbliste, Farbwert | Luminanzwert der Farbe
A (Farbmodell LAB) | Farbliste, Farbwert | A- Wert der Farbe
B (Farbmodell LAB) | Farbliste, Farbwert | B- Wert der Farbe

Um die Prüfergebnisse für einen anderen Detektor aufzurufen, markieren Sie diesen in der Auswahlliste.

Im Programm Vision Sensor Visualisation Studio können Sie Prüfergebnisse und statistische Auswertungen inklusive der gewählten grafischen Darstellungen archivieren.


Wechsel des aktiven Jobs

Im Reiter Job werden in der Auswahlliste die auf dem Sensor verfügbaren Jobs angezeigt. Hier können Sie zwischen verschiedenen im Sensor gespeicherten Jobs umschalten.

Die Ausführung von Funktionen, die ein Anhalten des aktiven Sensors zur Folge haben (Job-Umschaltung, Job-Upload und Recoderbilder holen), erfordert falls aktiviert in Vision Sensor Device Manager die Eingabe eines Passworts (Benutzergruppe Werker, siehe Benutzerverwaltung).

Passwortebenen

Abbildung: Abbildung, Passwortebenen

Abbildung: Abbildung, Vision Sensor Visualisation Studio, Jobumschaltung

Wählen Sie einen Job aus der Liste und aktivieren Sie ihn mit Button „Aktiviert".

Der bisherige Job wird deaktiviert, der gewählte Job ist jetzt aktiv.

Hinweise:

Bei Jobwechsel und Wechsel des Betriebsmodus von Run- nach Config Mode entstehen folgende Sonderzustände der Ausgänge:

  • Der Puffer der verzögerten Ausgänge wird bei Jobwechsel und Wechsel des Betriebsmodus von „Run" nach „Config" gelöscht.
  • Digitalausgänge: Diese werden bei Jobwechsel und Wechsel des Betriebsmodus von „Run" nach „Config" auf die Grundeinstellungen (Defaults) zurückgesetzt. Die Grundeinstellungen werden durch „Invert" im Tab Output-> Ausgangssignale festgelegt. „Invert" invertiert die Grundeinstellung des Digitalausgangs und gleichzeitig das Ergebnis.
  • Ready und Valid: Ready und Valid signalisieren bei Jobwechsel und Wechsel des Betriebsmodus von „Run" nach „Config", dass der Sensor nicht bereit ist und die Ergebnisse nicht gültig sind. (Low Pegel)


Hochladen

Im Reiter Hochladen können Sie neue Jobs oder ganze Jobsätze vom PC in den Sensorspeicher laden. Die verfügbaren Jobs bzw. Jobsätze werden in der Auswahlliste angezeigt.

Jobs und Jobsätze können im Programm Vision Sensor Configuration Studio erstellt und dort unter Menü Datei / Speichere Job / Jobsatz unter ... abgespeichert werden.

Abbildung: Abbildung, Vision Sensor Visualisation Studio, Jobsätze laden

Hinweise:

  • Ein Jobsatz besteht aus einem oder mehreren Jobs, die im Sensor oder auf Festplatte gespeichert sind.
  • Die Ausführung von Funktionen, die ein Anhalten des aktiven Sensors zur Folge haben, erfordert u.U. die Eingabe eines Passworts (Benutzergruppe Werker, siehe Benutzerverwaltung).
  • Wählen Sie einen Job oder Jobsatz aus der Liste und laden Sie ihn mit Button „Hochladen" auf den Sensor.
  • Alle bisher auf dem Sensor gespeicherten Jobs werden bei dieser Aktion gelöscht!


Anhang

Telegramm, Datenausgabe

Steuerung der Bildwiedergabe

SensoView oder SensoConfig starten über Autostart


Telegramm, Datenausgabe

Folgende Telegramme stehen zur Datenausgabe zur Verfügung

Serielle Kommunikation ASCII

Serielle Kommunikation BINÄR

EtherNet/IP, Anhang


Serielle Kommunikation ASCII

Datenformate der Kommandos und Datenausgabev

Kommunikationseinstellungen

Kommunikation | Ethernet | RS422
Zum Sensor, Kommando | Wählbar im Tab: Datenausgabe (Binär oder ASCII)
Vom Sensor, Datenausgabe | Wählbar im Tab: Datenausgabe (Binär oder ASCII)

Kommandos an den Sensor in ASCII

Trigger (ASCII) Request String an Sensor
Byte Nr. | Inhalt ASCII | Bedeutung
1 | T | Trigger, (einfacher Trigger ohne Index, via Port 2006)
2 | R
3 | G
Trigger (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | T | Trigger, (Response auf Kommando Trigger ohne Index, via Port 2006. Falls definiert: Ergebnisdaten ohne Index via Port 2005)
2 | R
3 | G
4 | P F | Erfolgreich (Pass) Fehler (Fail)
Zusatzinformationen
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Ja
Akzeptiert wenn Ready Low: |  | Nein
Status des Signals Ready während Bearbeitung: |  | Low
Telegrammende |  | max. 4 Byte (optional)

Extended Trigger (ASCII) Request String an Sensor
Byte Nr. | Inhalt ASCII | Bedeutung
1 | T | Extended Trigger, (Trigger mit Index, zur Zuordnung Trigger zu entsprechenden Ergebnisdaten, via Port 2006)
2 | R
3 | X
4 | x | Länge nachfolgender Daten (n)
5 | x
6...n | x | Daten
Extended Trigger (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | T | Extended Trigger, (Response auf Trigger mit Index und Ergebnisdaten, via Port 2006, zur Zuodrnung von Trigger zum Ergebnis. Ergebnisdaten ausserdem ohne Index via Port 2005)
2 | R
3 | X
4 | P F | Erfolgreich (Pass) Fehler (Fail)
5 | x | Länge nachfolgender Daten (n)
6 | x
7...n | x | Daten aus dem Sendebefehl
n+1 | x | C = Config R = Run
n+2 | x | Länge nachfolgender Ergebnis Daten (m)
n+3 | x
n+4 | x
n+5 | x
n+6 | x
n+7 | x
n+8 | x
n+9 | x
n+9...m | x | Ergebnis Daten
m+1 | x | Telegrammende (optional, max. 4 Byte)
m+2 | x
m+3 | x
m+4 | x
Zusatzinformationen
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Ja
Akzeptiert wenn Ready Low: |  | Nein
Status des Signals Ready während Bearbeitung: |  | low
Telegrammende |  | max. 4 Byte (optional)

Jobwechsel (ASCII) Request String an Sensor
Byte Nr. | Inhalt ASCII | Bedeutung
1 | C | Change Job
2 | J
3 | B
4 | X | Job Nummer
5 | X
6 | X
Jobwechsel (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Change Job
2 | J
3 | B
4 | P F | Erfolgreich (Pass) Fehler (Fail)
5 | T F | Triggered Freerun
6 | X | Job Nummer
7 | X
8 | X
Zusatzinformationen
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Low
Telegrammende |  | max. 4 Byte (optional)

Parameter setzen (ASCII)
Byte Nr. | Inhalt ASCII | Bedeutung
1 | S | Setze Parameter
2 | P
3 | P T | P Permanent T Temporär Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
4 | X | Detektor Nummer
5 | X
6 | X
7 | X | Kommando: Referenzstring / Wert setzen *1) s. unten
8 | X
9 | X
10 | X | Länge Referenzstring / Wert in Bytes (n)
11 | X
12 | X
13 | X
14 | X
15...n | X | Referenzstring / Wert
Parameter setzen (ASCII) Response string vom Sensor
Byte Nr. | Inhalt ASCII | Bedeutung
1 | S | Setze Parameter
2 | P
3 | P T | P Permanent T Temporär Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
4 | P F | P Erfolgreich (Pass) F Fehler (Fail)
5 | S | Parameter vom Typ STRG (String) wurde gesetzt
6 | T
7 | R
8 | G
Zusatzinformationen
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Low
Telegrammende |  | max. 4 Byte (optional)

*1) Byte Nr. 7: Kommando Referenzstring / Wert setzen

Detector | Function | Command
Alignment Pattern matching | Threshold Min Threshold Max | 001 002
Alignment Contour | Threshold Min Threshold Max | 001 002
Alignment Edge | Threshold Min Threshold Max Transition_Horizontal Transition_Vertical | 001 002 101 102
Pattern matching | Threshold Min Threshold Max | 001 002
Contour | Threshold Min Threshold Max | 001 002
Grey Level | Threshold Min Threshold Max GreyMin GreyMax GreyInvert | 001 002 101 102 103
Contrast | Threshold Min Threshold Max | 001 002
Brightness | Threshold Min Threshold Max | 001 002
Barcode | Reference String | 101
Datacode | Reference String | 101
OCR | Reference String | 101
Color Value | ColorMinChannel1 ColorMaxChannel1 ColorInvertChannel1 ColorMinChannel2 ColorMaxChannel2 ColorInvertChannel2 ColorMinChannel3 ColorMaxChannel3 ColorInvertChannel3 | 101 102 103 104 105 106 107 108 109
ColorArea | ColorMinChannel1 ColorMaxChannel1 ColorInvertChannel1 ColorMinChannel2 ColorMaxChannel2 ColorInvertChannel2 ColorMinChannel3 ColorMaxChannel3 ColorInvertChannel3 | 101 102 103 104 105 106 107 108 109
BLOB | GreyAbsoluteMin GreyAbsoluteMax GreyAbsoluteInvert | 101 102 103

Parameter lesen (ASCII)
Byte Nr. | Inhalt | Bedeutung
1 | G | Lese Parameter
2 | P
3 | A
4 | X | Detektor Nummer z.B. 001
5 | X
6 | X
7 | X | Kommando: Referenzstring / Wert lesen *1) s. unten
8 | X
9 | X
Parameter lesen (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | G | Lese Parameter
2 | P
3 | A
4 | P F | P Erfolgreich (Pass) F Fehler (Fail)
5 | S | Parameter vom Typ STRG (String) wurde gelesen
6 | T
7 | R
8 | G
9 | X | Länge des Referenzstrings / Wert (n) z.B. 00005
10 | X
11 | X
12 | X
13 | X
14...n | X | Referenzsting / Wert
Zusatzinformationen
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | keine Veränderung
Telegrammende |  | max. 4 Byte (optional)

*1) Byte Nr. 7: Kommando: Referenzstring / Wert lesen

Detector | Function | Command
Alignment Pattern matching | Threshold Min Threshold Max | 001 002
Alignment Contour | Threshold Min Threshold Max | 001 002
Alignment Edge | Threshold Min Threshold Max Transition_Horizontal Transition_Vertical | 001 002 101 102
Pattern matching | Threshold Min Threshold Max | 001 002
Contour | Threshold Min Threshold Max | 001 002
Grey Level | Threshold Min Threshold Max GreyMin GreyMax GreyInvert | 001 002 101 102 103
Contrast | Threshold Min Threshold Max | 001 002
Brightness | Threshold Min Threshold Max | 001 002
Barcode | Reference String | 101
Datacode | Reference String | 101
OCR | Reference String | 101
Color Value | ColorMinChannel1 ColorMaxChannel1 ColorInvertChannel1 ColorMinChannel2 ColorMaxChannel2 ColorInvertChannel2 ColorMinChannel3 ColorMaxChannel3 ColorInvertChannel3 | 101 102 103 104 105 106 107 108 109
ColorArea | ColorMinChannel1 ColorMaxChannel1 ColorInvertChannel1 ColorMinChannel2 ColorMaxChannel2 ColorInvertChannel2 ColorMinChannel3 ColorMaxChannel3 ColorInvertChannel3 | 101 102 103 104 105 106 107 108 109
BLOB | GreyAbsoluteMin GreyAbsoluteMax GreyAbsoluteInvert | 101 102 103

Bild holen (ASCII), nicht verfügbar für RS232/RS422
Byte Nr. | Inhalt | Bedeutung
1 | G | Bild holen
2 | I
3 | M
4 | X | 0 – Letztes Bild 1 – Letztes Schlecht-Bild 2 – Letztes Gut-Bild
Bild holen (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Antwort ID Bild holen
1 | G | Bild holen
2 | I
3 | M
4 | P F | P Erfolgreich (Pass) F Fehler (Fail)
5 | X | Error code 0 – Erfolgreich, 1 – Rekorder aus 2 – Kein passendes Bild für diesen Request
6 | X | Typ Bild 0 - Graustufen 1 – COLOR_BAYER_GB 2 – COLOR_BAYER_GR 3 – COLOR_BAYER_BG 4 – COLOR_BAYER_RG Bei Konvertierung des Farb Bildes von Bayer in RGB, muss der entsprechende Bild Typ berücksichtigt werden. Vorverarbeitungs- Filter der Kategorie "Anordnung" haben Einfluß auf den Bayer- Type.
7 | X | Image result 1 - good image 0 - failed image
8 | X | Anzahl der Zeilen z.B. 0480 / 0200
9 | X
10 | X
11 | X
12 | X | Anzahl der Spalten z.B. 0640 / 0320
13 | X
14 | X
15 | X
16...n | X | Binäre Bilddaten (Zeilen * Spalten)
Zusatzinformationen
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | pulled low
Telegrammende |  | max. 4 Byte (optional)

Shutter setzen (ASCII)
Byte Nr. | Inhalt | Bedeutung
1 | S | Shutter setzen in aktivem Job
2 | S
3 | P T | Permanent Temporär Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
4 | X | Anzahl der Stellen des Shutter Werts, z.B. 04
5 | X
6 | X | Neuer Shutter Wert in Mikrosekunden, z.B. 8000 = 8 ms
7 | X
8 | X
9 | X
Shutter setzen (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Antwort ID Bild holen
1 | S | Shutter setzen
2 | S |
3 | P T | Permanent Temporär Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
4 | P F | P Erfolgreich (Pass) F Fehler (Fail)
Zusatzinformationen
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | pulled low
Telegrammende |  | max. 4 Byte (optional)

Shutterwert lesen (ASCII, ab Version 1.6.5.3)
Byte Nr. | Inhalt | Bedeutung
1 | G | Get shutter, von aktivem Job
2 | S
3 | H
Shutterwert lesen(ASCII) Antwort String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | G | Get shutter
2 | S
3 | H
4 | P F | P Pass F Fail
5 | X | Shutterwert, Länge
6 .. n | X | Shutterwert
Zusätzliche Informationen
Akzeptiert in Run Mode: |  | Ja
Akzeptiert in Konfigurations Mode: |  | Nein
Akezeptiert wenn Ready low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | keine Veränderung
Telegrammende |  | max. 4 Byte (optional)

ROI setzen (ASCII), nicht verfügbar für RS232/RS422
Byte Nr. | Inhalt | Bedeutung
1 | S | ROI setzen SRP0000005500100020016000000120000000800000004000000180000 Länge=55, Detektor=1,gelber Suchbereich, Rechteck, Zentrum X=160, Zentrum Y=120, Halbe Breite= 80, Halbe Höhe=40
2 | R
3 | P T | Permanent Temporär Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
4-11 | X | ROI Info Länge in Bytes ab Byte 4 bis Ende z.B. 00000055
12 | X | Detektor Nr. z.B. 001
13 | X
14 | X
15 | X | ROI Index = 00 für gelben Suchbereich = 01 für roten Teachbereich
16 | X
17 | X | ROI Form 01=Kreis / 02=Rechteck / 03=Ellipse z.B. 02 für Rechteck
18 | X
19-26 | X | Zentrum X (Wert in Pixeln * 1000), z.B. 160 Pixel = 00160000
27-34 | X | Zentrum Y (Wert in Pixeln * 1000), z.B. 120 Pixel = 00120000
35-42 | X | Halbe Breite / X-Radius (Wert in Pixeln * 1000), z.B. 80 Pixel = 0008000
43-50 | X | Halbe Höhe / Y-Radius (Wert in Pixeln * 1000), z.B. 40 Pixel = 0004000
51-58 | X | Winkel (nicht bei Kreis / Ellipse) (Wert in ° * 1000), z.B. 180° = 0018000
ROI setzen (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Antwort ID Bild holen
1 | S | ROI setzen
2 | R |
3 | P T | Permanent Temporär Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
4 | P F | P Erfolgreich (Pass) F Fehler (Fail)
Zusatzinformationen
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | pulled low
Telegrammende |  | max. 4 Byte (optional)

ROI auslesen (ASCII), nicht verfügbar für RS232/RS422
Byte Nr. | Inhalt | Bedeutung
1 | G | ROI auslesen z.B. GRI00100
2 | R
3 | I
4 | X | Detektor Nr. z.B. 001
5 | X
6 | X
7 | X | ROI Index = 00 für gelben Suchbereich = 01 für roten Teachbereich
8 | X
ROI auslesen (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Antwort ID ROI auslesen
1 | G | ROI auslesen
2 | R
3 | I
4 | P F | P Erfolgreich (Pass) F Fehler (Fail)
5-12 | X | ROI Info Länge in Bytes, ab Byte 5 bis Ende String
13 | X | Detektor Nr.
14 | X
15 | X
16 | X | ROI Index = 00 für gelben Suchbereich = 01 für roten Teachbereich
17 | X
18 | X | ROI Form 01=Kreis / 02=Rechteck / 03=Ellipse
19 | X
20-27 | X | Zentrum X (Wert in Pixeln * 1000)
28-35 | X | Zentrum Y (Wert in Pixeln * 1000)
36-43 | X | Halbe Breite / X-Radius (Wert in Pixeln * 1000)
44-51 | X | Halbe Höhe / Y-Radius (Wert in Pixeln * 1000)
52-59 | X | Winkel (nicht bei Kreis / Ellipse) (Wert in ° * 1000)
Zusatzinformationen
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | pulled low
Telegrammende |  | max. 4 Byte (optional)

Detektor einlernen (ASCII)
Byte Nr. | Inhalt | Bedeutung
1 | T | Detektor einlernen (Teach detector)
2 | E
3 | D
4 | X | Detektornummer 0 = Lagenachführung >= 1 Detektoren
5 | X
6 | X
7 | X | Permanenz 0 = Temporär 1 = Permanent Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
8 | X | Trigger 0 = kein Trigger 1 = Trigger
Detektor einlernen (ASCII) Response String vom Sensor
Byte Nr. | Inhalt |
1 | T | Detektor einlernen (Teach detector)
2 | E
3 | D
4 | P F | P Erfolgreich (Pass) F Fehler (Fail)
Zusatzinformationen
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | pulled low
Telegrammende |  | max. 4 Byte (optional)

Kalibrierung: Add Point (ASCII) Request String zum Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Calibration Add Point
2 | A
3 | P
4-8 | X | Listenindex des Kalibrierpunktpaars 0: neuen Punkt am Ende der Liste anfügen >0: Punkt an bestehendem Index überschreiben 1: erster Listeneintrag
9-16 | X | Welt- X
17-24 | X | Welt - Y
Kalibrierung: Add Point (ASCII) Response String vom Sensor
Byte Nr. | Inhalt |
1 | C | Calibration Add Point
2 | A
3 | P
4 | P F | P Erfolgreich (Pass) F Fehler (Fail)
5-8 |  | Listenindex des eingefügten Kalibrierpunktpaars
9-16 | X | Bild- X
17-24 | X | Bild- Y
Zusatzinformationen
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | keine Veränderung
Telegrammende |  | max. 4 Byte (optional)
Nötige Einstellungen im aufrufenden Job |  | Unter "Ausgabe/Datenausgabe/Detektorspezifische Nutzdaten" müssen als erster und zweiter Ausgabewert der X- und der Y- Wert der Findeposition eingestellt sein.

Kalibrierung: Calibrate (ASCII) Request String zum Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Calibration Calibrate
2 | C
3 | L
4 | X | Permanenz 0 = Temporär 1 = Permanent
Kalibrierung: Calibrate (ASCII) Response String vom Sensor
Byte Nr. | Inhalt |
1 | C | Calibration Calibrate
2 | C
3 | L
4 | P F | P Erfolgreich (Pass) F Fehler (Fail)
5-9 | X | Aktuell höchster Punktpaarindex
10-17 | X | RMSE (Root Mean Square Error)
18-25 | X | Mittelwert (Abweichung)
26-33 | X | Max (Abweichung)
34-41 | X | Min (Abweichung)
Zusatzinformationen
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | keine Veränderung
Telegrammende |  | max. 4 Byte (optional)

Kalibrierung: Clear (ASCII), Request String zum Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Calibration Clear
2 | C
3 | D
Kalibrierung: Clear (ASCII), Response String vom Sensor
Byte Nr. | Inhalt |
1 | C | Calibration Clear
2 | C
3 | D
4 | P F | P Erfolgreich (Pass) F Fehler (Fail)
Zusatzinformationen
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | keine Veränderung
Telegrammende |  | max. 4 Byte (optional)

Kalibrierung Validation (ASCII) Request String zum Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Calibration Validation
2 | V
3 | L
Kalibrierung Validation (ASCII) Response String vom Sensor
Byte Nr. | Inhalt |
1 | C | Calibration Validation
2 | V
3 | L
4 | P F | P Erfolgreich (Pass) F Fehler (Fail)
5-9 | X | Aktuell höchster Punktpaarindex
10-17 | X | RMSE (Root Mean Square Error)Welt- X
18-25 | X | Mittelwert (Abweichung)Welt- Y
26-33 | X | Max (Abweichung)
34-41 | X | Min (Abweichung)
Zusatzinformationen
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | keine Veränderung
Telegrammende |  | max. 4 Byte (optional)

Gain setzen (ASCII), Request String zum Sensor
Byte Nr. | Inhalt | Bedeutung
1 | S | Gain setzen
2 | G
3 | A
4 | 1 0 | 1 = Permanent 0 = Temporär Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
5 | X | Neuer Gain Wert
6 | X
7 | X
8 | X
9 | X
Gain setzen (ASCII), Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | S | Gain setzen
2 | G
3 | A
4 | P F | P = Erfolgreich (Pass) F = Fehler (Fail)
5-9 | X | Aktueller Gain Wert
Zusatzinformationen
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Keine Veränderung
Telegrammende |  | max. 4 Byte (optional)

Datenausgabe in ASCII

Dynamisch zusammengesetzt nach User-Einstellungen in Software

Für detailierte Angaben zum Datenformat s. auch: Datenausgabe

Prinzipieller Stringaufbau:

<START> (((<OPTIONAL FIELDS> <SEPARATOR> <PAYLOAD>))) <CHKSUM> <TRAILER>

Ausgabedaten (ASCII), dynamisch zusammengesetzt nach User-Einstellungen in Software

Name | Byte Anzahl | Inhalt ASCII / Beispiel | Bedeutung /Kommentare
Vorspann | 1 - max. 8 | User definiert, bis max. 8 Zeichen | Start String (Header)
Gewählte Felder | 16 | 1 Byte pro Feld | über dieses Feld werden alle aktivierten Checkboxen ausgegeben. - Die Reihenfolge der Ausgabe ist von links nach rechts und von oben nach unten - D.h. pro aktiver Checkbox wird ein Byte beginnend beim LSB = Low significant Bit ausgegeben. - Die Checkbox „Gewählte Felder" selbst wird nicht mit ausgegeben! P = logischer Ausgang gesetzt F = logischer Ausgang nicht gesetzt 0 = logischer Ausgang nicht aktiv
Trennzeichen | 1 - 5 | User definiert, bis max 5 Zeichen (pro Separator) | Separator ab: „nach erstem optionalen Feld“, oder „nach erstem detektorspez. Datum“
Telegrammlänge | n | Pro Ziffer der Dezimalzahl ein Byte z.B. 102 „1“; „0“; „2“ | Telegrammlänge in Byte
Statusbyte | 3 | „110” triggered mode oder „101” free-run mode |
Detektorergebnisse | n | Byte 1 = UND Verknüpfung aller Detektoren Byte 2 = Boolsches Ergebnis der Lagenachführung Byte 3 = Globales Ergebnis des aktiven Jobs Folgende Bytes: Anzahl der Detektoren Folgende Bytes: Detektor Ergebnisse (P = Erfolgreich (Pass), F = Fehler (Fail)), das letzte Byte steht für den ersten Detektor Länge.: 4 Byte + 1 Byte je genutztem Detektor |
Digitalausgänge | n | Erste Bytes: Anzahl aktiver Ausgänge Folgende Bytes:Digitale Ausgänge, | P = logischer Ausgang gesetzt F = logischer Ausgang nicht gesetzt 0 = logischer Ausgang nicht aktiv
Logische Ausgänge | n | Erste Bytes: Anzahl aktiver logischer Ausgänge Folgende Bytes:Logische Ausgänge, | Beispiel: 18 logische Ausgänge werden konfiguriert, aber nur Ausgang 1,2 und 9 werden tatsächlich mit Funktionen belegt (sind also aktiv): 3PP000000P 2 Bytes Anzahl aktiver Ausgänge dann alle Ergebnisse bit- codiert... Im Beispiel werden wg. Ausgang 9, zwei Bytes benötigt.... P = logischer Ausgang gesetzt F = logischer Ausgang nicht gesetzt 0 = logischer Ausgang nicht aktiv
Ausführungszeit | n |  | Aktuelle (Job-)Zykluszeit in [ms]
Aktiver Job | 1-3 |  | Aktive Job Nr. (1..255)
<<Detector specific>> |  |  |
Detektor Ergebnis | 1 | P = Erfolgreich (Pass) F = Fehler (Fail) | Boolsches Detektorergebnis
Score 1 .. n | 1-3 |  | Score (0..100%)
Ausfürhrungszeit | n |  | Ausführungzeit des einzelnen Detektors in [msec].
Abstand | n |  | Berechneter Abstand
Position X 1 .. n | n | z.B.: X = 180 (pixel) = (in ASCII) „180000" = 6 Byte | Gefundene Position X (x-coordinate). [1/1000] *1)
Position Y 1 .. n | n |  | Gefundene Position Y (y-coordinate). [1/1000] *1)
Delta Pos X | n |  | Delta Position X zwischen eingelerntem und gefundenem Objekt [1/1000] *1)
Delta Pos Y | n |  | Delta Position X zwischen eingelerntem und gefundenem Objekt [1/1000] *1)
Winkel | n |  | Orientierung des gefundenen Objekts (0°..360°) [1/1000] *1)
Delta Winkel | n |  | Winkel zwischen eingelerntem und gefundenem Objekt (0°..360°) [1/1000] *1)
Skalierung | n |  | Nur bei Kontur (0,5..2) [1/1000] *1)
Ergebnis horizontal | 1 | P = Erfolgreich (Pass) F = Fehler (Fail) | Boolsches Ergebnis der horizontalen Kantenantastung der Lagenachführung
Ergebnis vertikal | 1 | P = Erfolgreich (Pass) F = Fehler (Fail) | Boolsches Ergebnis der horizontalen Kantenantastung der Lagenachführung
Score horizontal | 1-3 |  | Score 0..100% (Nur Lagenachf. mittles Kantenantastung)
Score vertikal | 1-3 |  | Score 0..100% (Nur Lagenachf. mittles Kantenantastung)
R(ot) | n |  | Wert für Farbparameter
G(rün) | n |  | Wert für Farbparameter
B(lau) | n |  | Wert für Farbparameter
H(ue) | n |  | Wert für Farbparameter
S(aturation) | n |  | Wert für Farbparameter
V(alue) | n |  | Wert für Farbparameter
L(uminanz) | n |  | Wert für Farbparameter
A | n |  | Wert für Farbparameter
B | n |  | Wert für Farbparameter
Ergebnis Index | n |  | Listenindex
Farbabstand | n |  | Abstand der aktuellen Farbe ggü. der eingelernten Farbe
Fläche | n |  | Fläche des BLOBs, ohne Löcher, in Pixel
Fläche (inkl. Löcher) | n |  | Fläche des BLOBs, mit Löchern, in Pixel
Konturlänge | n |  | Anzahl der Pixel der äußeren Kontur
Kompaktheit | n |  | Kompaktheit des BLOBs, (Kreis = 1, andere >1). Je größer die Abweichung der BLOB- Form vom idealen Kreis, desto größer wird der Wert für die Kompaktheit.
Schwerpunkt X | n |  | X- Koordinate des BLOB- Schwerpunkts
Schwerpunkt Y | n |  | Y- Koordinate des BLOB- Schwerpunkts
Zentrum X | n |  | X- Koordinate des gefitteten, geometrischen Elements (Rechtecks / Ellipse)
Zentrum Y | n |  | Y- Koordinate des gefitteten, geometrischen Elements (Rechtecks / Ellipse)
Breite | n |  | Breite des gefitteten, geometrischen Elements (Rechtecks / Ellipse, Breite >= 0, Breite >= Höhe, negative Werte = Fehler)
Höhe | n |  | Höhe des gefitteten, geometrischen Elemets (Rechtecks / Ellipse, Höhe >= 0, Höhe <= Breite, negative Werte = Fehler)
Winkel (360) | n |  | Winkellage des Objekts in Grad, bzgl. der Objektbreite,(Wertebereich +180° ... -180, 0° = Ost, Drehrichtung = Gegenuhrzeigersinn)
Exzentrizität | n |  | Numerische Exzentrizität (Wertebereich. 0,0 ... 1,0)
Bauch/Rücken, Fläche | n |  | Bauch- / Rücken- Lage, Unterscheidung auf Basis: Fläche, angezeigt durch Vorzeichen
String | 1...n | maximale Länge 127 !! | Inhalt des gelesenen Codes, Abhängig vom Code kann die Stringlänge variieren. Wird eine feste Stringlänge gewünscht, so müssen die minimale Stringlänge (Detektorspezifische Nutzdaten) und die maximale Stringlänge (Detektoreinstellungen) auf den gleichen Wert (z.B. 127) gesetzt werden.
Stringlänge | n |  | Länge des gelesenen Codes in Bytes
Trucated | 1 | F = Code komplett, P = Code abgeschnitten | Code abgeschnitten
Prüfsumme | 3 |  | XOR-Prüfsumme über alle Bytes im Telegramm
Nachspann | 1 - max. 8 | User defined, bis max. 8 Charakter | Ende String (Trailer)

*1)Alle detektorspezifischen Daten mit Nachkommastellen werden als ganze Zahlen (mit 1000 multipliziert) übertragen und müssen nach Datenempfang deshalb durch 1000 geteilt werden.


Serielle Kommunikation BINÄR

Datenformate der Kommandos und Datenausgabe

Kommunikationseinstellungen

Kommunikation | Ethernet | RS422
Zum Sensor, Kommando | Wählbar im Tab: Datenausgabe (Binär oder ASCII)
An Sensor, Datenausgabe | Wählbar im Tab: Datenausgabe (Binär oder ASCII)

Kommandos an den Sensor in BINÄR

Trigger (Binär) Anforderungs- String an Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsigned Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x05
5 | Unsigned Char | 0x01 | Kommando Trigger, (einfacher Trigger ohne Index, via Port 2006)
Trigger (Binär) Antwort- String vom Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsined Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x07
5 | Unsigned Char | 0x01 | Kommando Trigger , (Response auf Kommnado Trigger ohne Index, via Port 2006. Falls definiert: Ergebnisdaten ohne Index via Port 2005)
6 | Unsigned Short | 0x00 | Fehler Code 0 = Erfolgreich (Pass) 1 = Fehler (Fail)
7 |  | 0xXX |
Zusatzinformationen
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Ja
Akzeptiert wenn Ready Low: |  |  | Nein
Status des Signals Ready während Bearbeitung: |  |  | Low

Extended Trigger (Binär) Anforderungs- String an Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsigned Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x05
5 | Unsigned Char | 0x013 | Kommando Extended Trigger, Trigger mit Index, zur ZuordnungTrigger zu entsprechenden Ergebnisdaten, via Port 2006)
6 | Unsigned Char | 0xXX | Länge nachfolgender Daten (n)
7...n | Unsigned Char | 0xXX | Daten
Extendetd Trigger (Binär) Antwort- String vom Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsined Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x07
5 | Unsigned Char | 0x013 | Kommando Extended Trigger, (Response auf Trigger mit Index und Ergebnisdaten, via Port 2006, von Zuordnung von Trigger zum Ergebnis. Ergebnisdaten ausserdem ohne Index via Port 2005)
6 | Unsigned Short | 0x00 | Fehler Code 0 = Erfolgreich (Pass) 1 = Fehler (Fail)
7 |  | 0xXX
8 | Unsigned Char | 0xXX | Länge nachfolgender Daten (n)
9...n | Unsigned Char | 0xXX | Daten aus dem Sendebefehl
n+1 | Unsigned Char [] | 0xXX | Betriebsmodus 0 = Konfig Mode 1 = Run Mode
n+2 | Unsigned Int | 0xXX | Ergebnis Daten
n+3 |  | 0xXX
n+4 |  | 0xXX
n+5 |  | 0xXX
n+6 | Unsigned Char [] | 0xXX | Ergebnis Daten
n+7 |  | 0xXX
n+8 |  | 0xXX
n+9...m |  | 0xXX
Zusatzinformationen
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Ja
Akzeptiert wenn Ready Low: |  |  | Nein
Status des Signals Ready während Bearbeitung: |  |  | Low

Jobwechsel (Binär) Anforderungs- String an Sensor
Byte Nr. | DataTyp | Inhalt |  | Bedeutung
1 | Unsigned Int | 0x00 |  | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x06
5 | Unsigned Char | 0x02 |  | Kommando Jobwechsel
6 | Unsigned Char | 0xXX |  | Job Nr, XX = 1- n
Jobwechsel (Binär) Antwort- String vom Sensor
Byte Nr. | DataTyp | Inhalt |  | Bedeutung
1 | Unsined Int | 0x00 |  | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x09
5 | Unsigned Char | 0x02 |  | Kommando Jobwechsel
6 | Unsigned Short | 0x00 |  | Fehler Code 0 = Erfolgreich (Pass) 1 = Fehler (Fail)
7 |  | 0xXX |  |
8 | Unsigned Char | 0xXX |  | Trigger Mode 0 = getriggert 1 = Freilauf
9 | Unsigned Char | 0xXX |  | Job Nr, XX = 1- n
Zusatzinformationen
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Low

Parameter setzen (Binär) Anforderungs- String an Sensor
Byte Nr. | DataTyp | Inhalt |  | Bedeutung
1 | Unsigned Int | 0x00 |  | Telegrammlänge = 9 Bytes + Länge Referenzstring (n)
2 |  | 0x00
3 |  | 0x00
4 |  | 0xn
5 | Unsigned Char | 0x05 0x06 |  | Kommando Parameter permanent setzen Kommando Parameter temporär setzen Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
6 | Unsigned Char | 0xXX |  | Detektor Nr., XX = 1- n
7 | Unsigned Char | 0x65 |  | Kommando Referenzstring / Wert setzen*1), siehe unten!
8 | Unsigned Short | 0x00 |  | Länge neuer Referenzstring / Wert (n)
9 |  | 0x0n
10..n | Unsigned Char | 0xn |  | Referenzstring / Wert
Parameter setzen (Binär) Antwort- String vom Sensor (kann bis zu 4-5 Sekunden verzögert ankommen)
Byte Nr. | DataTyp | Inhalt |  | Bedeutung
1 | Unsigned Int | 0x00 |  | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x08
5 | Unsigned Char | 0x05 0x06 |  | ID Referenzstring permanent setzen ID Referenzstring temporär setzen Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
6 | Unsigned Short | 0xXX |  | Error Code 00 00 = Pass Error Code 00 01 = Fail
7 |  | 0xXX
8 | Unsigned Char | 0x0A |  | Parameter Typ String
Zusatzinformationen
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Low

*1) Byte Nr. 7: Kommando Referenzstring / Wert setzen

Detector | Function | Command | Length of following data
Alignment Pattern matching | Threshold Min Threshold Max | 1 2 | 4 4
Alignment Contour | Threshold Min Threshold Max | 1 2 | 4 4
Alignment Edge | Threshold Min Threshold Max Transition_Horizontal Transition_Vertical | 1 2 101 102 | 4 4 4 4
Pattern matching | Threshold Min Threshold Max | 1 2 | 4 4
Contour | Threshold Min Threshold Max | 1 2 | 4 4
Grey Level | Threshold Min Threshold Max GreyMin GreyMax GreyInvert | 1 2 101 102 103 | 4 4 4 4 1
Contrast | Threshold Min Threshold Max | 1 2 | 4 4
Barcode | Reference String | 101 | n
Datacode | Reference String | 101 | n
OCR | Reference String | 101 | n
ColorValue | ColorMinChannel1 ColorMaxChannel1 ColorInvertChannel1 ColorMinChannel2 ColorMaxChannel2 ColorInvertChannel2 ColorMinChannel3 ColorMaxChannel3 ColorInvertChannel3 | 101 102 103 104 105 106 107 108 109 | 4 4 4 4 4 4 4 4 4
ColorArea | ColorMinChannel1 ColorMaxChannel1 ColorInvertChannel1 ColorMinChannel2 ColorMaxChannel2 ColorInvertChannel2 ColorMinChannel3 ColorMaxChannel3 ColorInvertChannel3 | 101 102 103 104 105 106 107 108 109 | 4 4 4 4 4 4 4 4 4
BLOB | GreyAbsoluteMin GreyAbsoluteMax GreyAbsoluteInvert | 101 102 103 | 4 4 1

Parameter lesen (Binär) Anforderungs- String an Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsigned Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x07
5 | Unsigned Char | 0x0A | Kommando Parameter lesen
6 | Unsigned Char | 0xn | Detektor Nr., XX = 1- n
7 | Unsigned Char | 0x65 | Kommando Referenzstring / Wert lesen*1), siehe unten!
Parameter lesen (Binär) Antwort- String vom Sensor (kann bis zu 4-5 Sekunden verzögert ankommen)
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsigned Int | 0x00 | Telegrammlänge = 10 Bytes + Länge Referenzstring (n)
2 |  | 0x00
3 |  | 0x00
4 |  | 0x0n
5 | Unsigned Char | 0x0A | ID Parameter lesen
6 | Unsigned Short | 0xXX | Error Code 00 00 = Pass Error Code 00 01 = Fail
7 |  | 0xXX
8 | Unsigned Char | 0x0A | Parameter Typ String
9 | Unsigned Short | 0x00 | Länge gelesener Wert (n)
10 |  | 0x0n |
11..n | Unsigned Char | 0xn | Referenzstring / Wert
Zusatzinformationen
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | keine Veränderung

*1) Byte Nr. 7: Kommando Referenzstring / Wert lesen

Detector | Function | Command | Length of following data
Alignment Pattern matching | Threshold Min Threshold Max | 1 2 | 4 4
Alignment Contour | Threshold Min Threshold Max | 1 2 | 4 4
Alignment Edge | Threshold Min Threshold Max Transition_Horizontal Transition_Vertical | 1 2 101 102 | 4 4 4 4
Pattern matching | Threshold Min Threshold Max | 1 2 | 4 4
Contour | Threshold Min Threshold Max | 1 2 | 4 4
Grey Level | Threshold Min Threshold Max GreyMin GreyMax GreyInvert | 1 2 101 102 103 | 4 4 4 4 1
Contrast | Threshold Min Threshold Max | 1 2 | 4 4
Barcode | Reference String | 101 | n
Datacode | Reference String | 101 | n
OCR | Reference String | 101 | n
ColorValue | ColorMinChannel1 ColorMaxChannel1 ColorInvertChannel1 ColorMinChannel2 ColorMaxChannel2 ColorInvertChannel2 ColorMinChannel3 ColorMaxChannel3 ColorInvertChannel3 | 101 102 103 104 105 106 107 108 109 | 4 4 4 4 4 4 4 4 4
ColorArea | ColorMinChannel1 ColorMaxChannel1 ColorInvertChannel1 ColorMinChannel2 ColorMaxChannel2 ColorInvertChannel2 ColorMinChannel3 ColorMaxChannel3 ColorInvertChannel3 | 101 102 103 104 105 106 107 108 109 | 4 4 4 4 4 4 4 4 4
BLOB | GreyAbsoluteMin GreyAbsoluteMax GreyAbsoluteInvert | 101 102 103 | 4 4 1

Bild holen (Binär) Anforderungs- String an Sensor, nicht verfügbar für RS232/RS422
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsigned Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x06
5 | Unsigned Char | 0x03 | Bild holen
6 | Unsigned Char | 0xXX | 0 – Letztes Bild 1 – Letztes Schlecht-Bild 2 – Letztes Gut-Bild
Bild holen (Binär) Antwort- String vom Sensor (kann bis zu 4-5 Sekunden verzögert ankommen)
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsigned Int | 0xXX | Telegrammlänge z.B. 00 04 B0 0D
2 |  | 0xXX
3 |  | 0xXX
4 |  | 0xXX
5 | Unsigned Char | 0x03 | Antwort ID Bild holen
6 | Unsigned short | 0xXX | Error code 00 00 – Erfolgreich, 00 01 – Rekorder aus 00 02 – Kein passendes Bild für diesen Request
7 |  | 0xXX
8 | Unsigned Char | 0xXX | Typ Bild 00 - Graustufen 1 – COLOR_BAYER_GB 2 – COLOR_BAYER_GR 3 – COLOR_BAYER_BG 4 – COLOR_BAYER_RG Bei Konvertierung des Farb Bildes von Bayer in RGB, muss der entsprechende Bild Typ berücksichtigt werden. Vorverarbeitungs- Filter der Kategorie "Anordnung" haben Einfluß auf den Bayer- Type.
9 | Unsigned Char | 0xXX | Ergebnis Bild 01 - Gut-Bild 00 - Schlecht-Bild
10 | Unsigned short | 0xXX | Anzahl der Zeilen e.g. 01 E0
11 |  | 0xXX
12 | Unsigned short | 0xXX | Anzahl der Spalten e.g. 02 80
13 |  | 0xXX
14...n | Unsigned Char | 0xXX | Binäre Bilddaten (Zeilen * Spalten)
Zusatzinformationen
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | pulled low

Shutter setzen (Binär) Anforderungs- String an Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsigned Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x09
5 | Unsigned Char | 0x0E 0x0F | Kommando Shutter setzen temporär Kommando Shutter setzen permanent Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
6 | Unsigned Int | 0xXX | Shutter Wert
7 |  | 0xXX
8 |  | 0xX
9 |  | 0xXX
Shutter setzen (Binär) Antwort- String vom Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsined Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x07
5 | Unsigned Char | 0x0E 0x0F | Antwort Shutter setzen temporär Antwort Shutter setzen permanent Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
6 | Unsigned Short | 0x00 | Fehler Code, 0 = Erfolgreich (Pass), 1 = Fehler (Fail)
7 |  | 0xXX
Zusatzinformationen
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Pulled Low

Shutter lesen (Binär), Anforderungsstring an Sensor (ab Version 1.6.5.3)
Byte Nr. | Datentyp | Inhalt | Bedeutung
1 | Unsigned int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x05
5 | Unsigned Char | 0x17 | Request ID, Shutter lesen
Shutter lesen (Binär) Antwort String vom Sensor
1 | Unsigned int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x0B
5 | Unsigned Char | 0x17 | Request ID, Shutter lesen
6 | Unsigned short | 0xXX | 0 - Pass 1 - Fail 2 - Ungenutzt 3 - Unzureichende Parameter Daten 4 - Kommando abgewiesen, mehrere, gleichzeitige Anfragen empfangen
7 |  | 0xXX
8 | Unsigned int | 0xXX | Shutterwert
9 |  | 0xXX
10 |  | 0xXX
11 |  | 0xXX
Zusätzliche Informationen
Akzeptiert im Run Mode |  |  | Ja
Akezeptiert im Konfigrutaions Mode: |  |  | Nein
Akzeptiert wenn Ready low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Keine Veränderung

ROI setzen (Binär) Anforderungs- String an Sensor, nicht verfügbar für RS232/RS422
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsigned Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x20
5 | Unsigned Char | 0x10 0x11 | Kommando ROI setzen temporär Kommando ROI setzen permanent Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
6 | Unsigned Int | 0xXX | ROI Info Länge in Bytes ab Byte 6 bis Ende
7 |  | 0xXX
8 |  | 0xXX
9 |  | 0xXX
10 | Unsigned Char | 0xXX | Detektor Nr.
11 | Unsigned Char | 0x00 | ROI Index = 00 = gelber Rahmen
12 | Unsigned Char | 0xXX | ROI Form 01=Kreis / 02=Rechteck / 03=Ellipse
13 | Unsigned Int | 0xXX | ROI Parameter: Mittelpunkt X (Wert in Pixeln * 1000)
14 |  | 0xXX
15 |  | 0xXX
16 |  | 0xXX
17 | Unsigned Int | 0xXX | ROI Parameter: Mittelpunkt Y (Wert in Pixeln * 1000)
18 |  | 0xXX
19 |  | 0xXX
20 |  | 0xXX
21 | Unsigned Int | 0xXX | ROI Parameter: halbe Breite bzw. Radius X (Wert in Pixeln * 1000)
22 |  | 0xXX
23 |  | 0xXX
24 |  | 0xXX
25 | Unsigned Int | 0xXX | Nur bei Ellipse / Rechteck: ROI Parameter: halbe Breite bzw. Radius Y (Wert in Pixeln * 1000)
26 |  | 0xXX
27 |  | 0xXX
28 |  | 0xXX
29 | Unsigned Int | 0xXX | Nur bei Ellipse / Rechteck: ROI Parameter: Winkel in ° (Wert in ° * 1000)
30 |  | 0xXX
31 |  | 0xXX
32 |  | 0xXX
ROI setzen (Binär) Antwort- String vom Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsigned Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x07
5 | Unsigned Char | 0x10 0x11 | Antwort ROI setzen temporär Antwort ROI setzen permanent Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
6 | Unsigned Short | 0x00 | Fehler Code, 0 = Erfolgreich (Pass), 1 = Fehler (Fail)
7 |  | 0xXX
Zusatzinformationen
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Pulled Low

ROI auslesen (Binär) Anforderungs- String an Sensor, nicht verfügbar für RS232/RS422
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsigned Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x07
5 | Unsigned Char | 0x12 | Kommando ROI auslesen
6 | Unsigned Char | 0xXX | Detektor Nr.
7 | Unsigned Char | 0xXX | ROI Index = 00 = gelber Rahmen
ROI auslesen (Binär) Antwort- String vom Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsined Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x34
5 | Unsigned Char | 0x12 | Antwort ROI auslesen
6 | Unsigned Short | 0x00 | Fehler Code, 0 = Erfolgreich (Pass), 1 = Fehler (Fail)
7 |  | 0xXX
8 | Unsigned Int | 0xXX | ROI Info Länge in Bytes ab Byte 8 bis Ende
9 |  | 0xXX
10 |  | 0xXX
11 |  | 0xXX
12 | Unsigned Char | 0xXX | Detektor Nr.
13 | Unsigned Char | 0x00 | ROI Index = 00 = gelber Rahmen
14 | Unsigned Char | 0xXX | ROI Form 01=Kreis / 02=Rechteck / 03=Ellipse
15 | Unsigned Int | 0xXX | ROI Parameter: Mittelpunkt X (Wert in Pixeln * 1000)
16 |  | 0xXX
17 |  | 0xXX
18 |  | 0xXX
19 | Unsigned Int | 0xXX | ROI Parameter: Mittelpunkt Y (Wert in Pixeln * 1000)
20 |  | 0xXX
21 |  | 0xXX
22 |  | 0xXX
23 | Unsigned Int | 0xXX | ROI Parameter: halbe Breite bzw. Radius X (Wert in Pixeln * 1000)
24 |  | 0xXX
25 |  | 0xXX
26 |  | 0xXX
27 | Unsigned Int | 0xXX | Nur bei Ellipse / Rechteck: ROI Parameter: halbe Breite bzw. Radius Y (Wert in Pixeln * 1000)
28 |  | 0xXX
29 |  | 0xXX
30 |  | 0xXX
31 | Unsigned Int | 0xXX | Nur bei Ellipse / Rechteck: ROI Parameter: Winkel in ° (Wert in ° * 1000)
32 |  | 0xXX
33 |  | 0xXX
34 |  | 0xXX
Zusatzinformationen
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Pulled Low

Teach Detektor (Binär) Anforderungs- String an Sensor
Byte Nr. | DataTyp | Inhalt |  | Bedeutung
1 | Unsigned Int | 0x00 |  | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x08
5 | Unsigned Char | 0x18 |  | Kommando Teach Detektor
6 | Unsigned Char | 0xXX |  | Detektornummer 0 = Lagenachführung >= 1 Detektoren
7 | Unsigned Char | 0xXX |  | Permanenz 0 = Temporär 1 = Permanent Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
8 | Unsigned Char | 0xXX |  | Trigger 0 = kein Trigger 1 = Trigger
Teach Detectorl (Binär) Antwort- String vom Sensor
Byte Nr. | DataTyp | Inhalt |  | Bedeutung
1 | Unsined Int | 0x00 |  | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x07
5 | Unsigned Char | 0x18 |  | Kommando Teach Detektor
6 | Unsigned Short | 0xXX |  | Fehler Code 0 = Erfolgreich (Pass) 1 = Fehler (Fail) 2 = Unused 3 = Insufficient parameter data 4 = Command rejected, simultaneous module requests received
7 |  | 0xXX
Zusatzinformationen
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Nicht verändert

12-15

Kalibrierung Add Point (Binär) Anforderungs- String an Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsigned Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x10
5 | Unsigned Char | 0x1D | Kommando Calibration Add Point
6 | Unsigned Short | 0xXX | Listenindex des Kalibrierpunktpaars 0: neuen Punkt am Ende der Liste anfügen >0: Punkt an bestehendem Index überschreiben 1: erster Listeneintrag
7 |  | 0xXX
8-11 | Unsigned Int | 0xXX | Welt- X
12-15 | Unsigned Int | 0xXX | Welt- Y
Kalibrierung Add Point (Binär) Antwort- String vom Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsined Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x0F
5 | Unsigned Char | 0x1D | Kommando Calibration Add Point
6 | Unsigned Short | 0x00 | Fehler Code 0 = Erfolgreich (Pass) 1 = Fehler (Fail) 2 = Nicht benutzt 3 = Unzureichende Parameterdaten 4 = Kommando zurückgewiesen, da gleichzeitig anderer Request
7 |  | 0xXX
8-11 | Unsigned Int | 0xXX | Bild- X
12-15 | Unsigned int | 0xXX | Bild- Y
Zusatzinformationen
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | keine Veränderung
Nötige Einstellungen im aufrufenden Job |  |  | Unter "Ausgabe/Datenausgabe/Detektorspezifische Nutzdaten" müssen als erster und zweiter Ausgabewert der X- und der Y- Wert der Findeposition eingestellt sein.

12-15

Kalibrierung Calibration (Binär) Anforderungs- String an Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsigned Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x05
5 | Unsigned Char | 0x1E | Kommando Calibration Calibrate
6 | Unsigned Char | 0xXX | Permanenz 0 = Temporär 1 = Permanent
Kalibrierung Calibration (Binär) Antwort- String vom Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsined Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x17
5 | Unsigned Char | 0x1E | Kommando Calibration Calibrate
6 | Unsigned Short | 0xXX | Fehler Code 0 = Erfolgreich (Pass) t 1 = Fehler (Fail) 2 = Nicht benutzt 3 = Unzureichende parameter Daten 4 = Kommando zurückgewiesen, da gleichzeitig anderer Request
7 |  | 0xXX
8-9 | Unsigned Short | 0xXX | Aktuell höchster Punktpaarindex
10-13 | Unsigned Int | 0xXX | RMSE (Root Mean Square Error)
14-17 | Unsigned Int | 0xXX | Mean (Abweichung)
18-21 | Unsigned Int | 0xXX | Max (Abweichung)
22-25 | Unsigned Int | 0xXX | Min (Abweichung)
Zusatzinformationen
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | keine Veränderung

12-15

Kalibrierung Clear (Binär) Anforderungs- String an Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsigned Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x07
5 | Unsigned Char | 0x1F | Kommando Calibration Clear
Kalibrierung Clear (Binär) Antwort- String vom Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsined Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x07
5 | Unsigned Char | 0x1F | Kommando Calibration Clear
6 | Unsigned Short | 0xXX | Fehler Code 0 = Erfolgreich (Pass) 1 = Fehler (Fail) 2 = Nicht benutzt 3 = Unzureichende parameter Daten 4 = Kommando zurückgewiesen, da gleichzeitig anderer Request
7 |  | 0xXX
Zusatzinformationen
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | keine Veränderung

12-15

Kalibrierung Validation (Binär) Anforderungs- String an Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsigned Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x05
5 | Unsigned Char | 0x20 | Kommando Calibration Validate
Kalibrierung Validation (Binär) Antwort- String vom Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsined Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x17
5 | Unsigned Char | 0x20 | Kommando Calibration Validate
6 | Unsigned Short | 0xXX00 | Fehler Code 0 = Erfolgreich (Pass) 1 = Fehler (Fail) 2 = Nicht benutzt 3 = Unzureichende Parameterdaten 4 = Kommando zurückgewiesen, da gleichzeitig anderer Request
7 |  | 0xXX
8-9 | Unsigned Short | 0xXX | Aktuell höchster Punktpaarindex
10-13 | Unsigned Int | 0xXX | RMSE (Root Mean Square Error)
14-17 | Unsigned Int | 0xXX | Mean (Abweichung)
18-21 | Unsigned Int | 0xXX | Max (Abweichung)
22-25 | Unsigned Int | 0xXX | Min (Abweichung)
Zusatzinformationen
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | keine Veränderung

Gain setzen (Binär) Anforderungs- String an Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsigned Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x0A
5 | Unsigned Char | 0x1B | Kommando Gain setzen
6 | Unsigned Char | 0xXX | 1 = Permanent 0 = Temporär Permanente Änderungen wirken auf alle Parameter, auch auf diejenigen die zuvor nur temporär geändert wurden.
7 | Unsigned Int | 0xXX | Gain Wert
8 |  | 0xXX
9 |  | 0xX
10 |  | 0xXX
Gain setzen (Binär) Antwort- String vom Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsigned Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x0B
5 | Unsigned Char | 0x1B | Kommando Gain setzen
6 | Unsigned Short |  | Fehler Code 0 = Erfolgreich (Pass) 1 = Fehler (Fail) 2 = Nicht benutzt 3 = Unzureichende Parameterdaten 4 = Kommando zurückgewiesen, da gleichzeitig anderer Request
7 |  | 0xXX
8 | Unsigned Int | 0xXX | Aktueller Gain Wert
9 |  | 0xXX
10 |  | 0xXX
11 |  | 0xXX
Zusatzinformationen
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Keine Veränderung

Datenausgabe in BINÄR

Dynamisch zusammengesetzt nach User-Einstellungen in Software

Für detailierte Angaben zum Datenformat s. auch: Datenausgabe

Prinzipieller Stringaufbau:

<START> <OPTIONAL FIELDS> <PAYLOAD> <CHKSUM> <TRAILER>

Ausgabedaten (BINÄR), dynamisch zusammengesetzt nach User-Einstellungen in Software
Name | Byte Anzahl | Inhalt Binär / Beispiel | Bedeutung /Kommentare
Vorspann | 1 - max. 8 | User definiert, bis max. 8 Byte | Start String (Header)
Gewählte Felder | 2 (Word) | 1 Bit pro Feld | über dieses Feld werden „bit-codiert" (in 2Bytes!) alle aktivierten Checkboxen ausgegeben. - Die Reihenfolge der Ausgabe ist von links nach rechts und von oben nach unten. - D.h. pro aktiver Checkbox wird ein Bit (gesetzt/nicht gesetzt) beginnend beim LSB = Low significant Bit ausgegeben. - Die Checkbox „Gewählte Felder" selbst wird nicht mit ausgegeben!
Telegrammlänge | 2 (Word) | z.B. 0x00, 0x02 = Länge =2 Byte | Telegrammlänge in Byte
Statusbyte | 2 (Word) | z.B. 0x00, 0x06 (triggered) z.B. 0x00, 0x05 (free-run) | Byte1: 00000xxx Bit0 = <Free-run> Bit1 = <triggered> Bit2 = <Op.mode> (1=run/0=config) Byte2 (reserved), always 0x00
Detektorergebnis | 4..n | z.B. 0x05 (Bit1+3=5) 0x00 (zwei Bytes Anz. Detektoren) 0x01 0x01 (Detektor-Ergebnis D1) | Byte 1 Bit1 (LSB) = Globales Jobergebnis (1 = Pass, 0 = Fail) Bit2 = Boolsches Erg. nur Lagenachführung, Lagenachführung inaktiv =True Bit3 = UND Verkn. aller Det. des aktiven Jobs Byte 2 und 3 zwei Bytes fuer die Anzahl der Detektoren im Job (ohne Alignment-Detektor). Byte 4 - n 1 Byte je Block von 8 genutzten Detektoren z.B: Bit1(LSB) = Detektor 1, Bit2 = Det. 2, ....
Digitalausgänge | n | Byte 1 und 2: die Anzahl aktiver Ausgänge Byte 3 ... n: Ausgänge, bit-codiert | Ergebnisse aller digitalen Ausgänge (bit-codiert)
Logische Ausgänge | n | Byte 1 und Byte 2: die Anzahl aktiver! log. Ausgänge Byte 3 ... n alle aktiven logischen Ausgänge, bit-codiert | Beispiel: 18 logische Ausgänge werden konfiguriert, aber nur Ausgang 1,2 und 9 werden tatsächlich mit Funktionen belegt (sind also aktiv): 000,003, 003, 001 2 Bytes Anzahl aktiver Ausgänge dann alle Ergebnisse bit-codiert... Im Beispiel werden wg. Ausgang 9, zwei Bytes benötigt.... 1.ErgebnisByte = 00000011 (log. Ausgang1+2) 2.ErgebnisByte = 00000001 (log.Ausgang 9)
Ausführungszeit | 4 (Integer) |  | Aktuelle (Job-)Zykluszeit in [ms]
Aktiver Job | 1 |  | Aktive Job Nr. (1..255)
<<Detektor spezifisch>>
Detektor Ergebnis | 1 | (1 = Pass, 0 = Fail) | Boolsches Detektorergebnis
Score 1 .. n | 4 |  | Score (0..100%)
Ausführungszeit | 4 |  | Ausführungzeit des einzelnen Detektors in [msec].
Abstand | 4 |  | Berechneter Abstand, signed integer [1/1000] *1)
Position X 1 .. n | 4 |  | Gefundene Position X (x-coordinate). [1/1000] *1)
Position Y 1 .. n | 4 |  | Gefundene Position Y (y-coordinate). [1/1000] *1)
Delta Pos X | 4 |  | Delta Position X zwischen eingelerntem und gefundenem Objekt [1/1000] *1)
Delta Pos Y | 4 |  | Delta Position X zwischen eingelerntem und gefundenem Objekt [1/1000] *1)
Winkel | 4 |  | Orientierung des gefundenen Objekts (0°..360°) [1/1000]*1)
Delta Winkel | 4 |  | Winkel zwischen eingelerntem und gefundenem Objekt (0°..360°) [1/1000] *1)
Skalierung | 4 |  | Nur bei Kontur (0,5..2) [1/1000] *1)
Ergebnis horizontal | 1 | 0x01 = True, 0x00 = fail | Boolsches Ergebnis der horizontalen Kantenantastung der Lagenachführung
Ergebnis vertikal | 1 | 0x01 = True, 0x00 = fail | Boolsches Ergebnis der horizontalen Kantenantastung der Lagenachführung
Score horizontal | 2 |  | Score 0..100% (Nur Lagenachf. mittles Kantenantastung)
Score vertikal | 2 |  | Score 0..100% (Nur Lagenachf. mittles Kantenantastung)
R(ot) | 4 |  | Wert für Farbparameter, signed integer [1/1000] *1)
G(rün) | 4 |  | Wert für Farbparameter, signed integer [1/1000] *1)
B(lau) | 4 |  | Wert für Farbparameter, signed integer [1/1000] *1)
H(ue) | 4 |  | Wert für Farbparameter, signed integer [1/1000] *1)
S(aturation) | 4 |  | Wert für Farbparameter, signed integer [1/1000] *1)
V(alue) | 4 |  | Wert für Farbparameter, signed integer [1/1000] *1)
L(uminanz) | 4 |  | Wert für Farbparameter, signed integer [1/1000] *1)
A | 4 |  | Wert für Farbparameter, signed integer [1/1000] *1)
B | 4 |  | Wert für Farbparameter, signed integer [1/1000] *1)
Ergebnis Index | 4 |  | Listenindex, signed integer, [1/1000] *1)
Farbabstand | 4 |  | Abstand der aktuellen Farbe ggü. der eingelernten Farbe, signed integer [1/1000] *1)
Fläche | 4 |  | Fläche des BLOBs, ohne Löcher, in Pixel, signed integer, [1/1000] *1)
Fläche (inkl. Löcher) | 4 |  | Fläche des BLOBs, mit Löchern, in Pixel, signed integer, [1/1000] *1)
Konturlänge | 4 |  | Anzahl der Pixel der äußeren Kontur, signed integer, [1/1000] *1)
Kompaktheit | 4 |  | Kompaktheit des BLOBs, (Kreis = 1, andere >1), signed integer [1/1000] *1)
Schwerpunkt X | 4 |  | X- Koordinate des BLOB- Schwerpunkts, signed integer [1/1000] *1)
Schwerpunkt Y | 4 |  | Y- Koordinate des BLOB- Schwerpunkts, signed integer [1/1000] *1)
Zentrum X | 4 |  | X- Koordinate des gefitteten Rechtecks / Ellipse, signed integer [1/1000] *1)
Zentrum Y | 4 |  | Y- Koordinate des gefitteten Rechtecks / Ellipse, signed integer [1/1000] *1)
Breite | 4 |  | Breite des gefitteten, geometrischen Elements (Rechtecks / Ellipse, Breite >= 0, Breite >= Höhe, negative Werte = Fehler), signed integer [1/1000] *1)
Höhe | 4 |  | Höhe des gefitteten, geometrischen Elemets (Rechtecks / Ellipse, Höhe >= 0, Höhe <= Breite, negative Werte = Fehler), signed integer [1/1000] *1)
Winkel (360) | 4 |  | Winkellage des Objekts in Grad (Wertebereich +180° ... -180, 0° = Ost, Drehrichtung = Gegenuhrzeigersinn), signed integer [1/1000] *1)
Exzentrizität | 4 |  | Numerische Exzentrizität (Wertebereich. 0,0 ... 1,0), signed integer [1/1000] *1)
Bauch/Rücken, Fläche | 4 |  | Bauch- / Rücken- Lage, Basis: Fläche, Unterscheidung der Lage durch Vorzeichen, signed integer [1/1000] *1)
String | 1...n | maximale Länge 127 !! | Inhalt des gelesenen Codes, Abhängig vom Code kann die Stringlänge variieren. Wird eine feste Stringlänge gewünscht, so müssen die minimale Stringlänge (Detektorspezifische Nutzdaten) und die maximale Stringlänge (Detektoreinstellungen) auf den gleichen Wert (z.B. 127) gesetzt werden.
Stringlänge | 4 |  | Länge des gelesenen Codes in Bytes
Truncated | 1 | 0x00 = Code komplett, 0x01 = Code abgeschnitten | Code abgeschnitten
Prüfsumme | 1 |  | XOR-Prüfsumme über alle Bytes im Telegramm
Nachspann | 1 - max. 8 |  | Ende String (Trailer)

*1) Alle detektorspezifischen Daten mit Nachkommastellen werden als ganze Zahlen (mit 1000 multipliziert) übertragen und müssen nach Datenempfang deshalb durch 1000 geteilt werden. Die Werte werden im Format „Big Endian" übertragen.

Beispiel: „Score" Werte (Binär Protokoll)

In Configuration Studio/Visualisation Studio wird „Score" = 35 angezeigt.
Via Ethernet werden dann z.B. folgende vier Bytes empfangen: 000,000,139,115
Formel zu Umrechnung: (HiWordByte*256 + HiLowByte) *65536 + HiByte*256 + LoByte = Value

Da Big Endian (vom Sensor) geschickt wird, gilt:
000 = HiWordByte, 000 = HiLowByte, 139 = HiByte, 115 = LoByte
(0*256 + 0) * 65536 + (139 * 256) + 115 = 35699 / 1000 = 35,699 (= echter Score Wert).
Winkelangaben bzw. andere negative Zahlen werden im Zweierkomplement dargestellt.


Steuerung der Bildwiedergabe

Abbildung: Bildwiedergabe

Mit den Buttons „<" (Zurück), Start / Stop und „>" (Vor) sowie der Schiebeleiste unter dem Bildfeld können Sie die Auswahl und Wiedergabe gespeicherter Bilder steuern. Im Bildzähler wird Ihnen die Nummer des aktuellen Bildes sowie die Anzahl der Bilder im aktiven Filmstreifen angezeigt.


Vision Sensor Visualisation Studio oder Vision Sensor Configuration Studio starten über Autostart

Für den Start von Vision Sensor Visualisation Studio oder Vision Sensor Configuration Studio über Autostart steht unter: Vision Sensor Device Manager/Datei/Autostart- Datei, ein Auswahldialog zur Generierung und Speicherung der entsprechenden Autostart- Datei zur Verfügung.

Nach Auswahl des zu startenden Moduls und des Benutzerlevels, mit "Speichern" die entsprechende Autostartdatei im Ordner ..\Windows\Start Menu\Programs abspeichern (genauer Pfad abhängig von Windiows- Installation).


Vision Sensor EtherNet/IP, Einleitung

Dieses Kapitel beschreibt den Betrieb des Vision Sensors mit EtherNet/IP.

Zum Datenaustausch zwischen Vision Sensor und SPS via EtherNet/IP werden dazu im Folgenden neben dem elektrischen Anschluss die erforderlichen Einstellungen im Vision Sensor und in der SPS (beispielhaft für Rockwell RSLogix) beschrieben.


Job 1… 31 via binärem Eingangs-Bitmuster

Für die Umschaltung von bis zu 31 Jobs via binärer Eingangskombination an den bis zu 5 Eingängen werden alle benötigten Eingänge unter Vision Sensor Configuration Studio/Ausgabe/Pinbelegung mit der entsprechenden Funktion „Jobwechsel Bit x“ belegt. Die entsprechenden wie in unterem Bild gezeigten binären Eingangsmuster schalten dann direkt beim Anlegen auf den entsprechenden Job um. S. auch Kap: Pinbelegung / Funktionen der Eingänge ff.

Hinweise:
  • Jobumschaltung startet sofort nachdem die Eingangskombination gewechselt hat
  • Die Anzeige des aktiven Job´s in der Statuszeile wechselt mit dem ersten folgenden Trigger
  • Die Zuordnung der I/O´s ist nicht fix, sie hängt von den Einstellungen unter Vision Sensor Configuration Studio/Ausgabe/Pinbelegung ab
  • Der Pegelwechsel der zugehörigen Eingänge muss gleichzeitig erfolgen (innerhalb von längstens 10ms müssen alle Pegel stabil anliegen)

Abbildung: Job- Umschaltung binär


Netzwerkanschluss


Netzwerkanschluss Kurzanleitung

Durch die nachfolgenden Anweisungen wird die Netzwerkkonfiguration des PC und des SBS Vision Sensors geändert. Werden dabei falsche Einstellungen verwendet, können unter Umständen die Netzwerkverbindungen auf dem PC verloren gehen. Zur Sicherheit sind die alten Einstellungen zu notieren und bei Bedarf wieder zu verwenden. Ein Neustart des Systems wird nach der Durchführung dieser Anweisungen möglicherweise notwendig. Um herauszufinden welche IP-Adresse in Ihrem Netzwerk oder lokal auf Ihrem PC zulässig ist, und um Ihre Einstellungen an Ihrem PC durchzuführen, bitte zuvor den zuständigen Systembetreuer oder Administrator kontaktieren. Die verwendeten Abbildungen, Dialoge und Menüs stammen aus dem Betriebssystem Microsoft Windows XP™. In anderen Betriebssystemen sind die Abbildungen ähnlich.


EtherNet/IP, Anhang

Assembly Request

Kommunikations Einstellungen

Description: | Request posted from PLC to Vision Sensor
Class: | Class 1
nAssemblyInstance: | 100
nType: | AssemblyConsuming
nLength (bytes): | 344
szAssemblyName: | AssemblyRequest

Assembly Request

Der Vision Sensor empfängt einen Daten Frame mit 344 bytes.

Um Kommandos abzusetzen den Anweisungen folgen.

Jedes Byte entspricht den Werten, die von der SPS zum Sensor geschickt werden. Die Position definiert das genutzte Byte und die Größe definiert die Länge des Kommandos.

Position | Size (bytes) | Member | Data type | Description
0 | 2 | unKey | U16 | request key, eg. a request counter
2 | 2 | unId | U16 | request ID, eg. for requests "trigger", "change job"
4 | 2 | unNumChar | U16 | no. of valid char parameters
6 | 2 | unNumInt | U16 | no. of valid int parameters
8 | 256 | pcValueChar[RQST_NUM_CHAR] | I8 | char parameters for request, member may only hold one string
264 | 80 | 16 int parameters for request | I16 | int parameters for request

Request Key:

Der Request Key steht an Position 0 (Byte 0) und ist 2 Bytes lang. Um die Änderung eines Parameters der gesendet wurde zu bestätigen muss dieser um einen beliebigen Wert inkrementiert werden. Dies ist erforderlich, um das Kommando abzusetzen / zu validieren.

Beispiel:

Im Vision Sensor Trigger auslösen. Der Default Code des Request Key ist 0x0 0x0. Nach der Trigger konfiguration (Beschreibung s. u. ), Request Key inkrementieren um den Trigger auszulösen. Der Request Key Code ist nun: 0x0 0x2.

Position 0:

Byte 1 | Byte 0
Always 0 | 0000 0010

Kommando Konfiguration:

Der Request Key hat eine Größe von 2 Bytes (Position 0 und 1). Das Kommando beginnt an Position 2 und ist 2 Bytes lang. Über die Request ID sind die Kommandos: Trigger, Change job, Statistics reset, Auto shutter, Teach permanent oder temporary, wählbar.

Position 2:

Byte 3 | Byte 2
Always 0 | 0000 0001

Change job: Code: 0x0 0x2 an Position 2 schreiben. LSB an Position 6 auf "1" setzen. (Standard Version: Job 1 oder Job 2, Advanced Version: 255 Jobs). Job Nummer (4 Bytes) an Position / Byte 264 schreiben.

Um den Request zu validieren, den Requeset key inkrementieren. Um danach den Job zu wechseln muss ein Trigger abgesetzt werden. (Wichtig: LSB an Position 6 auf "0" setzen)

Position 2:

Byte 3 | Byte 2
Always 0 | 0000 0010

Position 6:

Byte 7 | Byte 6
Always 0 | 0000 0001

Position 264:

Byte 265 | Byte 264
Always 0 | 0000 0010

Byte 3 | Byte 2
Always 0 | 0000 0100

Auto Shutter: Code: 0x0 0x7 an Position 2 schreiben.

Position 2:

Byte 3 | Byte 2
Always 0 | 0000 0111

Permanent teach: Dieses Einlernen wird permanent gespreichert, d.h. das neue Referenzmuster / Kontur etc. bleibt auch nach einem Reset im Sensor gespeichert. Code: 0x0 0x8 an position 2 schreiben. Trigger setzen um Kommando auszuführen und Request Key inkrementieren.

Position 2:

Byte 3 | Byte 2
Always 0 | 0000 1000

Temporary teach: Dieses Einlernen erfolgt temporärt, d.h. das neue Referenzmuster / Kontur etc. ist nach einem Reset nicht mehr verfügbar. Code: 0x0 0x9 an position 2 schreiben. Trigger setzen um Kommando auszuführen und Request Key inkrementieren.

Position 2:

Byte 3 | Byte 2
Always on 0 | 0000 1001

Summary of available commands:

Commands | Position | Size | Code
Trigger | 2 | 2 | 0x0 0x1
Change job | 2 | 2 | 0x0 0x2
Job number | 264 | 4 | Job number
Statistics reset | 2 | 2 | 0x0 0x4
Auto shutter | 2 | 2 | 0x0 0x7
Permanent teach | 2 | 2 | 0x0 0x8
Temporary teach | 2 | 2 | 0x0 0x9

Beispiel: Um einen Trigger zu setzen: Code 0x0 0x1 an Position 2 schreiben. Request Key an Position 0 verändern: 0x0 0x2 => 0x0 0x4. Der Vision Sensor startet eine neue Bildaufnahme.

Wichtig: Vergessen sie nicht den Request Key zu inkremetieren um das Kommando zu validieren.

Assembly Response

Communication settings

Description: | Response returned from Vision Sensor to PLC
Class: | Class 1
nAssemblyInstance: | 101
nType: | AssemblyProducing
nLength (bytes): | 444
szAssemblyName: | AssemblyResponse

Assembly Response

Assembly Responses sind Daten, die vom Sensor gesendet werden, nachdem dieser Kommandos, die er von der SPS oder einem Programm erhalten hatte, ausgeführt hat.

SPS- Kommandos siehe Ethernet/IP Request File.

Nach der SPS und SBS Vision Sensor Konfiguration ist die Größe des Frame des Assembly response 444Bytes. Jedes Byte entspricht den Werten, die im Folgenden beschrieben sind.

Position | Size (bytes) | Member | Data type | Description
0 | 4 | unFault | U32 | member is standard in Rockwell RSLogix
4 | 2 | unKey | U16 | Request key is returned in response
6 | 2 | unId | U16 | Request ID is returned in response. (Trigger, Change job, Statistics reset…)
8 | 2 | unError | U16 | Error code of response
10 4 unNumChar U32

Responses values for requests like job change, teach …

 | Byte 13 | Byte 12 | Byte 11 | Byte 10
Trigger | Always 0 | Always 0 | Always 0 | 0000 0001
Change job | Always 0 | Always 0 | Always 0 | 0000 0010
Permanent teach | Always 0 | Always 0 | Always 0 | 0000 1000
14 | 2 | RESERVED
16 | 16 | pcValueChar[RPNS_NUM_CHAR] | 18 | char parameters for response, member may only hold one string
32 | 16 | pnValueInt[RPNS_NUM_INT] | U32 | int parameters for response
48 | 4 | unImageCount | U32 | Number of images taken by the Vision Sensor sensor.
52 | 4 | unExecutionTime | U32 | Average execution time of last processed image. (To active this data, select in Vision SensorConfig : Execution time)
56 4 pucStatus[RPNS_IMPL_NUM_BYTE_STATUS] U32

Status : Vision Sensor mode (To active this data, select in Vision SensorConfig : Status)

Freerun : The sensor takes a new picture when the processing is finished.

Trigger : The sensor wait an external signal to take a new picture.

Example Byte 56, bit "0" and "1":

 | Byte 59 | Byte 58 | Byte 57 | Byte 56
Freerun | Always 0 | Always 0 | 0000 000X | 0000 0X01
Trigger mode | Always 0 | Always 0 | 0000 000X | 0000 0X10

Additionnal data for 1.7.10.1 version or more

Configuration : The sensor is connected to a PC for configuration

Example Byte 56, bit "2":

 | Byte 59 | Byte 58 | Byte 57 | Byte 56
Configuration | Always 0 | Always 0 | 0000 000X | 0000 00XX
Run | Always 0 | Always 0 | 0000 000X | 0000 01XX

Run : The job is downloaded in the Vision Sensor memory. The sensor works stand alone.

Byte "57", bit "0" shows the sensor ready status

 | Byte 59 | Byte 58 | Byte 57 | Byte 56
Sensor ready | Always 0 | Always 0 | 0000 0001 | 0000 0XXX
Sensor not ready | Always 0 | Always 0 | 0000 0000 | 0000 0XXX

60

 2 unActiveJob U16 Active job : Value of job number
62 | 2 | RESERVED
64 2 unNumDigital U16

Number of active digital outputs (assigned to one tool) (To active this data, select in Vision SensorConfig : Digital outputs)

According to: Byte 1 and 2, of "Digitalausgänge", in "Serielle Kommunikation /Datenausgabe Binär"
66 2 unNumLogic U16

Number of active logical outputs (assigned to one tool) (To active this data, select in Vision SensorConfig : Logical outputs)

According to: Byte 1 and 2, of "Logische Ausgänge", in "Serielle Kommunikation /Datenausgabe Binär"
68 2 unNumDetector U16

Number of selected tools (It is a default value)

According to: Byte 2 and 3, of "Detektroergebnis", in "Serielle Kommunikation /Datenausgabe Binär"
70 | 2 | unNumBool | U16 | no. of valid boolean parameters
72 | 2 | unNumString | U16 | no. of strings included in pcValueChar
74 | 2 | unNumInt | U16 | Number of received payload (To active this data, select a data in Vision SensorConfig : Payload)
76 2 pucDigital[RPNS_IMPL_NUM_BYTE_DIGITAL] U8

Digital outputs results: result according to the order of the outputs. LSB => first output. MSB => Last output.

Example: 4 active outputs (12, 09, 05, 06). Status of outputs :

12 = OK; 09 = NOK; 05 = OK; 06 = OK. The code will be :

 | Byte 79 | Byte 78 | Byte 77 | Byte 76
Result | 0000 0000 | 0000 0000 | 0000 0000 | 0000 1101

(To active this data, select in Vision SensorConfig : Digital outputs)

According to: Byte 3 ... n, of "Digitalausgänge", in "Serielle Kommunikation /Datenausgabe Binär"
80 8 pucLogic[RPNS_IMPL_NUM_BYTE_LOGIC] U8

Logical outputs results: result according to the order of the outputs. LSB => first output. MSB => Last output.

Example: 4 active outputs (12, 09, 05, 06). Status of outputs :

12 = OK; 09 = NOK; 05 = OK; 06 = OK. The code will be : 1011

 | Byte 83..87 | Byte 82 | Byte 81 | Byte 80
Result | 0000 0000 | 0000 0000 | 0000 0000 | 0000 1011

(To active this data, select in Vision SensorConfig : Logical outputs)

According to: Byte 3 ... n, of "Logische Ausgänge", in "Serielle Kommunikation /Datenausgabe Binär"
88 1 pucDetector[RPNS_IMPL_NUM_BYTE_DETECTOR] U8

Global result (Only available on Vision SensorConfig and Vision SensorViewer):

Only coded on the third LSB bits.

Bit0 = Global result status (0 : OK ; 1 : NOK)

Bit1 = Status of the case « Detector result » in Optional field during the data configuration.

Bit2 = Indicate if one of tools is NOK even if result global is OK => 0

Example 1: We select Detector result case; Tool1 OK; Tool2 OK; Global result on tool1 and on tool2 => OK, the bit2 will be on 1.

 | Byte 88
Result | 0000 0111

Example 2: We select Detector result case; Tool1 OK; Tool2 NOK; Global result on tool1 => OK, the bit2 will be on 0.

 | Byte 88
Result | 0000 0011

Other bits always on 0.

(To active this data, select in Vision SensorConfig : Detector results)

According to: Byte 1, of "Detektroergebnis", in "Serielle Kommunikation /Datenausgabe Binär"
89 3 pucDetector[RPNS_IMPL_NUM_BYTE_DETECTOR] U8

Detector result: Each bit corresponds to a tool.

Only on 1Byte: Bit1 = tool1; bit2 = tool2; bit3 = tool3... until 8 bits.

Other bytes, always on 0.

Future Applications, coded on 3 bytes.

(To active this data, select in Vision SensorConfig : Detector results)

According to: Byte 4 ... n, of "Detektroergebnis", in "Serielle Kommunikation /Datenausgabe Binär"
92 | 4 | pucBool[RPNS_IMPL_NUM_BYTE_BOOL] | U8 | boolean results (bitwise) as configured in HMI (listbox)
96 | 16 | punStringLength[RPNS_IMPL_NUM_STRING] | U16 | lengths of strings included in pcValueChar
112 | 2 | pucStringTruncated[RPNS_IMPL_NUM_BYTE_STRING_TRUNCATED] | U8 | indicates for each string whether it has been truncated (bitwise)
114 | 2 | RESERVED
116 | 128 | pcString[RPNS_IMPL_NUM_BYTE_STRING] | I8 | char result as configured in HMI (listbox), member may hold multiple strings
244 | 200 | pnInt[RPNS_IMPL_NUM_INT] | U32 | Results of payload configured on Vision SensorConfig in tab « frame ». All data on payload are describe as follow :


Vision Sensor Profinet, Einleitung

Dieses Kapitel beschreibt den Betrieb des Vision Sensor mit Profinet. Dies steht zur Verfügung ab Version 1.12.x.x.


Weitere Erläuterungen zur Kantenantastung (Lagenachführung)

Wirkung von Anzahl Suchstrahlen

„Suchstrahlen“ gibt an, in wie viele parallele Suchstrahlen der Suchbereich aufgeteilt wird. Die Kantenantastung wird in jedem Suchstrahl separat durchgeführt. Die erste Kante in Suchrichtung aller Suchstrahlen wird als Gesamtergebnis betrachtet. Mit Erhöhung von „Suchstrahlen“ wird sichergestellt, dass die erste Kante im Suchbereich gefunden wird.

Beim Erhöhen von „Suchstrahlen“ kann es vorkommen, dass die gefundene Kantenstärke stark schwankt, z.B. wenn nur der halbe Suchbereich von der Kante belegt ist. Ursache hierfür ist, dass die Kantenstärke für die erste (nicht die stärkste) Kante angezeigt wird, die in Suchrichtung über der Schaltschwelle liegt.

Abbildung: Kantenantastung mit Suchstrahlen = 1. Es wird die dominierende Kante senkrecht zur Suchrichtung gefunden.

Abbildung: Kantenantastung mit Suchstrahlen >> 1. Es wird die erste Kante senkrecht zur Suchrichtung gefunden.

Wirkung von Sigma (Glättung) auf scharfe bzw. unscharfe Kanten

Die Kantenstärke ergibt sich durch Summation von Kantenstufen über einen Bereich in Suchrichtung, dessen Größe durch „Sigma“ (Glättung) gegeben ist. Bei scharfen Kanten wird die Kantenstärke durch wachsende Glättung nicht erhöht. Bei unscharfen Kanten dagegen wird die Kantenstärke durch wachsende Glättung erhöht.

Abbildung: Antastung von scharfer Kante. Hohe Kantenstärke bei kleinem Sigma (Glättung).

Abbildung: Antastung von unscharfer Kante. Niedrige Kantenstärke bei kleinem Sigma (Glättung).

Abbildung: Antastung von unscharfer Kante. Hohe Kantenstärke bei großem Sigma (Glättung).

Wirkung von Sigma (Glättung) auf Störkanten

Wie oben erwähnt, ergibt sich die Kantenstärke durch Summation von Kantenstufen über einen Bereich in Suchrichtung, dessen Größe durch „Sigma“ (Glättung) gegeben ist. Liegen in diesem Bereich Kanten unterschiedlicher Polarität (dunkel-hell: positive Polarität, hell-dunkel: negative Polarität) so können sich deren Kantenstufen aufheben. Dies kann ausgenutzt werden, um Störkanten zu unterdrücken, indem „Sigma „ (Glättung) hinreichend groß gewählt wird.

Abbildung: Kantenantastung mit Sigma (Glättung) = 1. Störkante wird nicht übersprungen.

Abbildung: , Kantenantastung mit Sigma (Glättung) >> 1. Störkante wird übersprungen.