Vision Sensor – Bedien- und Konfigurationssoftware

Vision Sensor – Bedien- und Konfigurationssoftware – Übersicht

Aufbau der PC- Software

Die Vision Sensor Konfigurationssoftware besteht aus den folgenden drei Anwendungen:

  • Vision Sensor – Bedien- und Konfigurationssoftware –Kurzanleitung

    Mit diesem Programm wählen Sie den zu konfigurierenden Sensor oder einen Sensor-Simulator aus und starten wahlweise die Anwendungen Vision Sensor Configuration Studio oder Vision Sensor Visualisation Studio. Hier werden auch wenn gewünscht / erforderlich Passworte und Benutzerrechte verwaltet.

  • Vision Sensor Configuration Studio

    Dieses Programm stellt Ihnen umfassende Funktionen für Einrichtung und Test von Sensoren sowie die Definition von Prüfaufgaben (Jobs) zur Verfügung. Zur Bedienung benötigen Sie, falls Passwortschutz aktiviert, die Berechtigung der Benutzergruppe Administrator.

  • Vision Sensor Visualisation Studio

    Dieses Programm dient zur Anzeige von Bildern und Ergebnissen und damit zur Überwachung/Überprüfung von Sensoren und zur Analyse von Messergebnissen. Im Vergleich zu Vision Sensor Configuration Studio bietet es nur eingeschränkte Konfigurationsmöglichkeiten. Zur Bedienung benötigen Sie, falls Passwortschutz aktiviert, die Berechtigung der Benutzergruppe Administrator oder Werker. Von hier aus stehen auch umfangreiche Archivierungsfunktionen zur Verfügung.

Abbildung: Softwarestruktur

Hilfe im Kontext

Für alle wichtigen Programmfunktionen gibt es kontextsensitive Hilfe-Seiten: Sobald Sie eine bestimmte Funktion auf der Programmoberfläche auswählen, erhalten Sie im Hilfe-Fenster die passenden Informationen.

Alle verfügbaren Hilfeseiten im Zusammenhang können Sie einsehen, wenn Sie Hilfe (Button mit "?"- Symbol, oder Doppelklick im Online- Hilfe Fenster) im Menü wählen. Dort können Sie auch nach Begriffen oder Stichworten suchen.

Im Unterschied zur kontextsensitiven Hilfe können Sie die Größe dieses Hilfefensters beliebig anpassen, sodass auch längere Hilfetexte übersichtlich dargestellt werden


Vision Sensor – Bedien- und Konfigurationssoftware –Kurzanleitung

Exemplarischer Ablauf, (Beispiel: Objektsensor)

Vision Sensor, Kurzanleitung, Starten der Software

Diese Kurzanleitung erläutert Schritt für Schritt den exemplarischen Ablauf zur Einstellung einer Prüfaufgabe auf dem Vision Sensor.

Zum Starten der Vision Sensor Anwendungssoftware auf das Desktop- Icon „Vision Sensor“ klicken.

Abbildung: Icon Vision Sensor

Vision Sensor Device Manager: Sensoren oder Sensorsimulationen öffnen / Passworte

In diesem Programm können Sie einen Sensor oder eine Sensor-Simulation zur Konfiguration oder zur Anzeige (Überwachung) auswählen sowie verschiedene Grundeinstellungen vornehmen.

Nächstes Thema: Vision Sensor Configuration Studio: Sensor einstellen

Sensoren konfigurieren oder anzeigen

Um einen Sensor zur Konfiguration oder zur Anzeige zu öffnen, den gewünschten Sensor in der Liste „Aktive Sensoren“ markieren. Danach startet ein Klick auf den Button „Konfigurieren“ das Modul „Vision Sensor Configuration Studio“. Mit dem Button „Anzeigen“ startet das Modul „Vision Sensor Visualisation Studio“.

Sensorsimulation

Um einen Sensor zur Offline- Simulation zu öffnen, den gewünschten Sensor in der Liste „Sensoren für Simulationsbetrieb“ markieren. Danach startet ein Klick auf den Button „Konfigurieren“ das Modul „Vision Sensor Configuration Studio“.

Abbildung: Vision Sensor Device Manager Übersicht

A) Aktive Sensoren

In dieser Liste werden alle vom PC aus erreichbaren Vision Sensoren angezeigt.

B) Sensoren für Simulationsbetrieb

Hier werden alle zur Offline- Simulation verfügbaren Vision Sensoren angezeigt.

C) Sensoren per IP Adresse hinzufügen

Sensoren, die nach Softwarestart bzw. nach „Finden“ (Auslösen weiterer Suchdurchgang) nicht in der Liste „Aktive Sensoren“ erscheinen, aber sicher im Netzwerk vorhanden sind (ggf. z.B. erst hinter einem Gateway), und deren IP-Adresse bekannt ist, können hier mit Ihrer IP- Adresse eingetragen werden. Mit Drücken des Buttons „Hinzufügen“ werden solche Sensoren, wenn gefunden, ebenfalls in die Liste „Aktive Sensoren“ eingetragen und können nun bearbeitet werden.

D) Funktionen

  • Finden

Auslösen eines weiteren Suchdurchganges

  • Konfigurieren

Konfigurieren eines angeschlossenen Sensors oder einer Sensorsimulation = Vision Sensor Configuration Studio

  • Anzeigen

Anzeige von Bild- und Ergebnisdaten eines angeschlossenen Sensors = Vision Sensor Visualisation Studio

  • Einstellungen

Netzwerkeinstellungen wie IP-Adresse etc. des Sensors bearbeiten

E) Kontext- Hilfe

Kontextsensitive Hilfe zum aktuellen Thema

Passworte

Beim ersten Start nach der Installation ist die Passworteingabe komplett deaktiviert und der Auto-Login als Administrator voreingestellt.

Sollen Parametereinstellungen vor unbefugtem Zugriff geschützt werden, sollten Passworte für die Passwortebenen „Admin“ und „User“ s.u. vergeben werden. Dies kann über die Menüleiste Datei / Benutzerverwaltung bzw. den Button mit dem Schlüsselsymbol in der Toolbar aufgerufen werden.

Abbildung: Passwort Button

Passwortebenen:

Abbildung: Passwortebenen

Um nach Vergabe von Passworten die Funktion „Konfigurieren“ nutzen zu können, ist nun ein Login mit Klick auf den Toolbar- Login- Button, und danach die Eingabe des vorher vergebenen Passworts nötig.

Abbildung: Login Button

Abbildung: Passworteingabe

Durch Vergabe eines leeren Passworts kann die Abfrage wieder ohne weitere Eingabe quittiert werden. Durch Aktivierung der Checkbox „Passwortabfrage deaktivieren“ wird die Abfrage dauerhaft deaktiviert.

Wurden Passworte vergeben und dann aber vergessen, ist durch Neuinstallation der Software das Rücksetzen auf den Auslieferungszustand möglich.


Vision Sensor Configuration Studio: Sensor einstellen

Mit diesem Programm können Sie Ihren Vision Sensor in sechs folgerichtigen Arbeitsschritten für eine oder mehrere Prüfaufgaben (Jobs) konfigurieren.

Nächstes Thema:Lagenachführung einstellen

Abbildung: Vision Sensor Configuration Studio

Die verschiedenen Arbeitsbereiche sind:

A) Menü- und Toolbar

B) Bedienschritte
Erklärung s. nächstes Kapitel

C) Bild
Bildausgabe mit grafisch einstellbaren Arbeits- und Suchbereichen, sowie Zoomfunktion und Filmstreifennavigation

D) Kontext- Hilfe
Kontextsensitive Online Hilfe, automatisch zu jeder Aktion aktualisiert.

E) Einstellungen der Bildaufnahme
Umschaltung zwischen kontinuierlichem Modus und Einzelbildmodus und Software Trigger

F) Verbindungsmodus
Umschaltung zwischen Online- und Offline- Modus. (Sensor vorhanden oder Simulation ohne Sensor)

G) Konfigurationsfenster
Variabel, zur entsprechenden Aktion, wechselnder Inhalt zur Einstellung der zugehörigen Parameter.

H) Statusleiste

Verschieden Statusinformationen einschließlich: Modus / Name des Vision Sensor / aktiver Job. Im Run Modus: Zykluszeit xy Position des Cursors und Identsität des Pixels / einzelne I/O Ein-/Aus- Status (wie unter "Ausgabe/Ausgangssignale" konfiguriert).

Job konfigurieren

Um einen Job zu konfigurieren: unter Bedienschritte/Job im Feld "Jobs", den Jobeintrag editieren oder ggf. einen neuen Job anlegen.

Abbildung: Vision Sensor Configuration Studio Job

Hier werden im Feld „Jobs“ neue Jobs angelegt und auch mehrere Jobs verwaltet. Außerdem werden hier alle globalen Einstellungen, die für die gesamte Prüfaufgabe gültig sind, wie z.B. Verschlusszeit, Verstärkung, Beleuchtungseinstellungen etc. vorgenommen. Ein Job enthält sämtliche Einstellungen und Parameter, die zur Durchführung einer bestimmten Prüfaufgabe erforderlich sind.

  • Zuerst sollten, um ein kontrastreiches und scharfes Bild zu erhalten, folgende grundlegenden Bildeinstellungen gemacht werden:
    * Bildhelligkeit: Verschlusszeit bzw Verstärkung einstellen s. Job/Bildaufnahme
    * Bildschärfe: Focus Einstellschraube an der Rückseite des Vision Sensor einstellen bis eine scharfe Abbildung sichtbar ist
  • Im Auslieferungszustand ist als Trigger Modus = "Freilauf" (s. Job/Bildaufnahme) und als „Trigger / Bildaktualisierung“ = "Kontinuierlich" eingestellt. Damit wird zur Focus- und Helligkeitseinstellung permanent ein neues Bild eingezogen und somit die Anzeige auch permanent aktualisiert.
  • Die danach folgende Einstellung der Lagenachführung und der Detektoren erfolgt vorzugsweise im Einzelbildmodus, da alle Einstellungen dann auf einem Masterbild basieren und der Bildeinzug nicht permanent ausgeführt wird. Dazu unter Bildaufnahme/Triggermodus = Trigger einstellen.
  • Innerhalb eines Jobs kann nachfolgend eine Lagenachführung und verschiedene Detektoren zur Lösung der Prüfaufgabe definiert werden.


Lagenachführung einstellen

Bei Objekten bzw. Merkmalen, deren Position im Bild variiert, kann eine Lagenachführung nützlich bzw. erforderlich sein.

Nächstes Thema: Detektoren einstellen

Die Lagenachführung ist optional und steht mit der Methode Konturvergleich zur Verfügung.

Nach Auswahl der Lagenachführung die entsprechenden Arbeitsbereiche im Bild grafisch in Position und Größe auf das Merkmal, welches zur Lagebestimmung dienen soll, einstellen.

Die zugehörigen Parameter werden unten rechts dargestellt und können dort auch angepasst werden. Die Lagenachführung wirkt auf alle nachfolgend in diesem Job definierten Detektoren.

Im Beispiel hier wird die linke obere Ecke des rechteckigen Bauteils durch die Bestimmung der linken und der oberen Außenkante und deren Schnittpunkt zur Lagebestimmung des nur translatorisch in X- und Y- Richtung in der Position variierenden Bauteiles bestimmt. Sollte auch die Winkellage des Bauteiles variieren können, ist die Methode „Konturvergleich“ zur Lagenachführung zu verwenden.

Abbildung: Lagenachführung


Detektoren einstellen

Hier können verschiedene Detektoren zur Lösung einer Prüfaufgabe ausgewählt und eingestellt werden. Zuerst wird im unten dargestellten Dialog ein gewünschter Detektor ausgewählt.

Abbildung: Detektorliste Objektsensor

Danach werden die Arbeits- und Suchbereiche graphisch im Bild eingestellt. Falls Einlernbereiche vorhanden sind, werden diese sofort bei Abschluss der Einstellung eingelernt. Unten links werden alle in diesem Job definierten Detektoren angezeigt. Unten rechts werden die Parameter des aktuell ausgewählten Detektors angezeigt und können dort auch angepasst werden. Falls weitere Merkmale am selben Teil zu prüfen sind, lassen sich mit „Neu" beliebig viele weitere Detektoren, analog wie oben beschrieben, erstellen. Im Beispiel wurden zwei Helligkeits- Detektoren zur Überprüfung der Anwesenheit von Kontakten im Prüfteil definiert. Detektor 1 findet einen Kontakt (Helligkeitswert liegt im geforderten Bereich, da metallisch- glänzender, d.h. hoch reflektierender Kontakt vorhanden), und meldet deshalb ein positives Ergebnis.
Detektor 2 findet keinen Kontakt (Helligkeitswert liegt außerhalb des geforderten Bereichs, da kaum Reflektion durch dunkles Kunststoffgehäuse), und meldet deshalb ein negatives Ergebnis.

Abbildung: Detektor erstellen


Ausgabe, I/O und Datenausgabe

Im Bedienschritt Ausgabe können verschiedene Einstellungen bezüglich der digitalen Ein- / Ausgänge und der Datenausgaben gemacht werden.

Nächstes Thema: Ergebnis

In den verschiedenen Tabs die Schnittstellen auswählen und aktivieren. Detektorergebnisse logisch verknüpfen, und den vorhandenen I/O´s zuordnen.

Zur Ausgabe von Ergebnisdaten ebenfalls gewünschte Schnittstelle wählen und Datenstring zusammenstellen.

Abbildung: Abbildung, Ausgabe, Digitale Signale und Daten

Einstellmöglichkeiten in den verschiedenen Tabs:

  • Pinbelegung

    Auswahl und Zuordnung der digitalen Schalt- Ein- und Ausgänge.

  • Ausgangssignale

    Zuordnung einer logischen Verknüpfung unter Nutzung der boolschen Ergebnisse aller Detektoren. Definition von komplexen logischen Verknüpfungen via Tabelle oder via Eingabe einer logischen Formel.

    Zu jedem vorhandenen digitalen Ausgang kann eine eigene logische Verknüpfung zugeordnet werden.

  • Schnittstellen

    Auswahl, Einstellung und Aktivierung der einzelnen Schnittstellen.

  • Zeitsteuerung

    Einstellung der Delayzeiten: Trigger-Verzögerung, Ergebnis-Verzögerung und Ergebnis-Dauer

  • Datenausgabe

    Einstellung des Datenausgabestrings via RS422 oder Ethernet.

Auswahl von: Binärem- oder ASCII- Protokoll, Vorspann u./o. Nachspann, Standardinhalten u./o. flexibel zusammenstellbaren, speziellen Einzeldaten der einzelnen Detektoren.
Es können beliebig viele Einzelergebnisse aller definierten Detektoren im Ausgabestring frei angeordnet werden.


Ergebnis

Über diese Funktion wird die Prüfung mit allen gemachten Einstellungen auf dem PC zu Kontrollzwecken ausgeführt. Dabei werden alle Ergebnisse genau wie später auf dem Sensor erzeugt und angezeigt. Jedoch z.B. die Ausführungszeiten nicht aktualisiert, da diese Werte nur aussagefähig sind, wenn die Ausführung auf dem Sensor selbst erfolgt. S. nächster Schritt: „Sensor starten“. Es werden keine Hardware- Ausgänge gesetzt.

Nächstes Thema: Sensor starten

Abbildung: Ergebnisanzeige


Sensor starten

Mit Aktivierung dieser Funktion werden alle Einstellungen auf den Sensor übertragen, im Flash gespeichert und dort entsprechend der vorgenommenen Einstellungen z.B. im Freilauf oder im getriggerten Modus ausgeführt. Alle Anzeigen in der Detektorliste, im Ergebnisfeld bzw. unter „Statistik“ werden hier aktualisiert. Bei Aktivierung dieser Funktion werden die übertragenen Parameter permanent gespeichert und bei der Ausfühurng werden auch die entsprechenden Hardware- Ausgänge gesetzt.

Nächstes Thema: Vision Sensor Visualisation Studio, Bilder und Ergebnisse anzeigen

Abbildung: Sensor starten


Vision Sensor Visualisation Studio, Bilder und Ergebnisse anzeigen

Dieses Programm dient zur Überwachung/Überprüfung von angeschlossenen Sensoren und zur Analyse von Prüfergebnissen, sowie zur Archivierung von Prüfergebnissen und Bildern.

Nach Klick auf den Button „Anzeigen" in Vision Sensor Device Manager startet das Modul Vision Sensor Visualisation Studio.

Das aktuelle Bild wird mit Einzeichnungen der Lagenachführung und der Detektoren angezeigt (falls „Bildübertragung = Aktiv“ im Konfigurationsmodul unter Job/Allgemein aktiviert ist).

Im Tab „Ergebnis“ werden die einzelnen Detektoren mit Ihren Ergebnissen, und das Gesamtergebnis dargestellt.
Im Tab „Statistik“ werden weitere statistische Ergebnisse angezeigt.
Mit „Bild einfrieren" können ereignisgesteuert (z.B. Schlechtteil) Bilder in der Anzeige festgehalten werden.
Mit „Zoom" können Bilder vergrößert dargestellt werden.
Mit „Bilder archivieren" können Bilder und Ergebnisdaten, wie zuvor unter „Menü Datei/Archivierung konfigurieren", eingestellt, auf der Festplatte des angeschlossenen PC´s, mit oder ohne numerischen Ergebnisdaten, archiviert werden.
Mit „Rek. Bilder" kann der Bildrekorder ausgelesen werden.
Im Tab „Job“ können auf dem Sensor vorhandene Jobs umgeschaltet werden.
Im Tab „Hochladen“ können weitere zuvor definierte Jobs oder ganze Jobsätze von Vision Sensor Visualisation Studio aus auf den Sensor geladen werden.

Abbildung: Vision Sensor Visualisation Studio


Vision Sensor – Bedien- und Konfigurationssoftware – Vision Sensor Device Manager, alle Funktionen

In diesem Programm können Sie einen Sensor oder eine Sensor-Simulation zur Konfiguration, oder zur Anzeige (Überwachung) auswählen, sowie verschiedene Grundeinstellungen vornehmen:

  • Aktive Sensoren
  • Sensoren für Simulationsbetrieb
  • Finden / Aktiven Sensor hinzufügen
  • Konfigurieren eines angeschlossenen Sensors
  • Anzeigen von Bild und Ergebnisdaten
  • Netzwerk- Einstellungen des Sensors
  • Update / Firmware-Aktualisierung
  • Benutzerverwaltung / Passworte

Abbildung: Vision Sensor Device Manager

Ist die Funktion „Konfigurieren"" nicht zugänglich (Button inaktiv) so ist ein Login (Button mit Türsymbol und Pfeil) mit Passworteingabe nötig. Falls Sie das Passwort nicht kennen, bitte den Administrator kontaktieren.


Aktive Sensoren

In der Auswahlliste Aktive Sensoren werden die im Netzwerk verfügbaren Sensoren angezeigt.

Konfigurieren eines angeschlossenen Sensors (Aufruf von Vision Sensor Configuration Studio)

Anzeigen von Bild und Ergebnisdaten (Aufruf von Vision Sensor Visualisation Studio)

Bedeutung der angezeigten Parameter
Parameter | Bedeutung
IP-Adresse | IP- Adresse des Sensors im Netzwerk
Hardware | Hardware Version (R3 o.ä.)
Sensortyp | Sensortyp (Objekt-, Code reader o.ä.)
Variante | Sensor-Variante
Version | Firmware-Version
Mode | Betriebsart (Run, Config oder Offline)
Sensorname | Name des Sensors
Hersteller | Name des Herstellers
Mac-Adresse | Mac-Adresse des Sensors
Subnetz-Maske | Subnetzmaske des Sensors
Gateway | Standard Gateway
DHCP | DHCP aktiv / inaktiv
Betriebssystem | Art des Betriebssystems
Betriebssystem Version | Version des Betriebssystems
Plattform | z.B. Vision Sensor
Hardware | Hardware Version
RAM | RAM Größe
Flash | Flash Größe
Hinweise:
  • Werden in der Liste keine Einträge angezeigt, obwohl ein Sensor angeschlossen ist, können Sie diesen mit Button „Finden" oder Button „Hinzufügen" einfügen.
  • Ist kein Sensor angeschlossen, stehen Ihnen in der Liste Sensoren für Simulationsbetrieb, Simulationen verschiedener Sensoranwendungen zur Verfügung.

Über den Button Details (am rechten Ende der Parameter Liste von „Aktive Sensoren“) ist eine noch detailiertere Liste der Vision Sensor Parameter abzurufen.

Abbildung: Sensoreigenschaften


Sensoren für Simulationsbetrieb

In der Auswahlliste Simulation werden Ihnen verfügbare Sensor-Simulationen angezeigt.

Zur Bearbeitung einen Listeneintrag doppelklicken bzw. auswählen und Button: Konfigurieren (Aufruf von Vision Sensor Configuration Studio) drücken.

Bedeutung der angezeigten Parameter

Parameter | Bedeutung
Sensortyp | Sensortyp (z.B. Objekt-, Code reader, ...)
Version | Firmware-Version
Variante | Sensor-Variante

Ist die Funktionen "Konfigurieren" nicht zugänglich (Button inaktiv), so ist ein Login mit Passworteingabe nötig. Falls Sie das Passwort nicht kennen, bitte den Administrator kontaktieren.


Finden / Aktiven Sensor hinzufügen

Werden in der Auswahlliste „Aktive Sensoren“ keine Einträge angezeigt, obwohl ein Sensor angeschlossen ist, gehen Sie wie folgt vor:

Finden / Sensor suchen:

Um nach am PC angeschlossenen, oder im Netzwerk verfügbaren Sensoren zu suchen, klicken Sie auf Button „Finden".

Aktiven Sensor hinzufügen:

Wenn ein Sensor, obwohl er im Netzwerk, ggf. auch erst hinter einem Gateway, angeschlossen ist, auch nach einem weiteren mit Button „Finden“ durchgeführten Suchlauf nicht in der Liste „Aktive Sensoren“ erscheint. Und aber die IP-Adresse des Sensors bekannt ist, geben Sie diese in das Feld IP-Adresse ein und klicken Sie anschließend auf Button „Hinzufügen".

Der Sensor erscheint nun in der Liste und kann zur Bearbeitung ausgewählt werden.


Konfigurieren eines angeschlossenen Sensors

Markieren Sie einen Sensor (bzw. eine Simulation) in der Liste und klicken Sie auf den Button „Konfigurieren".

Das Konfigurationsprogramm Vision Sensor Configuration Studio wird aufgerufen und die ggf. auf dem Sensor gespeicherten Jobs werden in der Auswahlliste angezeigt.

Beim Aufruf von Vision Sensor Configuration Studio erscheint u.U. eine Passwortabfrage. Zur Festlegung von Passwörtern siehe Benutzerverwaltung. (Button mit Schlüsselsymbol)

s. Kapitel: Vision Sensor – Bedien- und Konfigurationssoftware –Vision Sensor Configuration Studio, alle Funktionen


Anzeigen von Bild und Ergebnisdaten

Markieren Sie einen Sensor in der Liste und klicken Sie auf den Button „Anzeigen".

Das Programm Vision Sensor Visualisation Studio wird aufgerufen und Bilder und Messergebnisse des aktiven Jobs angezeigt.

Hinweise:

Durch Aufruf von Vision Sensor Visualisation Studio wird der Betrieb des ausgewählten Sensors zunächst nicht beeinflusst.

s. Kapitel : Vision Sensor – Bedien- und Konfigurationssoftware –Vision Sensor Visualisation Studio, alle Funktionen


Netzwerk- Einstellungen des Sensors

Mit dem Button „Einstellungen" können Sie die Netzwerkeinstellungen des gewählten Sensors ändern.

IP-Adresse, Subnetz-Maske, Standard- Gateway, DHCP und ein Sensorname können hier eingestellt werden.

Die IP-Adresse und die Subnetz-Maske des PC wird unten in der Statusleiste von Vision Sensor Device Manager angezeigt.

Zur Verbindung des Sensors mit dem PC müssen die Adressräume übereinstimmen. Dazu ggf. hier die IP-Adresse etc. des Sensors entsprechend einstellen.

Bitte kontaktieren Sie zur Festlegung von Netzwerkparametern Ihren Administrator. Weitere Informationen hierzu finden Sie auch im Kapitel Netzwerkanschluss Kurzanleitung und Netzwerkanschluss .

Wenn "DHCP = aktiv" gewählt wird, muss für den Sensor ein Name vergeben werden, da die IP-Adresse dann bei jedem Sensorstart neu vergeben wird und somit wechseln kann, d.h. nicht mehr eindeutig ist.

Für diese Funktionen benötigen Sie Administratorrechte (siehe Benutzerverwaltung).

Abbildung: Vision Sensor Device Manager IP Setup

s. Kapitel: Netzwerkanschluss Kurzanleitung und Netzwerkanschluss


Update / Firmware-Aktualisierung

Mit dem Menüpunkt Datei/Firmware-Update können Sie die Firmware des gewählten Sensors aktualisieren.

Dazu muss vorher via Download von der Festo Homepage www.festo.com, im entsprechenden Support Portal mit Suchbegriff "SBSI", die entsprechende Firmware-Update Datei beschafft werden.

Wählen Sie im sich öffnenden Dialog die entsprechende Firmware-Datei und folgen den Anweisungen.

Abbildung: Vision Sensor Device Manager, Firmware Update


Benutzerverwaltung / Passworte

Die Vision Sensor-Konfigurationssoftware unterscheidet drei Benutzergruppen, die unterschiedliche Berechtigungen besitzen:

(Button oben, links, mit Schlüsselsymbol)

Abbildung: Vision Sensor Device Manager, Passworte

Benutzer | Vision Sensor Device Manager | Vision Sensor Configuration Studio | Vision Sensor Visualisation Studio
Administrator | alle Funktionen | alle Funktionen | alle Funktionen
Werker | alle Fkt. außer - Konfig. - Einstell. - Update | keine | alle Funktionen
Bediener (ohne Passwort) | alle Fkt. außer - Konfig. - Einstell. - Update | keine | nur Anzeige Bilder, Prüfergebnisse und -statistik

Nach Installation der Software wird der Login automatisch sofort bei Aufruf der Anwendung ohne Passwortabfrage ausgeführt. Es sind keine Passworte vergeben.

Passwörter festlegen:

Wählen Sie Benutzerverwaltung im Datei-Menü oder klicken Sie in der Toolbar auf den Button mit Schlüsselsymbol, um Passwörter für die Benutzerkategorien Administrator und Werker zu vergeben bzw. zu ändern. Nach Eingabe eines Passworts wird automatisch ein LogOut ausgeführt, d.h. ab dann ist die Eingabe des neu vergebenen Passwortes nötig. Bei Vergabe eines "leeren" Passworts kann die Eingabe einfach mit OK quittiert werden.

Abbildung: Vision Sensor Device Manager, Passwort-Button

Login

Nach der Vergabe von Passworten und darauf folgendem automatischem LogOut ist z. B. zur Konfiguration eines Sensors ein Login nötig. Dazu in der Toolbar auf den Button mit Schlüsselsymbol klicken, um sich einzuloggen oder / und, nach erfolgter Passworteingabe, die Passworteingabe für die nächsten Sitzungen für die gewählte Benutzergruppe zu deaktivieren.

Wurde der Haken bei „Passwortabfrage deaktivieren" gesetzt, wird beim nächsten Start der Anwendung nicht mehr nach dem Passwort gefragt.

Abbildung: Vision Sensor Device Manager Login- Button


Vision Sensor – Bedien- und Konfigurationssoftware –Vision Sensor Configuration Studio, alle Funktionen

Mit diesem Programm können Sie Ihren Vision Sensor in sechs Arbeitsschritten für eine oder mehrere Prüfaufgaben (Jobs) konfigurieren:

  • Jobs (Prüfaufgaben)
  • Lagenachführung
  • Detektoren
  • Ausgabe von Prüfergebnissen
  • Ergebnis
  • Start des Sensors

Weitere Programmfunktionen:

  • Trigger-Einstellungen
  • Verbindungsmodus- Umschalten zwischen Online- und Offline-Modus
  • Simulation von Jobs (Offline-Modus) von Prüfjobs anhand von Bilderserien (Filmstreifen)
  • Erstellen von Filmstreifen zu Analyse- oder Simulationszwecken.
    Die Ausführung von Vision Sensor Configuration Studio erfordert u.U. die Eingabe eines Passworts (Benutzergruppe: Administrator). Siehe hierzu : Benutzerverwaltung / Passworte
  • Archivierung Bildrekorder (auch via FTP / SMB)

Um auch ohne Trigger ein stetig aktualisiertes Livebild zu erhalten folgende Einstellungen vornehmen:

  • Freilauf einstellen unter "Job/Bildaufnahme"
  • Kontinuierlichh einstellen unter "Trigger / Bild holen" Programmoberfläche und Bedienung


Jobs (Prüfaufgaben)

Ein Job enthält sämtliche Einstellungen und Parameter, die zur Durchführung einer bestimmten Prüfaufgabe erforderlich sind.

Nächstes Thema: Erstellen, Bearbeiten und Verwalten von Jobs

Abbildung: Vision Sensor Configuration Studio Job


Erstellen, Bearbeiten und Verwalten von Jobs

Einen ausgewählten (in der Liste links unten markierten) Job können Sie durch Eingabe von Parametern in den Reitern des Konfigurationsfensters (rechts, unten) bearbeiten.

Nächstes Thema: Laden und Speichern von Job oder Jobsatz

Wenn kein Jobeintrag in der Liste vorhanden ist, müssen Sie zuerst einen neuen Job erstellen.

Neuen Job erstellen:

1. Klicken Sie auf den Button "Neu" unter der Job-Auswahlliste links unten. Ein neuer Jobeintrag erscheint in der Liste.

2. Editieren Sie den Eintrag durch Doppelklick auf das jeweilige Feld (Name, Beschreibung, Autor)

Weitere Funktionen:

Funktion | Beschreibung
Neu | Neuen Job definieren
Laden | Einen Job vom PC laden
Speichern | Den ausgewählten Job auf dem PC speichern
Löschen | Den ausgewählten Job aus der Liste löschen
Alle löschen | Alle Jobs in der Liste löschen

Alle beschriebenen Funktionen können Sie auch über das Datei-Menü ausführen.

Abbildung: Vision Sensor Configuration Studio Jobliste

Wenn die Kapazität des Sensorspeichers erschöpft ist und keine weiteren Jobs auf den Sensor geladen werden können, wechselt die Farbe der Restspeicheranzeige in der Statuszeile (unten) auf Rot.


Laden und Speichern von Job oder Jobsatz

Jobs können einzeln oder ein ganzer Satz von Jobs als Jobsatz geladen und gespeichert werden. Sind mehrere Jobs auf dem Sensor gespeichert, bilden diese einen Jobsatz, den Sie genau so wie einen einzelnen Job als XML-Datei auf Ihrem PC oder einem externen Speichermedium ablegen können.

Nächstes Thema: Bildaufnahme Parameter

Job / JobSet speichern:

Wählen Sie „Job speichern unter ...“, oder „Jobsatz speichern unter ...“ aus dem Datei-Menü.

Job / Jobsatz öffnen:

Wählen Sie „Job öffnen ...“, oder „Jobsatz öffnen“ ... aus dem Datei-Menü.

Mit dem Button "Sensor starten" werden Jobs auf den Sensor übertagen.

Alle auf dem Sensor gespeicherten Jobs werden beim Laden eines neuen Jobsatzes gelöscht!

Abbildung: Vision Sensor Configuration Studio Jobs laden / speichern


Bildaufnahme Parameter

Im Reiter Bildaufnahme S. Kap. Jobs (Prüfaufgaben) bestimmen Sie die grundlegenden Parameter der Bildaufnahme.

Die Bildschärfe wird mit der Focus- Einstellschraube an der Geräterückseite des Vision Sensor eingestellt.

Parameter | Funktion und Einstellmöglichkeiten

Auflösung

Standardauflösung ist QVGA (320x240), bei zeitkritischen Anwendungen kann eine andere Auflösung gewählt werden.

Verfügbare Auflösungen:

R3: WVGA (736x480), VGA (640x480), QVGA (320x240), QQVGA (160x120)

Bei Änderung der Auflösung werden alle bereits definierten Detektoren gelöscht!

Zoom

Über die Auswahl verschiedener Zoom-Stufen können unterschiedliche Bildausschnitte mit unterschiedlichen Abbildungsgrößen erzielt werden.
Dynamik | Optimierung der Charakteristik der Bildaufnahme: "Linear" bedeutet lineare Kennlinie (verhalten wie bei Vision Sensor-Produkten, die keine dynamische Bildaufnahme unterstützen), "Hoch" bedeutet bessere Feinabstufung in hellen Bereichen des Bildes (Übersteuerung).

Triggermodus

Auswahlmöglichkeit, ob der Vision Sensor im getriggerten Modus oder im Freilauf betrieben werden soll.

Im getriggerten Modus kann über den Triggereingang Pin 03 WH oder über eine der Schnittstellen eine Bildaufnahme ausgelöst werden.

Im Freilauf macht der Vision Sensor kontinuierlich Bilder und Auswertungen.

Verschlusszeit

Parameter zur Steuerung der Bildhelligkeit. Die Bildhelligkeit sollte vorzugsweise mit der Verschlusszeit eingestellt werden. Erst im zweiten Schritt, wenn nötig, die Verstärkung einstellen (Grundeinstellung Verstärkung = 1). Bei bewegten Prüfobjekten kann eine längere Verschlusszeit zu Bewegungsunschärfe im Bild führen. Mit dem Button „Auto“ kann die Belichtung automatisch eingestellt werden. Die maximal am Schieberegler einstellbare Verschlusszeit ist auf 100 ms eingestellt. Jedoch ist zu beachten, dass die Dauer des internen Belichtungspulses auf 8 ms begrenzt ist. Verschlusszeiten länger als 8 ms machen also nur Sinn, wenn externe Beleuchtung oder interne + externe Beleuchtung verwendet werden.

Verstärkung

Parameter zur Steuerung der Bildhelligkeit. Die Bildhelligkeit sollte vorzugsweise mit der Verschlusszeit eingestellt werden, erst im zweiten Schritt wenn nötig die Verstärkung einstellen (Grundeinstellung Verstärkung = 1)

Quadranten Beleuchtung

Durch Klicken auf die Darstellung der LED können einzelne Quadranten der Beleuchtung abgeschalten werden. Diese Funktion kann bei geringen Arbeitsabständen Reflektionen unterdrücken.

Interne Beleuchtung

Auswahl für interne Beleuchtung (Ein / Aus)

Externe Beleuchtung

Auswahl für externe Beleuchtung (Ein / Aus / Permanent), die externe Beleuchtung wird über Pin 09 RD geschalten.

Um auch ohne Trigger ein stetig aktualisiertes Livebild zu erhalten, folgende Einstellungen (ggf. temporär) vornehmen:

Freilauf einstellen unter "Job/Bildaufnahme"

Kontinuierlich einstellen unter "Trigger/Bildaktualisierung" (links, halbe Höhe)


Bildübertragung Parameter

Im Reiter Bildübertragung kann die Bildübertragung und/oder der Bildrekorder aktiviert werden.

Nächstes Thema: Archivierung Parameter

Hinweis

Ein Ausrufezeichen als Einblendung im Livebild sagt aus, dass die Bilddarstellung / Bildspeicherung im PC langsamer läuft als die Bildauswertung auf dem Vision Sensor. Es werden nicht mehr alle Bilder, die vom Vision Sensor aufgenommen werden, angezeigt. Dies kann bei Verwendung der Schlechtbildarchivierung evtl. zu Bildverlusten führen. Bei häufigem Auftreten des Ausrufezeichens, sollten auf dem PC Programme im Hintergrund geschlossen werden, um mehr PC-Leistung zur Verfügung zu stellen.

Parameter Funktion und EinstellmöglichkeitenVision Sensor Visualisation Studio

Anzeige von Bildern im Anzeigemodul Vision Sensor Visualisation Studio im Run Modus aktivieren/deaktivieren. (Deaktivierung erhöht die Geschwindigkeit der Anwendung)

Bildrekorder

Speicherung von max. 10 Bildern im internen Ringspeicher des Sensors. Einstellmöglichkeiten: Aus, Alle, Gutteile, Schlechtteile

Ram Disk

Speicherung des letzen Bildes im internen RAM-Speicher, dieses Bild kann von einem FTP- Client abgeholt werden.

Einstellmöglichkeiten: Aus, Alle, Gutteile, Schlechtteile.

Das Bild wird im RAM des Vision Sensor unter dem Namen "image.bmp" im Verzeichnis /tmp/results/ abgelegt.

Parameter für FTP- Client: Benutzer: "user", Passwort: "user"

Beispiel Windows Konsole: Start > Ausführen > cmd

Microsoft Windows XP [Version 5.1.2600]

(C) Copyright 1985-2001 Microsoft Corp.

C:\>ftp 192.168.100.100

Verbindung mit 192.168.100.100 wurde hergestellt.

220 Welcome to Vision Sensor ftp-server!

Benutzer (192.168.100.100:(none)): user

331 Please specify the password.

Kennwort: user

230 Login successful.

ftp> cd /tmp/results

250 Directory successfully changed.

ftp> get image.bmp

200 PORT command successful. Consider using PASV.

150 Opening BINARY mode data connection for image.bmp (354358 bytes).

226 File send OK.

FTP: 64d Bytes empfangen in 0,23Sekunden 1514,35KB/s

ftp>

Das Bild befindet sich nun im Laufwerk C des ausführenden PC.

Wenn eingeschaltet, können auf gleichem Wege die Ergebnisdaten über die Datei "results.csv" bezogen werden.

Abbildung: Reiter Job / Bildübertragung


Archivierung Parameter

Im Reiter Archivierung können Sie die Archivierung der Daten konfigurieren.

Nächstes Thema: Filter zur Bildverbesserung

Parameter | Funktion und Einstellmöglichkeiten
Archivtyp | Aus: keine Archivierung, FTP: Archivierung zum FTP Server, SMB: Archivierung auf ein Laufwerk über SMB Dienst (Server Message Block) Achtung! Bei Nutzung von Archivservern in anderen Subnetzen zunächst in Vision Sensor Device Manager das Gateway einstellen.
IP-Adresse | IP-Adresse des Zielservers / clients
Freigabename | Freigabename der bei der Ordnerfreigabe im PC im Dialog: "Erweiterte Freigabe" definiert wurde.
Arbeitsgruppe (Domainname) | Optional !, Arbeitsgruppe / Domainname des Zielservers / clients.
Benutzername | Benutzer Name für FTP / SMB Verbindung.
Passwort | Passwort für FTP / SMB Verbindung.
Verzeichnis (Gutteile) | Verzeichnis für Archivierung der Datensätze der Gutteile (Für C:/TESTGUT nur TESTGUTeingeben).
Verzeichnis (Schlechtteile) | Verzeichnis für Archivierung der Datensätze der Schlechtteile (Für C:/TESTSCHLECHT nur TESTSCHLECHT eingeben) .
Dateiname | Dateiname für Bilder und Protokolldatei, dieser Name wird noch automatisch durch die Bildnummer ergänzt (Z.B. TESTDATEI).
Bilddateien | Aktivierung der Archivierung der Bilder .
Ergebnisdateien | Wird die Protokolldatei aktiviert, werden alle Daten, die unter "Ausgabe / Datenausgabe" spezifiziert wurden, zusätzlich in eine .csv-Datei protokolliert. Es wird pro Auswertung (Trigger) eine Datei angelegt. Die Dateien werden fortlaufend nummeriert.
Bildinhalt | Möglichkeit zur Auswahl, ob Bilder unter Anwendung des eingestellten Software-Filters gespeichert werden sollen oder als „Roh"-Bilder, wie sie von der Kamera gekommen sind.
Speichermodus | Begrenzt: wenn die maximale Anzahl der Dateien erreicht ist, wird die Übertragung beendet. Unbegrenzt: Dateien werden geschrieben, bis das Ziellaufwerk voll ist. Zyklisch: nach Erreichen der maximalen Anzahl von Dateien wird jeweils die älteste von der neusten überschrieben.
Max. Anzahl Dateien | Maximale Anzahl von Datensätzen, die im Zielverzeichnis abgelegt werden dürfen.

Abbildung: Reiter Job / Archivierung


Filter zur Bildverbesserung

Im Reiter Filter können Sie die vom Sensor aufgenommenen Bilder vor der Auswertung filtern.

  • Es können bis zu 5 Filter aktiviert werden, die in der angegebenen Reihenfolge ausgeführt werden.
  • Alle Detektoren (Lagenachführung und Standard-Detektoren) werden auf dem vorverarbeiteten Bild arbeiten, nicht auf dem Originalbild.
  • Insbesondere mit den morphologischen Operatoren (Dilatation und Erosion) können auch in Kombination Verbesserungen des Bildes erreicht werden, z.B. durch Nacheinanderausführung von Erosion und Dilatation oder umgekehrt.

Nächstes Thema: Zeitverhalten Parameter

Beispiel:

Schwarze, punktförmige Störungen vor hellem Hintergrund lassen sich eliminieren, wenn Dilatation und Erosion aufeinander folgen.

Folgende Filter für die Bildverbesserung stehen zur Verfügung:

Filtertyp | Effekt
Gauss | Reduktion von Rauschen, Unterdrückung störender Details und Artefakte, Glättung von Kanten
Erosion | Ausweitung dunkler Bereiche, Eliminierung heller Pixel in dunklen Bereichen, Elimination von Artekfakten, Trennung von hellen Objekten. Wirkung: Jeder Grauwert wird durch den minimalen Grauwert innerhalb der Filtermaske (z.B. 3x3 Filtermaske) ersetzt.
Dilation | Ausweitung heller Bereiche, Eliminierung dunkler Pixel in hellen Bereichen, Elimination von Artekfakten, Trennung von dunklen Objekten. Wirkung: Jeder Grauwert wird durch den maximalen Grauwert innerhalb der Filtermaske (z.B. 3x3 Filtermaske) ersetzt.
Median | Glättung des Bildes, Unterdrückung von Bildrauschen
Mean | Reduktion von Rauschen
Range | Findet Kanten und Helligkeitssprünge (ab Firmware 1.5.X.X)
Spiegelung vertikal | Spiegelung vertikal
Spiegelung horizontal | Spiegelung horizontal
Invertierung | Invertierung

Die Wirkung eines aktivierten Filters ist unmittelbar im Bild erkennbar. Je größer der Filterkern gewählt wird, umso stärker ist die Filterwirkung. Die Reihenfolge der Anwendung der Filter ist mit der Reihenfolge von oben nach unten identisch.

Filter konfigurieren:

1. Wählen Sie die Filter in der gewünschten Reihenfolge über die Ausklappmenüs in der Spalte Filter.

2. Geben Sie die Größe des Filterkerns in den Ausklappmenüs in der Spalte Wert ein. Bei Einstellung „Aus“ wird der betreffende Filter deaktiviert.

Abbildung: Reiter Job / Filter


Zeitverhalten Parameter

Im Reiter Zeitverhalten bestimmen Sie das Zeitverhalten des Vision Sensor.

Nächstes Thema: Lagenachführung

Parameter | Funktion und Einstellmöglichkeiten

Max. Zykluszeit

Parameter zur Steuerung der Ausführungszeit eines Zyklus. Innerhalb eines Zyklus können mehrere Bilder ausgewertet werden (im Falle "Anzahl Bilder" > 1).

Die maximale Ausführungszeit dient zum Abbruch eines Zyklus nach einer definierten Zeit. Das Ergebnis des Zyklus ist nach Abbruch immer "nicht o.k.". Die maximale Zykluszeit sollte immer größer gewählt werden als der Zeitbedarf für eine komplette Auswertung.

Die Zykluszeit misst die Zeit vom Trigger bis zum Setzen der digitalen Schaltausgänge. Soll die Zykluszeit begrenzt werden, z.B. weil der Maschinentakt nicht überschritten werden darf, muss der Wert für die maximale Zykluszeit entsprechend begrenzt werden. Das Ergebnis aller bis zu diesem Zeitpunkt nicht fertig ausgeführten Detektoren wird auf fehlerhaft gesetzt. Bei der Wahl der maximalen Zykluszeit ist zu berücksichtigen, dass diese nicht hart eingehalten wird, sondern in Abhängigkeit des gerade ausgeführten Detektors etliche weitere Millisekunden bis zum Abbruch verstreichen können. Es wird empfohlen, diese Überschreitung der maximalen Zykluszeit anhand der tatsächlichen Ausführungszeit zu überprüfen und den eingestellten Wert für die maximale Zykluszeit entsprechend zu verkleinern.
Max. Bearbeitungszeit pro Bild | Maximale Dauer einer Auswertung innerhalb des Zyklus inkl. Bildaufnahme.
Min. Bearbeitungszeit pro Bild | Minimale Dauer einer Auswertung innerhalb des Zyklus inkl. Bildaufnahme. Die minimale Bearbeitungszeit kann zum Unterdrücken von Mehrfachtriggern verwendet werden. Im Fall von "Anzahl Bilder" = 1 (default) entspricht die Min. Bearbeitungszeit pro Bild der minimalen Zykluszeit.
Anzahl Bilder (max) | Maximale Anzahl von Bildaufnahmen, die nach einem Trigger ausgeführt werden, sofern das Abbruchkriterium nicht erfüllt ist. Abbruchkriterium ist das "Gesamt Jobergebnis" (einstellbar unter Ausgabe/Ausgangssignale).

LED-Stärke

Dieser Wert wird automatisch berechnet und nur angezeigt. Standard-Wert ist 100%. Die LED-Leistung wird automatisch reduziert, wenn bei relativ langen Belichtungszeiten und relativ kurzer minimaler Job-Zeit (kurze min. Zykluszeit und / oder sehr schnelle Bearbeitung der Detektoren) die Pause zum Abkühlen der LEDs zu klein wird. Die minimale Zykluszeit muss Faktor 10 größer sein als die Shutterzeit, damit die LEDs mit 100% Leistung betrieben werden können.

Auto

Der Schalter "Auto" stellt die "Min. Bearbeitungszeit pro Bild" so ein, dass die LED-Stärke immer 100 % ist.

Abbildung: Reiter Job / Zykluszeit


Lagenachführung

Bei Objekten bzw. Merkmalen, deren Position im Bild variiert, kann eine Lagenachführung erforderlich sein.

Für jeden Job kann maximal ein Lagedetektor definiert werden.

Funktionsweise einer Lagenachführung

Bei einer Lagenachführung handelt es sich um ein nachgeführtes Koordinatensystem, das an einem ausgewählten Merkmal verankert wird. Alle in der Folge definierten Detektoren werden relativ zu diesem Koordinatensystem ausgerichtet. Das nachgeführte Koordinatensystem wird in dunkelblau eingezeichnet

Hinweise zur Bedeutung und Einstellung der verschiedenen Rahmen im Bild s. Kap.

Such- und Merkmalsbereiche

Da die Lagenachführung einen zusätzlichen Rechenschritt darstellt und somit Zykluszeit in Anspruch nimmt, sollte sie nur dann eingesetzt werden, wenn es die Anwendung erfordert.


Lagenachführung Kontur

Dieser Lagedetektor eignet sich zur Erkennung von Konturen bestehend aus Kanten in beliebigen Winkellagen.

Lagedetektor Konturerkennung, Parameter


Lagedetektor Konturerkennung, Parameter

Dieser Lagedetektor eignet sich zur Erkennung von Konturen bestehend aus Kanten in beliebigen Winkellagen.

Nächstes Thema: Detektoren

Einstellungen im Reiter Parameter:

Parameter Funktion und Einstellmöglichkeiten

Schaltschwelle

Bereich für die geforderte Übereinstimmung der gefundenen Kontur mit der gelernten Kontur

Winkelbereich

Winkelbereich, in dem gesucht wird (großer Bereich bedeutet längere Bearbeitungszeit)

Schrittweite (Winkel)

Schrittweite in ° der Suche über den gewählten Winkelbereich

(Wenn Winkelbereich und Schrittweite auf 0 gesetzt werden, sucht der Detektor nur nach nicht gedrehten Objekten)

Genau - Schnell

Kandidaten mit Übereinstimmungsgrad unterhalb des angegebenen Werts werden bereits bei der Suche verworfen.
Großer Wert: schneller = riskanter (Kandidaten übersehen)

Kleiner Wert: langsamer = risikoärmer (alle Kandidaten)

Min. Kontrast Modell

Minimal geforderter Kontrast beim eingelernten Modell bei dem eine Kante als solche akzeptiert wird.

Min. Kontrast Bild

Minimal geforderter Kontrast im aktuellen Bild bei dem eine Kante als solche akzeptiert wird

Rücksetzen

Für diesen Lagedetektor die Werkseinstellung wieder herstellen

Kontur bearbeiten

Über den Parameter „Kontur anpassen“ können Bereiche der eingelernten Kontur ausgeblendet werden. Wie mit einem Radierer können im Suchbereich die Bereiche

entfernt werden, die für die Auswertung nicht benötigt werden. Diese markierten Bereiche können auch invertiert werden, also die Bereiche markiert werden, die für die Ausführung wichtig sind. S. auch Kap. Funktion: Muster bearbeiten

Abbildung: Lagedetektor Kontur


Detektoren

Jeder Job beinhaltet einen oder mehrere Prüfschritte (Detektoren), die Sie hier definieren können.

Nächstes Thema: Erstellen und Bearbeiten von Detektoren

Für Hinweise zur Bedeutung und Einstellung der verschiedenen Rahmen im Bild s. Kap. Such- und Merkmalsbereiche

Bei der ersten Auswahl des Verarbeitungsschrittes „Detektoren“ öffnet sich direkt der Auswahldialog für einen neuen Detektor. Hier einen Detektor auswählen. Die entsprechenden Einstellbereiche werden grafisch im Bild als Rahmen in voreingestellter Lage und Größe dargestellt. Nun die Rahmen und die Parameter entsprechend der Prüfaufgabe einstellen.

Abbildung: Detektor Auswahlliste Objektsensor


Erstellen und Bearbeiten von Detektoren

Detektortypen:
  • Detektor Mustervergleich
  • Detektor Konturerkennung
  • Detektor Kontrast
  • Detektor Helligkeit
  • Detektor Graustufe
  • Detektor Barcode
  • Detektor 2D-Code

Neuen Detektor erstellen:

1. Klicken Sie auf Button „Neu" unter der Auswahlliste im Konfigurationsfenster und wählen Sie den gewünschten Detektortyp. Ein neuer Detektoreintrag erscheint in der Auswahlliste.

2. Editieren Sie den Detektornamen durch Doppelklick auf das Feld „Name".

Detektor konfigurieren:

1. Markieren Sie einen Detektor in der Auswahlliste. Für jeden Detektor kann hier ein Name vergeben werden.

2. Legen Sie die zugehörigen Such- und Merkmalsbereiche grafisch im Bild fest.

3. Konfigurieren Sie den Detektor, indem Sie Parameter in den Reitern Parameter /Allgemein und ggf. Erweitert des Konfigurationsfensters eingeben / einstellen.

Welche Reiter angezeigt werden, hängt vom gewählten Detektortyp ab.

Im Menüpunkt „Ansicht/Einzeichnungen konfigurieren" können die Einzeichnungen im Bild (Rahmen in gelb, rot, etc.) beliebig je Detektor oder Kategorie an- oder abgeschaltet werden. Unter "Ansicht/Einzeichnungen nur aktueller Detektor" bzw. mit dem Button mit Rahmensymbol, können alle Einzeichnungen im Bild bis auf die des aktuell bearbeiteten Detektors abgeschaltet werden.

Funktionen zum Verwalten der Detektoren:

Schaltfeld Funktion

Neu

Neuen Detektor einfügen > Dialog mit o.g. Detektorauswahlliste erscheint

Kopieren

Kopieren sämtlicher Parameter von einem Detektor zu einem oder mehren anderen. Die Merkmalsbereiche (verschiedenfarbige Rahmen wie: Einlernbereich, Suchbereich etc.) werden dabei nicht mit kopiert. Die Detektortypen müssen dazu identisch sein.

Kopiervorgang:

Alle gewünschten Zieldetektoren vom gleichen Typ wie Quelldetektor anlegen. Quelldetektor in der Detektorliste auswählen.

Button „Kopieren“ drücken.

In der nun erscheinenden Liste alle gewünschten Zieldetektoren markieren (Mehrfachmarkierung mit gedrückter „Strg“- Taste und mit „Kopieren“ bestätigen.

Rücksetzen

Zurücksetzen der Parameter und des Such- und Merkmalsbereichs des ausgewählten Detektors auf die Standardwerte

Löschen

Löschen des ausgewählten Detektors

Alle Löschen

Löschen aller Detektoren in der Liste

Hinweis:

In der Statuszeile am unteren Bildschirmrand wird mit „Flash: x.x/yyyy.y kB", zuerst der durch die momentane Konfiguration benutzte Speicher (x.x), bzw. der auf dem Sensor verfügbare Speicher (yyyy.y) in kB angezeigt. Übersteigt der genutzte Speicher den verfügbaren Speicher wechselt diese Anzeige in rote Darstellung, da dann die momentanen Einstellungen nicht mehr auf dem Sensor Platz finden würden. In diesem Fall können Sie vor der Übertragung andere Jobs vom Sensor löschen.


Auswahl eines geeigneten Detektors

Nächstes Thema: Detektor Mustervergleich

Folgende Detektoren stehen zur Verfügung:

Objektsensor

Detektortyp | Beschreibung
Mustervergleich | Teileerkennung mittels Mustervergleich, X - und Y- translatorisch
Konturvergleich | Teileerkennung mittels Objektkontur, Rotation bis 360°
Kontrast | Bestimmung des Kontrastes im ausgewählten Suchfeld
Helligkeit | Prüfen der Helligkeit im gewählten Suchbereich
Graustufe | Bestimmung der Grauwerte im ausgewählten Suchfeld

Code Reader

Detektortyp | Beschreibung
Barcode | Barcodelesung 1D Codes
DataCode | Datacodelesung 2D Codes


Detektor Mustervergleich

Dieser Detektor eignet sich zur Erkennung von Mustern beliebiger Form, auch ohne deutliche Kanten oder Konturen.

Abbildung: Detektor Mustervergleich

Nächstes Thema: Detektor Konturerkennung

Mustervergleich Applikation

Einstellungen im Reiter Muster:

Parameter | Funktion
Schaltschwelle | Bereich für die geforderte Übereinstimmung des gefundenen Musters mit dem gelernten Muster in %.
Genau - Schnell | Anzahl der Suchstufen / Vergröberungsstufen. ( Mögliche Einstellungen 2-10) Großer Wert: schneller = riskanter (Kandidaten übersehen) Kleiner Wert: langsamer = risikoärmer (alle Kandidaten)
Positions- kontrolle | Prüfung, ob sich das gefundene Muster an der richtigen Position befindet. Bei Aktivierung der Positionskontrolle wird der Positiosrahmen in blau (wahlweise rechteckig oder elliptisch) angezeigt. Der Mittelpunkt des Musters muss innerhalb des blauen Rahmens liegen.
Muster | Zeigt das eingelernte Muster = Inhalt des roten Rahmens

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.

Optimierung Mustervergleich:

Ausführungsgeschwindigkeit:

  • Suchbereich für Position (gelber Rahmen) nur so groß wie nötig.

    Beachte: Suchbereich gibt den Bereich an, in dem der Schwerpunkt des Musters gesucht wird.
  • Auflösung auf QVGA statt VGA verringern (Achtung: Globaler Parameter, wirkt auf alle Detektoren!)
  • Regler: Genau - Schnell auf: Schnell

Robuste Mustererkennung

  • Suchbereich für Position (gelber Rahmen) ausreichend groß?
  • Regler: Genau - Schnell auf: Genau
  • Markantes Grauwertmuster wählen, ggf. neu einlernen
  • Wenn an falscher Position gefunden: Eindeutiges Muster verwenden, ggf. neu einlernen, ectl Schwellwert anpassen.

Wird unmittelbar nach Einlernen festgestellt, dass gefundene Position (grüne ROI) nicht mit Einlernbereich (rote ROI) übereinstimmt, sollte Regler: Genau - Schnell auf: Genau eingestellt werden.


Mustervergleich Applikation

Im Beispiel wurde ein Kontakt (ganz links) des Prüfteiles als Muster eingelernt und wird an dieser Stelle auch mit hohem Übereinstimmungsgrad (Schaltschwelle nahe 100%) erkannt.

Abbildung: Mustervergleich, Applikationsbeispiel, positives Ergebnis

Abbildung: Mustervergleich, Applikationsbeispiel, negatives Ergebnis

Wird nun der gleiche Mustervergleich an einer Stelle des Prüfteiles durchgeführt, an dem der gesuchte Kontakt fehlt, erreicht der Übereinstimmungsgrad nicht den geforderten Schwellwert und das Ergebnis wird negativ. Der Kontakt wird hier aufgrund der Grauwerte an den jeweiligen Orten im Bild gesucht. Da der innenliegende, sehr hoch reflektierende und damit helle Bereich nicht existiert, und stattdessen die Bildpixel entsprechend dunklere Werte aufweisen, ist hier der Übereinstimmungsgrad nicht so hoch wie bei einem vorhandenen Kontakt. Weil aber auch große Teile des Musters identisch mit dem eingelernten sind (der gesamte äußere, schwarze Bereich) ist der Übereinstimmungsgrad immer noch recht hoch bei ca. 70% !

Die hier gemachten Einstellungen sind nur zur Verdeutlichung der Wirkungsweise des Mustervergleichs-Detektors so gewählt, und sollten im realen Betrieb weiter optimiert werden, (Etwa durch Verkleinerung des Such- und Merkmalsbereichs >> relevantes Muster wird signifikanter, etc. )

Beim Einlernen wird das im roten Rahmen befindliche Bild als Referenz im Sensor gespeichert. Die Größe und Lage der Referenz wird durch den roten Rahmen definiert. Im Run-Modus sucht der Vision Sensor dann im aktuellen Bild nach der größten Übereinstimmung mit dem Referenzbild / Muster innerhalb des Suchbereichs. Je nach Einstellung des Schwellwerts (= Grad der Übereinstimmung) wird das Objekt als gut erkannt oder nicht.

Die Mustererkennung ist nur bis zu ca. ± 5 Winkel-Grad drehlagentolerant. Muster mit größeren Verdrehungen werden nicht erkannt. Nutzbar z.B. zur Prüfung der Lagerichtigkeit von Teilen in Zuführanlagen.

Beispiel:

Folgendes Muster wurde im Sensor eingelernt:

Abbildung: Muster, Referenz

Bei den folgenden drei Beispielbildern wird das Objekt mit 100% Übereinstimmung erkannt, da das eingelernte Muster exakt gleich ist, obwohl es sich an einem anderen Ort im Bild befindet, jedoch nur in X- bzw. Y- Richtung verschoben, und nicht verdreht ist.

Abbildung: Muster, positives Ergebnis

Bei den drei nun folgenden Beispielbildern wird das Objekt ebenfalls erkannt, jedoch mit weniger als

100% Übereinstimmung (ca. 70-80%), da es in einigen Pixeln vom eingelernten Muster abweicht. Je nach Einstellung des Schwellwerts (Grad der Übereinstimmung) werden Gut- oder Schlecht- Ergebnisse geliefert.

Abbildung: Muster, Grenzfälle

Die Mustererkennung ist nur bis zu ± 5 Winkel- Grad drehlagentolerant. Das bedeutet, die Bilder in unterster Reihe würden auch erkannt, allerdings wäre hier, trotz 100% Pixelübereinstimmung, der tatsächliche Grad der Übereinstimmung zum Musterbild kleiner 100%. Muster mit größerer Verdrehung werden nicht erkannt. Dies kann z.B. zur Erkennung der Lagerichtigkeit von Teilen in Zuführanlagen als Funktion genutzt werden.

Abbildung: Muster, Rotation


Funktion: Muster bearbeiten

Mit der Funktion Suchbereich anpassen, können innerhalb der Suchfelder / Merkmalsfelder der verschiedenen Detektoren Bereiche für die Bewertung zugelassen oder ausgeschlossen werden.

Anwendungsbeispiel:

In diesem Beispiel werden nur die Grün markierten Bereiche innerhalb der ROI des Helligkeitsdetektors bewertet.

Abbildung: Abbildung, Muster bearbeiten

Bedienung:

Parameter | Funktion
Cursor (Form) | Ändern der Form des Cursors (Quadrat oder Kreis)
Cursorgröße | Ändern der Größe des Cursors (Mögliche Einstellung 1-500, auch durch z.B. Mausrad)
Pixel hinzufügen / Pixel entfernen | Auswahl, ob der Cursor Pixel zur Bildverarbeitung hinzufügt oder ausschließt
Alles hinzufügen | Fügt alle Pixel der Bildverarbeitung hinzu
Alles entfernen | Schließt alle Pixel von der Bildverarbeitung aus
Rückgängig | Macht die letzte Aktion rückgängig
Wiederherstellen | Stellt die zuletzt rückgängig gemachte Aktion wieder her
Anzeige | Wählt den Anzeigemodus

Durch die flexible Auswahl der Cursorform- und -Größe, sowie, ob eine Aktion Pixel hinzufügt oder entfernt, können sehr einfach und schnell komplexe geometrische oder frei geformte Bereiche definiert werden, die für die Prüfung relevant sind (=grün) oder nicht berücksichtigt werden (= rot).

Bei den verschiedenen Detektortypen sind folgende Einstellungen für die Nutzung der Funktion „Muster bearbeiten“ nötig.

Detektortyp | Nötige Einstellung zur Bearbeitung des Musters
Mustervergleich | Generell möglich mit „Muster bearbeiten“
Kontur | Generell möglich mit „Kontur bearbeiten“
Kontrast | Suchbereich „Freiform“ auswählen
Helligkeit | Suchbereich „Freiform“ auswählen
Graustufe | Suchbereich „Freiform“ auswählen


Funktion: Muster bearbeiten

Mit der Funktion Suchbereich anpassen, können innerhalb der Suchfelder / Merkmalsfelder der verschiedenen Detektoren Bereiche für die Bewertung zugelassen oder ausgeschlossen werden.

Anwendungsbeispiel:

In diesem Beispiel werden nur die Grün markierten Bereiche innerhalb der ROI des Helligkeitsdetektors bewertet.

Abbildung: Abbildung, Muster bearbeiten

Bedienung:

Parameter | Funktion
Cursor (Form) | Ändern der Form des Cursors (Quadrat oder Kreis)
Cursorgröße | Ändern der Größe des Cursors (Mögliche Einstellung 1-500, auch durch z.B. Mausrad)
Pixel hinzufügen / Pixel entfernen | Auswahl, ob der Cursor Pixel zur Bildverarbeitung hinzufügt oder ausschließt
Alles hinzufügen | Fügt alle Pixel der Bildverarbeitung hinzu
Alles entfernen | Schließt alle Pixel von der Bildverarbeitung aus
Rückgängig | Macht die letzte Aktion rückgängig
Wiederherstellen | Stellt die zuletzt rückgängig gemachte Aktion wieder her
Anzeige | Wählt den Anzeigemodus

Durch die flexible Auswahl der Cursorform- und -Größe, sowie, ob eine Aktion Pixel hinzufügt oder entfernt, können sehr einfach und schnell komplexe geometrische oder frei geformte Bereiche definiert werden, die für die Prüfung relevant sind (=grün) oder nicht berücksichtigt werden (= rot).

Bei den verschiedenen Detektortypen sind folgende Einstellungen für die Nutzung der Funktion „Muster bearbeiten“ nötig.

Detektortyp | Nötige Einstellung zur Bearbeitung des Musters
Mustervergleich | Generell möglich mit „Muster bearbeiten“
Kontur | Generell möglich mit „Kontur bearbeiten“
Kontrast | Suchbereich „Freiform“ auswählen
Helligkeit | Suchbereich „Freiform“ auswählen
Graustufe | Suchbereich „Freiform“ auswählen

Maskierung von Such- und Einlernbereichen, Beispiele

Anpassung des Suchbereichs an das Objekt für Detektoren Kontrast, Helligkeit und Grauschwelle

Für die Detektoren Kontrast, Helligkeit und Grauschwelle gibt es drei Formen für den Suchbereich: Kreis, Rechteck und Freiform. Sollte mit Kreis bzw. Rechteck, das über den Kontrollpunkt an dem Pfeil auch gedreht werden kann, der Arbeitsbereich nicht gut genug an das Objekt angepasst werden können, dann den Freiform-Suchbereich verwenden. Damit lassen sich beliebige Suchbereichsgeometrien erstellen. Der Cursor zur Bearbeitung der Suchbereichs kann als Quadrat oder als Kreis in beliebig einstellbarer Größe gewählt werden.


Detektor Konturerkennung

Dieser Detektor eignet sich zur Erkennung von Mustern anhand von Kanten, auch in beliebigen Winkellagen.

Nächstes Thema: Detektor Kontrast

Einstellungen im Reiter Winkel:

Einstellungen im Reiter Skalierung:

Kontur Applikation

Funktion: Muster bearbeiten (Kontur)

Die Konturen des Objekts im Suchfeld werden beim Einlernen im Sensor gespeichert. Im Run-Modus sucht der Sensor die Position der größten Übereinstimmung mit der eingelernten Kontur im aktuellen Bild. Ist die Übereinstimmung zur abgespeicherten Kontur größer als der eingestellte Schwellwert, wird das Objekt als gut

erkannt. Die Konturerkennung ist komplett drehlagentolerant, d.h. das gesuchte Objekt darf in beliebiger Lage im Bild erscheinen (Winkeleinstellungen entsprechend wählen!).

Abbildung: Detektor Kontur, Reiter Kontur

Die rechts unten hellblau eingezeichneten Kanten (kontrastreiche Übergänge im Bild) wurden auf Grund der getätigten Parametereinstellungen identifiziert und eingezeichnet. Diese können ggf. durch Veränderung der Parameter bzw. durch die Funktion „Kontur bearbeiten“ weiter verändert werden. Diese Kontur wird nun im Bild innerhalb des Suchbereiches (gelber Rahmen) gesucht.

Einstellungen im Reiter Kontur:

Parameter | Funktion
Schaltschwelle | Bereich für die geforderte Übereinstimmung der gefundenen Kontur mit der gelernten Kontur.
Min. Kontrast Muster | Minimal geforderter Kontrast beim eingelernten Modell bei dem eine Kante als solche akzeptiert wird.
Min. Kontrast Bild | Minimal geforderter Kontrast im aktuellen Bild bei dem eine Kante als solche akzeptiert wird.
Positionskontrolle | Prüfung, ob sich das gefundene Muster an der richtigen Position befindet. Bei Aktivierung der Positionskontrolle wird der zulässige Bereich für die Position des gefundenen Merkmals in einem blauen Rahmen (wahlweise rechteckig oder elliptisch) angezeigt. Das Zentrum (grünes Kreuz) des gefundenen Merkmals muss sich dabei innerhalb des blauen Rahmens befinden.
Kontur | Zeigt die eingelernte Kontur mit Anzeige der gefundenen Kanten (Inhalt des roten Rahmen beim Einlernen)
Kontur bearbeiten | Über Kontur bearbeiten können Teile des Suchbereichs ausgeblendet werden. Wie mit einem Radierer können im Suchbereich die Bereiche entfernt werden, die für die Auswertung nicht gewünscht sind. Die markierten Bereiche können auch invertiert werden. Es werden somit die Teile markiert , die für die Ausführung wichtig sind. S. auch Kap. Funktion: Muster bearbeiten

Optimierung:

Ausführungsgeschwindigkeit:

  • Suchbereich für Position (gelber Rahmen) nur so groß wie nötig.

    Beachte: Suchbereich gibt den Bereich an, in dem der Schwerpunkt des Musters gesucht wird.
  • Suchbereich für Winkel nur so groß wie nötig
  • Suchbereich für Skalierung nur so groß wie nötig
  • Auflösung auf QVGA statt VGA verringern (Achtung: Globaler Parameter, wirkt auf alle Detektoren!)
  • Wert für „Min. Kontrast Muster“ erhöhen. In der Anzeige des Musters überprüfen, ob die relevanten Konturen noch vorhanden sind.
  • Wert für „Min. Kontrast Bild“ erhöhen.
  • Insbesondere im Fall von Lagenachführung: Alternatives Suchmuster verwenden. Beispielsweise mit höherem Kontrast, so dass „Min. Kontrast Muster“ und „Min. Kontrast Bild“ erhöht werden können.

Robuste Erkennung:

  • Suchbereich für Position (gelber Rahmen) ausreichend groß?
  • Suchbereich für Winkel ausreichend groß?
  • Suchbereich für Skalierung ausreichend groß?
  • „Min. Kontrast Muster“ geeignet gewählt? Werden im eingelernten Muster die relevanten Konturen nicht angezeigt, so ist „Min. Kontrast Muster“ zu verkleinern. Werden zu viele Konturen angezeigt, so ist „Min. Kontrast Muster“ zu erhöhen.
  • „Min. Kontrast Bild“ für aktuelles Bild geeignet gewählt? Hat das aktuelle Bild einen kleineren/größeren Kontrast als das eingelernte Muster, so ist „Min. Kontrast Bild“ kleiner/größer als „Min. Kontrast Muster“ zu wählen.
  • Sind im Bild mehrere, sich überlappende Instanzen des Musters vorhanden
  • Markante Kanten in Muster vorhanden? Gegebenenfalls Muster neu einlernen, so dass markante Kanten im eingelernten Muster liegen.
  • Ergebniswert schwankt von Bild zu Bild? Gegebenenfalls dafür sorgen, dass keine „falschen“ Konturen im Bild eingelernt werden. Dies kann durch Erhöhnung „Min. Kontrast Muster“ erreicht werden. Mit Hilfe von „Kontur bearbeiten“ können Suchbereiche ausgeblendet werden.
  • Muster an falscher Position gefunden? Falls eingelerntes Muster nicht eindeutig ist, neues Muster einlernen.


Funktion: Kontur bearbeiten

s. Kap: Funktion: Muster bearbeiten


Einstellungen im Reiter Winkel:

Detektor Konturerkennung

Einstellungen im Reiter Skalierung:

Kontur Applikation

Funktion: Muster bearbeiten

Parameter | Funktion
Winkelbereich | Winkelbereich, in dem gesucht wird
Schrittweite (Winkel) | Empfindlichkeit der Suche über den gewählten Winkelbereich in °
Genau - Schnell | Kandidaten mit Übereinstimmungsgrad unterhalb des angegebenen Werts werden bereits bei der Suche verworfen. Großer Wert: frühes Verwerfen = schneller = riskanter Kleiner Wert: spätes Verwerfen = langsamer = risikoärmer Falls die Suche fehlschlägt, kann der Wert für "Vollständige Suche" verkleinert werden.

Abbildung: Abbildung, Detektor Kontur, Reiter Winkel


Einstellungen im Reiter Skalierung:

Detektor Konturerkennung

Einstellungen im Reiter Skalierung:

Kontur Applikation

Funktion: Muster bearbeiten (Kontur)

Parameter | Funktion
Skalierung Min/Max | Erkennung auch von vergrößerten oder verkleinerten Objekten im angegebenen Skalierungsbereich
Schrittweite Skalierung | Empfindlichkeit der Suche über den gewählten Skalierungsbereich
Genau - Schnell | Anzahl der Suchstufen / Vergröberungsstufen. 0 = automatische Wahl Großer Wert: schneller = riskanter (Kandidaten übersehen) Kleiner Wert: langsamer = risikoärmer (alle Kandidaten)

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.

Abbildung: Abbildung, Detektor Kontur, Reiter Skalierung


Kontur Applikation

Die sichtbaren Kanten eines im Prüfteil eingebauten Kontaktes werden als Kontur eingelernt und so das Vorhandensein des Kontaktes kontrolliert.

Abbildung: Kontur, Applikationsbeispiel, positives Ergebnis

Die gefundenen Konturlinien werden rechts unten in hell blau eingezeichnet. Der Kontakt wird so zuverlässig gefunden

Abbildung: Kontur, Applikationsbeispiel, negatives Ergebnis

Wird nun dieselbe Konturprüfung an einer Stelle gemacht an der das Kontaktteil fehlt, werden dort auch die entsprechenden Kanten nicht gefunden und die Prüfung liefert ein negatives Ergebnis.


Detektor Kontrast

Nächstes Thema: Detektor Graustufe

Kontrast Applikation

Dieser Detektor bestimmt den Kontrast im ausgewählten Suchfeld. Hierzu werden alle Bildpunkte innerhalb des Suchbereichs mit ihren Grauwerten bewertet und der Kontrast berechnet. Liegt der Kontrastwert innerhalb der unter „Schaltschwelle“ eingestellten Grenzwerte wird das Ergebnis positiv. Die Lage der hellen bzw. dunklen Pixel ist hier irrelevant. Es kommt einzig auf die Spreizung von hellen und dunklen Pixeln und deren Mengenverhältnis an (Höchster Kontrast bei 50% Grauwert 0 = schwarz, und 50% Grauwert 255 = weiß).

Abbildung: Detektor Kontrast

Einstellungen im Reiter Kontrast

Parameter | Funktion
Schaltschwelle | Vorgabe des Kontrastbereichs, der akzeptiert wird.
Suchbereich (Form ) | Die Form des Suchbereiches kann als Rechteck oder als Kreis gewählt werden.

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


Kontrast Applikation

Detektor Kontrast

Im Beispiel wird anhand eines Kontrastdetektors die Anwesenheit eines Kontaktes geprüft.

Abbildung: Kontrast, Applikationsbeispiel, positives Ergebnis

Der hochreflektrierende, d.h. helle metallische Kontakt, inmitten des ihn umgebenden schwarzen Kunststoffgehäuses, wird mit einem Kontrastdetektor auf Anwesenheit geprüft. Da in diesem Bereich der Kontrast sehr hoch ist, liefert der Detektor einen hohen Wert und somit im Zusammenspiel mit einer Lagenachführung ein zuverlässiges Ergebnis.

Abbildung: Kontrast, Applikationsbeispiel, negatives Ergebnis

Wird der selbe Detektor an einer Stelle eingesetzt, an der der Kontakt fehlt, liefert der Detektor ein negatives Ergebnis, da hier der Kontrast sehr niedrig ist zwischen der schwarzen Umgebung und dem nun sichtbaren, ebenfalls schwarzen Hintergrund des Kontaktes.

Funktion Detektor Kontrast

Die dunklen und hellen Pixel werden nach Anzahl und Hell- bzw. Dunkelintensität bewertet.

Die Lage der hellen bzw. dunklen Pixel im Suchbereich ist irrelevant.

Abbildung:

Abbildung: Kontrast Beispiele

Abbildung: Kontrast Erläuterung


Detektor Graustufe

Nächstes Thema: Detektor Helligkeit

Graustufe Applikation

Bei diesem Detektor wird im ersten Schritt mit den beiden Limitschiebern des Parameters „Grauschwelle“ der Wertebereich der Grauwerte festgelegt, die im Suchbereich auftreten dürfen.
Im zweiten Schritt wird unter „Schaltschwelle“ der Flächenanteil (in %) des Suchbereiches definiert, der die in Schritt 1 definierten Grauwerten aufweisen sein muss, um ein positives Ergebnis zu liefern.
Durch die jeweilige Invertierung können alle denkbaren Kombinationen eingestellt werden, auch solche bei denen z.B. nur Grauwerte am oberen und unteren Rand des Wertebereichs zulässig sind. Die Lage der hellen bzw. dunklen Pixel ist hier irrelevant.
Unter „Einzeichnungen“ können als Auswahlhilfe die Pixel, die einen Grauwert innerhalb (Gültige Pixel) oder außerhalb (Ungültige Pixel) der Grauwertbereichsfestlegung unter „Grauschwelle“ aufweisen, farbig markiert werden. So können sehr leicht z.B. Störpixel / Bereiche, die nicht vom Grauwertbereich abgedeckt sind erfasst werden.

Einstellungen im Reiter Grauschwelle:

Parameter | Funktion
Grauschwelle | Wertebereich in dem die Grauwerte akzeptiert werden
Schaltschwelle | Prozentualer Anteil der Fläche, die die unter „Grauschwelle“ definierten Grauwerte aufweisen muss
Suchbereich (Form) | Die Form des Suchbereiches kann als Rechteckoder alsKreis gewählt werden.
Einzeichnung | Auswahl der Pixel, die einen Grauwert innerhalb (Gültige Pixel) oder außerhalb (Ungültige Pixel) der Grauwertbereichsfestlegung unter „Grauschwelle“ aufweisen. Diese werden dann aus Auswahlhilfe farbig markiert. So können sehr leicht z.B. Störpixel / Bereiche, die nicht vom Grauwertbereich abgedeckt sind erfasst werden.

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


Graustufe Applikation

Detektor Graustufe

Abbildung: Graustufe, Applikationsbeispiel, positives Ergebnis

Kontakt im Suchbereich vorhanden. Hohe Reflektion des Metallteiles bringt Grauwerte im Bereich > 192, d.h. innerhalb der geforderten Schwellwerte = positives Ergebnis

Abbildung: Grauschwelle, Applikationsbeispiel, negatives Ergebnis

Kontakt (hohe Reflektion des Metallteiles) im Suchfeld nicht vorhanden. D.h. Mittelwert der Grauwerte im Suchbereich nicht innerhalb der Schwellwerte (nicht innerhalb Grauwert 192-255, eher im Bereich < 50). Ergebnis: negativ = Kontakt nicht gefunden.

Hinweis zur Bestimmung der Grauwerte:

In der Statuszeile am unteren Bildrand wird im zweitletzten Feld rechts beim Platzieren des Cursors irgendwo im Bildbereich die entsprechende X- und Y- Koordinate und der Grauwert („I“ = Intensity) angezeigt.

Funktion Detektor Grauschwelle

Mit den beiden Limits des Schiebereglers Grauschwelle wird der zulässige Grauwertbereich definiert.

Alle Pixel, die innerhalb dieses Grauwertbereichs und innerhalb des definierten Arbeitsbereiches (gelber Rahmen) liegen werden aufsummiert. Das Verhältnis der Anzahl aller Pixel im Arbeitsbereich (gelber Rahmen) und der Anzahl der Pixel im akzeptierten Grauwertbereich repräsentiert das Ergebnis dieses Detektors.

Liegt dieses Ergebnis innerhalb der Limits, die am Schieberegler Schaltschwelle eingestellt sind, ist das Ergebnis positiv.

Die Position der Grauwertpixel im Bild spielt dabei keine Rolle.

Beispiel: (bei Einstellung des Schiebereglers Grauschwelle auf sehr dunkle Werte):

Die beiden Bilder liefern beim Detektor Grauschwelle genau das gleiche

Ergebnis, da jeweils 9 von 25 Pixeln als dunkel erkannt werden.

Abbildung: Grauschwelle, Beispiel 1

Angenommen der Schwellwert in diesem Beispiel wäre auf 10 eingestellt,

würden folgende Bilder zu einem positiven Ergebnis führen.

Abbildung: Grauschwelle Beispiel 2


Detektor Helligkeit

Nächstes Thema: Detektor Barcode

Helligkeit Applikation

Dieser Detektor bestimmt den Mittelwert der Grauwerte im Suchbereich. Mit den beiden Schwellwert-Schiebern des Parameters „Schaltschwelle“ wird der zulässige Bereich für diesen Helligkeits- Mittelwert eingestellt. Sobald sich der berechnete Mittelwert innerhalb dieser beiden Schwellwerte bewegt ist das Ergebnis positiv. Das Ergebnis wird auf % normiert. Die Lage der hellen bzw. dunklen Pixel im Suchbereich ist irrelevant. Detektor kann dann wirkungsvoll eingesetzt werden, wenn die Position des gesuchten Objektes im Bild von Prüfung zu Prüfung absolut unverändert ist, oder, falls Abweichungen in der Position auftreten können, muss die Lagenachführung verwendet werden.

Einstellungen im Reiter Helligkeit

Parameter | Funktion
Schaltschwelle | Vorgabe des Helligkeitsbereichs, der akzeptiert wird
Suchbereich (Form) | Die Form des Suchbereiches kann als Rechteck oder als Kreis gewählt werden.

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


Helligkeit Applikation

Detektor Helligkeit

Der Detektor Helligkeit berechnet den Mittelwert der Grauwerte aller Pixel im Suchbereich.

Abbildung: Helligkeit, Applikationsbeispiel, positives Ergebnis

Kontakt ist an gesuchter Stelle vorhanden und der Mittelwert der Grauwerte im Suchbereich liefert deshalb einen sehr hohen Wert (nahe 100%). Damit ist der aktuelle Wert innerhalb der geforderten Schaltschwellen und das Ergebnis ist positiv = Kontakt vorhanden.

Abbildung: Helligkeit, Applikationsbeispiel, negatives Ergebnis

Kontakt ist an gesuchter Stelle nicht vorhanden und der Mittelwert der Grauwerte im Suchbereich liefert deshalb einen sehr niedrigen Wert (nahe 0%). Damit ist der aktuelle Wert nicht innerhalb der geforderten Schaltschwellen und das Ergebnis ist negativ = Kontakt nicht vorhanden.

Beispiele: Helligkeitswert als Mittelwerte der Grauwerte

Abbildung: Helligkeit, Beispiele


Detektor Barcode

Nächstes Thema: Detektor 2D-Code

Barcode-Detektor, Reiter Referenzstring

Abbildung: Detektor Barcode, Reiter Code

Barcode-Detektor, Reiter Code

Parameter

Funktion

Barcode Typ

Wählen Sie hier den Typ des Barcodes aus, den Sie mit dem Code Leser lesen wollen.

Max. Stringlänge

Max. Länge eines Barcodes. Wenn der Inhalt des Codes die maximale Länge überschreitet, wird der Überhang abgeschnitten.

Beim Lesen von mehreren Codes gleichzeitig, muss dieser Wert auf die maximale Länge des längsten Codes eingestellt werden.

Prüfziffer

Dieser Parameter aktiviert die Erkennung eines Prüfzeichens falls dies im Code vorhanden. Barcodes mit Prüfzeichen sind z.B. Code 39, Codabar, 25 Industrial oder 25 Interleaved. Wird dieser Parameter nicht ausgewählt, dann wird das Prüfzeichen als normales Datenzeichen interpretiert und in der Zeichefolge mit ausgegeben.

Min. Anzahl Codes

Minimale Anzahl der Codes, die innerhalb des Suchbereichs gelesen werden sollen.

Max. Anzahl Codes

Maximale Anzahl der Codes, die innerhalb des Suchbereichs gelesen werden sollen. Wird dieser Wert höher gewählt, als tatsächlich notwendig, so kann sich die Ausführungszeit des Detektors geringfügig erhöhen.

Textausgabe bei Fehllesung

Spezifiziert den Text, der im Falle einer Fehllesung über die Schnittstellen ausgegeben wird. Der Text erscheint nicht in der Ergebnisanzeige.

Polarität

Auswahlmöglichkeit für Druckfarbe des Codes „dunkel auf hell" oder „hell auf dunkel".

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.

Optimierung:

Ausführungsgeschwindigkeit:

  • Suchbereich für Position (gelber Rahmen) nur so groß wie nötig.

Robuste Erkennung:

  • Suchbereich (gelber Rahmen) ausreichend groß?
  • Markanter Kontrast vorhanden?
  • Wurde die Auswahl "Prüfzeichen" aktiviert, obwohl kein Prüfzeichen im Code ist?


Barcode-Detektor, Reiter Referenzstring

Detektor Barcode

Barcode-Detektor, Reiter Qualität

Abbildung: Abbildung, Detektor Barcode, Reiter Referenzstring

Einstellungen im Reiter Referenzstring

Parameter | Funktion
Stringvergleich | Aktiviert die Überprüfung des Inhaltes der gelesenen Informationen. Die Überprüfung des Inhaltes der gelesenen Informationen erfolgt auf Basis von regulären Ausdrücken.
Referenzstring | Dieser Text bzw. reguläre Ausdruck wird zur Verifikation herangezogen. Hier können konkrete Zeichen stehen, die direkt verglichen werden, oder reguläre Ausdrücke, um den Aufbau des gelesenen Ergebnisses zu überprüfen.
Ausdruck hinzufügen | Öffnet eine Liste mit Vorgaben für reguläre Ausdrücke.
Referenzstring einlernen | Liest den Code, der sich gerade unter dem Code Leser befindet und übernimmt den gelesenen Inhalt als Vergleichstext, der Text kann nachträglich noch editiert werden.

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.

Beispiele für Referenzzeichenketten definiert durch reguläre Ausdrücke:

Referenzzeichenkette | Treffer | Beispiel für Treffer
123 | Zeichenkette, die 123 enthält | 01234
\A123 | Zeichenkette, die mit 123 beginnt | 1234
123\Z | Zeichenkette, die mit 123 endet | 0123
\A123\Z | Zeichenkette, die genau 123 entspricht | 123
[123] | Zeichenkette, die eines der Zeichen enthält | 33
[123]{2} | Zeichenkette, die eine Kette von 2 der Zeichen enthält | 23
[12]|[34] | Zeichenkette, die ein Zeichen aus einer der beiden Gruppen enthält | 4

Die wichtigsten Elemente regulärer Ausdrücke:

^ Steht für den Anfang der Zeichenkette

$ Steht für das Ende der Zeichenkette, ggf. inklusive einem Newline als letztes Zeichen

. Steht für jedes Zeichen außer Newline

[...] Steht für jedes in den eckigen Klammern aufgeführte Literal. Ist das erste Zeichen ein '^', so ist der Ausdruck negiert. Mit dem Zeichen '-' kann man Wertebereiche angeben wie in '[A-Z0-9]'. Andere Zeichen verlieren ihre spezielle Bedeutung innerhalb eckiger Klammern, außer '\'.

* Erlaubt 0 oder mehr Wiederholungen des vorhergehenden Literals / Gruppe

+ Erlaubt 1 oder mehr Wiederholungen

? Erlaubt 0 oder 1 Wiederholung

{n,m} Erlaubt n bis m Wiederholungen

{n} Erlaubt genau n Wiederholungen

| Trennt alternative Suchausdrücke


Barcode-Detektor, Reiter Qualität

Barcode-Detektor, Reiter Referenzstring

Barcode-Detektor, Reiter Codedetails

Abbildung: Abbildung, Detektor Barcode, Reiter Qualität

Einstellungen im Reiter Allgemein

Parameter Funktion

Qualitätsparameter

Bewertung der Druckqualität gemäß dem internationalen Standard ISO/IEC 15416.

Für eine normgerechte Qualitätsbewertung sind bestimmte Mindestanforderungen an die Abbildung des Codes in der Kamera (Auflösung), die Anordnung der Kamera und die Art und Anordnung der Beleuchtung vorgeschrieben. Diese sind in den jeweiligen Normen abgedruckt.

Für die einfachen 1D Barcodes wird die Bewertung der Druckqualität in einem Tupel mit acht Elementen zusammengefasst:

Q1 Overall

Q2 Decode

Q3 Symbol Contrast

Q4 Minimal Reflectance

Q5 Minimal Edge contrast

Q6 Modulation

Q7 Defects

Q8 Decodability

Während die Gesamtqualität der endgültige Symbolgrad ist, weisen die restlichen Grade auf mögliche qualitätsverringernde Ursachen hin. Eine Liste mit häufig vorkommenden Defekten und deren Effekt auf die einzelnen Qualitätsgrade kann man im Standard ISO/IEC 15416 finden.

Die einzelnen Qualitätsgrade sind wie folgt definiert: „overall" ist der Minimalwert aller restlichen Gradwerte. „decode" ist auf 4 gesetzt, wenn das untersuchte Barcodesymbol gelesen werden konnte, und auf 0 anderenfalls. Der „symbol contrast" ist die Differenz zwischen maximalem und minimalem Reflexionswert des Grauwertprofils; stärkerer Kontrast ergibt einen besseren Grad. Der „minimal reflectance" ist auf 4 gesetzt, wenn der minimale Reflexionswert des Grauwertprofils kleiner oder gleich 0.5 der maximale Reflexionswert ist, und auf 0 anderenfalls. Der Kantenkontrast ist der Kontrast zwischen zwei benachbarten Symbolelementen (beide Strich-zu-Loch oder Loch-zu-Strich). Der „minimal edge contrast" bewertet den minimalen Kantenkontrast im Grauwertprofil. Die „modulation" bewertet die Amplitude zwischen den Symbolelementen. Höhere Amplituden bedingen, dass Striche und Löcher zuverlässiger voneinander unterschieden werden können und dieser Grad höher bewertet wird. Die „defects" sind Unregelmäßigkeiten im Grauwertprofil innerhalb einzelner Symbolelemente oder der Quietzonen, deren Vorhandensein mit niedrigerem Grad gekennzeichnet wird. Die „decodability" bezeichnet Abweichungen der Symbolelementbreiten von ihrem Nominalwert, der im entsprechenden Symbologiestandard festgelegt ist. Die „additional requirements" sind weitere symbologie-spezifische Anforderungen wie z.B.: die quiet zone Breiten, das wide/narrow Verhältnis, inter character gaps, guarding patterns oder andere.

Die Druckqualitätsbewertung eines „Composit" Barcodes umfasst die folgenden 24 Grade:

OVERALL:

Q1 Overall

Q2 Overall Linear

Q3 Overall Composite

LINEAR:

Q4 Decode

Q5 Symbol Contrast

Q6 Minimal Reflectance

Q7 Minimal Edge contrast

Q8 Modulation

Q9 Defects

Q10 Decodability

Q11 Additional Requirements

COMPOSITE:

Q12 Decode

Q13 Rap Overall

COMPOSITE RAP:

Q14 Contrast

Q15 Minimal Reflectance

Q16 Minimal Edge Contrast

Q17 Modulation

Q18 Defects

Q19 Decodability

Q20 Codeword Yield

Q21 Unused Error Correction

Q22 Modulation

Q23 Decodability

Q24 Defects

Der Gesamtgrad „overall" von der OVERALL Gruppe ist der endgültige Symbolgrad. Er ist der kleinere der anderen zwei Grade in der Gruppe: „overall linear" und „overall composite", welche der Gesamtgrade des linearen (1D) bzw. compositen (2D) Anteils des compositen Symbols darstellen. Die anderen zwei Gruppen, LINEAR und COMPOSITE, bestehen aus einzelnen Qualitätsgraden beider Symbolanteile und weisen auf mögliche qualitätsverringernde Ursachen hin. Die Grade aus der Gruppe LINEAR entsprechen denjenigen aus dem oben beschriebenen einfachen 1D Barcode Fall. Die Grade aus der Gruppe COMPOSITE entsprechen den PDF 417 Qualitätsgraden, wobei rap overall nach dem so genannten RAP Start-Stop Muster benannt ist, das für composite Symbole spezifisch ist. Zusätzlich stellt die Untergruppe COMPOSITE RAP die einzelnen Grauwertprofilgrade des RAP Musters dar. Diese Grade stimmen mit den einfachen 1D Barcode Qualitätsgraden überein.

Typ Qualitätsparam.

Es gibt zwei Darstellungsformate für Qualitätsparameter. Beide Formate entsprechen den Normen. Die Parameter können mit Werten von A-F oder von 0-4 angegeben werden A, bzw. 4 ist die jeweils beste Bewertung. Die hier gemachte Einstellung wirkt sowohl auf die Anzeige der Qualitätsparameter am Bildschirm, als auch auf die Ausgabe der Qualitätsparameter über die Schnittstellen.

Die Zuordnung ergibt sich wie folgt:

A B C D F

4 3 2 1 0

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


Barcode-Detektor, Reiter Codedetails

Barcode-Detektor, Reiter Qualität

Abbildung: Abbildung, Detektor Barcode, Reiter Codedetails

Einstellungen im Reiter Codedetails

Parameter | Funktion
Minimale Strichbreite | Die minimale Größe eines Elements, d.h. die minimale Dicke aller Striche und Zwischenräume. Für sehr schmale Barcodes sollte der Wert auf 1.5 reduziert werden. Für sehr große Barcodes kann der Wert entsprechend vergrößert werden, was kürzere Laufzeiten mit sich bringt.
Maximale Strichbreite | Die maximale Größe eines Elements, d.h. die maximale Dicke aller Striche und Zwischenräume. Dieser Wert sollte groß genug sein, damit für das komplette Symbol die Kandidatenregion gefunden wird. Anderseits darf er nicht zu groß gewählt werden, dass zwei benachbarte Barcodes zu einem einzelnen Kandidaten verschmelzen.
Minimale Strichhöhe | Die minimale Höhe des Barcodes. Bei sehr flachen Barcodes mit einer Höhe von weniger als 16 Pixeln ist es sinnvoll die Höhe manuell einzustellen, damit der Barcode gefunden und gelesen werden kann. Die minimale Höhe beträgt 8 Pixel. Bei sehr hohen Barcodes, z.B. mit 70 Pixeln und mehr, kann das manuelle Setzen auf die entsprechende Höhe zu einer Beschleunigung beim Lesen führen.
Orientierung | Erwarteter Barcode Orientierungswinkel. Falls die Barcodes nur mit einer bestimmten Orientierung in den bearbeiteten Bildern erscheinen, so kann man den Wertebereich entsprechend reduzieren. Dadurch werden falsche Kandidaten früher erkannt. Die Ausführungszeit des Operators wird bei Einschränkung des Orientierungswinkels verkürzt. Diese Strategie gilt vor allem dann, wenn die bearbeiteten Bilder viel Hintegrundtextur mit falsch orientierten, barcodeähnliche Strukturen.
Orientierungs- toleranz | Toleranz der Orientierung. Siehe 'Orientierung' für weitere Erklärungen.
Kanten- schwellwert | Innerhalb einer Scanlinie werden Kanten mit Hilfe eines relativen Schwellwertes gefunden. Liegen in dem Barcode Störungen vor oder ist das Rauschen groß, so sollte der 'Kantenschwellwert' auf größere Werte gesetzt werden.
Max. Abweichung (Orientierung) | Ein potentieller Barcode besteht aus Strichen und damit auch Kanten mit einer einheitlichen Orientierung. Die Größe „Maximale Orientierungsabweichung“ gibt an, wie stark der Unterschied in der Orientierung benachbarter Kanten sein darf. Die Maximale Orientierungsabweichung ist ein Differenzwinkel in Gradmaß. Ist ein Barcode ausgefranst, d.h. die Strichkanten sind gestört, so ist die Maximale Orientierungsabweichung groß zu wählen. Mit kleinen Werten dagegen kann die Anzahl falscher Barcode Kandidaten reduziert werden.

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


Optimierung:

Ausführungsgeschwindigkeit:
  • Suchbereich für Position (gelber Rahmen) nur so groß wie nötig

Robustheit:

  • Suchbereich (gelber Rahmen) ausreichend groß?
  • Markanter Kontrast vorhanden?
  • Wurde die Auswahl "Prüfzeichen" aktiviert obwohl kein Prüfzeichen im Code ist?
  • Code ausreichend groß im Sichtbereich ?
  • Ist die Strichbreite ausreichend groß ?


Detektor 2D-Code

2D-Code-Detektor, Reiter Code

2D-Code-Detektor, Reiter Referenzstring

Abbildung: Detektor 2D Code, Reiter Code

Parameter Funktion

Codetyp

Wählen Sie hier den Typ des 2D Codes aus, der gelesen werden soll.

Max Stringlänge

Max. Länge eines Codes. Wenn der Inhalt des Codes die maximale Länge überschreitet, wird der Überhang abgeschnitten.

Beim Lesen von mehreren Codes gleichzeitig, muss dieser Wert auf die maximale Länge des längsten Codes eingestellt werden.

Min. Anzahl Codes

Minimale Anzahl der Codes, die innerhalb des Suchbereichs gelesen werden sollen.

Max. Anzahl Codes

Maximale Anzahl der Codes, die innerhalb des Suchbereichs gelesen werden sollen. Wird dieser Wert höher gewählt, als tatsächlich notwendig, so kann sich die Ausführungszeit des Detektors geringfügig erhöhen.

Rücksetzen

Parameter rücksetzen dient zum Zurücksetzen der eingelernten Parameter auf den Anfangszustand vor dem Einlernen. Es gibt die Auswahlmöglichkeiten „Standard“, „Erweitert“ und „Maximum". „Standard“ setzt die Grenzen des Suchbereiches so, dass beim Einlernen die Mehrzahl der möglichen Codes erkannt wird. Sollte Ihr Code dennoch nicht erkannt werden, dann wählen Sie die Einstellung „Erweitert“. Kann der Code immer noch nicht gelesen werden, so setzten Sie die Einstellung auf „Maximum". Die Einstellungen „Erweitert" und „Maximum" können die Ausführungszeit verlangsamen. Der Unterschied zu einem kompletten Zurücksetzten des Sensors ist, dass nur die Parameter für den Datamatrix Code zurückgesetzt werden. Die grundsätzlichen Parameter des Sensors wie z.B. für Beleuchtung, Ein- Ausgänge, serielle Schnittstelle usw. bleiben erhalten. Nach dem Zurücksetzen der Parameter kann wieder mit „Einlernen“ ein neuer Einlernvorgang gestartet werden.

Erstes Einlernen /

Zusätzliches Einlernen

Einlernen: der Suchbereich des Sensors wird nach einem Datamatrix Code durchsucht. Wurde ein gültiger Code gefunden, dann werden die Parameter für diesen Code gespeichert. Ist der Einlernvorgang erfolgreich, wird der gefundene Code mit einem grünen Rahmen markiert. Im „Run“ - Modus wird dann nur genau nach diesem eingelernten Code gesucht.

Nach erfolgtem Einlernen erscheint an gleicher Stelle der Button „Zusätzliches Einlernen“. Dieser ermöglicht die Erweiterung der eingelernten Parameter um entweder mehrere verschiedene Codes in einer Konfiguration lesen zu können oder eventuell vorhandene Streubereiche in der Druckqualität eines einzigen Codes zu erfassen. Mit "Zusätzliches Einlernen" wird der bereits eingelernte Parametersatz erweitert.

Textausgabe bei Fehllesung

Spezifiziert den Text, der im Falle einer Fehllesung über die Schnittstellen ausgegeben wird.

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.

Optimierung:

Ausführungsgeschwindigkeit:

  • Suchbereich für Position (gelber Rahmen) nur so groß wie nötig

Robuste Erkennung:

  • Suchbereich (gelber Rahmen) ausreichend groß?
  • Markanter Kontrast vorhanden?


2D-Code-Detektor, Reiter Referenzstring

Detektor 2D-Code

2D-Code-Detektor, Reiter Qualitätsparameter

Abbildung: Detektor 2D Code, Reiter Referenzstring

Einstellungen im Reiter Referenzstring

Parameter | Funktion
Stringvergleich | Aktiviert die Überprüfung des Inhaltes der gelesenen Informationen. Die Überprüfung des Inhaltes der gelesenen Informationen erfolgt auf Basis von regulären Ausdrücken.
Referenzstring | Dieser Text bzw. reguläre Ausdruck wird zur Verifikation herangezogen. Hier können konkrete Zeichen stehen, die direkt verglichen werden, oder reguläre Ausdrücke, um den Aufbau des gelesenen Ergebnisses zu überprüfen.
Ausdruck hinzufügen | Öffnet eine Liste mit Vorgaben für reguläre Ausdrücke.
Referenzstring einlernen | Liest den Code, der sich gerade unter dem Code Leser befindet und übernimmt den gelesenen Inhalt als Vergleichstext, der Text kann nachträglich noch editiert werden.

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.

Beispiele für Referenzzeichenketten definiert durch reguläre Ausdrücke:

Referenzzeichenkette | Treffer | Beispiel für Treffer
123 | Zeichenkette, die 123 enthält | 01234
\A123 | Zeichenkette, die mit 123 beginnt | 1234
123\Z | Zeichenkette, die mit 123 endet | 0123
\A123\Z | Zeichenkette, die genau 123 entspricht | 123
[123] | Zeichenkette, die eines der Zeichen enthält | 33
[123]{2} | Zeichenkette, die eine Kette von 2 der Zeichen enthält | 23
[12]|[34] | Zeichenkette, die ein Zeichen aus einer der beiden Gruppen enthält | 4

Die wichtigsten Elemente regulärer Ausdrücke:

^ | Steht für den Anfang der Zeichenkette
$ | Steht für das Ende der Zeichenkette, ggf. inklusive einem Newline als letztes Zeichen
. | Steht für jedes Zeichen außer Newline
[...] | Steht für jedes in den eckigen Klammern aufgeführte Literal. Ist das erste Zeichen ein '^', so ist der Ausdruck negiert. Mit dem Zeichen '-' kann man Wertebereiche angeben wie in '[A-Z0-9]'. Andere Zeichen verlieren ihre spezielle Bedeutung innerhalb eckiger Klammern, außer '\'.
* | Erlaubt 0 oder mehr Wiederholungen des vorhergehenden Literals / Gruppe
+ | Erlaubt 1 oder mehr Wiederholungen
? | Erlaubt 0 oder 1 Wiederholung
{n,m} | Erlaubt n bis m Wiederholungen
{n} | Erlaubt genau n Wiederholungen
| | Trennt alternative Suchausdrücke


2D-Code-Detektor, Reiter Qualitätsparameter

2D-Code-Detektor, Reiter Referenzstring

2D-Code-Detektor, Reiter Abbildung

Abbildung: Abbildung, Detektor 2D Code, Reiter Qualität

Einstellungen im Reiter Qualität

Parameter

Funktion

Qualitätsparameter

Qualitätsparameter werden als zusätzliche Infomationen zur Bewertung der Qualität der Codes zur Verfügung gestellt. Es gibt Qualitätsparameter nach nach AIM DPM-1-2006 und ISO/IEC 15415 Standard. Die Qualitätsparameter setzen sich aus insgesamt 8 Einzelbewertungen zusammen:

Q1 Overall quality

Q2 Contrast

Q3 Modulation

Q4 Fixed pattern damage

Q5 Decode

Q6 Axial nonuniformity

Q7 Grid nonuniformity

Q8 Unused error correction

Q9 Mean light

Overall quality: Das Minimum aller folgenden Einzelbewertungen.

Contrast: Ist der Bereich zwischen minimaler und maximaler Pixelintensität.

Modulation: Gibt einen Wert für das Verhältnis von Schwarzanteil zu Weißanteil im Code wieder. Sowohl zu viel, als auch zu wenig Schwarzanteil führen zu einer Reduzierung des Wertes. Ein ausgewogenes Verhältnis von Schwarz- und Weißanteil vereinfacht die Zuordnung der einzelnen Module.

Fixed pattern damage: Gibt Auskunft über den Zustand des „Finder Patterns” und der Ruhenzonen des Codes.

Decode quality: hat immer den Wert 4, wenn der Code erfolgreich gelesen wurde. Codes, die nicht gelesen werden können, können auch keiner Qualitätsbewertung unterzogen werden. Weil Datamatrix Codes eine Fehlerkorrektur beinhalten, können Fehler in einzelnen Modulen korrigiert werden. Die Summe der korrigierten Fehler wird im Wert „unused error correction” abgebildet. Es ist durchaus möglich, dass Codes mit einer Unused Error Bewertung von 0 trotzdem gelesen werden können.

Axial nonuniformity: Gibt Auskunft über eine eventuelle horizontale oder vertikale Verzerrung des Codes.

Grid nonuniformity: Gibt Auskunft über generelle Verzerrungen des Codes.

Qualitätsparameter nach AIM DPM-1-2006 sind eine Erweiterung zum ISO/IEC 15415 Standard, welche bestimmte Anforderungen an die Grauwert-Eigenschaften des Bildes des Datamatrix Codes definiert und somit die Reproduzierbarkeit der Qualitätsbewertung zwischen verschiedenen Herstellern verbessert.

Die ungenutzte Fehlerkorrekturkapazität des behandelten Symbols wird im Grad unused error correction berechnet.

Qualitätsparameter nach AIM haben einen Wert mehr, als Qualitätsparameter nach ISO/IEC 15415. Dieser Wert wird mit „Mean Light“ bezeichnet. „Mean light“ ist kein Qualitätswert für den Code, er gibt Aussage über die Qualität des Bildes, indem der durchschnittliche Grauwert der hellen Datacode Module berechnet wird. „Mean light“ kann Werte von 0.0 bis 1.0 haben was 0% bis 100% des maximalen Grauwertes entspricht. Ein Bild hat dann die geforderten Grauwerteigenschaften, wenn der Wert „mean light“ zwischen 70% und 86% liegt (also 0.70 bis 0.86).

Für eine normgerechte Qualitätsbewertung sind bestimmte Mindestanforderungen an die Abbildung des Codes in der Kamera (Auflösung), die Anordnung der Kamera und die Art und Anordnung der Beleuchtung vorgeschrieben. Diese sind in den jeweiligen Normen abgedruckt.

Typ Qualitätsparameter

Es gibt zwei Darstellungsformate für Qualitätsparameter. Beide Formate entsprechen den Normen. Die Parameter können mit Werten von A-F oder von 0-4 angegeben werden A, bzw. 4 ist die jeweils beste Bewertung. Die hier gemachte Einstellung wirkt sowohl auf die Anzeige der Qualitätsparameter am Bildschirm, als auch auf die Ausgabe der Qualitätsparameter über die Schnittstellen.

Die Zuordnung ergibt sich wie folgt:

A B C D F

4 3 2 1 0

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


2D-Code-Detektor, Reiter Abbildung

2D-Code-Detektor, Reiter Qualitätsparameter

2D-Code-Detektor, Reiter Symbole

Abbildung: Detektor 2D Code, Reiter Abbildung

Einstellungen im Reiter Abbildung

Parameter | Funktion
Min. Kontrast | Minimaler Kontrast in Graustufen zwischen hellen und dunklen Elementen des Codes, Wertebereich (1...100).
Polarität | Einstellmöglichkeit, ob heller Code auf dunklem Untergrund oder dunkler Code auf hellem Untergrund gelesen werden soll.
Neigung | Maximale Abweichung des Winkels im L- förmigen Finderpattern vom (idealerweise) rechten Winkel; die Angabe erfolgt im Bogenmaß und korrespondiert mit perspektivischen Verzerrungen, die beim Druck des Symbols oder bei der Bildaufnahme auftreten können.
Gespiegelt | Einstellmöglichkeit, ob der Code gespiegelt aufgebracht wurde, oder nicht. Aufgrund der Symmetrie des Codes ist dies mit bloßem Auge nicht erkennbar. Die Funktion ist hilfreich, wenn z.B. Codes auf transparentem Untergrund von hinten gelesen werden sollen.

Bei neu angelegten Detektoren sind für alle Parameter Standardwerte voreingestellt, die für viele Anwendungen geeignet sind.


2D-Code-Detektor, Reiter Symbole

2D-Code-Detektor, Reiter Abbildung

2D-Code-Detektor, Reiter Module

Abbildung: Abbildung, Detektor 2D Code, Reiter Symbole

Einstellungen im Reiter Symbole

Parameter | Funktion
Symbolgröße min. / max. | Nur QR-Code: Größe der Symbole im Bild in Pixel.
Spalten min. / max. | Nur ECC200 und PDF 417: Anzahl der Spalten inklusive Finder Pattern.
Zeilen min. / max. | Nur ECC200 und PDF 417: Anzahl der Zeilen inklusive Finder Pattern.


2D-Code-Detektor, Reiter Module

2D-Code-Detektor, Reiter Symbole

2D-Code-Detektor, Reiter Codedetails

Abbildung: Detektor 2D Code, Reiter Module

Einstellungen im Reiter Module

Parameter | Funktion
Modulgröße min. / max. | Größe der Module in Pixeln.
Modulbreite min. / max. | Nur PDF 417: Breite der Module im Bild in Pixel.
Modulverhältnis min. / max. | Nur PDF 417: Seitenverhältnis der Module im Bild (Höhe zu Breite).
Spaltenabstand | Nur ECC200 und QR-Code: Zulässiger Leerraum zwischen zwei Spalten, z.B. bei genagelten Codes, die keine flächendeckenden Module haben.
Zeilenabstand | Nur ECC200 und QR-Code: Zulässiger Leerraum zwischen zwei Zeilen.


2D-Code-Detektor, Reiter Codedetails

2D-Code-Detektor, Reiter Module

Abbildung: Detektor 2D Code, Reiter Codedetails

Einstellungen im Reiter Codedetails

Parameter | Funktion
Version | Nur bei QR-Code: Version des Codes, bei Modell 1 Wertebereich 1..14, bei Modell 2 Wertebereich 1..40. Version gibt die Größe des Codes an. Version 1 bedeutet 21x21 Module, Version 2 bedeutet 25x25 Module . . .(Pro Version je 4 Module mehr)
Modell Typ | Nur bei QR-Code: Modell1 oder Modell 2, Modell 2 ist die neuere Variante, unterstützt größere Codes.
Form | Nur bei ECC200 und QR-Code: Dient zur Spezifikation, ob rechteckige oder quadratische Codes gelesen werden sollen.
Modul Robustheit | Robustheit der Dekodierung gegenüber Datacodes mit sehr kleiner Modulgröße. Wird der Parameter auf 'hoch' gesetzt, so erhöht sich die Wahrscheinlichkeit, dass Datacodes mit sehr kleinen Modulen dekodiert werden können. Zusätzlich sollte in diesem Fall auch die minimale Modulgröße entsprechend angepasst werden, d.h. auf die angenommene minimale Modulgröße bzw. Modulbreite gesetzt werden.
Modul Raster | Nur ECC200: Angabe darüber, ob die Größe der Module in einem gewissen Rahmen variieren darf oder nicht. In Abhängigkeit von diesem Parameter werden verschiedene Algorithmen für die Berechnung der Modulpositionen verwendet. In einem Fall ('fixed') wird ein festes Gitter, bei dem die Abstände zwischen den Modulmittelpunkten alle gleich sind, verwendet. Im anderen Fall ('variable') wird das Gitter an der alternierenden Seite des Finderpatterns ausgerichtet. Bei 'any' werden beide Varianten für das Gitter nacheinander ausprobiert. Zu beachten ist, dass der Wert von 'module_grid' ignoriert wird, wenn 'finder_pattern_tolerance' auf 'high' gesetzt ist. In diesem Fall wird immer von einem festen Gitter ausgegangen. Werteliste: 'fixed', 'variable', 'any' Default: 'fixed' (enhanced: 'any')
Genaues Modell | Spezifiziert, ob die eingegebenen Parameter genau eingehalten werden müssen. Bei Auswahl von „Ja“ werden Codes Außerhalb der Parametergrenzen ignoriert.
Position Muster | Nur QR-Code: Anzahl von Position-Detection-Patterns, die im Bild gut sichtbar sein müssen, damit ein Code gesucht wird.
Suchmuster Toleranz | Nur bei ECC200: Toleranz der Suche gegenüber einem gestörten oder fehlenden Finderpattern. Das Finderpattern umschließt sowohl die L-förmige als auch die gegenüberliegende alternierende Seite. In einem Fall ('low') wird davon ausgegangen, dass das Finderpattern zum großen Teil vorhanden ist und kaum Störungen aufweist. Im anderen Fall ('high') kann das Finderpattern stark gestört sein oder komplett fehlen, ohne dass die Erkennung beeinträchtigt wird. Zu beachten ist allerdings, dass bei dieser Variante eine erhöhte Rechenzeit zu erwarten ist.


Ausgabe von Prüfergebnissen

Hier definieren Sie die Belegung und logische Verknüpfung der digitalen Signalausgänge, sowie die Schnittstellen und Ausgabedaten des Vision Sensor.

Pinbelegung

Ausgangssignale (Digitalausgänge / Logik)

Schnittstellen

Zeitsteuerung Digitale Ausgänge

Datenausgabe


Pinbelegung

Hier werden folgende Einstellungen vorgenommen:

1. Festlegung welche der variabel nutzbaren I/O als Ein- oder Ausgang genutzt werden sollen. Pin 05 rosa, Pin 06 gelb, Pin 07 schwarz (LED B), Pin 08 grau (LED C), können sowohl als Eingang als auch als Ausgang genutzt werden).

2. Zuordnung der Funktionen zu den Ein- / Ausgängen. In den jeweiligen Listboxen sind die für diesen Ein- oder Ausgang verfügbaren Funktionen aufgeführt und können hier auch definiert werden. Die Funktionen die unter. "Alleinige Funktionen" aufgeführt sind, sind nur über diesen Pin / Leitung verfügbar.

Abbildung: Ausgabe, Pinbelegung

Funktionen der Eingänge

Funktion | Beschreibung
H/W Trigger | Hardware Trigger (nur über Pin 03 weiß verfügbar)
Trigger freischalten | Funktion zum Freischalten oder Unterdrücken von Triggersignalen. Das Einlesen dieser Funktion benötigt ca. 1 ms. Es entsteht dadurch also eine Pause in der ein Triggersignal ignoriert wird, obwohl das Enable Trigger Signal anliegt.
Job 1..n | Jobumschaltung über Impulsfolge an einem Eingang, Wenn möglich sollte der Jobwechsel über die Binärsignale (binär codiert) stattfinden.
Einlernen temporär Einlernen permanent | Einlernen aller Detektoren und ggf. der Lagenachführung, sobald an diesem Eingang eine high Signal anliegt UND ein Trigger erfolgt. Temporär = Speicherung im RAM, flüchtig nach Reset, Permanent = Speicherung im Flash, dauerhaft, auch nach Reset
Job PinX, binär codiert | Jobumschaltung via binärem Bitmuster an bis zu 5 hierfür definierbaren Eingängen, d.h. Umschaltung zwischen 1 bis zu 32 Jobs. Rangfolge der Bits laut zugewiesener, aufsteigender Eingangsbezeichnung 1-5. s. auch Kap. Job 1… 31 via binärem Eingangs-Bitmuster
Keine Funktion, undefiniert | Keine Funktion, nicht genutzt

Funktionen, die schon vollkommen ausgenutzt sind, erscheinen in der Listbox blass grau, da nicht noch einmal nutzbar. Alle Eingänge benötigen eine minimale Signallänge von 2ms.

Abbildung: Abbildung, Ausgabe, Eingänge

Encoder Anschluss

Werden beide Spuren A+ und B+ verwendet ist die Vorwärts- / Rückwärts- Unterscheidung / Zählung möglich.

Abbildung: Encoder Spuren A+ / B+

Funktionen der Ausgänge

Funktion Beschreibung

Auswerfer

Spezieller Auswerferausgang (kann mit bis zu 100mA belastet werden, alle anderen Ausgänge = 50mA) nur über Pin 12 RDBU verfügbar (entspricht auch Anzeige- LED „A").

Ergebnis

Ergebnisausgang, jedem der hier definierten Ergebinsausgänge kann im Reiter „I/O- Logik" ein Detektorergebnis oder eine Verknüpfung von Detektorergebnissen zugewiesen werden.

Bestätigung Jobwechsel

Bei Jobwechsel via Digital I/O („Job 1..N" oder „Job PinX, binär codiert") kann hier zur Bestätigung des Erfolgsfalles eine Low/High Flanke eingestellt werden. Die High Flanke wird gesetzt, nachdem der neue Job- Inhalt geladen und aktiv ist , d. h. gleichzeitig mit der High Flanke beim Ready- Signals nach Umschaltung (s. Timing ..). Der High Pegel bleibt für 20ms stehen und wird dann wieder gelöscht.

Falls die Umschaltung nicht erfolgreich war, wird kein High Pegel ausgegeben d. h. das Signal ist permanent Low.

Externe Beleuchtung

Wird diese Einstellung gewählt (nur über Pin 09 RD verfügbar), kann hier eine externe Beleuchtung angeschlossen / getriggert werden.

Keine Funktion,

undefiniert

Keine Funktion, nicht genutzt

Abbildung: Abbildung, Ausgabe, Ausgänge

Es gibt zwei weitere, fest definierte Ausgänge:

  • Ready: zeigt an, ob der Sensor zum Empfang eines Triggers / nächsten Auswertung bereit ist.
  • Valid: zeigt an, ob die Daten an den Ausgängen gültig sind.

Programmierbare Funktionen der digitalen Eingänge:

Im Betrieb mit einer Prozesssteuerung können folgende Funkionen über die Eingänge ausgeführt werden:

  • Inaktiv
  • Enable/Disable
  • Lade Job (binär codiert)
  • Lade Job 1 ... n
  • Einlernen temporär
  • Einlernen permanent

Beschreibung der unterschiedlichen Fälle mit Signaldiagramm.

Eingang: "Trigger freischalten"

Schaltet den Triggereingang des Vision Sensor frei (High Signal) oder blockiert Hardware-Trigger (Low-Signal).

Abbildung: Eingang Timing, Trigger freischalten

Eingang: Job Wechsel über Binärsignale, oder über Funktion Job 1 oder 2

Jobwechsel Binär, über bis zu 5 Eingänge (Job 1- max. 31):

Nur möglich wenn Ready = High. Beim Wechsel der binären Eingangssignale wird Ready auf Low gesetzt. Ready bleibt Low bis die Umschaltung auf den neuen Job erfolgt ist. Falls das optionale Job- Wechel Bestätigungs- Signal genutzt wird, erfolgt dieses nach dem Job-Wechsel, und Ready wird erst danach wieder High. Während der Jobumschaltung dürfen keine Triggersignale gesendet werden. Der Pegelwechsel der zugehörigen Eingänge muss gleichzeitig erfolgen (innerhalb von längstens 10ms müssen alle Pegel stabil anliegen, liegen die Pegelwechsel einzelner Eingänge weiter auseinander werden ggf. mehrere Jobumschaltungen nacheinander ausgeführt)

Jobwechsel durch Funktion Job 1 oder 2:

Nur möglich wenn Ready = High. Beim Wechsel des Pegels des entsprechend definierten Eingangs wird Ready auf Low gesetzt. Ready bleibt Low bis die Umschaltung auf den neuen Job erfolgt ist. Falls das optionale Job- Wechel Bestätigungs- Signal genutzt wird, erfolgt dieses nach dem Job-Wechsel, und Ready wird erst danach wieder High. Während der Jobumschaltung dürfen keine Triggersignale gesendet werden. Bei Job 1 oder 2 schaltet Low-Pegel auf Job 1 und High-Pegel auf Job 2

Unterschied Binärsignale gegenüber Job 1 oder 2:

Bei Nutzung der Umschaltung via Binärsignalen muss in jedem Fall die gewünschte Job Nr binär kodiert angelegt werden, also müssen bei 2 Jobs mindestens 2 Eingänge genutzt werden.

Bei Job 1 oder 2 schaltet Low-Pegel auf Job 1 und High-Pegel auf Job 2. Es können also über einen Eingang zwei Jobs gewählt werden.

Abbildung: Eingang Timing, Jobwechsel via Binär / 1 oder 2

Eingang: Job 1 ... n

Zur Umschaltung von Jobs mittels digitalen Impulsen.

Nur möglich wenn Ready = High. Impulse werden bis zur ersten Pause von >= 50ms gezählt und danach wird auf den entsprechenden Job umgeschaltet. Ready wird nach erkannter Endebedingung (Pause >= 50ms) auf Low gesetzt und bleibt Low, bis die Umschaltung auf den neuen Job erfolgt ist. Falls das optionale Job- Wechel Bestätigungs- Signal genutzt wird, erfolgt dieses nach dem Job-Wechsel, und Ready wird erst danach wieder High. Die Impulslänge zur Jobumschaltung sollte 5 ms Puls und 5 ms Pause betragen. (Die Puls/Pausen- Zeiten sollten nicht kürzer als 10ms/10ms, und nicht länger als 25ms/25ms sein) Während der Jobumschaltung dürfen keine Triggersignale gesendet werden. Wenn möglich sollte der Jobwechsel über die oben beschriebene Umschaltung via Binärsignalen erfolgen, diese ist ggf. die schnellere Variante.

Abbildung: Eingang Timing, Job 1...n

Achtung !

Bei der Jobumschaltung ist Folgendes zu beachten:

- alle Jobs müssen die gleiche Einstellung zur Jobumschaltung haben.

- alle Jobs in Trigger- Modus.

- Ready muss High sein wenn die Triggersequenz startet.

Eingang: Teach temp. / perm.

Zum neuen Teachen der Muster aller Detektoren und ggf. der Lagenachführung des aktuellen Jobs. Nur möglich wenn Ready = High. Eine steigende Flanke initiiert den Teach, dabei muss der High Pegel mindestens bis zum nächsten Trigger anliegen, damit ein Bild eines Prüfteiles in korrekter Lage aufgenommen werden kann. Ready wird auf Low gesetzt und bleibt Low bis der Teach erfolgt ist. Die Speicherung erfolgt je nach Einstellung temporär (nur im RAM), oder permanent (im Flash).

Abbildung: Eingang Timing, Teach

Achtung!

Die Funktionen Job 1 oder 2, Job 1 ... n oder Einlernen temp./perm. sind nur im Trigger- Modus sinnvoll nutzbar.


Ausgangssignale (Digitalausgänge / Logik)

In diesem Reiter definieren Sie das Schaltverhalten und die logische Verknüpfung der einzelnen Detektoren mit den digitalen Ausgängen. Die Anzahl der Ausgänge richtet sich nach den Einstellungen unter dem Reiter Pinbelegung.

Abbildung: Abbildung, Ausgabe, Reiter Ausgangssignale / Logik

Logische Kombination der Detektoren für den jeweiligen Ausgang auswählen:

Je Pin (Ausgang) gibt es folgende Möglichkeiten:

Parameter | Funktion
Gesamt-Jobergebnis | kein physikalischer Ausgang. Hat Auswirkung auf Logik für Rekorder, Statistik und Archivierungsfunktionen
Invertieren | Gesamtergebnis aus den folgenden Einstellungen für diesen Pin (Ausgang) invertieren
Modus | Standard: Mehrere Detektoren können über die logischen Operatoren UND (&) / ODER (|) / NOT (!) zu einem logischen Ausdruck kombiniert werden. Erweitert: Die logische Formel zum Kombinieren der Detektoren kann frei erstellt werden.
NOT | Auswahl: Operator NOT (!)
Logik | Auswahl: Operator UND (&) / ODER (|)
D1 - D... | Je nach Anzahl aktivierter Detektoren werden in dieser Liste alle Detektoren eingefügt, diese können jedem aufgelisteten Ausgang logisch zugeordnet werden. Jeder Detektor kann für den jeweiligen Pin (Ausgang) ein-, invertiert- oder ausgeschaltet werden.
Logischer Ausdruck | Es wird entweder der im Standart Modus zusammengestellte logische Ausdruck angezeigt, oder der logische Ausdruck kann hier im Erweiterten Modus selbst zusammengestellt werden.
Logische Verknüpfung definieren:

Legen Sie die logische Verknüpfung zwischen den Prüfergebnissen der einzelnen Detektoren und den Status des gewählten Ausgangs fest. Sie haben zwei Möglichkeiten der Eingabe:

  • Standard Modus (Checkboxen und Operatoren)
  • Formel Modus


Logische Verknüpfung – Standard-Modus

Im Standard-Modus wird die Verknüpfung der Detektor-Prüfergebnisse für den gewählten Ausgang über die Radiobuttons Operator und die Checkboxen in der Detektorauswahlliste vorgenommen. Das Ergebnis wird im Feld Logische Formel angezeigt (nicht editierbar).

Ergebnisse verknüpfen:

1. Wählen Sie im Feld Operator den logischen Operator für die Verknüpfung der Detektoren in der Auswahlliste.

2. Aktivieren Sie in der Auswahlliste diejenigen Detektoren, die zum Ergebnis beitragen sollen (Häkchen in der Spalte Aktiv).

Durch Aktivierung der Spalte „Invertiert“ können Sie das jeweilige Detektorergebnis invertieren.

Entsprechend ändert sich der Eintrag in der Spalte Ergebnis.

Beispiele:

Hier können die Detektorergebnisse nur durch eine logische Operation verknüpft werden wie z.B.:

  • (D1&D2&D3) oder
  • !((!D1)|D2|D3) etc.

(Für komplexere Verknüpfungen bitte den Formel Modus wählen)


Logische Verknüpfung – Formel Modus

Im Formel Modus wird die Verknüpfung der Detektor-Prüfergebnisse für den gewählten Ausgang durch Direkteingabe einer logischen Formel definiert. Hierfür stehen Ihnen die Operatoren AND, OR und NOT sowie runde Klammern zur Verfügung.

Zur Editierung der Formel bitte folgende Zeichen für die logischen Operatoren verwenden:

  • "&" für AND
  • "|" für OR (Taste "AltGr" und Taste "<>")
  • "!" für NOT

Beispiele:

Hier können beliebig komplexe logische Ausdrücke erstellt werden wie z.B:

  • (D1&D2)|(D3&D4)
  • !((D1|D2)&(D3|D4))
  • (D1|D2)&(D3|D4)&(D5|D6)

etc.


Schnittstellen

In diesem Reiter selektieren und aktivieren Sie die genutzten digitalen Ein-/Ausgange und die Schnittstellen zur Datenausgabe:

Abbildung: Abbildung, Ausgabe, Reiter Schnittstellen

Parameter | Funktion
Interne I/O | Auswahl der Funktion der internen I/O: PNP oder NPN
Seriell | RS422 zur Datenausgabe mit Auswahl der Datenübertragungsrate. Grundeinstellungen: 8 Datenbits, 1 Stoppbit, keine Parität.
Externe I/O Erweiterung | Im Moment nicht verfügbar
Ethernet | Ethernet TCP/IP zur Datenausgabe. Der Sensor ist immer ein Socket Server. Es werden zwei verschiedene Ports verwendet, die vom Anwender definiert werden können. Grundeinstellung: Port 2006 (IN) für Kommandos an den Sensor (Steuerbefehle und Antwortprotokoll) und Port 2005 (OUT) für die eigentliche Datenausgabe.
EtherNet/IP | Feldbus EtherNet/IP zur Datenausgabe

Logische Ausgänge:

Bei Nutzung von RS422, Ethernet und EtherNet/IP Schnittstelle können zusätzliche logische Ausgänge definiert werden, die nur logisch existieren und nur per Datenausgabeschnittstelle kommuniziert werden können.

Logische Ausgänge können z.B. einem Detektorergebnis oder einem logischen Ausdruck (Formel) zugeordnet werden.

Hinweis:

In der Spalte „Aktiv“ können die Ausgänge und Schnittstellen separat aktiviert oder deaktiviert werden.


Zeitsteuerung Digitale Ausgänge

In diesem Reiter bestimmen Sie das Zeitverhalten des gewählten Signalausgangs: Wenn in der IO-Konfiguration ein Encoder aktiviert wurde, werden die Verzögerungen in Encoderschritten angegeben. Abhängig von der Einstellung in der IOKonfiguration werden alle folgenden Verzögerungen entweder in ms oder in Encoderschritten angegeben.

Abbildung: Abbildung, Ausgabe, Reiter Zeitsteuerung

Parameter | Funktion
Trigger Verzögerung | Zeit zwischen Trigger und Start der Bildaufnahme (in ms oder Encoder Impulsen). Maximal einstellbare Zeit ist 3000ms.
Digitale Ausgänge | Es können entweder alle Ausgänge verzögert werden oder nur der Auswerferausgang.
Auswerfer / Ergebnissverzögerung | Zeit zwischen Trigger und Anliegen des Ergebnispegels (in ms oder Encoder-Impulsen). Es dürfen maximal 20 Bauteile zwischen den Trigger und den Auswerfer passen (Puffergröße). Maximale Einstellwert 3000 ms / Encoder Impulse
Signalisierung | Auswahl des Ereignisses, das die Ausgänge zurücksetzt. Wechsel bei nächstem Ergebnis (Grundeinstellung) Wechsel bei Trigger Ergebnisdauer (feste Dauer in ms, danach Rücksetzen auf Inaktiv)
Ergebnisdauer | Dauer des Ergebnissignals (in ms oder Encoder Impulsen). Maximale Einstellwert 3000 ms / Encoder Impulse

Hinweise:

Bei Jobwechsel und Wechsel Run- zu Config Mode entstehen folgende Sonderzustände:

  • Der Puffer der verzögerten Ausgänge wird bei Jobwechsel und Wechsel des Betriebsmodus von „Run" nach „Config" gelöscht.

Digitalausgänge:

Diese werden bei Jobwechsel und Wechsel des Betriebsmodus von „Run" nach „Config" auf die Grundeinstellungen (Defaults) zurückgesetzt. Die Grundeinstellungen werden durch „Invert" im Tab Vision Sensor Configuration Studio/Ausgabe/Ausgangssignale festgelegt.“Invertiert = Aktiv" invertiert die Grundeinstellung des Digitalausgangs und gleichzeitig das Ergebnis.

Rücksetzen der Digitalausgänge:

Das Rücksetzen der Ergebnisausgänge kann in Abhängigkeit von verschiedenen Einstellungen / Ereignissen geschehen. Diese sind:

  • „Wechsel bei nächstem Ergebnis“ (Default):
    Der Ausgang wechselt seinen Pegel entsprechend dem logischen Ergebnis nur, wenn das nächste Ergebnis vorliegt. Typisch verwendet bei Weichensteuerung bei z.B. Sortierung etc.
  • „Wechsel bei Trigger“:
    Der Ausgang wird auf Inaktiv gesetzt (im Betriebsmodus PNP = Low) beim nächsten Trigger. Typisch verwendet bei Betrieb an einer SPS.
  • „Ergebnisdauer“:
    Der Ausgang wechselt zurück auf Inaktiv nach der hier eingestellten Ergebnisdauer in ms. Typisch verwendet bei z.B. pneumatischen Auswerfern (Ausblaser)

S. Vision Sensor Configuration Studio/Ausgabe/Zeitsteuerung/Signalisierung

Ready und Valid

  • Ready signalisiert wenn high, Bereitschaft für neue Bildaufnahme.
  • Valid signalisiert wenn high, dass Ergebnisse an den Ausgängen gültig sind.

PNP oder NPN Betriebsmodus

Alle hier beschriebenen Beispiele sind im Betriebsmodus „PNP“ ausgeführt. Ist die Einstellung „NPN“ gesetzt, gelten die Beispiele in analoger Weise mit umgekehrten Pegeln.

S. Vision Sensor Configuration Studio/Ausgabe/Schnittstellen/Interne I/O

Folgende Fälle im Zeitverhalten können unterschieden werden:

Normaler Trigger ohne Nutzung von Verzögerungszeiten:

Ablauf: (hier Signalisierung: Wechsel beim nächsten Ereignis)

  • steigende Flanke am Trigger-Eingang (Pin03 WH)
  • als Folge von Trigger = High: Ready = Low, und Valid = Low
  • Nachdem der Vision Sensor das Bild ausgewertet hat, und die entsprechenden Ergebnisse vorliegen, wechseln alle definierten Ausgänge in die entsprechenden logische Zustände und Ready und Valid gehen wieder auf High- Pegel. (Ausgänge gültig, Vision Sensor bereit zur nächsten Auswertung)

Abbildung: Abbildung, Digitale Ausgänge Timing, Standardablauf bei normalem Trigger

Trigger-Verzögerung aktiv

(Trigger- Verzögerung wirkt nur auf Hardware- Trigger)

Diese Einstellung dient zur gezielten Verzögerung der Bildaufnahme / Beginn der Auswertung ggü. dem tatsächlich physikalischen Trigger, der z.B. durch eine Trigger-Lichtschranke oder die Maschinensteuerung ausgelöst wurde. Hiermit ist die Feineinstellung des Triggerzeitpunkts ohne Änderungen an Mechanik oder Steuerungsprogramm möglich.

Ablauf:

Bild wird nach Trigger erst nach verstrichener Trigger- Verzögerungs- Zeit aufgenommen. Die Zykluszeit ist: Trigger-Verzögerung + Auswertezeit) s. Vision Sensor Configuration Studio/Ausgabe/Zeitsteuerung/Trigger/ Verzögerung

  • steigende Flanke am Trigger- Eingang (Pin03 WH)
  • als Folge von Trigger = High: Ready = Low, Valid = Low, alle definierten Ergebnisausgänge = Low (Signalisierung = Wechsel bei Trigger)
  • bevor das Bild für die Auswertung aufgenommen wird, verstreicht die eingestellte Trigger- Verzögerungszeit (Trigger delay)
  • Nun erfolgt die Auswertung. Sobald die entsprechenden Ergebnisse vorliegen, wechseln alle definierten Ausgänge in die entsprechenden logischen Zustände, und Ready und Valid gehen wieder auf High-Pegel. (Ausgänge gültig, Vision Sensor bereit zur nächsten Auswertung)

Abbildung: Abbildung, Digitale Ausgänge Timing, Trigger Verzögerung

Trigger Verzögerung + Ergebnisverzögerung (hier nur Auswerfer):

(Trigger- Verzögerung wirkt nur auf Hardware- Trigger)

Die Ergebnisverzögerung (ob für alle Ausgänge oder nur Auswerfer) dient zur Feineinstellung des z.B. Auswerferzeitpunktes unabhängig von der Auswertezeit, da insbesondere diese auch leichte Schwankungen aufweisen kann.

Ablauf:

Bild wird nach Trigger erst nach verstrichener Trigger- Verzögerungs-Zeit aufgenommen. Außerdem wirkt die Ergebnisverzögerung. In diesem Beispiel jedoch nur auf den Auswerfer-Ausgang (Pin 12 RDBU).

Die Zykluszeit ist für die definierten Ergebnisausgänge, außer dem Auswerfer-Ausgang: Die Trigger- Verzögerung- + Auswertezeit

Die Zykluszeit für den Auswerfer-Ausgang ist: Alleine die Ergebnisverzögerung (gezählt ab Triggerzeitpunkt, nur sinnvoll wenn länger als Summe o.g. Zeiten !) s. Vision Sensor Configuration Studio/Ausgabe/Zeitsteuerung/Digitale Ausgänge/Verzögerung.

  • steigende Flanke am Trigger- Eingang (Pin03 WH)
  • als Folge von Trigger = High: Ready = Low, Valid = Low, alle definierten Ergebnisausgänge = Low. Ausser Auswerfer, für diesen ist hier eine feste Ergebnisdauer definiert,
  • bevor das Bild für die Auswertung aufgenommen wird, verstreicht die eingestellte Trigger- Verzögerungszeit (Trigger delay)
  • Nun erfolgt die Auswertung. Sobald die entsprechenden Ergebnisse vorliegen, wechseln alle definierten Ausgänge (hier außer Auswerfer) in die entsprechenden logischen Zustände und Ready und Valid gehen wieder auf High- Pegel.
  • In diesem Betriebsmodus wird einzig der Auswerferausgang erst nach dem Verstreichen der Ergebnisverzögerung gesetzt. Der Auswerferausgang ist in diesem Beispiel auch mit einer Ergebnisdauer versehen und wird deshalb definiert nach dieser Ergebnisdauer auf Inaktiv gesetzt.

Abbildung: Abbildung, Digitale Ausgänge Timing, Ergebnis Verzögerung Auswerfer

Trigger Verzögerung + Ergebnisverzögerung (hier alle Ausgänge):

(Trigger- Verzögerung wirkt nur auf Hardware- Trigger)

Die Ergebnisverzögerung (ob für alle Ausgänge oder nur Auswerfer) dient zur Feineinstellung des z.B. Auswerferzeitpunktes unabhängig von der Auswertezeit, da insbesondere diese auch leichte Schwankungen aufweisen kann.

Ablauf:

Bild wird nach Trigger erst nach verstrichener Trigger- Verzögerungs- Zeit aufgenommen. Außerdem wirkt die Ergebnisverzögerung, in diesem Beispiel auf ALLE definierten Ergebnisausgänge.

Die Zykluszeit ist für alle Ergebnisausgänge: Alleine die Ergebnisverzögerung (gezählt ab Triggerzeitpunkt, nur sinnvoll wenn länger als Summe von Trigger-Verzögerung + Auswertezeit!)
s. Vision Sensor Configuration Studio/Ausgabe/Zeitsteuerung/Digitale Ausgänge/Verzögerung

  • steigende Flanke am Trigger- Eingang (Pin03 WH)
  • als Folge von Trigger = High: Ready = Low und Valid = Low,
  • bevor das Bild für die Auswertung aufgenommen wird, verstreicht die eingestellte Trigger- Verzögerungszeit (Trigger delay)
  • Nun erfolgt die Auswertung. Nach Vorliegen der entsprechenden Ergebnisse, wird einzig das Signal Ready nun gleich wieder auf High gesetzt (bereit zur nächsten Auswertung). Ansonsten wird noch auf das Verstreichen der Ergebnisverzögerung gewartet. Erst dann wechseln alle definierten Ausgänge in die entsprechenden logischen Zustände. Auch Valid geht wieder auf High- Pegel. (Valid = High: Ergebnissausgänge gültig, Signalisierung = Wechsel bei nächstem Ergebnis)

In diesem Betriebsmodus wechselt einzig das Signal „Ready“ schon nach Verstreichen von Trigger- Verzögerung + Bildaufnahme + Auswertezeit. Ready = High: Bereit zur nächsten Auswertung. Dies ist sinnvoll, da der Vision Sensor unabhängig vom späteren Setzen der Ausgänge, schon wieder bereit ist für die nächste Auswertung.

Abbildung: Abbildung, Digitale Ausgänge Timing, Ergebnis Verzögerung alle Ausgänge

Ergebnis-Dauer aktiv, betrifft hier z.B. alle Ausgänge:

Diese Zeiteinstellung dient zur Erzielung eines Ausgangspulses mit definierter Länge, etwa zur Ansteuerung eines pneumatischen Auswerfers (Ausblaser) im Falle eines Schlechtteiles, o.ä.

Alle definierten Ergebnissausgänge werden nach dem Aktivieren, exakt nach der eingestellten Ergebnis-Dauer in ms wieder auf Low-Pegel (Inaktiv im PNP-Betrieb) zurück gesetzt.

Abbildung: Abbildung, Digitale Ausgänge Timing, Ergebnis Dauer

Zykluszeit (Min, Max) aktiv:

(hier: Signalisierung: Wechsel bei Trigger)

Parameter zur Steuerung der Ausführungszeit eines Jobs. Schieber für Minimal- und Maximal-Wert.

Die minimale Ausführungszeit kann zum Unterdrücken von Mehrfachtriggern verwendet werden und kann Auswirkung auf die LED Leistung haben. (D. h. falls noch innerhalb der minimalen Job- Zeit ein weiterer Trigger eingeht wird dieser ignoriert)

Die maximale Ausführungszeit dient zum Abbruch eines Jobs nach einer definierten Zeit. Das Ergebnis des Jobs ist nach Abbruch immer "nicht o.k.". Die maximale Ausführungszeit sollte immer größer gewählt werden als der Zeitbedarf für eine Auswertung.

Die Zykluszeit misst die Zeit vom Trigger bis zum Setzen der digitalen Schaltausgänge. Soll die Zykluszeit begrenzt werden, z.B. weil der Maschinentakt nicht überschritten werden darf, muss der Wert für die maximale Zykluszeit entsprechend begrenzt werden. Das Ergebnis aller bis zu diesem Zeitpunkt nicht fertig ausgeführten Detektoren wird auf fehlerhaft gesetzt. Bei der Wahl der maximalen Zykluszeit ist zu berücksichtigen, dass diese nicht hart eingehalten wird, sondern in Abhängigkeit des gerade ausgeführten Detektors etliche weitere Millisekunden bis zum Abbruch verstreichen können. Es wird empfohlen, diese Überschreitung der maximalen Zykluszeit anhand der tatsächlichen Ausführungszeit zu überprüfen und den eingestellten Wert für die maximale Zykluszeit entsprechend zu verkleinern.

Ablauf:

Alle Ausgänge und das Signal „Valid“ (Ausgänge gültig) werden direkt nach der Auswertung gesetzt.

Das Signal „Ready“ (Bereit zur nächsten Auswertung) wird jedoch erst nach Verstreichen der Min. Job Zeit gesetzt, und damit werden erst ab diesem Zeitpunkt wieder Trigger für die nächste Auswertung akzeptiert.

Abbildung: Abbildung, Digitale Ausgänge Timing, Min Job Zeit

Multiple Ergebnisverzögerung für Auswerfer

Dieser Betriebsmodus wird verwendet, wenn zwischen Trigger/Auswertung für Prüfteil A und dessen Ausschleusung so viel Zeit / Förderstrecke liegt, dass der Vision Sensor bereits n (bis max. 20 möglich) weitere Prüfteile prüfen und deren jeweils ebenfalls späteren Ausschleusungszeitpunkt verwalten muss.

(nur verfügbar im Modus: Vision Sensor Configuration Studio/Ausgabe/Zeitsteuerung/Verzögerung: „Nur Auswerfer / Auswerfer- / Ergebnisverzögerung“ (ejector / result delay))

Hier: Signalisierung = Ergebnis-Dauer (alternativ auch „Wechsel bei nächstem Ergebnis“ verwendbar)

Es dürfen maximal 20 Bauteile zwischen den Trigger und den Auswerfer passen.

Abbildung: Abbildung, Digitale Ausgänge Timing, Multiple Ergebnisverzögerung Auswerfer


Datenausgabe

Konfiguration der Datenausgabe für die seriellen Schnittstellen RS422 und Ethernet sowie für die Archivierung in .csv-Dateien. Hier können sämtliche Einstellungen, welche Ergebnisdaten vom Vision Sensor über die zuvor ausgewählte und aktivierte Schnittstelle ausgegeben werden sollen, getroffen werden.

Serielle Kommunikation ASCII

Serielle Kommunikation BINÄR

EtherNet/IP Assembly Response

EtherNet/IP Assembly Request

Abbildung: Abbildung, Ausgabe, Reiter Datenausgabe

Parameter | Funktion
Binär / ASCII | Auswahl ob Ausgabedaten in Binär- (Hex) oder in ASCII- Format ausgegeben werden.
Export | Export des Dateiformats mit aktuellen Ergebnissen als .csv
Rücksetzen | Rücksetzen aller Eintragungen in diesem Reiter

Protokoll-Standardinhalte (Vorspann .... bis .... Prüfsumme)

Oft benötigte Standardinhalte können durch einfaches Ausfüllen bzw. Aktivieren via Checkbox zum Ausgabestring hinzugefügt werden.

  • Vorspann
  • Nachspann
  • Trennzeichen
  • Telegrammende
  • Gewählte Felder
  • ......

Detektorspezifische Einzelergebnisse zum Ausgabestring hinzufügen

Zuerst mit der Schaltfläche "+" einen neuen Eintrag erzeugen.

Funktion der Schaltfelder

  • "+": Neuen Eintrag einfügen
  • "-": Markierten Eintrag löschen
  • "Up", "Down": Markierten Eintrag verschieben

Über die Auswahlliste „Detektorspezifische Nutzdaten“ können Sie detektorspezifische Einzelergebnisse in der gewünschten Reihenfolge flexibel zum Datentelegramm hinzufügen. Hinzufügen von Werten mit Button „+“

Abbildung: Abbildung, Ausgabe, Detektrospezifische Nutzdaten

Spalte | Funktion
Aktiv | Aktivieren/Deaktivieren des markierten Ausgabewerts
Detektor | Detektorname (Wahl über Ausklappliste)
Wert | Verfügbare Detektorergebnisse (Wahl über Ausklappliste)
Min. Länge | Festlegung der Mindestlänge des Felds Wert; ist die tatsächliche Länge geringer als die Vorgabe, wird das Feld mit Leerzeichen (ASCII) bzw. Nullen (binär) aufgefüllt

Datenausgabemöglichkeiten des Vision Sensor (s. auch Kap. Kommunikation)

(Ethernet-)port 2005 / RS422

Numerische Daten, die unter Ausgabe/Datenausgabe konfiguriert wurden, können in einem eigenen ASCII/BINAER Format ausgegeben werden.

Ethernet: Der Sensor ist hierbei der (Socket-)“Server" und stellt die Daten über eine „Server-Socket" Schnittstelle zur Verfügung. Hauptsächlich ist dies eine „Programmier-Schnittstelle". Um die Daten lesen/verarbeiten zu können muss ein „Socket-Client" (PC, SPS, etc.) eine (Socket-)Verbindung (aktiv) zum Sensor aufbauen, und kann dann die Daten verarbeiten.

PC-Archivierung (Vision Sensor Visualisation Studio)

Hiermit können Bilder und numerische Daten (im csv Format) durch den „Viewer" (Vision Sensor Visualisation Studio) selbst permanent (in ein Verzeichnis auf dem PC) mitprotokolliert werden. Die Konfiguration (Verzeichnis, etc.) dieser Archivierung erfolgt über den „Viewer" (-> über Menue „Datei/Archivierung konfigurieren"). Dies ist eine reine PC-Funktionalität.

PC-Archivierung (Vision Sensor Visualisation Studio)

Hiermit können Bilder und numerische Daten (im csv Format) durch den „Viewer" (Vision Sensor Visualisation Studio) selbst permanent (in ein Verzeichnis auf dem PC) mitprotokolliert werden. Die Konfiguration (Verzeichnis, etc.) dieser Archivierung erfolgt über den „Viewer" (-> über Menue „Datei/Archivierung konfigurieren"). Dies ist eine reine PC-Funktionalität.

Ramdisk (auf dem Sensor)

Auf dem Sensor wird das letzte Bild, sowie numerische Daten, welche unter „Ausgabe/Datenausgabe" konfiguriert wurden, permanent (in einer .csv Datei) auf dem Sensor in ein Ramdisk-Verzeichnis unter „/tmp/results/" gespeichert. Diese Funktionalität muss unter „Job/Bildübertragung" aktiviert werden. Um diese Daten „lesen" zu können, muss aktiv eine ftp-Verbindung zum Sensor aufgebaut werden. Hierzu wird ein ftp-Client benötigt.

Hinweise

* Das Format der csv Dateien (ftp, smb, ram-disk, Vision Sensor Visualisation Studio) ist einheitlich „gleich".

* Die Daten werden lesbar (per default mit Semikolon getrennt) in die csv Datei ausgegeben.

* Es werden nur (Nutz-)Daten, welche unter (Ausgabe/Datenausgabe) konfiguriert wurden ausgegeben.

Kommunikations- Einstellungen

Kommunikation | Ethernet | RS422
Zum Sensor, Kommando | Wählbar im Tab: Datenausgabe (Binär oder ASCII)
An Sensor, Datenausgabe | Wählbar im Tab: Datenausgabe (Binär oder ASCII)

Protokoll-Einstellungen

Parameter | Funktion
Protokoll | Kommunikation Binär oder ASCII
Export | Speichern der Vorschau auf dem PC, z.B. als Vorlage für SPS-Programmierung

Grundlagen zum Aufbau der Verbindung:

Der Vision Sensor wird immer als tcp/ip (socket-) server verwendet.

Der Vision Sensor Sensor öffnet immer zwei (socket-) Kommunikationsports (default: 2005 + 2006).

  • 2005 = Daten Port zum Senden numerischer Ergebnisse an den Kunden.
  • 2006 = Befehlsport um Befehle am Sensor zu empfangen.

Es kann gleichzeitig nur ein (socket-) client (PC or PLC) an jeden Port verbunden werden.

Empfehlungen:

Bestehende Socket Verbindungen müssen nur wiederverbunden werden, wenn ein Fehler aufgetreten ist (z.B.: SPS oder Client in Stop mode oder Fehler mode, etc.). Während des fehlerfreien Betriebes brauchen keine bestehenden Verbindungen erneut aufgebaut werden.

Ethernet Daten Handling: Besonders bei Nutzung mehrerer Vision Sensor, sollte bevorzugt über die Ethernet Kommunikation erfolgen.


Ergebnis

Mit dieser Funktion wird der definierte Job auf dem PC ausgeführt, und das „Ergebnisse/Statistik" Fenster mit Detektorliste und Auswerteergebnissen angezeigt. Die Ausführungszeiten werden in diesem Modus nicht aktualisiert, da sie vom Sensor nicht vorliegen.

Im Run-Modus werden die detaillierten Prüfergebnisse des in der Auswahlliste markierten Detektors angezeigt.

Im Bildfenster werden – sofern eingestellt – das Bild, die Such- und Merkmalsbereiche und Ergebnisgrafen angezeigt.

Abbildung: Ergebnis

Angezeigte Ergebnispar. | für Detektortyp | Bedeutung
Ergebnis | alle | Teil / Merkmal erkannt (Erkannt = grün, Nicht erkannt = rot)
Score | alle | Übereinstimmungsgrad des gefunden Musters mit dem eingelernten Muster
Ausführungszeit | alle | Zykluszeit für eine Auswertung in ms
PositionX, PositionY | Kontur | Koordinaten des gefundenen Merkmals (Mittelpunkt)
Delta X, Delta Y | Kontur | Abweichung der Findekoordinaten ggü. Einlernposition / durch Lagenachführung
Positionskontrolle | Kontur | Findeposition innerhalb des definierten Positionsrahmens
Winkel | Kontur | Orientierung (absoluter Winkel) des gefunden Merkmals
Delta Winkel | Kontur | Winkelabweichung zwischen eingelerntem und gefundenem Merkmal
Skalierung | Kontur | Skalierung der gefundenen Kontur ggü. der eingelernten

Die angezeigten Parameter variieren in Abhängigkeit vom ausgewählten Detektortyp.
Um die Prüfergebnisse für einen anderen Detektor aufzurufen, markieren Sie diesen in der Auswahlliste.
Im Programm Vision Sensor Visualisation Studio können Sie Prüfergebnisse und statistische Auswertungen inklusive der gewählten grafischen Darstellungen archivieren.


Start des Sensors

Mit dieser Funktion können Sie den Sensor in den Run-Modus versetzen und Ihren Job ausführen.

Bildanzeige

Ergebnis

Statistik

Jobausführung starten:

Klicken Sie auf den Button "Sensor starten".

Der aktive (= in der Auswahlliste markierte) Job wird auf den Sensor übertragen, im Sensorspeicher nichtflüchtig abgelegt und gestartet (Run-Modus).

Im Bildfenster werden die gefundenen Merkmale, im Konfigurationsfenster die Prüfergebnisse für den ersten bzw ausgewählten Detektor in der Auswahlliste, sowie statistische Parameter angezeigt.

Detektoranzeige wechseln:

Um die Prüfergebnisse für einen anderen Detektor als den gerade ausgewählten anzuzeigen, markieren Sie diesen in der Detektor-Auswahlliste (links unten) oder klicken auf dessen grafische Darstellung im Bildfenster.

Jobausführung beenden:

Klicken Sie auf den Button „Stop Sensor". Sie befinden sich jetzt wieder im Konfigurationsmodus und können Ihren Job bearbeiten.

Abbildung: Sensor starten


Weitere Themen zu Vision Sensor Configuration Studio

Trigger-Einstellungen

Umschalten zwischen Online- und Offline-Modus

Simulation von Jobs (Offline-Modus)

Erstellen von Filmstreifen

Bildrekorder

Anzeigen im Bildfenster

Such- und Merkmalsbereiche


Trigger-Einstellungen

Wählen Sie in den Job-Einstellungen im Reiter „Bildaufnahme" den gewünschten Trigger-Modus:

Parameter | Funktion
Getriggert | Betrieb mit externem Trigger, oder Button „Trigger" auf der Vision Sensor Configuration Studio-Oberfläche
Freilauf | Betrieb mit automatisch laufendem Selbsttrigger; der Sensor liefert Bilder/Auswertungen mit der maximal möglichen Frequenz

Wählen Sie mit den Schaltflächen im Bereich Trigger/Bildaktualisierung in welcher Form Bilder vom Sensor geliefert werden sollen:

Parameter Funktion

Einzelbild

Aufnahme eines Einzelbilds, Bildaufnahme erfolgt einmalig bei:

1. Trigger Modus = Getriggert: Erstem externem Triggersignal oder mit dem Button „Trigger" auf der Vision Sensor Configuration Studio- Oberfläche

2. Trigger Modus = Freilauf: Erstem Click auf Button „Einzelbild" auf der Vision Sensor Configuration Studio- Oberfläche (Wichtig z.B. im Einricht- Betrieb)

Kontinuierlich

Kontinuierliche Lieferung von Bildern, Bildaufnahme erfolgt fortlaufend bei:

1. Trigger Modus = Getriggert: Jedem externen Trigger oder bei jedem Click auf den Button „Trigger" auf der Vision Sensor Configuration Studio- Oberfläche

2. Trigger Modus = Freilauf: Kontinuierlich durch interne Selbsttriggerung mit maximaler Frequenz

Bei Änderung der Parameter Belichtungszeit, Verstärkung, Beleuchtung oder Auflösung in den Job-Einstellungen wird automatisch ein neues Bild vom Sensor angefordert.

Um auch ohne Trigger ein stetig aktualisiertes Livebild zu erhalten folgende Einstellungen vornehmen:

  • Freilauf einstellen unter „Job/Bildaufnahme"
  • Kontinuierlich einstellen unter „Trigger / Bildaktualisierung"


Umschalten zwischen Online- und Offline-Modus

Für Konfiguration und Testlauf des Sensors stehen Ihnen zwei Betriebsarten zur Verfügung, die Sie im Feld Verbindung auswählen können.

  • Online-Modus: Konfiguration mit angeschlossenem Sensor.
  • Offline-Modus: Simulation eines Sensors mit Hilfe gespeicherter Bilder im Filmstreifen.

Abbildung: Abbildung, Verbindungsmodus

Bei angeschlossenem Sensor stehen beide Modi zur Verfügung, es kann dazwischen umgeschaltet werden. Ist kein Sensor vorhanden, kann nur im Offline- Modus, d. h. mit einer Sensor- Simulation gearbeitet werden.


Simulation von Jobs (Offline-Modus)

Sie können Ihre Konfiguration auch ohne angeschlossenen Sensor anhand gespeicherter Filmstreifen (= Bilderserien) erstellen und testen. Eine Simulation kann z.B. sinnvoll sein, um eine Konfiguration vorzubereiten oder eine online vorgenommene Konfigurationen zu optimieren.

Anzeigen im Bildfenster

Erstellen von Filmstreifen

Hinweise:

  • Im Auslieferungszustand von Vision Sensor Configuration Studio stehen Ihnen einige vorbereitete Filme zur Verfügung.
  • Weitere Möglichkeiten zur Bildaufnahme: Bildrekorder


Erstellen von Filmstreifen

Im Konfigurationsmodus Online-Modus werden kontinuierlich Bilder vom Sensor in das RAM des PC geladen. Nach dem Umschalten vom Online- in den Offline- Modus stehen Ihnen hier maximal 30 Bilder zur Verfügung, die Sie als Bilderserie in einer Filmstreifendatei speichern können. Alternativ oder zusätzlich zu den auf dem Sensor gespeicherten Bildern können Sie auf Ihrem PC oder einem externen Speichermedium abgelegte Bilderserien oder Einzelbilder laden und zu neuen Filmen zusammenstellen.

Wenn Sie ein Bild in der Liste markieren, wird es im Kleinformat im Preview- Fenster rechts angezeigt.

Bilder vom Sensor als Filmstreifen speichern:

1. Zuerst den PC mit dem Sensor verbinden. Im Freilauf Bilder in den Speicher auflaufen lassen. (Verbindungsmodus = Online)

2. Wählen Sie Radiobutton „Offline" im Feld Verbindungsmodus.

3. Wählen Sie „Filmstreifen konfigurieren“ aus dem Datei-Menü oder klicken Sie auf das Icon Filmstreifen in der Toolbar. In der sich unten öffnenden Auswahlliste erscheinen die vom Sensor geladenen Bilder:

Abbildung: Filmstreifen

Nun können die Bilder betrachtet, umsortiert oder einzelne Bilder gelöscht bzw hinzugefügt werden. Die maximale Bildanzahl in einem Filmstreifen ist 30.

4. Klicken Sie auf Button „Speichern Filmstreifen" unter der Auswahlliste.

Sämtliche Bilder in der Liste werden in der angezeigten Reihenfolge in einer Filmstreifendatei (Erweiterung .flm) gespeichert und stehen Ihnen für künftige Simulationen zur Verfügung.

Filmstreifen und Einzelbilder vom PC laden:

1. Wählen Sie Radiobutton „Offline" im Feld Verbindungsmodus.

2. Wählen Sie Filmstreifen konfigurieren aus dem Datei-Menü oder klicken Sie auf das Icon Filmstreifen in der Toolbar.

3. Wählen Sie eine Filmdatei aus der Auswahlliste und klicken Sie auf Button „Laden Filmstreifen" oder laden Sie mit Button „Bild laden" einzelne Bilder von Ihrem PC oder einem externen Speichermedium.

Die geladenen Bilder werden der Auswahlliste hinzugefügt.

In der Spalte Quelle werden Art und Speicherort der Datei angezeigt: Auf dem PC gespeicherter Filmstreifen (Film), auf dem PC gespeichertes Einzelbild (Datei), Bild im Sensorspeicher (Sensor). Nach der Umschaltung vom Online- in den Offline-Modus sind alle Einträge vom Typ Sensor.

Filmstreifen bearbeiten:

Sie können aus den Einzelbildern in der Auswahlliste unabhängig von ihrer Quelle neue Filme erstellen.

Folgende Funktionen stehen Ihnen hierfür zur Verfügung:

Button | Funktion
"<", "<<", ">", ">>" | Bildreihenfolge ändern: Das markierte Bild wird um einen Platz oder bis ans Ende der Liste nach oben/unten verschoben.
Bild laden | Weiteres Bild laden
Löschen, Alle löschen | Bild aus der Liste löschen/Alle Bilder aus der Liste löschen. (Die Bilder auf dem PC werden dabei nicht gelöscht.)
Abbruch> | Verlassen der Listenansicht ohne Änderung
Übernehmen | Laden sämtlicher Bilder in der angezeigten Reihenfolge in den Filmspeicher auf dem PC. Diese stehen dann für die Anzeige und Auswertung im Offline-Modus zur Verfügung.
Laden / Speichern Filmstreifen | Filmstreifen von PC laden oder dort speichern


Anzeigen im Bildfenster

Steuerung der Bildwiedergabe

Abbildung: Bildwiedergabe

Mit den Buttons „<" (Zurück), Start / Stop und „>" (Vor) sowie der Schiebeleiste unter dem Bildfeld können Sie die Auswahl und Wiedergabe gespeicherter Bilder steuern. Im Bildzähler wird Ihnen die Nummer des aktuellen Bildes sowie die Anzahl der Bilder im aktiven Filmstreifen angezeigt.

Bildausschnitt und -vergrößerung

Abbildung: Zoom

Mit den Schaltflächen bzw. über das Ausklappmenü unter dem Bildfenster können Sie den gewünschten Bildausschnitt wählen.

Grafische Ergebnisanzeige

Im Menü Ansicht können Sie folgende grafischen Darstellungen aktivieren bzw. deaktivieren:

  • Ergebnis Bargraph: Anzeige des Prüfergebnisses als Balkendiagramm
  • Einzeichnungen: Anzeige von Such-, Merkmals- und Positionsrahmen von Detektoren und Lagedetektoren
  • Fokussierhilfe: Anzeige der Bildschärfe (siehe auch Job-Einstellungen)
  • Vergrößerte Anzeige: Einblendung eines separaten vergößerten Bildfensters, das sich über Anfasser an den Rahmenecken beliebig skalieren lässt

Im Programm Vision Sensor Visualisation Studio steht Ihnen eine eingeschränkte Auswahl dieser Funktionen zur Verfügung.


Bildrekorder

In den Programmen Vision Sensor Configuration Studio und Vision Sensor Visualisation Studio steht Ihnen ein Bildrekorder zur Verfügung. Wenn der Rekorder aktiviert ist, werden kontinuierlich entweder alle Bilder oder nur Fehlerbilder in den internen Speicher des Sensors geladen. Dieser fasst 10 Bilder, die ältesten Bilder werden jeweils überschrieben (Ringpuffer). Die aufgezeichneten Bilder können anschließend mit einem PC abgerufen und angezeigt, sowie auf dem PC oder einem externen Speichermedium abgelegt werden und stehen dann zu Analyse- oder Simulationszwecken im Offline- Modus zur Verfügung.

Im Programm Vision Sensor Visualisation Studio müssen Sie zum Abrufen der Rekorderbilder u.U. (falls aktiviert) ein Passwort eingeben (Benutzergruppe Werker, siehe Benutzerverwaltung).

Rekorder aktivieren:

Aktivieren Sie die Aufnahmefunktion in den Jobeinstellungen des Programms Vision Sensor Configuration Studio (Reiter Allgemein). In der Ausklappliste des Parameters Rekorder können Sie wählen, ob alle Bilder oder nur Fehlerbilder aufgezeichnet werden sollen.

Bilder auswählen und aufzeichnen:

Wählen Sie Bildrekorder auslesen aus dem Datei-Menü oder klicken Sie auf Button „Rek.Bilder" (nur in Vision Sensor Visualisation Studio).

Es erscheint ein Bildfenster, in dem Sie die im Sensor gespeicherten Bilder auf den PC laden, betrachten und abspeichern können:

Abbildung: Abbildung, Bildrekorder

Parameter | Bedeutung
Zurück | Anzeige des vorhergehenden Bildes
Vor | Anzeige des nächsten Bildes
Speichern | Speichern des angezeigten Bildes auf dem PC bzw. einem externen Speichermedium
Alle speichern | Speichern aller Bilder

Hinweise:

  • Die laufende Nummer des ausgewählten Bildes und die Gesamtzahl der Bilder (max. 10) werden im Zähler unter dem Bildfenster angezeigt.
  • Beim Speichern werden die Bilder im Bitmap-Format (Extension .bmp) abgelegt.
  • Das zum jeweiligen Bild gehörige Prüfergebnis (OK bzw. Fehler) und das Datum werden im Dateinamen gespeichert (Format JJMMTT_laufende Nr._Pass/Fail.bmp, z.B. 090225_123456_Pass.bmp).
  • Wenn Sie zusammen mit den Bildern detaillierte Prüfergebnisse aufzeichnen wollen, verwenden Sie die Funktion Archivierung in Vision Sensor Visualisation Studio.
  • Wenn Sie nur ein einzelnes Bild mit oder ohne Overlay aufnehmen wollen, können Sie anstelle des Rekorders die Funktion Speichere aktuelles Bild im Datei-Menü verwenden.
  • Die Bilder werden bei der Übertragung auf den PC mit einem Zeitstempel versehen.
  • Durch das Laden der Bilder vom Sensor auf den PC werden die Daten auf dem Sensor gelöscht. Wenn das Rekorder Fenster geschlossen wird ohne die Bilder vorher zu speichern gehen die Bilder verloren.


Such- und Merkmalsbereiche

In den Konfigurationsschritten Lagenachführung und Detektoren können Sie Such- und Merkmalsbereiche definieren. Diese sind im Bildfenster durch verschiedenfarbige Rahmen gekennzeichnet.

Im Menüpunkt „Ansicht/Einzeichnungen konfigurieren" können die Einzeichnungen im Bild (Rahmen in gelb, rot, etc.) beliebig je Detektor oder Kategorie an- oder abgeschaltet werden. Unter „Ansicht/Einzeichnungen nur aktueller Detektor" können alle Einzeichnungen im Bild bis auf die des aktuell bearbeiteten Detektors abgeschaltet werden.

Definition von Such- und Merkmalsbereichen

Bei der Erstellung eines neuen Detektors wird ein gelber Rahmen angezeigt, der den Suchbereich des Detektors definiert. Standardform des Suchbereichs ist ein Rechteck. Es können auch je nach Detektortyp die Form Kreis oder Freiform ausgewählt werden. Die definierten Merkmale (roter Rahmen) werden gefunden (grüner Rahmen), solange sich dessen Mittelpunkt innerhalb des Suchbereiches (gelber Rahmen) befindet.

Bei den Detektoren Mustervergleich und Konturerkennung gibt es zusätzlich einen Merkmalsbereich innerhalb des Suchbereichs, der durch eine roten bzw. grünen Rahmen dargestellt wird:

  • Roter Rahmen = Merkmal einlernen
  • Grüner Rahmen = Merkmal gefunden.

Ist eine Positionserkennung definiert, erscheint zusätzlich ein blauer Rahmen (wahlweise Rechteck, Kreis oder Ellipse).

Ist ein Lagedetektor definiert, werden dessen Rahmen gelb gestrichelt angezeigt.

An der jeweils linken oberen Ecke der Rahmen wird die entsprechende Detektornummer angezeigt.

Anpassen von Such- und Merkmalsbereichen

Die zuerst in Standardgröße und -position angezeigten Bereiche können Sie im Bild oder in der Detektorliste auswählen / markieren und in der Position und Größe verändern. Über acht Anfasser am Rahmen lassen sich Rahmenformat und -größe anpassen, über Klick irgendwo innerhalb des Rahmens dessen Position verschieben. Am zur Mitte zeigenden Pfeil lässt sich die Drehlage des Rahmens verändern.

Das eingelernte Muster wird in Originalgröße im Reiter Allgemein oder Parameter in der rechten unteren Bildschirmecke dargestellt. Nur die Rahmen des im Bild oder in der Detektorliste gewählten, momentan aktiven Detektors wird in dicker Linienstärke und den Anfasspunkten dargestellt, alle anderen, zu diesem Zeitpunkt nicht selektierten Rahmen, werden mit dünnen bzw gestrichelten Linien (Lagedetektor) dargestellt.

Abbildung: Abbildung, Such- und Merkmalsrahmen

Hinweise:

  • Für eine optimale Erkennung sollten Merkmale eindeutig sein und keine variablen Anteile, z.B. Schatten, enthalten.
  • Signifikante Konturen, Kanten und Kontrastunterschiede sind von Vorteil.
  • Um die Auswertezeit zu minimieren, sollte der Suchbereich nicht unnötig groß gewählt werden.

Ergebnisbalken:

Rechts neben dem Suchbereich wird der Übereinstimmungsgrad des gesuchten mit dem gefundenen Merkmal als stehender Ergebnisbalken mit eingestelltem Schwellwert angezeigt:

  • Grüner Balken = Das gesuchte Merkmal wurde gefunden und der voreingestellte Schwellwert der Mindest- Übereinstimmung erreicht.
  • Roter Balken = Das Objekt konnte nicht mit dem erforderlichen Übereinstimmungsgrad gefunden werden. Welche grafischen Darstellungen angezeigt werden, können Sie im Menü Ansicht wählen.


Vision Sensor – Bedien- und Konfigurationssoftware –Vision Sensor Visualisation Studio, alle Funktionen

Dieses Programm dient zur Überwachung/Überprüfung von angeschlossenen Sensoren und zur Analyse von Prüfergebnissen.

Von hier aus können auf dem Sensor keine neuen Einstellungen gemacht werden.

Bildanzeige

Ergebnis

Statistik

Wechsel des aktiven Jobs

Hochladen

Kommandos / Bild einfrieren

Bildrekorder

Archivierung von Prüfergebnissen und Bildern

Es kann über die reine Anzeige hinaus nur zwischen bereits existierende Jobs auf dem Sensor umgeschaltet werden, oder vordefinierte Jobsätze vom autorisierten Werker vom PC / Steuerung auf den Sensor hochgeladen werden. Somit dient dieses Anzeigetool hauptsächlich zur Visualisierung von Bildern und Ergebnissen, und zum Jobwechsel bei z.B. Teilewechsel auf der Maschine.


Bildanzeige

Die grafische Anzeige des Bildes und der Prüfergebnisse im Bildfenster hängt von den Einstellungen im Reiter Bildübertragung in den Jobeinstellungen (Reiter Bildübertragung Kap Bildübertragung Parameter im Programm Vision Sensor Configuration Studio) ab:

  • Bildübertragung aktiv: Das aktuelle Bild sowie die Rahmen für die definierten Such-, Merkmals- und Positionsbereiche und die gefundenen Merkmale werden angezeigt.
  • Bildübertragung inaktiv: Es werden nur die Rahmen für die definierten Such-, Merkmals- und Positionsbereiche und die gefundenen Merkmale angezeigt (das aktuelle Bild wird nicht angezeigt).

Rechts neben dem Suchbereich des jeweiligen Detektors wird der Übereinstimmungsgrad des gesuchten mit dem gefundenen Merkmal als stehender Ergebnisbalken mit eingestelltem Schwellwert angezeigt:

  • Grüner Balken: Das gesuchte Merkmal wurde gefunden und der voreingestellte Schwellwert der Übereinstimmung erreicht.
  • Roter Balken: Das Objekt konnte nicht mit dem erforderlichen Übereinstimmungsgrad gefunden werden

Ein „Ausrufezeichen“ als Einblendung im Livebild sagt aus, dass die Bildauswertung im PC langsamer läuft als die Bildauswertung auf dem Vision Sensor, es werden nicht mehr alle Bilder, die vom Vision Sensor aufgenommen werden angezeigt.

Dies kann bei Verwendung der Schlechtbildarchivierung evtl. zu Bildverlusten führen. Bei häufigem Auftreten des Ausrufezeichens, sollten auf dem PC Programme im Hintergrund geschlossen werden, um mehr PC-Leistung zur Verfügung zu stellen.

Im Menü Vision Sensor Visualisation Studio / Ansicht können Sie die grafische Darstellung der Prüfergebnisse konfigurieren.

Abbildung: Abbildung, Vision Sensor Visualisation Studio

Mit Ausnahme der Archivierung stehen sämtliche Funktionen von Vision Sensor Visualisation Studio auch im Programm Vision Sensor Configuration Studio zur Verfügung.


Kommandos / Bild einfrieren

Mit dem Button „Bild einfrieren" können Sie Einzelbilder des gewünschten Typs (Aktuelles Bild, Nächstes Bild, Nächstes Fehlerbild) anfordern und im Bildfenster zur Anzeige festhalten.

Das gewünschte Einzelbild wird angezeigt und der Bildzähler bleibt auf der entsprechenden Bildnummer stehen.

Mit „Fortsetzen" beenden Sie die Einzelbildanzeige.


Zoom

Mit dem Button "Zoom" wird das Bild in einem neuen Fenster in vergrößerter Anzeige geöffnet.


Archivierung von Prüfergebnissen und Bildern

Sie können Bilder mit und ohne Einzeichnungen sowie Prüfergebnisse auf Ihrem PC oder einem externen Speichermedium zu Analyse- oder Simulationszwecken archivieren (siehe Offline-Modus).

Die Ausführung dieser Funktionen erfordert u.U. die Eingabe eines Passworts (Benutzergruppe Werker, siehe Benutzerverwaltung).

Archivierung konfigurieren:

1. Wählen Sie „Archivierung konfigurieren“ aus dem Datei-Menü.

Es erscheint ein Dialogfenster mit folgender Auswahl:

Abbildung: Abbildung, Archivierung konfigurieren

Parameter | Funktion
Pfad für Archivierung | Verzeichnis, in dem die Archivierungsdatei(en) abgelegt werden.
Einstellungen, Automatischer Start | Startet die Archivierung automatisch nach Start von Vision Sensor Visualisation Studio.
Einstellungen, Zyklisches Überschreiben | Aktiviert das zyklische Überschreiben der ältesten Bilder bei erreichen des Speicherlimit.
Einstellungen, Speicherlimit | Hier kann die Datenmenge begrenzt werden.
Einstellungen, Bildtyp | In dieser Ausklappliste kann spezifiziert werden, welche Bilder (alle Bilder bzw. nur Gut- bzw. Schlechtbilder) gespeichert werden sollen.
Einzeichnungen, Ergebnis Bargraph | Auswahl der zu archivierenden grafischen Darstellungen im Bild.
Numerische Ergebnisse | Wenn „mitprotokollieren" aktiviert ist, werden in einer zusätzlichen .csv-Datei numerische Ergebnisdaten wie Koordinatenwerte o.ä. archiviert.

2. Wählen Sie die gewünschten Optionen und bestätigen Sie Ihre Wahl mit OK.

Archivierung starten/beenden:

Klicken Sie auf den Button „Bilder archivieren" im Fenster „Kommandos", um die Archivierungsfunktion mit o.g. Einstellungen zu starten bzw. zu beenden. In der Statusleiste wird die gegenwärtig zu speichernde Bilddatei mit Namen angezeigt. Die Archivierung wird ausgeführt, solange der Button „Bilder archivieren" gedrückt ist.


Statistik

Im Run-Modus werden die statistischen Daten des Prüfprozesses im Reiter Statistik angezeigt. Die angezeigten statistischen Daten sind für alle Detektortypen identisch:

Parameter | Bedeutung
Alle Auswertungen | Gesamtzahl der Prüfungen
Gutteile | Anzahl der Prüfungen mit Resultat „OK"
Schlechtteile | Anzahl der Prüfungen mit Resultat „Fehler"
Min./Max./Mittlere Ausführungszeit | Min./Max./Mittlere Ausführungszeit für eine Auswertung in ms

Mit dem Button „Rücksetzen" können Sie alle Statistikwerte auf Null zurücksetzen.

Im Programm Vision Sensor Visualisation Studio können Sie Prüfergebnisse und statistische Auswertungen inklusive der gewählten grafischen Darstellungen archivieren.


Ergebnis

Mit dieser Funktion wird der definierte Job auf dem PC ausgeführt, und das „Ergebnis Statistik" Fenster mit Detektorliste und Auswerteergebnissen angezeigt. Die Ausführungszeiten werden in diesem Modus nicht aktualisiert, da sie vom Sensor nicht vorliegen.
Im Run-Modus werden die detaillierten Prüfergebnisse des in der Auswahlliste markierten Detektors angezeigt. Im Bildfenster werden – sofern eingestellt – das Bild, die Such- und Merkmalsbereiche und Ergebnisgrafen angezeigt.

Die angezeigten Parameter variieren in Abhängigkeit vom ausgewählten Detektortyp:

Abbildung: Abbildung, Vision Sensor Visualisation Studio, Ergebnis

Angezeigte Ergebnispar. | für Detektortyp | Bedeutung
Ergebnis | alle | Teil / Merkmal erkannt (Erkannt = grün, Nicht erkannt = rot)
Score | alle | Übereinstimmungsgrad des gefunden Musters mit dem eingelernten Muster
Ausführungszeit | alle | Zykluszeit für eine Auswertung in ms
PositionX, PositionY | Kontur | Koordinaten des gefundenen Merkmals (Mittelpunkt)
Delta X, Delta Y | Kontur | Abweichung der Findekoordinaten ggü. Einlernposition / durch Lagenachführung
Positions- kontrolle | Kontur | Findeposition innerhalb des definierten Positionsrahmens
Winkel | Kontur | Orientierung (absoluter Winkel) des gefunden Merkmals
Delta Winkel | Kontur | Winkelabweichung zwischen eingelerntem und gefundenem Merkmal
Skalierung | Kontur | Skalierung der gefundenen Kontur ggü. der eingelernten

Um die Prüfergebnisse für einen anderen Detektor aufzurufen, markieren Sie diesen in der Auswahlliste.
Im Programm Vision Sensor Visualisation Studio können Sie Prüfergebnisse und statistische Auswertungen inklusive der gewählten grafischen Darstellungen archivieren.


Wechsel des aktiven Jobs

Im Reiter Job werden in der Auswahlliste die auf dem Sensor verfügbaren Jobs angezeigt. Hier können Sie zwischen verschiedenen im Sensor gespeicherten Jobs umschalten.

Die Ausführung von Funktionen, die ein Anhalten des aktiven Sensors zur Folge haben (Job-Umschaltung, Job-Upload und Recoderbilder holen), erfordert falls aktiviert in Vision Sensor Device Manager die Eingabe eines Passworts (Benutzergruppe Werker, siehe Benutzerverwaltung).

Passwortebenen

Abbildung: Abbildung, Passwortebenen

Abbildung: Abbildung, Vision Sensor Visualisation Studio, Jobumschaltung

Wählen Sie einen Job aus der Liste und aktivieren Sie ihn mit Button „Aktiviert".

Der bisherige Job wird deaktiviert, der gewählte Job ist jetzt aktiv.

Hinweise:

Bei Jobwechsel und Wechsel des Betriebsmodus von Run- nach Config Mode entstehen folgende Sonderzustände der Ausgänge:

  • Der Puffer der verzögerten Ausgänge wird bei Jobwechsel und Wechsel des Betriebsmodus von „Run" nach „Config" gelöscht.
  • Digitalausgänge: Diese werden bei Jobwechsel und Wechsel des Betriebsmodus von „Run" nach „Config" auf die Grundeinstellungen (Defaults) zurückgesetzt. Die Grundeinstellungen werden durch „Invert" im Tab Output-> Ausgangssignale festgelegt. „Invert" invertiert die Grundeinstellung des Digitalausgangs und gleichzeitig das Ergebnis.
  • Ready und Valid: Ready und Valid signalisieren bei Jobwechsel und Wechsel des Betriebsmodus von „Run" nach „Config", dass der Sensor nicht bereit ist und die Ergebnisse nicht gültig sind. (Low Pegel)


Hochladen

Im Reiter Hochladen können Sie neue Jobs oder ganze Jobsätze vom PC in den Sensorspeicher laden. Die verfügbaren Jobs bzw. Jobsätze werden in der Auswahlliste angezeigt.

Jobs und Jobsätze können im Programm Vision Sensor Configuration Studio erstellt und dort unter Menü Datei / Speichere Job / Jobsatz unter ... abgespeichert werden.

Abbildung: Abbildung, Vision Sensor Visualisation Studio, Jobsätze laden

Hinweise:

  • Ein Jobsatz besteht aus einem oder mehreren Jobs, die im Sensor oder auf Festplatte gespeichert sind.
  • Die Ausführung von Funktionen, die ein Anhalten des aktiven Sensors zur Folge haben, erfordert u.U. die Eingabe eines Passworts (Benutzergruppe Werker, siehe Benutzerverwaltung).
  • Wählen Sie einen Job oder Jobsatz aus der Liste und laden Sie ihn mit Button „Hochladen" auf den Sensor.
  • Alle bisher auf dem Sensor gespeicherten Jobs werden bei dieser Aktion gelöscht!


Anhang

Telegramm, Daten Ausgabe

Vision Sensor Visualisation Studio oder Vision Sensor Configuration Studio starten über Autostart


Telegramm, Daten Ausgabe

Die folgenden Telegramme stehen zur Verfügung:

Serielle Kommunikation ASCII

Serielle Kommunikation BINÄR

EtherNet/IP Assembly Request

EtherNet/IP Assembly Request


Serielle Kommunikation ASCII

Datenformate der Kommandos und Datenausgabe

Kommunikationseinstellungen

Kommunikation | Ethernet | RS422
Zum Sensor, Kommando | Wählbar im Tab: Datenausgabe (Binär oder ASCII)
Vom Sensor, Datenausgabe | Wählbar im Tab: Datenausgabe (Binär oder ASCII)

Kommandos an den Sensor in ASCII

Trigger (ASCII) Request String an Sensor
Byte Nr. | Inhalt ASCII | Bedeutung
1 | T | Trigger
2 | R
3 | G
Trigger (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | T | Trigger
2 | R
3 | G
4 | P F | Erfolgreich (Pass) Fehler (Fail)
Zusatzinformationen
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Ja
Akzeptiert wenn Ready Low: |  | Nein
Status des Signals Ready während Bearbeitung: |  | Low
Telegrammende |  | max. 4 Byte (optional)

Extended Trigger (ASCII) Request String an Sensor
Byte Nr. | Inhalt ASCII | Bedeutung
1 | T | Extended Trigger
2 | R
3 | X
4 | x | Länge nachfolgender Daten (n)
5 | x
6...n | x | Daten
Extended Trigger (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | T | Extended Trigger
2 | R
3 | X
4 | P F | Erfolgreich (Pass) Fehler (Fail)
5 | x | Länge nachfolgender Daten (n)
6 | x
7...n | x | Daten aus dem Sendebefehl
n+1 | x | C = Config R = Run
n+2 | x | Länge nachfolgender Ergebnis Daten (m)
n+3 | x
n+4 | x
n+5 | x
n+6 | x
n+7 | x
n+8 | x
n+9 | x
n+9...m | x | Ergebnis Daten
m+1 | x | Telegrammende (optional, max. 4 Byte)
m+2 | x
m+3 | x
m+4 | x
Zusatzinformationen
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Ja
Akzeptiert wenn Ready Low: |  | Nein
Status des Signals Ready während Bearbeitung: |  | low
Telegrammende |  | max. 4 Byte (optional)

Jobwechsel (ASCII) Request String an Sensor
Byte Nr. | Inhalt ASCII | Bedeutung
1 | C | Change Job
2 | J
3 | B
4 | X | Job Nummer
5 | X
6 | X
Jobwechsel (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | C | Change Job
2 | J
3 | B
4 | P F | Erfolgreich (Pass) Fehler (Fail)
5 | T F | Triggered Freerun
6 | X | Job Nummer
7 | X
8 | X
Zusatzinformationen
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Low
Telegrammende |  | max. 4 Byte (optional)

Parameter setzen (ASCII)
Byte Nr. | Inhalt ASCII | Bedeutung
1 | S | Setze Parameter
2 | P
3 | P T | P Permanent T Temporär
4 | X | Detektor Nummer
5 | X
6 | X
7 | X | Parameter Nummer 101 = Referenz String
8 | X
9 | X
10 | X | Länge neuer Referenzstring in Bytes (n)
11 | X
12 | X
13 | X
14 | X
15...n | X | Neuer Referenzstring
Parameter setzen (ASCII) Response string vom Sensor
Byte Nr. | Inhalt ASCII | Bedeutung
1 | S | Setze Parameter
2 | P
3 | P T | P Permanent T Temporär
4 | P F | P Erfolgreich (Pass) F Fehler (Fail)
5 | S | Parameter vom Typ STRG (String) wurde gesetzt
6 | T
7 | R
8 | G
Zusatzinformationen
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | Low
Telegrammende |  | max. 4 Byte (optional)

Parameter lesen (ASCII)
Byte Nr. | Inhalt | Bedeutung
1 | G | Lese Parameter
2 | P
3 | A
4 | X | Detektor Nummer z.B. 001
5 | X
6 | X
7 | X | Parameter Nummer 101 = Referenz String
8 | X
9 | X
Parameter lesen (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Bedeutung
1 | G | Lese Parameter
2 | P
3 | A
4 | P F | P Erfolgreich (Pass) F Fehler (Fail)
5 | S | Parameter vom Typ STRG (String) wurde gelesen
6 | T
7 | R
8 | G
9 | X | Länge des Referenzstrings (n) z.B. 00005
10 | X
11 | X
12 | X
13 | X
14...n | X | Referenzsting
Zusatzinformationen
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | keine Veränderung
Telegrammende |  | max. 4 Byte (optional)

Bild holen (ASCII)
Byte Nr. | Inhalt | Bedeutung
1 | G | Bild holen
2 | I
3 | M
4 | X | 0 – Letztes Bild 1 – Letztes Schlecht-Bild 2 – Letztes Gut-Bild
Bild holen (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Antwort ID Bild holen
1 | G | Bild holen
2 | I
3 | M
4 | P F | P Erfolgreich (Pass) F Fehler (Fail)
5 | X | Error code 0 – Erfolgreich, 1 – Rekorder aus 2 – Kein passendes Bild für diesen Request
6 | X | Typ Bild 0 - Graustufen 1 – COLOR_BAYER_GB 2 – COLOR_BAYER_GR 3 – COLOR_BAYER_BG 4 – COLOR_BAYER_RG Bei Konvertierung des Farb Bildes von Bayer in RGB, muss der entsprechende Bild Typ berücksichtigt werden.
7 | X | Image result 0 - good image 1 - failed image
8 | X | Anzahl der Zeilen z.B. 0480 / 0200
9 | X
10 | X
11 | X
12 | X | Anzahl der Spalten z.B. 0640 / 0320
13 | X
14 | X
15 | X
16...n | X | Binäre Bilddaten (Zeilen * Spalten)
Zusatzinformationen
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | pulled low
Telegrammende |  | max. 4 Byte (optional)

Shutter setzen (ASCII)
Byte Nr. | Inhalt | Bedeutung
1 | S | Shutter setzen in aktivem Job
2 | S
3 | P T | Permanent Temporär
4 | X | Anzahl der Stellen des Shutter Werts, z.B. 04
5 | X
6 | X | Neuer Shutter Wert in Mikrosekunden, z.B. 8000 = 8 ms
7 | X
8 | X
9 | X
Shutter setzen (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Antwort ID Bild holen
1 | S | Shutter setzen
2 | S |
3 | P T | Permanent Temporär
4 | P F | P Erfolgreich (Pass) F Fehler (Fail)
Zusatzinformationen
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | pulled low
Telegrammende |  | max. 4 Byte (optional)

ROI setzen (ASCII)
Byte Nr. | Inhalt | Bedeutung
1 | S | ROI setzen SRP4900100020016000000120000000800000004000000180000 Länge=49, Detektor=1,gelber Suchbereich, Rechteck, Zentrum X=160, Zentrum Y=120, Halbe Breite= 80, Halbe Höhe=40
2 | R
3 | P T | Permanent Temporär
4 | X | ROI Info Länge in Bytes ab Byte 4 bis Ende z.B. 49
5 | X
6 | X | Detektor Nr. z.B. 001
7 | X
8 | X
9 | X | ROI Index = 00 für gelben Suchbereich
10 | X
11 | X | ROI Form 01=Kreis / 02=Rechteck / 03=Ellipse z.B. 02 für Rechteck
12 | X
13-20 | X | Zentrum X (Wert in Pixeln * 1000), z.B. 160 Pixel = 00160000
21-28 | X | Zentrum Y (Wert in Pixeln * 1000), z.B. 120 Pixel = 00120000
29-36 | X | Halbe Breite / X-Radius (Wert in Pixeln * 1000), z.B. 80 Pixel = 0008000
37-44 | X | Halbe Höhe / Y-Radius (Wert in Pixeln * 1000), z.B. 40 Pixel = 0004000
45-52 | X | Winkel (nicht bei Kreis / Ellipse) (Wert in ° * 1000), z.B. 180° = 0018000
ROI setzen (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Antwort ID Bild holen
1 | S | ROI setzen
2 | R |
3 | P T | Permanent Temporär
4 | P F | P Erfolgreich (Pass) F Fehler (Fail)
Zusatzinformationen
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | pulled low
Telegrammende |  | max. 4 Byte (optional)

ROI auslesen (ASCII) |  |
Byte Nr. | Inhalt | Bedeutung
1 | G | ROI auslesen z.B. GRI00100
2 | R
3 | I
4 | X | Detektor Nr. z.B. 001
5 | X
6 | X
7 | X | ROI Index = 00 für gelben Suchbereich
8 | X
ROI auslesen (ASCII) Response String vom Sensor
Byte Nr. | Inhalt | Antwort ID ROI auslesen
1 | G | ROI auslesen
2 | R
3 | I
4 | P F | P Erfolgreich (Pass) F Fehler (Fail)
5 | X | ROI Info Länge in Bytes ab Byte 5 bis Ende
6 | X
7 | X | Detektor Nr.
8 | X
9 | X
10 | X | ROI Index = 00 für gelben Suchbereich
11 | X
12 | X | ROI Form 01=Kreis / 02=Rechteck / 03=Ellipse
13 | X
14-21 | X | Zentrum X (Wert in Pixeln * 1000)
22-29 | X | Zentrum Y (Wert in Pixeln * 1000)
30-37 | X | Halbe Breite / X-Radius (Wert in Pixeln * 1000)
38-45 | X | Halbe Höhe / Y-Radius (Wert in Pixeln * 1000)
46-53 | X | Winkel (nicht bei Kreis / Ellipse) (Wert in ° * 1000)
Zusatzinformationen
Akzeptiert im Run Mode: |  | Ja
Akzeptiert im Konfigurations Mode: |  | Nein
Akzeptiert wenn Ready Low: |  | Ja
Status des Signals Ready während Bearbeitung: |  | pulled low
Telegrammende |  | max. 4 Byte (optional)

Datenausgabe in ASCII

Dynamisch zusammengesetzt nach User-Einstellungen in Software

Prinzipieller Stringaufbau:

<START> (((<OPTIONAL FIELDS> <SEPARATOR> <PAYLOAD>))) <CHKSUM> <TRAILER>

Ausgabedaten (ASCII), dynamisch zusammengesetzt nach User-Einstellungen in Software

Name | Byte Anzahl | Inhalt ASCII / Beispiel | Bedeutung /Kommentare
Vorspann | 1 - max. 8 | User definiert, bis max. 8 Zeichen | Start String (Header)
Gewählte Felder | 16 | 1 Byte pro Feld | über dieses Feld werden alle aktivierten Checkboxen ausgegeben. - Die Reihenfolge der Ausgabe ist von links nach rechts und von oben nach unten - D.h. pro aktiver Checkbox wird ein Byte beginnend beim LSB = Low significant Bit ausgegeben. - Die Checkbox „Gewählte Felder" selbst wird nicht mit ausgegeben! P = logischer Ausgang gesetzt F = logischer Ausgang nicht gesetzt 0 = logischer Ausgang nicht aktiv
Trennzeichen | 1 - 5 | User definiert, bis max 5 Zeichen (pro Separator) | Separator ab: „nach erstem optionalen Feld“, oder „nach erstem detektorspez. Datum“
Telegrammlänge | n | Pro Ziffer der Dezimalzahl ein Byte z.B. 102 „1“; „0“; „2“ | Telegrammlänge in Byte
Statusbyte | 3 | „110” triggered mode oder „101” free-run mode |
Detektorergebnisse | n | Byte 1 = UND Verknüpfung aller Detektoren Byte 2 = Boolsches Ergebnis der Lagenachführung Byte 3 = Globales Ergebnis des aktiven Jobs Folgende Bytes: Anzahl der Detektoren Folgende Bytes: Detektor Ergebnisse (P = Erfolgreich (Pass), F = Fehler (Fail)), das letzte Byte steht für den ersten Detektor Länge.: 4 Byte + 1 Byte je genutztem Detektor |
Digitalausgänge | n | Erste Bytes: Anzahl aktiver Ausgänge Folgende Bytes:Digitale Ausgänge, | P = logischer Ausgang gesetzt F = logischer Ausgang nicht gesetzt 0 = logischer Ausgang nicht aktiv
Logische Ausgänge | n | Erste Bytes: Anzahl aktiver logischer Ausgänge Folgende Bytes:Logische Ausgänge, | Beispiel: 18 logische Ausgänge werden konfiguriert, aber nur Ausgang 1,2 und 9 werden tatsächlich mit Funktionen belegt (sind also aktiv): 3PP000000P 2 Bytes Anzahl aktiver Ausgänge dann alle Ergebnisse bit- codiert... Im Beispiel werden wg. Ausgang 9, zwei Bytes benötigt.... P = logischer Ausgang gesetzt F = logischer Ausgang nicht gesetzt 0 = logischer Ausgang nicht aktiv
Ausführungszeit | n |  | Aktuelle (Job-)Zykluszeit in [ms]
Aktiver Job | 1-3 |  | Aktive Job Nr. (1..255)
<<Detector specific>> |  |  |
Detector result | 1 | P = Erfolgreich (Pass) F = Fehler (Fail) | Boolsches Detektorergebnis
Score value | 1-3 |  | Score (0..100%)
Execution time | n |  | Ausführungzeit des einzelnen Detektors in [msec].
Position X | n | z.B.: X = 180 (pixel) = (in ASCII) „180000" = 6 Byte | Gefundene Position X (x-coordinate). [1/1000]
Position Y | n |  | Gefundene Position Y (y-coordinate). [1/1000]
DeltaPos X | n |  | Delta Position X zwischen eingelerntem und gefundenem Objekt [1/1000]
DeltaPos Y | n |  | Delta Position X zwischen eingelerntem und gefundenem Objekt [1/1000]
Angle | n |  | Orientierung des gefundenen Objekts (0°..360°) [1/1000)
Delta Angle | n |  | Winkel zwischen eingelerntem und gefundenem Objekt (0°..360°) [1/1000]
Scaling | n |  | Nur bei Kontur (0,5..2) [1/1000]
String | 1...n | maximale Länge 127 !! | Inhalt des gelesenen Codes, Abhängig vom Code kann die Stringlänge variieren. Wird eine feste Stringlänge gewünscht, so müssen die minimale Stringlänge (Detektorspezifische Nutzdaten) und die maximale Stringlänge (Detektoreinstellungen) auf den gleichen Wert (z.B. 127) gesetzt werden.
String length | n |  | Länge des gelesenen Codes in Bytes
Trucated | 1 | F = Code komplett, P = Code abgeschnitten | Code abgeschnitten
Prüfsumme | 3 |  | XOR-Prüfsumme über alle Bytes im Telegramm
Nachspann | 1 - max. 8 | User defined, bis max. 8 Charakter | Ende String (Trailer)

Alle detektorspezifischen Daten mit Nachkommastellen werden als ganze Zahlen (mit 1000 multipliziert) übertragen und müssen nach Datenempfang deshalb durch 1000 geteilt werden.


Serielle Kommunikation BINÄR

Datenformate der Kommandos und Datenausgabe

Kommunikationseinstellungen

Kommunikation | Ethernet | RS422
Zum Sensor, Kommando | Wählbar im Tab: Datenausgabe (Binär oder ASCII)
An Sensor, Datenausgabe | Wählbar im Tab: Datenausgabe (Binär oder ASCII)

Kommandos an den Sensor in BINÄR

Trigger (Binär) Anforderungs- String an Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsigned Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x05
5 | Unsigned Char | 0x01 | Kommando Trigger
Trigger (Binär) Antwort- String vom Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsined Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x07
5 | Unsigned Char | 0x01 | Kommando Trigger
6 | Unsigned Short | 0x00 | Fehler Code 0 = Erfolgreich (Pass) 1 = Fehler (Fail)
7 |  | 0xXX |
Zusatzinformationen
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Ja
Akzeptiert wenn Ready Low: |  |  | Nein
Status des Signals Ready während Bearbeitung: |  |  | Low

Extended Trigger (Binär) Anforderungs- String an Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsigned Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x05
5 | Unsigned Char | 0x013 | Kommando Extended Trigger
6 | Unsigned Char | 0xXX | Länge nachfolgender Daten (n)
7...n | Unsigned Char | 0xXX | Daten
Extendetd Trigger (Binär) Antwort- String vom Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsined Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x07
5 | Unsigned Char | 0x013 | Kommando Extended Trigger
6 | Unsigned Short | 0x00 | Fehler Code 0 = Erfolgreich (Pass) 1 = Fehler (Fail)
7 |  | 0xXX
8 | Unsigned Char | 0xXX | Länge nachfolgender Daten (n)
9...n | Unsigned Char | 0xXX | Daten aus dem Sendebefehl
n+1 | Unsigned Char [] | 0xXX | Betriebsmodus 0 = Konfig Mode 1 = Run Mode
n+2 | Unsigned Int | 0xXX | Ergebnis Daten
n+3 |  | 0xXX
n+4 |  | 0xXX
n+5 |  | 0xXX
n+6 | Unsigned Char [] | 0xXX | Ergebnis Daten
n+7 |  | 0xXX
n+8 |  | 0xXX
n+9...m |  | 0xXX
Zusatzinformationen
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Ja
Akzeptiert wenn Ready Low: |  |  | Nein
Status des Signals Ready während Bearbeitung: |  |  | Low

Jobwechsel (Binär) Anforderungs- String an Sensor
Byte Nr. | DataTyp | Inhalt |  | Bedeutung
1 | Unsigned Int | 0x00 |  | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x06
5 | Unsigned Char | 0x02 |  | Kommando Jobwechsel
6 | Unsigned Char | 0xXX |  | Job Nr, XX = 1- n
Jobwechsel (Binär) Antwort- String vom Sensor
Byte Nr. | DataTyp | Inhalt |  | Bedeutung
1 | Unsined Int | 0x00 |  | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x09
5 | Unsigned Char | 0x02 |  | Kommando Jobwechsel
6 | Unsigned Short | 0x00 |  | Fehler Code 0 = Erfolgreich (Pass) 1 = Fehler (Fail)
7 |  | 0xXX |  |
8 | Unsigned Char | 0xXX |  | Trigger Mode 0 = getriggert 1 = Freilauf
9 | Unsigned Char | 0xXX |  | Job Nr, XX = 1- n
Zusatzinformationen
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Low

Parameter setzen (Binär) Anforderungs- String an Sensor
Byte Nr. | DataTyp | Inhalt |  | Bedeutung
1 | Unsigned Int | 0x00 |  | Telegrammlänge = 9 Bytes + Länge Referenzstring (n)
2 |  | 0x00
3 |  | 0x00
4 |  | 0xn
5 | Unsigned Char | 0x05 0x06 |  | Kommando Parameter permanent setzen Kommando Parameter temporär setzen
6 | Unsigned Char | 0xXX |  | Detektor Nr., XX = 1- n
7 | Unsigned Char | 0x65 |  | Kommando Referenzstring setzen
8 | Unsigned Short | 0x00 |  | Länge neuer Referenzstring (n)
9 |  | 0x0n
10..n | Unsigned Char | 0xn |  | Referenzstring
Parameter setzen (Binär) Antwort- String vom Sensor (kann bis zu 4-5 Sekunden verzögert ankommen)
Byte Nr. | DataTyp | Inhalt |  | Bedeutung
1 | Unsigned Int | 0x00 |  | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x08
5 | Unsigned Char | 0x05 0x06 |  | ID Referenzstring permanent setzen ID Referenzstring temporär setzen
6 | Unsigned Short | 0xXX |  | Error Code 00 00 = Pass Error Code 00 01 = Fail
7 |  | 0xXX
8 | Unsigned Char | 0x0A |  | Parameter Typ String
Zusatzinformationen
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Low

Parameter lesen (Binär) Anforderungs- String an Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsigned Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x07
5 | Unsigned Char | 0x0A | Kommando Parameter lesen
6 | Unsigned Char | 0xn | Detektor Nr., XX = 1- n
7 | Unsigned Char | 0x65 | Kommando Referenzstring lesen
Parameter lesen (Binär) Antwort- String vom Sensor (kann bis zu 4-5 Sekunden verzögert ankommen)
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsigned Int | 0x00 | Telegrammlänge = 10 Bytes + Länge Referenzstring (n)
2 |  | 0x00
3 |  | 0x00
4 |  | 0x0n
5 | Unsigned Char | 0x0A | ID Parameter lesen
6 | Unsigned Short | 0xXX | Error Code 00 00 = Pass Error Code 00 01 = Fail
7 |  | 0xXX
8 | Unsigned Char | 0x0A | Parameter Typ String
9 | Unsigned Short | 0x00 | Länge gelesener Wert (n)
10 |  | 0x0n |
11..n | Unsigned Char | 0xn | Referenzstring
Zusatzinformationen
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | keine Veränderung

Bild holen (Binär) Anforderungs- String an Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsigned Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x06
5 | Unsigned Char | 0x03 | Bild holen
6 | Unsigned Char | 0xXX | 0 – Letztes Bild 1 – Letztes Schlecht-Bild 2 – Letztes Gut-Bild
Bild holen (Binär) Antwort- String vom Sensor (kann bis zu 4-5 Sekunden verzögert ankommen)
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsigned Int | 0xXX | Telegrammlänge z.B. 00 04 B0 0D
2 |  | 0xXX
3 |  | 0xXX
4 |  | 0xXX
5 | Unsigned Char | 0x03 | Antwort ID Bild holen
6 | Unsigned short | 0xXX | Error code 00 00 – Erfolgreich, 00 01 – Rekorder aus 00 02 – Kein passendes Bild für diesen Request
7 |  | 0xXX
8 | Unsigned Char | 0xXX | Typ Bild 00 - Graustufen 1 – COLOR_BAYER_GB 2 – COLOR_BAYER_GR 3 – COLOR_BAYER_BG 4 – COLOR_BAYER_RG Bei Konvertierung des Farb Bildes von Bayer in RGB, muss der entsprechende Bild Typ berücksichtigt werden.
9 | Unsigned Char | 0xXX | Ergebnis Bild 00 - Gut-Bild 01 - Schlecht-Bild
10 | Unsigned short | 0xXX | Anzahl der Zeilen e.g. 01 E0
11 |  | 0xXX
12 | Unsigned short | 0xXX | Anzahl der Spalten e.g. 02 80
13 |  | 0xXX
14...n | Unsigned Char | 0xXX | Binäre Bilddaten (Zeilen * Spalten)
Zusatzinformationen
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | pulled low

Shutter setzen (Binär) Anforderungs- String an Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsigned Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x09
5 | Unsigned Char | 0x0E 0x0F | Kommando Shutter setzen temporär Kommando Shutter setzen permanent
6 | Unsigned Int | 0xXX | Shutter Wert
7 |  | 0xXX
8 |  | 0xX
9 |  | 0xXX
Shutter setzen (Binär) Antwort- String vom Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsined Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x07
5 | Unsigned Char | 0x0E 0x0F | Antwort Shutter setzen temporär Antwort Shutter setzen permanent
6 | Unsigned Short | 0x00 | Fehler Code, 0 = Erfolgreich (Pass), 1 = Fehler (Fail)
7 |  | 0xXX
Zusatzinformationen
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Pulled Low

ROI setzen (Binär) Anforderungs- String an Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsigned Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x32
5 | Unsigned Char | 0x10 0x11 | Kommando ROI setzen temporär Kommando ROI setzen permanent
6 | Unsigned Int | 0xXX | ROI Info Länge in Bytes ab Byte 6 bis Ende
7 |  | 0xXX
8 |  | 0xXX
9 |  | 0xXX
10 | Unsigned Char | 0xXX | Detektor Nr.
11 | Unsigned Char | 0x00 | ROI Index = 00 = gelber Rahmen
12 | Unsigned Char | 0xXX | ROI Form 01=Kreis / 02=Rechteck / 03=Ellipse
13 | Unsigned Int | 0xXX | ROI Parameter: Mittelpunkt X (Wert in Pixeln * 1000)
14 |  | 0xXX
15 |  | 0xXX
16 |  | 0xXX
17 | Unsigned Int | 0xXX | ROI Parameter: Mittelpunkt Y (Wert in Pixeln * 1000)
18 |  | 0xXX
19 |  | 0xXX
20 |  | 0xXX
21 | Unsigned Int | 0xXX | ROI Parameter: halbe Breite bzw. Radius X (Wert in Pixeln * 1000)
22 |  | 0xXX
23 |  | 0xXX
24 |  | 0xXX
25 | Unsigned Int | 0xXX | Nur bei Ellipse / Rechteck: ROI Parameter: halbe Breite bzw. Radius Y (Wert in Pixeln * 1000)
26 |  | 0xXX
27 |  | 0xXX
28 |  | 0xXX
29 | Unsigned Int | 0xXX | Nur bei Ellipse / Rechteck: ROI Parameter: Winkel in ° (Wert in ° * 1000)
30 |  | 0xXX
31 |  | 0xXX
32 |  | 0xXX
ROI setzen (Binär) Antwort- String vom Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsigned Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x07
5 | Unsigned Char | 0x10 0x11 | Antwort ROI setzen temporär Antwort ROI setzen permanent
6 | Unsigned Short | 0x00 | Fehler Code, 0 = Erfolgreich (Pass), 1 = Fehler (Fail)
7 |  | 0xXX
Zusatzinformationen
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Pulled Low

ROI auslesen (Binär) Anforderungs- String an Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsigned Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x09
5 | Unsigned Char | 0x12 | Kommando ROI auslesen
6 | Unsigned Char | 0xXX | Detektor Nr.
7 | Unsigned Char | 0xXX | ROI Index = 00 = gelber Rahmen
ROI auslesen (Binär) Antwort- String vom Sensor
Byte Nr. | DataTyp | Inhalt | Bedeutung
1 | Unsined Int | 0x00 | Telegrammlänge
2 |  | 0x00
3 |  | 0x00
4 |  | 0x34
5 | Unsigned Char | 0x12 | Antwort ROI auslesen
6 | Unsigned Short | 0x00 | Fehler Code, 0 = Erfolgreich (Pass), 1 = Fehler (Fail)
7 |  | 0xXX
8 | Unsigned Int | 0xXX | ROI Info Länge in Bytes ab Byte 8 bis Ende
9 |  | 0xXX
10 |  | 0xXX
11 |  | 0xXX
12 | Unsigned Char | 0xXX | Detektor Nr.
13 | Unsigned Char | 0x00 | ROI Index = 00 = gelber Rahmen
14 | Unsigned Char | 0xXX | ROI Form 01=Kreis / 02=Rechteck / 03=Ellipse
15 | Unsigned Int | 0xXX | ROI Parameter: Mittelpunkt X (Wert in Pixeln * 1000)
16 |  | 0xXX
17 |  | 0xXX
18 |  | 0xXX
19 | Unsigned Int | 0xXX | ROI Parameter: Mittelpunkt Y (Wert in Pixeln * 1000)
20 |  | 0xXX
21 |  | 0xXX
22 |  | 0xXX
23 | Unsigned Int | 0xXX | ROI Parameter: halbe Breite bzw. Radius X (Wert in Pixeln * 1000)
24 |  | 0xXX
25 |  | 0xXX
26 |  | 0xXX
27 | Unsigned Int | 0xXX | Nur bei Ellipse / Rechteck: ROI Parameter: halbe Breite bzw. Radius Y (Wert in Pixeln * 1000)
28 |  | 0xXX
29 |  | 0xXX
30 |  | 0xXX
31 | Unsigned Int | 0xXX | Nur bei Ellipse / Rechteck: ROI Parameter: Winkel in ° (Wert in ° * 1000)
32 |  | 0xXX
33 |  | 0xXX
34 |  | 0xXX
Zusatzinformationen
Akzeptiert im Run Mode: |  |  | Ja
Akzeptiert im Konfigurations Mode: |  |  | Nein
Akzeptiert wenn Ready Low: |  |  | Ja
Status des Signals Ready während Bearbeitung: |  |  | Pulled Low

Datenausgabe in BINÄR

Dynamisch zusammengesetzt nach User-Einstellungen in Software

Prinzipieller Stringaufbau:

<START> <OPTIONAL FIELDS> <PAYLOAD> <CHKSUM> <TRAILER>

Ausgabedaten (BINÄR), dynamisch zusammengesetzt nach User-Einstellungen in Software
Name | Byte Anzahl | Inhalt Binär / Beispiel | Bedeutung /Kommentare
Vorspann | 1 - max. 8 | User definiert, bis max. 8 Byte | Start String (Header)
Gewählte Felder | 2 (Word) | 1 Bit pro Feld | über dieses Feld werden „bit-codiert" (in 2Bytes!) alle aktivierten Checkboxen ausgegeben. - Die Reihenfolge der Ausgabe ist von links nach rechts und von oben nach unten. - D.h. pro aktiver Checkbox wird ein Bit (gesetzt/nicht gesetzt) beginnend beim LSB = Low significant Bit ausgegeben. - Die Checkbox „Gewählte Felder" selbst wird nicht mit ausgegeben!
Telegrammlänge | 2 (Word) | z.B. 0x00, 0x02 = Länge =2 Byte | Telegrammlänge in Byte
Statusbyte | 2 (Word) | z.B. 0x00, 0x06 (triggered) z.B. 0x00, 0x05 (free-run) | Byte1: 00000xxx Bit0 = <Free-run> Bit1 = <triggered> Bit2 = <Op.mode> (1=run/0=config) Byte2 (reserved), always 0x00
Detektorergebnis | 4..n | z.B. 0x05 (Bit1+3=5) 0x00 (zwei Bytes Anz. Detektoren) 0x01 0x01 (Detektor-Ergebnis D1) | Byte 1 Bit1 (LSB) = Globales Jobergebnis (1 = Pass, 0 = Fail) Bit2 = Boolsches Erg. nur Lagenachführung, Lagenachführung inaktiv =True Bit3 = UND Verkn. aller Det. des aktiven Jobs Byte 2 und 3 zwei Bytes fuer die Anzahl der Detektoren im Job (ohne Alignment-Detektor). Byte 4 - n 1 Byte je Block von 8 genutzten Detektoren z.B: Bit1(LSB) = Detektor 1, Bit2 = Det. 2, ....
Digitalausgänge | n | Byte 1 und 2: die Anzahl aktiver Ausgänge Byte 3 ... n: Ausgänge, bit-codiert | Ergebnisse aller digitalen Ausgänge (bit-codiert)
Logische Ausgänge | n | Byte 1 und Byte 2: die Anzahl aktiver! log. Ausgänge Byte 3 ... n alle aktiven logischen Ausgänge, bit-codiert | Beispiel: 18 logische Ausgänge werden konfiguriert, aber nur Ausgang 1,2 und 9 werden tatsächlich mit Funktionen belegt (sind also aktiv): 000,003, 003, 001 2 Bytes Anzahl aktiver Ausgänge dann alle Ergebnisse bit-codiert... Im Beispiel werden wg. Ausgang 9, zwei Bytes benötigt.... 1.ErgebnisByte = 00000011 (log. Ausgang1+2) 2.ErgebnisByte = 00000001 (log.Ausgang 9)
Ausführungszeit | 4 (Integer) |  | Aktuelle (Job-)Zykluszeit in [ms]
Aktiver Job | 1 |  | Aktive Job Nr. (1..255)
<<Detektor spezifisch>>
Detector result | 1 | (1 = Pass, 0 = Fail) | Boolsches Detektorergebnis
Score value | 4 |  | Score (0..100%)
Execution time | 4 |  | Ausführungzeit des einzelnen Detektors in [msec].
Position X | 4 |  | Gefundene Position X (x-coordinate). [1/1000]
Position Y | 4 |  | Gefundene Position Y (y-coordinate). [1/1000]
DeltaPos X | 4 |  | Delta Position X zwischen eingelerntem und gefundenem Objekt [1/1000]
DeltaPos Y | 4 |  | Delta Position X zwischen eingelerntem und gefundenem Objekt [1/1000]
Angle | 4 |  | Orientierung des gefundenen Objekts (0°..360°) [1/1000)
Delta Angle | 4 |  | Winkel zwischen eingelerntem und gefundenem Objekt (0°..360°) [1/1000]
Scaling | 4 |  | Nur bei Kontur (0,5..2) [1/1000]
String | 1...n | maximale Länge 127 !! | Inhalt des gelesenen Codes, Abhängig vom Code kann die Stringlänge variieren. Wird eine feste Stringlänge gewünscht, so müssen die minimale Stringlänge (Detektorspezifische Nutzdaten) und die maximale Stringlänge (Detektoreinstellungen) auf den gleichen Wert (z.B. 127) gesetzt werden.
String length | 4 |  | Länge des gelesenen Codes in Bytes
Truncated | 1 | 0x00 = Code komplett, 0x01 = Code abgeschnitten | Code abgeschnitten
Prüfsumme | 1 |  | XOR-Prüfsumme über alle Bytes im Telegramm
Nachspann | 1 - max. 8 |  | Ende String (Trailer)

Alle detektorspezifischen Daten mit Nachkommastellen werden als ganze Zahlen (mit 1000 multipliziert) übertragen und müssen nach Datenempfang deshalb durch 1000 geteilt werden. Die Werte werden im Format „Big Endian" übertragen.

Beispiel: „Score" Werte (Binär Protokoll)

In Vision Sensor Configuration Studio/Vision Sensor Visualisation Studio wird „Score" = 35 angezeigt.

Via Ethernet werden dann z.B. folgende vier Bytes empfangen: 000,000,139,115

Formel zu Umrechnung: (HiWordByte*256 + HiLowByte) *65536 + HiByte*256 + LoByte = Value

Da Big Endian (vom Sensor) geschickt wird, gilt:

000 = HiWordByte, 000 = HiLowByte, 139 = HiByte, 115 = LoByte

(0*256 + 0) * 65536 + (139 * 256) + 115 = 35699 / 1000 = 35,699 (= echter Score Wert).

Winkelangaben bzw. andere negative Zahlen werden im Zweierkomplement dargestellt.


EtherNet/IP Assembly Request

Communication Settings

Description: | Response returned from sensor to PLC
Class: | Class 1
nAssemblyInstance | 101
nType | AssemblyProducing
nLength (bytes) | 444
szAssemblyName | AssemblyResponse

Assembly request

Position | Size (bytes) | Member | Data type | Description
0 | 2 | unKey | U16 | request key, eg. a request counter
2 | 2 | unId | U16 | request ID, eg. for requests "trigger", "change job"
4 | 2 | unNumChar | U16 | no. of valid char parameters
6 | 2 | unNumInt | U16 | no. of valid int parameters
8 | 256 | pcValueChar[RQST_NUM_CHAR] | I8 | char parameters for request, member may only hold one string
264 | 80 | pnValueInt[RQST_NUM_INT] | I32 | int parameters for request


EtherNet/IP Assembly Response

Description: | Request posted to sensor from PLC
Class: | Class 1
nAssemblyInstance | 100
nType | AssemblyConsuming
nLength (bytes) | 344
szAssemblyName | AssemblyRequest

Assembly response

Position | Size (bytes) | Member | Data type | Description
0 | 4 | unFault | U32 | member is standard in Rockwell RSLogix
4 | 2 | unKey | U16 | request key is returned in response
6 | 2 | unId | U16 | request ID is returned in response
8 | 2 | unError | U16 | error code of response
10 | 2 | unNumChar | U16 | no. of valid char parameters
12 | 2 | unNumInt | U16 | no. of valid int parameters
14 | 2 | ucAlignmentDummy | U8 |
16 | 16 | pcValueChar[RPNS_NUM_CHAR] | I8 | char parameters for response, member may only hold one string
32 | 16 | pnValueInt[RPNS_NUM_INT] | U32 | int parameters for response
48 | 4 | unImageCount | U32 | no. of last processed image.
52 | 4 | unExecutionTime | U32 | execution time in msec of last processed image.
56 | 4 | pucStatus[RPNS_IMPL_NUM_BYTE_STATUS] | U8 | status information, including operation mode
60 | 2 | unActiveJob | U16 | active job
62 | 2 | ucAlignmentDummy | U8 |
64 | 2 | unNumDigital | U16 | no. of valid digital outputs
66 | 2 | unNumLogic | U16 | no. of valid logic outputs
68 | 2 | unNumDetector | U16 | no. of valid logic outputs
70 | 2 | unNumBool | U16 | no. of valid boolean parameters
72 | 2 | unNumString | U16 | no. of strings included in pcValueChar
74 | 2 | unNumInt | U16 | no. of valid int parameters
76 | 4 | pucDigital[RPNS_IMPL_NUM_BYTE_DIGITAL] | U8 | digital outputs (bitwise)
80 | 8 | pucLogic[RPNS_IMPL_NUM_BYTE_LOGIC] | U8 | logic outputs (bitwise)
88 | 4 | pucDetector[RPNS_IMPL_NUM_BYTE_DETECTOR] | U8 | detector results (bitwise), formerly stored in pucValueBool
92 | 4 | pucBool[RPNS_IMPL_NUM_BYTE_BOOL] | U8 | boolean results (bitwise) as configured in HMI (listbox)
96 | 16 | punStringLength[RPNS_IMPL_NUM_STRING] | U16 | lengths of strings included in pcValueChar
112 | 2 | pucStringTruncated[RPNS_IMPL_NUM_BYTE_STRING_TRUNCATED] | U8 | indicates for each string whether it has been truncated (bitwise)
114 | 2 | ucAlignmentDummy | U8 |
116 | 128 | pcString[RPNS_IMPL_NUM_BYTE_STRING] | I8 | char result as configured in HMI (listbox), member may hold multiple strings
244 | 200 | pnInt[RPNS_IMPL_NUM_INT] | U32 | int results as configured in HMI (listbox)


Vision Sensor Visualisation Studio oder Vision Sensor Configuration Studio starten über Autostart

Für den Start von Vision Sensor Visualisation Studio oder Vision Sensor Configuration Studio über Autostart steht unter: Vision Sensor Device Manager/Datei/Autostart- Datei, ein Auswahldialog zur Generierung und Speicherung der entsprechenden Autostart- Datei zur Verfügung.

Nach Auswahl des zu startenden Moduls und des Benutzerlevels, mit "Speichern" die entsprechende Autostartdatei im Ordner ..\Windows\Start Menu\Programs abspeichern (genauer Pfad abhängig von Windiows- Installation).


Job 1… 31 via binärem Eingangs-Bitmuster

Für die Umschaltung von bis zu 31 Jobs via binärer Eingangskombination an den bis zu 5 Eingängen werden alle benötigten Eingänge unter Vision Sensor Configuration Studio/Ausgabe/Pinbelegung mit der entsprechenden Funktion „Jobwechsel Bit x“ belegt. Die entsprechenden wie in unterem Bild gezeigten binären Eingangsmuster schalten dann direkt beim Anlegen auf den entsprechenden Job um. S. auch Kap: Pinbelegung / Funktionen der Eingänge ff.

Hinweise:
  • Jobumschaltung startet sofort nachdem die Eingangskombination gewechselt hat
  • Die Anzeige des aktiven Job´s in der Statuszeile wechselt mit dem ersten folgenden Trigger
  • Die Zuordnung der I/O´s ist nicht fix, sie hängt von den Einstellungen unter Vision Sensor Configuration Studio/Ausgabe/Pinbelegung ab
  • Der Pegelwechsel der zugehörigen Eingänge muss gleichzeitig erfolgen (innerhalb von längstens 10ms müssen alle Pegel stabil anliegen)

Abbildung: Job- Umschaltung binär


Kommunikation


Netzwerkanschluss


Netzwerkanschluss Kurzanleitung

Durch die nachfolgenden Anweisungen wird die Netzwerkkonfiguration des PC und des
Vision Sensors geändert. Werden dabei falsche Einstellungen verwendet, können unter Umständen die Netzwerkverbindungen auf dem PC verloren gehen. Zur Sicherheit sind die alten Einstellungen zu notieren und bei Bedarf wieder zu verwenden.
Ein Neustart des Systems wird nach der Durchführung dieser Anweisungen möglicherweise notwendig. Um herauszufinden welche IP-Adresse in Ihrem Netzwerk oder lokal auf Ihrem PC zulässig ist, und um Ihre Einstellungen an Ihrem PC durchzuführen, bitte zuvor den zuständigen Systembetreuer oder Administrator kontaktieren.
Die verwendeten Abbildungen, Dialoge und Menüs stammen aus dem Betriebssystem Microsoft Windows XP™. In anderen Betriebssystemen sind die Abbildungen ähnlich.